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About This Guide

This guide explains how to install and configure the Novell® Identity Manager WorkOrder driver 
1.0.

This guide contains the following sections: 

Chapter 1, “Overview,” on page 11
Chapter 2, “Planning,” on page 15
Chapter 3, “Understanding Driver Architecture,” on page 17
Chapter 4, “Objects and Attributes Used,” on page 23
Chapter 5, “Customizing the Driver,” on page 25
Chapter 6, “Installing and Configuring,” on page 31
Chapter 7, “Creating and Managing Work Orders,” on page 37
Chapter 8, “Managing the Driver,” on page 39
Chapter 9, “Troubleshooting Driver Processes,” on page 55
Chapter 10, “Backing Up the Driver,” on page 63
Chapter 11, “Security: Best Practices,” on page 65
Appendix A, “DirXML Command Line Utility,” on page 67
Appendix B, “Schema For Work Order Management,” on page 81
Appendix C, “Properties of the Driver,” on page 85

Audience

This guide is intended for developers and administrators using Identity Manager and the WorkOrder 
driver.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Updates

For the most recent version of the Identity Manager Work Order Guide, visit the Identity Manager 
Documentation Web site (http://www.novell.com/documentation/idm35drivers).

Additional Documentation

For documentation on other Identity Manager drivers, see the Identity Manager Documentation Web 
site  (http://www.novell.com/documentation/idm35drivers).
About This Guide 9
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Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
 Identity Manager 3.5.1 Driver for WorkOrder
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1Overview

This section provides an overview of the Novell® Identity Manager 3.5.1 WorkOrder driver. 

Section 1.1, “What’s New,” on page 11
Section 1.2, “The Role of the WorkOrder Driver,” on page 11
Section 1.3, “Terminology,” on page 12
Section 1.4, “Key Functions,” on page 12
Section 1.5, “WorkOrder Driver Features,” on page 13
Section 1.6, “The Subscriber and Publisher Channels,” on page 13

1.1  What’s New
The WorkOrder driver for Identity Manager 3.5.1 adds one new attribute to the WorkOrder and 
WorkToDo objects:

DirXML-nwoRepeatCount. This attribute repeats the work order as many times as you specify and 
is used in conjunction with the DirXML-nwoRepeatInterval attribute. See Table B-1 on page 81.

1.2  The Role of the WorkOrder Driver
The purpose of the Identity Manager WorkOrder driver is to allow work to be scheduled. The driver 
uses information from the work order container to see which WorkOrder objects are pending and 
due. Work orders that are pending and due are processed by the driver. The definition of the work to 
do is contained in the work order. For example, the work to do can be modifying an object attribute 
in the Identity Vault or sending an e-mail to the administrator. Policies in the WorkOrder driver 
perform the work that is defined in the work order.

The WorkOrder driver publishes the WorkToDo object in order to publish the work order.

The following diagram illustrates how the WorkOrder driver connects to the Identity Vault to 
manage work orders for other systems in the network.
Overview 11
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Figure 1-1   The WorkOrder driver Connected to the Identity Vault

The WorkOrder driver does not replace the workflow functionality of the User Application.

1.3  Terminology
The following terms are used by the WorkOrder driver:

Due Date: The date and time the work order is to be executed.
Content: The definition of the work that is to be processed.
Interval: The amount of time until the work order is to be repeated.
Dependency: The distinguished name of a work order that should be completed first.
Status: The value returned by the driver after the work order was processed (Configured, 
Error, etc.).
Process Log: The description of the events that occurred when the work order was processed.
DeleteDueDate: The date the work order will be deleted from the Identity Vault.
Pending: A work order that is not yet due.

1.4  Key Functions
Review the following key functions to see if they are supported by the WorkOrder driver.

1.4.1  Local Platforms
The WorkOrder driver can run on the Identity Manager machine.
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1.4.2  Remote Platforms
The WorkOrder driver works on all the local and remote platforms that the engine runs on.

1.4.3  Role-Based Entitlements
The WorkOrder driver does not support Role-Based Entitlements.

1.4.4  Password Synchronization Support
The WorkOrder driver does not support Password Synchronization.

1.4.5  Synchronized Objects
The WorkOrder driver synchronizes WorkOrder objects.

1.5  WorkOrder Driver Features
Driver features:

Schedules work orders: The WorkOrder driver allows work to be scheduled for a specific 
date and time.

Supports dependent work orders: If a work order is dependent on another work order, it is 
not processed until the dependent work order has been processed successfully.
Repeats work orders: The driver allows for work orders to be repeated at a set interval. 
Facilitates tracking and accountability of work orders: Each work order carries with it the 
creator and main contact of the work order, a description of the action taken and the errors it 
encountered.

1.6  The Subscriber and Publisher Channels
In the driver configuration, the Subscriber channel processes only events that pertain to work orders. 
For many drivers, the Subscriber channel performs changes in the third-party application in response 
to events in the Identity Vault. However, for the WorkOrder driver, the Publisher channel is the 
agent that performs the work orders. 

Through the Publisher channel, the Identity Manager 3.5.1 WorkOrder driver queries the Identity 
Vault for work orders. The Publisher channel then configures the work orders in the driver.

For more information on how the Subscriber channel and Publisher channel are configured, see 
Section 6.8, “Configuring the Subscriber and Publisher Channels,” on page 34.
Overview 13
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2Planning

Planning issues vary significantly, depending on your goals and the environment. This section 
provides a starting point to plan your customized WorkOrder driver.

Section 2.1, “Planning Issues for All Configurations,” on page 15
Section 2.2, “Designing the Driver,” on page 16
Section 2.3, “Prerequisites,” on page 16

2.1  Planning Issues for All Configurations
Use the following list to plan how you want to implement the WorkOrder driver.

Specify or create containers to hold the new objects used by the WorkOrder driver. Driver 
configuration requires that container objects be provided for the creation and processing of 
DirXML-WorkOrder objects, as well as the creation of DirXML-WorkToDo objects that are 
generated to process DirXML-WorkOrder objects.

Which container do you want to use for DirXML-WorkOrder objects?
Which container do you want to use for DirXML-WorkToDo objects?

Figure 2-1   Example of Containers for New Objects

Work Orders

Work To Do

Additional Containers
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NOTE: You should restrict rights to these containers so that only authorized administrators can 
change the containers or the objects they hold.

Identify when you want the driver to poll for work orders that are due. You can control the 
timing by using the polling interval, time or day, or both.

To learn how to configure the polling time, see Section 6.5, “Configuration Information,” on 
page 32.

2.2  Designing the Driver
Novell® Identity Manager 3.5.1 contains a visual configuration tool that provides a simple yet 
powerful way to design and configure Identity Manager projects. Designer for Identity Manager 
allows you to:

Graphically model the implementation
Re-use configurations to help reduce deployment time
Create and test scenarios to ensure proper policy definition before deploying in production
Automatically generate project documentation for all implementation details
Use the offline mode to safely configure implementations outside of the production 
environment
Design and manage policies

Drivers can be deployed through Designer or iManager. Novell recommends that you use Designer 
to configure and test the drivers, and that you use iManager for administration after drivers are 
deployed into your environment. For more information about Designer, see the Designer 
Administration Guide (http://www.novell.com/documentation/designer/).

2.3  Prerequisites
Before installing the driver, ensure that you meet the following prerequisites required for the 
Identity Manager 3.5.1 WorkOrder driver:

Novell Identity Manager 3.5.1 with the latest patches and product updates.
Java Developer Kit or the Java Runtime Environment version 1.3.1 or later.
eDirectoryTM administrator username and password, so you can log in during the installation to 
allow schema extension. The schema extensions are described in Appendix B, “Schema For 
Work Order Management,” on page 81.
 Identity Manager 3.5.1 Driver for WorkOrder
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3Understanding Driver Architecture

The following sections describe how the Publisher channel and Subscriber channel work with the 
Novell® Identity Manager 3.5.1 WorkOrder driver. This driver functions differently than the 
traditional Identity Manager drivers, so it is important to review this information.

Section 3.1, “Base Configuration,” on page 17
Section 3.2, “Subscriber Channel Functions,” on page 17
Section 3.3, “Publisher Channel Functions,” on page 18

3.1  Base Configuration
The base configuration demonstrates the functionality of the WorkOrder driver. It shows how the 
driver manages WorkOrder objects in the Identity Vault. In the base configuration, the driver 
processes WorkOrder objects from the configured work order container. The rules and policies in 
the base configuration are set up so you can create WorkOrder objects using a new object class, 
DirXML-WorkOrder, in a work order container. The following information explains how the base 
configuration works when a DirXML-WorkOrder object has been created in the directory.

3.2  Subscriber Channel Functions
This section provides a basic understanding of the functions the Subscriber channel performs in the 
WorkOrder driver.

First, Placement and Create rules are configured so all new work orders that contain the required 
attributes are sent to the Subscriber channel. The following attributes must be present for a work 
order to pass the Create rule and go to the Subscriber channel:

DirXML-nwoContent
DirXML-nwoStatus
DirXML-DoItNow Flag
DirXML-SendToPublisher Flag

Figure 3-1 shows what happens when the Subscriber channel receives a work order. 
Understanding Driver Architecture 17



18 Novell

novdocx (en)  17 S
eptem

ber 2009
Figure 3-1   Subscriber Channel Configuration

The Subscriber channel performs the following actions:

1. Creates an association for each WorkOrder object it receives.
2. Checks if the DoItNow and SendToPublisher flags are set to True. If these attributes are set to 

True, the Subscriber channel builds a work order and sends it immediately to the Publisher 
channel.

3. If the DoItNow and SendToPublisher flags are not set to True, the Subscriber channel waits 
until the next event.

3.3  Publisher Channel Functions
This section reviews the functions of the Publisher channel.

Section 3.3.1, “The Publisher Channel Wakes Up,” on page 18
Section 3.3.2, “How the Publisher Channel Processes Work Orders,” on page 20
Section 3.3.3, “How the Publisher Channel Deletes Work Orders,” on page 21

3.3.1  The Publisher Channel Wakes Up
The following flowchart illustrates the Publisher channel’s action when it wakes up.
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Figure 3-2   Publisher Channel Configuration

1. The Publisher channel wakes because the Subscriber channel sends a WorkOrder object. If the 
SendToPublisher flag is set to True, the work order is written out to the work order container. If 
the DoItNow flag is set to True, the work order is processed immediately.

2. The Publisher channel wakes when the polling time has expired and queries the work order 
container for work orders that are pending and due. The driver processes these work orders. 
Work orders with delete due dates are deleted.

a. The Publisher channel queries the work order container for work orders that are pending 
and due. See Section 3.3.2, “How the Publisher Channel Processes Work Orders,” on 
page 20.

b. The Publisher channel queries all work orders for expired DeleteDueDates. See 
Section 3.3.3, “How the Publisher Channel Deletes Work Orders,” on page 21.

3. If the driver heartbeat is configured, the driver wakes to report the driver status.
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3.3.2  How the Publisher Channel Processes Work Orders
After the Publisher channel queries the Identity Vault for work orders, it configures the work orders 
in the driver. The following flowchart illustrates how the Publisher channel processes work orders.

Figure 3-3   How the Publisher Processes Work Orders

1. Before a work order is processed, the driver checks the DependentWorkOrder attribute to see if 
the work order is dependent on another work order. If there is a dependent work order, the 
Publisher channel queries Identity Manager to see the status of the dependent work order. If the 
dependent work order status is configured, the Publisher channel processes the work order. If 
not, the work order waits until the next polling loop to see if the dependent work order has been 
configured.

2. The Publisher channel performs the work orders that are due, completing the appropriate action 
based on the attributes of the DirXML-WorkOrder objects.

3. To process the work order, the driver writes a DirXML-WorkToDo object to the WorkToDo 
container. The DirXML-nwoContent attribute of the WorkToDo object contains the value of 
the DirXML-nwoContent attribute of the WorkOrder object. The default configuration does not 
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do anything else with the WorkToDo object. A policy could use the WorkToDo object to 
process the work order. For example, the content attribute might contain the DN of a user 
object whose LogOnDisabled flag should be changed from True to False at the due date. 

4. The Publisher channel updates the DirXML-WorkOrder with the results. If the WorkToDo 
object was processed without an error, the status of the work order will be changed to 
configured. If an error occurred, then the status is changed to Error. The work order process log 
is updated to contain the results.

5. If the WorkOrder object has a repeat interval value, the value is added to the Due Date and the 
work order status remains pending. This allows for the work order to be repeated as many times 
as specified in the repeat interval count value, or indefinitely if no repeat interval count value is 
specified. The process log contains the results. 

3.3.3  How the Publisher Channel Deletes Work Orders
The Publisher channel now queries the work order container for work orders with an expired 
DeleteDueDate attribute. If the status of the work order is pending or configured, and the 
DeleteDueDate has expired, the work order is deleted. The work order is also deleted if it has an 
error status and the DeleteOnError attribute is set to True. The following flowchart illustrates this 
process.

Figure 3-4   The DeleteDueDate Process
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4Objects and Attributes Used

This section reviews the new objects and attributes used by the driver. 

Section 4.1, “New Objects Used by the Driver,” on page 23
Section 4.2, “DoItNow and SendToPublisher Flags,” on page 24

4.1  New Objects Used by the Driver
Using two new object classes in the Identity Vault, the Identity Manager WorkOrder driver 
configures work orders and records the results. For a description of a schema for these objects, see 
Appendix B, “Schema For Work Order Management,” on page 81.

Section 4.1.1, “DirXML-WorkOrder Object,” on page 23
Section 4.1.2, “DirXML-WorkToDo Object,” on page 23

4.1.1  DirXML-WorkOrder Object
The DirXML-WorkOrder object delays the work order to be processed until the scheduled date and 
time or until a dependent work order is configured. The driver also repeats work orders if the work 
order has a repeating interval. 

If the work order is marked DoItNow, the driver performs it immediately and doesn’t wait for a 
polling time or time of day. To learn how to use the DoItNow and SendToPublisher flags, see 
Section 4.2, “DoItNow and SendToPublisher Flags,” on page 24.

An iManager plug-in is provided to help you create and maintain work orders. To learn how to use 
the plug-in, see Section 7.2, “Using the iManager Plug-in,” on page 37.

4.1.2  DirXML-WorkToDo Object
The driver creates this object and writes it to the Identity Vault to process the work order. The Value 
of the WorkOrder Content attribute becomes the value of the DirXML-WorkToDo Content 
attribute. The driver sends this object to the Identity Vault and returns the status of the work order 
(Configured, Error, etc.) and writes it in the ProcessLog attribute. Any results or information 
available to the driver are recorded in the ProcessLog.

If the work order has a repeat attribute, the work order gets a new due date with the interval added 
and the status remains pending, allowing it to be processed again on the new due date.

NOTE: The work-order driver creates the DirXML-WorkToDo objects. These objects are not 
automatically deleted. To avoid the number of objects growing indefinitely, the developer of the 
driver policies can add code for cleaning the objects.
Objects and Attributes Used 23
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4.2  DoItNow and SendToPublisher Flags
The Novell Identity Manager 3.5.1 WorkOrder driver has two flags to initiate a work order event.

Section 4.2.1, “DoItNow Flag,” on page 24
Section 4.2.2, “SendToPublisherFlag,” on page 24

4.2.1  DoItNow Flag
When this flag is set to True, the Subscriber channel wakes up the Publisher channel by sending the 
work order to the Publisher channel. This allows the Publisher channel to perform the work order 
immediately instead of waiting for the next polling time or polling interval.

Use this flag when you want the work order completed immediately. You can set this flag to True 
when you manually create a work order, or in an automated solution you can use policies to 
determine whether the flag should be set.

4.2.2  SendToPublisherFlag
When this flag is set to True for a work order, the Subscriber channel sends the work order to the 
Publisher channel and the Publisher channel writes the WorkOrder object to the WorkOrder 
container specified in the configuration parameters.

This flag is usually set to False. However, if a work order is created by a policy in response to an 
event in the Identity Vault, setting the flag to True enables the work order to be written in the work 
order container.
 Identity Manager 3.5.1 Driver for WorkOrder
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5Customizing the Driver

 Identity Manager 3.5.1 is designed so you can customize the driver for your specific business needs. 
To customize the WorkOrder driver, you need to know what the default template does. The 
following sections explain the default functionality of the driver and how to customize the driver to 
meet your business needs.

Section 5.1, “Default Driver Parameters,” on page 25
Section 5.2, “Customizing the Driver,” on page 25
Section 5.3, “Additional Solutions,” on page 25

5.1  Default Driver Parameters
The driver import file defines some basic functionality in the driver. How the driver handles this 
information for each channel is explained in the tables in Section 6.5, “Configuration Information,” 
on page 32 and Section 6.8, “Configuring the Subscriber and Publisher Channels,” on page 34.

5.2  Customizing the Driver
Section 5.2.1, “Customizing Policies,” on page 25
Section 5.2.2, “Customizing Driver Parameters,” on page 25

5.2.1  Customizing Policies
To change the default functionality of the driver, use the Policy Builder to change the policies. For 
more information, see the Policy Builder and Driver Customization Guide (http://www.novell.com/
documentation/idm/)

5.2.2  Customizing Driver Parameters
You can also change the default functionality of the driver by changing the driver’s parameters. 

1 In iManager, click Identity Manager > Identity Manager Overview.
2 Browse to the driver set where the driver exists, then click Search.
3 Click the upper right corner of the driver icon and select Edit properties.
4 Select Driver Configuration and scroll down to Driver Parameters.
5 Make the changes you want, then click OK.

5.3  Additional Solutions
The WorkOrder driver can be used in conjunction with other drivers to create and schedule work 
orders. The following samples illustrate two possible solutions for customizing your driver.

Section 5.3.1, “Human Resource Sample Using an HR Driver,” on page 26
Section 5.3.2, “Human Resource Sample without an HR Driver,” on page 28
Customizing the Driver 25
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5.3.1  Human Resource Sample Using an HR Driver
The following samples illustrate how the WorkOrder driver can be used with an HR driver to create 
a new user and postpone activating the new employee’s access to the system until the hire date. 
Figure 5-1 illustrates how these drivers work together in the sample configuration.

In this scenario, the new employee is hired, but does not begin wok until a future date and time. The 
new employee is put into the HR system with his hire date set. The employee is marked as not active 
and does not have access to the system.

The HR Identity Manager driver writes the new user object to the Identity Vault. A policy in that 
driver checks to see if he is active. If he is active, the driver performs the work. If he is not active, 
the policy creates a work order to activate the new employee on the hire date. The work order is 
marked pending. A policy in the WorkOrder driver processes the work order on the hire date. The 
policy in the WorkOrder driver sets the user object’s loginDisabled attribute to False, allowing the 
user to log in.

The sample could be extended to allow other Identity Manager drivers to have a Create rule to 
disallow the creation of the user object in other connected systems until the user object’s 
loginDisabled attribute is set to False. The result is that the user’s system access is provisioned on 
his hire date and not before.
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Figure 5-1   Data Flow with an HR Driver

Other Identity Manager drivers that are interested in this user have a Create rule that does not allow 
the user to be created in the application until the loginDisabled attribute is set to False.

Human Resource Driver Policies

The following policies show how to implement this sample. In the sample, the Delimited Text 
Driver is acting as the HR system interface. The Delimited Text Driver is configured to provide the 
needed attributes: LastName, FirstName, HireDate, Disabled.
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Mapping Rule

The mapping Rule maps the attributes used in the Delimited Text Driver to attributes in the Identity 
Vault. You can view the sample at hr-drv-schema-map.xml (../samples/hr-drv-schema-map.xml).

Filter

The filter attribute allows only the attributes that are needed by this example to be passed through. 
The DirXML-DueDate is notify only. This attribute should not be applied to the user object. 
However, it should be available for the Command Transformation. You can view the sample at hr-
drv-schema-map.xml (../samples/hr-drv-filter.xml)

Command Transformation Policy

The Command Transformation policy checks to see if a user object is being added to the Identity 
Vault. It also ensures that the loginDisabled attribute is set to True. If the conditions are satisfied, the 
policy then creates a work order and places it in the WorkOrder container. The WorkOrder driver 
looks in this container for work orders to process.

The policy puts the DN of the user that was created in the DirXML-nwoContent attribute. It also 
puts the DirXML-DueDate from the user into the WorkOrder object DirXML-DueDate and then 
sets the work order status to “pending”. You can view the sample at hr-drv-cmd-transform.xml (../
samples/hr-drv-cmd-transform.xml).

WorkOrder Driver Policy

The WorkOrder driver Policy only uses the Publisher Command Transformation policy, described 
below:

Publisher Command Transformation Policy

The Work Order Command Transformation policy checks to see that a DirXML-WorkToDo object 
is being added. If it is, the policy gets the DN of the user from the DirXML-nwoContent attribute. It 
then sets the users Login Disable attribute to False. This allows the user to log in. 

NOTE: <do-add-dest-attr-value class-name="User" direct="true" name="Login 
Disabled"> should not be used. 

When direct is equal to True, the action is performed as desired, but the results are not returned to 
the driver. Therefore, the driver cannot report the results of the write correctly. You can view the 
sample at hr-wo-drv-pub-cmd-transform.xml (../samples/hr-wo-drv-pub-cmd-transform.xml).

5.3.2  Human Resource Sample without an HR Driver
This sample creates a new user and postpones activating the new employee’s access to the system 
until the hire date by putting policies in the WorkOrder driver to create the work order. Figure 5-2   
illustrates this sample configuration.

When a new user object is created in the Identity Vault, a policy in the WorkOrder driver checks to 
see if the loginDisabled attribute is set to True. If it is not set to True, the Create rule blocks the 
event. If it is set to True, the policy creates a work order to set the loginDisabled attribute on the user 
to False on the loginActivationTime.
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Figure 5-2   Data flow without an HR Driver

The following policies show how to implement the sample configuration:

Filter Additions

Modify the filter to allow user objects with loginActivationTime and loginDisabled attributes to 
synchronize on the Subscriber channel. You can view the sample at wo-filter.xml (../samples/wo-
filter.xml).

Subscriber Create Rule

The Create rule vetoes this event if the loginActivationTime or the loginDisabled attributes are not 
present. It also vetoes this event if the loginDisabled attribute is set to False. You can view the 
sample at wo-create.xml (../samples/wo-create.xml).

Subscriber Command Transform

This policy checks to see if the event is an Add of a user object. If that is true, the policy creates a 
WorkOrder object. The DN of the user object is added to the DirXML-nwoContent attribute. The 
DirXML-DueDate is set to the loginActivationTime. The DirXML-nwoStatus is set to pending. The 
DirXML-nwoSendToPublisher attribute is set to True.
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This work order has not yet been created in the Identity Vault, This sample configuration creates the 
work order in the Identity Vault by setting the SendToPublisher attribute to True. This tells the 
publisher in the WorkOrder driver to write the policy to the work order container that it looks in for 
work orders to be processed. You can view the sample at wo-sub-cmd-transform.xml (../samples/
wo-sub-cmd-transform.xml).

Work Order E-Mail Notification of Work Order Completion

This policy can be used with the WorkOrder driver to send e-mail notification of a completed work 
order. This policy is in the Publisher Command Transform. The policy checks to see if a DirXML-
WorkOrder modify event is happening. If it is, it builds an e-mail from the status, description, and 
process log of the work order and then sends it to an administrator. This notifies the administrator 
that a work order has been processed and gives them the results. You can view the sample at wo-
pub-cmd-transform.xml (../samples/wo-pub-cmd-transform.xml).
 Identity Manager 3.5.1 Driver for WorkOrder
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6Installing and Configuring

The WorkOrder driver is installed as part of the Novell® Identity Manager 3.5.1. The following 
sections review the tasks required to install and configure the driver:

Section 6.1, “Prerequisites,” on page 31
Section 6.2, “Files Included with the WorkOrder Driver,” on page 31
Section 6.3, “Creating Containers,” on page 31
Section 6.4, “Installation,” on page 32
Section 6.5, “Configuration Information,” on page 32
Section 6.6, “Configuring the Driver in Designer,” on page 32
Section 6.7, “Configuring the Driver in iManager,” on page 33
Section 6.8, “Configuring the Subscriber and Publisher Channels,” on page 34

6.1  Prerequisites
Before installing the WorkOrder driver as part of Novell Identity Manager 3.5.1, see Section 2.3, 
“Prerequisites,” on page 16.

6.2  Files Included with the WorkOrder Driver
The following files are included with the WorkOrder driver:

WorkOrder.jar is the driver shim. This file is copied to the server where Identity Manager is 
installed or to the server where Remote Loader is installed.
WorkOrderDriver-IDM3_5_1-V1.xml is the import file with configuration and policies for the 
driver. This file is copied to the server where iManager is installed.
The latest iManager plug-ins are included for creating and managing work orders in the 
directory.

6.3  Creating Containers
The driver configuration requires that container objects be provided for creating and processing 
DirXML-WorkOrder objects and DirXML-WorkToDo objects. These objects are generated after the 
Publisher configures the DirXML-WorkOrder objects. 

To plan the implementation of the WorkOrder driver:

Identify the container for the DirXML-WorkOrder objects
Identify the container for the DirXML-WorkToDo objects
Identify additional containers to store work orders based on the return status of configured 
work orders. For example, separate containers can store work orders with error or warning 
messages.
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6.4  Installation
The WorkOrder driver is installed automatically with the Novell Identity Manager 3.5.1. To install, 
see the Identity Manager 3.5.1 Installation Guide.

6.5  Configuration Information
The WorkOrder driver configuration file is a sample configuration you customize to your 
environment. After the WorkOrder driver is installed, you must import and customize the driver 
configuration file in either Designer or iManager. 

As you import the driver configuration file, you are prompted for certain information depending on 
the configuration selection you made. The following table explains the parameters you must provide 
during initial driver configuration.

Table 6-1   Configuring the Driver

6.6  Configuring the Driver in Designer
Designer allows you to import the basic driver configuration file for the WorkOrder driver. This file 
creates and configures the objects and policies needed to make the driver work properly. 

Parameter Name Parameter Descriptions

Driver Name The actual name you want to use for the driver.

WorkOrders Container The name of the container where work orders are 
to be stored.

WorkToDo Container The name of the container to store configured work 
orders.

Polling Method Specifies the polling method by interval or time. 
Interval indicates that the driver will poll at a 
specified time interval. Polling by time indicates a 
specific time of day.

Driver Heartbeat Specifies if the Publisher should emit heartbeat 
documents. The driver emits heartbeat documents 
to indicate to the Identity Manager that the driver is 
still functioning.

Install Driver as Remote or Local Select Remote to configure the driver for use with 
the Remote Loader service.

Select Local to configure the driver for local use.

Poll Interval The polling interval (in minutes) at which the 
Publisher channel polls the Identity Manager Vault 
for work orders to be configured.

Poll Time Time of day the Publisher channel wakes up to 
check the Identity Manager Vault for work orders to 
be configured.
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There are different ways to import the driver configuration file. The following example documents 
one method to import the driver’s configuration in Designer. 

1 Open a project in Designer. Go to the Modeler and right-click the Driver Set object, then select 
New>Driver to open a project in Designer.

2 Define the driver parameters.
For information on the settings, see Chapter 5, “Customizing the Driver,” on page 25.

3 After defining the driver parameters, click OK to import the driver.
4 Customize and test the driver before deploying the driver into the production environment. To 

learn how to customize the driver, see Chapter 5, “Customizing the Driver,” on page 25.
5 After the driver is fully tested, deploy the driver into the Identity Vault as described in 

Documenting Projects (http://www.novell.com/documentation/designer21/admin_guide/data/
docgenoverview.html) in the Designer 2.1 for Identity Manager 3.5.1.

6.7  Configuring the Driver in iManager
To import the WorkOrder driver configuration in iManager:

1 In iManager, select Identity Manager Utilities > Import Configurations.
2 Select an existing driver set or select a new driver set.
3 If you selected an existing driver set, continue with Step 4.

or
If you placed the driver in a new driver set, skip to Step 5.

4 If you selected an existing driver set: 
4a Browse to and select the driver set, then click Next.
4b Skip to Step 7.

5 If you selected to place the driver in a new driver set, click Next, then define the properties of 
the new driver set: 
5a Specify the name of the driver set.
5b Browse to and select the context where the driver set is created.
5c Browse to and select the server you want to associate with the driver set.
5d Select the Create a new partition on this driver set option.
5e  Click Next.

Novell recommends that you create a partition for the driver object. For Identity Manager 
to function, the server that is associated with the driver set must hold a real replica of the 
Identity Manager object. If the server holds a Master or Read/Write replica of the context 
where the WorkOrder objects are created, the partition is not required.

6 Select how you want the driver configurations sorted:
All configurations
Identity Manager 3.5 configurations
Identity Manager 3.0 configurations
Configurations not associated with an IDM version

7 Select the WorkOrder driver, then click Next.
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8 Define the driver parameters, then click Next. 
For information on the settings, see Section 6.5, “Configuration Information,” on page 32.

9 Assign security rights to the WorkOrder driver object:
9a Select Define Security Equivalences.
9b Click Add, then browse to and select a user object that has the rights the driver needs to 

have on the server.
Many administrators give the WorkOrder object security equivalence to the Administrator 
User object in the Identity Vault. However, you might want to create another object, such 
as a DriversUser, and assign security equivalence to that user. 
Whatever object you select must have Read/Write access to all objects the driver will read 
or write.

9c Click OK twice.
10 Exclude the administrative roles from replication.

10a Select Exclude Administrative Roles.
10b Click Add.
10c Browse to the Identity Vault and select the security-equivalence object that you specified 

in Step 9 (for example, DriversUser) and exclude the object from replication.

IMPORTANT: If you delete the security-equivalence object, you remove the rights from 
the driver. Consequently, the driver can’t make changes to Identity Manager.

If there are objects that are currently excluded, they do not appear in the Excluded users 
list unless you select Retrieve Current Exclusions.

10d Click OK twice.
11 Click Next.
12 View the summary, then click Finish.
13 To view information about configuring additional driver properties, see Chapter 5, 

“Customizing the Driver,” on page 25.

6.8  Configuring the Subscriber and Publisher 
Channels
This section provides the rules needed to configure the Subscriber channel and the Publisher 
channel. For an overview on how the Subscriber and Publisher channels work, see Section 3.2, 
“Subscriber Channel Functions,” on page 17 and Section 3.3, “Publisher Channel Functions,” on 
page 18.

6.8.1  Configuring the Subscriber Channel
The Subscriber channel processes only events that pertain to the work orders. The following table 
lists the rules and policies used in configuring the Subscriber channel.
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Table 6-2   Configuring the Subscriber Channel

6.8.2  Configuring the Publisher Channel
The following table lists the rules and policies used to configure the Publisher channel.

Table 6-3   Configuring the Publisher channel

Rule or Policy What it does

Subscriber Filter Allows only events for WorkOrder Objects to be 
processed.

Event Transformation Not used in the sample configuration.

Matching Rule Not used in the sample configuration.

Create Rule Contains rules only for WorkOrder objects.

Requires values for the following attributes on a 
WorkOrder object:

nwoStatus

nwoSendToPublisher

nwoDoItNow

nwoContent

If the values are not present, the work order is not 
sent to the Publisher channel and it is not 
configured by the driver.

For a description of these attributes, see 
Appendix B, “Schema For Work Order 
Management,” on page 81.

Placement Rule Maps work orders from the work order container 
you specified to the driver. This mapping is 
necessary so that the Subscriber channel can 
check the work orders to see if the DoItNow flag is 
set to True.

Command Transformation Not used in the sample configuration.

Schema Mapping Maps the eDirectory namespace to the Work Order 
namespace.

Output Transformation Not used in the sample configuration.

Rule or Policy What it does

Schema Mapping Maps the Work Order driver namespace to the 
eDirectory namespace.

Event Transformation Not used in the sample configuration.

Publisher Filter Allows only events for WorkOrder objects to be 
processed.
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Matching Rule Not used in the sample configuration.

Placement Rule Places WorkOrder objects in the correct container 
as defined in the driver’s configuration parameters.

Places WorkToDo objects in the correct container.

Command Transformation Not used in the sample configuration.

Rule or Policy What it does
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7Creating and Managing Work 
Orders

There are two ways to create work orders in the Novell® Identity Manager 3.5.1 WorkOrder driver. 
The following sections review how this is accomplished:

Section 7.1, “Work Orders Created from Events,” on page 37
Section 7.2, “Using the iManager Plug-in,” on page 37

7.1  Work Orders Created from Events
Work orders can be created from events on the Subscriber channel. For an example of how this is 
done, see Section 5.3, “Additional Solutions,” on page 25.

7.2  Using the iManager Plug-in
An iManager plug-in is provided to help you create and maintain work orders. 

Section 7.2.1, “Creating and Deleting a New Work Order,” on page 37
Section 7.2.2, “Specifying and Editing Work Order Properties,” on page 38

7.2.1  Creating and Deleting a New Work Order
To create a new work order:

1 In iManager, select Work Orders > Work Order Management. 
2 Select New under Work Order Management.
3 Specify the name for the work order. This value creates the CN of the resource object in the 

Identity Vault.
4 Select the new work order to specify the properties.

To delete a work order, select the box and click Delete.

To sort the list according to name, status or date, click the appropriate selection button on the table 
heading. After selecting the column, an arrow icon will appear next to the column heading. This 
allows you to sort in ascending or descending order.

To filter the work order list:

1 Click Show under Work Order Management.
2 From the drop-down menu, select the filter type:

Show all: All work orders associated with the driver are listed.
Configured: Only configured work orders associated with the driver are listed.
Error: Only work orders with an error status are listed.
On Hold: Work orders that have been manually placed on hold are listed.
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Pending: Work order that are not yet due are listed.

7.2.2  Specifying and Editing Work Order Properties
The following section explains the Work Order Property Page that allows you to create or edit a 
DirXML-nwoWorkOrder object. This interface allows you to specify the properties for new work 
orders, or edit the properties of existing work orders.

1 Select the status of the work order. Normally, the status is marked Pending. You can stop a 
work order by marking it On Hold.

2 Select whether to have the driver do the work order immediately, or use the calendar to 
schedule the work order due date.

3 Specify if it is a repeating work order. Specify the time interval by choosing the number of 
weeks, days, hours, or minutes before the work order is to be repeated. The work order stops 
repeating on the Delete DueDate, or until it is manually deleted by editing the work order, or if 
the driver sends an error message.

4 Use the calendar to specify the date the work order will be deleted.
5 List any dependent work orders by clicking the Search icon and selecting dependent work 

order. Click the Subtract icon to delete dependent work orders.
6 Write the information about the work order. This attribute is passed through to the WorkToDo 

object when the work order is processed.
7 (Optional) Assign a unique work order number. This value can be assigned by a corporate work 

order system.
8 Indicate the information of the person responsible for the work order.
9 The Work Order Processing Log is for the driver to log the results of the work order. Use this 

field to check on the status of a work order or to identify any problems the driver encountered 
while attempting to configure the work order. The following results can be recorded:

Pending: The driver is waiting for the due date to complete the work order.
Configured: The work order has been successfully processed.
Error: The driver was unable to perform the work order.
Warning: There is a warning regarding the work order. For example, if the work order 
has a dependent work order with a later due date, the driver processes a warning.

10 Provide a description of the work order.
11 In the Work Order content field, indicate the data used by the driver’s rules to process the work 

order. For example, it might be the XML the Command Transformation uses to process the 
work order.

12 Select one of the following options when you are finished specifying or editing the work order 
properties:

Click Apply to save the current information and continue working.
Click OK to save and close the work order.
Click Cancel to close the work order without saving the information.
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8Managing the Driver

The driver can be managed through Designer, iManager, or the DirXML® Command Line utility. 

Section 8.1, “Starting, Stopping, or Restarting the Driver,” on page 39
Section 8.2, “Using the DirXML Command Line Utility,” on page 40
Section 8.3, “Viewing Driver Versioning Information,” on page 40
Section 8.4, “Reassociating a Driver Set Object with a Server Object,” on page 45
Section 8.5, “Changing the Driver Configuration,” on page 46
Section 8.6, “Storing Driver Passwords Securely with Named Passwords,” on page 46
Section 8.7, “Adding a Driver Heartbeat,” on page 53

8.1  Starting, Stopping, or Restarting the Driver
Section 8.1.1, “Starting the Driver in Designer,” on page 39
Section 8.1.2, “Starting the Driver in iManager,” on page 39
Section 8.1.3, “Stopping the Driver in Designer,” on page 39
Section 8.1.4, “Stopping the Driver in iManager,” on page 39
Section 8.1.5, “Restarting the Driver in Designer,” on page 40
Section 8.1.6, “Restarting the Driver in iManager,” on page 40

8.1.1  Starting the Driver in Designer
1 Open a project in the Modeler, then right-click the driver line.
2 Select Live > Start Driver.

8.1.2  Starting the Driver in iManager
1 In iManager, click Identity Manager > Identity Manager Overview.
2 Browse to the driver set where the driver exists, then click Search.
3 Click the upper right corner of the driver icon, then click Start driver.

8.1.3  Stopping the Driver in Designer
1 Open a project in the Modeler, then right-click the driver line.
2 Select Live > Stop Driver.

8.1.4  Stopping the Driver in iManager
1 In iManager, click Identity Manager > Identity Manager Overview.
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2 Browse to the driver set where the driver exists, then click Search.
3 Click the upper right corner of the driver icon, then click Stop driver.

8.1.5  Restarting the Driver in Designer
1 Open a project in the Modeler, then right-click the driver line.
2 Select Live > Restart Driver.

8.1.6  Restarting the Driver in iManager
1 In iManager, click Identity Manager > Identity Manager Overview.
2 Browse to the driver set where the driver exists, then click Search.
3 Click the upper right corner of the driver icon, then click Restart driver.

8.2  Using the DirXML Command Line Utility
The DirXML Command Line utility provides command line access to manage the driver. This utility 
is not a replacement for iManager or Designer. The primary use of this utility is to allow you to 
create platform-specific scripts to manage the driver.

For example, you could create a shell script on Linux* to check the status of the driver.   See 
Appendix A, “DirXML Command Line Utility,” on page 67 for detailed information about the 
DirXML Command Line utility. For daily tasks, use iManager or Designer. 

8.3  Viewing Driver Versioning Information
The Versioning Discovery tool only exists in iManager.

Section 8.3.1, “Viewing a Hierarchical Display of Versioning Information,” on page 40
Section 8.3.2, “Viewing the Versioning Information as a Text File,” on page 42
Section 8.3.3, “Saving Versioning Information,” on page 44

8.3.1  Viewing a Hierarchical Display of Versioning Information
1 To find your Driver Set object in iManager, click Identity Manager > Identity Manager 

Overview, then click Search.
2 In the Identity Manager Overview, click Information.
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You can also select Identity Manager Utilities > Versions Discovery, browse to and select the 
Driver Set object, then click OK.

3 View a top-level or unexpanded display of versioning information.

The unexpanded hierarchical view displays the following:
The eDirectoryTM tree that you are authenticated to
The Driver Set object that you selected
Servers that are associated with the Driver Set object
If the Driver Set object is associated with two or more servers, you can view Identity 
Manager information on each server.
Drivers 

4 View versioning information related to servers by expanding the server icon.
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The expanded view of a top-level server icon displays the following:
Last log time
Version of Identity Manager that is running on the server

5 View versioning information related to drivers by expanding the driver icon.

The expanded view of a top-level driver icon displays the following:
The driver name 
The driver module (for example, 
com.novell.nds.dirxml.driver.delimitedtext.DelimitedTextDriver) 

The expanded view of a server under a driver icon displays the following:
The driver ID 
The version of the instance of the driver running on that server

8.3.2  Viewing the Versioning Information as a Text File
Identity Manager publishes versioning information to a file. You can view this information in text 
format. The textual representation is the same information contained in the hierarchical view.

1 To find your Driver Set object in iManager, click Identity Manager > Identity Manager 
Overview, then click Search.

2 In the Identity Manager Overview, click Information.
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You can also select Identity Manager Utilities > Versioning Discovery, browse to and select 
the Driver Set object, then click Information.

3 In the Versioning Discovery Tool dialog box, click View.

The information is displayed as a text file in the Report Viewer window.
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8.3.3  Saving Versioning Information
You can save versioning information to a text file on your local or network drive.

1 To find the Driver Set object in iManager, click Identity Manager > Identity Manager 
Overview, then click Search.

2 In the Identity Manager Overview, click Information.
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You can also select Identity Manager Utilities > Versioning Discovery, browse to and select 
the Driver Set object, then click Information.

3 In the Versioning Discovery Tool dialog box, click Save As.

4 In the File Download dialog box, click Save.
5 Navigate to the desired directory, type a filename, then click Save.

Identity Manager saves the data to a text file.

8.4  Reassociating a Driver Set Object with a 
Server Object
The Driver Set object should always be associated with a server object. If the driver set is not 
associated with a server object, none of the drivers in the driver set can start.
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If the link between the Driver Set object and the server object becomes invalid, you see one of the 
following conditions:

When upgrading eDirectory on your Identity Manager server, you get the error 
UniqueSPIException error -783.
No server is listed next to the driver set in the Identity Manager Overview window.
A server is listed next to the driver set in the Identity Manager Overview window, but the name 
is garbled text.

To resolve this issue, disassociate the Driver Set object and the Server object, then reassociate them. 

1 In iManager click Identity Manager > Identity Manager Overview, then click Search to find the 
driver set object that the driver should be associated with.

2 Click the Remove server icon, then click OK.
3 Click the Add server icon, then browse to and select the server object.
4 Click OK.

8.5  Changing the Driver Configuration
If you need to change the driver configuration, Identity Manager allows you to make the change 
through iManager or Designer. 

To change the driver configuration in iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to and select the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties.

To change the driver configuration in Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties.

For a listing of all of the configuration fields, see Appendix C, “Properties of the Driver,” on 
page 85.

8.6  Storing Driver Passwords Securely with 
Named Passwords
Identity Manager allows you to store multiple passwords securely for a particular driver. This 
functionality is referred to as Named Passwords. Each different password is accessed by a key, or 
name.

You can also use the Named Passwords feature to store other pieces of information securely, such as 
a user name.
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To use a Named Password in a driver policy, you refer to it by the name of the password, instead of 
using the actual password, and the Metadirectory engine sends the password to the driver. The 
method described in this section for storing and retrieving Named Passwords can be used with any 
driver without making changes to the driver shim.

Section 8.6.1, “Using Designer to Configure Named Passwords,” on page 47
Section 8.6.2, “Using iManager to Configure Named Passwords,” on page 47
Section 8.6.3, “Using Named Passwords in Driver Policies,” on page 49
Section 8.6.4, “Using the DirXML Command Line Utility to Configure Named Passwords,” on 
page 49

8.6.1  Using Designer to Configure Named Passwords
1 Right-click the driver object, then select Properties.
2 Select Named Password, then click New.

3 Specify the Name of the Named Password.
4 Specify the Display name of the Named Password.
5 Specify the Named Password, then re-enter the password.
6 Click OK twice.

8.6.2  Using iManager to Configure Named Passwords
1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 

driver set that is associated with the driver.
2 In the Identity Manager Overview, click the upper right corner of the driver icon, then click 

Edit properties.
3 On the Modify Object page on the Identity Manager tab, click Named Passwords.

The Named Passwords page appears, listing the current Named Passwords for this driver. If 
you have not set up any Named Passwords, the list is empty.
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4 To add a Named Password, click Add, complete the fields, then click OK.

5 Specify a name, display name and a password, then click OK twice.
You can use this feature to store other kinds of information securely, such as a username.

6 Click OK to restart the driver and have the changes take effect.
7 To remove a Named Password, select the password name, then click Remove.

The password is removed without prompting you to confirm the action.
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8.6.3  Using Named Passwords in Driver Policies
“Using the Policy Builder” on page 49
“Using XSLT” on page 49

Using the Policy Builder

The Policy Builder allows you to make a call to a Named Password. Create a new rule and select 
Named Password as the condition, then set an action depending upon if the Named Password is 
available or not available. 

1 In Designer, launch the Policy Builder, right-click, then click New > Rule.
2 Specify the name of the rule, then click Next.
3 Select the condition structure, then click Next.
4 Select named password for the Condition.
5 Browse to and select the Named Password that is stored on the driver.

In this example, it is userinfo.
6 Select whether the Operator is available or not available.
7 Select an action for the Do field.

In this example, the action is veto.

The example indicates that if the userinfo Named Password is not available, then the event is vetoed.

Figure 8-1   A Policy Using Named Passwords

Using XSLT

The following example shows how a Named Password can be referenced in a driver policy on the 
Subscriber channel in XSLT:

<xsl:value-of 
select=”query:getNamedPassword($srcQueryProcessor,'mynamedpassword')”
xmlns:query=”http://www.novell.com/java/
com.novell.nds.dirxml.driver.XdsQueryProcessor/>

8.6.4  Using the DirXML Command Line Utility to Configure 
Named Passwords

“Creating a Named Password in the DirXML Command Line Utility” on page 50
“Using the DirXML Command Line Utility to Remove a Named Password” on page 51
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Creating a Named Password in the DirXML Command Line Utility

1 Run the DirXML Command Line utility.
For information, see Appendix A, “DirXML Command Line Utility,” on page 67.

2 Enter your username and password.
The following list of options appears.
DirXML commands

 1: Start driver
 2: Stop driver
 3: Driver operations...
 4: Driver set operations...
 5: Log events operations...
 6: Get DirXML version

 7: Job operations...
99: Quit

Enter choice:

3 Enter 3 for driver operations.
A numbered list of drivers appears.

4 Enter the number for the driver you want to add a Named Password to.
The following list of options appears.
Select a driver operation for:
driver_name

 1: Start driver
 2: Stop driver
 3: Get driver state
 4: Get driver start option
 5: Set driver start option
 6: Resync driver
 7: Migrate from application into DirXML
 8: Submit XDS command document to driver

 9: Submit XDS event document to driver

10: Queue event for driver
11: Check object password
12: Initialize new driver object
13: Passwords operations
14: Cache operations
99: Exit

Enter choice:

5 Enter 13 for password operations.
The following list of options appears.
Select a password operation

 1: Set shim password
 2: Reset shim password

 3: Set Remote Loader password

 4: Clear Remote Loader password
 5: Set named password
 6: Clear named password(s)
 7: List named passwords
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 8: Get passwords state
99: Exit

Enter choice:

6 Enter 5 to set a new Named Password.
The following prompt appears:
Enter password name:

7 Enter the name by which you want to refer to the Named Password.
8 Enter the actual password that you want to secure at the following prompt:

Enter password:

The characters you type for the password are not displayed.
9 Confirm the password by entering it again at the following prompt:

Confirm password:

10 After you enter and confirm the password, you are returned to the password operations menu.
11 After completing this procedure, you can use the 99 option twice to exit the menu and quit the 

DirXML Command Line Utility.

Using the DirXML Command Line Utility to Remove a Named Password

This option is useful if you no longer need Named Passwords that you previously created.

1 Run the DirXML Command Line utility.
For information, see Appendix A, “DirXML Command Line Utility,” on page 67.

2 Enter your username and password.
The following list of options appears.
DirXML commands

 1: Start driver
 2: Stop driver
 3: Driver operations...
 4: Driver set operations...
 5: Log events operations...
 6: Get DirXML version

 7: Job operations
99: Quit

Enter choice:

3 Enter 3 for driver operations.
A numbered list of drivers appears.

4 Enter the number for the driver you want to remove Named Passwords from.
The following list of options appears.
Select a driver operation for:
driver_name
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 1: Start driver
 2: Stop driver
 3: Get driver state
 4: Get driver start option
 5: Set driver start option
 6: Resync driver
 7: Migrate from application into DirXML
 8: Submit XDS command document to driver

 9: Submit XDS event document to driver

10: Queue event for driver
11: Check object password
12: Initialize new driver object
13: Passwords operations
14: Cache operations
99: Exit

Enter choice:

5 Enter 13 for password operations.
The following list of options appears.
Select a password operation

 1: Set shim password
 2: Reset shim password

 3: Set Remote Loader password

 4: Clear Remote Loader passwor
 5: Set named password
 6: Clear named password(s)
 7: List named passwords

 8: Get passwords state
99: Exit

Enter choice:

6 (Optional) Enter 7 to see the list of existing Named Passwords.
The list of existing Named Passwords is displayed.
This step can help you make sure you are removing the correct password.

7 Enter 6 to remove one or more Named Passwords.
8 Enter No to remove a single Named Password at the following prompt:

Do you want to clear all named passwords? (yes/no):

9 Enter the name of the Named Password you want to remove at the following prompt:
Enter password name:

After you enter the name of the Named Password you want to remove, you are returned to the 
password operations menu:
Select a password operation

 1: Set shim password
 2: Reset shim password

 3: Set Remote Loader password

 4: Clear Remote Loader password
 5: Set named password
 6: Clear named password(s)
 7: List named passwords
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 8: Get passwords state
99: Exit

Enter choice:

10 (Optional) Enter 7 to see the list of existing Named Passwords.
This step lets you verify that you have removed the correct password.

11 After completing this procedure, use the 99 option twice to exit the menu and quit the DirXML 
Command Line utility.

8.7  Adding a Driver Heartbeat
The driver heartbeat is a feature of the Identity Manager drivers that ship with Identity Manager 2 
and later. Its use is optional.  When a heartbeat is set to Yes, the driver sends a heartbeat document to 
the Metadirectory engine if there is no communication on the Publisher channel for the specified 
interval of time. 

The intent of the driver heartbeat is to give you a trigger to allow you to initiate an action at regular 
intervals, if the driver does not communicate on the Publisher channel as often as you want the 
action to occur. To take advantage of the heartbeat, you must customize your driver configuration or 
other tools. The Metadirectory engine accepts the heartbeat document but does not take any action 
because of it. 

For most drivers, a driver parameter for heartbeat is not used in the sample configurations, but you 
can add it.

A custom driver that is not provided with Identity Manager can also provide a heartbeat document, 
if the driver developer has written the driver to support it.

To configure the heartbeat:

1 In iManager, click Identity Manager > Identity Manager Overview. 
2 Browse to and select your driver set object, then click Search.
3 In the Identity Manager Overview, click the upper right corner of the driver icon, then click 

Edit properties.
4 On the Identity Manager tab, click Driver Configuration, scroll to Driver Parameters, then 

look for Heart Beat or a similar display name. If you want the driver to send heart beat 
documents, set the value to Yes.

5 Save the changes, and make sure the driver is stopped and restarted.

After you have added the driver parameter, you can edit the time interval by using the graphical 
view. Another option is to create a reference to a global configuration value (GCV) for the time 
interval. Like other global configuration values, the driver heartbeat can be set at the driver set level 
instead of on each individual driver object. If a driver does not have a particular global configuration 
value, and the driver set object does have it, the driver inherits the value from the driver set object.
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9Troubleshooting Driver Processes

Viewing driver processes is necessary to analyze unexpected behavior. To view the driver 
processing events, use DSTrace. You should only use it during testing and troubleshooting the 
driver. Running DSTrace while the drivers are in production increases the utilization on the Identity 
Manager server and can cause events to process very slowly.

9.1  Viewing Driver Processes
In order to see the driver processes in DSTrace, values are added to the driver set and the driver 
objects. You can do this in Designer and iManager.

Section 9.1.1, “Adding Trace Levels in Designer,” on page 55
Section 9.1.2, “Adding Trace Levels in iManager,” on page 57
Section 9.1.3, “Capturing Driver Processes to a File,” on page 58

9.1.1  Adding Trace Levels in Designer
You can add trace levels to the driver set object or to each driver object.

“Driver Set” on page 55
“Driver” on page 56

Driver Set 

1 In an open project in Designer, select the driver set object in the Outline view.

2 Right-click and select Properties, then click 5. Trace.
3 Set the parameters for tracing, then click OK. 
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If you set the trace level on the driver set object, all drivers appear in the DSTrace logs.

Driver

1 In an open project in Designer, select the driver object in the Outline view.
2 Right-click and select Properties, then click 8. Trace.
3 Set the parameters for tracing, then click OK. 

Parameter Description

Driver trace level As the driver object trace level increases, the amount of information 
displayed in DSTrace increases. 

Trace level 1 shows errors, but not the cause of the errors. If you want 
to see password synchronization information, set the trace level to 5.

XSL trace level DSTrace displays XSL events. Set this trace level only when 
troubleshooting XSL style sheets. If you do not want to see XSL 
information, set the level to zero.

Java debug port Allows developers to attach a Java debugger.

Java trace file When a value is set in this field, all Java information for the driver set 
object is written to a file. The value for this field is the patch for that file.

As long as the file is specified, Java information is written to this file. If 
you do not need to debug Java, leave this field blank.

Trace file size limit Allows you to set a limit for the Java trace file. If you set the file size to 
Unlimited, the file grows in size until there is no disk space left.

NOTE: The trace file is created in multiple files. Identity Manager 
automatically divides the maximum file size by ten and creates ten 
seperate files. The combined size of these files equals the maximum 
trace file size.
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If you set the parameters only on the driver object, only information for that driver appears in 
the DSTRACE log.

9.1.2  Adding Trace Levels in iManager
You can add trace levels to the driver set object or to each driver object.

“Driver Set” on page 57
“Driver” on page 58

Driver Set

1 In iManager, select Identity Manager > Identity Manager Overview.
2 Browse to the driver set object, then click Search.
3 Click the driver set name.

Parameter Description

Trace level As the driver object trace level increases, the amount of information 
displayed in DSTrace increases.

Trace level 1 shows errors, but not the cause of the errors. If you want to 
see password synchronization information, set the trace level to 5.

if you select Use setting from Driver Set, the value is taken from the driver 
set object.

Trace file Specify a filename and location for where the Identity Manager information 
is written for the selected driver.

if you select Use setting from Driver Set, the value is taken from the driver 
set object.

Trace file size limit Allows you to set a limit for the Java trace file. If you set the file size to 
Unlimited, the file grows in size until there is no disk space left.

If you select Use setting from Driver Set, the value is taken from the driver 
set object.

NOTE: The trace file is created in multiple files. Identity Manager 
automatically divides the maximum file size by ten and creates ten 
seperate files. The combined size of these files equals the maximum trace 
file size.

Trace name The driver trace messages are prepended with the value entered instead 
of the driver name. Use this option if the driver name is very long.
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4 Select the Misc tab for the driver set object.
5 Set the parameters for tracing, then click OK. 

See “Misc” on page 95 for the parameters.

Driver

1 In iManager, select Identity Manager > Identity Manager Overview.
2 Browse to the driver set object where the driver object resides, then click Search.
3 Click the upper right corner of the driver object, then click Edit properties.
4 Select the Misc tab for the driver object.
5 Set the parameters for tracing, then click OK.

See “Misc” on page 95 for the parameters.
The option Use setting from Driver Set does not exist in iManager.

9.1.3  Capturing Driver Processes to a File
You can save driver processes to a file by using the parameter on the driver object or by using 
DSTrace. The parameter on the driver object is the Trace file parameter, under the MISC tab.

The driver processes that are captured through DSTrace are the processes that occur on the Identity 
Manager engine. If you use the Remote Loader, you need to capture a trace on the Remote Loader at 
the same time as you are capturing the trace on the Identity Manager engine.

The following methods helps you capture and save Identity Manager processes through DSTrace on 
different platforms.

“NetWare” on page 59
“Windows” on page 59
“UNIX” on page 59
“iMonitor” on page 60
“Remote Loader” on page 60
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NetWare

Use dstrace.nlm to display trace messages on the system console or trace messages to a file 
(sys:\system\dstrace.log). Use dstrace.nlm to display the trace messages to a screen labeled 
DSTrace Console.

1 Enter dstrace.nlm at the server console to load dstrace.nlm into memory.
2 Enter dstrace screen on at the server console to allow trace messages to appear on the 

DSTrace Console screen.
3 Enter dstrace file on at the server console to capture trace messages sent to the DSTrace 

Console to the dstrace.log file.
4 (Optional) Enter dstrace -all at the server console to make it easier to read the trace log.
5 Enter dstrace +dxml dstrace +dvrs at the server console to display Identity Manager 

events.
6 Enter dstrace +tags dstrace +time at the server console to display message tags and time 

stamps.
7 Toggle to the DSTrace Console screen and watch for the event to pass.
8 Toggle back to the server console.
9 Enter dstrace file off at the server console.

This stops capturing trace messages to the log file. It also stops logging information into the 
file.

10 Open the dstrace.log in a text editor and search for the event or the object you modified.

Windows

1 Open the Control Panel > NDS Services > dstrace.dlm, then click Start to display the NDS 
Server Trace utility window.

2 Click Edit > Options, then click Clear All to clear all of the default flags.
3 Select DirXML and DirXML Drivers.
4 Click OK.
5 Click File > New.
6 Specify the filename and location where you want the DSTRACE information saved, then click 

Open.
7 Wait for the event to occur.
8 Click File > Close. 

This stops the information from being written to the log file.
9 Open the file in a text editor and search for the event or the object you modified.

UNIX

1 Enter ndstrace to start the ndstrace utility.
2 Enter set ndstrace=nodebug to turn off all trace flags currently set.
3 Enter set ndstrace on to display trace messages to the console.
4 Enter set ndstrace file on to capture trace messages to the ndstrace.log file in the 

directory where eDirectory is installed. By default it is /var/nds.
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5 Enter set ndstrace=+dxml to display the Identity Manager events.
6 Enter set ndstrace=+dvrs to display the Identity Manager driver events.
7 Wait for the event to occur.
8 Enter set ndstrace file off to stop logging information to the file.
9 Enter exit to quite the ndstrace utility.

10 Open the file in a text editor. Search for the event or the object that was modified.

iMonitor

iMonitor allows you to get DSTrace information from a Web browser. It does not matter where 
Identity Manager is running. The following files run iMonitor:

ndsimon.nlm runs on NetWare®.
ndsimon.dlm runs on Windows*.
ndsimonitor runs on UNIX.

1 Access iMonitor from http://server_ip:8008/nds.
Port 8008 is the default.

2 Specify a username and password with administrative rights, then click Login.
3 Select Trace Configuration on the left side.
4 Click Clear All.
5 Select DirXML and DirXML Drivers.
6 Click Trace On.
7 Select Trace History on the left side.
8 Click the document with the Modification Time of Current to see a live trace.
9 Change the Refresh Interval if you want to see information more often.

10 Select Trace Configuration on the left side, then click Trace Off to turn the tracing off.
11 Select Trace History to view the trace history.

The files are distinguished by their time stamp.

If you need a copy of the HTML file, the default location is:

NetWare: sys:\system\ndsimon\dstrace*.htm
Windows: Drive_letter:\novell\nds\ndsimon\dstrace\*.htm
UNIX: /var/nds/dstrace/*.htm

Remote Loader

You can capture the events that occur on the machine by running the Remote Loader service.

1 Launch the Remote Loader Console by clicking the icon.
2 Select the driver instance, then click Edit.
3 Set the Trace Level to 3 or above.
4 Specify a location and file for the trace file.
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5 Specify the amount of disk space that the file is allowed.
6 Click OK twice to save the changes.

You can also enable tracing from the command line by using the switches in Table 9-1. For more 
information, see “Configuring the Remote Loader ” in the Novell Identity Manager 3.5.1 
Administration Guide.

Table 9-1   Command Line Tracing Switches

Option Short Name Parameter Description

-trace -t integer Specifies the trace level. This is only used when hosting 
an application shim. Trace levels correspond to those 
used on the Identity Manager server.

Example: -trace 3 or -t3

-tracefile -tf filename Specifies a file to write trace messages to. Trace 
messages are written to the file if the trace level is greater 
than zero. Trace messages are written to the file even if 
the trace window is not open. 

Example: -tracefile c:\temp\trace.txt or -tf 
c:\temp\trace.txt

-tracefilemax -tfm size Specifies the approximate maximum size that trace file 
data can occupy on disk. If you specify this option, there is 
a trace file with the name specified using the tracefile 
option and up to 9 additional “roll-over” files. The roll-over 
files are named using the base of the main trace filename 
plus “_n”, where n is 1 through 9.

The size parameter is the number of bytes. Specify the 
size by using the suffixes K, M, or G for kilobytes, 
megabytes, or gigabytes.

If the trace file data is larger than the specified maximum 
when the Remote Loader is started, the trace file data 
remains larger than the specified maximum until roll-over 
is completed through all 10 files.

Example: -tracefilemax 1000M or -tfm 1000M
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10Backing Up the Driver

You can use Designer or iManager to create an XML file of the driver. The file contains all of the 
information entered into the driver during configuration. If the driver becomes corrupted, the 
exported file can be imported to restore the configuration information.

IMPORTANT: If the driver has been deleted, all of the associations on the objects are purged. 
When the XML file is imported again, new associations are created through the migration process.

Not all server-specific information stored on the driver is contained in the XML file. Make sure this 
information is documented through the Doc Gen process in Designer. See “Documenting Projects” 
in the Designer 2.1 for Identity Manager 3.5.1.

Section 10.1, “Exporting the Driver in Designer,” on page 63
Section 10.2, “Exporting the Driver in iManager,” on page 63

10.1  Exporting the Driver in Designer
1 Open a project in Designer, then right-click the driver object.
2 Select Export to Configuration File.
3 Specify a unique name for the configuration file, browse to location where it should be saved, 

then click Save.
4 Click OK in the Export Configuration Results window.

10.2  Exporting the Driver in iManager
1 In iManager, select Identity Manager > Identity Manager Overview.
2 Browse to and select the driver set object, then click Search.
3 Click the driver icon.
4 Select Export in the Identity Manager Driver Overview window.
5 Browse to and select the driver object you want to export, then click Next.
6 Select Export all policies, linked to the configuration or not or select Only export policies that 

are linked to the configuration, depending upon the information you want to have stored in the 
XML file.

7 Click Next.
8 Click Save As, then click Save.
9 Browse and select a location to save the XML file, then click Save.

10 Click Finish.
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11Security: Best Practices

For more information on how to secure the driver and the information it is synchronizing, see 
“Security: Best Practices” in the Novell Identity Manager 3.5.1 Administration Guide.
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ADirXML Command Line Utility 

The DirXML® Command Line utility allows you to use a command line interface to manage the 
driver. You can also create or customize scripts to manage the driver with the commands. 

The utility and the default script are installed on all platforms during the Identity Manager 
installation. They are installed to the following locations: 

Windows: \Novell\Nds\dxcmd.bat
NetWare®: sys:\system\dxcmd.ncf 
UNIX and Linux: /usr/bin/dxcmd (for eDirectoryTM 8.7.x)
UNIX and Linux: /opt/novell/eDirectory/bin/dxcmd (for eDirectory 8.8 and above)

There are two different methods for using the DirXML Command Line utility:

Section A.1, “Interactive Mode,” on page 67
Section A.2, “Command Line Mode,” on page 76

A.1  Interactive Mode
The interactive mode provides a text interface to control and use the DirXML Command Line utility. 

1 At the console, enter dxcmd.
2 Enter the name of a user with sufficient rights to the Identity Manager objects, such as 

admin.novell.
3 Enter the user’s password.

4 Enter the number of the command you want to perform.
Table A-1 on page 68 contains the list of options and what functionality is available.

5 Enter 99 to quit the utility.

NOTE: If you are running eDirectory 8.8 or greater on UNIX or Linux, you must specify the -host 
and -port parameters. For example, dxcmd -host 10.0.0.1 -port 524. If the parameters are not 
specified, a jclient error occurs.

novell.jclient.JCException: connect (to address) 111 UNKNOWN ERROR
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By default, eDirectory 8.8 is not listening to localhost. The DirXML Command Line utility needs to 
resolve the server IP address or hostname and the port to be able to authenticate.

Table A-1   Interactive Mode Options

Figure A-1   Driver Options

Option Description

1: Start Driver Starts the driver. If there is more than one driver, each driver is listed 
with a number. Enter the number of the driver to start the driver.

2: Stop Driver Stops the driver. If there is more than one driver, each driver is listed 
with a number. Enter the number of the driver to stop the driver.

3: Driver operations Lists the operations available for the driver. If there is more than one 
driver, each driver is listed with a number. Enter the number of the driver 
to see the operations available. See Table A-2 on page 69 for a list of 
operations.

4: Driver set operations Lists the operations available for the driver set.

1: Associate driver set with server

2: Disassociate driver set from server

99: Exit

5: Log events operations Lists the operations available for logging events through Novell® Audit. 
See Table A-5 on page 73 for a description of these options.

6: Get DirXML version Lists the version of the Identity Manager installed.

7: Job operations Manages jobs created for Identity Manager.

99: Quit Exits the DirXML Command Line utility
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Table A-2   Driver Options

Options Description

1: Start driver Starts the driver.

2: Stop driver Stops the driver.

3: Get driver state Lists the state of the driver.

0 - Driver is stopped

1 - Driver is starting

2 - Driver is running

3 - Driver is stopping

4: Get driver start option Lists the current driver start option.

1 - Disabled

2 - Manual

3 - Auto

5: Set driver start option Changes the start option of the driver.

1 - Disabled 

2 - Manual

3 - Auto

99 - Exit

6: Resync driver Forces a resynchronization of the driver. It prompts 
for a time delay: Do you want to specify a minimum 
time for resync? (yes/no).

If you enter Yes, specify the date and time you want 
the resynchronization to occur: Enter a date/time 
(format 9/27/05 3:27 PM).

If you enter No, the resynchronization occurs 
immediately.

7: Migrate from application into DirXML Processes an XML document that contains a query 
command: Enter filename of XDS query document:

Create the XML document that contains a query 
command by using the Novell nds.dtd (http://
developer.novell.com/ndk/doc/dirxml/dirxmlbk/ref/
ndsdtd/query.html).

Examples: 

NetWare: sys:\files\query.xml

Windows: c:\files\query.xml

Linux: /files/query.xml
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8: Submit XDS command document to driver Processes an XDS command document:

Enter filename of XDS command document:

Examples: 

NetWare: sys:\files\user.xml

Windows: c:\files\user.xml

Linux: /files/user.xml

Enter name of file for response:

Examples: 

NetWare: sys:\files\user.log

Windows: c:\files\user.log

Linux: /files/user.log

9: Submit XDS event document to driver Processes an XDS event document:

Enter filename of XDS event document:

Examples:

NetWare: sys:\files\add.xml

Windows: c:\files\add.xml

Linux: /files/add.xml

10: Queue event for driver Adds an event to the driver queue:

Enter filename of XDS event document:

Examples:

NetWare: sys:\files\add.xml

Windows: c:\files\add.xml

Linux: /files/add.xml

11: Check object password Validates that an object’s password in the 
connected system is associated with a driver. It 
matches the object’s eDirectory password 
(Distribution Password, used with Universal 
Password). 

Enter user name:

12: Initialize new driver object Performs an internal initialization of data on a new 
Driver object. This is only for testing purposes.

13: Password operations There are nine Password options. See Table A-3 
on page 71 for a description of these options.

14: Cache operations There are five Cache operations. See Table A-4 on 
page 72 for a description of these options.

Options Description
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Figure A-2   Password Operations

Table A-3   Password Operations

99: Exit Exits the driver options.

Operation Description

1: Set shim password Sets the application password. This is the 
password of the user account you are using to 
authenticate into the connected system with.

2: Clear shim password Clears the application password.

3: Set Remote Loader password The Remote Loader password is used to control 
access to the Remote Loader instance. 

Enter the Remote Loader password, then confirm 
the password by typing it again. 

4: Clear Remote Loader password Clears the Remote Loader password so no Remote 
Loader password is set on the Driver object.

5: Set named password Allows you to store a password or other pieces of 
security information on the driver. See Section 8.6, 
“Storing Driver Passwords Securely with Named 
Passwords,” on page 46 for more information.

There are four prompts to fill in:

Enter password name: 

Enter password description:

Enter password:

Confirm password:

Options Description
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Figure A-3   Cache Operations

Table A-4   Cache Operations

6: Clear named passwords Clears a specified Named Password or all named 
passwords that are stored on the driver object: Do 
you want to clear all named passwords? (yes/no).

If you enter Yes, all Named Passwords are cleared. 
If you enter No, you are prompted to specify the 
password name that you want to clear.

7: List named passwords Lists all named passwords that are stored on the 
driver object. It lists the password name and the 
password description.

8: Get password state Lists if a password is set for:

Driver Object password

Application password

Remote loader password

The dxcmd utility allows you to set the Application 
password and the Remote Loader password. You 
cannot set the Driver Object password with this 
utility. It shows if the password has been set or not.

99: Exit Exits the current menu and takes you back to the 
Driver options.

Operation Description

1: Get driver cache limit Displays the current cache limit that is set for the 
driver.

2: Set driver cache limit Sets the driver cache limit in kilobytes. A value of 0 
is unlimited.

Operation Description
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Figure A-4   Log Event Operations

Table A-5   Log Events Operations

3: View cached transactions A text file is created with the events that are stored 
in cache. You can select the number of 
transactions to view.

Enter option token (default=0):

Enter maximum transactions records to return 
(default=1):

Enter name of file for response:

4: Delete cached transactions Deletes the transactions stored in cache.

Enter position token (default=0):

Enter event-id value of first transaction record 
to delete (optional):

Enter number of transaction records to delete 
(default=1):

99: Exit Exits the current menu and takes you back to the 
Driver options.

Operation Description

1: Set driver set log events Allows you to log driver set events through Novell 
Audit. There are 49 items you can select to log. See 
Table A-6 on page 74 for a list of these options.

Type the number of the item you want to log. After 
the items are selected, enter 99 to accept the 
selections.

2: Reset driver set log events Resets all of the log event options.

3: Set driver log events Allows you to log driver events through Novell 
Audit. There are 49 items to select to log. See 
Table A-6 on page 74 for a list of these options.

Type the number of the item you want to log. After 
the items are selected, enter 99 to accept the 
selections.

Operation Description
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Table A-6   Driver Set and Driver Log Events

4: Reset driver log events Resets all of the log event options.

99: Exit Exits the log events operations menu.

Options

1: Status success

2: Status retry

3: Status warning

4: Status error

5: Status fatal

6: Status other

7: Query elements

8: Add elements

9: Remove elements

10: Modify elements

11: Rename elements

12: Move elements

13: Add-association elements

14: Remove-association elements

15: Query-schema elements

16: Check-password elements

17: Check-object-password elements

18: Modify-password elements

19: Sync elements

20: Pre-transformed XDS document from shim

21: Post input transformation XDS document

22: Post output transformation XDS document

23: Post event transformation XDS document

24: Post placement transformation XDS document

25: Post create transformation XDS document

26: Post mapping transformation <inbound> XDS document

27: Post mapping transformation <outbound> XDS document

Operation Description
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28: Post matching transformation XDS document

29: Post command transformation XDS document

30: Post-filtered XDS document <Publisher>

31: User agent XDS command document

32: Driver resync request

33: Driver migrate from application

34: Driver start

35: Driver stop

36: Password sync

37: Password request

38: Engine error

39: Engine warning

40: Add attribute

41: Clear attribute

42: Add value

43: Remove value

44: Merge entire

45: Get named password

46: Reset Attributes

47: Add Value - Add Entry

48: Set SSO Credential

49: Clear SSO Credential

50: Set SSO Passphrase

51: User defined IDs

99: Accept checked items

Options
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Table A-7   Enter Table Title Here

A.2  Command Line Mode
The command line mode allows you to use script or batch files. Table A-8 on page 76 lists the 
different options that are available.

To use the command line options, decide which items you want to use and string them together.

Example: dxcmd -user admin.headquarters -host 10.0.0.1 -password n0vell -start 
test.driverset.headquarters

This example command starts the driver.

Table A-8   Command Line Options

Options Description

1: Get available job definitions Allows you to select an existing job.

Enter the job number:

Do you want to filter the job definitions by 
containment? Enter Yes or No

Enter name of the file for response:

Examples:

NetWare: sys:\files\user.log

Windows: c:\files\user.log

Linux: /files/user.log

2: Operations on specific job object Allows you to perform operations for a specific job.

Option Description

Configuration

-user <user name> Specify the name of a user with administrative 
rights to the drivers you want to test.

-host <name or IP address> Specify the IP address of the server where the 
driver is installed.

-password <user password> Specify the password of the user specified above.

-port <port number> Specify a port number, if the default port is not 
used.

-q <quiet mode> Displays very little information when a command is 
executed.

-v <verbose mode> Displays detailed information when a command is 
executed.
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-s <stdout> Writes the results of the dxcmd command to 
stdout.

-? <show this message> Displays the help menu.

-help <show this message> Displays the help menu.

Actions

-start <driver dn> Starts the driver.

-stop <driver dn> Stops the driver.

-getstate <driver dn> Shows the state of the driver as running or stopped.

-getstartoption <driver dn> Shows the startup option of the driver.

-setstartoption <driver dn> <disabled|manual|auto> 
<resync|noresync>

Sets how the driver starts if the server is rebooted. 
Sets whether the objects are to be resynchronized 
when the driver restarts.

-getcachelimit <driver dn> Lists the cache limit set for the driver.

-setcachelimit <driver dn> <0 or positive integer> Sets the cache limit for the driver.

-migrateapp <driver dn> <filename> Processes an XML document that contains a query 
command. 

Create the XML document that contains a query 
command by using the Novell nds.dtd (http://
www.novell.com/documentation/idm35/
index.html?page=/documentation/idm35/
policy_dtd/data/
dtdndsoverview.html#dtdndsoverview).

-setshimpassword <driver dn> <password> Sets the application password. This is the 
password of the user account you are using to 
authenticate into the connected system with.

-clearshimpassword <driver dn> <password> Clears the application password.

-setremoteloaderpassword <driver dn> 
<password>

Sets the Remote Loader password.

The Remote Loader password is used to control 
access to the Remote Loader instance. 

<clearremoteloaderpassword <driver dn> Clears the Remote Loader password.

Option Description
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-sendcommand <driver dn> <input filename> 
<output filename>

Processes an XDS command document.

Specify the XDS command document as the input 
file.

Examples: 

NetWare: sys:\files\user.xml

Windows: c:\files\user.xml

Linux: /files/user.log

Specify the output filename to see the results.

Examples: 

NetWare: sys:\files\user.log

Windows: c:\files\user.log

Linux: /files/user.log

-sendevent <driver dn> <input filename> Submits a document to the driver’s Subscriber 
channel, bypassing the driver cache. The 
document is processed ahead of anything that 
might be in the cache at the time of the submission. 
It also means that the submission fails if the driver 
is not running.

-queueevent <driver dn> <input filename> Submits a document to the driver’s Subscriber 
channel by queuing the document in the driver 
cache. The document gets processed after 
anything that might be in the cache at the time of 
the submission. The submission won’t fail if the 
driver isn’t running.

-setlogevents <dn> <integer ...> Sets Novell Audit log events on the driver. The 
integer is the option of the item to log. See Table A-
6 on page 74 for the list of the integers to enter.

-clearlogevents <dn> Clears all Novell Audit log events that are set on the 
driver.

-setdriverset <driver set dn> Associates a driver set with the server.

-cleardriverset Clears the driver set association from the server.

-getversion Shows the version of Identity Manager that is 
installed.

-initdriver object <dn> Performs an internal initialization of data on a new 
Driver object. This is only for testing purposes.

-setnamedpassword <driver dn> <name> 
<password> [description]

Sets named passwords on the driver object. You 
specify the name, the password, and the 
description of the named password.

-clearnamedpassword <driver dn> <name> Clears a specified named password.

-startjob <job dn> Starts the specified job.

Option Description
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If a command line is executed successfully, it returns a zero. If the command line returns anything 
other than zero, it is an error. For example 0 means success, and -641 means invalid operation. -641 
is an eDirectory error code. Table A-9 on page 79 contains other values for specific command line 
options.

Table A-9   Command Line Option Values

-abortjob <job dn> Aborts the specified job.

-getjobrunningstate <job dn> Returns the specified job’s running state.

-getjobenabledstate <job dn> Returns the specified job’s enabled state.

-getjobnextruntime <job dn> Returns the specified job’s next run time.

-updatejob <job dn> Updates the specified job.

-clearallnamedpaswords <driver dn> Clears all named passwords set on a specific 
driver.

Command Line Option Values

-getstate 0- stopped

1- starting

2- running

3- shutting down

11- get schema

Anything else that is returned is an error.

-getstartoption 0- disabled

1- manual

2- auto

Anything else that is returned is an error.

-getcachelimit 0- unlimited

Anything else that is returned is an error.

-getjobrunningstate 0- stopped

1- running

Anything else that is returned is an error.

-getjobenabledstate 0- disabled

1- enabled

2- configuration error

Anything else that is returned is an error.

Option Description
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-getjobnextruntime Returns the next scheduled time for the job in 
eDirectory time format (number of seconds since 
00:00:00 Jan 1, 1970 UTC).

Command Line Option Values
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BSchema For Work Order 
Management

As part of the installation of the Novell® Identity Manager WorkOrder driver, eDirectoryTM is 
extended to include two new object classes. These objects allow the driver to connect to the Identity 
Vault correctly, perform work orders, and create a process log with the work order status.

Installing Identity Manager 3.5.1 provides iManager plug-ins to help you create or view these 
objects in the WorkOrder driver. See Chapter 5, “Customizing the Driver,” on page 25.

Section B.1, “DirXML-WorkOrder Object,” on page 81
Section B.2, “DirXML-WorkToDo Object,” on page 83
Section B.3, “Publisher Placement Rule,” on page 84
Section B.4, “Subscriber Placement Rule,” on page 84
Section B.5, “Subscriber Create Rule,” on page 84

B.1  DirXML-WorkOrder Object
The DirXML-WorkOrder object (sometimes referred to as the WorkOrder object in this 
documentation) is used to tell the driver what tasks to perform. It delays the work order until a date 
and time or until another work order is configured. It also repeats work orders at a given interval.

The following table shows the work order attributes you need to specify:

Table B-1   WorkOrder Object Attributes

Work Order Attributes 
(eDirectory Namespace) Description Type

Description Description of the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

Common Name The naming attribute for eDirectory Case ignore string

DirXML-nwoContact Name Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

DirXML-nwoContent This attribute is passed through to the 
WorkToDo object. It is used by policies to 
process the work order.

Case ignore string

DirXML-DueDate The date and time the work order is to be 
processed.

Time
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DirXML-nwoDoItNowFlag If set to True, the Subscriber channel sends 
the work order to the Publisher channel to 
be processed immediately.

Boolean

DirXML-
nwoSendToPublisher

If set to True, the Subscriber channel sends 
the work order to the Publisher channel to 
be written to the WorkOrder container. For 
example, if the work order was created by a 
policy as a result of an event in the Identity 
Vault.

Boolean

DirXML-woType Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

User defined

DirXML-nwoCreationDate Information about the work order. The driver 
does not change this attribute.

Time

DirXML-
nwoDependentWorkOrder

The DN of the dependent work order. The 
work order is not processed until the 
dependent work order has a status of 
Configured. If the attribute is non-existent or 
empty, it is ignored.

Distinguished Name

DirXML-nwoRepeatInterval The amount of time, in hours, before the 
work order is repeated. This value is added 
to the due date after the work order is 
processed.

Case ignore string

DirXML-nwoRepeatCount Repeats the work order as many times as 
the number specifies. Use this attribute in 
association with the DirXML-
nwoRepeatInterval attribute.

Case ignore string

DirXML-nwoStatus Status of the work order.

Pending: The work order will be processed 
on the due date.

Configured: The work order was processed.

Error: An error occurred when processing.

On Hold: The work order is not to be 
processed.

Case ignore string

DirXML-
nwoWorkOrderNumber

Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

DirXML-nwoDeleteOnError If set to True, the work order is deleted if the 
status is Error and the DeleteDueDate has 
expired.

Boolean

DirXML-nwoProcessLog Contains information relating to the 
processing of the work order.

Case ignore string

Work Order Attributes 
(eDirectory Namespace) Description Type
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B.2  DirXML-WorkToDo Object
The DirXML-WorkToDo object is created by the driver to attempt processing. It is used by the 
policy to process the work to be done. All attributes in this object get their values from the work 
order object that initiated this object.

Table B-2   DirXML-WorkToDo Object Attributes

DirXML-nwoDeleteDueDate If the status is Pending or Configured, this 
attribute shows the date and time the work 
order will be deleted.

Time

DirXML-Creator Name Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

DirXML-Other1 Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

DriXML-Other2 Information about the work order. The driver 
does not change this attribute. It is passed 
through to the WorkToDo object when the 
work order is processed.

Case ignore string

WorkToDo Attributes Description Type

DirXML-CreatorName Information about the work order. The 
driver does not change this attribute.

Case ignore string

DirXML-nwoContent The value of the content attribute in the 
work order.

Case ignore string

DirXML-nwoDN DN of the work order. Distinguished Name

Description Information about the work order. The 
driver does not change this attribute.

Case ignore string

DirXML-nwoContactName Information about the work order. The 
driver does not change this attribute.

Case ignore string

DirXML-nwoWorkOrderNumber Information about the work order. The 
driver does not change this attribute.

Case ignore string

DirXML-woType Information about the work order. The 
driver does not change this attribute.

Case ignore string

DirXML-nwoRepeatCount Shows the number of repeats the work 
order has left to perform.

Case ignore string

DirXML-Other1 Information about the work order. The 
driver does not change this attribute.

Case ignore string

Work Order Attributes 
(eDirectory Namespace) Description Type
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B.3  Publisher Placement Rule
The Publisher Placement rule determines where the work orders are placed in the Identity Vault 
after they are processed. These containers might be the same or different, depending on how you 
choose to set up your customized driver. For example, you could have work orders stored in 
containers depending on the returned status, such as configured, error, warning, or on hold.

B.4  Subscriber Placement Rule
The Subscriber Placement rule determines the container that work orders are created in and sent to 
the WorkOrder driver.

B.5  Subscriber Create Rule
To create a work order, the Subscriber Create rule is set up so all new work orders with the 
necessary information can be sent to the Subscriber channel. The following attributes must be 
present to pass the Create rule and go to the Subscriber channel:

Table B-3   Work Order Attributes for the Subscriber Create Rule

DirXML-Other2 Information about the work order. The 
driver does not change this attribute.

Case ignore string

Required Attributes Description Values or Examples

DirXML-nwoSendToPublisher Send the work order directly to 
the Publisher channel.

True or False

DirXML-nwoStatus State of the work order so the 
driver knows what to do with the 
work order.

Pending, Configured, Error, on 
Hold, Warning

DirXML-nwoDoItNowFlag When to perform the work order. True or False

DirXML-nwoContent Content to be processed by the 
driver.

XML code

WorkToDo Attributes Description Type
 Identity Manager 3.5.1 Driver for WorkOrder
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CProperties of the Driver 

There are many different fields and values for the driver. Sometimes the information is displayed 
differently in iManager than in Designer. This section is a reference for all of the fields on the driver 
as displayed in iManager and Designer.

The information is presented from the viewpoint of iManager. If a field is different in Designer, it is 
marked with an  icon.

Section C.1, “Driver Configuration,” on page 85
Section C.2, “Global Configuration Values,” on page 90
Section C.3, “Named Passwords,” on page 90
Section C.4, “Engine Control Values,” on page 91
Section C.5, “Log Level,” on page 93
Section C.6, “Driver Image,” on page 94
Section C.7, “Security Equals,” on page 94
Section C.8, “Filter,” on page 94
Section C.9, “Edit Filter XML,” on page 95
Section C.10, “Misc,” on page 95
Section C.11, “Excluded Users,” on page 96
Section C.12, “Driver Manifest,” on page 96
Section C.13, “Driver Inspector,” on page 97
Section C.14, “Driver Cache Inspector,” on page 97
Section C.15, “Inspector,” on page 98
Section C.16, “Server Variables,” on page 98

C.1  Driver Configuration
In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon. 
3 Click Edit Properties > Driver Configuration.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and click Properties > Driver 
Configuration.

There are different sections under Driver Configuration. In this document, each section is listed in a 
table. The table contains a description of the fields, and the default value or an example of the value 
that should be specified in the field.
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C.1.1  Driver Module
The driver module changes the driver from running locally to running remotely or the reverse.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon. 
3 Click Edit Properties > Driver Configuration > Driver Module.

See Table C-1 for a list of the driver module options.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Configuration.

2 Select the Driver Module tab.
See Table C-1 for a list of the driver module options.

Table C-1   Driver Modules

C.1.2  Driver Object Password
In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Configuration > Driver Object Password > Set Password.

See Table C-2 for more information.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and click Properties > Driver 
Configuration.

Option Description

Java Used to specify the name of the Java class that is 
instantiated for the shim component of the driver. 
This class can be located in the classes directory 
as a class file, or in the lib directory as a .jar 
file. If this option is selected, the driver is running 
locally.

Connect to Remote Loader Used when the driver is connecting remotely to the 
connected system.

Remote Loader Client Configuration for 
Documentation 

Includes the Remote Loader client configuration 
information in the driver documentation that is 
generated by Designer.
 Identity Manager 3.5.1 Driver for WorkOrder



novdocx (en)  17 S
eptem

ber 2009
2 Click Driver Module > Connect to Remote Loader > Driver Object Password > Set Password.
See Table C-2 for more information.

Table C-2   Driver Object Password

C.1.3  Authentication
The authentication section stores the information required to authenticate to the connected system.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Configuration > Authentication.

See Table C-3 for a list of the authentication options.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Configuration.

2 Click Authentication.
See Table C-3 for a list of the authentication options.

Table C-3   Authentication Options

Option Description

Driver Object Password Use this option to set a password for the driver 
object. If you are using the Remote Loader, you 
must enter a password on this page or the remote 
driver does not run. This password is used by the 
Remote Loader to authenticate itself to the remote 
driver shim.

Option Description

Authentication ID

or 

User ID

Specify a user application ID. This ID is used to pass Identity Vault 
subscription information to the application.

Example: Administrator

Authentication Context

or

Connection Information 

Specify the IP address or name of the server the application shim 
should communicate with. 
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C.1.4  Startup Option
The Startup Option allows you to set the driver state when the Identity Manager server is started.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Configuration > Startup Option.

See Table C-4 for a list of the startup options.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Configuration.

2 Click Startup Option.
See Table C-4 for a list of the startup options.

Remote Loader Connection 
Parameters

or

Host name

Port

KMO

Other parameters

Used only if the driver is connecting to the application through the 
Remote Loader. The parameter to enter is 
hostname=xxx.xxx.xxx.xxx port=xxxx 
kmo=certificatename, when the host name is the IP address of the 
application server running the Remote Loader server and the port is the 
port the remote loader is listening on. The default port for the Remote 
Loader is 8090.

The kmo entry is optional. It is only used when there is an SSL 
connection between the Remote Loader and the Metadirectory engine.

Example: hostname=10.0.0.1 port=8090 
kmo=IDMCertificate

Driver Cache Limit (kilobytes)

or

Cache limit (KB)

Specify the maximum event cache file size (in KB). If it is set to zero, the 
file size is unlimited.

Click Unlimited to set the file size to unlimited in Designer.

Application Password

or

Set Password

Specify the password for the user object listed in the Authentication ID 
field.

Remote Loader Password

or

Set Password

Used only if the driver is connecting to the application through the 
Remote Loader. The password is used to control access to the Remote 
Loader instance. It must be the same password specified during the 
configuration of the Remote Loader on the connected system.

Option Description
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Table C-4   Startup Options

C.1.5  Driver Parameters
In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Configuration > Driver Parameters.

See Table C-5 for a list of the driver parameters.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Configuration.

2 Click Driver Parameters.
See Table C-5 for a list of the driver parameters.

Table C-5   Driver Parameters

Option Description

Auto start The driver starts every time the Identity Manager server is started.

Manual The driver does not start when the Identity Manager server is started. The 
driver must be started through Designer or iManager.

Disabled The driver has a cache file that stores all of the events. When the driver is set 
to Disabled, this file is deleted and no new events are stored in the file until the 
driver state is changed to Manual or Auto Start.

Do not automatically 
synchronize the driver

This option only applies if the driver is deployed and was previously disabled. If 
this is not selected, the driver re-synchronizes the next time it is started.

Parameter Name Parameter Descriptions

Driver Name The actual name you want to use for the driver.

WorkOrders Container The name of the container where work orders are 
to be stored.

WorkToDo Container The name of the container to store configured work 
orders.

Polling Method Specifies the polling method by interval or time. 
Interval indicates that the driver will poll at a 
specified time interval. Polling by time indicates a 
specific time of day.

Driver Heartbeat Specifies if the Publisher should emit heartbeat 
documents. The driver emits heartbeat documents 
to indicate to the Identity Manager that the driver is 
still functioning.
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C.2  Global Configuration Values
Global configuration values (GCVs) allow you to specify settings for the Identity Manager features 
such as driver heartbeat, as well as settings that are specific to the function of an individual driver 
configuration. Some GCVs are provided with the drivers, but you can also add your own.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Global Config Values.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Global 
Config Values.

C.3  Named Passwords
Identity Manager allows you to store multiple passwords securely for a particular driver. This 
functionality is referred to as Named Passwords. Each different password is accessed by a key, or 
name.

You can also use the Named Passwords feature to store other pieces of information securely, such as 
a user name. To configured Named Passwords, see Section 8.6, “Storing Driver Passwords Securely 
with Named Passwords,” on page 46.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Named Passwords.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Named 
Passwords.

Install Driver as Remote or Local Select Remote to configure the driver for use with 
the Remote Loader service.

Select Local to configure the driver for local use.

Poll Interval The polling interval (in minutes) at which the 
Publisher channel polls the Identity Manager Vault 
for work orders to be configured.

Poll Time Time of day the Publisher channel wakes up to 
check the Identity Manager Vault for work orders to 
be configured.

Parameter Name Parameter Descriptions
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C.4  Engine Control Values
The engine control values are a means through which certain default behaviors of the Metadirectory 
engine can be changed. The values can only be accessed if a server is associated with the Driver Set 
object.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Engine Control Values.

See Table C-6 for a list of the engine control values.

In Designer:

1 In the Modeler, right-click the driver line.
2 Select Properties > Engine Control Values.
3 Click the tooltip icon to the right of the Engine Control For Server field. If a server is 

associated with the Identity Vault, and if you are authenticated, the engine control values 
display in the large pane.
See Table C-6 for a list of the engine control values.

Table C-6   Engine Control Values

Option Description

Subscriber channel retry 
interval in seconds

The Subscriber channel retry interval controls how frequently the 
Metadirectory engine retries the processing of a cached transaction after 
the application shim's Subscriber object returns a retry status.

Qualified form for DN-syntax 
attribute values

The qualified specification for DN-syntax attribute values controls whether 
values for DN-syntax attribute values are presented in unqualified slash 
form or qualified slash form. A True setting means the values are 
presented in qualified form. 

Qualified form from rename 
events

The qualified form for rename events controls whether the new-name 
portion of rename events coming from the Identity Vault are presented to 
the Subscriber channel with type qualifiers. For example, CN=. A True 
setting means the names are presented in qualified form. 

Maximum eDirectory 
replication wait time in 
seconds

The maximum eDirectoryTM replication wait time controls the maximum 
time that the Metadirectory engine waits for a particular change to 
replicate between the local replica and a remote replica. This only affects 
operations where the Metadirectory engine is required to contact a remote 
eDirectory server in the same tree to perform an operation and might need 
to wait until some change has replicated to or from the remote server 
before the operation can be completed (for example, object moves when 
the Identity Manager server does not hold the master replica of the moved 
object; file system rights operations for Users created from a template.) 
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Use non-compliant 
backwards-compatible 
mode for XSLT

This control sets the XSLT processor used by the Metadirectory engine to 
a backward-compatible mode. The backward-compatible mode causes 
the XSLT processor to use one or more behaviors that are not XPath 1.0 
and XSLT 1.0 standards-compliant. This is done in the interest of 
backward-compatibility with existing DirXML® style sheets that depend on 
the non-standard behaviors. 

For example, the behavior of the XPath “!=” operator when one operand is 
a node set and the other operand is other than a node set is incorrect in 
DirXML releases up to and including Identity Manager 2.0. This behavior 
has been corrected; however, the corrected behavior is disabled by default 
through this control in favor of backward-compatibility with existing DirXML 
style sheets. 

Maximum application 
objects to migrate at once

This control is used to limit the number of application objects that the 
Metadirectory engine requests from an application during a single query 
that is performed as part of a Migrate Objects from Application operation. 

If java.lang.OutOfMemoryError errors are encountered during a Migrate 
from Application operation, this number should be set lower than the 
default. The default is 50.

NOTE: This control does not limit the number of application objects that 
can be migrated; it merely limits the batch size.

Set creatorsName on 
objects created in Identity 
Vault 

This control is used by the Identity Manager engine to determine if the 
creatorsName attribute should be set to the DN of this driver on all objects 
created in the Identity Vault by this driver.

Setting the creatorsName attribute allows for easily identifying objects 
created by this driver, but also carries a performance penalty. If not set, the 
creatorsName attribute defaults to the DN of the NCPTM Server object that 
is hosting the driver.

Write pending associations This control determines whether the Identity Manager engine writes a 
pending association on an object during Subscriber channel processing.

Writing a pending association confers little or no benefit but does incur a 
performance penalty. Nevertheless, the option exists to turn it on for 
backward compatibility.

Use password event values This control determines the source of the value reported for the 
nspmDistributionPassword attribute for Subscriber channel Add and 
Modify events.

Setting the control to False means that the current value of the 
nspmDistributionPassword is obtained and reported as the value of the 
attribute event. This means that only the current password value is 
available. This is the default behavior.

Setting the control to True means that the value recorded with the 
eDirectory event is decrypted and is reported as the value of the attribute 
event. This means that both the old password value (if it exists) and the 
replacement password value at the time of the event are available. This is 
useful for synchronizing passwords to certain applications that require the 
old password to enable setting a new password. 

Option Description
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C.5  Log Level
Every driver set and driver has a log level field where you can define the level of errors that should 
be tracked. The level you indicate here determines which messages are available to the logs. By 
default, the log level is set to track error messages (this also includes fatal messages). Change the log 
level if you want to track additional message types.

Novell® recommends that you use Novell Audit instead of setting the log levels. See “Integrating 
Identity Manager with Novell Audit” in the Identity Manager 3.5.1 Logging and Reporting.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Log Level.

See Table C-7 for a list of the driver log levels.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Log Level.
See Table C-7 for a list of the driver log levels.

Table C-7   Driver Log Levels

Enable password 
synchronization status 
reporting

This control determines whether the Identity Manager engine reports the 
status of Subscriber channel password change events. 

Reporting the status of Subscriber channel password change events 
allows applications such as the Identity Manager User Application to 
monitor the synchronization progress of a password change that should 
be synchronized to the connected application. 

Option Description

Use log settings from the DriverSet If this is selected, the driver logs events as the options are 
set on the Driver Set object. 

Log errors Logs just errors

Log errors and warnings Logs errors and warnings

Log specific events Logs the events that are selected. Click the  icon to see a 
list of the events.

Only update the last log time Updates the last log time.

Logging off Turns logging off for the driver.

Turn off logging to DriverSet, Subscriber 
and Publisher logs

If selected, turns all logging off for this driver on the Driver 
Set object, Subscriber channel, and the Publisher channel.

Option Description
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C.6  Driver Image
Allows you to change the image associated with the driver. You can browse and select a different 
image from the default image.

The image associated with a driver is used by the Identity Manager Overview plug-in when showing 
the graphical representation of your Identity Manager configuration. Although storing an image is 
optional, it makes the overview display more intuitive.

NOTE: The driver image is maintained when a driver configuration is exported.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Image.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > iManager 
Icon.

C.7  Security Equals
Use the Security page to view or change the list of objects that the driver is explicitly security 
equivalent to. This object effectively has all rights of the listed objects. 

If you add or delete an object in the list, the system automatically adds or deletes this object in that 
object's Security Equal to Me property. You don't need to add the [Public] trustee or the parent 
containers of this object to the list, because this object is already implicitly security equivalent to 
them. 

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Security Equals.

Designer does not list the users the driver is security equivalent to.

C.8  Filter
Launches the Filter editor. You can edit the filter from this tab.

Maximum number of entries in the log (50-
500)

Number of entries in the log. The default value is 50.

Option Description
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In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Filter.

The Filter editor is accessed through the outline view in Designer:

1 In an open project, click the Outline tab.
2 Select the driver you want to manage the filter for, then click the plus sign to the left.
3 Double-click the Filter icon to launch the Filter Editor. 

C.9  Edit Filter XML
Allows you to edit the filter directly in XML instead of using the Filter Editor.

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Filter.

You can edit the Filter in XML through the Filter Editor:

1 In an open project, click the Outline tab.
2 Select the driver you want to manage the filter for, then click the plus sign to the left.
3 Double-click the Filter icon to launch the Filter Editor, then click XML Source at the bottom of 

the Filter Editor.

C.10  Misc
Allows you to add a trace level to your driver. With the trace level set, DSTrace displays the Identity 
Manager events as the Metadirectory engine processes the events. The trace level only affects the 
driver it is set for. Use the trace level for troubleshooting issues with the driver when the driver is 
deployed. DSTrace displays the output of the specified trace level. 

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Misc.

See Table C-8 for a list of the driver trace options.

In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Trace.
See Table C-8 for a list of the driver trace options.
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Table C-8   Driver Trace Options

C.11  Excluded Users
Use this page to create a list of users or resources that are not replicated to the application. Novell 
recommends that you add all objects that represent an administrative role to this list (for example, 
the Admin object).

In iManager:

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Excluded Users.

Designer does not list the excluded users.

C.12  Driver Manifest
The driver manifest is like a resumé for the driver. It states what the driver supports, and includes a 
few configuration settings. The driver manifest is created by default when the Driver object is 
imported. A network administrator usually does not need to edit the driver manifest.

In iManager: 

1 Click Identity Manager > Identity Manager Overview, then click Search to search for the 
driver set that is associated with the driver.

2 Browse to the driver, then click the upper right corner of the driver icon.
3 Click Edit Properties > Driver Manifest.

Option Description

Trace level Increases the amount of information displayed in DSTrace. Trace level 1 
shows errors, but not the cause of the errors. If you want to see 
password synchronization information, set the trace level to 5.

Trace file When a value is set in this field, all Java information for the driver is 
written to the file. The value for this field is the path for that file.

As long as the file is specified, Java information is written to this file. If 
you do not need to debug Java, leave this field blank.

Trace file size limit Allows you to set a limit for the Java trace file. If you set the file size to 
Unlimited, the file grows in size until there is no disk space left.

NOTE: The trace file is created in multiple files. Identity Manager 
automatically divides the maximum file size by ten and creates ten 
seperate files. The combined size of these files equals the maximum 
trace file size.

Trace name Driver trace messages are prepended with the value entered in this field.

Use setting from Driver Set This option is only available in Designer. It allows the driver to use the 
same setting that is set on the Driver Set object.
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In Designer:

1 Open a project in the Modeler, then right-click the driver line and select Properties > Driver 
Manifest.

C.13  Driver Inspector
The Driver Inspector page displays information about all of the objects associated with the driver. 

Driver: A link to run the Driver Overview on the driver that is being inspected.
Driver Set: A link to run the Driver Set Overview of the driver set that holds the driver.
Delete: Deletes the associations of the selected objects.
Refresh: Select this option to re-read all of the objects associated with the driver and refresh 
the displayed information.
Actions: Allows you to perform actions on the objects associated with the driver. Click Actions 
to expand the menu, which includes:

Show All Associations: Displays all objects associated with the driver.
Filter for Disabled Associations: Displays all objects associated with the driver that 
have a Disabled state.
Filter for Manual Associations: Displays all objects associated with the driver that have 
a Manual state.
Filter for Migrate Associations: Displays all objects associated with the driver that have 
a Migrate state.
Filter for Pending Associations: Displays all objects associated with the driver that have 
a Pending state.
Filter for Processed Associations: Displays all objects associated with the driver that 
have a Processed state.
Filter for Undefined Associations: Displays all objects associated with the driver that 
have an Undefined state.
Association Summary: Displays the state of all objects associated with the driver.

Object DN: Displays the DN of the associated objects.
State: Displays the association state of the object.
Object ID: Displays the value of the association.

C.14  Driver Cache Inspector
The Driver Cache Inspector page uses a table format to display information about the cache file that 
stores events while the driver is stopped.

Driver: A link to run the Driver Overview on the driver that is associated with this cache file.
Driver Set: A link to run the Driver Set Overview on the driver set that holds the driver.
Driver’s cache on: Lists the server object that contains this instance of the cache file.
Start/Stop Driver icons: Displays the current state of the driver and allows you to start or stop 
the driver.
Edit icon: Allows you to edit the properties of the currently selected Server object.
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Delete: Deletes the selected items from the cache file.
Refresh: Select this option to re-read the cache file and refresh the displayed information.
Show: Limits the number of items to be displayed. The options are:

25 per page
50 per page
100 per page
Other: Allows you to specify a desired number.

Actions: Allows you to perform actions on the entries in the cache file. Click Actions to expand 
the menu, which includes:

Expand All: Expands all of the entries displayed in the cache file.
Collapse All: Collapses all of the entries displayed in the cache file.
Go To: Allows you to access a specified entry in the cache file. Specify the entry number, 
then click OK.
Cache Summary: Summarizes all of the events stored in the cache file.

C.15  Inspector
The Inspector displays information about the connected system without directly accessing the 
system. Designer does not have this option.

C.16  Server Variables
This page lets you enable and disable password synchronization and the associated options for the 
selected driver.

When setting up password synchronization, consider both the settings on this page for an individual 
driver and the Universal Password Configuration options in your password policies.

This page lets you control that password that Identity Manager updates directly, either the Universal 
Password for an Identity Vault, or the Distribution Password used for Password Synchronization by 
Identity Manager.

However, Novell Modular Authentication Service (NMASTM) controls whether the various 
passwords inside the Identity Vault are synchronized with each other. Password Policies are 
enforced by NMAS, and they include settings for synchronizing Universal Password, NDS® 
Password, Distribution Password, and Simple Password. 

To change these settings in iManager:

1 In iManager, select Passwords > Password Policies.
2 Select a password policy, then click Edit.
3 Select Universal Password.

This option is available from a drop-down list or a tab, depending on your version of iManager 
and your browser. 

4 Select Configuration Options, make changes, then click OK.
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NOTE: Enabling or disabling options on this page corresponds to values of True or False for 
certain global configuration values (GCVs) used for password synchronization in the driver 
parameters. Novell recommends that you edit them here in the graphical interface, instead of on 
the GCVs page. This interface helps ensure that you don't set conflicting values for the 
password synchronization GCVs. 

Option Description

Identity Manager accepts 
password (Publisher 
channel)

If this option is enabled, Identity Manager allows passwords to flow 
from the connected system driver into the Identity Vault data store.

Disabling this option means that no <password> elements are 
allowed to flow to Identity Manager. They are stripped out of the XML 
by a password synchronization policy on the Publisher channel.

If this option is enabled, and the option below it for Distribution 
Password is disabled, a <password> value coming from the 
connected system is written directly to the Universal Password in the 
Identity Vault if it is enabled for the user. If the user's password policy 
does not enable Universal Password, the password is written to the 
NDS Password.

Use Distribution Password 
for password 
synchronization

To use this setting, you must have a version of eDirectory that 
supports Universal Password, regardless of whether you have 
enabled Universal Password in your password policies.

If this option is enabled, a password value coming from the 
connected system is written to the Distribution Password. The 
Distribution Password is reversible, which means that it can be 
retrieved from the Identity Vault data store for password 
synchronization. It is used by Identity Manager for bidirectional 
password synchronization with connected systems. For Identity 
Manager to distribute passwords to connected systems, this option 
must be enabled.

NMAS and Password policies control whether the Distribution 
Password is synchronized with other passwords in the Identity Vault. 
By default, the Distribution Password is the same as the Universal 
Password in the Identity Vault. 

If the password in the Identity Vault is to be independent of password 
synchronization, so that Identity Manager is a conduit only for 
synchronizing passwords among connected systems, change this 
default setting. In the Universal Password Configuration Options in a 
Password policy, disable Synchronize Universal Password with 
Distribution Password. This use of Identity Manager password 
synchronization is also referred to as “tunneling.” 

Accept password only if it 
complies with user’s 
Password Policy

To use this setting, users must have a Password policy assigned that 
has Universal Password enabled, and Advanced Password Rules 
enabled and configured.

If this option is chosen, Identity Manager does not write a password 
from this connected system to the Distribution Password in the 
Identity Manager data store or publish it to connected systems unless 
the password complies with the user's Password policy. 

By using the notification option that is also on this page, you can 
inform users when a password is not set because it is not compliant.
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If password does not 
comply, ignore Password 
Policy on the connected 
system by resetting user’s 
password to the Distribution 
Password

This option lets you enforce Password policies on the connected 
system by replacing a password that does not comply. If you select 
this option, and a user's password on the connected system does not 
comply with the user's Password policy, Identity Manager resets the 
password on the connected system by using the Distribution 
Password from the Identity Vault data store. 

Keep in mind that if you do not select this option, user passwords can 
become out-of-sync on connected systems.

By using the notification option that is also on this page, you can 
inform users when a password is not set or reset. Notification is 
especially helpful for this option. If the user changes to a password 
that is allowed by the connected system but rejected by Identity 
Manager because of the Password policy, the user won't know that 
the password has been reset until the user receives a notification or 
tries to log in to the connected system with the old password. 

NOTE:  Consider the connected system's password policies when 
deciding whether to use this option. Some connected systems might 
not allow the reset because they don't allow you to repeat passwords. 

Always accept password; 
ignore Password Policies

If you select this option, Identity Manager does not enforce the user's 
Password policy for this connected system. Identity Manager writes 
the password from this connected system to the Distribution 
Password in the Identity Vault data store, and distributes it to other 
connected systems, even if the password does not comply with the 
user's Password policy.

Application accepts 
passwords (Subscriber 
Channel)

If you select this option, the driver sends passwords from the Identity 
Vault data store to this connected system. This also means that if a 
user changes the password on a different connected system that is 
publishing passwords to the Distribution Password in the Identity 
Vault data store, the password is changed on this connected system.

By default, the Distribution Password is the same as the Universal 
Password in the Identity Vault, so changes to the Universal Password 
made in the Identity Vault are also sent to the connected system. 

If you want the password in the Identity Vault to be independent of 
password synchronization, so that Identity Manager is a conduit only 
for synchronizing passwords among connected systems, you can 
change this default setting. In the Universal Password Configuration 
Options in a password policy, disable Synchronize Universal 
Password with Distribution Password. This use of password 
synchronization is also referred to as “tunneling.”

Notify the user of password 
synchronization failure via-
email

If you select this option, e-mail is sent to the user if a password is not 
synchronized, set, or reset. The e-mail that is sent to the user is 
based on an e-mail template. This template is provided by the 
Password Synchronization application. However, for the template to 
work, you must customize it and specify an e-mail server to send the 
notification messages.

NOTE: To set up e-mail notification, select Passwords > Edit EMail 
Templates.

Option Description
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