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About This Guide

This guide provides example solutions that you can implement when using the Novell® Compliance
Management Platform extension for SAP environments. The guide is organized as follows:

¢ Chapter 1, “Overview,” on page 9

¢ Chapter 2, “Managing User Accounts,” on page 13
¢ Chapter 3, “Managing Roles,” on page 21

¢ Chapter 4, “Managing Passwords,” on page 25

*

Chapter 5, “Simplifying User Access,” on page 29

*

Chapter 6, “Auditing Real-Time Events,” on page 41

Audience

This guide is intended for partners, consultants, and customers who are extremely familiar with SAP
and the Novell products in the Novell Compliance Management Platform.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comments feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentation/feedback.html and enter your
comments there.

Documentation Updates

For the most recent version of the Novell Compliance Manage Platform Extension for SAP
Environments Solutions Guide, visit the Novell Compliance Management Platform Extension for
SAP Environments Documentation Web site (http://www.novell.com/documentation/ncmp_sap10).

Additional Documentation

For documentation on the Novell Compliance Management Platform, see the Novell Compliance
Management Platform Documentation Web site (http://www.novell.com/documentation/ncmp10/
index.html).

For documentation on the Role Mapping Administrator, see the Novell Compliance Management
Platform Documentation Web site (http://www.novell.com/documentation/ncmp_sap10).

For documentation on the Identity Manager Roles Based Provisioning Module, see the Identity
Manager Roles Based Provisioning Module 3.6.1 Documentation Web site (http://www.novell.com/
documentation/idmrbpm361/index.html).

For documentation on the SAP drivers, see the Identity Manager 3.6.1 Drivers Documentation Web
site (http://www.novell.com/documentation/idm36drivers/index.html).

For documentation on Access Manager, see the Access Manager 3.1 Documentation Web site (http:/
/www.novell.com/documentation/novellaccessmanager31/index.html).
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For documentation on Sentinel™, see the Sentinel 6.1 Documentation Web site (http://
www.novell.com/documentation/sentinel61/index.html).

For documentation on the SAP Connector, SAP Collector, and the SAP Solution Pack, see the
Sentinel 6.1 download Web site (http://support.novell.com/products/sentinel/secure/
sentinel61.html).

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and
items in a cross-reference path.

A trademark symbol (®, ™ etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for
other platforms, the pathname is presented with a backslash. Users of platforms that require a
forward slash, such as Linux* or UNIX*, should use forward slashes as required by your software.

Novell Compliance Management Platform Extension for SAP Environments 1.0 SP1 Solutions Guide
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Overview

The extension for SAP environments contains business solutions that simplify the management of
your SAP systems. These business solutions help mitigate risk, simplify business governance, and
ensure compliance throughout the enterprise.

¢ Section 1.1, “Terminology,” on page 9

¢ Section 1.2, “Business Solutions for the Extension for SAP Environments,” on page 10

1.1 Terminology

This section gives you essential information about terminology used with SAP. If you need further
help with SAP terminology, see the Glossary for the SAP Library (http://help.sap.com/saphelp 46¢/
helpdata/En/35/2¢d77bd7705394¢10000009b387¢12/frameset.htm).

ABAP: Advanced Business Application Programming. A programming language designed for
creating large-scale business applications.

ALE: Application Link Enabling. Technology that enables communication between SAP and
external systems such as the Identity Vault.

BAPI: Business Application Programming Interface. SAP business APIs for the SAP business
object types.

CCMS: Computer Center Management System. A set of tools to monitor, control, and configure an
SAP system.

client: In an SAP system, a self-contained unit with its own set of users and data.
CUA: Central User Administration. The SAP tool used to centrally maintain user master records.

ERP: Enterprise resource planning. A software system for planning and automating enterprise-wide
business processes.

GRC: Governance, risk, and compliance. Software or business processes that facilitate conformity
to legal requirements.

IDocs: Intermediate document. A data exchange format used between SAP systems and between
SAP systems and external applications.

JCo: SAP Java* Connector. A toolkit that allows Java applications to communicate with any SAP
system.

SPML: Service Provisioning Markup Language. An XML-based framework for managing the
provisioning and allocation of identity information and system resources within and between
organizations.

SSCR: SAP Software Change Registration. A procedure for registering manual changes to SAP
source code and dictionary object.s

UME: User Management Engine. Provides central user administration for Java applications.

Overview
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XAL: External interface for alert management. Enables external system management software to
read and set properties in order to integrate with SAP administration tools.

1.2 Business Solutions for the Extension for
SAP Environments

You see some common business problems when managing your SAP systems.

¢ Section 1.2.1, “Managing Accounts,” on page 10

¢ Section 1.2.2, “Managing Roles,” on page 10

*

Section 1.2.3, “Managing Passwords,” on page 10

*

Section 1.2.4, “Managing User Access,” on page 11

*

Section 1.2.5, “Auditing Real-Time Events,” on page 11

1.2.1 Managing Accounts

Managing accounts in the different SAP systems is a very complex task. Trying to manually
maintain account information in the SAP systems and then trying to synchronize that information
with the other systems in your environment is very costly, time-consuming, and error-prone.

The extension for SAP environments contains provisioning solutions for the different SAP systems
in your environment. The solutions allow you to provision users from the SAP GRC Access Control,
the SAP Portal, and from traditional SAP application servers.

The provisioning solutions use the new and updated Identity Manager drivers to provision the SAP
accounts. Identity Manager then provisions the SAP account information into any other system that
you have connected through Identity Manager. These provisioning processes are automated to save
time and money, and to reduce errors. For instructions on how to configure the provisioning
solutions, see Chapter 2, “Managing User Accounts,” on page 13.

1.2.2 Managing Roles

Typically, business managers do not have direct access to assign SAP roles or profiles to users.
Instead, they must work through the SAP administrator to facilitate these assignments. The
extension for SAP environments provides a solution that enables business managers to easily make
role assignments. For instructions on how to configure the solutions for managing roles, see
Chapter 3, “Managing Roles,” on page 21.

1.2.3 Managing Passwords

One of the most common and expensive business problems is how to manage user passwords. SAP
adds many complexities to password management because each user account in each system and
child system has a password associated with it. The extension for SAP environments contains two
solutions for managing passwords:

¢ The SAP Identity Manager driver automatically assigns passwords to users when they are
provisioned in to the SAP systems and child systems.

¢ You can allow users to manage their own passwords.
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For instructions on how to manage user passwords, see Chapter 4, “Managing Passwords,” on
page 25.

1.2.4 Managing User Access

After users are provisioned, they need access to the resources to do their jobs. A common frustration
for users is being required to authenticate each time they access a resource. The solution provided
with the extension for SAP environments uses Access Manager to allow users to log into Windows*
workstation and then have access to the SAP Portal, the Roles Based Provisioning Module, and the
Role Mapping Administrator. When users launch a Web browser that is pointing at one of these
resources, they are automatically authenticated to that resource through Access Manager. For
instructions on how to configure the single sign-on solution, see Chapter 5, “Simplifying User
Access,” on page 29.

1.2.5 Auditing Real-Time Events

The final part of any solution is to provide auditing and reporting capabilities for the solution. The
extension for SAP environments provides real-time auditing and reporting capabilities for your SAP
systems through Sentinel™. This allows you to provide automated reports that can prove compliance
with the business policies implemented when users are provisioned and granted access to resources.
For instructions on how to configure the auditing solution, see Chapter 6, “Auditing Real-Time
Events,” on page 41.

Overview
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Managing User Accounts

The extension for SAP environments provides multiple solutions that allow you to automate the
management of user accounts in your SAP environment. These solutions automate the provisioning
of user objects throughout SAP clients, CUA, NetWeaver*, ERP systems, and GRC systems. These
provisioning solutions use one or more of the Identity Manager drivers to automate the managing of
users accounts.

In an SAP landscape, a user has multiple accounts in multiple systems that are not connected. For
example, when a new finance clerk is hired in a company, he or she needs access to the SAP finance
system and to the SAP Portal. Without the provisioning solutions, an SAP administrator creates the
user in the SAP HR system, in the SAP client that is running the SAP Finance application, and in the
SAP Portal.

The manual process takes considerable time, because it is likely that a different people create each
user account. The manual process is error-prone. It can also be expensive, because new employees
can’t work and be productive until they have access to the systems they need to do the job.

This solution explains how to take advantage of features in Identity Manager to simplify
provisioning of user accounts. This solution uses dynamic groups and entitlements, and is based on
the Roles Based Provisioning Module as the entitlement agent, as displayed in Figure 2-1.

The solution explains how to set up your environment so that a new user who is created as an active
employee automatically receives the required accounts and resources.

Managing User Accounts
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Figure 2-1 Provisioning Solution with Multiple SAP Systems
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Complete the following sections to implement the managing users solutions.

¢ Section 2.1, “Prerequisites,” on page 14

¢ Section 2.2, “Configuring the User Application Roles Based Provisioning Module to Consume
Dynamic Groups,” on page 15

¢ Section 2.3, “Creating Dynamic Groups,” on page 15
+ Section 2.4, “Creating Roles Based Provisioning Module Roles,” on page 17

+ Section 2.5, “Assigning the Roles Based Provisioning Module Roles to the Dynamic Group,”
on page 17

¢ Section 2.6, “Installing and Configuring the Identity Manager Drivers for SAP,” on page 18
¢ Section 2.7, “Mapping the SAP Authorizations to the Roles,” on page 19

2.1 Prerequisites

This solution assumes the following:

O Identity Manager 3.6 is installed. For more information, see “* Installing Identity Manager” in
the Identity Manager 3.6.1 Installation Guide.

Novell Compliance Management Platform Extension for SAP Environments 1.0 SP1 Solutions Guide



O The User Application Roles Based Provisioning Module 3.6.1 is installed and configured with
the User Application driver and the Roles Service driver. For more information, see the Identity
Manager Roles Based Provisioning Module 3.6.1 User Application: Installation Guide (http://
www.novell.com/documentation/idmrbpm361/install/data/bookinfo.html)

O Your Identity Manager project is contained in Designer. For more information, see “Importing
into Designer” in the Designer 3.0.1 for Identity Manager 3.6 Administration Guide.

2.2 Configuring the User Application Roles
Based Provisioning Module to Consume
Dynamic Groups

The User Application Roles Based Provisioning Module must be configured to consume dynamic
groups.

1 Run the ConfigUpdate utility in the User Application installation directory by executing the
following command:

Linux: configupdate.sh

Windows: configupdate.bat

Click Show Advanced Options.

Select the Use Dynamic Groups option in the Metadirectory User Groups section.

Click OK to save this selection.

a b ODN

Restart the User Application to apply the changes.

2.3 Creating Dynamic Groups

This solution uses dynamic groups to define the criteria required to receive a Roles Based
Provisioning Module role. Dynamic groups allow you to specify the criteria used to evaluate
membership in the group. For more information about dynamic groups, see the AppNote How to
Manage and Use Dynamic Groups (http://support.novell.com/techcenter/articles/
ana20020405.html)

To create a dynamic group for all active employees:

Log in to iManager as an administrative user.
Click Directory Administration > Create Object under Roles and Tasks.

Select Dynamic Group from the available object classes list, then click OK.

H WO DN =

Use the following information to create the dynamic group:

GroupName: Specify a unique name for the group. For example, Active Employees.
Context: Browse to and select the container where you want to create the dynamic group.
Dynamic Group: Select the option to create the dynamic group.

Nested Group: For this solution, do not select this option.

Set Owner: Select this option to set the logged-in user as the owner.

5 Click OK, then click Modify.

6 In the Description field, specify a description for this role.

Managing User Accounts
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IMPORTANT: The description is the value displayed for the group in the User Application. If
there is no description value, the group is not displayed in the User Application.

7 Click the Dynamic tab.
Use the following information to define the criteria for membership in this dynamic group:

Query: If you have more than one requirement for the dynamic group, click the plus icon to
add another query.

Start search at(Base DN): Specify the DN of the starting location to perform the search for
members of the group.

Search Scope: Specify a scope for the search. If you don’t specify a scope, the base scope is
assumed. The options are:

¢ Search Base DN searches only the base object.

¢ Search One Level searches the direct subordinates of the base object. The base object is
not searched.

¢ Search Sub Containers searches the base object and all objects in the subtree below it.

Search Multiple Servers: Select whether the search should include multiple servers or only
the server containing the dynamic group object. If you select yes, the server communicates with
other servers while searching for dynamic members. If you select o, a local search is
performed for dynamic members.

NOTE: If you select to search multiple servers for dynamic members, it can take a long time
for the results to be returned.

Search Filter Read Write Replica: Select whether to search for dynamic members in the
Filtered Read Write replica. This option is enabled only if you have selected no for Search
Multiple Servers.

Search Filter: Define the criteria for membership in the dynamic group.You can type the text
if you know the proper syntax, or you can launch the Advance Selection Criterion Wizard to
define the criteria.

For an object to become of a member of the dynamic group, this solution requires that it must
have an objectClass that is equal to inetOrgPerson and that the attribute of employeeStatus is
equal to Active.

Object type(s): [All] oK |
Aux class(es): | FY3 Help

=| Logic Group 1

= Iobjectclass ;l I is equal ;l IinetOrgPerson Ial'lcl j
— IemployeeStatus ;I I is equal ;I IActi\ne ap

9 Click OK to save the changes.

10 Create a second dynamic group where the objectClass is equal to inetOrgPerson and the Title
attribute is equal to Finance Clerk.
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2.4 Creating Roles Based Provisioning Module
Roles

The Roles Based Provisioning Module role is used to assign privileges in the connected system. In
our solution is it used to assign access to the SAP Portal as well as restrict access to finance
resources. When a user requests access to the SAP Portal, they are granted access. When a user
requests access to a finance resource, their manager has to approve the resource.

To create the SAP Self Service role:

1 Launch Designer, and verify that your project is current.

To verify that your project is current, see “Using the Compare Feature When Importing” in the
Designer 3.0.1 for Identity Manager 3.6 Administration Guide.

2 In the Designer toolbar, click Window > Show View > Provisioning to display the Provisioning
view.

By default, the Provisioning view is displayed in the lower left corner of Designer.
3 In the Provisioning view, click User Application > Role Catalog > Roles > Business Role.
4 Right-click the Business Role, then click New.
5 Use the following information to create the role:

Identifier: Specify a unique name for the role. In this example, the role name is SAP Self
Service. The Display Name and Description are populated with this name.

Category: Select the Default category.

Trustees: Add the container that holds your user objects as a trustee of this role. When a user
logs in to the Roles Based Provisioning Module, this role is displayed for them to access.

6 Click Finish to create the role.
7 Click the Advanced Options tab at the bottom of the new role.
8 Select None under the Approval Details section.

When a user logs in to the Roles Based Provisioning Module and requests the SAP Portal
resource, it is automatically granted to them.

9 Click the Save icon in the toolbar to save the change.
10 Right-click the User Application driver in the Provisioning view, then click Live > Deploy to
deploy the new role to the Identity Vault.

To create a finance role that requires a manager approval, see Section 3.3, “Implementing Approval
Policies on Roles that Grant SAP Authorizations,” on page 23. Create the role with the name of SAP
Finance instead of SAP Restricted Resource.

2.5 Assigning the Roles Based Provisioning
Module Roles to the Dynamic Group

The Roles Service driver evaluates the dynamic group membership for Roles Based Provisioning
Module updates to the associated role. When a user meets the dynamic group criteria for
membership, the users inherit role assignments and are assigned the Roles Based Provisioning
Module role.

Managing User Accounts
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To assign the role to the dynamic group:

Log in to the User Application as an administrative user.

Click Roles > Role Assignments > Role Assignments.

Click the Role P icon, then click the Search © icon.

Specify the role name of SAP Self Service, then click the Search “4, icon.
Click the name of the role.

Click New Assignment.

N OO g b~ WODN =

Use the following information to make the assignment:

Initial Request Description: Specify a description that is displayed when the initial request
occurs.

Type of Assignment: Select Group for the type of assignment.

Select Groups: Browse to and select the dynamic group created in Section 2.3, “Creating
Dynamic Groups,” on page 15.

Effective Date: Specify a date for this assignment to occur. If not date is specified, the
effective date is immediately.

8 Click Submit to make the assignment.

9 Repeat the process for the finance group and SAP Finance role create in Section 2.4, “Creating
Roles Based Provisioning Module Roles,” on page 17.

2.6 Installing and Configuring the Identity
Manager Drivers for SAP

You can install and configure any of the Identity Manager drivers for SAP to work with this solution
if the driver uses entitlements and can work with the Role Mapping Administrator.

O Install the extension for SAP environments Identity Manager drivers. For installation
instructions, see “Installing the Identity Manager Drivers for the extension for SAP
environments” in the Novell Compliance Management Platform Extension for SAP
Environments 1.0 SP 1 Overview.

O Create new driver object. For instructions, see:

¢ “Creating a New Driver” in the Identity Manager 3.6.1 Driver for SAP GRC Access
Control Implementation Guide.

¢ “Creating a New Driver” in the Identity Manager 3.6.1 Driver for SAP Portal
Implementation Guide.

+ “Creating a New Driver” in the Identity Manager 3.6.1 Driver for SAP User Managment
(JCo 3) Implementation Guide.

O Verify that the Use User Account Entitlement GCV is set to True in the properties of each driver
used in this solution.

O Very that the Enable role mapping GCV is set to Yes in the properties of each driver used in this
solution.
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2.7 Mapping the SAP Authorizations to the Roles

With the roles created for active employees and the finance clerk, you can use the Role Mapping
Administrator to map the corresponding roles from SAP to these role. For instructions, see
Chapter 3, “Managing Roles,” on page 21.

With the mapping in place when a user object is created and the employStatus attribute equals
Active, the user is provisioned to the SAP Portal environment the SAP client that contains the
finance application. When users log into the User Application, they can request access to the SAP
Portal and it is automatically granted. They can also request access to the finance group. The
manager receives notification of this request and either grants or denies the request.

Managing User Accounts 19
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Managing Roles

Typically, business managers do not have direct access to assign SAP roles or profiles to users.
Instead, they must work through the SAP administrator to facilitate these assignments.

The extension for SAP environments provides a solution that enables business managers to easily
make the role assignments. The solution utilizes the Roles Based Provisioning Module, Identity
Manager drivers, and the Roles Mapping Administrator.

The Roles Mapping Administrator lets you map SAP roles, composite roles, and profiles
(collectively referred to as SAP authorizations) to Identity Manager roles. When a user is assigned a
role through the Identity Manager User Application, he or she receives all SAP authorizations
mapped to that role. Or, when a role is removed from a user, all SAP authorizations that were
granted through that role are removed.

The following are solutions that can be implemented in your environment to simplify business
processes.

¢ Section 3.1, “Prerequisites,” on page 21
¢ Section 3.2, “Implementing User Self Service for SAP Authorization Requests,” on page 22

¢ Section 3.3, “Implementing Approval Policies on Roles that Grant SAP Authorizations,” on
page 23

3.1 Prerequisites

The steps for these solutions assume the following:

O Identity Manager 3.6 is installed with the User Application Roles Based Provisioning Module
3.6.1. This includes the User Application driver and Roles Service driver. For more
information, see Identity Manager Roles Based Provisioning Module 3.6.1 User Application:
Installation Guide (http://www.novell.com/documentation/idmrbpm361/install/data/
bookinfo.html).

O The User Application Roles Based Provisioning system is configured with the roles to which
the SAP authorizations will be mapped. If the roles do not exist, they can be created in the User
Application or in the Role Mapping Administrator after it is installed. For more information,
see “Configuring Roles” (http://www.novell.com/documentation/idmrbpm361/dgpro/data/
roleschapter.html) in the User Application: Design Guide (http://www.novell.com/
documentation/idmrbpm361/dgpro/dgpro/data/bookinfo.html).

O One or more of the following Identity Manager drivers for SAP are installed and connected to
the SAP systems.

+ SAP GRC Access Control driver. For more information, see the I/dentity Manager 3.6.1
Driver for SAP GRC Access Control Implementation Guide.

+ SAP Portal driver. For more information, see the /dentity Manager 3.6.1 Driver for SAP
Portal Implementation Guide.

¢ SAP User Management driver. For more information, see the I/dentity Manager 3.6.1
Driver for SAP User Managment (JCo 3) Implementation Guide.
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O The Role Mapping Administrator is installed and configured. See the /dentity Manager Role
Mapping Administrator 1.0 Installation and Configuration Guide.

O Your Identity Manager project is contained in Designer. For more information, see “Importing
into Designer” in the Designer 3.0.1 for Identity Manager 3.6 Administration Guide.

3.2 Implementing User Self Service for SAP
Authorization Requests

To reduce help desk calls and the amount of time required to grant resources, you can use the Role
Mapping Administrator and the Roles Based Provisioning Module to allow users to request access
to certain SAP authorizations.

After the following procedures are completed, users can log into the Roles Based Provisioning
Module and request access to the SAP Portal, then automatically receive access after the request is
issued.

To create a SAP Self Service role:

1 Launch Designer, and verify that your project is current.

To verify that your project is current, see “Using the Compare Feature When Importing” in the
Designer 3.0.1 for Identity Manager 3.6 Administration Guide.

2 1In the Designer toolbar, click Window > Show View > Provisioning to display the Provisioning
view.

By default, the Provisioning view is displayed in the lower left corner of Designer.
3 In the Provisioning view, click User Application > Role Catalog > Roles > Business Role.
4 Right-click the Business Role, then click New.
5 Use the following information to create the role:

Identifier: Specify a unique name for the role. In this example the role name is SAP Self
Service. The Display Name and Description are populated with this name.

Category: Select the Default category.

Trustees: Add the container that holds your user objects as a trustee of this role. When a user
logs in to the Roles Based Provisioning Module, this role is displayed for them to access.

6 Click Finish to create the role.
7 Click the Advanced Options tab at the bottom of the new role.
8 Select None under the Approval Details section.

When a user logs in to the Roles Based Provisioning Module and requests the SAP Portal
resource, it is automatically granted to them.

9 Click the Save icon in the toolbar to save the change.

10 Right-click the User Application driver in the Provisioning view, then click Live > Deploy to
deploy the new role to the Identity Vault.

To map the Self Service role to the SAP Portal Access:

1 Log in to the Role Mapping Administrator.
2 Select the SAP Self Service role.
3 Access the SAP Portal System in the Authorizations panel.
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4 Sclect the roles in the SAP Portal that grant a user access to the resource and drag and drop
them into the Mapping panel.

5 Click Apply to save and deploy the changes.
The Self Service role is mapped to the SAP Portal authorization, which is now available for users to

request through the Roles Based Provisioning Module. When the users request this access, they are
automatically granted access to the SAP Portal because of the role mapping.

3.3 Implementing Approval Policies on Roles
that Grant SAP Authorizations

To make sure the correct people are granted access to powerful SAP authorizations, you can define a
role that requires a manager’s approval for all access requests to those authorizations.

To create a restricted SAP Access role:

1 Launch Designer, and verify that your project is current.

To verify that your project is current, see “Using the Compare Feature When Importing” in the
Designer 3.0.1 for Identity Manager 3.6 Administration Guide.

2 In the Designer toolbar, click Window > Show View > Provisioning to display the Provisioning
view.

3 In the Provisioning view, click User Application > Role Catalog > Roles > Business Role.
4 Right-click the Business Role, then click New.
5 Use the following information to create the role:

Identifier: Specify a unique name for the role. In this example, it is Restrict SAP Access. The
Display Name and Description are populated with this name.

Category: Select the Default category.

Trustees: Add the container that holds your user objects as a trustee of this role. When a user
logs in to the Roles Based Provisioning Module, this role is displayed for them to access.

6 Click Finish to create the role.
7 Click the Advanced Options tab at the bottom of the new role.

8 Select Standard to determine the type of approval process for granting access to the SAP
resource.

9 Select the approval type of Serial.

When you select Serial, the request is sent to the approvers and the approvers must approve the
request before it is granted. In this use case the approver is the users’ manager.

10 Click the plus icon to add the approvers for the request. You can have one or more approvers.
To map the Restricted SAP Access role to the SAP resource:

Log in to the Role Mapping Administrator.
Select the Restricted SAP Access role.

Access the SAP system that you want to restrict access to in the Authorizations panel.

H ODN =

Select the roles in the SAP system that grant a user access to the resource and drag and drop
them into the Mapping panel.

5 Click Apply to save and deploy the changes.
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The Restricted SAP access role is mapped to the SAP role, which is now available for the users to
request through the Roles Based Provisioning Module. When the users request this resource, the
manager is notified. The manager either approves or denies the request.
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