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About This Guide

This guide is designed to help you understand and evaluate Novell Filr by:

 Downloading two pre-configured virtual machines (VMs).
 Performing basic administration and end-user tasks involving those VMs. 

It contains the following sections:

 Chapter 1, “Overview of the Three Filr Hands-on Paths,” on page 7
 Chapter 2, “System Requirements,” on page 9
 Chapter 3, “Filr Hands-on Administration Exercises,” on page 11
 Chapter 4, “Filr Hands-on End User Exercises,” on page 23
 Appendix A, “Creating Your Own Virtual Machines for the Filr Hands-on Exercises,” on page 37
 Appendix B, “Documentation Updates,” on page 69

Audience

This guide is intended for network administrators and others who want a direct experience with 
Novell Filr as part of their product evaluation.

Feedback

We want to hear your comments and suggestions about this guide and the other documentation 
included with Novell Filr. To submit your comments, use the User Comments feature at the bottom of 
each page of the online documentation.

Documentation Updates

 For the most recent version of this guide, see the Novell Filr Documentation Web site  (http://
www.novell.com/documentation/novell-filr1/filr1_hands-on/data/front.html).

Additional Documentation

 For other Novell Filr documentation, see the Novell Filr Documentation Web site  (http://
www.novell.com/documentation/novell-filr1/).
About This Guide 5
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1 1Overview of the Three Filr Hands-on 
Paths

Setting up an evaluation environment is always a big challenge for product evaluations.

Therefore, we have removed the “setting up” challenge by providing downloadable, pre-configured, 
ready-to-use VMs that you can download and run, as illustrated in Figure 1-1.

Figure 1-1   Evaluation and Setup Paths Covered in This Guide

Start with 
Section A - “Creating 

Your Own Virtual Machines”

Finish with 
Section 4 - “Filr Hands-on

End user Exercises”

Continue with 
Section 3 - “Filr Hands-on
Administration Exercises”

OESOES
Sychronize eDirectory Users

Set Up Personal Storage

Set Up Net Folders

Set Up Sharing

OESOES

Path 3:  Customize the tasks in this guide with your own settings.

Filr

OESOES

OES Server

oes11. ... .DVD.iso

filr.x86.version.ovf.zip

Start with 
Section 4 - “Filr Hands-on

End User Exercises”

Sychronize eDirectory Users

Set Up Personal Storage

Set Up Net Folders

Set Up Sharing

OESOES

Path 2:  Explore only the Filr end user experience.

OESOES

H . . . U.zip

OESOES

Filr

OESOES

OES Server

Continue with 
Section 4 - “Filr Hands-on 

End user Exercises”

Start with 
Section 3 - “Filr Hands-on 
Administration Exercises”

OESOES

Path 1:  Explore Filr from network administration and end user points of view.

OESOES
Sychronize eDirectory Users

Set Up Personal Storage

Set Up Net Folders

Set Up Sharing

H . . . A-U.zip

OESOES

Filr

OESOES

OES Server
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About the Three Filr Evaluation Paths

As illustrated in Figure 1-1, you can approach your Filr product evaluation in three different ways:

 Download the administrative-ready VMs, then explore both the administrative and the end user 
exercises.

 Download the end user-ready VMs, then explore only the end user exercises.
 Download and install Open Enterprise Server and Filr evaluation software, then explore the 

administrative and end user exercises.

About the Downloable Sets of Pre-Configured Virtual Machines

There are two sets of pre-configured VMs associated with this guide: 

 One set that is ready to be used with Chapter 3, “Filr Hands-on Administration Exercises,” on 
page 11, and then with Chapter 4, “Filr Hands-on End User Exercises,” on page 23.

 One that begins where Chapter 3 ends and is ready for Chapter 4, “Filr Hands-on End User 
Exercises,” on page 23. 

Both sets contain fully functional evaluation installations of Novell Filr and Novell’s premier file 
server—Open Enterprise Server 11 SP1 (OES 11 SP1). 

No previous OES experience is required for using the exercises in this guide.

Migrating or Updating the Evaluation VMs to a Production Deployment Is Not 
Supported

To facilitate Filr evaluations, Novell provides the ability to install Small Installation Filr appliance, in 
which the Filr appliance, database server, and search engine all run in a single VM. Both of the hands-
on evaluation file sets include one Small Installation Filr appliance. 

Small Installation Filr appliances are not suitable for production environments from either scalability 
or performance perspectives. Production environments require at least three separate single-
purposes appliances that are running: the Filr appliance, a MySQL database server, and the Filr-
supplied Lucene search appliance. 

There is no migration or update path for converting a small installation to three separate appliances. 
Therefore, there is no path for moving the hands-on evaluation VMs to a production environment. 

Work through the Guide Sequentially

As illustrated in Figure 1-1 on page 7 and explained above, there are three possible paths through this 
guide. After picking a starting point, be sure to access and complete the remaining instructions in the 
order given. Each section and sub-section depends on completion of the tasks that precede it.

If You Want to Use This Guide as a Reference

If you want to install additional virtual machines, create a different eDirectory tree structure than the 
one specified in this guide, or diverge from the instructions presented, you can still use these 
instructions as a basic outline for getting acquainted with Novell Filr. For more information, see 
Appendix A, “Creating Your Own Virtual Machines for the Filr Hands-on Exercises,” on page 37.
8 Novell Filr: Hands-on Guide for OES



2 2System Requirements

For the tasks and exercises associated with this guide, you need the following:

 A wireless router (home network varieties are fine)

 VMware Workstation 8 or later

IMPORTANT: The use of VMware Workstation 8 is intended for Novell Filr evaluation 
purposes only. It is not supported for Novell Filr running in a production environment.

 A 64-bit host workstation that meets the following conditions:

 Has the VMware platform of your choice (above) installed and ready to use
 Has the following resources available for running VMware:

 Has a version of LibreOffice installed.

 Two Web-based email addresses for receiving invitations and notifications. 

 At least one mobile device (iOS 5 or later or Android 2.3 or later) that is capable of connecting to 
the wireless router.

 Software for the evaluation path you are following in this guide. 

For Path 1 and Path 2, download the applicable Hands-on VMs from the Web:
1. If you don’t already have a Novell account, register for one on the Novell website (https://

secure-www.novell.com/selfreg/jsp/createAccount.jsp?).
2. Access the Novell Downloads Web page (http://download.novell.com).
3. Do a keyword search for Novell Filr.
4. In the Results section, click Novell Filr Evaluation.
5. Click the proceed to download button (upper-right corner of the first table).
6. If you are prompted to log in, type your Novell Account > username and password, then click 

login.
7. Accept the Export Agreement (required for first downloads only), and answer the survey 

questions about your download (optional).
8. Print the download page. You need the listed MD5 verification numbers for verifying your 

download.

Component Minimum Recommended

RAM 6 GB 8 GB

Hard drive free space 50 GB

Network card Ethernet 100 Mbps

Mozilla Firefox latest version
System Requirements 9
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9. For Path 1, download the Hands-on_Filr_1_A-U.zip file to your VMware host 
workstation. 
For Path 2, download the Hands-on_Filr_1_U.zip file to your VMware host workstation.

IMPORTANT: These files are approximately 3.7 GB. 
We strongly recommend that you use a download manager, such as those recommended in 
the how to use a download manager link on the download page.

10. Verify the integrity of each downloaded file by running an MD5-based checksum utility on 
it and comparing the values against the list that you printed in Step 8.
For example, on a Linux system you can enter the following command:
md5sum Hands-on_Filr_1_path-type.zip

For a Windows system, you need to obtain a Windows-compatible MD5-based checksum 
utility from the Web and follow its usage instructions.

11. Continue with Filr Hands-on Administration Exercises.
For Path 3, you must download the software listed in Section A.2.1, “Obtaining Installation 
Media,” on page 41) to your VMware host workstation.
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3 3Filr Hands-on Administration Exercises

This section guides you through the following tasks:

 Section 3.1, “Overview of Filr Administration Exercises,” on page 11
 Section 3.2, “Starting the Virtual Machines,” on page 12
 Section 3.3, “Connecting to the Wireless Router,” on page 12
 Section 3.4, “Before You Begin the Administrative Exercises,” on page 14
 Section 3.5, “Synchronizing LDAP Users,” on page 14
 Section 3.6, “Setting Up Users’ My Files Folders,” on page 16
 Section 3.7, “Setting Up Net Folders,” on page 17
 Section 3.8, “Enabling Sharing,” on page 20
 Section 3.9, “Allowing the Desktop Application to Be Deployed,” on page 20
 Section 3.10, “(Optional) Setting Up Email Communication with the Filr VM,” on page 20

3.1 Overview of Filr Administration Exercises
The Filr administration exercises can be summarized as follows:

1. Downloading and Starting the Administration-Ready Virtual Machines

OESOES

Download

Filr Documentation Site

Filr
Virtual Appliance

OES Server
Virtual Machine

VMware Workstation with
Wireless Router

Unzip

OESOES

Hands-on_Filr_1_A-U.zip

Open and Power On
Filr Hands-on Administration Exercises 11



2. Configuring Filr and Connecting It to the OES Server

Make sure you have reviewed the system and software requirements that are outlined in Chapter 2, 
“System Requirements,” on page 9 before proceeding.

3.2 Starting the Virtual Machines

IMPORTANT: The instructions in this section only apply to Path 1. If you are following Path 3, skip 
this section and continue with Section 3.3, “Connecting to the Wireless Router,” on page 12.

Start the downloaded, pre-configured virtual appliances by doing the following: 

1 If you haven’t already downloaded the software for Path 1, review and follow the instructions in 
Chapter 2, “System Requirements,” on page 9.

2 After the zip file is downloaded, extract the files and folders to where you want to run them in 
VMware.

3 Start your chosen VMware platform and open the OES-11 VM (oes-11.vmx).
4 Open the Filr VM (filr.vmx).
5 Select the oes-11 tab, click Edit Virtual Machine Settings, click Network Adapter, select Bridged and 

the Replicate physical network connection state option, then click OK.
6 Repeat Step 5 for the Filr VM. 
7 Start the pre-configured VMs by doing the following: 

7a Select the oes-11 tab, then click Power on this virtual machine.
7b When VMware asks whether the VM was moved or copied, select I moved it.
7c After the OES server VM has started up, select the Filr VM, then click Power on this virtual 

machine.
7d When VMware asks whether the VM was moved or copied, select I moved it.

8 When both VMs are running, continue with Connecting to the Wireless Router.

3.3 Connecting to the Wireless Router
When you have completed the instructions in this section, your wireless router configuration should 
resemble Figure 3-1.

Filr
Virtual Appliance

OES Server
Virtual Machine

Sychronize eDirectory UsersA

Set Up Personal StorageB

Set Up Net FoldersC

Set Up SharingD

OESOES
HOME My Files

N:\ NetFolder

Shared by MeShared with Me

eDirectory Users Filr Users
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Figure 3-1   Wireless Router Setup

IMPORTANT: The instructions in this section assume that you are connecting your wireless router to 
the Internet through your organization’s network. Most wireless routers have DHCP services active 
by default. To avoid problems with your organization’s DHCP service, you need to disable DHCP 
before connecting the router to the network. 

Of course, having DHCP disabled necessitates that each device connecting to the router use a static IP 
address.

Set up your wireless router, and connect to it by doing the following:

1 Disconnect the VMware workstation from your organization’s network, and connect it to one of 
the LAN ports on the wireless router.

IMPORTANT: Do not connect the router to the Internet at this point.

2 Start the router.
3 Using the instructions for your router, access the administration console and do the following:

3a Set the router to obtain its IP address through a DHCP service. 
If DHCP is not available, configure it with a static IP address, network mask, gateway, and 
so on, for your network. 

3b Set the router to communicate with devices that are attached to it by ensuring that its LAN 
IP setup uses IP address 192.168.1.1 and network mask 255.255.255.0. 

3c Ensure that the router is not set to act as a DHCP server.
3d For the wireless configuration, assign an easily identifiable SSID, such as Filr_Lab. 
3e If possible, disable wireless security to make it simpler to connect through a wireless 

connection.
3f Save the settings. 

VMware Workstation

OESOES IP Address: 192.168.1.5

Network Mask: 255.255.255.0

Gateway: 192.168.1.1

DNS Server: 192.168.1.1

IP Address: 192.168.1.10

Network Mask: 255.255.255.0

Gateway: 192.168.1.1

DNS Server: 192.168.1.1Wireless DeviceIP Address: 192.168.1.1

Network Mask: 255.255.255.0

LAN IP Setup

IP Address: XXX.XXX.XXX.XXX

Network Mask: XXX.XXX.XXX.XXX

Gateway: XXX.XXX.XXX.XXX

DNS Server: XXX.XXX.XXX.XXX

Device’s IP Configuration

Wireless Router

Organization’s Network Internet
Filr Hands-on Administration Exercises 13



IMPORTANT: If your router’s LAN IP address configuration changed, then remember to 
use 192.168.1.1, rather than the previous address, when connecting to the router’s 
management console.

4 Set the workstation’s network adapter that is connected to the wireless router, with the following 
IP address information: 

For example, on Windows 7, access the workstation’s Control Panel. Then in the Network 
Sharing Center, set the Local Area Connection adapter with the address information.

5 Connect the wireless router to your organization’s network.
6 Configure the mobile device with the following Static IP address information:

For example, on an iPad, access the Settings panel, choose Wi-Fi, choose the network with the 
SSID name you set in Step 3d, choose the blue arrow for the network, choose the Static tab, then 
specify the address information.

7 Open a browser on the workstation and the mobile device, and ensure that you can connect to 
the Internet through them, then continue with the next section.

3.4 Before You Begin the Administrative Exercises
If you want the ability to repeat the exercises that follow, consider taking a snapshot in VMware 
before you begin. That way you can always restore the VMs to their original states without risking 
ripple effects from previous sessions.

3.5 Synchronizing LDAP Users
Your OES 11 server is pre-configured with the eDirectory users shown in Figure 3-2 on page 15.

IP address 192.168.1.5

Network Mask 255.255.255.0

Default Gateway 192.168.1.1

DNS Server Addresses 192.168.1.1

IP address 192.168.1.10

Network Mask 255.255.255.0

Default Gateway 192.168.1.1

DNS Server Addresses 192.168.1.1
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Figure 3-2   The Pre-configured eDirectory Tree and the Users That It Contains

Importing users to Filr is accomplished by setting up LDAP synchronization with the eDirectory tree 
as follows:

1 Using your administrative browser, access Filr through the following URL:
https://192.168.1.110:8443

2 If prompted, accept and trust the certificate.
3 Sign in as User: admin with Password: admin.
4 When prompted, change the password to novellfilr.

5 Click admin (upper right), then select Administration Console.
6 Under System, click LDAP.
7 Click Add a New LDAP Source > OK.

DEV

OES-11

MARKETING

FILR-LAB

ISadmin SALES

EXAMPLE_TREE

red

pink

blue

green

yellow

orange

black

gray

filrproxyuser

USERS USERS USERS USERS
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8 In the LDAP server URL field, type ldaps://192.168.1.100.
This is the IP address of the OES server (oes-11 in Figure 3-2 on page 15).

9 In the User DN field, type cn=admin,o=filr-lab.
This is the eDirectory tree Admin (Figure 3-2 on page 15).

10 In the Password field, type novellfilr.
11 In the LDAP attribute that uniquely identifies a user or group field, type GUID.
12 In the LDAP Attribute Used for Filr Name field replace uid with cn.
13 Skip to the Base DN field, then type ou=users,ou=dev,o=filr-lab.

This is the location of users red and pink in the eDirectory tree (Figure 3-2 on page 15).
14 Click Add to enter the next Base DN.
15 Create Base DN entries for the following, clicking Add for each entry.

 ou=users,ou=is,o=filr-lab

 ou=users,ou=mrktg,o=filr-lab

 ou=users,ou=sales,o=filr-lab

16 Select the following options: 
 Enable Schedule
 Run Immediately
 Every Day
 Repeat Every 0.25 Hours

17 Select the following options for User synchronization: 
 Synchronize User Profiles
 Register LDAP User Profiles Automatically

18 Click Apply.
The eight users in the four USERS containers are added.

19 Do not close the Administration Console. Continue with Section 3.6, “Setting Up Users’ My Files 
Folders,” on page 16.

For complete instructions on using Filr LDAP synchronization, see “Synchronizing Users and 
Groups from an LDAP Directory,” in the Novell Filr 1.0 Administration Guide.

3.6 Setting Up Users’ My Files Folders
1 Under Management, click User Accounts.
2 Select the check boxes next to the names of the following users that you synchronized from 

eDirectory, then click More > Enable Personal Storage.
 M Black
 M Green
 M Orange
 M Pink

3 Do not close the Administration Console. Continue with Setting Up Net Folders.
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3.7 Setting Up Net Folders
 Section 3.7.1, “Specifying Net Folder Servers,” on page 17
 Section 3.7.2, “Setting Net Folder Access and Sharing Rights,” on page 18

3.7.1 Specifying Net Folder Servers

Net Folder Servers are connections to NSS volumes on NetWare and OES file servers, and to shares 
on Windows file servers. You can set up as many connections to each file server as needed. For the 
hands-on lab, you create one Net Folder Server for each NSS volume.

1 Under Management, click Net Folder Servers.
2 Four of the users that you synchronized with the OES-11 server have Home directories on the 

server. Therefore, the Net Folder Server 192.168.1.100-HOME is already created and listed.

IMPORTANT: Although Home folders are technically like other Net Folders in Filr, their 
primary role is personal storage. Therefore, they are accessed through My Files rather than 
through Net Folders.

3 The Home Net Folder Server is marked with an icon that indicates that its configuration needs 
attention.
In the Name column, click 192.168.1.100-HOME.

4 A chief feature of Filr is the ability to share files and folders with others who do not have native 
file system rights. This sharing functionality is provided through Filr proxy users, but the Home 
Net Folder Server has no Filr proxy user assigned.
The proxy user for these exercises (filrproxyuser) is shown in the FILR-LAB organization in 
Figure 3-2 on page 15.
In the Proxy Name field, type 
cn=filrproxyuser,o=filr-lab

In the Proxy Password field, type
novellfilr

5 Click Test Connection.
You should see a message that the test succeeded.

6 Click OK > OK.
7 To add Net Folder Servers for the other volumes on the OES server, click Add.
8 Type the following in the fields indicated for a volume, beginning with DEV:

Volume Field Text

DEV Name Development

Server Path \\192.168.1.100\DEV

Proxy Name cn=filrproxyuser,o=filr-lab

Proxy Password novellfilr
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Notice that the Net Folder Server names do not necessarily need to mirror the server and volume 
information.

9 Click Test Connection to ensure that everything is entered correctly.
10 Under Synchronization Schedule, select 

 Enable Scheduled Synchronization
 Every Day
 At 0:00 GMT

11 Click OK.
12 Repeat from Step 8 for the IS, MRKTG, and SALES volumes.
13 Click Sync.

When the sync operation completes, Filr has metadata for each Net Folder Server in its database.
14 Continue with Setting Net Folder Access and Sharing Rights.

3.7.2 Setting Net Folder Access and Sharing Rights

Net Folders are connections to specific directories on Net Folder Servers. You can set up as many Net 
Folders as needed. You can also specify a separate and independent synchronization schedule for 
each Net Folder.

1 Under Management, click Net Folders.
Notice that although four users have Home folders and the HOME volume was listed as a Net 
Folder Server in the previous section, there are no Net Folders displayed in the list. This is 
because Home folders are displayed and managed under My Files rather than Net Folders.

2 Click Add, then use the information in Table 3-1 to complete the sub-steps for each Net Folder 
listed.

IS Name IS

Server Path \\192.168.1.100\IS

Proxy Name cn=filrproxyuser,o=filr-lab

Proxy Password novellfilr

MRKTG Name Marketing

Server Path \\192.168.1.100\MRKTG

Proxy Name cn=filrproxyuser,o=filr-lab

Proxy Password novellfilr

SALES Name Sales

Server Path \\192.168.1.100\SALES

Proxy Name cn=filrproxyuser,o=filr-lab

Proxy Password novellfilr

Volume Field Text
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Table 3-1   Net Folder Configuration Information

2a In the Name field, type a name from Table 3-1 (reviews is first).
2b In the Net Folder Server drop-down list, select the Net Folder Server listed for the Net Folder 

(Development is first).
2c In the Relative Path field, type the relative path shown for the Net Folder 

(personnel\reviews is first).
2d Click Test Connection and verify that the information is entered correctly. 
2e Click Index the Contents of This Net Folder. 

Although content indexing carries significant processing overhead and should, therefore, 
probably not be applied to all Net Folders, the content used in these exercises is so small 
that the overhead involved with indexing it is miniscule. 

2f Click Enable Just-in-Time Synchronization.
Again, the content used in these exercises is small, and this option ensures that the folder’s 
content is synchronized between OES and Filr each time a user accesses it.

2g Click the Rights tab.
2h In the User or Group field, begin typing, and then select the first user listed for the Net 

Folder (M Red is first.)
2i In the Grant Rights dialog, set the sharing rights as listed (the first choices are: Allow Access 

to the Net Folder and Internal Users), then click OK.

Name Server Relative Path Users with Rights 
to Net Folder

Sharing Rights

reviews Development personnel\reviews red Allow Access

Internal

comp planning Development personnel\salaries red Allow Access

projects Development projects red Allow Access

Internal

External

training IS training\quick_starts blue Allow Access

Internal

Re-share

cool stuff Marketing advertising\brochures yellow Allow Access

Internal

External

Public

Re-share

projections Sales revenue\projections black Allow Access

Internal

2013 tracking Sales revenue\quotas black Allow Access

Internal
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2j Click OK > OK, then return to Step 2a for the next Net Folder.
2k When all of the Net Folders have been specified, continue with Enabling Sharing.

3.8 Enabling Sharing
Even though you granted sharing rights in the previous section, actually allowing users to share files 
and folders requires that you enable sharing for the Filr site.

1 Under System, click Share Settings.
2 In the User or Group field, start to type all, then select All Internal Users.

Because the Filr VM was copied, in some cases the system index gets compromised. If the list is 
empty, do the following:
2a Under Management, click Search Index.
2b Select Re-Index Everything, then click OK. 

On most installations, reindexing would take some time. However, because this is such a 
small installation, the process happens very quickly. 

2c Repeat from Step 1.
3 Click Re-share Items and Share with the Public, then click OK > OK.

This sets the maximum sharing rights that can be granted anywhere on the system. Re-sharing 
and public access are only available if they are actually enabled on the Net Folders.

4 Under System, click User Access, select Allow Guest access and Guest access is read-only, then click 
OK.
The read-only option prevents public (guest) users from logging comments. This is generally a 
good idea in light of the risk of “spam” comments. Comments cannot be removed in this version 
of Filr.

5 Continue with Allowing the Desktop Application to Be Deployed.

3.9 Allowing the Desktop Application to Be Deployed
Some of the Filr end user exercises are done through the Desktop Application. To enable the Desktop 
Application to be deployed through the Web application:

1 Under System, click Desktop Application.
2 Select Be deployed.
3 In the Auto-update URL field, type https://192.168.1.110:8443/desktopapp/.
4 Click OK.
5 Continue with (Optional) Setting Up Email Communication with the Filr VM.

3.10 (Optional) Setting Up Email Communication with the Filr VM
The hands-on exercises leverage two of your personal email addresses:

 One is assigned to user red for demonstrating Filr’s notification capabilities.
 The other is used for inviting an external user to collaborate on a project.
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If you are not interested in email notifications or external sharing as part of the end user exercises, 
you can skip all of the remaining sections and steps in this guide that are marked (Email Only).

If you want to experiment with email notifications that originate from Filr, you must complete the 
following sections:

 Section 3.10.1, “(Email Only) Configuring the Host Workstation to Recognize Filr’s DNS Name,” 
on page 21

 Section 3.10.2, “(Email Only) Entering an Email Address for User red,” on page 21
 Section 3.10.3, “(Email Only) Synchronizing red’s Change with Filr,” on page 22

3.10.1 (Email Only) Configuring the Host Workstation to Recognize Filr’s DNS 
Name

1 On the VMware host workstation, open Windows Explorer and ensure that the file toolbar is 
displayed. If it’s not displayed, press F10.

2 Click Tools > Folder Options. 
3 Click the View tab, then click Show hidden files, folders, and drives > Apply > OK.
4 Navigate to Windows > System 32 > drivers > etc, then right-click the hosts file and select 

Properties. 
5 Click the Security tab.
6 Select your user name, then Edit the permissions and assign yourself Full Control of the hosts 

file.
7 Click OK.
8 Right-click the hosts file and open it in a text editor, such as Notepad, then add the following 

line:
192.168.1.110 filr.filr-lab.example.com.

9 Save and close the file.

3.10.2 (Email Only) Entering an Email Address for User red

1 Go to Section A.2.6, “Accessing iManager,” on page 48, complete the instructions in that section 
and in Section A.2.7, “Enabling Pop-Ups for iManager,” on page 48, then return here.

2 Ensure that the Roles and Tasks icon  is selected.
3 In the left panel, click Users > Modify User.

4 Click the Browse icon  next to the Username field.
5 Click the Search tab.
6 In the Search for objects named field, type red, then click Search.
7 Under Results, click the link for user red.
8 Click OK.
9 Click the plus icon next to the Internet E-mail address field.

10 Type the email address you have chosen to use with these exercises, for example 
myusername@examplemail.com.

11 Click OK > Apply > OK, then close iManager.
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3.10.3 (Email Only) Synchronizing red’s Change with Filr

1 Using your administrative browser, access Filr through the following URL:
https://192.168.1.110:8443

2 Sign in as User: admin with Password: novellfilr.
3 Click admin (upper right), then select Administration Console.
4 Under System, click LDAP.
5 Click Run Immediately.
6 Click Apply.

User red’s profile is modified.
7 Continue with Chapter 4, “Filr Hands-on End User Exercises,” on page 23.
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4 4Filr Hands-on End User Exercises

This section guides you through the following tasks:

 Section 4.1, “Overview of Filr End User Exercises,” on page 23
 Section 4.2, “Downloading and Starting the Virtual Machines,” on page 24
 Section 4.3, “Connecting to the Wireless Router,” on page 25
 Section 4.4, “Accessing Filr to Do the Filr End User Exercises,” on page 26
 Section 4.5, “FILR-LAB Users and Roles,” on page 27
 Section 4.6, “Before You Begin the End User Exercises,” on page 28
 Section 4.7, “Exploring Filr Functionality for End Users,” on page 28

4.1 Overview of Filr End User Exercises
The Filr end user exercises can be summarized as follows:

(Conditional*) Downloading the End-User-Ready Virtual Machines

OESOES

Download

Filr Documentation Site

Filr
Virtual Appliance

OES Server
Virtual Machine

VMware Workstation with
Wireless Router

Unzip

OESOES

Hands-on_Filr_1_U.zip

Open and Power On

* This is required only if you are doing just the end user exercises. 
Otherwise, your virtual machines are already prepared for the end user exercises.

VMware Workstation with
Wireless Router
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Using Filr As an End User

4.2 Downloading and Starting the Virtual Machines

IMPORTANT: There are two things you must understand about the downloadable end-user exercise 
VM files.

 The instructions in this section only apply to Path 2. If you are following Paths 1 or 3, you have 
already prepared the virtual machines for the exercises in this section. Therefore, you should not 
complete the steps below. Instead, skip to Section 4.4, “Accessing Filr to Do the Filr End User 
Exercises,” on page 26.

 The downloadable end-user exercise VM files are not configured with an email address for user 
red. This means that if you are following Path 2 and you want to do the optional email exercises, 
you must complete the instructions in Section 3.10, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 20 after downloading the end-user exercise VM files 
and completing the steps below. 
Of course, if you aren’t interested in the email exercises, setting up email communication is not 
needed.

Download the pre-configured virtual appliances by doing the following: 

1 If you haven’t already downloaded the software for Path 1, review and follow the instructions in 
Chapter 2, “System Requirements,” on page 9.

2 After the zip file is downloaded, extract the files and folders to where you want to run them in 
VMware.

3 Start your chosen VMware platform and open the OES-11 VM (oes-11.vmx).
4 Open the Filr VM (filr.vmx).
5 Select the oes-11 tab, click Edit Virtual Machine Settings, click Network Adapter, select Bridged and 

the Replicate physical network connection state option, then click OK.
6 Repeat Step 5 for the Filr VM. 
7 Start the pre-configured VMs by doing the following: 

7a Select the oes-11 tab, then click Power on this virtual machine.
7b When VMware asks whether the VM was moved or copied, select I moved it.
7c After the OES server VM has started up, select the Filr VM, then click Power on this virtual 

machine.
7d When VMware asks whether the VM was moved or copied, select I moved it.

8 When both VMs are running, continue with Connecting to the Wireless Router.

OES-11FilrYou

OESOES

Access Devices and Methods
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4.3 Connecting to the Wireless Router

IMPORTANT: The instructions in this section only apply to Path 2. If you are following Paths 1 or 3, 
you have already set up the wireless router and connected to it. Skip to Section 4.4, “Accessing Filr to 
Do the Filr End User Exercises,” on page 26.

When you have completed the instructions in this section, your wireless router configuration should 
resemble Figure 4-1.

Figure 4-1   Wireless Router Setup

IMPORTANT: The instructions in this section assume that you are connecting your wireless router to 
the Internet through your organization’s network. Most wireless routers have DHCP services active 
by default. To avoid problems with your organization’s DHCP service, you need to disable DHCP 
before connecting the router to the network. 

Of course, having DHCP disabled necessitates that each device connecting to the router use a static IP 
address.

Set up your wireless router, and connect to it by doing the following:

1 Disconnect the VMware workstation from your organization’s network, and connect it to one of 
the LAN ports on the wireless router.

IMPORTANT: Do not connect the router to the Internet at this point.

2 Start the router.
3 Using the instructions for your router, access the administration console and do the following:

3a Set the router to obtain its IP address through a DHCP service. 
If DHCP is not available, configure it with a static IP address, network mask, gateway, and 
so on, for your network. 

3b Set the router to communicate with devices that are attached to it by ensuring that its LAN 
IP setup uses IP address 192.168.1.1 and network mask 255.255.255.0. 

VMware Workstation

OESOES IP Address: 192.168.1.5

Network Mask: 255.255.255.0

Gateway: 192.168.1.1

DNS Server: 192.168.1.1

IP Address: 192.168.1.10

Network Mask: 255.255.255.0

Gateway: 192.168.1.1

DNS Server: 192.168.1.1Wireless DeviceIP Address: 192.168.1.1

Network Mask: 255.255.255.0

LAN IP Setup

IP Address: XXX.XXX.XXX.XXX

Network Mask: XXX.XXX.XXX.XXX

Gateway: XXX.XXX.XXX.XXX

DNS Server: XXX.XXX.XXX.XXX

Device’s IP Configuration

Wireless Router

Organization’s Network Internet
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3c Ensure that the router is not set to act as a DHCP server.
3d For the wireless configuration, assign an easily identifiable SSID, such as Filr_Lab. 
3e If possible, disable wireless security to make it simpler to connect through a wireless 

connection.
3f Save the settings. 

IMPORTANT: If your router’s LAN IP address configuration changed, then remember to 
use 192.168.1.1, rather than the previous address, when connecting to the router’s 
management console.

4 Set the workstation’s network adapter that is connected to the wireless router, with the following 
IP address information: 

For example, on Windows 7, access the workstation’s Control Panel. Then in the Network 
Sharing Center, set the Local Area Connection adapter with the address information.

5 Connect the wireless router to your organization’s network.
6 Configure the mobile device with the following Static IP address information:

For example, on an iPad, access the Settings panel, choose Wi-Fi, choose the network with the 
SSID name you set in Step 3d, choose the blue arrow for the network, choose the Static tab, then 
specify the address information.

7 Open a browser on the workstation and the mobile device, and ensure that you can connect to 
the Internet through them, then continue with the next section.

4.4 Accessing Filr to Do the Filr End User Exercises
You need connections to Filr through the following access points to complete the Filr End User 
Exercises:

 A browser on the VMware host workstation
 The Filr Desktop Application on the VMware host workstation
 The wireless device

IP address 192.168.1.5

Network Mask 255.255.255.0

Default Gateway 192.168.1.1

DNS Server Addresses 192.168.1.1

IP address 192.168.1.10

Network Mask 255.255.255.0

Default Gateway 192.168.1.1

DNS Server Addresses 192.168.1.1
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4.4.1 Connecting to Filr through the Browser and Installing the Filr Desktop 
Application

To connect through the browser and install the Filr Desktop Application:

1 On the VMware host workstation, start the browser and access the following URL:
https://192.168.1.110:8443

2 If prompted, accept and install the certificate.
3 Log in as User ID: Admin with Password: novellfilr.
4 In the upper-right corner, click admin, then select Download Filr Desktop App.
5 Click the appropriate link for the host workstation, for example, Windows X64 Client.
6 Save the file, close the download dialog, then install the client. 

For help, see the applicable Quick Start on the Novell Filr online documentation site.
7 Continue with Starting the Filr Desktop Application.

4.4.2 Starting the Filr Desktop Application

1 On the Novell Filr welcome screen, click Start.
2 In the Server URL field, type https://192.168.1.110:8443.
3 Log in as Username: pink with Password: filrrocks.
4 Continue through any security warnings.
5 Click Next > Next > Finish.

The Filr folder is now available in Windows Explorer or Macintosh Finder.

4.4.3 Installing and Starting a Filr Mobile App

Filr mobile apps are available as free downloads in the Apple App Store, the Google Play App Store, 
and the Amazon Appstore for Android.

Download and install the Filr mobile app on the mobile device as you would any other device app.

To access the Filr Mobile App:

1 Start the app in the same was as you start other apps on your mobile device.
2 Log in as Username: black with Password: filrrocks.
3 Continue with FILR-LAB Users and Roles.

4.5 FILR-LAB Users and Roles
Table 4-1 lists eight users that have been synchronized from the OES 11 server to Filr.

As you can see, there are differences in their Home directory and personal storage allocations (third 
column). We will briefly explore these in Section 4.7.1, “My Files—Home Directories and Personal 
Storage,” on page 29.
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Only the manager-level users, such as red, blue, and so on, have file system rights on the OES 11 
server (fourth column). However, the server contains files that need to be accessed by internal users, 
such as pink, green, and so on, who do not have file system rights. Some files also need to be reviewed 
by external users. 

We will explore how Filr facilitates your organization’s review and input processes in Section 4.7.3, 
“Internal Sharing,” on page 31 and the sections that follow it.

Table 4-1   User Roles and Tasks

4.6 Before You Begin the End User Exercises
If you want the ability to repeat the exercises that follow, consider taking a snapshot in VMware 
before you begin. That way you can always restore the VMs to their original states without risking 
ripple effects from previous sessions.

4.7 Exploring Filr Functionality for End Users
After you have completed the setup and administrations instructions in this guide that pertain to the 
Path you are following, the Filr and OES 11 VMs are ready for the exercises in the following sections:

 Section 4.7.1, “My Files—Home Directories and Personal Storage,” on page 29
 Section 4.7.2, “About the Folders and Files That Are on the OES Server and Are Accessible 

through Filr,” on page 30
 Section 4.7.3, “Internal Sharing,” on page 31
 Section 4.7.4, “(Email Only) External Sharing,” on page 33
 Section 4.7.5, “Public Sharing,” on page 35
 Section 4.7.6, “Re-sharing and Searching,” on page 36
 Section 4.7.7, “More Things You Can Try,” on page 36

User Name
Role in the FILR-LAB 
organization

Home Directory and 
Personal Storage

File System Rights on the 
OES 11 Server

red Development Manager HOME Supervisor on volume DEV

pink Developer Personal None

blue IT Manager HOME Supervisor on volume IT

green Filr Administrator Personal None

yellow Marketing Manager HOME Supervisor on volume MRKTG

orange Product Line Manager Personal None

black District Manager HOME

Personal

Supervisor on volume SALES

gray Account Manager None
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4.7.1 My Files—Home Directories and Personal Storage

Table 4-1 lists the different storage locations assigned to users for their personal storage needs and 
accessed through Filr’s My Files functionality. 

The files and folders that users see when they access My Files are illustrated in Figure 4-2 and 
demonstrated in the steps that follow.

Figure 4-2   What Filr Users See in My Files Depends on What Is Set Up for Them

In the following steps, take the role and do the steps of the users that are indicated.

1 User black is a fan of the Hubble telescope and especially likes this image (http://hubblesite.org/
gallery/wallpaper/pr2007041a). 
Click the 1280X1024 link and save the displayed image to the desktop.

2 Copy the image to black’s home folder on the OES server.
For example, on Windows 7:
2a Open Windows Explorer and enter the following URL in the Address Bar:

\\192.168.1.100\HOME

2b Log in as User Name: black with Password: filrrocks.
Notice that although users red, blue, and yellow each have home directories, black only sees 
the black directory.

2c Open the black folder.
2d Copy the downloaded image to the folder.

My Files

local.txt

Only
Filr Storage

My Files

remote.txt

Only
Home Folder

Home 

My Files

local.txt

Both

remote.txt

Filer Data Disk

local.txt

NSS or NTFS
Home Folders

remote.txt

My Files

and
or
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3 Access the Filr Web site, sign out as user admin, then sign in as User ID: black with Password: 
filrrocks.
Notice that My Files includes a sub-folder named Home. This is black’s home directory on the 
OES server. 
Refer to Table 4-1 and notice that user black has a home directory and is also assigned personal 
storage. In other words, user black is an example of the section labeled “Both” in Figure 4-2. 

4 Open the Home folder. The Hubble image file is there as you would expect it to be.
5 Sign out as user black, then sign in as User ID: admin with Password: novellfilr.
6 Access the Administration Console (upper-right corner), then under Management click User 

Accounts. 
7 Select M Black, then click More and select Purge User Workspaces > Yes.
8 Select M Black again, then click More and select Disable Personal Storage.
9 Sign out as user admin, then sign in as user black.

10 Notice that the Home folder has disappeared from user black’s My Files folder and the Hubble 
image file is now directly listed as a child. 
Because you purged and removed the Personal Storage that was assigned to user black, user black 
now fits the definition in the section of Figure 4-2 that is labeled “Only Home Folder.” (Purging 
black’s personal storage had no effect on the OES server’s file structure.)

11 Click the down-arrow next to the image, then select Share. 
12 In the Share with field, type a, then select All Internal Users. 
13 Click OK > OK.
14 Feel free to explore further if you want to get more experience with Filr’s My Files functionality 

and the role that traditional home folders play in that context. Then continue with About the 
Folders and Files That Are on the OES Server and Are Accessible through Filr.

4.7.2 About the Folders and Files That Are on the OES Server and Are 
Accessible through Filr

Unless you are following Path 3, and you personally prepared the OES and Filr VMs, you haven’t yet 
been introduced to the folders and files as they are stored on the OES 11 server. Figure 4-3 shows a 
visual summary. 
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Figure 4-3   Files and Folders on the Hands-on OES 11 Server

If you are following Path 1, then in Section 3.7, “Setting Up Net Folders,” on page 17, you created Net 
Folder servers for the volumes shown and Net Folders for the folders marked with a single asterisk 
(*) in the graphic. If you are following Path 2, these were created for you in the VMs that you 
downloaded.

The remaining end user exercises deal primarily with these files and folders.

4.7.3 Internal Sharing

The exercises in this section demonstrate how Novell Filr users can share files with users who are 
internal to your organization. 

 “User red Initiates User pink’s Annual Review” on page 32
 “User pink Responds to the Annual Review Request” on page 32
 “User red Approves pink’s Annual Review” on page 33

FILR_POOL

OES-11.IS.FILR-LAB.EXAMPLE_TREE

SALESMRKTG

personnel

2014.ods

reviews *

salaries *

mpink

2013.ods

projects *

current

future

abc-requ.odt

xyz-requ.odt

Novell_Filr.pdf

quick_starts *

advertising

filr_flyer.pdf

brochures *

budget

requests *

orange_new_ws.odt **

revenue

2014.ods

projections *

quotas *

2013.ods

training

* These folders become Net Folders with the implementation of Filr. 

DEV IS

** User orange creates this file as part of the exercises.
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User red Initiates User pink’s Annual Review

User red needs to complete the annual review for user pink, but pink doesn’t have file system access to 
the review file (mpink_2013.odt). Rather than sending the file in email or assigning pink the required 
file system trustee rights on the OES server, red simply shares the review file with pink and includes 
Editor privileges. First, however, red optionally ensures that email notifications will be sent when the 
file changes.

1 Sign in to the Web application as user red. (This requires that you sign out as user admin first.)
2 Click Shared with Me and notice that the image that black shared is listed.

IMPORTANT: If you are not experimenting with email notifications, skip to Step 4 and skip all 
subsequent steps that are marked (Email only).

3 (Email only) Click M Red in the upper-right corner, then select View Profile. 
When the profile displays, notice that the email address you configured in eDirectory for user 
red is listed.

4 Click Net Folders > reviews > mpink.

5 Click the check box for mpink_2013.odt, then click the file drop-down arrow  to the right of 
the file and select Share.

6 In the Share with field, type p, then select M Pink.
7 Select Editor, then click OK > OK.
8 (Email only) Click the check box for mpink_2013.odt and the file drop-down arrow again, then 

click Subscribe.
9 (Email only) Expand the Message Only option, then select the email address you entered for user 

red in Directory and click OK.

10 Click the comment icon .
11 Add a comment, such as 

Hi pink. 

Would you please edit this with your objectives and achievements and let me 
know when you have finished? 
Thanks. 
red

12 Click Send and close the Comments dialog.

User pink Responds to the Annual Review Request

1 On the desktop in the notifications area, right-click the Filr icon. 

2 Select Open Filr folder.
3 Right-click mpink_2013.odt, then select Open.
4 In the notifications area, right-click the Filr icon, then select Open Filr folder.

The file opens in LibreOffice Writer.
5 Make a few changes, then save and close the file. 
32 Novell Filr: Hands-on Guide for OES



You can be as verbose or brief as you want.
6 In the Shared with Me folder on the workstation, right-click the file you just edited and select 

Synchronize now.
7 Sign in to the Web application as user pink, then click Shared with Me.
8 Click the drop-down arrow for mpink_2013.odt, then click View HTML.

Your changes are reflected in the view.
9 Close the HTML view tab.

10 Click the review file’s comment icon, type a comment indicating that the review is ready, then 
click Send and close the comment panel.

User red Approves pink’s Annual Review

1 Log in to the email account that you assigned to user red.
2 Open the message from filr-admin.
3 Click the Visit Message link.
4 Sign in to the Web application as user red.

The revised Performance Review is displayed as HTML.
5 Click the Comments down arrow to view pink’s comment.
6 In the new comment box, type a comment indicating that the review is approved, then click 

Send.
7 Close the view. 
8 Continue with (Email Only) External Sharing.

4.7.4 (Email Only) External Sharing

The exercises in this section demonstrate how Filr users can share files with users who are external to 
your organization. 

 “About External Users” on page 33
 “User red Gathers Input for the Next Release” on page 34
 “User opaque Self-Provisions and Responds to the Review Request” on page 34
 “User red Responds to User opaque’s Input” on page 35

IMPORTANT: Completing the instructions in Section 3.10, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 20 is required for the exercises in this section.

About External Users

External users are those who receive share invitations through email and subsequently provision 
themselves as system users. They can then log in to the system using the credentials they establish 
with Filr, or they can elect to be authenticated through a Google or Yahoo Open ID account.

For more information about the different kinds of users who can access Filr, see “Users and Groups 
with Filr” in the Novell Filr 1 “How Filr Works”–Overview Guide.
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User red Gathers Input for the Next Release

User red managed the ABC product release and is responsible for gathering input for the upcoming 
XYZ product. User red also wants to invite input from a key partner named M Opaque. Inviting M 
Opaque to participate requires using the second email address mentioned in Chapter 2, “System 
Requirements,” on page 9 and further explained in Section 3.10, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 20.

1 If you aren’t already signed in to the Web application as user red, do so now.
2 Click Net Folders > projects > current.

3 Click the check box for abc_reqr.odt, then click the file drop-down arrow  to the right of the 
file and select Share.

4 In the Share with field, type your second email address, then click the plus sign (+) to add the 
external user.
At this point user red could share the document with other internal users, but for brevity’s sake, 
we aren’t including steps for that. 

5 Click OK > OK.
6 Click the check box for abc_reqr.odt and the file drop-down arrow again, then click Subscribe.
7 Expand the Message Only option, then select the email address you entered for user red in 

Directory and click OK.

8 Click the comment icon  to the right of the down-arrow.
9 Add a comment, such as

It’s time to gather input for the next release. 
Please log comments to let us know which features we need to include this time. 

10 Then click Send and close the Comments dialog.

User opaque Self-Provisions and Responds to the Review Request

1 Log in to the email account that you used to invite user opaque to participate in the review.
2 Open the message from the email address you assigned to user red.
3 Click the abc_reqr.odt link.
4 The email address is the automatic User ID assigned to M Opaque and cannot be changed.

We suggest you type First name: M, Last name: Opaque, Password: filrrocks, and Re-enter 
password: filrrocks, but you are free to customize these fields as you wish. 
Of course, the two password field values must match.

5 Click Register.
6 Open the confirmation email, then click Sign in and access shared items.
7 Type the password you chose for user opaque, then click Sign in. 
8 Click Comments and read the comment from user red.
9 Click Actions, then click Subscribe. 

Emails will now be sent to user opaque as others comment on the document, and so on.
10 Read the HTML view of ABC Project displayed in the window, then log the following comment:

Competing products have had morning coffee functionality for over 18 months 
now.
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If the next release doesn’t include this, we will be forced to switch.

11 Click Send.

User red Responds to User opaque’s Input

User red receives notification of user opaque’s comment (you can check red’s email if you wish) and 
remembers that the requested feature has been discussed. It should already be in the next 
requirements document (xyz_reqr.odt), but red isn’t certain that it is.

1 Log in to the Web application as user red.
2 Click Net Folders > projects > future.

3 Click the file drop-down arrow  for xyz_reqr.odt and select View HTML. 
The file has not been updated.

4 Click the file drop-down arrow  again, then select View details. 
5 Click Edit this file, then continue past the security warning and other messages until you are 

prompted to log in.
6 Log in as user red.
7 Insert the following text before the period:

, and it will make the morning coffee

8 Save the file and close LibreOffice.
9 Navigate to xyz_reqr.odt again and view its details to confirm that the change has been made.

10 Log and send a comment indicating that the file has been updated.
11 Share the file with user opaque.

4.7.5 Public Sharing

User yellow wants to get the word out about the abc version of the organization’s product and elicits 
user orange’s help with the effort.

1 Log in to the Web application as User ID: yellow with Password: filrrocks.
2 Click Net Folders > cool stuff.

3 Click the file drop-down arrow  for abc_flyer.pdf, then select Share. 
4 In the Share with field, type o, then select M Orange.
5 Click Public > OK > OK.
6 Log in as User ID: orange with Password: filrrocks.
7 Click Shared with Me.
8 Select the abc_flyer.pdf file, then click Share.
9 Click Make Public.

10 In the Type column, click Public to view and copy the URLs that can be shared in social media, 
and so on.

11 Enter one of the URLs in a separate browser window or tab to see what Internet users who 
access the URL will see.
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4.7.6 Re-sharing and Searching

User red hears about a training quick start but can’t find it.

1 Log in to the Web application as User ID: blue with Password: filrrocks.
2 In Net Folders, navigate to training > quick_starts > Novell-Filr.pdf, then share the file with green as 

a Viewer with rights to reshare the file with internal users.
3 Log in as user green, then share the file, with rights to reshare, with users pink, yellow, orange, 

black, and gray.
At this point, user pink comments on the quick start to user red in the hallway.

4 Log in as user red, then in the search field type quick and press Enter.
Because the file is not found, user red asks pink to share the file.

5 Log in as user pink and share the file with red.
6 Log in as user red and search for the file again.

The file is listed in the search results window.

4.7.7 More Things You Can Try

There are a few additional files in the other Net Folders that you can experiment with as indicated 
below. You can also experiment with your own files. 

Activity Type Net Folder File Location Task Descriptions

Planning comp planning 2014.ods 1. User red opens the file in LibreOffice and plans a 
5.5% increase for pink’s 2014 salary.

Planning projections fy_2014.ods 1. User black shares the file with user gray as a viewer 
and asks whether the goals are realistic.

2. User gray comments that the Q3 estimate is low and 
the Q4 estimate is high. gray asks that $10,000 be 
transferred from Q4 to Q3.

3. User black adjusts Q3 and Q4 estimates, thanks gray, 
and acknowledges the change.

Reporting quotas fy_2013.ods 1. User black shares this file with user gray as an Editor 
and requests that gray update it with Q4 actual 
results.

2. User gray opens the file, enters $110,900, and saves 
the file. 

3. User gray comments that the file is now ready for 
review.
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A ACreating Your Own Virtual Machines 
for the Filr Hands-on Exercises

This section presents the steps that were followed to create the pre-configured OES and Filr virtual 
machines that are available for download, and are used with Chapter 3, “Filr Hands-on 
Administration Exercises,” on page 11. It contains the following information:

 Section A.1, “Configuring the VMware Host Workstation for the Wireless Router,” on page 37
 Section A.2, “Installing the OES Server,” on page 40
 Section A.3, “Creating Users, Pools, and Volumes,” on page 49
 Section A.4, “Setting Up Novell CIFS,” on page 54
 Section A.5, “Preparing Files for the Hands-on Exercises,” on page 56
 Section A.6, “Installing and Configuring the Filr Appliance,” on page 60

A.1 Configuring the VMware Host Workstation for the Wireless 
Router
The instructions in this section assume that you are using a Windows 7 workstation (VMware 
Workstation host) that is directly connected to your organization’s network for optimal bandwidth 
for downloading large files. (Later, you connect it to the wireless router, but that is not recommended 
for initial configuration because the router might not provide the same bandwidth, thus impacting 
the download and installation process.)

Furthermore, these instructions assume that you plan to use a wireless router that is configured for a 
192.168.1.0 IP address subnet, with the router itself configured with IP address 192.168.1.1 (a 
common configuration for many home wireless routers).

Finally, these instructions prepare VMware Workstation to support VMs that are created with IP 
address configurations that are compatible with connecting to the wireless router through a bridged 
connection. However, the VMs are created in VMware by using the NAT (network address 
translation) capabilities in VMware, which is why these preparation steps are required.

1 Ensure that you have met all of the system and software requirements outlined in Chapter 2, 
“System Requirements,” on page 9.

2 Start VMware Workstation, then click Edit > Virtual Network Editor.
3 Select VMnet8, change the Subnet IP field to 192.168.1.0 and Subnet Mask field to 

255.255.255.0, then click NAT Settings.
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4 Change the Gateway IP field to 192.168.1.1.
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5 Click OK > Apply > OK.
6 On the workstation’s desktop, click Start > Control Panel > Network Sharing Center. Then under 

View Your Active Networks, select VMware Network Adapter VMnet8.

7 Click Properties > Internet Protocol Version 4 (TCP/IPv4) > Properties.
8 Specify only the IP address (192.168.1.2) and the Subnet mask (255.255.255.0) for the 

VMware 8 adapter as shown.
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9 Click OK > Close > Close.
10 Close the Control Panel and continue with Installing the OES Server.

A.2 Installing the OES Server
 Section A.2.1, “Obtaining Installation Media,” on page 41
 Section A.2.2, “Installing the Server Software,” on page 41
 Section A.2.3, “Setting the Root Password and Updating the Server,” on page 44
 Section A.2.4, “Configuring eDirectory and OES Services,” on page 46
 Section A.2.5, “Setting Up the Graphical User Interface,” on page 47
 Section A.2.6, “Accessing iManager,” on page 48
 Section A.2.7, “Enabling Pop-Ups for iManager,” on page 48
 Section A.2.8, “Where to Go from Here,” on page 49
40 Novell Filr: Hands-on Guide for OES



A.2.1 Obtaining Installation Media

To complete the instructions in this section, you need to download the OES 11 SP1 combined 
installation ISO file.

1 Go to “Downloading OES 11 SP1 Software from the Novell Web Site,” in the OES 11 SP1: 
Planning and Implementation Guide.

2 Working on the VMware workstation host, complete all steps in the section, except the 
instructions on deciding which files to download. The file you need for the exercises in this 
guide is OES11-SP1-addon_with_SLES11-SP2-x86_64-DVD.iso.

3 Be sure to print the pages as instructed, record the two activation codes, print and check the 
MD5 verification checksum, and so on.

4 After you have downloaded the file to your VMware workstation host, continue with Installing 
the Server Software.

A.2.2 Installing the Server Software

1 In VMware Workstation 8, click File > New Virtual Machine.
2 Ensure that the Typical option is selected, then click Next.
3 Select I will install the operating system later, then click Next.
4 Under Guest Operating System, click Linux. Then under Version, select SUSE Linux Enterprise 11.
5 Click Next.
6 Name the virtual machine oes-11, specify an alternate location for the VM if desired, then click 

Next.
7 Ensure that the Maximum Disk Size is 20 GB, select Store virtual disk as a single file, then click Next.
8 Click Customize Hardware.
9 In the right panel, change the Memory (RAM) setting to 1024 MB.

Normally, the RAM setting would be higher; however, for this small installation, this amount is 
adequate.

10 In the left panel, click New CD/DVD (IDE).
11 Select Use ISO image file.
12 Browse to the OES11-SP1-addon_with_SLES11-SP2-x86_64-DVD.iso file that you downloaded 

in “Obtaining Installation Media,” then click Open.
13 Click Network Adapter, then select the NAT option.
14 Click Close > Finish.
15 With the OES 11 SP1 VM selected, click VM > Power > Power On to BIOS.
16 Click inside the setup dialog, then use the Right-arrow key to move to Boot. 
17 Use the Down-arrow key to select CD-ROM Drive, then use Shift + to move CD-ROM Drive to the 

top of the list.
18 Use the Right-arrow key to select Exit, then press Enter and Enter again to exit.
19 When the boot selection page appears, immediately press the Down-arrow key to select the 

Installation option, then press Enter.
If you don’t respond before the machine starts trying to boot from the hard disk, restart the VM 
and repeat this step.
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20 After the boot process finishes, select a Language and Keyboard Layout, read and agree to the SLES 
11 SP2 software license agreement, then click Next.

21 Read and agree to the software license agreement for OES 11 SP1, then click Next.
22 Ensure that New Installation is selected, select Include Add-on Products from Separate Media, then 

click Next.
23 Ensure that the Yes, Run the Network Setup option is selected, then click Next.
24 Use the following table to navigate and configure your server.

25 To ensure a clean installation, use the following table to navigate the partitioning pages and 
prepare your system disk.

Page Name Action

Network Setup 1. Select Static Address Setup.

2. In the IP Address field, type 192.168.1.100.

3. In the Netmask field, type 255.255.255.0.

4. In the Default Gateway IP field, type 192.168.1.1.

5. In the DNS Server IP field, type 192.168.1.1.

6. Click OK.

Add-On Product Installation 1. Ensure that Novell Open Enterprise Server 11 SP1 is 
listed as an add-on product, then click Next.

Clock and Time Zone 1. Select the region and time zone for the server, then click 
Next. The preconfigured VMs are set to use Mountain 
(Denver).

Server Base Scenario 1. Ensure that the Physical Machine option is selected, then 
click Next.

Installation Settings 1. Click Partitioning.

Page Name Action

Preparing Hard Disk: Step 1 1. Select Custom Partitioning (for experts).

2. Click Next.

Expert Partitioner 1. Double-click the VMware virtual disk.

2. Click Add.
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26 On the Installation Settings page, click Software.
Use the following table to navigate and configure the software pages:

27 If you are prompted for additional input during the configuration, accept the default actions.
28 Continue with Setting the Root Password and Updating the Server.

Add Partition on device_name 1. With Primary Partition selected, click Next.

2. In the Custom Size field, type 200 MB, then click Next.

3. Under File System, select Ext2.

4. In the Mount Point drop-down list, select /boot, then click 
Finish.

5. Click Add > Next.

6. In the Custom Size field, type 2048 MB, then click Next.

7. In the File system drop-down list, select Swap, then click 
Finish.

8. Click Add > Next.

9. In the Custom Size field, type 10 GB, then click Next.

10. In the Mount Point drop-down list, ensure that / is selected, 
then click Finish.

11. Click Accept.

Page Name Action

Software Selection and System 
Tasks

1. Under OES Services, select (or confirm the selection of) 
the following:

 Novell CIFS

 Novell eDirectory* 

 Novell iManager

 Novell NCP Server/Dynamic Storage Technology*

 Novell Storage Services*

Services marked with an asterisk (*) are selected when 
you click Novell AFP.

Novell Backup/Storage Management Services (SMS), 
Novell Linux User Management, and Novell Remote 
Manager are all selected by default when any OES 
selections are made, and they are installed on every OES 
11 SP1 server.

2. Click OK.

agfa fonts 1. Click Accept.

Installation Settings 1. Click Install.

Confirm Installation 1. Click Install.

Page Name Action
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A.2.3 Setting the Root Password and Updating the Server

After the initial system configuration and system reboot, the installation needs a password for the 
root user. It also needs to update the system with the latest software.

1 Use the following table to navigate and complete the various configuration pages.

Page Name Action

Password for the System 
Administrator “root”

1. Enter and confirm the password novellfilr, click Next, 
then confirm that you want to use that password.

Hostname and Domain Name 1. In the Host Name field, type oes-11.

2. In the Domain Name field, type filr-lab.example.com.

3. Deselect Change Hostname via DHCP.

4. Click Next.

Network Configuration 1. Click Next.

You configured the network in Section A.2.2, “Installing the 
Server Software,” on page 41.

Test Internet Connection You will need to register your server on the Internet in order to 
download the latest patches, so you should test the Internet 
connection at this point to ensure that everything is configured 
correctly.

1. Select the option to test the connection.

2. Click Next.

Running Internet Connection Test After a few moments, the Test Status should indicate Success.

If it does not, you need to click Back and fix your network 
configuration and the connection to the Internet. It is essential 
that OES 11 SP1 servers always have the latest security and 
other critical patches downloaded and installed.

1. Click Next.

Novell Customer Center Configuration 1. Click Next.

The server establishes a connection with the Novell Customer 
Center.

Manual Interaction Required 1. Click Continue.
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2 Continue with Configuring eDirectory and OES Services.

Novell Customer Center System 
Registration

1. In the fields indicated, type and confirm the email address to 
which you want administrative notifications sent.

2. In the Activation code for SLES components field, type the 
SLES activation code you noted or printed while 
downloading the image files.

If this code is not entered, the server can’t download 
updates and patches through the Novell patch channels. 
For the OES 11 SP1 release, downloading the SLES 
patches is critical for service configuration success.

3. In the Activation code for OES components field, type the 
OES 11 SP1 activation code you noted or printed while 
downloading the image files.

If this code is not entered, the same patch channel 
restriction applies as for SLES.

4. Click Submit.

Your registration information is sent to the Novell Customer 
Center. This might take a couple of minutes to complete.

5. Click Continue.

The update server is added to your system configuration. 
Again, this might take a few minutes.

Novell Customer Center Configuration 
pop-up

1. Click OK.

Online Update Depending on the patches that are in the Update channels, you 
might need to run the update process more than once. 

1. Select Run Update, then click Next.

2. Click Accept. 

3. If you see one or more YaST pop-ups indicating that 
changes have been made to resolve dependencies, click 
Continue.

If you see pop-ups indicating that you have selected 
patches that should be installed later, click Cancel.

The update patches are downloaded and installed.

4. Click Next > OK.

The system restarts.

5. Repeat from Step 2 until no more patches are selected for 
installation.

Network Services Configuration 1. Because the system reboots due to a kernel changes, you 
must type and confirm the root password (novellfilr), then 
click OK.

2. Click Next.

Page Name Action
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A.2.4 Configuring eDirectory and OES Services

For the exercises in this guide, you need specific eDirectory, NTP, and SLP configurations.

1 Use the following table to navigate and complete the eDirectory pages.

Page Name Action

eDirectory Configuration - New or 
Existing Tree

1. In the Tree Name field, type EXAMPLE_TREE.

Notice that the Use eDirectory Certificates for HTTPS Services 
option is selected. This option configures all of the HTTPS 
services (OES and SLES) to use the new eDirectory tree’s 
Organizational CA for certificate management and encryption 
of HTTPS communications. 

For more information on the value that this adds to your 
network, see “Certificate Management” in the OES 11 SP1: 
Planning and Implementation Guide.

2. Click Next.

eDirectory Configuration - New Tree 
Information

1. In the FDN Admin Name with Context field, type 
CN=admin.O=FILR-LAB. 

In this guide, the Admin User object is named admin (all 
lowercase) to differentiate the name from the object itself 
(Admin User), which is a standard eDirectory object and is 
always capitalized in the documentation by convention. 

The eDirectory Admin User object can have any name you 
choose, although most administrators use “admin.”

In this guide, all container objects, such as FILR-LAB, are 
created in uppercase so that they are more easily 
distinguished in the illustrations and procedures.

2. In the Admin Password and Verify Admin Password fields, 
specify novellfilr as the password for the eDirectory 
Admin User.

3. Click Next.

eDirectory Configuration - Local 
Server Configuration

1. Change the server context to OU=IS.O=FILR-LAB.

2. Click Next.

eDirectory Configuration - NTP Time synchronization is required for eDirectory. 

1. Click Add.

2. Type time-a.nist.gov, then click Add.

3. Click Next. 

eDirectory Configuration - SLP 1. Click Next.

2. Click Yes to confirm that SLP is being configured for multicast.

Because this is a single-server tree and for Filr evaluation only, 
further SLP configuration is not needed. 

Novell Modular Authentication 
Services

1. Click Next.
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2 Continue with Setting Up the Graphical User Interface.

A.2.5 Setting Up the Graphical User Interface

Although most Linux servers don’t have a graphical user interface loaded, your OES 11 hands-on 
server runs the GNOME interface by default.

When the Hardware Configuration page appears:

1 Review the Graphics Cards configuration to ensure that your monitor was detected and that 
your color and resolution settings are the way you want them. 
If the settings are correct, skip to Step 3.

2 If the configuration is incomplete or wrong, click the blue links to configure your monitor, color, 
resolution, and so forth.

3 Click Next.
4 When the Installation Completed page appears, deselect Clone This System for Autoyast, then click 

Finish.
5 When the login splash page appears, continue with Accessing iManager.

OES Common Proxy User 
Information

1. Click Next.

This creates a common proxy user for some of the OES 
services you are installing. For more information, see 
“Common Proxy User” in the OES 11 SP1: Planning and 
Implementation Guide.

IMPORTANT: Filr also has proxy users. They are not the 
same as this common proxy user.

Novell Open Enterprise Server 
Configuration

1. Click Next.

The eDirectory and iManager configuration processes can 
take a few minutes, or much longer, depending on the server 
processor speed, and so forth. The other OES services should 
self-configure fairly quickly.

User Authentication Method 1. Click Next.

New Local User The local root user was created during the SLES installation. On 
OES servers, we recommend that all users except root be defined 
in eDirectory. Therefore, you shouldn’t create additional local users.

1. Click Next.

Empty User Login 1. Click Yes.

Release Notes 1. Click Next.

The official OES 11 SP1: Readme is published with the OES 
11 SP1 Online Documentation (http://www.novell.com/
documentation/beta/oes11).

Page Name Action
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A.2.6 Accessing iManager

iManager is the main browser-based tool that is used to manage eDirectory and the OES services. 

To start iManager and prepare your browser for future sessions:

1 On your VMware host workstation, open the OES 11 SP1 Welcome page in your Web browser by 
entering the following URL:
http://192.168.1.100

2 If you receive a security alert, such as a warning that the connection is not trusted, select the 
options to continue, such as I Understand the Risks > Add Exception. Ensure that the option to 
permanently store the exception is selected if available, then confirm the exception.

3 Click the Management Services tab.
4 On the Available Services page, click iManager.

You can also start iManager directly by including /nps after IP_or_DNS in the access URL. For 
example, enter http://192.168.1.100/nps.

5 Log in as the eDirectory Admin user:
5a In the Username field, type admin.
5b In the Password field, type novellfilr.
5c In the Tree field, type 192.168.1.100.

If SLP services were configured and working properly, you could enter the tree name, but 
they are not.

5d Click Login.
6 Do not close iManager. Continue with the next section, Enabling Pop-Ups for iManager.

A.2.7 Enabling Pop-Ups for iManager

Some iManager plug-ins use pop-up dialog boxes that are blocked by most browsers. To use 
iManager, you must enable pop-ups that originate from the servers where iManager is running. 

Firefox

1 On the Firefox menu bar, click Tools > Options > Content.
2 Disable all pop-up blocking by deselecting the Block Popup Windows option and clicking OK. 

or 
Add the hands-on lab server to the list of exceptions by doing the following:
2a Click the Exceptions button.
2b In the Address of Web Site field, type the OES 11 SP1 hands-on lab server’s IP address.
2c Click Allow > Close.

Internet Explorer

1 On the Command bar, click Tools > Pop-up Blocker > Turn Off Pop-up Blocker.
2 Click Yes.
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A.2.8 Where to Go from Here

Continue with Creating Users, Pools, and Volumes.

A.3 Creating Users, Pools, and Volumes
eDirectory is the central, key component of Novell Open Enterprise Server (OES). It provides the 
following:

 Centralized identity management
 The underlying infrastructure for managing your network servers and the services they provide
 Secure access to network services, from within the firewall and from the Web

At this point you have created a new eDirectory tree named EXAMPLE_TREE that you will use to 
learn about Filr. Now you need to create users and configure Novell Storage Services (NSS) for the 
exercises in this guide.

See the following:

 Section A.3.1, “Your Hands-on eDirectory Tree,” on page 49
 Section A.3.2, “Creating Contexts for Your Users,” on page 50
 Section A.3.3, “Assigning a Password Policy to Your Users,” on page 51
 Section A.3.4, “NSS Pools and Volumes,” on page 51
 Section A.3.5, “Creating an NSS Pool,” on page 52
 Section A.3.6, “Creating Users,” on page 53

A.3.1 Your Hands-on eDirectory Tree

Figure A-1 illustrates the basic eDirectory tree that you will now create on your hands-on OES 11 
server. 

Figure A-1   Your Hands-on eDirectory Tree

DEV

OES-11

MRKTG

FILR-LAB

ISadmin SALES

EXAMPLE_TREEA

C

B

D

red

E

pink

blue
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yellow

orange

black

gray

filrproxyuser

FUSERS USERS USERS USERS
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A.3.2 Creating Contexts for Your Users

Figure A-1 illustrates that the users in this hands-on-setup belong to four different organizations that 
are represented by OUs in your eDirectory tree: DEV, IS, MRKTG, and SALES. These OUs are the 
parent containers for the users, and define their contexts within the tree. 

To create the Organizational Unit container objects shown in Figure A-1: 

1 In iManager, click the View Objects icon .
2 In the left pane, click the Tree tab.

3 Click the FILR-LAB Organization object . 
The objects contained in FILR-LAB are listed in the right pane. Notice that the IS OU object 
already exists. This was created when you specified the context of the OES server during the 
installation.

4 Click New, then select Create Object from the drop-down list.
5 From the Available Object Classes list, select Organizational Unit, then click OK.
6 In the Organizational Unit name field, type DEV.
7 Click OK.
8 Click Repeat Task, then repeat from Step 6 to create objects for the MRKTG and SALES 

organizations.

9 Click the DEV Organization object . 
10 Click New, then select Create Object from the drop-down list.
11 From the Available Object Classes list, select Organizational Unit, then click OK.
12 In the Organizational Unit name field, type USERS.
13 Click Repeat Task, then repeat from Step 9 to create USERS Organization Unit objects in the IS, 

MRKTG, and SALES OUs. 

Reference 
Letter Explanation

The Tree object is the top container object in the tree.

The Organization object (FILR-LAB) normally represents your company or organization. 
However, in this case its only purpose is to contain the eDirectory objects and configuration 
information required for the exercises and explanations in this guide.

Every tree requires an Admin User object. You can log in as Admin to manage objects in the 
tree.

filrproxyuser is a system user that reads, writes, creates, and deletes files on file servers in 
behalf of users who have rights via a Share in Filr, rather than native rights on the file 
systems.

FILR-LAB contains four Organizational Unit (OU) container objects (DEV, IS, MRKTG, and 
SALES), each representing a department within the organization. 

Each of these in turn has a USERS OU container.

Unlike its sibling departments, the IS OU also contains the OES-11 object that represents 
the OES 11 SP1 server that all departments use.

A

B

C

D

E

F
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With each iteration, in the Context field replace DEV with one of the other three OUs in turn (IS, 
MRKTG, and SALES) until each contains a USERS OU object.

14 Click OK.
15 Do not close iManager. Continue with the next section, Assigning a Password Policy to Your 

Users.

A.3.3 Assigning a Password Policy to Your Users

In “Configuring eDirectory and OES Services” on page 46, you create a common proxy user and a 
universal password policy named Common Proxy Policy.

For the users to use some of the OES services you have installed, you must associate the Common 
Proxy Policy with those users. The simplest method for doing this is to associate the policy with the 
containers you created in Section A.3.2, “Creating Contexts for Your Users,” on page 50.

NOTE: The Common Proxy Policy is associated with the server’s parent container (IS) by default. If 
all of your users were in the same container as the server or in a subcontainer of it, then the following 
steps would not be needed. However, the DEV, MRKTG, and SALES containers are siblings to the IS 
container in the tree created in this guide, and must be associated with the policy manually.

1 In iManager, click the Roles and Tasks icon .
2 Click Passwords > Password Policies.
3 Click the Common Proxy Policy link.
4 Click the Policy Assignment tab.

5 Click the Browse icon  next to the Assign To field.

6 In the Contents pane, click the down-arrow  next to FILR_LAB.
7 Navigate to and select the USERS objects in the IS, DEV, MRKTG, and SALES Organizational 

Unit objects, then click OK.
8 Click Apply > OK.
9 Do not close iManager. Continue with the next section, Creating an NSS Pool.

A.3.4 NSS Pools and Volumes

OES supports NSS volumes. NSS is a fast-mounting, journaled file system for OES and NetWare. It is 
the only file system in the industry that is integrated with identity management. NSS volumes 
support the Novell File and Directory Trustee Rights model and also NSS file attributes. For more 
information, see The Traditional Novell Access Control Model, in the OES 11 SP1: Planning and 
Implementation Guide.

If you create NCP and NSS volumes before creating users, you can then create home directories at the 
same time as you create the user objects. For that reason, it makes sense to set up the volumes prior to 
user object creation.
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A.3.5 Creating an NSS Pool

NSS volumes are created inside NSS Pools.

1 From your hands-on lab workstation, access iManager, then click the Roles and Tasks icon .
2 Click Storage > Pools.

3 Click the Browse icon  next to the Server field.
4 Browse to and select your hands-on oes-11 object (in FILR-LAB > IS).
5 Click New.
6 Name the pool filr_pool, then click Next.
7 Click the box next to the system disk in your server (sda). 
8 By default, all free space on the disk (~7.8 GB) should automatically be entered in the Used Size 

field, and the amount should match the Free Size (MB) displayed to the right of the system disk. 
If the Used Size field is blank, type the free space amount.

9 Click Finish.
FILR_POOL is listed as an available pool. Notice that the NSS pool name is uppercase, even 
though you typed lowercase. All NSS pools and volumes are created and displayed in uppercase 
to give a visual distinction from the Linux POSIX lowercase norm, to prevent visual confusion of 
letters and numbers (vol1 vs. VOL1), and because names are case-insensitive on NSS.

Creating NSS Volumes

1 After the pool appears in the list, continue in the Storage task by clicking Volumes in the left 
frame. Then use the information below to create five NSS volumes on your server.

2 Click New.
3 In the Name field, type the first volume name listed in Step 1, then click Next.
4 Click the box next to FILR_POOL, then deselect Allow volume quota to grow to the pool size.
5 Type the volume quota in the Volume Quota field, then click Next > Finish.

The volume is listed.
6 Repeat from Step 2 until all volumes have been created.
7 Do not close iManager. Continue with the next section, Summary of Hands-on Volumes and 

Purposes.

Volume Name Volume Quota in GB

HOME 3

DEV 1

IS 1

MRKTG 1

SALES 1
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Summary of Hands-on Volumes and Purposes

Your hands-on OES 11 server now has five volumes.

 HOME: This volume is the personal workspace for all users in the FILR-LAB organization. 
When you provision users in Filr, some of their My Files workspaces point to directories on this 
volume. 

 DEV, IS, MRKTG, and SALES: These volumes contain their respective department’s folders 
and files. Access is generally limited to members of the department. Access to certain folders 
and files is limited according to roles within the department. When you set up Filr, you create 
Net Folders in Filr that point to directories that they contain.

A.3.6 Creating Users

For the hands-on exercises, you need to create the users shown in Table A-1. 

Table A-1   Users to Create

To create the users:

1 In iManager, in the left pane, click Users > Create User.
2 In the Username field, type a user name from Table A-1. 

For the first user, this is red.
3 Type the first name and last name for the user, as shown in Table A-1.

4 Click the Browse icon  next to the Context field.
5 Browse to the context indicated for the user, then click the OU object.
6 Type the password listed in both the Password field and the Retype Password field.

None of the exercises require unique passwords, so for simplicity, we use the same password for 
each user except filrproxyuser, as indicated in the table.

User Name First Name Last Name eDirectory Context 
within FILR-LAB Password Home 

Directory

red M Red DEV/USERS filrrocks Yes

pink M Pink DEV/USERS filrrocks No

blue M Blue IS/USERS filrrocks Yes

green M Green IS/USERS filrrocks No

yellow M Yellow MRKTG/USERS filrrocks Yes

orange M Orange MRKTG/USERS filrrocks No

black M Black SALES/USERS filrrocks Yes

gray M Gray SALES/USERS filrrocks No

filrproxyuser Filr Proxyuser (directly in FILR-LAB 
with the eDir Admin 
user)

novellfilr

IMPORTANT: the 
password for this user is 
novellfilr, not 
filrrocks.

No
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7 If the Home Directory column is marked No, skip to Step 8. Otherwise, select the Create Home 
Directory option and browse  to the oes-11_HOME volume (in the IS OU). 

For the third and other odd-numbered users, you can use the object-history icon  to select the 
context rather than browsing.

8 Click OK.
9 Click Repeat Task to repeat the process until the other users listed in Table A-1 on page 53 are 

created.
10 Do not close iManager. Continue with Setting Up Novell CIFS.

A.4 Setting Up Novell CIFS
Novell CIFS lets Windows users access NSS volumes on Novell Open Enterprise Server 11 SP1 
servers exactly as they would access a Windows file server. For some organizations, CIFS (Common 
Internet File System) is preferred over NCP (NetWare Core Protocol) because it doesn’t require the 
installation of Novell Client software. 

Filr enables mobile device access to files through both the CIFS and the NCP file protocols.

See following:

 Section A.4.1, “Overview of Novell CIFS,” on page 54
 Section A.4.2, “Setting the Search Context,” on page 55
 Section A.4.3, “Making Novell CIFS Shares Available to CIFS Users,” on page 55
 Section A.4.4, “Novell CIFS Users’ Access Rights,” on page 56

A.4.1 Overview of Novell CIFS

Figure A-2 illustrates the file services available through Novell CIFS in OES. 

For more information on Novell CIFS file services in OES 11 SP1, see Novell CIFS Implementation 
and Maintenance in the OES 11 SP1: Planning and Implementation Guide.
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Figure A-2   Novell CIFS

A.4.2 Setting the Search Context

By default, the search context for CIFS users is set to the container where the OES 11 SP1 server is 
installed (IS in this case). The assigned proxy user searches in this context for users seeking access to 
the CIFS file service. You must set a context that points to the other containers where your User 
objects are located.

1 In iManager, click Roles and Tasks, then click File Protocols > CIFS.
2 Click the Browse icon next to the Server field, then browse to and select the oes-11 lab server (in 

the IS container).
3 Click the Context tab.
4 Click Add.
5 Browse to and select the USERS container in DEV, then click OK.
6 Repeat from Step 4 to add the USERS containers in IS, MRKTG, and SALES containers.
7 Continue with the next section.

A.4.3 Making Novell CIFS Shares Available to CIFS Users

By default, all NSS volumes hosted on an OES server have shares associated with them. These shares 
point to the root of the volume. 

If a volume is created while the Novell CIFS service is running, the service must be restarted to 
discover the volume.

1 Click the Shares tab.
2 If the five shares are listed (one for each volume), skip to Novell CIFS Users’ Access Rights. 

If not, continue with Step 3.
3 Click the General tab, then click Stop. The service status changes to Stopped.

Any CIFS/SMB Client
(such as Windows Explorer)

Web Folders
(Windows Explorer or

Internet Explorer browser)

eDirectory
LDAP server

OES server

Access Points Authentication CIFS File Services

eDirectory users have 
automatic access 
to the Novell CIFS 
server.

Novell
CIFS server

WebDAV

CIFS
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4 Click the Start sub-tab. The service status changes to Running.
5 Click the Shares tab.

The five shares are listed.
6 Continue with Novell CIFS Users’ Access Rights.

A.4.4 Novell CIFS Users’ Access Rights

As illustrated in Figure A-2 on page 55, all eDirectory users have automatic access to the Novell CIFS 
file service, assuming that the service is configured correctly. 

However, access to the CIFS file service does not equate to access to the NSS file system and the 
folders and files that it contains. It is the Novell File and Directory Trustee Rights model that 
provides this access. It also ensures that users can see only those files and folders to which they have 
access rights, including when they use Filr for access.

Continue with Preparing Files for the Hands-on Exercises.

A.5 Preparing Files for the Hands-on Exercises
After installing and configuring the OES-11 server and its required services, you need to create files 
and folders on the server in order to use in the exercises in this guide. See the following sections:

 Section A.5.1, “Creating Files and Folders,” on page 56
 Section A.5.2, “Uploading the Files to the OES 11 Server,” on page 59
 Section A.5.3, “Assigning File and Folder Trustee Rights,” on page 59
 Section A.5.4, “Proxy User Rights to Volume Objects,” on page 60

A.5.1 Creating Files and Folders

Refer to Figure A-3 and Table A-2 as you create the folders and files that will be used for the exercises.
56 Novell Filr: Hands-on Guide for OES



Figure A-3   Files and Folders on the Hands-on OES 11 Server
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Table A-2   Folder Structure to Create on the OES Server

1 In iManager, click Roles and Tasks > Files and Folders > New Folder.

2 Click the Browse icon  next to the Path field.
3 In the Contents pane, navigate to FILR-LAB > IS > oes-11_DEV.
4 In oes-11_DEV, click the \\oes-11\DEV: link.

IMPORTANT: As you follow these steps, remember that the targets you are selecting are all 
found in the IS Organizational Unit object container and within their respective volume 
containers, such as oes-11_DEV. 
Unless you keep the structure of EXAMPLE_TREE in mind, it’s easy to get confused and try to 
find the DEV volume object in the DEV container.

5 In the Folder Name field, type personnel, then click OK.
6 Click Repeat Task.

7 Click the Browse icon  next to the Path field, then browse to and click the link to the personnel 
folder that you just created.

8 In the Folder Name field, type reviews, then click OK.
9 Repeat the applicable steps until you have created the folders shown in Figure A-3 and Table A-

2.
10 When you have created all of the folders, click OK.
11 Continue with Uploading the Files to the OES 11 Server.

Volume Name Subfolder Structure

DEV personnel

personnel\reviews

personnel\reviews\mpink

personnel\salaries

projects

projects\current

projects\future

IS training

training\quick_starts

MRKTG advertising

advertising\brochures

budget

budget\requests

SALES revenue

revenue\projections

revenue\quotas
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A.5.2 Uploading the Files to the OES 11 Server

1 Download the user exercise files from the Filr Documentation Site and unzip the archive, which 
contains the files shown below.

Table A-3   Files and Locations

2 In iManager, click Roles and Tasks, then click Files and Folders > Upload.

3 Click the Browse icon  next to the Path field, then navigate to the first path shown in Table A-3 
on page 59.

4 Browse to and click the link to the mpink folder.
5 Click Browse and navigate to the mpink_2013.odt file that you downloaded in Step 1, then click 

OK.
6 Click Repeat Task, then repeat from Step 3 and navigate to the second path, and so on, until all of 

the files that you created are uploaded to their proper folders.
7 Continue with Assigning File and Folder Trustee Rights.

A.5.3 Assigning File and Folder Trustee Rights

Filr access to files and folders is ultimately controlled by the rights on the file system. Therefore, you 
now need to assign the eDirectory users as trustees to the files and folders on the OES-11 server 
volumes.

1 Assign the managing users Supervisor rights to their respective volumes:
1a In iManager, click Roles and Tasks, then click Files and Folders > Properties.

1b Click the Browse icon  next to the Name field.
1c In the Contents pane, navigate to FILR-LAB > IS > oes-11_DEV.
1d Click the \\oes-11\DEV: link.
1e Click OK.
1f Click the Rights tab.

1g Click the Browse icon  next to the Add Trustee field.
1h Browse to FILR-LAB > DEV > USERS, then click the link for user red.

File Name Path to File

mpink_2013.odt DEV:personnel\reviews\mpink

2014.ods DEV:personnel\salaries

abc_reqr.odt DEV:projects\current

xyz_reqr.odt DEV:projects\future

Novell-Filr.pdf IS:training\quick_starts

abc_flyer.pdf MRKTG:advertising\brochures

fy_2014.ods SALES:revenue\projections

fy_2013.ods SALES:revenue\quotas
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1i Click OK.
1j In the Trustees panel, select the S (Supervisor) option. If desired, you can deselect W (Write) 

and F (File Scan) because S includes those rights.
1k Click Apply > OK.
1l Repeat from Step 1a and assign the following rights:

 User blue as Supervisor on volume IS.
 User yellow as Supervisor on volume MRKTG.
 User black as Supervisor on volume SALES.
 User filrproxyuser as Supervisor on DEV, HOME, IS, MRKTG, and SALES.

2 Continue with Proxy User Rights to Volume Objects.

A.5.4 Proxy User Rights to Volume Objects

The filrproxyuser needs Read rights to each volume object. Because filrproxyuser is in the FILR-LAB 
container above the volume objects, and therefore has Read rights to the objects, no additional action 
is required.

Continue with Installing and Configuring the Filr Appliance.

A.6 Installing and Configuring the Filr Appliance
For the hands-on exercises, Filr is installed using a small configuration. This means that Filr, the 
MySQL database, and the Lucene search server are installed together on the same virtual machine.

A.6.1 Downloading the Filr Files

To download Filr from the Web:

1 If you don’t already have a Novell account, register for one on the Web (https://secure-
www.novell.com/selfreg/jsp/createAccount.jsp?).

2 Access the Novell Downloads Web page (http://download.novell.com).
3 Do a keyword search for Novell Filr.
4 In the Results section, click Novell Filr Evaluation.
5 Click the proceed to download button (upper-right corner of the first table).
6 If you are prompted to log in, type your Novell Account > username and password, then click login.
7 Accept the Export Agreement (required for first downloads only), and answer the survey 

questions about your download (optional).
8 Print the download page. You need the listed MD5 verification numbers in order to verify your 

downloads.
9 Scroll down to the Download Instructions section, then click the Download Instructions link.

10 Print the Download Instructions page for future reference.
11 Verify the integrity of each downloaded file by running an MD5-based checksum utility on it 

and comparing the values against the list that you printed in Step 8.
For example, on a Linux system you can enter the following command:
md5sum Filr.x86_64-0.0.version.ovf.zip
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For a Windows system, you need to obtain a Windows-compatible MD5-based checksum utility 
from the Web and follow its usage instructions.

12 Continue with Deploying Filr.

A.6.2 Deploying Filr

1 Download the .zip file to your VMware virtual machine location. 
2 Extract the .zip file until you have a folder containing three files with .mf, .ovf, and .vmdk 

extensions.
3 On VMware workstation, open the .ovf file. 

To see the .ovf file listed, you might have to change the filter (by the File name field) to display 
all image files.

4 Change the VM name as shown, then click Import.

Filr is imported.

5 Click Edit virtual machine settings.

6 In the Hardware list, select Memory, then reduce the memory allocation to 4 GB. 
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7 In the Hardware list, select Hard Disk (SCSI), then click Add > Next.

8 Click Next > Next > Next > Next > Finish.
A second 20 GB hard disk is added.

9 In the Hardware list, click Network Adapter, then select NAT.
62 Novell Filr: Hands-on Guide for OES



10 Click OK.
11 Click Power on this virtual machine.

12 After the appliance starts, read and Accept the license agreement.
13 Complete the initial configuration settings, as shown in the screen shot below. 

All administrative passwords are novellfilr. (In the actual dialog, passwords are obfuscated 
by asterisks (*).) 

IMPORTANT: Ensure that the Time Zone settings match the settings of the OES 11 server that 
you specified in Step 24 on page 42.
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14 Click Next.
15 You created a second hard disk in Step 8, so click Next > Next > Next.
16 After the initial configuration process completes, you are instructed to open a browser and 

proceed with the configuration. 
17 Continue with Configuring the Filr Appliance.

A.6.3 Configuring the Filr Appliance

1 In your management browser, enter the following URL: https://192.168.1.110:9443.
2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and Password: novellfilr.
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4 Click the Novell Appliance Configuration icon.

5 Ensure that Small Deployment is selected, then click Next.
A Small Deployment has all three Filr services (Filr, Search, and MySQL) running on the same 
appliance.
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6 Specify and confirm novellfilr as the root user password, then click Next.

7 Click Finish.
8 Wait until the appliance restarts, then continue with Adjusting the Java Heap Size.

A.6.4 Adjusting the Java Heap Size

By default the Java Heap Size is set to 4 GB. However, you have reduced the default memory (RAM) 
allocation for the appliance to 4 GB, so the heap size must also be set lower.

1 If needed, log in to the appliance management console again (https://192.168.1.110:9443) and 
click the Novell Appliance Configuration icon.
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2 Click Java JDK.
3 Change the Java Heap Size to 2g, then click OK.

As a general rule, the heap size should be about 2 GB less than the total RAM assigned to the 
virtual appliance.

4 In the left panel, click Reconfigure Filr Server.
5 After the appliance reconfigures, continue with Securing LDAP Synchronization between the 

Filr VA and the OES Server.

A.6.5 Securing LDAP Synchronization between the Filr VA and the OES 
Server

1 Generate a root certificate for the eDirectory tree:

1a In iManager, click the Roles and Tasks icon . 
1b Click Novell Certificate Server > Configure Certificate Authority.
1c Click the Certificates tab, then select the check box for the self-signed certificate.
1d Click the Validate sub-tab, select the check box again, then click the Export sub-tab.
1e Deselect Export Private Key.

The Export Format changes to DER.
1f Click Next.

1g Click Save the Exported Certificate > OK, then save the file to disk. Change the file name to 
something that you’ll remember and note the location.

1h Click Close > OK.
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2 Import the certificate into the Java Keystore:
2a In the Filr Console, upper-right corner, click the Home link.
2b Click the Appliance System Configuration icon.

2c Click the Digital Certificates icon.

2d Click File > Import > Trusted Certificate.
2e Browse to the certificate file that you saved in Step 1g on page 67, then click Open.
2f Click OK > Close.

2g Click Reboot > OK > OK.

As soon as the Filr appliance restarts, both the OES server and Filr are prepared for the exercises in 
Chapter 3, “Filr Hands-on Administration Exercises,” on page 11.
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B BDocumentation Updates

This section summarizes the changes made to this guide since the initial release of Novell Filr.

June 7, 2013

Various Renamed the VM download files and changed the download 
location and instructions associated with them. 
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