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About This Guide

This guide describes the functionality and usage of the utilities included in the Novell Server 
Consolidation and Migration toolkit.

IMPORTANT: For NetWare to Open Enterprise Server 2 Linux migration, see the OES 2 SP3: 
Migration Tool Administration Guide.

 Part I, “Overview,” on page 9

 Part II, “Getting Started,” on page 23

 Part III, “Server Consolidations,” on page 31

 Part IV, “Server Migrations,” on page 79

 Part V, “Supplemental Information,” on page 107

 Appendix A, “Documentation Updates,” on page 115

Audience

This guide is intended for network installers and administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. To contact us, use the User Comments feature at the bottom of any page 
in the online documentation. 

Documentation Updates

For the most recent version of the Novell Server Consolidation and Migration Toolkit 
Administration Guide, see the Novell Product Documentation Web site (http://www.novell.com/
documentation).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX, should use forward slashes as required by your software.
About This Guide 7
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IOverview

 Chapter 1, “Server Consolidation and Migration Overview,” on page 11

 Chapter 2, “What’s New,” on page 19
Overview 9
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1Server Consolidation and 
Migration Overview

The Novell Server Consolidation and Migration Toolkit 1.2 combines the Novell Server 
Consolidation Utility 4.2 and the NetWare Migration Wizard 8.2 under a single launch interface. 
This interface asks you what type of consolidation or migration project you want to perform and 
then launches the appropriate utility automatically.

 Server Consolidation Utility is a file-and-print consolidation tool to help you copy data 
between existing servers, including NetWare and Windows servers, and migrate network 
printers. The automation provided by the Server Consolidation Utility eliminates the need to 
choose from various third-party utilities that would help you perform these tasks individually.

 NetWare Migration Wizard migrates the file system data and eDirectory (formerly NDS) 
database from an existing NetWare server to a faster, more reliable NetWare server. After the 
data is copied, the old server is brought down and the new server assumes its identity.

IMPORTANT: For NetWare to Open Enterprise Server 2 Linux migration, see the OES 2 SP3: 
Migration Tool Administration Guide.

This section provides an overview of server consolidation and migration to help you understand how 
the utilities in the toolkit work. It also provides some example scenarios of how you can use these 
utilities to consolidate or migrate your network resources.

 Section 1.1, “Consolidation Overview,” on page 11

 Section 1.2, “Migration Overview,” on page 14

 Section 1.3, “Supported Source and Destination Server Versions,” on page 16

For a list of new features and enhancements to the versions of Server Consolidation Utility and 
NetWare Migration Wizard included in the toolkit, see Chapter 2, “What’s New,” on page 19.

1.1  Consolidation Overview
The Novell Server Consolidation Utility is a file-and-print consolidation tool that helps you 
reorganize your network by copying data from any number of existing source servers to any number 
of destination servers. By consolidating data onto newer, more powerful servers, you can simplify 
your network administration processes and lower your IT costs.

The Server Consolidation Utility automates key tasks, such as migrating users and their trustee 
assignments, assigning passwords, and migrating the NetWare or Microsoft Windows NT file 
system data to NetWare servers in an eDirectory tree. This automation eliminates the need to choose 
from various utilities that would help you perform these tasks individually.

IMPORTANT: If you want to migrate NetWare data from old hardware that is being replaced, use 
the NetWare Migration Wizard that is included in the Server Consolidation and Migration Toolkit. 
For more information, see Part IV, “Server Migrations,” on page 79.
Server Consolidation and Migration Overview 11
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This section describes how the Server Consolidation Utility works and provides some example 
scenarios of how you can use it to consolidate your data.

1.1.1  Server Consolidation Projects

The Server Consolidation Utility is a versatile tool that lets you perform a variety of consolidation 
projects.

NetWare-to-NetWare Consolidations

For NetWare to NetWare consolidations, you can reorganize your network by copying data from any 
number of existing NetWare source servers to any number of NetWare destination servers. The 
accompanying rights, trustees, ownership, and name space information are copied to the destination 
server along with the files.

You can copy entire volumes or specific directories between servers in the same eDirectory tree or in 
different eDirectory trees. The source server can even be the same as the destination server.

NDPS Printer Agent Consolidations

As part of a NetWare-to-NetWare consolidation, you can reassign several Novell Distributed Print 
Services (NDPS) Printer Agents to a single NDPS Print Manager within the same tree. This 
simplifies your network printing configuration.

Windows-to-NetWare Consolidations

You can also use the Server Consolidation Utility to copy data from servers in Windows NT or 
Windows 2000/2003 domains to NetWare servers in Novell eDirectory trees. NTFS permissions and 
ownership information are converted to NetWare equivalents and transferred along with the 
necessary users and groups.

1.1.2  Drag-and-Drop Modeling

With the Server Consolidation Utility, you model your consolidation project using drag-and-drop 
procedures.

The utility’s main project window displays the source tree on the left-hand side and the destination 
tree on the right-hand side. To model your project, you simply drag folders or entire volumes from 
the source pane and drop them to the desired location in the destination pane. This gives you a visual 
representation of how the data will be organized on the destination servers. 

No data is actually copied during the modeling phase, so you are free to rearrange the data structure 
until you are satisfied with it.

When you are ready to proceed with the data copy, the Server Consolidation Utility performs a pre-
copy verification of the project. This helps prevent errors from interrupting your server 
consolidation and allows you to correct mistakes before data is copied to the destination servers. 

1.1.3  Example Consolidation Scenarios

The benefits the Server Consolidation Utility provides can be better understood through examining 
some sample consolidation scenarios.
 Server Consolidation and Migration Toolkit Administration Guide
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Basic Server Consolidation: Many-to-One

In the first scenario (see Figure 1-1), suppose you have three existing NetWare servers. You recently 
purchased a multiprocessor server that you want to install NetWare on to take advantage of 
NetWare's multiprocessor-enabled features. You want to copy the data from each of the three servers 
to the single NetWare server. Rather than manually moving all the data and Printer Agents, or 
backing up the data on each of the three servers and then restoring it to the NetWare server, you can 
use the Server Consolidation Utility to automate the process.

Figure 1-1   Many-to-One Server Consolidation

Although Figure 1-1 shows the servers all in the same eDirectory tree, the Server Consolidation 
Utility lets you do tree-to-tree consolidations as well.

Consolidating Data from Multiple Servers onto a Two-Node Cluster

In the second scenario (see Figure 1-2), suppose you have five existing NetWare servers. You 
recently purchased two multiprocessor servers and the necessary hardware to create a two-node 
cluster complete with an attached Storage Area Network (SAN). You have decided to install 
NetWare on the two-node cluster because NetWare comes with Novell Cluster Services software 
and a two-node cluster license. You want to copy the data from each of the five servers to the SAN 
on the two-node cluster. Rather than manually moving all the data and Printer Agents or backing up 
the data and restoring it to the SAN, you can use the Novell Server Consolidation Utility, which 
automates the data migration process.

Server 1 Server 2 Server 3

Data Migration

Data
Volumes

eDirectory Tree

MP Server
Server Consolidation and Migration Overview 13
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Figure 1-2   Cluster Server Consolidation

Cross-Platform Data Consolidations

As mentioned previously, the Server Consolidation Utility lets you copy data from Windows servers 
in a Windows NT domain or Windows 2000/2003 Mixed Mode domain to servers in a Novell 
eDirectory tree.

You can use the Server Consolidation Utility to copy data between the following server platforms:

 NetWare to NetWare

 Windows NT/2000/2003 to NetWare

1.2  Migration Overview
The NetWare Migration Wizard is a server data and identity migration tool to help you transfer file 
system data and the NDS/eDirectory database from an existing NetWare server to a new NetWare 
server on your network. When the migration is complete, the new server replaces and assumes the 
identity of the old server on the network.

NetWare Migration Wizard version 8.x supports migrations from NetWare 4, NetWare 5, or 
NetWare 6 source servers. Destination servers must be running NetWare 6.5.

You can create a migration project to do the following:

 Migrate file system data and NDS/eDirectory information from an existing NetWare server to a 
new NetWare server. Although you can use the Migration Wizard to reorganize the server data 
and resize volumes, it is best suited for migrations requiring a minimal amount of volume 
reorganization.

 Transfer file system and eDirectory information from an old NetWare server that is scheduled 
to be decommissioned to a faster, more reliable server running the latest version of NetWare. 
This is an easy way to upgrade a server’s OS and hardware at the same time.

NetWare Migration Wizard handles only NetWare-to-NetWare migrations.

Server 1 Server 2 Server 3 Server 4 Server 5
Cluster
Server 1

Cluster
Server 2

Fiber 
Channel
Switch

Data Migration

Shared Disk
System

Data
Volumes

Two Node ClusterFive NetWare Servers

eDirectory Tree
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IMPORTANT: If you want to migrate data from servers in Microsoft Windows domains, or 
consolidate data from one or more NetWare servers to existing NetWare servers, or Novell Branch 
Office servers, use the Novell Server Consolidation Utility that is included as part of the Server 
Consolidation and Migration Toolkit.

This section describes what NetWare Migration Wizard is and how you can use it to migrate data 
from an existing NetWare server to a new NetWare 6.5.

1.2.1  About NetWare Migration Wizard

NetWare Migration Wizard is designed to help you transfer the identity of one server to another 
server. This is what is referred to as a server hardware upgrade. 

NOTE: If you want to add a new server with a new name into your network, you wouldn't use the 
Migration Wizard; you would use the NetWare server installation program.

NetWare Migration Wizard is an ideal tool for moving existing NetWare data onto faster, more 
reliable server hardware. It is a Windows-based program that you run on a workstation. With the 
Migration Wizard, you model your migration project using simple drag-and-drop procedures before 
you actually perform the migration. This helps prevent errors from interrupting your data migration 
and allows you to prevent mistakes before they happen. 

You can also take advantage of this modeling capability to reorganize the data on your server and 
even resize volumes, if needed. However, Migration Wizard is best suited for migrations requiring a 
minimal amount of volume reorganization. 

As you work through the modeling phase of NetWare Migration Wizard, all of your decisions are 
recorded in a migration project file. At any time during the modeling process, you can save the 
project file, exit the utility, and then restart Migration Wizard and resume from where you left off.

After the modeling phase is completed, you can proceed with the actual migration. This process is 
divided into four basic steps:

 Step 1: Copy File System Data.

Using the data contained in the migration project file, Migration Wizard copies the files and 
folders (or even entire volumes) you selected from the source server to a newly installed 
destination server. All file system data, including meta-data such as file trustees, ownerships 
and attributes, is copied from the old machine to the new one.

 Step 2: Edit Configuration Files.

During this step, Migration Wizard presents configuration files such as autoexec.ncf and 
startup.ncf side-by-side so you can easily copy commands and settings from the source server's 
configuration files to matching files on the destination server.

 Step 3: Begin NDS/eDirectory Migration.

The NDS/eDirectory files are transferred from the old server to the new one without any 
additional work on your part. After the migration, the eDirectory partitions that existed on the 
old server will exist on the new server. This is because the Migration Wizard backs up the 
entire eDirectory database on the source server and then restores it on the destination server. 
Server Consolidation and Migration Overview 15
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 Step 4: Finish NDS/eDirectory Migration.

After the source server’s file system and NDS/eDirectory database are migrated to the 
destination server, the source server is automatically brought down and the destination server 
reboots and assumes the name and identity of the source server on your existing network.

Before you can migrate your data, you must first install a destination NetWare server in a temporary 
eDirectory tree (see Figure 1-3). A temporary eDirectory tree is simply a tree that contains one 
server with a pre-migration installation of NetWare and no additional products installed (other than 
SMS and other products installed by default).

Figure 1-3   Server Hardware Upgrade with NetWare Migration Wizard 

Migration Wizard automatically modifies the destination server’s autoexec.ncf file to include the 
source server’s name and internal IPX number/server ID. You don't have to modify these manually. 
Because the server's identity has been transferred from one physical server to another, you don't 
need to upgrade any client applications that might be doing drive mappings or running applications 
based on the server name. However, you do have to manually change the IP address of the 
destination server to match that of the source server.

Migration Wizard does not migrate any products and services that are running on the source server. 
After the migration is complete, you need to reinstall all applications on the destination server and 
reconfigure them, if necessary.

1.3  Supported Source and Destination Server 
Versions
The utilities included in this release of the Server Consolidation and Migration Toolkit support the 
source and destination server configurations listed below. These minimum server versions, and all 
newer versions, have been tested and are supported by Novell. Older server versions might work, 
but they have not been tested with this release of the toolkit. Novell recommends that all servers be 
updated to the latest Support Pack before attempting a consolidation or migration.

Server Consolidation and Migration Toolkit does not support eDirectory 8.8. If you want to upgrade 
to eDirectory 8.8, perform migration or consolidation first, then upgrade the newly-migrated servers 
to eDirectory 8.8.
 Server Consolidation and Migration Toolkit Administration Guide
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1.3.1  Server Consolidation Utility

The following NetWare and Windows configurations have been tested as source and destination 
servers with Server Consolidation Utility 4.2.

Table 1-1   Supported Source Server Versions for Server Consolidation Utility 4.2

IMPORTANT: Full support for Windows 2000/2003 Server Active Directory migrations is not 
available in the toolkit. The toolkit uses the Mixed Mode domain levels to access an Active 
Directory domain as if it were a flat NT domain. You will not be able to access certain aspects of 
Active Directory, such as trust relationships.

Table 1-2   Supported Destination Server Versions for Server Consolidation Utility 4.2

1.3.2  NetWare Migration Wizard

The following NetWare configurations have been tested as source and destination servers with 
NetWare Migration Wizard 8.2.

Minimum Supported (Tested) OS Version Other Requirements

NetWare 4.2

Minimum DS: NDS 6.21

To NetWare only; IPX must be loaded on the 
destination server.

NetWare 5.0 SP6a

Minimum DS: NDS 7.62c or 8.85c

To NetWare only; TCP/IP must be loaded on 
the source server.

NetWare 5.1 SP8 or later

Minimum DS: NDS 7.62c or 8.85c

NetWare 6.0 SP5 or later

Minimum DS: eDirectory 8.6.2

NetWare 6.5 SP2 or later

Minimum DS: eDirectory 8.7.x

NetWare (NetWare 6.5 SP3 or later)

Minimum DS: eDirectory 8.7.x

Windows NT 4.0 Server SP6a

Windows 2000 Server SP4 Domain functional level must be Mixed Mode.

Windows 2003 Server SP1 Domain functional level must be Windows 
2000 Mixed Mode.

Minimum Supported (Tested) OS Version Other Requirements

NetWare SP1 or later (NetWare 6.5 SP4 or later)
Server Consolidation and Migration Overview 17
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Table 1-3   Supported Source Server Versions for NetWare Migration Wizard 8.2

Table 1-4   Supported Destination Server Versions for NetWare Migration Wizard 8.2

NOTE: If you want to migrate NetWare servers running eDirectory 8.8 SP2, you must update both 
source and destination servers to NetWare 6.5 SP7 or later. Otherwise, the destination server fails to 
reboot after the third step of the migration.

Minimum Supported (Tested) OS Version Other Requirements

NetWare 4.2

Minimum DS: NDS 6.21

IPX must be loaded on the client workstation

NetWare 5.0 SP6a

Minimum DS: NDS 7.62c or 8.85c

NetWare 5.1 SP8 or later

Minimum DS: NDS 7.62c or 8.85c

NetWare 6.0 SP5 or later

Minimum DS: eDirectory 8.6.2

NetWare (NetWare 6.5 SP3 or later)

Minimum DS: eDirectory 8.7.x or 8.8 SP2

Minimum Supported (Tested) OS Version Other Requirements

NetWare SP1 or later (NetWare 6.5 SP4 or later)

Minimum DS: eDirectory 8.7.x or 8.8 SP2
 Server Consolidation and Migration Toolkit Administration Guide
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2What’s New

This chapter lists the new features and enhancements in recent versions of the utilities included in 
the Novell Server Consolidation and Migration Toolkit. Novell recommends that you use the latest 
release.

2.1  What's New in the Toolkit
The Server Consolidation and Migration Toolkit 1.2 combines updated versions of two formerly 
separate utilities:

 Novell Server Consolidation Utility 4.2

 NetWare Migration Wizard 8.2

The toolkit provides a single launch interface that asks you what type of consolidation or migration 
project you want to perform and then launches the appropriate utility automatically.

2.2  What’s New in the Server Consolidation 
Utility
This section lists the new features and enhancements in recent versions of the Server Consolidation 
Utility.

2.2.1  Server Consolidation Utility 4.2

Server Consolidation Utility 4.2 includes minor bug fixes.

2.2.2  Server Consolidation Utility 4.1

Server Consolidation Utility 4.1 includes the following new and enhanced features:

 The new unattended server-based processing feature gives you the flexibility of running the file 
copy process in unattended mode from the server, instead of having the Server Consolidation 
Utility monitor the process from your workstation. 

 The Server Consolidation Utility now supports filenames, folder names, and usernames 
containing double-byte or extended ASCII characters encoded via UTF-8. 

2.2.3  Server Consolidation Utility 4.0

Server Consolidation Utility 4.0 adds two significant new features:

 You can consolidate data from NetWare and Windows servers to servers running on either 
NetWare 6.5.

 When consolidating file system data from NT servers, the Server Consolidation Utility now 
copies ownerships for NTFS files and folders in addition to copying the permissions.
What’s New 19
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2.2.4  Server Consolidation Utility 3.0

Version 3.0 includes two new features.

 A new command line option is available for scheduling the utility to run at a predetermined 
date and time. Adding an N after the passwords instructs the utility to skip the Error and 
Success Log review dialog and simply exit the application after it finishes.

 Novell ZENworks 6.5 creates an NT Roaming Profile directory the first time an NT user logs 
into his or her eDirectory account on NetWare. The time-consuming process of having the 
Server Consolidation Utility copy the NT Profile directory is no longer needed and has been 
removed.

2.2.5  Server Consolidation Utility 2.6

New features in version 2.6 let you:

 Exclude specific file types or filenames from the copy process

For example, copy all of the data from a volume except for any .mp3 files.

 Automatically compare file information between the source and destination after the copy 
process completes to validate the integrity of the file copy

This includes the option of doing a detailed binary (byte-by-byte) comparison.

 Check for sufficient disk space on the destination server before beginning the file copy

 Disable login on the source server during the copy process

 Specify a default server and home directory path for any new users you create on the 
destination server

 Copy an expanded list of user attributes when creating users

2.2.6  Server Consolidation Utility 2.0

With version 2.0, you could copy volumes and specific directories between different eDirectory 
trees, as well as consolidate to NetWare 6.5. Version 2.0 also let you:

 Copy data from NT 4.0 Domains to NetWare

 Schedule projects and run them completely unattended

 Filter the files you want to copy based on date

 Add users to Novell eDirectory on the destination tree if they don’t already exist

 Copy data to the Novell Branch Office server

2.2.7  Server Consolidation Utility 1.0

With NetWare Server Consolidation Utility version 1.0, you could copy entire volumes and specific 
directories between NetWare 4, NetWare 5, and NetWare 6 servers in the same eDirectory tree. 

2.3  What’s New in the NetWare Migration Wizard
This section lists the new features and enhancements in recent versions of the NetWare Migration 
Wizard.
 Server Consolidation and Migration Toolkit Administration Guide
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TIP: Each new release of NetWare Migration Wizard includes performance enhancements and bug 
fixes that increase the speed and reliability of NetWare migrations. If you have had unsatisfactory 
results with early versions of this utility, we encourage you to give the latest version a try.

2.3.1  NetWare Migration Wizard 8.2

NetWare Migration Wizard 8.2 includes the following new features:

 This release supports NetWare servers running eDirectory 8.8 SP2.

 This release includes minor bug fixes.

2.3.2  NetWare Migration Wizard 8.1

NetWare Migration Wizard 8.1 includes the following new and enhanced features:

 The ability to perform a full backup of all the source server’s trustees has been removed from 
the NetWare Migration Wizard. This confusing and time-consuming step is not necessary as 
long as you do a full backup of your source server.

You can still choose to back up trustees for the files you are migrating.

 Migration Wizard 8.1 now supports NetWare 4.x and NetWare 5.0 as source servers. This 
functionality was previously available only in Migration Wizard 6.5.

2.3.3  NetWare Migration Wizard 8.0

NetWare Migration Wizard 8.0 includes the following new and enhanced features:

 Added the ability to filter the files you want to copy according to creation, last accessed, or 
modified dates.Let you exclude specific file types or file names from the copy process.Included 
an option to synchronize file and folders so that data deleted while you model a migration 
project is also deleted on the destination server when you run the project.Gave you the option 
to automatically compare file information between the source and destination after the copy 
process is complete to validate the integrity of the file copy.

2.3.4  NetWare Migration Wizard 7.1

NetWare Migration Wizard 7.1 includes the following enhanced feature:

 Allows migration directly from a NetWare 6 source server to a NetWare 6.5 destination server.

2.3.5  NetWare Migration Wizard 7.0

NetWare Migration Wizard 7.0 includes the following new and enhanced features:

 Speeds up the file copy procedure by implementing multithreading in determining file sizes 
while the file copy is running.

In previous versions of the Migration Wizard, the file copy procedure did not begin until the 
file sizes were completely discovered. With Migration Wizard 7.0, the copy procedure and the 
file size determination occurred simultaneously.
What’s New 21
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 Allows NICI keys to be transferred across the wire during the migration.

Previous versions of the Migration Wizard required using a floppy diskette swap to transfer 
NICI keys. Migration Wizard 7.0 still provided the option of using the floppy diskette swap if 
wanted, but the transfer could be completed quickly and securely over the wire instead.

 Displays a listing of created folders, dropped volumes, and dropped folders during the 
verification stage of the migration.

 Adds the ability to update ZENworks for Servers information during the migration process.

 Removes support for migrating data from NetWare 3 and 4 source servers.

 Moves the NT-to-NetWare migration capability to the Server Consolidation Utility.

 Moves the printing migration capability to the Server Consolidation Utility.

2.3.6  NetWare Migration Wizard 6.5

NetWare Migration Wizard 6.5 includes the following new and enhanced features:

 File copy operation no longer requires you to have exactly the same volumes on the source and 
destination servers.

 This version introduces the drag-and-drop interface that allows the user to model the migration 
project before actually performing the migration.

 The Begin NDS/eDir Migration step is divided into several substeps to allow you to verify that 
each step completed correctly before continuing.
 Server Consolidation and Migration Toolkit Administration Guide
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IIGetting Started

 Chapter 3, “Installing the Server Consolidation and Migration Toolkit,” on page 25

 Chapter 4, “Using the Server Consolidation and Migration Toolkit,” on page 29
Getting Started 23
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3Installing the Server Consolidation 
and Migration Toolkit

To install the Novell Server Consolidation and Migration Toolkit, complete the tasks in the 
following sections:

 Section 3.1, “Meeting the Workstation Requirements,” on page 25

 Section 3.2, “Installing the Server Consolidation and Migration Toolkit,” on page 26

 Section 3.3, “Uninstalling the Server Consolidation and Migration Toolkit,” on page 27

 Section 3.4, “What’s Next,” on page 27

3.1  Meeting the Workstation Requirements
The Server Consolidation and Migration Toolkit runs on a Windows workstation on the network. 
This workstation must meet the requirements outlined in this section.

 Windows XP Professional Edition or Windows 2000 with Service Pack 3 

The utilities in the toolkit do not run on Windows Vista, Windows XP Home Edition, Windows 
NT, or Windows 95/98.

NOTE: If you have Windows XP Professional Service Pack 2, you will see an error stating that 
the Server Consolidation and Migration Toolkit software has not been digitally signed when 
you run the installation program. You can safely ignore this message and continue installing the 
toolkit.

 100 MB of available disk space

 Novell Client 4.91 for Windows 2000/XP

To check the Novell Client version, right-click the N icon on the workstation toolbar and then 
click Novell Client Properties > Client.

You must also make the following settings in your Novell Client software:

 Disable file caching

Right-click the N icon, then click Novell Client Properties > Advanced Settings > File 
Caching > Setting: Off.

 (Conditional) Enable UTF-8 support if you are copying extended ASCII (multinational 
characters) or double-byte character set (oriental languages) data

Right-click the N icon, then click Novell Client Properties > Advanced Settings > Use 
UTF8 encoding and NCPs > Setting: On.

 (Conditional) If you are copying data from NetWare 4 servers, you must configure the 
Novell Client software to support the IPX protocol. See the Novell Client 4.91 for 
Windows 2000/XP documentation (http://www.novell.com/documentation/noclienu/
index.html) for more information.

 Microsoft Data Access Components (MDAC) 2.8
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If MDAC 2.8 is not installed on your workstation, it can be downloaded from the Microsoft 
Download Center (http://www.microsoft.com/downloads).

 Disable any antivirus programs running on the workstation. You can re-enable virus protection 
after the consolidation project is completed.

 For NetWare projects, you must be logged in as a user with the Supervisor right to the source 
and destination servers.

Use ConsoleOne to verify that you have the necessary rights to access all source and 
destination servers.

 For Windows projects, you must be logged in as a user with administrative rights to the domain 
containing the source server and workstation.

You need the Write/Modify permission to the domain and the Registry of the Primary Domain 
Controller (PDC). You also need the Read permission to all folders and files you are copying.

TIP: For Windows 2000/2003 consolidation projects, you can run the Server Consolidation Utility 
on the Windows server itself. This is the preferred method, especially if you have data that uses 
extended ASCII (multinational characters) or double-byte character sets (Japanese, Korean, and 
other oriental languages). You cannot run the Server Consolidation Utility on Windows NT servers.

If you have extended ASCII or double-byte character set data on a Windows source server and you 
plan to run the Server Consolidation Utility on a separate Windows workstation, the workstation 
must have Windows installed with the same language as the server. For example, if you are 
migrating a Japanese server, make sure that your workstation is also running Japanese. You must 
also enable UTF-8 support in the Novell Client.

For more information, see Chapter 12, “Copying Double-Byte Character Set Data,” on page 109.

3.2  Installing the Server Consolidation and 
Migration Toolkit
The Novell Server Consolidation and Migration Toolkit is located on NetWare 6.5 CD 1 (Operating 
System) or NetWare 6.5 SP7 DVD in the products/Migration_Utilities directory. The self-
extracting file is named scmt.exe.

You can also install the version on the CD/DVD through the Consolidate or Migrate Servers option 
in the Novell Deployment Manager utility. See “Using Deployment Manager”  in the NW65 SP8: 
Installation Guide for more information.

NOTE: NetWare Migration Wizard 8.1 does not support servers running eDirectory 8.8.x or later.

The latest version of the toolkit can be downloaded from the Novell Downloads page (http://
www.novell.com/download). Novell recommends that you use the latest version whenever possible.

To install the Server Consolidation and Migration Toolkit on the workstation, complete the 
following steps.
 Server Consolidation and Migration Toolkit Administration Guide

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
http://www.novell.com/download


n
ovdo

cx (e
n)  16

 A
p

ril 20
10
TIP: There are some known issues with Java and certain video cards that cause the Server 
Consolidation Utility installation to quit after extracting. If you encounter this issue, update your 
graphic card drivers to the latest version or disable the hardware acceleration for your graphics card.

1 Obtain the self-extracting file from one of the sources indicated above and copy it to your 
workstation.

2 Double-click the scmt.exe file to launch the installer, then click Next to proceed.

3 (Conditional) If you see a prompt indicating you don’t have the correct version of the Novell 
Client software installed, use the prompt’s link to download and install the Novell Client 
software and then restart the toolkit installation. 

4 (Conditional) If you are prompted to remove an earlier version of either NetWare Migration 
Wizard or Server Consolidation Utility, answer Yes or No and click Next.

5 (Conditional) If you answered Yes to the previous prompt, click Uninstall > Done.

6 Accept the license agreement, then click Next.

7 Read the Readme file, then click Next.

8 Specify where you want to install the toolkit, then click Next.

By default, the toolkit is installed in c:\program files\novell server consolidation 
and migration toolkit.

9 Specify whether you want to create desktop and quick launch icons, then click Next.

10 Verify your installation information, then click Install.

11 You must reboot the workstation to complete the installation. If you want to reboot when the 
installer exits, select Yes. Otherwise, select No. Click Done to exit the installer.

If you selected No, remember to reboot the workstation manually before you run the toolkit.

3.3  Uninstalling the Server Consolidation and 
Migration Toolkit

1 At the Windows workstation, click Start > Programs > Novell Server Consolidation and 
Migration Toolkit > Uninstall Novell Server Consolidation and Migration Toolkit.

2 Click Uninstall.

3 When the uninstall has completed, click Done.

The uninstall program does not delete the project folders that are created for each project you run.

3.4  What’s Next
For instructions on how to use the Server Consolidation and Migration Toolkit, go to Chapter 4, 
“Using the Server Consolidation and Migration Toolkit,” on page 29.
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4Using the Server Consolidation 
and Migration Toolkit

The Novell Server Consolidation and Migration Toolkit is a Windows program that is launched from 
the Start menu. It has a helpful interface that asks you what type of consolidation or migration 
project you want to perform and then launches the appropriate utility for you.

This section guides you through the introductory screens in the toolkit and refers you to the separate 
documentation for the appropriate utility.

4.1  Starting the Server Consolidation and 
Migration Toolkit
Do one of the following:

 Click Start > Programs > Novell Server Consolidation and Migration Toolkit > Novell Server 
Consolidation and Migration Toolkit.

 Double-click the Novell Server Consolidation and Migration Toolkit desktop icon.

 Click the Novell Server Consolidation and Migration Toolkit quick start icon.

The welcome screen displays version information, an About the Toolkit button to access the help, 
and a link to view the online documentation. To continue, click Create or Open Project.

4.2  Selecting the Source Operating System 
Platform
The Server Consolidation and Migration Toolkit helps you consolidate and migrate data from 
servers running either NetWare or Windows operating systems. In this first dialog box, you select 
the source operating system platform that you are consolidating or migrating data from. 

 NetWare (eDirectory)

Select this option if your source servers are running one of the supported versions of NetWare 
and are located in a Novell eDirectory tree. For a list of supported versions, see Section 1.3, 
“Supported Source and Destination Server Versions,” on page 16.

If your source servers do not meet the minimum version requirements, obtain and install the 
latest Support Packs before running the Server Consolidation and Migration Toolkit.

If you select this option, continue with Section 4.3, “Selecting a Consolidation or Migration,” 
on page 30.

 Windows NT Server (NT Domain)

Select this option if your source servers are running any of the supported versions of Windows 
and are located in an NT domain or a 2000/2003 Mixed Mode domain. For a list of supported 
versions, see Section 1.3, “Supported Source and Destination Server Versions,” on page 16.

If you select this option, the Server Consolidation Utility automatically launches. See Part III, 
“Server Consolidations,” on page 31 for further instructions.
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 Windows 2000/2003 Server (Active Directory)

Full support for Windows 2000/2003 Server Active Directory migrations is not available in this 
release of the toolkit. However, the toolkit does support Windows 2000/2003 as source servers 
in specific configurations. If your Windows 2000 or 2003 servers meet the requirements listed 
in Section 1.3, “Supported Source and Destination Server Versions,” on page 16, you should 
select Windows NT Server (NT Domain) as the source platform.

4.3  Selecting a Consolidation or Migration
When starting with NetWare as the source operating system platform, you can either consolidate 
(copy) data between servers or migrate file system and eDirectory data to a new NetWare server 
(also known as a hardware upgrade or server identity swap).

 Consolidate and Copy Data and Printing between Servers

Select this option if you want to do any of the following:

 Copy data from one or more NetWare source servers to one or more NetWare destination 
servers

 Consolidate one or more NDPS Printer Agents to a single NDPS Print Manager within the 
same tree

In all server consolidation scenarios, the source and destination servers continue to exist on the 
network and retain their original identities.

If you select this option, the Server Consolidation Utility automatically launches. See Part III, 
“Server Consolidations,” on page 31 for further instructions.

 Migrate Data to New Server (Hardware Upgrade)

Select this option if you want to migrate file system data and the NDS/eDirectory database 
from an old NetWare server to a new NetWare server. When the migration is complete, the old 
server is brought down and the new server assumes its name and IP address on the network. 
You can then surplus the old server hardware.

If you select this option, the NetWare Migration Wizard automatically launches. See Part IV, 
“Server Migrations,” on page 79 for further instructions.
 Server Consolidation and Migration Toolkit Administration Guide
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IIIServer Consolidations

 Chapter 5, “Preparing for a Server Consolidation,” on page 33

 Chapter 6, “Consolidating Data from NetWare Servers,” on page 39

 Chapter 7, “Consolidating Data from Windows Servers,” on page 61

 Chapter 8, “Troubleshooting Server Consolidations,” on page 71
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5Preparing for a Server 
Consolidation

To prepare your source and destination servers for a consolidation project with the Server 
Consolidation Utility, complete the tasks in the following sections:

 Section 5.1, “Meet System and Software Requirements,” on page 33

 Section 5.2, “Prepare the Source and Destination Servers,” on page 34

 Section 5.3, “Tips for Successful Consolidations,” on page 36

 Section 5.4, “Scheduling a Consolidation Project to Run at a Later Time,” on page 37

 Section 5.5, “What’s Next,” on page 38

In addition, you should review the information in the following sections:

 Section 5.3, “Tips for Successful Consolidations,” on page 36

 Section 5.4, “Scheduling a Consolidation Project to Run at a Later Time,” on page 37

5.1  Meet System and Software Requirements
The Server Consolidation Utility is launched from the Server Consolidation and Migration Toolkit, 
which runs on a Windows workstation on the network. This workstation must meet the requirements 
outlined in this section.

5.1.1  Workstation Requirements

Server Consolidation Utility is installed as part of the Server Consolidation and Migration Toolkit. If 
you have not already met the workstation requirements and installed the toolkit, see Section 3.1, 
“Meeting the Workstation Requirements,” on page 25.

The following are additional requirements for consolidation projects:

 For NetWare projects, you must be logged in as a user with the Supervisor right to the source 
and destination servers.

Use ConsoleOne to verify that you have the necessary rights to access all source and 
destination servers.

 For Windows projects, you must be logged in as a user with administrative rights to the domain 
containing the source server and workstation.

You need the Write/Modify permission to the domain and the Registry of the Primary Domain 
Controller (PDC). You also need the Read permission to all folders and files you are copying.

TIP: For Windows 2000/2003 consolidation projects, you can run the Server Consolidation and 
Migration Toolkit on the Windows server itself. This is the preferred method, especially if you have 
data that uses extended ASCII (multinational characters) or double-byte character sets (Japanese and 
other oriental languages). You cannot run the Toolkit on Windows NT servers.
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If you have extended ASCII or double-byte character set data on a Windows source server and you 
plan to run the Toolkit on a separate Windows workstation, the workstation must have Windows 
installed with the same language as the server. For example, if you are migrating a Japanese server, 
make sure that your workstation is also running Japanese. You must also enable UTF-8 support in 
the Novell Client.

For more information, see Chapter 12, “Copying Double-Byte Character Set Data,” on page 109.

5.2  Prepare the Source and Destination Servers
Before you launch Server Consolidation Utility from the Server Consolidation and Migration 
Toolkit, you must prepare the source and destination servers by completing these steps.

1 Ensure that all source and destination servers are running supported versions of NetWare, or 
Windows server software.

See Section 1.3, “Supported Source and Destination Server Versions,” on page 16 for more 
information on supported operating system versions.

2 If necessary, apply the latest NetWare Support Packs on both source and destination NetWare 
servers.

Updates are available for specific NetWare versions at the Consolidated Support Pack home 
page (http://support.novell.com/tools/csp).

3 If copying data from and to NetWare servers, set the same code page for both the source and 
destination servers.

IMPORTANT: If both servers don’t have the same code page, data will be lost during the 
consolidation. For instructions on changing your server’s codepage, see Section 12.2, 
“Changing the NetWare Server Code Page,” on page 109.

4 As a precaution, you should have a current backup of all data on the destination servers.

You should also back up the eDirectory information on the destination servers. For information 
on creating a backup of eDirectory, see “Backing Up and Restoring Novell eDirectory” in the 
Novell eDirectory 8.8 Administration Guide.

You should have a current data and trustee backup of the source servers, even though the source 
data is not modified during a data consolidation project. The only time data is changed on the 
source server is when you are consolidating printers.

5 For NetWare/eDirectory consolidations, load the latest Storage Management Services (SMS) 
Storage Management Data Requestor (smdr.nlm) and Target Service Agent (tsafs.nlm) 
modules on your source and destination NetWare servers.

To load the SMS modules provided with the NetWare operating system software, type load 
smdr and load tsafs at the server console.

6 Depending on how you have set up service discovery on your network, you might need to add 
the source server’s IP address, DNS name, and localhost name to the sys:/etc/hosts file on 
the destination server, and vice versa.

See Section 5.2.2, “Modifying the Hosts File,” on page 35 for additional information.
 Server Consolidation and Migration Toolkit Administration Guide
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5.2.1  Preparing NetWare 4 Source Servers

If you are planning to copy data from NetWare 4 source servers, complete these steps in addition to 
the ones in the previous section.

1 The source and destination servers must see each other via IPX. 

For information on verifying IPX communication between servers, see “Errors When 
Connecting to a NetWare 4 Server” on page 75.

2 Install long name space support on each volume containing data to be copied.

To add long name space support to a NetWare 4.10 volume, enter

load os2.nam

and then 

add name space os2 volume_name

at the server console. Replace volume_name with the name of the volume.

To add long name space support to a NetWare 4.2 volume, enter

load long.nam

and then

add name space long volume_name

at the server console. Replace volume_name with the name of the volume.

3 If you plan to copy compressed data from a NetWare 4 source server, enter the following 
command at the server console prompt:

set convert compressed to uncompressed option=0

Setting this parameter to 0 leaves compressed files compressed when they are accessed. This 
prevents compressed files from uncompressing and taking up all of your destination server's 
disk space when they are accessed. (Setting the option to 1 changes compressed files to 
uncompressed on second access, and setting the option to 2 always changes compressed files to 
the uncompressed version.)

To view your server’s current Convert Compressed to Uncompressed Option SET parameter, 
execute the SET command at the server console prompt, select the File System category, and 
then page through the information until you see Convert Compressed to Uncompressed Option.

5.2.2  Modifying the Hosts File

The Server Consolidation Utility connects the servers involved in a consolidation using one of two 
methods: SLP or the sys:\etc\hosts file. If you don’t have SLP configured on your network, you 
must modify the sys:\etc\hosts file to include the IP address and server name of every source 
server involved in the consolidation project. This information must be manually added to the file 
before running the consolidation project.

IMPORTANT: Because Novell Branch Office does not configure SLP, consolidations to Branch 
Office servers must use information in the hosts file. However, the Branch Office server 
reconfigures itself each time it is restarted. This causes the sys:\etc\hosts file on the server to be 
rewritten each time it is restarted. If only one consolidation is being run with a Branch Office server, 
the hosts file needs to be modified only once to include the source server’s IP address and server 
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name. However, if more than one consolidation is going to be run on a Branch Office server and the 
server has been restarted since the last consolidation, the hosts file must be modified each time the 
server is restarted.

You can modify the hosts file from the server console or from the client workstation.

From the Server Console

1 At the server console, enter

edit sys:etc/hosts

2 Add to the file the IP address and DNS server name of every source server involved in the 
consolidation project.

Type each IP address and server name as xxx.xxx.xxx.xxx Server_Name.

3 Save the file.

From the Client Workstation

1 Launch Windows Explorer.

2 Browse to the NetWare server or Nterprise Branch Office appliance.

3 Double-click the server name.

4 Double-click the sys: volume.

5 Double-click the etc directory.

6 Open the hosts file with a text editor.

7 Add to the file the IP address and server name of every source server involved in the 
consolidation project.

Type the IP addresses and server names as xxx.xxx.xxx.xxx Server_Name.

8 Save the file.

5.3  Tips for Successful Consolidations
 When you run the Server Consolidation Utility, you must be logged in to the network as a user 

with Supervisor rights to the source and destination servers. If you are not logged in when you 
start the utility, you can log in as you select the source and destination trees. 

 For better performance, Novell recommends that the source servers, destination servers, and 
client workstation all be located on a common LAN segment. 

 For Windows NT server consolidations, you should use the fastest workstation available to run 
the Server Consolidation Utility. If possible, assign the workstation a static IP address. Turn off 
screen savers and power management to avoid interruptions during the consolidation.

 When using the Server Consolidation Utility to copy data from a compressed volume to an 
uncompressed volume, ensure the destination server has enough space left in the volume to 
accommodate the uncompressed data. 

Decompression requires some disk space to decompress the file on the source and copy it. 
Having a small amount of space left on the source system might result in a server abend or 
unwanted behavior in the file system.
 Server Consolidation and Migration Toolkit Administration Guide
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5.4  Scheduling a Consolidation Project to Run at 
a Later Time
The Server Consolidation Utility lets you schedule projects to run at the most convenient time. This 
means that you can create a consolidation project during the day and schedule it to run during the 
night when there is a smaller chance that files that are to be moved will be open and being worked 
on. 

The Server Consolidation Utility uses the Scheduled Tasks capability built into Windows to 
schedule a consolidation project to run at a time that is most convenient to you. 

TIP: Before scheduling a consolidation project, Novell recommends that you complete the 
verification process and resolve all errors. When you have verified the project, resolved any errors, 
and reached the Start Novell Server Consolidation Utility dialog box, then the project can be 
scheduled.

To schedule a project to run at a later time:

1 Ensure that a Server Consolidation Project has been created. 

Write down the project name and path of its location for later reference.

2 Click Start > Settings > Control Panel. 

3 Double-click the Scheduled Tasks icon.

4 Double-click the Add Scheduled Task icon.

5 When the Scheduled Task Wizard launches, click Next. 

6 Select the Novell NetWare Server Consolidation Utility from the list of programs provided, 
then click Next.

7 Assign the scheduled task a name, select its frequency, then click Next. You can run a project as 
often as you want.

8 Select the start time and date for the project to run, then click Next.

9 Enter the Windows username and password of the user that will perform the task, then click 
Next.

10 Verify that the time displayed for running the project is correct. If it is, check the Open 
Advanced Properties for This Task When I Click Finish check box, then click Finish.

11 After the Advanced Properties dialog box opens, click Task.

12 In the dialog box that opens, complete the Run field.

The dialog box is populated with a pathname that ends in \fc.exe. Add the following 
parameters, separated by a single space, to this pathname for the scheduled consolidation 
project to run:

 (Required) The pathname, in quotation marks, to the consolidation project that you are 
scheduling to run. For example: 

“c:\my projects\sc1.mdb” (where sc1.mdb is the saved project)

 (Required) The letter Y, to automatically run the selected Server Consolidation project.

 (Required) The password for the admin on the source server.
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 (Required) The password for the admin on the destination server.

 (Optional) The letter N, to skip the Error and Success Log review dialog box and simply 
exit the utility after it finishes.

When completed, the Run field of the Advanced Properties dialog box should look similar to 
this:

c:\program files\novell\netware server consolidation utility\fc.exe "c:\my 
projects\sc1.mdb" y test1 test2

In the previous example, c:\program files\novell\netware server consolidation 
utility\fc.exe is the pathname that was already in the Run field of the dialog box, "c:\my 
projects\sc1.mdb" is the saved project that is scheduled to run, y is the Yes parameter to 
automatically run the project, test1 is the admin password on the source server, and test2 is the 
admin password on the destination server.

13 After entering the parameters, click OK.

14 In the dialog box that appears, enter the Windows username and password of the admin running 
the project, then click OK.

The Server Consolidation project will run at the scheduled time.

5.5  What’s Next
If you are consolidating data within a NetWare or Nterprise Branch Office environment, go to 
Chapter 6, “Consolidating Data from NetWare Servers,” on page 39.

If you are consolidating data from a Windows server to NetWare, go to Chapter 7, “Consolidating 
Data from Windows Servers,” on page 61.
 Server Consolidation and Migration Toolkit Administration Guide
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6Consolidating Data from NetWare 
Servers

After you have completed the prerequisite procedures and reviewed the pertinent information in 
Chapter 3, “Installing the Server Consolidation and Migration Toolkit,” on page 25, you are ready to 
proceed with your NetWare consolidation project.

To perform a NetWare consolidation project, complete the following tasks covered in this section:

1. Understand NetWare Server Consolidation Issues (page 39)

2. Launch Server Consolidation Utility and Create a Project File (page 40)

3. Select a Source and Destination Tree (page 41)

4. Model Your Consolidation Project (page 41)

5. Perform Pre-Copy Verifications (page 43)

6. Additional Steps for Tree-to-Tree Consolidations (page 49)

7. Run the Consolidation (page 52)

In addition, this section contains information on the following optional tasks:

1. Consolidating NDPS Printer Agents (page 52)

2. Consolidating Data to or from a NetWare 5.1 Cluster (page 54)

3. Consolidating Data to Novell Branch Office (page 55)

4. Consolidating Data from NetWare 4 Servers (page 57)

5. Server-Based Processing (page 58)

6.1  Understand NetWare Server Consolidation 
Issues
Before running a consolidation project in a NetWare/eDirectory environment, be sure you have 
prepared your server as described in Section 5.2, “Prepare the Source and Destination Servers,” on 
page 34.

You should also be aware of the issues discussed in this section.

6.1.1  Open Files Cannot Be Copied

The Novell Server Consolidation Utility cannot copy files that are open and currently in use.

There is one exception to this rule. NSS has a feature called File Copy on Write. This permits a file 
that is being changed to be accessed in the same state as it was in when it was last closed by all 
processes. 

This feature is enabled on an NSS volume either by using ConsoleOne or by entering

nss /filecopyonwrite=volname
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at the source server console to change the volume attributes. 

For example, nss /filecopyonwrite=vol1 would enable File Copy on Write for the vol1: 
volume. The effect is immediate, but it affects only files that are currently closed and then opened 
later.

6.1.2  Cluster Failover Stops File Copy

If you run a server consolidation project involving a NetWare cluster and the cluster fails over 
during the consolidation, the file copy will stop. The consolidation project must be run again.

6.1.3  User Space Restrictions Only Migrated in Full Volume 
Copies

In consolidation projects where individual folders are dragged and dropped, or where a volume is 
copied to a folder on the destination server, user space restrictions on the source volume are not 
migrated to the destination volume.  

If your consolidation project is set up to copy an entire volume, with the contents of the source 
volume being copied to the root of the destination volume, user space restrictions are migrated to the 
destination volume. If user space restrictions already exist on the destination volume, they are 
overwritten with the restrictions migrated from the source volume.

6.2  Launch Server Consolidation Utility and 
Create a Project File
The Server Consolidation Utility is a Windows program that is launched from the Server 
Consolidation and Migration Toolkit. 

1 If you have not already done so, start the Server Consolidation and Migration Toolkit.

By default, the toolkit is installed in c:\program files\novell server consolidation 
and migration toolkit. You can access it by clicking Start > Programs > Novell Server 
Consolidation and Migration Toolkit > Novell Server Consolidation and Migration Toolkit.

2 Read the Welcome page, then click Create or Open Project.

3 Select NetWare (eDirectory), then click Next.

4 Select Consolidate and Copy Data and Printing Between Servers, then click Next.

5 Read the About screen, then click OK.

6 Do one of the following:

 To start a new consolidation project, click Create a New Project > OK. Then continue with 
Step 7 on page 41.

 To open an existing project, click Open an Existing Project > OK, select the project you 
want to work on, and then click Open. Then skip to Section 6.4, “Model Your 
Consolidation Project,” on page 41.

 To open the last project you worked on, click Open Last Project > OK. Then skip to 
Section 6.4, “Model Your Consolidation Project,” on page 41.
 Server Consolidation and Migration Toolkit Administration Guide
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The Server Consolidation Utility uses a project (.mdb) file to record your intended actions. The 
actions are recorded so you can execute them now or save the project file and execute the 
actions later.

7 Type a project filename in the field provided.

The filename can be up to 64 characters long and can include any character except \ * ? < > | " 
/. The project name also serves as the project's folder name, so you might want to keep it short. 
The project folder stores the log files and other files associated with the project.

8 (Conditional) If you want to store the project file in a location other than the default location 
provided, click Browse and navigate to the desired location, and then click OK.

9 Click Next to continue to the next screen.

6.3  Select a Source and Destination Tree
After you create a project file, you need to select your source and destination trees. To do this, you 
must be logged in to the trees that you will be working in.

1 Select the source and destination eDirectory (NDS) tree from the drop-down list provided or 
click Login to browse to a tree that is not in the drop-down list.

Only trees that you are currently logged in to are available on the drop-down list.

1a (Conditional) In the Novell Login dialog box, click Trees.

1b Browse to each desired tree and log in with the correct username and password.

If you do not know the tree name, in the Server field of the Login dialog box, type the IP 
address or DNS name of the server that you will be consolidating to or from.

IMPORTANT: If you are performing a consolidation to an Nterprise Branch Office 
appliance, the Admin user’s context is always appusers.

1c Click OK.

2 Click Next.

3 Click Create to finish creating the project file.

6.4  Model Your Consolidation Project
The Project Window (see Figure 6-1) is where you select which volumes and directories to copy and 
which Printer objects to move. The Project Window is divided into two panes that each show the 
trees that you are working in.
Consolidating Data from NetWare Servers 41



42 Novell

n
ovdo

cx (e
n)  16

 A
p

ril 20
10
Figure 6-1   Server Consolidation Utility Project Window

You drag objects from the left pane and drop them into the right pane. You select volumes and 
directories to copy to different servers, and Printer Agents to move to different Print Managers. You 
can also create new eDirectory containers or file system folders by right-clicking on an existing 
container or folder and selecting New Container or New Folder from the pop-up menu.

Creating containers and folders and dragging-and-dropping objects in the Project Window does not 
immediately perform the action. It only creates a preview of where the files and objects will reside. 
The actions are completed only after the verification process is complete and the copy process 
begins.

Volume Drop Options

When you drag-and-drop volumes into the right pane of the Project Window, a Volume Drop 
Options dialog box displays. You must choose to either migrate the volume contents into the 
directory or volume that you selected or create a new directory with the name of the volume that is 
being moved.

1 Click the radio button next to the option you want. 

2 Click OK.

Duplicate Folder Options

If you drag-and-drop a folder onto a destination folder of the same name, a Duplicate Folder Options 
dialog box displays. You have several options: 

 Don’t Copy the Directory: The directory on the source server is not copied and the directory on 
the destination server is not replaced. 

 Merge Directory Contents: The contents of the source directory are merged into the destination 
directory with the same name.
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 Rename: The directory on the source server is copied to the destination server with a new name 
assigned to it. You must enter a new name in the field provided if you select this option.

 Merge All: If you are dragging-and-dropping multiple directories at once, select this option if 
you want to merge the contents for all duplicate directories.

1 Click the radio button next to the option you want. 

2 Click OK.

Other Project Window Options

In addition to dragging-and-dropping objects, you can perform several other tasks from the Project 
Window menu:

 Save project settings: Click File > Save As.

 Move created and dropped objects around by dragging them to the desired location.

 Create a new container or folder: Select the parent container or existing folder in the right pane, 
then click Edit > New Folder.

 Cancel a “dropped” action: Select the volume or directory in the right pane, then click Edit > 
Back Out.

 Rename a newly created container or folder: Select the parent container or existing folder in the 
right pane, then click Edit > Rename.

 Show where a folder or object went: Select the object in the left pane, then click Edit > Where 
Did It Go. The directory or volume that was moved is highlighted in its new location in the 
right pane.

 Show where a folder or object came from: Select the object in the right pane, then click Edit > 
Where Did It Come From. The directory or volume that it came from is highlighted in the left 
pane.

 Show all folders or objects selected for copying: Select a container in the left pane, then click 
Edit > Show Dropped Folders (or Show Dropped Printers).

TIP: The previous six tasks can also be performed by right-clicking the object to see the same 
menu option.

 View the available disk space before performing the verification by right-clicking the 
destination volume in the right pane of the Project Window and then selecting Properties. 
Right-clicking the source folder or volume in the left pane of the Project Window and then 
selecting Properties displays the size of the source object.

6.5  Perform Pre-Copy Verifications
After you have dragged-and-dropped the selected directories or volumes and have performed any 
other modeling tasks, proceed by clicking Project > Verify and Copy Data or by clicking Do the 
Consolidation on the button bar. 

NOTE: These instructions assume you have not enabled server-based processing. If you have, refer 
to the additional information in Section 6.12, “Server-Based Processing,” on page 58.
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Begin the Verification

1 When the Verification Wizard dialog box displays, click Next to begin the verification process.

2 The Dropped Folders dialog box displays, showing the source path and destination path for the 
dropped folders. Do one of the following:

 If the source and destination paths are correct, click Next.

 If the source or destination path is incorrect, click Cancel and make the appropriate 
changes in the Project window.

3 (Conditional) If you created new folders in the right pane of the Project window as part of your 
consolidation project, the Created Folders dialog box now displays. Do one of the following:

 If the destination path of the created folders is correct, click Next.

 If the destination path is not correct, click Cancel and make the appropriate changes in the 
Project window.

4 (Conditional) If you are moving NDPS printers as part of your consolidation project, the 
Dropped Printers dialog box now displays. Do one of the following:

 If the destination locations of the printers are correct, click Next.

 If the destination locations are not correct, click Cancel and make the appropriate changes 
in the Project window.

Duplicate File Resolution

If a file is found on the destination volume or directory that has the same name as a file being copied 
from the source, you must decide what to do. You have three options to choose from on the 
Duplicate File Resolution dialog box: 

 Don’t copy over existing files 

The file on the source server is not copied and the file on the destination server is not replaced.

 Copy the source file if it is newer (Default)

If the file on the source server is newer than the one on the destination server, the file on the 
destination server is replaced.

 Always copy the source file

The file on the source server always replaces the file with the same name on the destination 
server.

1 Click the radio button next to the option you want.

2 Click Next.

Synchronize Files and Folders

In the Synchronize Files and Folders dialog box, you have the option to delete files and folders on 
the destination server that do not exist on the source server. Selecting Yes deletes all files and folders 
on the destination server that are not on the source server. No is the default selection. 

1 Click the radio button next to the option you want.

2 Click Next.
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WARNING: Do not use this option in projects that involve consolidating data from two separate 
volumes or folders on the source server into a single volume or folder on the destination server. 
When the synchronization check compares the copied data to what exists in the first volume or 
folder, it will delete everything that was copied from the second. The same process occurs when 
comparing the copied data for the second volume or folder, and you end up with no copied data 
remaining in the destination volume or folder.

File Comparison

In the File Comparison dialog box, you have the option to compare files and folders between the 
source and destination servers after the copy process completes. Selecting Yes compares the 
following information between the source and destination files and folders:

 Names

 Dates

 Sizes

 Attributes

 Trustees

 Owners

1 (Conditional) If you do not want to compare source and destination files after the copy process, 
select No and then click Next. Skip to “File Date Filters” on page 45.

2 (Conditional) If you selected Yes, you have the option to do a binary (byte-by-byte) comparison 
of the files after the copy process completes. This option gives the greatest assurance that two 
files are identical, but it takes longer to complete.

If you want to perform a binary comparison of the files that were copied, select Binary (byte-
by-byte) comparison.

3 (Conditional) If you are seeing errors about files having different Rename inhibit (Di) and 
Delete inhibit (Ri) attributes after the comparison, you can disable the comparison of these 
attributes by deselecting Compare Ri/Di attributes on read-only files.

The reason for these errors is that the Novell Client version 4.9x does not automatically set the 
Di or Ri attributes when copying Read-only files, whereas the Server Consolidation Utility 
does. So if you have copied Read-only files to the source server using the Novell Client, they 
are marked Read-only but the Di and Ri attributes are not set by the Client. If you subsequently 
use the Server Consolidation Utility to copy these files to another server, the utility sets the Di 
and Ri attributes of all Read-only files on the destination server, as it should.

4 Click Next.

IMPORTANT: Novell recommends that you do not enable file comparison when copying files.

File Date Filters

In the File Date Filters dialog box, you have the option to copy files based on dates and three 
separate attributes: 

 Accessed
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 Modified

 Created

If you select No, all files are copied. If you select Yes, you can enter date ranges for the file copy. 
You can select as many criteria as you would like, and only those files that meet all of the selected 
criteria are copied. 

Two dates can be set for each attribute. The first date is an On or After date and the second is an On 
or Before date. For example, if you select only On or Before and set the date for November 10, 2000, 
for the Accessed attribute, only those files accessed on or before November 10, 2000, are copied. In 
the same example, if you also select On or After and set the date to October 1, 2000, only those files 
accessed on or after October 1, 2000, and on or before November 10, 2000, are copied. 

1 (Conditional) If you do not want to filter files based on dates, select No.

2 (Conditional) If you want to filter based on dates, select Yes and then select the desired 
combination of file types and dates to be copied.

To change the date from the default provided, check the box next to the desired date. Next, 
highlight with your mouse the portion of the date you want to change. Either type a new value 
using the keyboard number pad, or use the mouse to click the up- and down-arrows provided to 
the immediate right of the date field.

3 Click Next.

NOTE: On a Windows 2000/XP workstation, the Last Accessed date might not be reported 
correctly for files on NetWare volumes. The workstation might report a Last Accessed date that is 
one day off from the actual date on the file. Because the Server Consolidation Utility reads this date 
for the date filter settings, the date filters for the Last Accessed time might seem to be off by one 
day. However, the Server Consolidation Utility is working as designed based on the dates being 
reported to it.

Excluded File Extensions

In the Excluded File Extensions dialog box, you have the option to exclude specific file types or file 
names from the copy process. Wildcards are permitted.

A wildcard is a character that can be used to represent one or more characters in a search. The two 
most commonly used wildcards are the question mark (?) and the asterisk (*).

 The question mark (?) is used to represent a single alphanumeric character in a search 
expression.

For example, typing te?t.txt would exclude tent.txt, test.txt, and text.txt from the 
copy process.

 The asterisk (*) is used to specify zero or more alphanumeric characters in a search expression. 

For example, typing h*s.txt would exclude house.txt, his.txt, horses.txt, and 
happiness.txt from the copy process.

1 Type the file extension types or filenames in the field provided. For multiple filenames or 
types, press Enter between each entry. 

For example, if you want to exclude a specific file named test.txt from being copied, type 
test.txt in the field provided. If you want to exclude all .mp3 files from being copied, type 
*.mp3 in the field provided.
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Type as many filenames or file extension types as you want. Separate the filenames or file 
extensions by pressing Enter between each entry. Do not use spaces or commas to separate the 
entries. See the following examples:

Correct:

*.mp3

test.txt

*.wav

Incorrect:

*.mp3 test.txt *.wav

or

*.mp3, test.txt, *.wav

2 Click Next.

If you are performing a consolidation between servers in a single tree, the Check for Trustees and 
Ownerships dialog box is not displayed. Proceed to “Verify Password” on page 23.

Check for Trustees and Ownership

When you copy data from one tree to another, the Server Consolidation Utility searches the 
destination tree for objects whose names match the source tree object names. Objects that are 
potential matches are displayed and can be matched up during “Tree-to-Tree Object Match Up” on 
page 49.

If this option is enabled, the Server Consolidation Utility scans the dropped folders and their 
subordinates for trustees and owners. This check must be performed the first time a consolidation is 
run. If a consolidation is run a second time, this scan does not need to be repeated, as long as trustees 
have not been added to the source server and new directories or folders have not been dropped onto 
the destination server. If either has happened, another scan is necessary. This trustee and ownership 
check slows down the verification process.

NOTE: If a file has already been copied to the destination server or tree, that file’s trustees are not 
updated during the consolidation unless the source file data is recopied. See “Duplicate File 
Resolution” on page 44 for information about when a source file might overwrite the destination 
file.

1 Click Browse to select the destination container you want to search.

2 Select Search All Subordinate Containers to search all containers in the destination tree below, 
and including, the one you selected.

If you don’t select this option, the utility searches only the selected destination container. For 
better performance, limit the search to the container that you believe the object resides in. 
Searching from Root takes significantly longer depending on the size of the destination tree.

3 Click Next.

If consolidating data to an Nterprise Branch Office appliance, there is not an option to specify the 
container you want to search. Select Yes or No, then click Next.
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Password Verification

1 In the Password Verification dialog box, enter the passwords for the source and destination 
trees in the fields provided.

NOTE: SMS is the backup and copy engine used by the Server Consolidation Utility. You 
enter your password here because SMS requires that the servers involved in the consolidation 
be authenticated to each other.

2 Click Next. 

Check for Sufficient Disk Space and Disable Login

Before beginning to consolidate your data, you can verify that your destination volumes have 
enough space to accommodate the data that will be moved. Verifying disk space can be a long 
process if you have many files to copy.

You can also disable login on the source server before copying file data. Users already logged in to 
the source server are not logged out, but no new logins are allowed until the consolidation 
completes. If you disable login and the workstation running the consolidation project crashes for any 
reason during the consolidation, you might have to manually re-enable login on the source server 
console.

1 To verify the available space on the destination volumes, select Check for Sufficient Disk 
Space.

2 To have the utility disable login on the source server prior to copying data, select Disable 
Login.

3 Click Next.

Verification Wizard

When the Verification Wizard screen displays, click Next to begin the pre-copy verification.

During the verification process, you might see a message informing you that an updated tsafs.nlm 
or smdr.nlm must be copied for the consolidation to work. Click Yes to continue the project 
verification. Clicking No stops the verification.

6.5.1  Resolve Pre-Copy Verification Errors

If errors are discovered in the verification attempt, they are shown in the Error Resolution dialog 
box. Errors could include name conflicts, insufficient rights, required name spaces not loaded, and 
insufficient disk space. Errors found during the verification process are classified as follows:

 Errors must be resolved before files can be copied. 

 Warnings should be resolved but might not affect the copy process. 

In addition, the Error Resolution dialog box might display informational text classified as follows:

 Information about the decisions you made in the Project Window. 
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A description of the error and a possible resolution appears in the Information text box. If no 
resolution is provided, you can find more information in the Novell Error Code online 
documentation (http://www.novell.com/documentation/lg/nwec/index.html). (Search the system by 
error code number.)

After resolving any errors that exist, click Next.

6.6  Additional Steps for Tree-to-Tree 
Consolidations
If you are moving objects from one tree to another, the Tree-to-Tree Object Match Up dialog box 
now displays. If you are not moving objects between trees, proceed to Section 6.7, “Run the 
Consolidation,” on page 52.

6.6.1  Tree-to-Tree Object Match Up

All trustees of copied data that appear in both the source and destination trees are displayed in the 
Tree-to-Tree Object Match Up dialog box based on their category. These trustees are discovered 
during the Check for Trustees and Ownership step and are saved in the project database.

This screen allows you to match the trustee names found on the source server with trustees from the 
destination server. If an appropriate match does not exist, you can create an object on the destination 
server that matches the object name from the source server. You can also browse to an existing 
object in the destination tree and match it up with the source server object name.

IMPORTANT: If you are consolidating to an Nterprise Branch Office Appliance, see Section 6.10, 
“Consolidating Data to Novell Branch Office,” on page 55 now.

1 Select the type of objects to display from the drop-down list provided in the Tree-to-Tree 
Object Match Up dialog box.

2 Check the box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the box to the left of 
the objects that you want to select. You can also check the box to the left of one object, press 
and hold the Shift key, then check the box to the left of a second object to select those two 
objects and all other objects located between them in the list.

The following attributes are copied for each selected user:

 Common Name

 Description

 E-mail Address

 Fax Number

 Full Name

 Generational Qualifier

 Given Name

 Initials

 Internet E-mail Address

 Language
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 Locality Name

 Lockout After Detection

 Login Allowed Time

 Login Disabled

 Login Expiration Time

 Login Grace Limit

 Login Grace Remaining

 Login Intruder Limit

 Login Maximum Simultaneous

 Login Script

 Mailbox Location

 Network Address Restriction

 Organizational Name

 Organizational Unit Name

 Password Allow Change

 Password Expiration Interval

 Password Expiration Time

 Password Minimum Length

 Password Required

 Password Unique Required

 Physical Delivery Office name

 Post Office Box

 Postal Address

 Postal Code

 State or Province Name

 Street Address

 Surname

 Telephone Number

 Title

2a (Conditional) If you selected more than one object, right-click on the selected objects and 
then select Create All Selected Objects.

2b (Optional) If you want to create objects for all of the selected objects, select Yes.

2c To select the container that the objects will be created in, click Browse.

2d Click OK.

2e To unmatch more than one object, select the desired objects, right-click the objects, and 
then select Unmatch All Selected Objects.

3 From the drop-down menu under the Destination Object heading, select the option you want:

 The object in the destination tree that has the same name as the object in the source tree

 Don’t match (object doesn’t exist in the destination tree)
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 Browse

 Create

4 (Conditional) If you selected Browse in Step 3, do the following in the Context Browser dialog 
box:

4a Select a matching object.

4b Click OK.

5 (Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog 
box:

5a To browse to the container that the new object will be created in, click Browse.

5b Select the container.

5c Click OK.

5d Type the new object’s name in the field provided, then click OK.

5e Repeat Step 5d for each object you want to create.

NOTE: When the Server Consolidation Utility creates a new user, it assigns a random 
password to that user. The username and the randomly assigned password are written to 
the success log. This log file can be viewed after the consolidation completes.

The Server Consolidation Utility allows you to create groups if they don’t already exist in 
the destination tree and it adds the users that are members of the source group to the new 
destination group. However, it does not modify an existing group. If you use the utility to 
create a group in the destination tree and then add additional members to the source tree's 
group, those added members are not added to the destination group. Also, if you choose to 
create the groups manually (on the destination) rather than using the Server Consolidation 
Utility, and then you attempt to match up the groups during the consolidation, the group 
members are not transferred.

6 When you have finished matching all the objects, click Next.

7 (Conditional) If you have unmatched objects, do one of the following in the Unmatched 
Objects dialog box that displays:

 To proceed without matching the objects, select Yes.

 To go back and match up the objects before continuing, select No.

6.6.2  Default Server and Home Directory for Created Users

In the Default Server and Home Directory for Created Users dialog box, you have the option to 
assign a default server for all created users. The default server is the server the user gets a 
connection to during login if the user doesn’t request a connection to a specific server. It's also the 
server used if the user makes a network request without naming the server, and it's the server the 
user still has an attachment to after logging out.

You can also assign a parent directory for any created user's home directory. A home directory is an 
optional, single-valued property that specifies the location (volume and path) and name for the user's 
working area on the server.

1 (Conditional) If you want to assign a default server for all created users, click the first Browse 
button.

2 Select a server from the tree.
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3 Click OK.

4 (Conditional) If you want to assign a parent directory for any created user’s home directory, 
click the second Browse button.

5 Select a directory from the tree.

6 Click OK > Next.

6.7  Run the Consolidation
After resolving pre-copy verification errors, you can now copy your files by clicking Proceed in the 
Start Novell Server Consolidation Utility dialog box.

During the copy process, new folders and objects are created, files are copied, and Printer Agents are 
moved to their destination (as specified in the right pane of the Project Window).

When the copy process is complete, a Process Finished screen displays that lets you

 View the error log.

 View the success log.

 Close the Process Finished screen.

TIP: You can also view the error and success logs of any completed project from the Project 
Window by opening the project file and clicking View > Error Log or View > Success Log, or by 
clicking the corresponding button on the button bar.

If you interrupt the copy process before it completes, all objects, directories, and files already copied 
to the destination server will remain there unless you manually delete them.

6.8  Consolidating NDPS Printer Agents
This section explains how to consolidate NDPS Printer Agents from one NDPS Print Manager 
(PSM) to another as part of a NetWare-to-NetWare consolidation.

6.8.1  Understanding NDPS Printer Agent Consolidation

When consolidating NDPS Printer Agents, be aware of the following points:

 Because the Server Consolidation Utility actually moves the NDPS Printer Agents, you should 
back up your source server before launching this operation. If you make a mistake in moving a 
Printer Agent, wait until it is fully functional in its new location before you move it back.

 The Server Consolidation Utility does not move Print Brokers or Print Managers. It moves 
NDPS Printer Agents to an existing NDPS Print Manager on another server within the same 
tree. After the move, the original Printer Agents are deleted from the source Print Manager.

If you want to consolidate your NDPS Printer Agents to a new NDPS Print Manager in the 
same tree, you must first create the new Print Manager on the destination server, and then use 
the Server Consolidation Utility to drag-and-drop the Printer Agents to the new Print Manager.

 You cannot migrate NDPS Printer Agents to iPrint Print Managers. This utility supports 
moving NDPS Printer Agents to NDPS Print Managers, and only in NetWare-to-NetWare 
consolidation projects.
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 Printer Agents can be moved; print queues cannot.

 Printer Agents that are moved still use the same Print Broker.

 Printer Agents can be moved only within the same tree. They cannot be moved between 
different trees.

 Print Managers must be operational during the consolidation.

 If necessary, after moving Printer Agents from the source to the destination server, unload the 
source Print Manager so the installed printers on the workstations can establish a connection to 
the destination Print Manager.

TIP: After unloading the source Print Manager, send a test print job to the printer that was 
moved. This ensures that communication with the destination Print Manager is established. 
After that communication has been established, the source Print Manager can be brought back 
up.

 Printer defaults such as copies and media that are set in iManager through the iPrint > Manage 
Printer > Configuration > Defaults (legacy) page are migrated with Printer Agents.

 If you made changes to the iprint.ini (located in sys:\apache2\htdocs\ippdocs\), you 
should copy the file to the destination server. 

 iPrint maps and custom images are not migrated. If you are hosting these on your iPrint server, 
you need to copy them to the destination server.

 Driver Profiles and Custom banners are migrated. If a Printer Agent uses a custom banner, the 
Server Consolidation Utility copies the custom banner to the new Print Manager. If a banner 
with the exact same content already exists on the destination Print Manager, the banner is not 
migrated and the Printer Agent is assigned the custom banner that already exists on the 
destination server.

If there is no match for the custom banner, then the banner is copied from the source Print 
Manager using its same name. In the event that a banner with the same name but different 
options already exists on the destination Print Manager, the banner is copied from the source 
Print Manager and renamed as banner_name_0x.

For example, if a custom banner with the name of Banner1 already exists on the destination 
Print Manager with different options, then the banner is copied to the destination and renamed 
Banner1_01.

The same is true for driver profiles.

6.8.2  Using the Utility to Consolidate NDPS Printer Agents

Follow these steps to consolidate NDPS Printer Agents to an NDPS Print Manager within the same 
eDirectory tree.

1 If necessary, start the Server Consolidation and Migration Toolkit and select the following 
options to launch the Server Consolidation Utility:

 NetWare (eDirectory)

 Consolidate and Copy Data and Printing Between Servers

2 Create a new consolidation project by following the steps in Section 6.2, “Launch Server 
Consolidation Utility and Create a Project File,” on page 40.

3 Select the same tree for both the source and the destination tree.
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Migrating NDPS printers is supported only within the same eDirectory tree. See Section 6.3, 
“Select a Source and Destination Tree,” on page 41 for more information. 

4 In the Project Window’s source pane, locate the PSM that has the Printer Agents (printers) you 
want to move.

5 In the destination pane, locate the PSM that is to receive the Printer Agents.

6 Drag-and-drop the individual Printer Agents from the source PSM to the destination PSM.

Make sure the PSMs are running on both the source and destination servers before you attempt 
to drag-and-drop the associated Printer Agents. If you don’t do this, you will get unpredictable 
results.

7 Click Project > Verify and Copy Data to verify the project and start the migration.

The utility checks to ensure that it can communicate with the source Resource Management 
Service (RMS) and the destination Print Broker. It also verifies that the moves you want to 
make are valid.

During the verification, the Dropped Printers dialog displays the source and destination 
locations for the printers you are moving in this consolidation project.

 If the source and destination locations are correct, click Next.

 If the source or destination location is incorrect, click Cancel and make the appropriate 
changes in the Project Window.

At the end of the verification, the results dialog is displayed. To ensure a smooth migration, you 
should resolve all errors before proceeding.

8 When you are ready to commit the changes, run the consolidation.

See Section 6.7, “Run the Consolidation,” on page 52 for more information.

9 Upon completion, review both the success and error log files. 

The log file uses three possible states to identify the success of the migration of each Printer 
Agent:

 Success indicates that the Printer Agent was created on the destination server with all of 
its attributes and drivers.

 Partial Success indicates the Printer Agent was created on the destination server but not all 
of its attributes and drivers were included, so you should review its configuration.

 Failure indicates that the Printer Agent was not created on the destination server.

6.9  Consolidating Data to or from a NetWare 5.1 
Cluster
When a volume is cluster enabled, an object is created in eDirectory with the name of the cluster 
followed by an underscore followed by the volume name (for example, cluster1_vol1). For the 
Server Consolidation Utility to function properly with a NetWare 5.1 cluster-enabled volume, the 
server name followed by an underscore followed by the Volume Name object must be used in the 
Project Window instead (for example, server1_vol1).

This substitution can be accomplished by completing the following steps:

1 Start ConsoleOne, and browse to the context where the NCP Server object resides.

2 Right-click the right pane, select New > Volume, then type the name of the new object in the 
first field.
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This should be the server name followed by an underscore followed by the volume name.

3 In the second field, browse and select the appropriate server. 

4 In the third field, select the volume from the drop-down menu, then click OK.

5 In the Server Consolidation Utility Project Window, refresh the container where the Volume 
object is located to make the new object appear.

6 When dragging-and-dropping in the project window, use the newly created Volume object. 

If you use the clustername_volumename object instead of creating and using the new Volume 
object, a critical SMDR error will occur and you won’t be able to complete the consolidation 
process.

7 After the consolidation is complete, you can delete the newly created Volume object.

6.10  Consolidating Data to Novell Branch Office
Novell Branch Office (formerly Nterprise Branch Office) server is a business office management 
solution that reduces the costs and challenges of managing and using offices in remote locations. 
Novell Branch Office is server software that you can deploy on hardware at remote offices and still 
have the flexibility to manage from one central location at your corporate offices. Administrators 
and users access the features they need through the Internet from a Web browser.

Moving directories, volumes, or users and their associated trustees and rights to a new Branch 
Office server is a daunting task made easier by the Server Consolidation Utility. Moving information 
with the Server Consolidation Utility is faster and easier than manually entering individual users, 
copying files, and manually assigning their rights and trustees on a new Branch Office server.

NOTE: Anytime that a Branch Office server is rebooted, the sys: volume is recreated on the server. 
Because of this, the Server Consolidation Utility will not display the sys: volume on Branch Office 
servers.

The Server Consolidation Utility works with Novell Branch Office servers in much the same way it 
works with NetWare servers. However, there are a few differences in the way the Server 
Consolidation Utility runs in relation to Branch Office servers. This section describes the following:

 Unlocking the Branch Office Server (page 55)

 Performing a Server Consolidation to a Novell Branch Office Server (page 56)

6.10.1  Unlocking the Branch Office Server

In order to perform a consolidation to a Branch Office server, you must be logged in as Supervisor to 
the server. The Branch Office server does not allow supervisor rights unless the server is unlocked. 
When the server is unlocked, Supervisor is granted supervisor rights and the consolidation can be 
run.

WARNING: Do not use the Admin username and password to unlock the server. Doing so can 
corrupt the encrypted password and require a re-installation of the Branch Office server.

1 At the server console, log in by entering the Supervisor username and password.

2 Enter

unlock
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3 When prompted, enter y for Yes.

4 To relock the server, enter

lock

at the server console.

6.10.2  Performing a Server Consolidation to a Novell Branch 
Office Server

When performing a consolidation to a Branch Office server using the Server Consolidation Utility, 
you will see several screens that are different from the ones displayed during a consolidation on a 
regular NetWare server. The different screens that require navigation are described below.

Match Up Tree Objects

The Tree-to-Tree Object Match Up screen displays. Any objects that appear in both the source and 
destination trees are displayed based on their class. To match up objects in a consolidation involving 
a Branch Office server, complete the following steps:

1 Select the type of objects to display from the drop-down list provided.

2 Check the box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the box to the left of 
the objects that you want to select. You can also check the box to the left of one object, press 
and hold the Shift key, then check the box to the left of a second object to select those two 
objects and all other objects located between them in the list.

The following attributes are copied for each selected user:

 Department

 Description

 E-mail Address

 Fax Number

 Full Name

 Given Name

 Internet E-mail Address

 Location

 Postal Address

 Surname

 Telephone Number

 Title

 Unique IDs

2a (Conditional) If you selected more than one object, right-click the objects and then select 
Create All Selected Objects.

2b (Optional) If you want to create users for all of the selected users, select Yes.

2c From the drop-down list, select whether these will be Local Users or Remote Users.

2d Click OK.
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3 From the drop-down menu under the Destination Object heading, select the option you want:

 The object in the destination tree that has the same name as the object in the source tree

 Don’t match (object doesn’t exist in the destination tree)

 Browse

 Create (if you are matching users)

4 (Conditional) If you selected Browse in Step 3, do the following in the Context Browser dialog 
box:

4a Select a matching object.

4b Click OK.

5 (Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog 
box:

5a From the drop-down list, select whether you want to create a Local User or Remote User.

5b Type the new user’s name in the field provided, then click OK

5c Repeat Step 5a for each user you want to create.

6 When you have finished matching all the objects, click Next.

7 (Conditional) If you have unmatched objects, do one of the following in the Unmatched 
Objects dialog box that displays: 

 To proceed without matching the objects, select Yes.

 To go back and match up the objects before continuing, select No.

Refer to “Default Server and Home Directory for Created Users” on page 51 to complete the 
consolidation.

6.11  Consolidating Data from NetWare 4 Servers
NetWare 4 servers use the IPXTM protocol exclusively and do not support TCP/IP communication. 
Therefore, before running a consolidation project from a NetWare 4 server to a NetWare 5, NetWare 
6, or Nterprise Branch Office appliance, you must first bind IPX on the destination server and on the 
workstation running the Server Consolidation Utility. Otherwise, the consolidation will fail.

6.11.1  Binding IPX on the Server

1 At the server console, enter

inetcfg

2 Select Boards, then press Enter.

3 Press Insert.

4 Select the appropriate network interface, then press Enter.

5 Specify a board name and slot number, then press Esc.

6 Select Yes to save changes, then press Enter.

7 To return to the main Internetworking Configuration screen, press Esc.

8 Select Protocols, then press Enter.
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9 Select IPX, then press Enter.

10 Enable and configure IPX, then exit the INETCFG utility.

TIP: If you prefer, IPX can also be enabled on the server by adding the appropriate LOAD and 
BIND commands to the server’s autoexec.ncf file.

6.11.2  Binding IPX on the Client

1 Access the Novell Client software and start the installation procedure. 

2 Select the client version you want, then click Next.

3 Select the appropriate language, then click Next.

4 Select Custom, then click Next.

5 Select IP and IPX.

6 Click Next > Next > Finish.

6.11.3  Verifying IPX Is Bound on the Client

1 Right-click the red N on the status bar (system tray) on your workstation.

2 Select Novell Client Properties.

3 Click the Protocol Preferences tab.

If the Protocol window displays both IP and IPX, the client has IPX bound.

If the Protocol window displays only IP, then IPX needs to be bound on the workstation.

You can now proceed with your consolidation project.

6.12  Server-Based Processing
The server-based processing feature gives you the flexibility of running the file copy portion of the 
utility as a scripted process on the server, instead of having the workstation monitor the process. 
When this feature is enabled, the Server Consolidation Utility does not control or monitor the actual 
data copying or do any error handling. You must load an agent on each server to process the project.

This feature is primarily designed to be used in remote consolidation scenarios where the servers are 
located across a WAN link from the workstation. In such a scenario, there is a higher likelihood of 
losing the connection with the servers, which causes normal workstation-based consolidation 
projects to fail.

NOTE: Server-based processing does not support projects that include printer migrations. Use this 
feature only for data copy projects.

Because this feature is meant to be used only in specific situations, you must enable the feature in 
order to use it. 

6.12.1  Enabling Server-Based Processing

Server-based processing is enabled from the Project Window by clicking Project > Enable Server-
Based Processing and answering Yes to the prompt. 
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After the feature is enabled, continue to model your project as you normally would.

6.12.2  Verifying a Project for Server-Based Processing

After modeling your project, proceed with the precopy verification. With server-based processing 
enabled, you see an additional server-based processing dialog box that explains more about this 
feature. The dialog box asks you whether or not you want this project to run as a server-based 
process.

To have your project run as a server-based process, click Yes.

Two of the usual verification screens do not appear in a server-based processing project. One is the 
Synchronize Files and Folders dialog box, and the other is the Compare Files and Folders dialog 
box. If you want to perform the synchronization or comparison, you can do so after the process has 
run on the server. See Section 6.12.5, “Performing Synchronization or Comparison after a Server-
Based Process Project,” on page 60 for more information.

After the verification completes successfully, click Proceed in the Start Novell Server Consolidation 
Utility dialog box. Instead of copying data, the utility creates the files necessary for server-based 
processing on all appropriate servers.

When the files are ready, a dialog box displays that allows you to view the log files and close the 
project.

View the success log for a list of the commands you need to run on which servers. The syntax for the 
command is:

nuwagent -a "ProjectName"

When consolidating to a NetWare server, you run the command on the destination server.

Click Close to exit the Server Consolidation Utility.

6.12.3  Launching a Server-Based Process

Consult the project’s success log file for a list of which commands you need to run on which servers. 
The success log is located in the project folder (by default, project folders are created as 
subdirectories under My Documents). 

The information you need is found in the “End Project Options and Warnings” section of the file. An 
example is shown below:

*****************************************************************

End Project Options and Warnings.

*****************************************************************

Server-based process files created on server TEST2. Launch this process at the 
server console with the command: NUWAgent -a "Project01"

At the console of the specified server, enter the command as shown. Be sure to include the quotation 
marks around the project name. The command is not case sensitive.

Upon completion of the processing, you can check the status in the sys:scu/migerror.log file on 
the destination server.
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IMPORTANT: Allow each server-based process to run to completion before starting another 
server-based process.

For security, after the processing is completed you should delete the XML script that is stored in the 
same folder as the project file. The script contains the administrator passwords in obfuscated form. 
Although the passwords are not written to the file in clear text, a knowledgeable hacker could derive 
the passwords from the obfuscated versions.

6.12.4  Aborting a Server-Based Process

If you need to halt a server-based process after it has started, enter these commands at the server 
console:

nuwagent kill

unload nuwagent

6.12.5  Performing Synchronization or Comparison after a 
Server-Based Process Project

If you want to perform a post-copy file and folder synchronization, reopen the project and click 
Project > Synchronized Dropped Folders. This deletes files and folders on the destination server that 
do not now exist on the source server.

If you want to perform a post-copy file comparison, reopen the project and click Project > Compare 
Copied Data. This compares files and folders between the source and destination servers to ensure 
an accurate copy.
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7Consolidating Data from Windows 
Servers

When migrating data from Windows servers, the Novell Server Consolidation Utility automates key 
tasks, such as copying Windows NTFS file system data to NetWare servers in a Novell eDirectory 
tree, migrating users, groups, and their file permissions, and assigning new user passwords. 

Before beginning your Windows data migration, you should plan your consolidation project and 
make the necessary preparations. Perform the following tasks in the order listed.

1. Understand Windows Consolidation Issues (page 61)

2. Meet System and Software Requirements (page 62)

3. Perform Prerequisite Tasks (page 63)

4. Launch Server Consolidation Utility and Create a Project File (page 63)

5. Model Your Consolidation Project (page 65)

6. Perform Precopy Verifications (page 66)

7. Run the Consolidation (page 68)

8. Perform Post-Consolidation Tasks (page 69)

7.1  Understand Windows Consolidation Issues
Although many tasks are automated in the Server Consolidation Utility, you should consider the 
following issues before you get started.

 Which Windows users are accessing which files and directories, and where are those files and 
directories located?

This information will help you decide which Windows servers to migrate first and how many 
servers you will need to migrate at one time. When you migrate your users and groups, you will 
want to migrate all files and directories that they have access to at the same time that you 
migrate their User objects.

NOTE: The Server Consolidation Utility migrates only global user accounts in the selected 
domain. It does not migrate local accounts provided in the domain for users whose regular 
accounts are in another domain 

 Which NetWare servers and volumes are you going to migrate your Windows server folders to? 

You should plan which servers and volumes in your destination eDirectory tree will receive 
each of your Windows server folders. You can select a separate location for each folder, if 
desired. In order to plan effectively, you will need to become familiar with the file structure on 
the NetWare servers in your destination eDirectory tree.

 Which Windows users and groups am I going to migrate? Which eDirectory containers on the 
destination eDirectory tree am I going to migrate them into?
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Decide which Windows users and groups you are going to migrate, then determine whether you 
will need to create separate containers for your Windows users and groups in the destination 
eDirectory tree. When you model your migration in the Project Window, you can create any 
additional eDirectory containers you might need by right-clicking an eDirectory Organizational 
Unit.

 Will I need to modify any user trustee rights after the migration?

There are many inherent differences in the way Windows and NetWare handle user trustee 
assignments. You should take these into account when migrating data between these server 
platforms. 

For example, there is no inheritance in the Windows file system like there is in NetWare. When 
you copy a folder and its subfolders for which a user has rights in Windows to NetWare, that 
user is assigned as a trustee for every file and subfolder and the Inherited Rights Filter is turned 
on for every file and subfolder. This effectively prevents rights from flowing down the 
directory structure like they normally do in NetWare. If you want to modify that user's trustee 
rights after the migration, you would have to do so for each file and folder individually.

 Do any existing eDirectory User objects represent the same person in my Windows domain?

Determine whether any of your Windows users already have an eDirectory account. During the 
migration you will be asked if you want to search the eDirectory tree for duplicate usernames. 
When the Server Consolidation Utility finds identical usernames, it displays them in a table 
where you can choose to merge each listed Windows user with an eDirectory User object. 

 How do I want to migrate information about my users and groups? Do I want to use a Template 
object? 

For information, see “Create a Template Object” on page 63.

 What if I have NTFS encrypted files that I want to copy?

The Server Consolidation Utility does not support the copying of NTFS encrypted files from 
Windows 2000/2003 servers. You must unencrypt the files before copying them to NetWare 
destination servers.

 Do I have any trusted domains?

If so, you must reassign any trusted domain permissions to the appropriate Windows users and 
groups after the migration is complete. Use ConsoleOne to reassign all lost trusted domain 
permissions.

7.2  Meet System and Software Requirements
The Server Consolidation Utility is launched from the Server Consolidation and Migration Toolkit, 
which runs on a Windows 2000 or Windows XP Professional Edition workstation or on a Windows 
2000/2003 server. 

NOTE: Although the Server Consolidation Utility lets you consolidate data from Windows NT 
servers, you cannot run the utility on Windows NT because the Novell Client software no longer 
supports Windows NT.

See “Workstation Requirements” on page 33 for more information about system and software 
requirements for running the Server Consolidation Utility.
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7.3  Perform Prerequisite Tasks
Perform the tasks in this section before you run the Server Consolidation and Migration Toolkit.

7.3.1  Create a Template Object

The first prerequisite task is to determine whether you want to use a Template object to migrate your 
NT users to the destination eDirectory tree.

A Template object defines additional eDirectory User attributes for NT users during the migration. 
We recommend that you use a Template object because it is an organized way to migrate your NT 
users to the eDirectory tree and manage them after they are there.

IMPORTANT: In order to migrate home directories, you must use a Template object.

If there is a conflict between the properties of a Template object and an NT policy, the properties of 
the Template object will, in most cases, take priority. For example, if a minimum password length of 
seven characters is specified for user Jeff in an NT policy and a minimum password length of nine 
characters is specified in the Template object, then when Jeff's object is migrated, the object will be 
created in eDirectory with a password length of nine characters. 

If you want to know what additional eDirectory attributes can be defined in a Template object, run 
ConsoleOne and double-click a Template object to view all of the existing properties.

The last name, full name, and description of every Windows user object is always migrated and 
these corresponding properties from the Template object are overwritten. 

If you decide to use a Template object, you can create one in ConsoleOne by clicking File > New > 
Object > Template.

7.3.2  Register the Workstation

Make sure that the workstation running the Server Consolidation and Migration Toolkit is registered 
within the domain that you want to migrate. If it is registered properly, continue with Section 7.4, 
“Launch Server Consolidation Utility and Create a Project File,” on page 63. 

If you want to change the domain that your workstation is registered in, do the following.

1 At the workstation, right-click My Network Places and then select Properties.

2 Select the Network Identification link.

3 Select Properties, specify the computer name and appropriate domain, then click OK.

4 Reboot the workstation and launch the Server Consolidation Utility from the toolkit again; then 
continue with the next section, Launch Server Consolidation Utility and Create a Project File.

7.4  Launch Server Consolidation Utility and 
Create a Project File
The Server Consolidation Utility is a Windows program that is launched from the Server 
Consolidation and Migration Toolkit.

1 If you have not already done so, start the Server Consolidation and Migration Toolkit.
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By default, the toolkit is installed in c:\program files\novell server consolidation 
and migration toolkit. You can access it by clicking Start > Programs > Novell Server 
Consolidation and Migration Toolkit > Novell Server Consolidation and Migration Toolkit.

2 Read the Welcome page, then click Create or Open Project.

3 Select Windows NT Server (NT Domain), then click Next.

4 Read the About page, then click OK.

5 Do one of the following:

 To start a new consolidation project, click Create a New Project > OK. Then continue with 
Step 6.

 To open an existing project, click Open an Existing Project > OK, select the project you 
want to work on, and then click Open. Then skip to Step 8.

 To open the last project you worked on, click Open Last Project > OK. Then skip to 
Section 7.5, “Model Your Consolidation Project,” on page 65.

The Server Consolidation Utility uses a project (.mdb) file to record your intended actions. The 
actions are recorded so you can execute them upon completing the project or save the project 
file and execute the actions later.

6 Type a project filename in the field provided.

The filename can be up to 64 characters long and can include any character except \ * ? < > | “ 
/. The project name also serves as the project's folder name, so you might want to keep it short. 
The project folder stores the log files and other files associated with the project.

7 (Conditional) If you want to store the project files in a location other than the default location 
shown, click Browse and navigate to the desired location. Then click OK.

By default, the Server Consolidation Utility saves your project in a subdirectory of My 
Documents.

8 Verify that the Windows domain that appears in the grayed-out text field is the domain that you 
want to migrate.

The Server Consolidation Utility automatically displays the domain that your workstation or 
server is a member of. 

You can change the domain that the workstation running the utility is registered in. To do this, 
exit the utility and follow the instructions in “Register the Workstation” on page 63.

9 Select your destination eDirectory tree from the drop-down list, then click Next. 

The destination eDirectory tree is the eDirectory tree that you want to migrate your Windows 
server data to.

If you are not logged in to your eDirectory tree, the eDirectory tree name will not appear in the 
drop-down list. If this is the case, click the Login button to log in to your eDirectory tree. After 
you are logged in, the eDirectory tree name automatically appears in the drop-down list.

10 Decide whether you want Server Consolidation to find any User objects in your Windows 
domain and in the destination eDirectory tree that have the same name, select Yes or No, then 
click Next.

11 To create and save your consolidation project, click Create.

When a project is created and saved, the Server Consolidation Utility creates a file that contains 
the success and error logs of your project; these logs contain the details of what took place 
during the consolidation.
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12 (Conditional) If you selected Yes to find User objects with identical names in Step 10, continue 
with Step 12a to resolve name conflicts. If you selected No, skip the rest of the steps in this 
section and go to Section 7.5, “Model Your Consolidation Project,” on page 65.

12a To select an eDirectory container on the destination eDirectory tree, click the Browse 
button.

12b Browse the tree and select an eDirectory container, then click OK.

12c To begin searching for duplicate usernames, click Next.

12d Decide what you want to do with Windows users that have the same name as eDirectory 
users.

You have the following options for each listed Windows user:

 Merge the Windows user with the displayed eDirectory user. Simply leave that user 
as it is displayed in the table and continue with the next listed Windows user.

 Merge a Windows user with a different eDirectory user. Click the arrow by the 
eDirectory username to view a drop-down list containing all the eDirectory users that 
have the same username (including contexts) as this Windows user. Select one of the 
eDirectory names and continue with the next listed Windows user.

 Do not merge the Windows user with any of the matching eDirectory users. Click the 
arrow by the eDirectory username to view a drop-down list, then select Don’t Merge. 
Select this option only if you know that none of the listed eDirectory users represents 
the same person as the adjacent Windows user.

12e After you have made a decision for each listed Windows user, click Finish.

The Project Window will now appear and the Windows users that you chose to merge with 
eDirectory User objects appear automatically as dropped objects in the destination 
eDirectory tree. 

7.5  Model Your Consolidation Project
Most of your work will be done in the Project Window, where you can drag-and-drop Windows User 
and Group objects into eDirectory containers, and Windows server folders into any volume or folder 
in the destination eDirectory tree.

The Project Window is a place to model different migration scenarios before you begin the actual 
migration without affecting your Windows domain or your destination eDirectory tree. All of the 
planning in the Project Window is done offline, meaning that items moved and created in the Project 
Window are not actually moved or created until you begin the migration. 

TIP: For information on shared Windows folders that end with a dollar sign ($), click anywhere on 
your Windows desktop, press F1, click the Index tab, then type $shares in the keyword text field. 

The Project Window and the Using the Project Window dialog box appear after you have created the 
consolidation project. The three basic steps outlined in this dialog box should be performed for each 
consolidation project. When you are familiar with the tasks that you will be performing, click Close 
to access the Project Window and begin modeling your migration project.
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Dragging-and-Dropping the Domain Info Object

To perform a consolidation from a Windows domain, you must drag-and-drop the Domain Info 
object from the left pane of the Project Window to an eDirectory container in the right pane of the 
Project Window.

Other Project Window Options

Review the following tips to help you organize your migration project and use the Project Window 
more effectively.

 Creating a New eDirectory Organizational Unit or Folder: To create a new eDirectory 
Organizational Unit (OU), right-click the parent eDirectory Organizational Unit or folder and 
then select New Organizational Unit or New Folder. 

 Viewing a Description of the Objects in the Project Window:  To see a short description of 
what an icon represents in the Project Window, right-click an eDirectory object and then select 
What’s This?

 Backing Out a Dropped Object: To return a dropped object to its original position, right-click 
a dropped Windows object in the domain or the destination eDirectory tree and then select Back 
Out Dropped Object.

 Finding Out Where a Dropped NT Object Came From: To find out where a dropped object 
was located in the Windows domain, right-click a Windows object and then select Where Did It 
Come From? When dragging-and-dropping objects, this will help you remember where a 
dropped object was previously located in the domain.

When you are satisfied with where you have dropped your Windows server folders, users, and 
groups in the eDirectory tree, you can proceed to verify your consolidation project to resolve any 
potential problems before migrating your Windows data.

7.6  Perform Precopy Verifications
After you have modeled your consolidation in the Project Window, you should verify that the 
proposed locations for these new objects do not conflict with existing names, rights, name spaces, 
etc., in the eDirectory tree. 

Remember, you have simply created a model of how you want to copy the Windows data to the 
destination servers and volumes; no data has yet been migrated. Dragged-and-dropped items 
appearing in the eDirectory tree are merely assigned to be copied to that area in the eDirectory tree. 
Objects are not actually copied until you begin the consolidation process. When migrated, Windows 
User objects are converted to eDirectory objects and placed in the destination eDirectory tree.

Because a similar verification process is run when you begin the actual consolidation, running the 
precopy verification process prior to consolidation is not mandatory. However, catching any critical 
errors or warnings now will speed up the verification process during the consolidation. 

1 From the Server Consolidation Utility menu, select Project > Verify and Copy Data or click the 
Do the Consolidation button on the toolbar, then click Next.

2 Read the Welcome page, then click Next.

3 If you want to apply a Template object to newly created eDirectory users, browse the tree, 
select the Template object from the tree view, and then click Next. 

If you do not want to use a Template object, uncheck the box, then click Next.
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To migrate home directories, you must use a Template object when migrating your Windows 
users to the destination eDirectory tree. Make sure a Home Directory property is defined for the 
Template object you are using.

TIP: If you have not created a Template object but you want to use one now, save the project, 
go to ConsoleOne, and create the Template object. Next, launch the Server Consolidation 
Utility again and click Open Last Project. Then restart this migration procedure again starting 
with Step 1.

4 Decide how you want to handle any duplicate filenames between the Windows domain and the 
destination eDirectory tree, select one of the following, then click Next:

 Don’t Copy Over Existing Files: The file on the source server is not copied and the file 
on the destination server is not replaced. 

 Copy the Source File If It Is Newer: If the file on the source server is newer than the one 
on the destination server, the file on the destination server is replaced.

 Always Copy the Source File: The file on the source server always replaces the file with 
the same name on the destination server.

5 Decide how you want to handle passwords for your Windows users, select one of the following, 
then click Next:

 Assign the Same Password to All Users: The utility will assign the same password to all 
migrated users.

 Assign a Randomly Generated Password to All Users: The utility will randomly 
generate passwords, assign them, and then store the passwords it assigns in a file that it 
creates, named project_name_out.txt. This file is saved in the same directory where 
your consolidation project is located.

 Read Passwords from a File: The utility will migrate the current Windows passwords to 
the destination eDirectory tree by reading them from a text file. You must create the text 
file containing the Windows passwords before you begin the migration.

For more information on how to create this file, click the Help button.

6 Set Windows consolidation options by checking or unchecking the check boxes next to the 
following options and then click Next:

 Copy File Permissions: Normally, the utility migrates file and directory permissions. If, 
for some reason, you want to reassign file and directory permissions, you can choose to 
not copy the file and directory permissions here and then assign them later with 
ConsoleOne.

 Copy Everyone Permissions: The eDirectory container that you drop the Windows 
Domain Info object into will be assigned the permissions that were associated with group 
Everyone. If you are migrating the Everyone permissions, be sure to drop the Domain Info 
object high enough in the eDirectory tree so that all Windows users will inherit those 
permissions.

TIP: Every new folder that is created in the Windows domain automatically receives the 
Everyone permissions by default.
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 Restart Option: Normally, this information is not erased; however, if you have 
previously run a consolidation program and deleted the eDirectory objects from the 
destination tree, and you are planning to start over and migrate the same domain again, 
check this check box.

When you migrate users and groups from Windows, the Server Consolidation Utility 
stores a table of Windows names and associated eDirectory usernames in the registry of 
the Primary Domain Controller (PDC). The utility then uses this information when 
migrating the file system so that it can remember where each user and group has been 
migrated to in the destination eDirectory tree. By storing this information, the utility can 
assign the correct file permissions to the appropriate users. 

7 To begin the verification, click Next in the Verify NT to NetWare Project window. 

8 (Conditional) If prompted, resolve any naming conflicts between different-type objects, then 
click Next.

You can choose to merge different-type objects or to keep them as they are.

9 (Conditional) If prompted, resolve any naming conflicts between same-type objects, then click 
Next.

You can choose to merge same-type objects or to keep them as they are.

10 (Conditional) If prompted, verify that you do not want to migrate the listed Windows users and 
groups, then click Next. 

If you migrated all of your users and groups, you will not see this dialog box.

Otherwise, this step must be done three times—once each for your Windows local groups, 
global groups, and users that were not dragged and dropped into the destination eDirectory tree. 

If you have made a mistake, click Cancel to return to the Project Window. Then drag-and-drop 
the objects, go to the toolbar, click Project > Verify and Copy Data, then restart this procedure 
with Step 1 on page 66.

11 Resolve any critical errors. 

Warnings or noncritical errors can be resolved after the consolidation. To resolve a critical error 
or warning, read the description in the text field located beneath it. This description should give 
you a good idea of what could be the possible cause and a suggestion for fixing it.

If you are copying data from a Windows 2000/2003 server, you might see several “Group 
membership from another domain” errors stating that a particular group or user will not be 
migrated. These errors are informational; the specified group or user accounts have no purpose 
or function in Netware.

7.7  Run the Consolidation
1 Do one of the following:

 To start the actual consolidation, click Proceed.
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 If you are only running the verification process at this point and want to do the 
consolidation later, click Cancel > Yes to save the changes you have made to the project 
file. 

When you are ready to proceed with the consolidation project, relaunch the Server 
Consolidation Utility from the Server Consolidation and Migration Toolkit, select Open 
an Existing Project, and click OK. Select the project file you want to open, click Open, and 
then follow the instructions found in Section 7.6, “Perform Precopy Verifications,” on 
page 66, starting with Step 1.

2 View the error and success logs.

Continue with the next section, Section 7.8, “Perform Post-Consolidation Tasks,” on page 69.

7.8  Perform Post-Consolidation Tasks
After you’ve migrated your Windows data to the destination eDirectory tree, complete the following 
tasks:

 Use ConsoleOne or Novell iManager to make sure that your Windows users and groups have 
been migrated to the correct place in the destination eDirectory tree and have the correct file 
and share permissions. 

Keep in mind that some of the advanced NTFS permissions do not correspond to any of the 
NetWare rights and are therefore not migrated.

TIP: If you end up with more or fewer permissions than you planned for, enter CACLS/? at the 
DOS prompt and follow the on-screen instructions. Permissions are sometimes hidden in 
Microsoft utilities; therefore, running this command at the DOS prompt lets you see all of the 
permissions associated with your Windows objects, even the hidden ones.

 At the destination server, use iManager to view the volume that you migrated your data to and 
verify that it was done correctly.

 Set up iPrint. For instructions, go to the online documentation (http://www.novell.com/
documentation) for the destination server’s operating system and select iPrint.

 Check the migrated users’ home directories to make sure that they were migrated the way you 
expected them to be.

 Distribute the new eDirectory passwords to all of your users. The passwords are located in a 
password file that the Server Consolidation Utility created for you named 
project_name_out.txt. This file is located in the same directory where you saved your 
consolidation project.

7.8.1  Novell ZENworks and Roaming Profiles

If you are using Novell ZENworks to support Roaming Profiles, ZENworks version 6.5 and later 
creates an NT Roaming Profile directory the first time a migrated Windows user logs into his or her 
eDirectory account on NetWare. The directory is either the eDirectory User Home Directory or an 
explicit UNC path, as specified in the ZENworks User Package assigned to that user. The time-
consuming process of having the Server Consolidation Utility copy the NT Profile directory is no 
longer needed and has been removed.
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8Troubleshooting Server 
Consolidations

Refer to the appropriate section if you are having trouble.

8.1  Troubleshooting the Server Consolidation 
Utility
 “General Troubleshooting” on page 71

 “Error Code: 0Xfffffd63 - Contents of the eDirectory Container Can’t Be Listed” on page 71

 ““SMDR Not Communicating” or “Error Opening Connection to SMDR” Errors” on page 72

 “NDPS Printer Agents Don't Migrate” on page 77

 “NUWAGENT Won’t Load (NetWare 4.2 Only)” on page 77

 “Server Consolidation Performance Problems” on page 73

 “Volume Contents Do Not Display” on page 72

 “Server Consolidation Utility Copies Incomplete Data Files” on page 74

 “Errors When Connecting to a NetWare 4 Server” on page 75

General Troubleshooting

Explanation: In general, when troubleshooting errors in the Server Consolidation Utility, 
first ensure that the latest smdr.nlm and tsafs.nlm modules are loaded on 
the source and destination NetWare servers.

The log files contain detailed information about what was successfully copied 
(success log) and what was not copied and why (error log). The log files are 
written to the project folder, which is located by default in My Documents. 

Utility Hangs when Selecting Source and Destination Trees

Problem: When running the Server Consolidation Utility on a Windows 2000 
workstation, the application hangs when selecting the source and destination 
trees for the consolidation project.

Action: Install Windows 2000 SP 2 or later on the workstation to correct this issue.

Error Code: 0Xfffffd63 - Contents of the eDirectory Container Can’t Be Listed

Possible Cause: Your workstation is not running the latest support pack update of the Novell 
Client for Windows 2000/XP version 4.91.

Action: Download the latest version of the Novell Client 4.91 software from the 
Novell Downloads page (http://www.novell.com/download) and install it on 
your workstation. See “Workstation Requirements” on page 33 for other 
workstation requirements.

Possible  Cause: Authentication to eDirectory failed due to invalid password.
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Action: Make sure you are authenticated to the eDirectory tree. 

Possible Cause: When the source server attempts to synchronize with the target server and the 
server's database is locked.

Action: Make sure the target server’s database is not locked.

Possible Cause: NICI is corrupt.

Action: Reinstall NICI.

Volume Contents Do Not Display

Problem: No data appears in the Volume object after dropping a container into a volume 
that has not been opened.

Action: Map a drive to the volume from the workstation.

“SMDR Not Communicating” or “Error Opening Connection to SMDR” Errors

Possible Cause: The Storage Management Data Requester (SMDR) and Target Service Agent 
(TSA) are not loaded on either the source or the destination server, or the 
sys:etc/hosts file does not contain the server IP addresses, or Service 
Location Protocol (SLP) is not properly configured.

Action: Check to see if smdr.nlm is running on a NetWare server by entering m smdr at 
the server console.

If SMDR is not loaded on the source or destination server, manually load it. 
enter, load smdr. 

Action: Check to see if tsafs.nlm is running on a NetWare server by entering m tsa* 
at the server console.

If TSAFS is not loaded on the source or destination server, manually load it. 
enter, load tsafs.

Action: On a small network with three or fewer servers, you do not need to configure 
SLP. Instead, edit the sys:etc/hosts file on the source server to contain the 
IP address and DNS name of the destination server, and vice versa on the 
destination server.

After editing the sys:etc/hosts files, you might need to reload smdr.nlm 
and tsafs.nlm on your NetWare servers.

Action: Enter display slp services smdr.novell//(svcname-ws==source_ 
server_name) (replace source_server_name with the name of your source 
server) at the destination server console.

If it appears there is a problem with SLP, go to Novell’s Knowledgebase (http:/
/support.novell.com/search/kb_index.jsp) and search for SLP-related 
configuration information.

Trustee Rights Restored to Wrong User in Tree-to-Tree Copy

Problem: In a tree-to-tree consolidation scenario, it is possible to have users with the 
same Common Name (CN) that exist in multiple contexts in the destination 
tree (for example, jdoe.users.novell, jdoe.mktg.novell, and jdoe.sales.novell). 
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If you do not match up the user in the source tree with the desired user in the 
destination tree, SMS automatically copies trustee rights to the first user match 
it finds.

Action: Before running the consolidation, be sure to match up the users in the source 
tree with the correct users in the destination tree. 

Server Consolidation Performance Problems

Explanation: The performance of a project can be determined by looking at the success log 
after a project completes. The success log gives the amount of time the project 
took to complete and the amount of data copied.

There are several factors that determine the performance of the file copy. It is 
also important that each server be updated to the latest Support Pack to ensure 
you have the latest performance enhancements for SMS.

Possible Cause: Heavy traffic on the network.

Action: Speeds can be increased by connecting servers and the workstation to a 
dedicated switch.

Possible Cause: A mismatch in duplexing among servers, switches, and the workstation.

Action: Make sure all hardware is set to either full duplex or half duplex. Setting all 
hardware to half duplex might result in greater performance than full 
duplexing.

Possible Cause: Virus scan software running on the source or destination servers.

Action: Turn off any virus scanning software on the source or destination servers to 
increase the speed of the consolidation. Turn the virus scanning software back 
on after the consolidation completes.

Possible Cause: An incorrect version of smdr.nlm is loaded on a NetWare server.

Action: At the NetWare server, unload smdr.nlm, then load the version of the 
smdr.nlm file that comes with the newest Support Pack.

Possible Cause: Small file sizes.

In general, the larger the file sizes, the better the performance. Copying a 
single 500 MB file will be significantly faster than copying five thousand 100 
KB files.

Possible Cause: Hardware configuration.

The performance of the Server Consolidation Utility varies according to the 
environment. Using a 100 MB LAN, tests have measured speeds ranging from 
3 to 15 GB per hour, with the most common speed being between 5 and 8 GB 
per hour. You should check the performance of your LAN before copying very 
large amounts of data. 

The Server Consolidation Utility copies data at a faster rate than a Windows 
file copy.
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Server Consolidation Utility Copies Incomplete Data Files

Problem: Files copied to the destination server have any of the following characteristics:

 Destination is a 0-byte file.

 Creation time and date are incorrect when compared to the source server.

 Modification time and date are incorrect when compared to the source 
server.

 File was not completely copied. (This would be indicated by the 
destination file being smaller in size than the source file.)

Action: Use the latest SMDR and TSAFS modules on the source NetWare server.

Path Size Limitations for Data Copy

Problem: Because the Server Consolidation Utility is a Windows-based program, it is 
subject to the path size limitation of Windows, which is 255 characters. If you 
have data where the path name is longer than 255 characters, the Server 
Consolidation Utility cannot copy data that exceeds this maximum. 

Action: One workaround is to reorganize the data on your source server so that the path 
size does not exceed 255 characters.

Action: Another possibility is to use the server-based processing feature to copy the 
data. Since the workstation does not monitor the file copy process, it is not 
subject to the path size limitations of the workstation. However, the server-
based processing copy is limited by the supported path size of the server 
operating system. For example, if the server allows path sizes up to 1024 
characters, then data is copied up to the 1024-character path limit.

“Trustee Not Restored” Errors When Copying Double-Byte Character Data Tree-to-
Tree

Explanation: In a tree-to-tree consolidation, the Server Consolidation Utility stores the full 
distinguished names of trustees in a file that is stored on the destination server. 
This file is stored using the local code page of the destination server. Object 
names containing double-byte characters (Japanese and other oriental 
languages) may not match if the local code page versions on the source and 
destination servers do not match exactly. 

Problem: When the object names do not match between the source and destination 
server, you might see messages such as “Trustee name was not restored for 
path, because the trustee IDs are different.”

Action: Because of known limitations with code pages, this issue cannot be resolved in 
the current version of the Server Consolidation Utility. Novell plans to address 
this in a future release of the Server Consolidation and Migration Toolkit.

Errors When Migrating a Cluster Volume

Problem: When using the Server Consolidation Utility and migrating data from or to a 
cluster volume, an error (0xFFFDAE) might occur if your cluster server nodes 
are spread throughout different eDirectory contexts. If the server (from the 
SCU project) that holds the mounted cluster volumes does not have rights to 
the cluster Virtual Server object and the cluster-enabled Volume object, and 
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does not have a Read/Write replica of the partition these objects reside in, then 
a failure fffdae is displayed on the verification screen of the Server 
Consolidation Utility.

Action: To resolve this, add the server as a trustee of the context that contains the 
Virtual Server and Cluster Volume objects. The default rights assigned when 
adding the trustee are sufficient.

Problem: When migrating data to or from a NetWare 5.1 cluster volume, the copy fails 
with a critical error: “Error opening connection to SMDR.”

Action: For the Server Consolidation Utility to function properly with a NetWare 5.1 
cluster-enabled volume, you must use the server name followed by an 
underscore followed by the Volume Name object (for example, server1_vol1). 
For details, see Section 6.9, “Consolidating Data to or from a NetWare 5.1 
Cluster,” on page 54.

Unloading NUWAGENT.NLM on an Nterprise Branch Office Appliance

Problem: When running the Server Consolidation Utility in conjunction with an 
Nterprise Branch Office appliance, if an error state occurs and you are asked to 
unload nuwagent.nlm, the system might not allow you to unload the module. 

Action: Perform a reboot of the Nterprise Branch Office appliance.

Errors When Connecting to a NetWare 4 Server

Problem: When attempting to connect to a NetWare 4 server, any of the following types 
of errors are returned:

 An error occurred opening the file. filename was invalid.

 Error opening connection to SMDR.

 The name spaces couldn’t be checked.

 8998 error. NWGetVolumeNumber.

Action: There are several actions to take if errors are returned when trying to connect 
to a NetWare 4 server, including the following:

 If your source server is NetWare 4, make sure that you have IPX on your 
client. For information on verifying IPX on your client, see 
Section 6.11.3, “Verifying IPX Is Bound on the Client,” on page 58.

 Add a mapped drive to the source server.

 Ensure that SLP is configured properly on the servers involved in the 
consolidation project.

Problem: NetWare 6.5 won't communicate with NetWare 4 during a consolidation. IPX 
was not installed during the NetWare 6.5 installation.

Action: Add IPX to the NetWare 6.5 server after the NetWare 6.5 installation is 
complete.

1 Enter edit sys:system/autoexec.ncf at the NetWare 6.5 server 
console.

2 Add the server ID of the source server and save the autoexec.ncf file.
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Problem: IPX connection is not communicating.

Action: Ensure that there is an IPX connection to the server.

To verify that the source and destination servers can see each other via IPX:

1 On the server console of the destination server, enter serverid xxxxx, 
where xxxxx is the unique server ID number for the server.

2 Enter load ipxping.

3 Enter the internal IPX number of the source server.

4 Repeat this process on the source server, replacing the internal IPX 
number of the source server with the destination server's internal IPX 
number in Step 3.

Action: Bind IPX on the destination server.

1 At the destination server console, enter inetcfg.

2 Select Boards and press Enter.

3 Press the Insert key.

4 Select the appropriate network interface and press Enter.

5 Enter a board name and slot number, then press the Esc key.

6 Select Yes to save changes and press Enter.

7 Press the Esc key to return to the main Internetworking Configuration 
screen.

8 Select Protocols and press Enter.

9 Select IPX and press Enter.

10 Enable and configure IPX and exit the inetcfg utility.

TIP: If you prefer, IPX can also be enabled on the server by adding the 
appropriate Load and Bind commands to the server’s autoexec.ncf file.

Action: Verify that IPX is bound on the client running the Server Consolidation Utility:

1 Right-click the red N in the system tray on your workstation.

2 Select Novell Client Properties.

3 Select the Protocol Preferences tab.

If the Protocol window displays both IP and IPX, the client has IPX 
bound.

If the Protocol window displays only IP, then IPX needs to be bound on 
the workstation.

Action: Bind IPX on the client running the Server Consolidation Utility:

1 Obtain the latest Novell Client software and run the installation program. 

2 Select the appropriate language and click Next.

3 Select Custom and click Next.
 Server Consolidation and Migration Toolkit Administration Guide



n
ovdo

cx (e
n)  16

 A
p

ril 20
10
4 Click the radio button next to one of the following two choices:

 IP and IPX

 IP with IPX compatibility

TIP: You can select this choice if you are running in an scmd 
environment.

5 Click Next > Next > Finish.

Action: Ensure that the correct smdr.nlm and tsa.nlm are loaded on the server.

1 On the server console, enter unload smdr.

2 Enter smdr new.

3 Enter N when asked if you want to disable NDS.

4 Enter N when asked if you want to disable SLP.

5 Enter N when asked if you want to disable SAP.

6 Enter N when asked if you want to disable name resolution through 
sys:\etc\hosts file.

7 Enter load smdr on the server console.

8 Enter load tsafs on the server console.

NUWAGENT Won’t Load (NetWare 4.2 Only)

Possible Cause: Clibaux.nlm is not loaded.

Action: Go to the server specified in the error message and at the server console, enter 
load clibaux.nlm.

NDPS Printer Agents Don't Migrate

Possible Cause: If after a migration, it appears NDPS Printer Agents have not migrated, it is 
possible that eDirectory has not had time to properly synchronize.

Action: Wait for a few minutes, then check again to see if eDirectory has been updated 
to reflect the Printer Agent migration.

Action: If the Printer Agents have still not migrated after allowing eDirectory to 
synchronize, ensure the Novell Distributed Print Services Manager 
(ndpsm.nlm) is loaded on either the source or destination server.
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IVServer Migrations

 Chapter 9, “Preparing for a Server Migration,” on page 81

 Chapter 10, “Migrating Data from NetWare Servers,” on page 85

 Chapter 11, “Troubleshooting Server Migrations,” on page 99
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9Preparing for a Server Migration

To prepare your network for a server migration with the Novell NetWare Migration Wizard, 
complete the tasks in the following sections:

 Section 9.1, “Meeting System and Software Requirements,” on page 81

 Section 9.2, “Preparing the Source Server for Migration,” on page 82

 Section 9.3, “Installing the Destination Server,” on page 82

9.1  Meeting System and Software Requirements
The Server Consolidation and Migration Toolkit, which includes NetWare Migration Wizard 8.2, 
runs on a Windows workstation. This section provides information about the system and software 
requirements for the Windows workstation, the source server, and the destination server.

9.1.1  Workstation Requirements

NetWare Migration Wizard 8.2 is installed as part of the Server Consolidation and Migration 
Toolkit. If you have not already met the workstation requirements and installed the toolkit, see 
Section 3.1, “Meeting the Workstation Requirements,” on page 25.

9.1.2  Source Server Requirements

The source server is the NetWare server that contains the files, volumes, and NDS/eDirectory 
objects to be copied to the NetWare destination server. 

 The source server must be running a supported version of NetWare. See Section 1.3, 
“Supported Source and Destination Server Versions,” on page 16 for more information.

 If you want to migrate NetWare servers running eDirectory 8.8 SP2, you must update both 
source and destination servers to NetWare 6.5 SP7 or later. Otherwise, the destination server 
fails to reboot after the third step of the migration.

 If necessary, update the source server with the latest NetWare Support Pack. 

Updates are available at the Consolidated Support Pack home page (http://support.novell.com/
tools/csp).

 You must have the Supervisor right to the source server’s file system and the source server 
itself. Use ConsoleOne to verify that you have the necessary rights.

IMPORTANT: When migrating a NetWare 6.0 server with eDirectory version 8.6.2 to a new 
NetWare 6.0 server with eDirectory 8.6.2, you might encounter an NDS error stating you 
couldn’t copy an NDS object because you do not have the proper rights. This can occur even if 
you are logged in as Admin. 

Installing eDirectory version 8.7 or later on the source server and running the migration again 
resolves this issue.
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9.1.3  Destination Server Requirements

The destination server is the new computer that is to receive the data from the source server. This 
server must be installed into a temporary tree and it must be the only server in that tree. 

 The destination server must be running a supported version of NetWare. See Section 1.3, 
“Supported Source and Destination Server Versions,” on page 16 for more information.

Migration Wizard 8.2 does not migrate to NetWare 4 or NetWare 5 destination servers. 

 If you want to migrate NetWare servers running eDirectory 8.8 SP2, you must update both 
source and destination servers to NetWare 6.5 SP7 or later. Otherwise, the destination server 
fails to reboot after the third step of the migration.

 Select the Pre-Migration Server pattern when you install the destination server, as instructed in 
Section 9.3, “Installing the Destination Server,” on page 82.

 You must have the Supervisor right to the destination server’s file system and the destination 
server itself. After you install the destination server, use ConsoleOne to verify that you have the 
necessary rights.

 The source and destination servers must be using the same time synchronization method: 
Timesync (timesync.nlm) or NTPv3 (xntpd.nlm). 

See the NW 6.5 SP8: Network Time Synchronization Administration Guide and the NW 6.5 
SP8: NTP Administration Guide for more information about time synchronization.

9.2  Preparing the Source Server for Migration
Before you launch NetWare Migration Wizard from the Server Consolidation and Migration Toolkit, 
follow these steps to prepare the source server:

1 Shut down any applications, products, or services (virus scan software, backup software, etc.) 
running on the server to be migrated.

2 Verify the health of eDirectory by loading DSRepair and running the following three options:

 Unattended Full Repair

 Time Synchronization

 Report Synchronization Status

If any errors are reported, resolve them before attempting the migration.

3 Back up eDirectory and all data on the server.

4 Remove any unnecessary applications, then delete and purge unused files and folders.

9.3  Installing the Destination Server
The next step is to install the destination server with the NetWare operating system that you are 
migrating to. 

1 Obtain the NetWare installation software for the version of NetWare you require.

2 Prepare the new server hardware as recommended in the NetWare installation documentation.
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3 Run the NetWare Install program.

 For instructions on installing NetWare 6.5 up to and including SP2, see the NetWare 6.5 
Installation and Overview Guide (http://www.novell.com/documentation/nw65/install/
data/hz8pck9v.html).

 For instructions on installing NetWare (NetWare 6.5 SP7 and later), see the NW65 SP8: 
Installation Guide.

4 During the installation, make sure that you do the following:

 As you create volumes, verify that you have enough room on your destination server to 
accommodate your source server data.

If you are migrating compressed volumes to uncompressed volumes, Migration Wizard 
decompresses the volumes during the migration. Make sure you have enough room on the 
uncompressed volume to accommodate the source volumes after they are decompressed.

 Select the Pre-Migration Server pattern.

 Assign a different IP address to the destination server than is assigned to the source server.

After the migration completes and the source server is taken offline, you can change the 
destination server’s IP address to match what had been assigned to the source server.

 Assign the destination server a temporary name and install it into a new temporary 
eDirectory tree. 

You can name the server and tree anything you want (provided the names do not conflict 
with any existing server or tree on the network), because they are only temporary and 
cease to exist after the migration is complete.

IMPORTANT: The temporary server name and temporary tree name must not be the 
same as the source server's name or tree name; otherwise, the destination server cannot 
assume the identity of the source server after the migration.

5 (Conditional) If the destination server is running NetWare 6.5, you must disable the Universal 
Password feature until the migration completes. 

Universal Password is disabled by default on NetWare 6.5.

9.4  Tips for a Successful Migration
 When you run the NetWare Migration Wizard, you must be logged in to the network as a user 

with the Supervisor right to both the source and destination servers. If you are not logged in 
when you start the Migration Wizard, you can log in as you select the source and destination 
trees.

 For better performance, we strongly recommend that the source server, destination server, and 
client workstation run on a common LAN segment.

 You should use the fastest workstation available to run the Migration Wizard. If possible, 
assign the workstation a static IP address. Turn off screen savers and power management to 
avoid interruptions during the migration.

9.5  What’s Next
For instructions on using the NetWare Migration Wizard, continue with Chapter 10, “Migrating 
Data from NetWare Servers,” on page 85.
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10Migrating Data from NetWare 
Servers

After you have completed the prerequisite procedures in Chapter 9, “Preparing for a Server 
Migration,” on page 81, you are ready to migrate data from your NetWare source server. To do this, 
complete the following tasks in the order they are listed:

1. Launch Migration Wizard and Create a Project File (page 85).

2. Model Your Migration Project (page 86).

3. Verify Your Migration Project (page 88).

4. Migration Step 1: Copy File System Data (page 88).

5. Migration Step 2: Edit Configuration Files (page 91).

6. Migration Step 3: Begin NDS/eDirectory Migration (page 92).

7. Migration Step 4: Finish the NDS/eDirectory Migration (page 95).

8. Perform Post-Migration Tasks (page 95).

10.1  Understanding NetWare Server Migration 
Issues
Before running a migration project in a NetWare/eDirectory environment, be sure you have prepared 
your server as described in Chapter 9, “Preparing for a Server Migration,” on page 81.

You should also be aware of the issues discussed in this section.

10.1.1  User Space Restrictions Only Migrated in Full Volume 
Copies

In migration projects where individual folders are dragged and dropped, or where a volume is copied 
to a folder on the destination server, user space restrictions on the source volume are not migrated to 
the destination volume.  

If your migration project is set up to copy an entire volume, with the contents of the source volume 
being copied to the root of the destination volume, user space restrictions are migrated to the 
destination volume.

10.2  Launch Migration Wizard and Create a 
Project File

1 If you have not already done so, start the Server Consolidation and Migration Toolkit. 

By default, the toolkit is installed in c:\program files\novell server consolidation 
and migration toolkit. You can access it on the desktop by clicking Start > Programs > 
Novell Server Consolidation and Migration Toolkit > Novell Server Consolidation and 
Migration Toolkit.
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2 Read the Welcome screen, then click Create or Open Project.

3 Select NetWare (eDirectory), then click Next.

4 Select Migrate Data to New Server (Hardware Upgrade), then click Next.

NetWare Migration Wizard is launched.

5 Read the About screen, then click OK.

6 Do one of the following:

 To start a new migration project, select Create a New Project > OK.

 To open an existing project, select Open an Existing Project > OK, select the project file 
you want to work on, and then click Open.

 To open the last project you worked on, select Open Last Project > OK.

7 Name the project, select a place to save it, type a descriptive filename, then click Next.

By default, Migration Wizard saves all projects to c:\program files\novell migration 
wizard. You can click Browse to select a different location.

Migration Wizard uses a project (.mdb) file to record your progress throughout the migration. 
At any point before the migration is complete, you can exit Migration Wizard and restart the 
utility to pick up where you left off.

The filename can be up to 64 characters long and can include any character except \ * ? < > | “ 
/. It is a good idea to use a standard naming convention to clearly identify each project.

8 Select the eDirectory tree that contains your source server, then click Next.

If necessary, click the Login button to attach to the tree.

9 Select your source server from the eDirectory tree, then click Next.

If necessary, navigate the tree until you find the desired source server.

10 Select the eDirectory tree that contains your destination server, then click Next.

If necessary, click the Login button to attach to the tree.

11 Select your destination server from the destination eDirectory tree, then click Next. 

If necessary, navigate the tree until you find the destination server. It should be the only server 
in the tree.

12 To create the project file with the information you have entered thus far, click Create.

Continue with the next section, Model Your Migration Project.

10.3  Model Your Migration Project
The Project Window and the Getting Started Migrating from NetWare 5 or 6 window appear after 
you have created the migration project file.

If you do not want the Getting Started window to appear the next time you run the Migration 
Wizard, deselect Always Show This Window. Click Close to close the Getting Started window and 
begin modeling your project. 

The Project Window is where you can model different migration scenarios before you begin the 
actual migration. To do this, you drag volumes and folders from the left pane (which displays the 
source server’s volumes) and drop them into volumes and folders in the right pane (which shows the 
destination server’s volumes).
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Dragging-and-dropping data in the Project Window does not immediately perform the action. It only 
creates a preview of where the data will ultimately reside on the destination server. The data is 
copied only after the project verification is complete and the migration process begins.

10.3.1  Working in the Project Window

To begin modeling your migration project, decide what file system data on the source server will be 
copied to which volumes and folders on the destination server. You can drag-and-drop entire 
volumes or just selected folders from the source server to the destination server. 

You can also move created and dropped folders around in the destination pane by dragging them to 
the desired location.

Other Project Window Actions

In addition to dragging-and-dropping volumes and folders, you can perform several other tasks in 
the Project Window:

 To view a short description of the icons in the Project Window, right-click an object and then 
click What’s This?

 To set a new eDirectory tree context in either the left or right pane, right-click a container and 
then select Set Context.

 To create a new folder on the destination server, right-click an existing parent folder or volume 
and then select New Folder.

 To rename a newly created folder, right-click the folder and then select Rename.

 To show where a folder went, right-click the folder in the left pane and then select Where Did it 
Go?

The folder that was moved is highlighted in its new location in the right pane.

 To show where a folder came from, right-click the folder in the right pane and then select 
Where Did It Come From?

 To cancel a dropped action, right-click a folder in the right pane and then select Back Out 
Dropped Directory.

 To show all folders selected for copying, right-click a container in the left pane and then select 
Show Dropped Folders.

 To view the available disk space prior to performing the verification, right-click the destination 
volume in the right pane and then select Properties.

Right-clicking on a source volume or folder in the left pane and then selecting Properties 
displays the size of the source object.

Resolving Duplicate Directory Conflicts

If you drag a folder from the source server into a folder with the same name on the destination 
server, a Duplicate Directory Encountered window appears. Here you can indicate how you want to 
handle occurrences of duplicate directories:

 Don’t Copy the Directory: Ensures that directories already existing on the destination server 
are not overwritten. The Migration Wizard copies only the source directories that do not exist 
on the destination server.
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 Merge Directory Contents: Merges the contents of the directory on the source server with the 
contents of the duplicate directory on the destination server.

 Merge All: Merges the contents of all duplicate directories.

 Rename: Renames a directory on the source server. you must enter a new directory name in the 
field provided. The directory on the destination server retains its original name.

Migrating User Directories and Server Application Directories

Because the destination server takes the place of the source server when the migration is complete, 
you should model your project to minimize the necessity of changing user login script mappings and 
application load files.

To preserve login script mappings to user directories, drag-and-drop these directories to the same 
location on the destination server as on the source server.

Likewise, to preserve application load files, drag-and-drop application directories to the same 
location on the destination server as on the source server.

When you have finished modeling your migration project, continue with the next section, Verify 
Your Migration Project.

10.4  Verify Your Migration Project
After you have modeled your migration by dragging-and-dropping data in the Project Window, you 
must verify your project to check for problems that might hinder a successful migration. 

NOTE: Remember, dragged-and-dropped items appearing in the eDirectory tree are merely 
assigned to be copied to that area in the eDirectory tree. Objects are not migrated until you actually 
begin the migration.

To perform the verification:

1 On the Migration Wizard toolbar, click Project > Verify and Migrate Project, or click the Verify 
and Migrate button.

2 (Conditional) If the Verification Wizard finds any problems (such as insufficient rights, name 
spaces that are not loaded, disk space limitation, and improper TSAs), you must resolve these 
problems and rerun the Verification Wizard before proceeding.

Continue with the next section, Migration Step 1: Copy File System Data.

10.5  Migration Step 1: Copy File System Data
During the Copy File System Data step, the dropped directories are copied to the destination server 
and created directories are added to the destination server. 

1 In the Project View dialog box, click Copy File System Data.

2 In the Dropped Folders dialog box, verify the accuracy of the source and destination paths for 
all of your dropped folders and then click Next.

3 (Conditional) If you created new folders as part of your migration project, verify the source and 
destination paths in the Created Folders dialog box and then click Next.
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4 In the Duplicate Files dialog box, indicate how you want to handle any duplicate filenames 
between the source and the destination by selecting one of the following and then click Next:

 Don’t Copy Over Existing Files: The file on the source server is not copied and the file 
with the same name on the destination server is not replaced.

 Copy the Source File If It Is Newer (Default): If the file on the source server is newer 
than the one on the destination server, the file on the destination server is replaced.

 Always Copy the Source File: The file on the source server always replaces the file with 
the same name on the destination server.

5 In the Disable Login dialog box, indicate whether you want users to be logged in during the 
data migration by selecting one of the following and then click Next. 

 Copy Volumes with Users Logged In (Default): Migration Wizard does not copy open 
files. Select this option if you want to copy nonaccessed files while users are logged in.

 Disable Login: If you disable user login, you can be sure that no other users can log in to 
the network and open files during the file copy.

If you want to delete all user connections prior to performing the migration, click 
Broadcast Logout Message to warn users to log out. If any user connections remain, you 
must manually disconnect them from the source server console. 

6 In the File Date Filters dialog box, indicate whether you want to filter the files to be copied 
according to Accessed, Modified, or Created dates and then click Next. 

If you select Yes, specify the desired date ranges. If you select No, all files are copied. 

Two dates can be set for each attribute. The first date is an On or After date and the second is an 
On or Before date. For example, if you select only On or Before for the Accessed attribute and 
set the date for October 10, 2005, only those files accessed on or before October 10, 2005, are 
copied. In the same example, if you also select On or After and set the date to September 1, 
2005, only those files accessed on or after September 1, 2005, and on or before October 10, 
2005, are copied.

You can specify as many ranges as you want, and only those files that meet all of the selected 
criteria are copied.

7 In the Wildcard Selection dialog box, indicate whether you want to filter files by name or 
extension by typing the filenames or extension types in the field provided and then click Next.

You can use a wildcard character to represent one or more characters in a search. The two most 
commonly used wildcards are the question mark (?) and the asterisk (*).

 The question mark is used to represent a single alphanumeric character in a search 
expression. 

For example, typing te?t.txt would exclude tent.txt, test.txt, and text.txt from 
the copy process.

 The asterisk is used to specify zero or more alphanumeric characters in a search 
expression. 

For example, typing h*s.txt would exclude hs.txt, his.txt, house.txt, and 
happiness.txt from the copy process.

Type as many filenames or file extension types as you want. Separate each entry with a hard 
return. For example:

*.mp3

*.wav
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test.txt

8 In the Synchronize Files and Folders dialog box, specify whether you want the Migration 
Wizard to delete files and folders on the destination server that do not exist on the source server 
and then click Next.

If users are active on the source server while you model your migration project, it is possible 
that they could delete files and folders that you have already selected for migration. 

 Select Yes if you want the Migration Wizard to scan all dropped folders after the copy 
process completes and delete any files and folders from the destination server that don’t 
exist on the source server.

 If you don’t want to synchronize files and folders, select No (the default selection).

9 In the File Comparison dialog box, specify whether you want the Migration Wizard to compare 
files and folders between the source and destination servers after the copy process completes 
and then click Next.

 If you don’t want to enable the comparison option, select No (the default selection).

 Selecting Yes causes the Migration Wizard to compare the following information during 
the post-copy file comparison:

 Names

 Dates

 Sizes

 Attributes

 Trustees

 Owners

If you select Yes, you are given the option of doing a binary comparison of the files after 
the copy process completes. A binary (byte-by-byte) comparison gives the greatest 
assurance that two files are identical, but it takes longer to complete.

By default, the Migration Wizard compares the Read inhibit (Ri) and Delete inhibit (Di) 
attributes on Read-only files. If you do not want this check to be performed, deselect 
Compare Ri/Di Attributes for Read-only files.

10 Specify where to store the trustee backup files, then click Next.

Before Migration Wizard starts copying files, it backs up trustee and ownership information for 
the source server's standard sys: volume and dropped folders to special trustee backup files for 
use only by Migration Wizard. When the eDirectory migration is complete, Migration Wizard 
restores the trustees from the files stored on the destination server.

The trustee backup files are stored on the destination server’s sys: volume by default. If your 
destination server has limited free space on volume sys:, you can select another volume to hold 
the backup files.

11 Type the passwords for the source and destination trees, then click Next.

SMS is the backup and copy engine used by the Migration Wizard. You type your passwords 
here because SMS requires that the servers involved in the migration be authenticated to each 
other.

12 (Conditional) If prompted, resolve any critical errors or warnings discovered during 
verification and then click Next.
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If there were errors discovered in the verification attempt, they are shown in the Error 
Resolution dialog box. Errors could include name conflicts, insufficient rights, required name 
spaces not loaded, and insufficient disk space.

Errors found during the verification process are classified as follows:

 Errors that must be resolved before files can be copied

 Errors that should be resolved but might not affect the copy process

 Informational messages about the decisions you made in the Project Window

A description of each error and a possible resolution appear in the Information text box. If no 
resolution is provided, you can find more information in the Novell Error Codes online 
documentation (http://www.novell.com/documentation/nwec/index.html). Search the system 
by error code number.

13 (Conditional) If newer NLMTM programs are available and you want to copy them to your 
system, select Yes in the dialog box that appears.

14 In the Ready to Copy Files dialog box, read the explanation of the file copy process and then 
click Proceed.

The Migration Wizard proceeds with the trustee backup and file copy.

15 When the Copy Volumes Status screen appears, review the error and success logs and then 
click Done.

Continue with the next section, Migration Step 2: Edit Configuration Files.

10.6  Migration Step 2: Edit Configuration Files
The Edit Configuration Files step compares the configuration files between the source and 
destination servers and lets you make any desired changes to those files.

1 In the Project View dialog box, click Edit Configuration Files.

Migration Wizard lets you modify any .ncf or .cfg files on the destination server. These files 
contain default LOAD statements and parameters.

IMPORTANT: Make sure that all files are closed before you migrate your eDirectory 
database. 

2 In the text box, select the configuration file that you want to edit and then click Edit File.

3 Copy and paste the commands from the configuration file on the source server to the 
corresponding configuration file on the destination server, then click Save & Close. 

If you intend to change the IP address on your destination server to be the same as the IP 
address of your source server, you must edit your configuration files and change the IP address 
in two places: autoexec.ncf and sys:\etc\hosts.

Copy the source server’s IP address and paste it into the destination server’s autoexec.ncf 
file. (This works only if your IP LOAD and BIND statements are located in autoexec.ncf.) 
You also need to go to the server console of the destination server and change the IP address in 
the sys:\etc\hosts file. Look for the original name of the destination server.

If you use INETCFG to assign IP addresses, change the IP addresses after the migration is 
complete.
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4 (Conditional) If you are using configured time sources (timesync.cfg), copy and paste your 
Timesync information from the source server’s timesync.cfg file to the destination server’s 
timesync.cfg file.

5 Close the Compare Configurations dialog box.

Continue with the next section, Migration Step 3: Begin NDS/eDirectory Migration.

10.7  Migration Step 3: Begin NDS/eDirectory 
Migration
The Begin NDS/eDirectory Migration step migrates the eDirectory files from the source server to 
the destination server. The source server is brought down and the destination server is restarted 
during this step.

1 In the Project View dialog box, click Begin NDS/eDir Migration.

2 Before continuing, back up all volumes that you are not planning to migrate, ensure the 
following, and then click Next:

 All volume data migrated successfully

 All critical errors from the file copy are resolved

 The servers in your source tree are in time synchronization and eDirectory is synchronized

Verify that you have run the DSRepair procedures in Section 9.2, “Preparing the Source Server 
for Migration,” on page 82 to ensure that the eDirectory tree containing the source server is 
functioning correctly.

TIP: If you are required to fix any eDirectory errors, wait approximately 30 minutes for the 
eDirectory tree to synchronize before continuing.

3 In the Update Schema dialog box, indicate whether you want the Migration Wizard to update 
the source server's schema and then click Next.

 Yes is the default selection. This causes the Migration Wizard to compare the source and 
destination schemas and update the source server's schema to include the eDirectory 
classes of the default applications that are installed on the destination server. You must be 
logged in as a user with all rights to the [Root] of the tree to make these changes.

 If you do not have the necessary rights to extend the schema, select No. The migration 
continues, but you might experience some problems with your eDirectory tree if you skip 
this procedure.

4 In the Verify Novell Directory Services Tree dialog box, select Yes to acknowledge that the 
source eDirectory tree is healthy (you should have run the DSRepair procedures in Step 2). 

If you select No, the Migration Wizard does not prevent you from continuing. However, if your 
tree is unhealthy before you begin the migration, the migration might not complete 
successfully. 

5 To ensure the security certificate works properly on the destination server, indicate how you 
want to copy the source server’s NICI configuration files to the destination server and then 
click Next.

To facilitate the NICI file copy, nuwnici.nlm is first copied to both the source and destination 
servers. You can choose to copy the NICI files Automatically (over the network) or using a 
diskette swap. 
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6 (Conditional) If you selected the diskette swap, continue with Step 6a. If you selected the 
automatic copy over the network, skip to Step 7.

6a To copy the nuwnici.nlm file to the source and destination servers, click Copy NLM and 
then click Next.

6b Insert a blank formatted diskette into the floppy drive on the destination server.

6c At the destination server console, enter

load nuwnici -1

6d Remove the diskette from the destination server and insert it into the source server’s 
floppy drive.

6e At the source server console, enter 

load nuwnici -2

This copies the NICI files to the diskette.

6f Remove the diskette from the source server and insert it into the destination server's 
floppy drive.

6g At the destination server console, enter 

load nuwnici -3

This copies the NICI files to the destination server.

6h Click Next.

TIP: If you get NICI errors when eDirectory tries to load or when you copy the NICI files, 
check to see if pki.nlm will load on the destination server. If it won’t load, see 
Section 11.4.2, “NICI Errors,” on page 102.

7 Delete all user connections (except your own) to the source and destination servers, then click 
Next.

If you want to first broadcast a logout message to any users logged in to the server, select 
Broadcast Logout Message, type the message in the field, and then click OK.

8 Type the passwords for the source and destination trees, then click Next.

9 Resolve any critical errors or warnings on the Migrate NDS/eDir Verification Results screen, 
then click Next.

10 Perform the eDirectory step-by-step migration.

The eDirectory migration is divided into several steps. This is for diagnostic purposes. If the 
eDirectory migration fails for any reason, you know exactly what step it failed on and can take 
the appropriate measures to fix the problem.

For more information on the NDS/eDirectory migration process, including steps to restore the 
source and destination servers, see Section 11.5, “Recovering from NDS/eDirectory Migration 
Failures,” on page 103.

10a Click Next.

The first step changes autoexec.ncf and timesync.cfg; modifies the server name in 
hosts, hostname, and snmp.cfg; and renames smdr.cfg to smdr.mig. The first step 
also renames rootcert.der in both the sys:system and sys:public directories to 
rootcert.der.bak.

At the end of the migration process, the source server is brought down and the destination 
server reboots and takes over the name and identity of the source server.
Migrating Data from NetWare Servers 93



94 Novell

n
ovdo

cx (e
n)  16

 A
p

ril 20
10
Migration Wizard automatically modifies the following items in the destination server’s 
autoexec.ncf file:

 The file server name is changed to the name of the source server.

 The time zone is changed to the one stored in the source server’s autoexec.ncf file.

 The server ID is changed to the IPXTM internal net value or server ID stored in the 
source server’s autoexec.ncf file.

 The default time server type is changed to the value stored in the source server’s 
autoexec.ncf file.

 The bindery context is changed to the bindery context stored in source server’s 
autoexec.ncf file

IMPORTANT: During the migration, the source server’s Timesync information is not 
automatically migrated.

10b Click Next again.

This step backs up eDirectory and copies the eDirectory backup files to the destination 
server and to sys:system\nuw30\ndsbu on the source server.

10c Down the source server by clicking Next.

The Source Server Status dialog box displays. 

10d Verify that the source server is down by selecting Yes.

10e Click Next again.

This step removes eDirectory from the destination server and deletes the client 
connection.

10f Click Next again.

This step upgrades eDirectory on the destination server if necessary, restores eDirectory 
on the destination server, and prepares to reboot the destination server.

10g Reboot the destination server by clicking Next.

10h When you are ready to proceed, select Yes > Finish.

11 Check the former destination server and verify that it has restarted and taken on the name of the 
source server.

The server console prompt should display the source server's name.

12 Exit the Migration Wizard.

The project file is automatically saved.

13 Reboot your workstation and log in to the former destination server. 

This clears old connections from the workstation and establishes a clean connection to the 
former destination server.

If you can’t log in, refer to Section 11.1.1, “Workstation-to-Server Connection Problems,” on 
page 99.

14 Restart the Migration Wizard utility.

15 Read the About screen, then click OK.

16 Select Open Last Project > OK.
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The utility verifies that the first three steps of the project file are complete. 

17 Select Yes when prompted if you are ready to proceed to the fourth step.

10.8  Migration Step 4: Finish the NDS/eDirectory 
Migration
The Finish the NDS/eDirectory Migration step upgrades the schema and restores the trustees to the 
new server after it has restarted.

1 In the Project View dialog box, click Finish NDS/eDir Migration.

The Continue NDS/eDir Migration dialog box appears, outlining the eDirectory health checks 
and other tasks you should complete before continuing.

2 To run the NDS/eDirectory backlinker process, go to the destination server console and enter 
the following commands:

set dstrace=on

set dstrace=+blink

set dstrace=*b

Check the Directory Services screen for messages indicating the successful completion of the 
backlinker process.

3 On the Continue NDS/eDir Migration screen, select Yes > Next.

4 Type the tree password in the field provided, then click Next > Continue.

5 Review the error and success logs, then click Done.

6 In the Project View dialog box, click Close.

7 Select File > Exit to exit the Migration Wizard.

Continue with the next section, Perform Post-Migration Tasks.

10.9  Perform Post-Migration Tasks
1 Run DSRepair on the destination server and select Unattended Full Repair to ensure that 

eDirectory is functioning properly.

2 Using ConsoleOne, verify that the user information migrated successfully.

TIP: During the migration, the standard sys: directory from the source server is saved in the 
sys.mig directory on the destination server.

3 Run DSRepair > Time Synchronization to verify that your source server is synchronized with 
the rest of your servers. 

4 Verify that the correct IP address is assigned to the new server in all appropriate files.

For example, check autoexec.ncf, sys:\etc\hosts, and sys:\etc\hostname, or type 
config at the server console.

IMPORTANT: Failure to have the correct IP address in the hosts or hostname files causes the 
post-installation of some products to fail.

5 (Conditional) If you have performed a migration to a NetWare 6.0 destination server, verify 
that sys:\public\rootcert.der exists. 
Migrating Data from NetWare Servers 95



96 Novell

n
ovdo

cx (e
n)  16

 A
p

ril 20
10
If it does not exist, copy the file from an existing server on the network, or create a new one 
following the instructions in TID #10066860 (http://support.novell.com/cgi-bin/search/
searchtid.cgi?/10066860.htm). 

If the rootcert.der file does not exist, a post-migration install of applications could fail.

6 (Conditional) If you haven’t already done so, install the latest NetWare Support Pack on the 
destination server.

This ensures that you get the latest code for the applications that you are reinstalling. The latest 
Support Packs are available at the Novell Support Web site (http://support.novell.com/misc/
patlst.htm).

7 Reinstall any server applications.

IMPORTANT: Because the source server’s eDirectory database replaces the destination 
server’s eDirectory database, all eDirectory objects on the destination server before the 
migration, including those representing applications, are replaced by the eDirectory objects that 
exist on the source server. However, the NLM programs associated with the destination server's 
applications still exist. Because you cannot manage applications without their corresponding 
eDirectory objects, you must reinstall the applications to restore their eDirectory objects to the 
tree.

You can reinstall these network products and services using either of two methods:

 Go to the destination server, load the GUI interface if necessary by typing startx, and 
click the Novell icon in the lower-left corner of the servertop. Then click Install > Add to 
install products.

 To install products remotely, run the Novell Deployment Manager utility (nwdeploy.exe, 
or nwdeploynobrowser.exe for a nonbrowser-based version) located on NetWare 6.5 
CD 1 (Operating System). Under Post-Install tasks, select Install NetWare 6.5 Products 
and follow the on-screen instructions to run the Remote Product Install utility.

Installing Tomcat and exteNd Application Server after the Migration

If needed, after completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard, 
complete the following steps to ensure that Tomcat installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.

2 Copy sys:\sys.mig\adminsrv to sys:\adminsrv, overwriting all existing files.

3 Copy sys:\sys.mig\system\ipconf to sys:\system\ipconf, overwriting all existing 
files.

After completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard, complete 
the following steps to ensure that exteNdTM Application Server installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.

2 Copy sys:\sys.mig\etc\my.cnf to sys:\etc\my.cnf.

Installing Native File Access for UNIX after the Migration

If needed, after completing a NetWare 5.1-to-NetWare 6.5 migration using the Migration Wizard, 
complete the following steps to ensure that Native File Access for UNIX installs correctly:

1 Delete the NFAU User object.
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2 Run the schinst utility by entering

schinst -n -w

SCHINST takes the administrator’s FDN and password as input for extending the schema.

3 Run nisinst.

4 Execute nfsstart.
Migrating Data from NetWare Servers 97



98 Novell

n
ovdo

cx (e
n)  16

 A
p

ril 20
10
 Server Consolidation and Migration Toolkit Administration Guide



11

n
ovdo

cx (e
n)  16

 A
p

ril 20
10
11Troubleshooting Server 
Migrations

Refer to the appropriate section if you are having trouble with any of the following when using the 
NetWare Migration Wizard:

 Connection Problems (page 99)

 Issues During the File Copy (page 100)

 SMDR Errors (page 101)

 Miscellaneous Errors (page 101)

 Recovering from NDS/eDirectory Migration Failures (page 103) 

11.1  Connection Problems
To eliminate unnecessary connection problems, make sure that 

 The source and destination servers have enough available server and workstation licenses to do 
the migration.

 The eDirectory user that you are using to do the migration has no concurrent connection 
limitations. To check this, do the following:

 Run iManager or ConsoleOne on the workstation.

 Edit the properties of the User object.

 Click the Login Restrictions tab.

 Deselect the Limit Concurrent Connections option.

 The eDirectory user that you are using to do the migration has the Supervisor right to the source 
server’s eDirectory object. Use iManager or ConsoleOne to verify that the User object is listed 
in the source server’s Operators list.

11.1.1  Workstation-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers and 
workstations, try one or more of the following: 

 Reboot the client workstation to clear the cache in the Novell Client software. 

 Map a drive to the server instead of logging in. This is especially useful when connecting with 
the IPX protocol.

 Search for the server by its IP or IPX address instead of its name. Type the IP or IPX address in 
the Server field of the Novell Login dialog box.

 Try connecting to the server and not the eDirectory tree by specifying only the name of the 
server and leaving the tree name and context blank.

 Clear all unauthenticated connections. To do this, right-click the N icon and then click NetWare 
Connections. Detach from all servers and trees that you are not authenticated to, then try 
logging in again.
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 Make sure your Preferred NetWork Protocol is set correctly by doing the following:

 Right-click the N icon.

 Select Novell Client Properties > Protocol Preferences.

 Select the desired preferred network protocol, then click OK.

 Reboot the workstation.

 Unbind the protocol you are not using from the destination server. For example, if you are 
using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol 
on the destination server during the migration.

11.1.2  Server-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers, try one or more 
of the following:

 Do not remove the source and destination servers from their respective eDirectory trees. The 
servers must be able to communicate with the other servers in the tree during the migration.

 Make sure the destination and source servers can communicate with each other. 

For IP connections, enter ping at the server console and specify the other server’s IP address. 
For IPX connections, enter display servers at the server console. 

 For IP connections, verify that you have corresponding addressing, subnet mask, and gateway 
information. If you are using IPX, make sure the frame type and the IPX network number/
server ID are consistent between the source and destination servers.

 Reboot the destination server.

11.2  File Copy Problems
This section describes what to do if problems are encountered when copying files and restoring 
trustees.

11.2.1  Issues During the File Copy

If you are having problems during the file copy, try one or more of the following:

 Enable login on both the destination and source servers. If you have disabled login before you 
started the file copy, the servers can’t log in to each other in order to migrate the files. 

NOTE: If you have selected to do so, Migration Wizard disables user logins for you during the 
migration.

 If files are copying very slowly, make sure that the servers and workstation are configured at 
the highest common LAN speed. Verify that the NICs and anything in between are all hard 
coded to either communicate half-duplex or full-duplex; they need to be the same throughout. 
If there are problems with full-duplex, use half-duplex.

NOTE: If compressed files are migrated to uncompressed volumes, file copy might be slower.

 If Migration Wizard encounters filenames with a total path length of more than 256 bytes, the 
file copy stops. You might need to reorganize the data on your source server if your path 
lengths are longer than 256 bytes.
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11.2.2  Data Set Currently In Use Errors in the Error Log

If you see NWSMTS error: Data set is currently in use and cannot be accessed errors 
in the error log file after the migration, it means the specified files were open during the file copy 
and were not migrated. You can expect to see these errors for files such as sys:_swap_.mem and 
others that are always open. These errors are mainly informational.

11.2.3  Problems Restoring Trustees

 If you see the error An unknown error has occurred. (Source Server: SRV1 Path: 
‘SYS:SYSTEM\NUW30\TRUSTEE.REF’ Error: ‘1’ Function: ‘fopen 
(OpenTrusteeReference)’ when migrating from NetWare 5.1 to NetWare 6.5 SP6, make 
sure you have disabled file caching in the Novell Client. For more information, see Section 3.1, 
“Meeting the Workstation Requirements,” on page 25.

 If the trustees fail to restore and you get a 0xfffffffb error, this means that you did not modify 
your server’s IP address in all the necessary places. For more information, see Section 10.6, 
“Migration Step 2: Edit Configuration Files,” on page 91.

 If you need to restore trustees, you can click the Finish NDS/eDir Migration button in the 
Migration Wizard, or select Restore Trustees on the toolbar.

11.3  SMDR Errors
Sometimes the SMDR program that is running on the destination server can’t make a connection to 
the source server. To correct this problem, try one or more of the following:

 Unbind the protocol you are not using from the destination server. For example, if you are 
using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol 
on the destination server during the migration.

 If Migration Wizard can’t load the appropriate tsa.nlm on your destination server, manually 
load it from the destination server console and following the on-screen instructions. Or, enter 
smdr new at the server console to re-create the SMDR object.

 Load smdr.nlm at the destination server console and then enter smdr new at the destination 
server console to solve SMS problems.

 Make sure the latest NLM programs are loaded on your servers.

Migration Wizard automatically copies the required NLM programs to the source and 
destination servers. To verify that you have the latest NLM programs loaded, check the files in 
the NetWare Migration Wizard\products\nw3x directory. You might need to load TSA312 
manually.

 Check your primary connections. Right-click the N icon, then select NetWare Connections. 
Make sure the destination tree and server are marked as Primary.

 Reboot the source server.

11.4  Miscellaneous Errors
This section identifies other errors that might be encountered when using the NetWare Migration 
Wizard.
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11.4.1  Nuwagent.nlm Load Errors

Nuwagent.nlm is the NLM program that Migration Wizard uses to do much of its work. If you get 
errors that the nuwagent.nlm won’t load, try the following:

 Manually load nuwagent.nlm at the server console.

 Enter smdr new at the destination server console. This re-creates the SMDR configuration and 
allows nuwagent.nlm to load.

11.4.2  NICI Errors

If you are getting NICI errors when eDirectory is trying to load or when you are copying the NICI 
files in Migration Wizard, this might mean that your NICI files are corrupt. To correct the problem, 
follow these steps on the server that is getting NICI errors:

1 Copy the *.nfk file from NetWare 6.5 CD 1 (Operating System) to the server’s sys:system 
directory. 

2 Rename the *.nfk file that you just copied to nicifk (this has no extension).

3 Go to the Novell Support Web site (http://support.novell.com/filefinder) and download 
nrepair3.exe.

4 Extract nrepair3.exe and locate nrepair.nlm.

5 Run nrepair.nlm on the server, clicking Yes at all the prompts.

6 Reboot the server.

7 Load pki.nlm on the server and verify that you are no longer getting NICI errors.

If you still see NICI errors, refer to TID #10025666 (http://support.novell.com/search/) in the Novell 
Knowledgebase.

11.4.3  NMAS Error When Migrating from NetWare 5.1

When migrating from NetWare 5.1 Support Pack 7 with eDirectory 8 to NetWare 6.5 Support Pack 2 
using Migration Wizard 8.0, NMAS might show a - 1660 (0xFFFFF984) error after completing Step 
3 (Start NDS/eDirectory Migration) and rebooting the server and client.

This is the expected behavior because this is a new server that hasn’t been fully installed, so there 
are no objects in the Security container, which means that NMAS (and other security products such 
as NICI and PKI) have not been configured.

If you have Novell Client 4.9 and later, you must disable the NMAS authentication. Right-click the 
N icon, select Novell Client Properties > Advanced Login, then deselect the NMAS Authentication 
option.

11.4.4  CCS_pbeDecrypt Error When Migrating from NetWare 
5.0

When performing a migration from NetWare 5.0, you might receive a CCS_pbeDecrypt error on the 
source server console when attempting to back up either the source server trustees or the NDS 
database.
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If this occurs, make sure that the latest Support Pack is installed on the NetWare 5.0 server and then 
do the following:

1 At the NetWare 5.0 source server console, enter

down

2 At the DOS prompt, enter.

copy c:\nwserver\expxeng.xlm c:\nwserver\novxeng.xlm

3 Enter.

copy c:\nwserver\domxeng.xlm c:\nwserver\novxeng.xlm

NOTE: This might fail because domxeng.xlm is not present. This is not a problem.

If you used a directory other than \nwserver to store the server files, substitute that directory 
for \nwserver in steps 2 and 3.

4 Restart the NetWare 5.0 server.

11.5  Recovering from NDS/eDirectory Migration 
Failures
If the migration fails during the NDS/eDirectory Migration step, you need to restore the source and 
destination servers to their original configuration before you can retry the NDS/eDirectory 
migration. The instructions for restoring the servers to their original configurations are different 
depending on when the migration of data failed.

If Begin NDS/eDir Migration (Step 3) failed and the destination server did not reboot and take on 
the name and identity of the source server, complete the steps in “Restore Source Server to Its 
Original Configuration” on page 103.

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has already 
rebooted and taken on the name and identity of the source server, complete the steps in the following 
sections:

1. “Remove NDS/eDirectory from the Destination Server” on page 104.

2. “Remove NDS/eDirectory from the Source Server” on page 105.

3. “Restore NDS/eDirectory to the Source Server” on page 105.

4. “Reinstall the Destination Server” on page 106.

11.5.1  Restore Source Server to Its Original Configuration

If Begin NDS/eDir Migration (Step 3) failed and the destination server did not reboot and take on 
the name and identity of the source server, you need only restore NDS/eDirectory to the source 
server. When NDS/eDirectory has been restored, you have restored the source server to its original 
configuration and you are ready to try the NDS/eDirectory migration again.

1 Enter one of the following at the server console of the source server:

 load install if the source server is running NetWare 4

 nwconfig if the source server is running NetWare 5 or later
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2 Select Directory Options > Directory Backup and Restore > Restore Local DS Information 
after Hardware Upgrade.

3 Press F3 and enter sys:system\nuw30\ndsbu when prompted for the location of the backup 
files. 

NDS/eDirectory has now been restored to the source server.

IMPORTANT: Do not reboot the destination server. Because the destination server did not 
take over the identity of the source server, no other action is required prior to performing the 
NDS/eDirectory migration again.

4 Perform the NDS/eDirectory migration again.

4a Launch Migration Wizard and open the project you were previously working on. 

4b When the project opens and you see the Project Window, click Begin NDS/eDir 
Migration.

4c Follow the instructions in Section 10.7, “Migration Step 3: Begin NDS/eDirectory 
Migration,” on page 92.

11.5.2  Remove NDS/eDirectory from the Destination Server

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has already 
rebooted and taken on the name and identity of the source server, you must remove NDS/eDirectory 
from the destination server before you can restore NDS/eDirectory to the source server.

1 At the destination server console, enter nwconfig.

2 Select Directory Options > Remove Directory Services from This Server.

3 Press Enter when you see a warning instructing you to not remove Directory Services.

Ignore any other errors during the removal of NDS/eDirectory.

4 Select Yes to remove Directory Services.

5 Specify the Admin username and password.

6 Press Enter to reference a different object. 

This object is used when NDS/eDirectory is restored back to the source server.

WARNING: Do not press Esc. If you do, the server references you entered will not be saved or 
restored to the server.

7 Specify the full Admin username as the placeholder object distinguished name. 

8 Specify Root as the distinguished name to change from.

9 (Conditional) If the information about the single reference time source appears, review the 
information and press Enter.

10 (Conditional) If your server holds the master copy of a replica, press Enter when you see a 
warning.

11 Designate another server to hold the master replica.

You can choose to let NWCONFIG randomly select another server or you can designate one 
yourself.

12 Return to the NWCONFIG utility and select Remove Directory Services from This Server to 
verify that NDS/eDirectory has been removed. 
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If a message appears saying that NDS/eDirectory has already been removed, bring the 
destination server down and continue with the next section, Remove NDS/eDirectory from the 
Source Server.

If NDS/eDirectory was not successfully removed, exit NWCONFIG and enter nwconfig -
dsremove at the destination server console. Then follow this procedure again, beginning with 
Step 2 on page 104.

11.5.3  Remove NDS/eDirectory from the Source Server

After NDS/eDirectory has been removed from the destination server, remove NDS/eDirectory from 
the source server.

1 Restart the source server by entering server at the DOS command prompt.

2 Enter one of the following: 

 load install -dsremove (if source server is running NetWare 4)

 nwconfig -dsremove (if source server is running NetWare 5 or later)

INSTALL or NWCONFIG will now ignore any warnings or errors during the removal of NDS.

3 Select Directory Options > Remove Directory Services from This Server.

4 Press Enter to skip past any warning screens.

5 Select Yes to remove NDS/eDirectory.

6 Press Enter to skip the error message warning you that eDirectory is locked. 

Ignore, but keep track of, any additional eDirectory error messages that appear.

7 When the INSTALL or NWCONFIG menu appears again, select Remove Directory Services 
again. 

If a message indicates that eDirectory is already removed, continue with the next section, Restore 
NDS/eDirectory to the Source Server.

If eDirectory was not properly removed, contact Novell Support (http://www.novell.com/support).

11.5.4  Restore NDS/eDirectory to the Source Server

By removing NDS/eDirectory from the source server, you removed the server from any replica rings 
that held a partition of the source server. Now you must complete the following procedure to restore 
NDS/eDirectory to the source server.

1 Enter one of the following at the server console:

 load install (if source server was running NetWare 4)

 load nwconfig (if source server was running NetWare 5 or later)

2 Select Directory Services > Install Directory Services onto This Server.

3 Select the eDirectory tree where the source server existed prior to migration.

4 Select a time zone and time configuration parameters.

Make a note of any warnings or errors that appear during the restoration of eDirectory and 
press Esc to continue without fixing the errors.

5 Enter the Admin name and password.
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6 Type the context where the source server existed prior to migration, then press F10.

7 Save the NDS (Directory) information.

8 Wait while the server synchronizes with the eDirectory tree, which might take a while.

9 Return to the INSTALL or NWCONFIG utility and select Directory Options > Directory Back 
Up and Restore > Restore Reference from another Object to This Server. 

This restores all references that you assigned to the Server object when you removed 
eDirectory from the destination server.

10 Press Enter.

11 Enter the full Admin username as the placeholder object distinguished name, then specify Root 
as the distinguished name to change from.

12 Exit the NWCONFIG or INSTALL utility.

13 At the server console of the source server, enter load dsrepair. 

14 Select Unattended Full Repair > Advanced Options > Check Volume Objects and Trustees.

15 Enter the Admin username and password.

16 Exit DSREPAIR.

17 At the workstation where you performed the migration, open your project. (Make sure you 
have removed eDirectory from the destination server, as instructed in “Remove NDS/
eDirectory from the Destination Server” on page 104, and returned the destination server to its 
temporary tree with its temporary server name.)

18 From the Migration Wizard Project menu, select Restore Trustees to restore the trustee 
assignments.

19 (Conditional) If the source server held the master replica of any partitions and you want to 
restore these partitions prior to doing the eDirectory migration again, use DSREPAIR to re-
create them.

The source server is now restored to its original configuration.

Continue with the next section, Reinstall the Destination Server.

11.5.5  Reinstall the Destination Server

To perform the migration again, you must reinstall the operating system on the destination server. 

TIP: If you had your server imaged, you can just restore the image rather than reinstall the server.

1 Bring down the destination server.

2 Install NetWare and follow the on-screen instructions during the installation.

After NetWare is installed on the destination server, you are ready to perform the eDirectory 
migration again. Go to Section 10.7, “Migration Step 3: Begin NDS/eDirectory Migration,” on 
page 92.
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VSupplemental Information

 Chapter 12, “Copying Double-Byte Character Set Data,” on page 109

 Chapter 13, “Security Considerations,” on page 113
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12Copying Double-Byte Character 
Set Data

When you have servers containing extended ASCII data (multinational characters) or double-byte 
character set data (Japanese, Korean, and other oriental languages), extra care is required to ensure 
that this data is migrated correctly. This chapter outlines the additional steps you need to take when 
copying this data to NetWare servers.

 Section 12.1, “Preparing the Workstation,” on page 109

 Section 12.2, “Changing the NetWare Server Code Page,” on page 109

12.1  Preparing the Workstation
If you are copying extended ASCII or double-byte character set data from a server, the workstation 
must have Windows installed with the same language as the server. For example, if you are 
migrating a Japanese server, make sure your workstation is running Windows with Japanese 
language support.

For information on how to install language support in Windows XP, see Windows XP Language 
Interface Pack (http://www.microsoft.com/downloads/details.aspx?familyid=0db2e8f9-79c4-4625-
a07a-0cc1b341be7c&displaylang=en).

You must also enable UTF-8 support in the Novell Client on the workstation where you run the 
Server Consolidation and Migration Toolkit.

To do this, right-click the N icon on the workstation toolbar, then click Novell Client Properties > 
Advanced Settings > Use UTF8 encoding and NCPs > Setting: On.

TIP: For Windows 2000/2003 consolidation projects, you can run the Server Consolidation Utility 
on the Windows server itself. This is the preferred method, especially if you have data that uses 
extended ASCII or double-byte character sets. (You cannot run the Server Consolidation Utility on 
Windows NT servers, because the Novell Client no longer supports Windows NT.)

12.2  Changing the NetWare Server Code Page
When using the Server Consolidation Utility to copy extended ASCII and double-byte character set 
data from NetWare® to NetWare, the source and destination NetWare servers must have the same 
code page set, or data will be lost during the consolidation.

WARNING: Novell does not recommend converting a foreign-language code page server back to 
English, nor converting a foreign-language code page server to another foreign-language code page. 
If either is done, it is possible that documents and folders named with or containing foreign 
characters might become irreversibly corrupted.
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There are two recommended ways to create a NetWare server with foreign-code page support:

 Install the server with the regional support you want

 Convert an English server to a foreign-language code page

12.2.1  Install a NetWare Server with Regional Support

To install an English server with code page support for a foreign language, you must have an English 
NetWare installation CD or access to English NetWare install files.

1 Begin the NetWare installation.

For information on installing your specific version of NetWare, see the Novell online 
documentation (http://www.novell.com/documentation).

During the installation, a Regional Settings screen displays. You see three options:

 Country: 001 (USA)

 Code page: 437 (United States English)

 Keyboard: United States

2 Change the first option, Country, to the country you want the server to support.

For example, if you want to install your English server with Japanese double-byte support, 
change the Country option to 081 (Japan).

When you change the Country option, the Code page and Keyboard options change 
automatically to the appropriate code page and keyboard.

3 If you intend to type foreign characters using the keyboard on the server console, accept the 
automatic setting displayed for the Keyboard option. 

If you do not intend to type any foreign characters on the server console, manually change the 
Keyboard option to US International (the last keyboard option displayed in the list). 

4 Complete the server installation.

When the server reboots after the installation is complete, you will have an English server with 
a foreign code page.

12.2.2  Convert an Existing English NetWare Server to a 
Foreign Code Page

To convert an existing English server to a foreign code page, you must have an English NetWare 
installation CD or access to English NetWare install files.

1 Bring the server down.

2 At the DOS prompt, go to c:\nwserver.

3 Rename lconfig.sys to lconfig.437.

The lconfig.sys file determines what code page NetWare will run. The purpose of renaming 
the existing file is to allow for rolling back to the original configuration if necessary.

4 Browse to the \install\lconfig directory on the NetWare installation CD or at the location 
of your NetWare installation files. 
 Server Consolidation and Migration Toolkit Administration Guide
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This directory contains the lconfig.sys files for all languages. The naming convention is 
lc_country_codepage.country_telephone_code. Therefore, the Japanese lconfig.sys file is 
named lc_932.081, for example.

The following is a partial list of lconfig.sys files with their associated language names:

 Chinese-Simplified: LC_936.086

 Chinese-Traditional: LC_950.088

 French: LC_850.033

 German: LC_850.049

 Italian: LC_850.039

 Japanese: LC_932.081

 Korean: LC_949.082

 Portuguese: LC_860.351

 Russian: LC_855.007 or LC_866.007

 Spanish (Argentina): LC_850.054

 US English: LC_437.001

5 Select the language code page file you want to implement and copy it to the c:\nwserver 
directory.

6 Rename the lc_xxx.xxx file you just copied to lconfig.sys.

If you are converting an English server to a single-byte language like German or Russian, then 
you are finished. When you start the server, you will have foreign-language code page support 
for the country you selected.

If you have selected a double-byte code page like Japanese or Chinese, continue with Step 7.

7 (Conditional) If installing a double-byte code page, copy the necessary server font files. 

7a Go to \startup on your NetWare installation CD and select the font files appropriate for 
your language:

 Japanese: jpn*.fnt

 Korean: kor*.fnt

 Chinese Traditional: bg5*.fnt

 Chinese Simplified: gb*.fnt

7b Add Load vgadisp.nlm to c:\nwserver\startup.ncf.

Vgadisp.nlm allows for double-byte characters such as Japanese or Chinese to be viewed 
in the C-worthy portion of the system console. It is cosmetic and does not affect the 
functionality of the server.

8 Restart the server.

You will now have foreign-language code page support for the country you selected.

12.2.3  Verifying the Current Code Page on a NetWare Server

To verify the code page currently installed on your NetWare server, enter language at the server 
console.
Copying Double-Byte Character Set Data 111
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This returns “Current NLM language is (4) ENGLISH. Current DOS code page is (437),” if your 
server is using the English code page.

The following is a list of common code pages used for NetWare (note that some languages support 
multiple codepages):

 437: United States English

 850: Multilingual (English, French, German, Italian, Portuguese, Spanish)

 852: Slavic

 855: Cyrillic I

 857: Turkish

 860: Portuguese

 861: Icelandic

 862: Hebrew

 863: French Canadian

 865: Nordic

 866: Russian

 869: Greek

 874: Thailand

 932: Japanese

 936: Chinese Simplified

 949: Korean

 950: Chinese Traditional
 Server Consolidation and Migration Toolkit Administration Guide
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13Security Considerations

This section provides information on how to use the utilities included in the Novell Server 
Consolidation and Migration Toolkit in the most secure way possible.

 Section 13.1, “General Security Guidelines,” on page 113

 Section 13.2, “Server Consolidation Utility Security,” on page 113

 Section 13.3, “Migration Wizard Security,” on page 113

13.1  General Security Guidelines
Access to network resources in general, and servers in particular, should be governed by the security 
guidelines outlined in “Security” in the NW 6.5 SP8: Planning and Implementation Guide.

When using either the Server Consolidation Utility or the NetWare Migration Wizard, data between 
the source and destination servers is sent over a plain-text tunnel. In a secure environment, the 
source server, destination server, and client workstation should be attached to the same physical 
network segment with no connectivity outside of the internal network.

13.2  Server Consolidation Utility Security
Standard security algorithms and well-established obfuscation methods are used in the Novell 
Server Consolidation Utility to protect the privacy of administrator passwords. 

In a secure environment, you should not use the server-based processing feature. The XML script 
that is generated contains the administrator passwords in obfuscated form. Although the passwords 
are not written to the file in clear text, a knowledgeable hacker could derive the passwords from the 
obfuscated versions. For more information, see Section 6.12, “Server-Based Processing,” on 
page 58.

13.3  Migration Wizard Security
Standard security algorithms and well established obfuscation methods are used in the NetWare 
Migration Wizard to protect the privacy of administrator passwords. 

In a secure environment, you should use the diskette method to copy NICI keys from the source 
server to the destination server, instead of copying the keys over the wire. For more information, see 
Step 5 on page 92.
Security Considerations 113
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ADocumentation Updates

This section contains information on documentation content changes that have been made in the 
Novell Server Consolidation and Migration Toolkit 1.2 Administration Guide. This information can 
help you to keep current on updates to the documentation.

All changes that are noted in this section were also made in the documentation. The documentation 
is provided on the Web in two formats: HTML and PDF. The HTML and PDF documentation are 
both kept up-to-date with the documentation changes listed in this section.

The documentation update information is grouped according to the date the changes were published. 
Within a dated section, the changes are listed by the names of the main table of contents sections.

If you need to know whether a copy of the PDF documentation you are using is the most recent, the 
PDF document contains the date it was published on the front title page and in the Legal Notices 
section immediately following the title page.

This documentation was updated on the following dates:

 Section A.1, “February 15, 2011,” on page 115

 Section A.2, “September 28, 2007,” on page 115

 Section A.3, “December 23, 2005,” on page 115

A.1  February 15, 2011
Added an important note in “About This Guide” on page 7 providing information to migrate from 
Netware to OES.

A.2  September 28, 2007 
Changed version numbers to Server Consolidation and Migration Toolkit 1.2, Server Consolidation 
Utility 4.2, and NetWare Migration Utility 8.2. Added information about support for eDirectory 8.8 
SP2.

A.3  December 23, 2005 
Combined the Novell Server Consolidation Utility 4.1 Administration Guide and the Novell NetWare 
Migration Wizard 8.1 Administration Guide and added them to this guide. Also reformatted the page 
design to comply with revised Novell documentation standards.

Updates were made to the following sections. The changes are explained below.

 Section A.3.1, “Server Consolidation and Migration Overview,” on page 115

 Section A.3.2, “Installing the Server Consolidation and Migration Toolkit,” on page 116

A.3.1  Server Consolidation and Migration Overview

The following updates were made in this section:
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A.3.2  Installing the Server Consolidation and Migration Toolkit

The following updates were made in this section:

Location Change

Section 1.3, 
“Supported Source and 
Destination Server 
Versions,” on page 16

Updated the list of supported source and destination server versions.

Location Change

Section 3.1, “Meeting 
the Workstation 
Requirements,” on 
page 25

Updated the workstations requirements for running the toolkit.
 Server Consolidation and Migration Toolkit Administration Guide
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