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About This Guide

This guide describes how to use the Novell NetWare Server Consolidation 
Utility to copy data from one NetWare server to another NetWare server on 
your network. The guide is intended for network administrators and is divided 
into the following sections:

!  Chapter 1, �Novell NetWare Server Consolidation Utility Overview,� on 
page 5 explains the capabilities of the NetWare Server Consolidation 
Utility.

!  Chapter 2, �Installing the Server Consolidation Utility,� on page 9 
explains the prerequisites and instructions for installing the NetWare 
Server Consolidation Utility.

! Chapter 3, �Running the Server Consolidation Utility,� on page 13 
provides instructions for consolidating data and moving printers using the 
NetWare Server Consolidation Utility.

! �Troubleshooting the Server Consolidation Utility� on page 19 provides 
solutions for resolving errors encountered during the consolidation 
process.

Documentation Conventions
In this documentation, a greater-than symbol (>) is used to separate actions 
within a step and items in a cross-reference path.

Also, a trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk 
(*) denotes a third-party trademark.
About This Guide 3
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1 Novell NetWare Server Consolidation 
Utility Overview

The Novell® NetWare® Server Consolidation Utility helps you consolidate 
data and reorganize your network by moving data from any number of 
NetWare volumes (or directories within volumes) to a single NetWare 5 or 6 
server, a NetWare Cluster/SAN, or multiple NetWare 6 servers. This means 
you have fewer servers to manage. 

You can copy entire volumes and specific directories between NetWare 4, 
NetWare 5, and NetWare 6 servers in the same eDirectoryTM tree.You can also 
reassign several NDPS® Printer Agents to a single NDPS Print Manager. In 
each case, the accompanying rights, trustees, ownership, and name space 
information are copied along with the files to the destination server.

The benefits the NetWare Server Consolidation Utility provides can be better 
understood through the following two consolidation scenarios.

In the first scenario, suppose you have five existing NetWare 5 servers and 
you recently purchased two multiprocessor servers and the necessary 
hardware to create a two-node cluster complete with a Storage Area Network 
(SAN). You have decided to install NetWare 6 on the two node cluster 
because NetWare 6 is fully multiprocessor-enabled and comes with Novell 
Cluster ServicesTM software and a two-node cluster license. You want to 
migrate the data from each of the five servers to the SAN on the two-node 
cluster. Rather than manually moving all the data and printer agents or 
backing up the data and restoring it to the SAN, you can use the NetWare 
Server Consolidation Utility, which automates the data migration process.

The following figure shows how this consolidation scenario might look.
Novell NetWare Server Consolidation Utility Overview 5
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Figure 1 Cluster Server Consolidation

In the second scenario, suppose you have three existing NetWare 5 servers and 
you recently purchased a multiprocessor server that you want to make a 
NetWare 6 server. You want to migrate the data from each of the three servers 
to the single NetWare 6 server. Rather than manually moving all the data and 
printer agents or backing up the data on each of the three servers and then 
restoring it to the NetWare 6 server, you can use the NetWare Server 
Consolidation Utility to automate the data migration process.

The following figure shows how this consolidation scenario might look.
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Figure 2 Multiprocessor Server Consolidation

The Server Consolidation Utility has a helpful interface that guides you 
through each step of the consolidation process. See Chapter 2, �Installing the 
Server Consolidation Utility,� on page 9 and Chapter 3, �Running the Server 
Consolidation Utility,� on page 13 for instructions on how to install and use 
the NetWare Server Consolidation Utility.
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2 Installing the Server Consolidation 
Utility

The Novell® NetWare® Server Consolidation Utility helps you consolidate 
data from several servers onto fewer server, so you have fewer servers to 
manage. 

To set up the utility, complete the tasks in the following sections:

! �Meeting System and Software Requirements� on page 9

! �Installing the Software� on page 11

Meeting System and Software Requirements
The Server Consolidation Utility runs on a Windows* workstation and lets 
you copy files to different servers and reassign printer agents to different 
locations in the same eDirectoryTM tree.

Workstation Requirements
" Windows NT* (4.0 or later), Windows 2000, or Windows XP 

Professional Edition workstation with 50 MB of available disk space.

The Server Consolidation Utility does not work with Windows XP Home 
Edition or Windows 98.

" Novell ClientTM software installed and connected to the network.

Windows NT/2000/XP workstations must be running Novell Client for 
Windows NT/2000/XP version 4.83 or later. 
Installing the Server Consolidation Utility 9
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To check the Novell Client version, right-click the N icon on the 
workstation toolbar and then click Novell Client Properties > Client. To 
download the latest client, see the Novell Software Downloads site (http:/
/download.novell.com).

" The Supervisor right on the source server and the destination server.

" If you are copying data from NetWare 4, configure the IPXTM protocol to 
run on the Novell Client workstation.

" For best performance, the source server, destination server, and client 
workstation should be running on the same LAN segment.

Server Requirements
" Destination server and source server are in the same tree.

" Destination server is running NetWare 5.1, or 6.

" Source server is running NetWare 4.2, 5, 5.1, or 6.
NOTE: To copy data from NT Servers or NetWare 3 servers, use the NetWare 
Migration Wizard, which is available for free at the Novell Software Downloads site 
(http://download.novell.com).

" Supervisor right to both the source server and the destination server.

Use ConsoleOne® to verify that you have the Supervisor right to both 
servers.

" The latest NetWare Support Packs on both the source and destination 
servers.

Updates are available for specific NetWare versions at the Consolidated 
Support Pack home page (http://support.novell.com/csp/csplist.html).

" (Conditional) If you are copying data from NetWare 4.2, each volume to 
be copied must be running long name space support. 

To add long name space support to a NetWare 4.2 volume, enter the 
following at the server console: LOAD LONG and then enter ADD NAME 
SPACE LONG TO volumename. Replace volumename with the name 
of the NetWare 4.2 volume.

" A current backup of eDirectory before moving any printers.

After meeting the system and software requirements, you can install the 
software and run the program.
10   NetWare Server Consolidation Utility Guide
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Installing the Software
Download the Server Consolidation Utility from the Novell Software 
Downloads site (http://download.novell.com).

Expand the utility and install it on a workstation by double-clicking on the 
NWSC1.EXE file.
Installing the Server Consolidation Utility 11
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3 Running the Server Consolidation 
Utility

The Server Consolidation Utility is a Windows program that is launched from 
the Start menu. The default installation locates the program under Programs > 
Novell > NetWare Server Consolidation Utility.

To launch the utility, on the Start menu click Programs > Novell > NetWare 
Server Consolidation Utility > NetWare Server Consolidation Utility and 
complete the following tasks:

1. Create a Project File.

2. Log In to a Tree.

3. Select Volumes, Directories, and Printer Agents.

4. Verify Actions and Resolve Errors.

5. Copy Files and Move Printer Agents.

The Server Consolidation Utility has a helpful interface that guides you 
through each step of the process.

Create a Project File
The Server Consolidation Utility uses a project (.MDB) file to record your 
intended actions. The actions are recorded so you can execute them now or 
save the project file and execute the actions later.

The filename can be up to 64 characters long and can include any character 
except \ * ? < > | " /.

You can create a new project, open an existing project, or open the last project 
you worked on.
Running the Server Consolidation Utility 13

NetWare Server Consolidation Utility Guide
Part # 103-000264-001

December 4, 2002
Novell Confidential



Manual July 16, 200263
If you choose to create a new project, you are prompted to view the setup tasks 
for the utility and to verify that you have met the requirements before 
continuing. 

After performing the setup tasks for the utility, you must name the project and 
specify the location on the workstation where the project file is to be stored.

Log In to a Tree
Select and log in to the eDirectoryTM tree that contains the destination and 
source servers. Volumes, directories, and Printer objects can be moved 
between servers in the same tree.

Select Volumes, Directories, and Printer Agents
The Project Window is where you choose which volumes and directories to 
copy and which Printer objects to move. The Project Window is divided into 
two panes that each show the same tree.

You drag objects from the left pane and drop them into the right pane. You 
select volumes and directories to copy to different servers and Printer Agents 
to move to different Print Managers. Keep in mind that the Server 
Consolidation Utility does not move Print Brokers or Print Managers. If you 
want to move a Broker, you must first create a new one on the target server, 
copy the contents to the new server, and then delete the old one.  The Server 
Consolidation Utility only moves Printer Agents.

In addition to dragging and dropping objects, you can also create new folders 
in the right pane by selecting an existing volume or directory and then clicking 
the New Folder button on the tool bar. You can also drop directories, volumes 
and print objects into the newly created folder.  The Project Window also lets 
you move dropped objects around in the destination tree.

In this way, you create a view in the right pane of what the new tree will look 
like after you complete the copy process.
14   NetWare Server Consolidation Utility Guide
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Figure 3 Project Window Post Copy View

IMPORTANT: Creating containers and dragging and dropping objects in the Project 
Window does not immediately perform the action. It only creates a view of where the 
files and objects will reside. The actions are completed only after the verification 
process is complete and the copy process begins.

Working in the Project Window
In addition to dragging and dropping objects, you can perform several tasks 
from the Project Window menu:

! Save project settings: Click File > Save As.

! Create a new container or folder: Select the parent container or existing 
folder in the right pane and click Edit > New Folder. You can also right-
click on the object to get to the same menu option.

! Cancel a "dropped" action: Select the volume or directory in the right 
pane and click Edit > Back Out. You can also right-click on the object to 
get to the same menu option.
Running the Server Consolidation Utility 15
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! Rename a newly created container or folder: Select the parent container 
or existing folder in the right pane and click Edit > Rename. You can also 
right-click on the object to get to the same menu option.

! Show where a folder or object went: Select the object in the left pane and 
click Edit > Where Did It Go. You can also right-click on the object to get 
to the same menu option.

! Show where a folder or object came from: Select the object in the left 
pane and click Edit > Where Did It Come From. You can also right-click 
on the object to get to the same menu option.

! Show all folders or objects selected for copying: Select a container in the 
left pane and click Edit > Show Dropped Folders or Show Dropped 
Printers. You can also right-click on the object to get to the same menu 
option.

! Verify actions but do not copy files: Click Project > Verify Project. You 
can also click the Verify Project button on the button bar.

! Move created and dropped objects around by dragging them to the 
desired location.

Verify Actions and Resolve Errors
After you have selected your intended actions, proceed by clicking Project > 
Verify Project or the Verify Project button on the button bar. 

Your intended actions are verified and errors display if found. Errors could 
include name conflicts, insufficient rights, required name spaces not loaded, 
and insufficient disk space.

Resolving Errors
Errors found during the verification process are classified as follows:

 Errors must be resolved before files can be copied. 

 Errors should be resolved but might not affect the copy process. 

 Information about the decisions you made in the Project Window. 

A description of the error and a possible resolution appears in the Information 
text box. If no resolution is provided, you can find more information in the 
Novell Error Codes Help system. (Hint: Search by error code number.)
16   NetWare Server Consolidation Utility Guide
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Resolving File Conflicts
You can choose what happens when the source server already contains a file 
with the same name as the one being copied. 

! Don�t copy over existing files 

The file on the source server is not copied and the file on the destination 
server is not replaced.

! Copy the source file if it is newer 

If the file on the source server is newer than the one on the destination 
server, the file on the destination server is replaced.

! Always copy the source file

The file on the source server always replaces the file with the same name 
on the destination server.

Copy Files and Move Printer Agents
After selecting the objects to copy and resolving critical errors, you can copy 
the files by clicking Project > Verify and Copy Data or the Verify and Copy 
Data button on the button bar. The copy process begins after the verification 
check is complete and all critical errors are resolved.

During the copy process, new folders and objects are created, files are copied, 
and printer agents are moved to their destination (as specified in the right 
pane).

From the Project Window, you can view the error and success logs of any 
project by opening the project file and clicking View > Error Log or View > 
Success Log or clicking the corresponding button on the button bar.

If you interrupt the copy process before it completes, all objects, directories, 
and files already copied to the destination server will remain there unless you 
manually delete them.

There are certain rules that you should be aware of when copying files or 
moving printer agents.

! Printer agents can be moved. Print queues cannot.

! Printer agents that are moved still use the same print broker.

! You can move printer agents back after initially moving them.
Running the Server Consolidation Utility 17
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! Open files cannot be copied.

! Print Services Managers must be operational.

! You may need to manually load or reload TSA600 and/or TSA500.

Consolidating to or from a NetWare 5.1 Cluster
When a volume is cluster-enabled, an object is created in eDirectory with the 
name of the cluster followed by an underscore followed by the volume name. 
For example, Cluster1_vol1. For the Server Consolidation Utility to function 
properly with a NetWare 5.1 cluster enabled volume, the server name 
followed by an underscore followed by the volume name object must be used 
in the project window instead. For example, Server1_vol1.

This substitution can be accomplished by completing the following steps.

1 Start ConsoleOne, and browse to the context where the NCP Server 
object resides.

2 Right click on the right pane, select NEW/Volume, and enter the name of 
the new object in the first field.

This should be the server name followed by an underscore followed by 
the volume name.

3 In the second field, browse and select the appropriate server. In the third 
field click the drop down menu and select the volume, then click OK.

4 In the Server Consolidation Utility project window refresh the container 
where the volume object is located to make the new object appear.

5 When dragging and dropping in the project window, use the newly 
created volume object. 

6 After the consolidation is complete, delete the newly created volume 
object.

If you use the Clustername_Volumename object instead of creating and using 
the new volume object described above, a critical SMDR error will occur and 
you won�t be able to complete the consolidation process.
18   NetWare Server Consolidation Utility Guide
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Troubleshooting the Server Consolidation Utility

SMDR Not Communicating
Possible Cause: SMDR.NLM is not loaded on either the source or the destination server or 

SLP is not properly configured.

Action: Enter display slp services smdr.novell//(svcname-
ws==source_server_name) at the destination server console.

If SMDR.NLM is not loaded on the source or destination server, manually 
load it. 

If it appears there is a problem with SLP, go to Novell�s Support site (http://
support.novell.com/search/kb_index.jsp) and search for SLP-related 
configuration information.

NDPS Printer Agents Don�t Migrate
Possible Cause: If after a migration, it appears NDPS printer agents have not migrated it is 

possible that NDS has not had time to properly synchronize.

Action: Wait for a few minutes and then check again to see if NDS has been updated 
to reflect the printer agent migration.

Action: If the printer agents have still not migrated after allowing NDS to synchronize, 
ensure the Novell Distributed Print Services Manager (NDPSM.NLM) is 
loaded on either the source or destination server.

NUWAGENT Won�t Load (NetWare 4.2 Only)
Possible Cause: CLIBAUX.NLM is not loaded.

Action: Go to the server specified in the error message and manually load 
CLIBAUX.NLM.
Troubleshooting the Server Consolidation Utility 19
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Server Consolidation Performance Problems
NOTE: The Performance of a project can be determined by looking at the success log 
after a project completes.  The success log gives the time the project took to complete 
and the amount of data copied.

There are several factors that determine the performance of the file copy. It is also 
important to be updated to the latest Support Pack on each server to ensure you have 
the latest performance enhancements for SMS.

Possible Cause: Heavy traffic on the network

Action: Speeds can be increased by connecting servers and the workstation to a 
dedicated switch.

Possible Cause: A mismatch in duplexing among servers, switches, and the workstation.

Action: Make sure all hardware is set to full duplex or all of it is set to half duplex.  
Setting all hardware to half duplex may result in greater performance than full 
duplexing.

Possible Cause: An incorrect version of SMDR.NLM is loaded on a NetWare 5 server.

Action: At the NetWare 5 server, unload SMDR.NLM, then load the SMDR.NLM file 
that comes with the Server Consolidation utility.

Possible Cause: Small File Sizes

In general, the larger the file sizes the better the performance.  Copying a 500 
MB file will be significantly faster than copying 500MB of 1K files.

Possible Cause: Hardware Configuration

The performance of the Server Consolidation Utility will vary according to the 
environment. Using a 100MB LAN, tests have measured speeds ranging from 
3 to 15 GB per hour, with the most common speed being between 5 and 8 GB 
per hour. You should check the performance of your LAN before copying 
very large amounts of data. 

The Server Consolidation will copy data at a faster rate than a Windows file 
copy.

Volume Contents Do Not Display
Problem: No data appears in the volume object after dropping a container into a volume 

that has not been opened.

Action: If you encounter this problem, map a drive to the volume from a workstation.
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