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About This Guide

This is a short introduction to Ximian® Desktop 2 which will demonstrate the tools and resources 
available to you, whether you are an experienced Linux/UNIX desktop software user or are new 
to the operating system. 

It is not a complete guide to everything, but it demonstrates some of the capabilities of the desktop 
and points out what's new in this version. It can also help you find additional instruction manuals 
or get support for your software.

Documentation Conventions
A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX*, should use forward slashes as required by your software.

For clarity, special portions of text are denoted in the following ways: 

Commands you type at the command line

Buttons and Labels in application windows 

Menu selections look like this: Menu+Submenu > Menu Item

Anything you type in
Text output from a computer
About This Guide 7
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1 What Is Ximian Desktop 2?

Welcome to Ximian® Desktop 2. This guide will show you around and help you get started with 
the software you have just installed. If you are reading this guide before installation, you can visit 
ximian.com for installation instructions. 

Ximian Desktop provides everything you need to put your Linux system to work. It includes a 
graphical interface based on the GNOME platform, with high-quality applications like the Ximian 
Evolution® groupware suite.

All editions of Ximian Desktop add the following:

A special Ximian edition of the OpenOffice.org office suite. 

The most advanced Linux* printing system available today, integrated with the entire desktop 
and based on the CUPS subsystem. CUPS supports more printers and makes it much easier to 
set them up.

Extensive network compatibility for Windows* and UNIX networks.

Easy, removable media tools, including CD burning made simple.

A “My Computer” tool to help you navigate files, networks, and devices, designed especially 
for people migrating from Microsoft Windows.

The Red CarpetTM software management tool, which makes sure you get critical software 
updates quickly, easily, and securely.

Figure 1 Ximian Desktop
What Is Ximian Desktop 2? 9
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The Professional Edition of Ximian Desktop includes additional software and services:

Agfa Fonts: High-quality licensed fonts, metrically compatible with those used in Microsoft* 
Office, to help preserve formatting and styles across platforms. 

RealNetworks* RealPlayer*: Media player for RealAudio and RealVideo formats. Works 
with or without your Web browser.

Macromedia* Flash*: Browser plug-in for display of Flash vector animation on the Web.

Sun* Java* Runtime Environment: Allows you to use the broadest range of Java software 
with the best performance.

A year's subscription to Red Carpet Express, the Ximian high-bandwidth update service.

30 days of personalized Web-based support at support.ximian.com.
IMPORTANT: Before installing this software, you agreed to abide by the licensing terms for each component. 
Make sure that you own the licenses before using, and especially before altering or redistributing, any 
software. A copy of the licensing terms is available on the Ximian Web site. See Appendix B, “About Software 
Licensing,” on page 27 for more details.
10   Introducing Ximian Desktop 2
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2 Installing and Updating Your Desktop

This section will show you how to install Ximian® Desktop from CD-ROM or online, and how to 
get updates and new software using the Ximian Red CarpetTM software management tools.

Installing from CD
To install, you will need the Ximian Desktop CD and your system's root password. An Internet 
connection may be helpful as well if your system requires additional software that is not provided 
on the CD.

To begin, insert the Ximian Desktop CD into your CD-ROM drive. On some systems, the installer 
starts automatically and you can follow the instructions as they appear on the screen.

If the installer does not start automatically, do the following:

1 Open a terminal window.

For most systems, you can do this by right-clicking your desktop background and selecting 
New Terminal.

2 Type the command su and press Enter, then provide your root password when prompted.

3 Enter the following commands:

mkdir -p /mnt/cdrom
mount -t iso9660 -r /dev/cdrom /mnt/cdrom
cd /mnt/cdrom
./go-ximian
The installer will start.

4  Follow instructions as they appear on the screen.

Installing via Download
You may elect to download Ximian Desktop from exclusive high-bandwidth servers rather than 
have it delivered on CD.

All customers purchasing Ximian Desktop will receive an activation key which grants them access 
to the high-speed install servers and the Red Carpet Express update service. To use the key, 
download and start the installer as described at http://ximian.com/download.
NOTE: If your company has site-licensed Ximian Desktop, your network administrator will provide you with the 
key. Otherwise, the Ximian store will e-mail you the key at the time of purchase. 

When the installer prompts you for server selection, select Activate a New Red Carpet Express 
Account and enter your activation key and e-mail address.
Installing and Updating Your Desktop 11
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The installer will guide you through the rest of the install process.
TIP: If you have installed Ximian Desktop from a CD, we suggest that you run Ximian Red Carpet to see if any 
updates have been released since the disc was manufactured. If you installed online, you won't need to run 
Red Carpet right away, but you'll still want to check for updates on a regular basis.

To learn about Red Carpet, read “Updating Software with Ximian Red Carpet” on page 19.
12   Introducing Ximian Desktop 2
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3 Getting Started

This section will guide you through logging in, setting your preferences, and updating software.

The First Time You Log In
The first time you log in to Ximian® Desktop, the Doorman tool will start and welcome you to the 
desktop. It will present you with a quick question: Would you like to use new Ximian Desktop 
settings or keep your existing settings? 

Unless you have already been using a GNOME 2 desktop and have your system configured in a 
way that you particularly prefer, we suggest that you use the Ximian settings.

Removing the New Settings

If you don't like the new Doorman settings, you can switch back to the ones you had before you 
installed Ximian Desktop. Here's how:

1 Select System > Run Program from the menu panel, or open a terminal window.

2 Type the command doorman-reset and press Enter.

Your settings will be restored from the backup files, but will not take effect immediately. 

3 Log out.

You do not need to reboot.

4 Log in again.

The Doorman tool will run when you log in.

5 Select Keep My Settings to use your backup settings or Install the Ximian Desktop 2.0 Settings 
to use the Ximian Desktop default settings.

For information about fine-tuning your desktop using the Personal Settings window, read the next 
section, More Preferences: Personal Settings.

More Preferences: Personal Settings
Ximian Desktop offers two types of settings tools: Personal Settings, for general desktop 
configuration, and Administrator Settings, which affect the entire system and require the root 
password. Administrator settings will vary depending on your operating system, and you should 
consult your operating system's manual for information about them.

There are two ways to get to the Personal Settings tools. First, you can open the settings window 
by selecting System > Personal Settings from your menu panel. There, double-click the tool that 
you want to use. Alternately, double-click My Computer on your desktop to open the My Computer 
Getting Started 13
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window. In this window, double-click the Settings icon and then choose the settings category and  
tool you want to use.

The various tools are divided into five categories:

Personal: Tools related directly to you, such as your menu preferences, accessibility tools, and 
keyboard shortcuts.

Appearance: Tools that control the way that your desktop looks, such as the fonts, window and 
button themes, and the desktop background.

Hardware: Tools that control how your desktop interacts with your mouse, keyboard, and 
printers. 

System: Tools that let you set lower-level software behavior, such as network connections, 
login sessions, and file type associations.

Others: Any other tools that might be installed. This category will vary depending on your 
operating system and the software you have installed.

Figure 2 Personal Settings

You can find more detailed information about the various configuration tools by selecting Help > 
User Manual, then clicking the Desktop topic.

Viewing and Adding Printers
Double-click the Printers button in the Settings window to display a list of available printers. This 
is the same window you can get from the My Computer view. Some types of network printers will 
automatically appear in the list of printers, as will any printers you have previously set up.

You can use the printers display to check the status of current print jobs, change preferences for 
existing printers and, of course, add new ones.
14   Introducing Ximian Desktop 2
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To check the status of an individual printer, double-click it. To change its settings, right-click it and 
select Properties. The printer properties dialog lets you choose the resolution, name, paper type, 
and paper handling settings for your printer. You may need your root password to change the 
printers or to stop print jobs that do not belong to you. 

Figure 3 Adding a Printer

TIP: Active print jobs also appear in the Notification Area panel applet, if you are running it. To start the 
Notification Area tool, right-click a blank space in your panel and select Add to Panel+Utility > Notification Area.

The notification area also displays information from other applications, including instant messenger 
applications and the multimedia keys tool. 

To add a new printer, double-click the New Printer icon. A printer setup assistant will guide you 
through the process of adding a printer to the list of available printers.
Getting Started 15



    Novell Confidential                                                                                            Manual (ENU)  13 November 2003
16   Introducing Ximian Desktop 2



    Novell Confidential                                                                                            Manual (ENU)  13 November 2003
4 Working with Ximian Desktop

Ximian® Desktop contains tools to help you complete hundreds of different tasks in hundreds of 
different ways. Whether you're writing a letter, developing new software, or playing a game of 
solitaire, Ximian Desktop makes it fun, easy, and quick.

Create Documents and Presentations with OpenOffice.org
The Ximian Edition of the OpenOffice.org office suite is a complete set of office tools which can 
both read and save Microsoft Office file formats. It has a word processor, a spreadsheet, a drawing 
tool, and a presentation program. To get started, select one of the tools from the Programs > Office 
menu.

Figure 4 OpenOffice.org Office Suite

The Ximian edition of OpenOffice.org includes hundreds of new icons, a smoother user interface, 
tighter integration with the printing system, and faster startup times.
TIP: As shipped by Novell®, OpenOffice.org uses the Microsoft file formats by default and reduces startup time 
by preloading certain libraries when you log in. You can change these settings by selecting Office Settings from 
the Office portion of your Programs menu. The rest of the OpenOffice.org application settings are found in the 
OpenOffice application itself. To open the main OpenOffice.org settings window, select Tools > Configure
Working with Ximian Desktop 17
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Ximian has included a number of sample documents and templates, which you can find by 
selecting File+New > Templates and Documents. In addition, you can use AutoPilot, a feature 
which guides you through the creation of letters and other typical documents. 

There isn't room here to include detailed instructions on how to use OpenOffice.org. To find out 
more, you can go to the Help menu in the OpenOffice.org window and select Contents. 

Communicate and Schedule with Ximian Evolution
Ximian Evolution® seamlessly combines e-mail, calendar, address book, and task list in one easy-
to-use application. With its extensive support for communications and data interchange standards, 
Evolution can work with existing corporate networks and applications, including Microsoft 
Exchange.

To start Ximian Evolution, select Programs+Ximian Evolution. The first time you start it, Ximian 
Evolution will ask you a few questions as it sets up a mail account and helps you import mail from 
your old mail client. Then, it will bring you to the executive summary, which shows you how many 
new messages you have and lists upcoming appointments and tasks, as well as the current weather 
and news from news feeds. The calendar, address book, and mail tools are available in the shortcut 
bar on the left.

Figure 5 Ximiam Evolution Groupware Suite

For more information about how to use Ximian Evolution, select an item from the Help menu in 
the main Evolution window.
18   Introducing Ximian Desktop 2
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Updating Software with Ximian Red Carpet
Red Carpet is a software management tool that allows you to perform the following tasks:

Update: Check for security updates or improvements to your currently installed software.

Install: Find and install additional software.

Remove: Delete unused software without damaging the functionality of the system as a 
whole.

Red Carpet organizes software into channels, each of which contains related software packages. 
For example, the channel “Ximian Connector” contains the Ximian Connector for Microsoft 
Exchange and its associated support packages, and the channel “Red Hat 8.0” contains all of Red 
Hat* Linux 8.0.

Figure 6 Red Carpet Software Management Tool

To install software or be notified of updates to it, you must first subscribe to its channel. If you are 
not subscribed to a channel, Red Carpet will assume that you are not interested in installing or 
updating its contents. Channel subscriptions let you focus on the software you want and ignore the 
software you don’t.

To start Red Carpet, select System > Update Software. You will need your system's root password 
to change anything, but you can view your system and the available software as a regular user.

If you did not do so during the install process, you should activate your Red Carpet Express 
account now. Select File > Activate and enter your e-mail address and activation key.

The first time you run Red Carpet, you are not subscribed to any channels, so it will not display 
any updates. To adjust your channel subscriptions, click the Channels button in the toolbar at the 
top of the window. This will open a new window where you can select from a variety of channels.
Working with Ximian Desktop 19
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Click the check box to the left of a channel to subscribe to a channel. When you are done, click 
OK. If updates are available in any of the channels you have subscribed to, they will be displayed 
in the main window now. 

To perform an update, select a package by clicking it and then clicking the Mark for Installation 
button. When you have selected all the software you want to update, click the Run Now button. 

Red Carpet will then make sure that the update is possible and alert you if it must install or remove 
other software in order to perform the update. Confirm the transaction by clicking the Continue 
button, or cancel it by clicking Cancel. 

Check the Red Carpet manual, under the Help menu in the application window, for information 
about software conflicts and dependencies, installation, removal, advanced searching, and 
premium services.

Browse the Web
Ximian ships a Web browser based on the same display engine as the Mozilla and Netscape 
browsers. You can start it by selecting Programs+Web Browser from your menu panel. 

You can type an address into the location bar at the top, or click links in a page, to move to different 
pages, just like in any other Web browser.

Two features that deserve special mention are the smart toolbar and tabbed browsing. The smart 
toolbar is below the main location bar and has a series of text entry boxes you can use to run 
searches in the Google search engine, the GNOME bug database, or a dictionary, without having 
to go to any particular site first. You can create your own toolbar as well. See the browser's help 
menu for details. 

Figure 7 Browsing the Web
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Tabbed browsing lets you load multiple pages in a single window, putting one page per tab as 
though they were in a tabbed notebook. That way, you can have several pages open but not clutter 
your screen and window list with windows. To open a new tab, press Ctrl-T. To open a link in a 
new tab, right-click it and select Open Tab in New Window. You can set the browser to open new 
tabs instead of new windows all the time, even for popup ads, in the preferences window. Tab 
behavior is set in the User Interface portion of the browser preferences dialog, which you can open 
by selecting Edit > Preferences from a browser window. 
TIP: To open a link in a new window or tab, just middle-click it. Depending on the preferences you have set, 
the link will open in a new window or a new tab. To download a link, hold down the Shift key and left-click. You 
can also right-click a link and select from options like Open in New Window or Copy Link Location.

Using the Nautilus File Manager
If you have used a computer before, Ximian Desktop will probably look familiar to you: a desktop 
with icons on it and panels at the top and bottom with menus and buttons. 

The application that handles the display of the desktop and files is called Nautilus. Nautilus 
performs roughly the same tasks as the Macintosh Finder or Windows Explorer applications. 

You can use the desktop background to store and access files. Just double-click an icon and 
Nautilus will trigger the appropriate action. If you choose a folder, Nautilus will open a window 
and show you the contents. If you choose a file, Nautilus will open it in the associated application 
(or ask you to choose one). If you choose an application shortcut, Nautilus will start the 
application. 
TIP: If you're not sure what something is, hover the mouse over it. A small text box called a tool tip will appear 
to explain it. You can also right-click on most items to get a list of available actions.

To move files around, just drag them with the mouse. You can also use Ctrl-X, Ctrl-C, and Ctrl-V 
to cut, copy, and paste files just as you would text. 

To rename a file or change its access permissions, right-click it and select Properties. 

For a complete manual, select Help > User Manual and then click the Desktop topic, or select one 
of the items from the Help menu in a Nautilus window. 

My Computer and Other Special Locations
Nautilus has several special folder locations available to you, such as the My Computer view. To 
learn about them, double-click the My Computer icon on your desktop, or open a Nautilus window 
and type system:/// into the location bar. The My Computer view displays links to any 
removable drives you have available, such as a CD-ROM or floppy drive, and additional special 
folders for fonts, printers, menu editing, preferences, and network shared folders.

Accessing your CD-ROM and Floppy Drives
The CD-ROM and floppy drive icons will take you to your CD-ROM or floppy drive. To use these 
tools, your user account must have permission to use the drive and the files on it.

Viewing Fonts with the Fonts Display
The Fonts folder shows you the fonts that are available on your system. Double-click any of them 
to get additional information, samples, and more. If your user account has permission, you can can 
drag font files into and out of the folder to adjust the fonts available on your system. 
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The fonts licensed from Agfa are those which have “AMT” (Agfa Monotype) or “MT” 
(Monotype) in their names, such as Albany AMT and Bell MT. 

Editing the Programs Menu
Double-click the Programs folder to see a folder with the contents of your Programs menu from 
the menu panel. You can drag items in or out of the Programs folder to change the contents of the 
menu.

Create a new folder in the Programs window to create a new submenu in the Programs menu. To 
add a new item in the menus, select File > New Launcher.

Items in the menu will be sorted in alphabetical order. 

The Settings and Printers Views in My Computer
These two views are covered in “More Preferences: Personal Settings” on page 13 and “Viewing 
and Adding Printers” on page 14.

Accessing UNIX and Windows Network Folders
The folders Unix Servers and Windows Network offer you convenient access to shared folders 
mounted using the NFS (UNIX) and SMB (Windows) protocols. Both are similar to the Network 
Neighborhood folder you may be familiar with from Microsoft Windows. 

To access folders displayed in the Windows network, you may need to enter a username and 
password. The UNIX network folders will make use of Kerberos or UNIX authentication, but will 
not ask for a username or password. 

Writing to CD-R Discs
To write to a recordable CD or create a CD image (ISO) file: 

1 Select Go > CD Creator or enter the special Nautilus location burn:///.

2 Drag the files you want to burn to CD into the burn:/// window.

3 Select File > Write to CD.

4 In the dialog that opens, select the target for your files, which may be a writable CD drive or 
a disk image (.ISO) file.

5 Select a write speed.

Reducing the write speed can prevent some errors.

6 Enter a name for your CD.

7 Click OK.

Panels and Menus on the Desktop
The thin gray bars at the top and bottom of your screen are called panels. They hold application or 
document shortcuts, menus, and even small applications called applets, such as the clock and the 
window list. 
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The top panel is called the menu panel and its menus give you access to all major GNOME 
applications, plus system settings and help information. 

To add an item to your panel, you can drag it from anywhere on the desktop, or right-click a blank 
space in the panel and choose one of the items under Panel > Add to Panel. When you have added 
them, you can move items by middle-clicking them and dragging. 

For detailed help on using the panels, select Help > User Manual and then click the Desktop topic, 
or right-click the panel and select Help.

Important Panel Applets
There are a large number of panel tools, or applets, available. Two of the most important are the 
workspace switcher and the window list. For a complete list, right-click a blank space in the panel 
and select one of the items from Panel > Add to Panel.

The workspace switcher displays a series of boxes, each representing one virtual desktop. 
Normally, there are four. If you look inside them, you can see outlines of the windows you have 
open in the desktop. Click one of the workspaces to get to a new desktop, or drag a window around 
inside the applet to move it between the desktops. You can have as many (or as few) virtual 
desktops as you like. Right-click the applet and select Properties to change the settings. 

The window list applet contains a list of currently open windows. If you minimize a window, it 
will still appear in the window list and you can click its entry there to restore it to full size. 

Working in a Windows World
Ximian Desktop 2 provides a host of capabilities for organizations using a mixture of Linux and 
Windows systems:

Microsoft Office file format support: OpenOffice.org supports the file formats from Office 97, 
2000, and XP, so you don't have to worry about the format, even when people send you 
documents from the newest systems.  

Metrically compatible fonts: Not only will the files translate, but Ximian has chosen fonts that 
are the same size as those on Windows, to help preserve page breaks, bullet points, and other 
document formatting.

Windows (SMB) networking: Open the My Computer view and double-click the Windows 
Network icon to get to file servers and shared volumes.

Communications standards support: Ximian Evolution works with POP, SMTP, IMAP, and 
other standardized communications protocols letting you use the application as an e-mail 
client for virtually any messaging system.

Optional Microsoft Exchange support with Ximian Connector: With Ximian Connector, you 
can use Evolution to access shared or private e-mail, group schedules, company address lists, 
public folders, and more on a Microsoft Exchange 2000 or 2003 server.

Keyboard shortcuts: Ximian Desktop uses the familiar cut, copy, and paste shortcuts from 
Windows, and the Windows key found on many keyboards opens the main GNOME menu 
just as it would open the Start menu in Windows. To change keyboard shortcuts, select System 
> Personal Settings.
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A Troubleshooting, Manuals, and Support

This section presents you with three strategies to finding solutions for problems you might run 
into. The first step in most cases is to identify the problem as clearly as possible. Then, check the 
product manuals to see if they have any information about your problem. If you don't find the right 
information there, then check the Ximian® support center or the informal support network of the 
general Linux community. 

If an application crashes, or if you find a problem or defect in the software, you can use the Bug 
Buddy problem reporting tool to let the developers know what's wrong. A good, clear bug report 
is the best way to get a problem fixed in the next version of the software.

Troubleshooting: Identify the Problem
When you run into trouble, try to find out what exactly went wrong. The more you know about the 
problem, the easier it will be to find a solution.

Table 1 Common Problems and Likely Solutions

Problem Likely Cause Possible Solution

Can’t log in. Incorrect password. Check to be sure that the Caps Lock key 
is up. Reset user's password by logging 
in as root. 

Not enough disk space for temporary 
files created by user session.

Make sure that your hard drive, 
particularly the /tmp partition, is not full. 
You may need to log in at a text console 
(press Ctrl-Alt-F1 to get to one, and Ctrl-
Alt-F7 to get back.) and use the df -h 
command to do so. 

Corrupted ~/.gnome, ~/.gnome2, or  
~/.gconf directory.

Erase the ~/.gnome or ~/.gnome2 
directory. Note that this will reset all 
preferences to the system default. 
Alternately, use the gconf-editor tool to 
change or delete specific gconf keys. 
Check with a system administrator or 
online for more information about how to 
alter gconf entries.
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Instruction Manuals and Documentation
Ximian Desktop includes help, which you can find in several ways. The menu panel at the top of 
your screen has a Help menu where you can find the overall desktop help system. Each application 
also has a Help menu for specific instructions on how to use that application. 

The desktop help system provides access to man (manual) and info (information) pages associated 
with command line programs as well as to the help for graphical programs. To access the man and 
info pages, select Help > User's Manual from the menu panel and then click the links for the 
manual and info pages listed under the heading Additional Documents. 
TIP: Other places to look for support include the Ximian support center, your operating system vendor's Web 
page, and mailing lists which discuss the software specific to your problem. In addition, general purpose search 
engines are often helpful. For example, you might try the search terms "Linux CD-RW help" or "OpenOffice file 
conversion problem" if you were having trouble with the Galeon Web browser or with OpenOffice.org file 
conversion. Google also has a specific Linux search engine at http://www.google.com/linux which you may find 
useful.

Free and Paid Support Options
Support is available from several different sources. The purchase of Ximian Desktop includes a 
support activation ID that entitles you to personalized Web-based support at support.ximian.com. 
If you have already used the support included with your purchase, you may buy more. 

Your operating system vendor may also have paid support options available. 

Ximian provides an online knowledge base at support.ximian.com which provides answers to a 
host of common technical questions. 

Can't install new software. Wrong permissions, or using wrong 
command to become root.

Install as root user. Make sure you use 
the su rather than the sudo command.

Not enough disk space. Check to make sure that you have 
enough disk space, using the df -h 
command or your file manager.

Package database is corrupted or 
missing. 

For RPM distributions, use the  
rpm --rebuilddb command as root. Make 
sure that you have the most recent 
version of RPM. For Debian, use the  
apt-get -f install command with no other 
arguments.

Can't install software or use the df 
command to check disk usage.

Mounted file systems are inaccessible. Check that all inaccessible disks have 
been unmounted properly. An improper 
NFS server mount can cause indefinite 
delays in certain types of file system 
access. We suggest that you always 
mount NFS file systems with the soft, 
intr, and nolock options.

Applications such as Red Carpet or the 
Time and Date tool refuse to start from 
menus.

The gtk-usermode package is required 
for graphical permissions requests.

Open a terminal and become root with 
the su command, then run Red Carpet 
and install the package gtk-usermode.

Problem Likely Cause Possible Solution
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B About Software Licensing

Licensing terms for Ximian® Desktop are displayed during the install process, and you must read 
and agree to them before completing the installation. So that you can refer to them later, the 
licenses are also available at the Ximian Web site. 

Each piece of software (“package”) shipped with Ximian Desktop has its own license, which may 
or may not be determined by Ximian, Inc. 

Most packages in Ximian Desktop are free software, licensed under the GNU General Public 
License or Lesser General Public License (LGPL). You can find the source code for these packages 
at the developer.ximian.com, www.gnome.org, and www.openoffice.org Web sites. You can learn 
more about Free Software by visiting the Free Software Foundation Web site at www.gnu.org. 

Nonfree software shipped with Ximian Desktop includes Acrobat Reader, the Java Runtime 
Environmnet (JRE), Flash, the Agfa fonts, and RealPlayer. These programs are distributed under 
proprietary licenses and you may not redistribute them without permission from the 
manufacturers. 
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