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Chapter 35, “Understanding Message Delivery and Storage in the Post Office,” on page 463
Chapter 36, “Configuring the POA,” on page 475
Chapter 37, “Monitoring the POA,” on page 515
Chapter 38, “Optimizing the POA,” on page 547
Chapter 39, “Using POA Startup Switches,” on page 565
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35Understanding Message Delivery 
and Storage in the Post Office

A post office is a collection of user mailboxes and GroupWise® objects. Messages are delivered into 
mailboxes by the Post Office Agent (POA). The following topics help you understand the post office 
and the functions of the POA:

Section 35.1, “Post Office Representation in ConsoleOne,” on page 463
Section 35.2, “Post Office Directory Structure,” on page 464
Section 35.3, “Information Stored in the Post Office,” on page 464
Section 35.4, “Post Office Access Mode,” on page 468
Section 35.5, “Role of the Post Office Agent,” on page 469
Section 35.6, “Message Flow in the Post Office,” on page 471
Section 35.7, “Cross-Platform Issues in the Post Office,” on page 471

35.1  Post Office Representation in ConsoleOne
In ConsoleOne®, post offices are container objects that contain at least one POA object, as shown 
below:

Figure 35-1   ConsoleOne View Showing the POA Object

Although each post office is linked to a domain, it does not display as subordinate to the domain in 
the Console View. However, using the GroupWise View, you can display post offices as subordinate 
to the domains to which they are linked in your GroupWise system.
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Figure 35-2   GroupWise View Showing Post Offices in Relationship to Domains

35.2  Post Office Directory Structure
Physically, a post office consists of a set of directories that house all the information stored in the 
post office. See “Post Office Directory” in GroupWise 7 Troubleshooting 3: Message Flow and 
Directory Structure.

35.3  Information Stored in the Post Office
The following types of information are stored in the post office:

Section 35.3.1, “Post Office Database,” on page 464
Section 35.3.2, “Message Store,” on page 464
Section 35.3.3, “Guardian Database,” on page 466
Section 35.3.4, “Agent Input/Output Queues in the Post Office,” on page 466
Section 35.3.5, “Libraries (optional),” on page 467

All databases in the post office should be backed up regularly. How often you back up GroupWise 
databases depends on the reliability of your network and hardware. See Section 31.2, “Backing Up a 
Post Office,” on page 407.

35.3.1  Post Office Database
The post office database (wphost.db) contains all administrative information for the post office, 
including a copy of the GroupWise Address Book. This information is necessary for users to send 
messages to others in the GroupWise system.

35.3.2  Message Store
GroupWise messages are made up of three parts:

Message Header: The message header contains addressing information including the sender’s 
address, recipient’s address, message priority, status level, and a pointer that links the header to 
the message body.
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Message Body: The message body contains the message text in an encrypted format and a 
distribution list containing user IDs of the sender and recipients.
File Attachments (optional): File attachments can be any type of file that is attached to the 
message.

The message store consists of directories and databases that hold messages. The message store is 
shared by all members of the post office so only one copy of a message and its attachments is stored 
in the post office, no matter how many members of the post office receive the message. This makes 
the system more efficient in terms of message processing, speed, and storage space.

All information in the message store is encrypted to prevent unauthorized access.

The message store contains the following components:

“User Databases” on page 465
“Message Databases” on page 465
“Attachments Directory” on page 466

User Databases

Each member of the post office has a personal database (userxxx.db) which represents the user’s 
mailbox. The user database contains the following:

Message header information
Pointers to messages
Folder assignments
Personal groups
Personal address books
Rules
Contacts
Checklists
Categories
Junk Mail lists

When a member of another post office shares a folder with one or more members of the local post 
office, a “prime user” database (puxxxxx.db) is created to store the shared information. The 
“prime user” is the owner of the shared information.

Local user databases and prime user databases are stored in the ofuser directory in the post office.

Message Databases

Each member of the post office is arbitrarily assigned to a message database (msgnnn.db) where 
the body portions of messages are stored. Many users in a post office share a single message 
database. There can be as many as 255 message databases (numbered 0 through 254) in a post 
office. Message databases are stored in the ofmsg directory in the post office. 

Historical Note: Prior to GroupWise 7, the POA created a maximum of 25 message databases per 
post office. The current maximum of 255 message databases speeds up message delivery and 
minimizes user impact if a database is damaged.
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Outgoing messages from local senders are stored in the message database assigned to each sender. 
Incoming messages from users in other post offices are stored in the message database that 
corresponds to the message database assigned to the sender in his or her own post office. In each 
case, only one copy of the message is stored in the post office, no matter how many members of the 
post office it is addressed to.

Attachments Directory

The attachments directory (offiles) contains subdirectories that store file attachments, message 
text, and distribution lists that exceed 2 KB. Items of this size are stored more efficiently as files 
than as database records. The message database contains a pointer to where each item is found. 

35.3.3  Guardian Database
The guardian database (ngwguard.db) serves as the master copy of the data dictionary 
information for the following subordinate databases in the post office:

User databases (userxxx.db)
Message databases (msgnnn.db)
Prime user databases (puxxxxx.db)
Library databases (dmsh.db and dmxxnn01-FF.db)

The guardian database is vital to GroupWise functioning. Therefore, the POA has an automated 
back-up and roll-forward process to protect it. The POA keeps a known good copy of the guardian 
database called ngwguard.fbk. Whenever it modifies the ngwguard.db file, the POA also 
records the transaction in the roll-forward transaction log called ngwguard.rfl. If the POA 
detects damage to the ngwguard.db file on startup or during a write transaction, it goes back to 
the ngwguard.fbk file (the “fall back” copy) and applies the transactions recorded in the 
ngwguard.rfl file to create a new, valid and up-to-date ngwguard.db.

In addition to the POA back-up and roll-forward process, you should still back up the 
ngwguard.db, ngwguard.fbk, and ngwguard.rfl files regularly to protect against media 
failure. Without a valid ngwguard.db file, you cannot access your e-mail. With current 
ngwguard.fbk and ngwguard.rfl files, a valid ngwguard.db file can be rebuilt should the 
need arise.

The ngwguard.dc file is the structural template for building the guardian database and its 
subordinate databases. Also called a dictionary file, the ngwguard.dc file contains schema 
information, such as data types and record indexes. If this dictionary file is missing, no additional 
databases can be created in the post office.

35.3.4  Agent Input/Output Queues in the Post Office
Each post office contains agent input/output queues where messages are deposited and picked up for 
processing by the POA and the MTA. The MTA transfers messages into and out of the post office, 
while the POA handles message delivery. 

For illustrations of the processes presented below, see “Message Delivery to a Different Post Office” 
and “Message Delivery to a Different Domain” in GroupWise 7 Troubleshooting 3: Message Flow 
and Directory Structure. 
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MTA Output Queue in the Post Office

The MTA output queue in each post office is the post_office\wpcsout directory.

If the MTA has a mapped or UNC link to the post office, the MTA writes user messages directly into 
its output queue, which requires write access to the post office. If the MTA has a TCP/IP link to the 
post office, the MTA transfers user messages to the POA by way of TCP/IP. The POA then stores the 
messages in the MTA output queue on behalf of the MTA, so the MTA does not need write access to 
the post office.

The post_office\wpcsout\ofs subdirectory is where the MTA transfers user messages for 
delivery by the POA to users’ mailboxes in the local post office.

The MTA post_office\wpcsout\ads subdirectory is where the MTA transfers 
administrative messages instructing the POA admin thread to update the post office database 
(wphost.db).

POA Input Queue in the Post Office

The POA input queue in each post office is the post_office\wpcsout directory, which is the 
same as the MTA output queue.

The post_office\wpcsout\ofs subdirectory is where the POA picks up user messages 
deposited there by the MTA and updates the local message store, so users receive their messages.

The post_office\wpcsout\ads subdirectory is where the POA admin thread picks up 
administrative messages deposited there by the MTA and updates the post office database 
(wphost.db).

POA Output Queue in the Post Office

The POA output queue (post_office\wpcsin) is where the POA deposits user messages for the MTA 
to transfer to other domains and post offices.

Historical Note: In earlier versions of GroupWise, the GroupWise client wrote user messages to the 
POA output queue when using direct access to the post office. In GroupWise 6.x and later, client/
server access to the post office is the preferred method. 

MTA Input Queue in the Post Office

The MTA input queue in each post office (post_office\wpcsin) is the same as the POA 
output queue. The MTA picks up user messages deposited there by the POA and transfers them to 
other domains and post offices.

For a mapped or UNC link between the domain and post office, the MTA requires read/write access 
rights to its input/output queues in the post office. For a TCP/IP link, no access rights are required 
because messages are communicated to the MTA by way of TCP/IP.

35.3.5  Libraries (optional)
A library is a collection of documents and document properties stored in a database system that can 
be managed and searched. You do not need to set up libraries unless you are using GroupWise 
Document Management Services (DMS). See Part VII, “Libraries and Documents,” on page 291.
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Library Databases

The databases for managing libraries are stored in the gwdms directory and its subdirectories in the 
post office.

The dmsh.db file is a database shared by all libraries in the post office. It contains information 
about where each library in the post office is located.

Each library has its own subdirectory in the gwdms directory. In each library directory, the 
dmxxnn01-FF.db files contain information specific to that library, such as document properties 
and what users have rights to access the library.

Document Storage Areas

The actual documents in a library are not kept in the library databases. They are kept in a document 
storage area, which consists of a series of directories for storing document files. Documents are 
encrypted and stored in BLOBs (binary large objects) to make document management easier. A 
document, its versions, and related objects are stored together in the same BLOB.

A document storage area might be located in the post office directory structure, or in some other 
location where more storage space is available. If it is located in the post office, the document 
storage area can never be moved. Therefore, storing documents in the post office directory structure 
is not usually recommended. If it is stored outside the post office, a document storage area can be 
moved when additional disk space is required.

35.4  Post Office Access Mode
The GroupWise 6.x and later Windows client and the GroupWise 6.5 and later Cross-Platform client 
both use client/server access mode to the post office. This requires a TCP/IP connection between the 
GroupWise clients and the POA in order for users to access their mailboxes. Benefits of client/server 
access include:

Load Balancing: The workload is split between the client workstation and the POA on another 
server. The POA can perform a processor-intensive request while the client is doing something 
else.
Database Integrity: The GroupWise client does not need write access to databases in the post 
office. Therefore, client failures cannot damage databases.
Reduced Network Traffic: Requests are processed on the POA server and only the results are 
sent back across the network to the client workstation.
Tighter Security: Client users do not need to log in to the server where the post office is 
located. This eliminates the need for users to have write access to the post office directory.
Scalability: More concurrent users can be supported in a single post office.
Platform Independence: The GroupWise client on any platform can access the post office by 
way of TCP/IP communication with the POA.
Simplified Client Connections: The GroupWise client can communicate with any POA in the 
GroupWise system. Any POA can then redirect the client to connect to the correct POA for the 
users’ post office. 

Historical Note: In GroupWise 5.x, the GroupWise client allowed the user to enter a path to the post 
office directory to facilitate direct access mode. The GroupWise 6.x and later clients no longer offer 
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the user that option. However, you can force the GroupWise 6.x and later client to use direct access 
by starting it with the /ph switch and providing the path to the post office directory.

35.5  Role of the Post Office Agent
The GroupWise Post Office Agent (POA) delivers messages to users’ mailboxes, connects users to 
their post offices in client/server access mode, updates post office databases, indexes messages and 
documents, and performs other post office-related tasks. You must run at least one POA for each 
post office.

The following sections help you understand the various functions of the POA:

Section 35.5.1, “Client/Server Processing,” on page 469
Section 35.5.2, “Message File Processing,” on page 470
Section 35.5.3, “Other POA Functions,” on page 470

35.5.1  Client/Server Processing
Using client/server access mode, the GroupWise client maintains one or more TCP/IP connections 
with the POA and does not access the post office directly. Consequently, the performance of the 
POA in responding to requests from the GroupWise client directly affects the GroupWise client’s 
responsiveness to users. To provide the highest responsiveness to client users, you can configure a 
POA just to handle client/server processing. See Section 38.1.3, “Configuring a Dedicated Client/
Server POA,” on page 550.

When using client/server access mode, the GroupWise client can be configured to control how much 
time it spends actually connected to the POA.

In Online mode, the client is continuously connected.
In Caching mode, the client connects at regular intervals to check for incoming messages and 
also whenever the client user sends a message. Address lookup is performed locally. Caching 
mode allows the POA to service a much higher number of users than Online Mode.
In Remote mode, the client connects whenever the client user chooses, such as when using a 
brief modem connection to download and upload messages.

NOTE: Remote mode is not currently available in the Cross-Platform client.

For more information about the client modes available with client/server access mode, see “Using 
Caching Mode” and “Using Remote Mode” in the GroupWise 7 Windows Client User Guide and 
“Using Caching Mode” in the GroupWise 7 Cross-Platform Client User Guide.

Client/server access mode also allows users to access their GroupWise mailboxes from POP and 
IMAP clients, in addition to the GroupWise client. See Section 36.2.3, “Supporting IMAP Clients,” 
on page 490.

In client/server mode, the POA can provide and, if necessary, force secure SSL connections with all 
clients. See Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on 
page 498.
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35.5.2  Message File Processing
Messages from users in other post offices arrive in the local post office in the form of message files 
deposited in the POA input queue. See Section 35.3.4, “Agent Input/Output Queues in the Post 
Office,” on page 466. 

The POA picks up the message files and updates all user and message databases to deliver incoming 
messages in the local post office. To provide timely delivery for a large volume of incoming 
messages, you can configure a POA just to handle message file processing. See Section 38.2.2, 
“Configuring a Dedicated Message File Processing POA,” on page 553. 

35.5.3  Other POA Functions
In addition to client/server processing (interacting with client users) and message file processing 
(delivering messages), the POA: 

Performs indexing tasks for document management. See Section 38.3.1, “Regulating 
Indexing,” on page 555.
Performs scheduled maintenance on databases in the post office. See Section 36.4.1, 
“Scheduling Database Maintenance,” on page 507.
Monitors and manages disk space usage in the post office. See Section 36.4.2, “Scheduling 
Disk Space Management,” on page 510.
Restricts the size of messages that users can send outside the post office. See Section 36.2.8, 
“Restricting Message Size between Post Offices,” on page 495.
Primes users’ mailboxes for Caching mode. See Section 36.2.7, “Supporting Forced Mailbox 
Caching,” on page 494.
Performs nightly user upkeep so users do not need to wait while the GroupWise client performs 
it; also creates a downloadable version of the system Address Book for Remote and Caching 
users. See Section 36.4.3, “Performing Nightly User Upkeep,” on page 513.
Provides LDAP authentication and LDAP server pooling. See Section 36.3.4, “Providing 
LDAP Authentication for GroupWise Users,” on page 501.
Prevents unauthorized access to the post office. See Section 36.3.5, “Enabling Intruder 
Detection,” on page 506.
Tracks the GroupWise client software in use in the post office. See Section 36.2.6, “Checking 
What GroupWise Clients Are in Use,” on page 492.
Automatically detects and repairs invalid information in user databases (userxxx.db) and 
message databases (msgnnn.db) for the local post office by using an efficient multi-threaded 
process. See Section 38.4.1, “Adjusting the Number of POA Threads for Database 
Maintenance,” on page 559.
Automatically detects and repairs invalid information in the post office database 
(wphost.db).
Automatically detects and repairs damage to the guardian database (ngwguard.db) in the 
post office.
Updates the post office database whenever GroupWise users, resources, post offices, or other 
GroupWise objects are added, modified, or deleted.
Replicates shared folders between post offices. 
Executes GroupWise client rules. 
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Processes requests from GroupWise Remote users.

35.6  Message Flow in the Post Office
To see how messages are delivered using client/server access mode, see “Message Delivery in the 
Local Post Office” in GroupWise 7 Troubleshooting 3: Message Flow and Directory Structure.

35.7  Cross-Platform Issues in the Post Office
GroupWise is designed to function in a variety of environments. The GroupWise Windows client 
runs on the following platforms:

Windows 2000
Windows XP
Windows 2003

The GroupWise Cross-Platform client runs on the following platforms:

Linux
Macintosh

In addition, GroupWise users can access their mailboxes without using a GroupWise client through 
the following applications:

GroupWise WebAccess (see “WebAccess” on page 853)
POP and IMAP clients such as Netscape* Mail, Eudora* Pro, Microsoft Outlook, and 
Entourage*
MAPI clients such as Microsoft Mail and cc:Mail*
SOAP clients such as Evolution

Post offices can be located on the following platforms:

Novell® NetWare®

Windows Server
Linux

The GroupWise agents can run on the following platforms:

Novell NetWare
Windows Server
Linux

In general, GroupWise is most efficient if you match the agent platform with the network operating 
system, so the POA and the post office should be on the same platform, and the client should be on a 
compatible platform. Those with mixed networks might wonder what combinations are possible. 
You have several alternatives.

Section 35.7.1, “Client/Post Office Platform Independence through Browser Technology,” on 
page 472
Understanding Message Delivery and Storage in the Post Office 471



472 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
Section 35.7.2, “Client/Post Office Platform Independence through Client/Server Mode,” on 
page 472
Section 35.7.3, “POA/Post Office Platform Dependencies Because of Direct Access 
Requirements,” on page 472

35.7.1  Client/Post Office Platform Independence through 
Browser Technology
If your GroupWise users want to access their mailboxes through POP3, IMAP4, or SOAP clients, it 
makes no difference what platform their post offices are located on. However, users are limited to 
the client capabilities of their POP3, IMAP4, or SOAP clients.

If you install GroupWise WebAccess on a Web server, GroupWise users can still access their 
mailboxes through their browsers and with more native GroupWise features available. See 
“WebAccess” on page 853 for more information.

35.7.2  Client/Post Office Platform Independence through 
Client/Server Mode
The GroupWise 6.5 and later Windows client and the Cross-Platform client require Client/Server 
access mode. With this configuration, it makes no difference what platform users’ post offices are 
located on. The GroupWise client accesses the post office by communicating with the POA using 
TCP/IP, which is a platform-independent protocol.

35.7.3  POA/Post Office Platform Dependencies Because of 
Direct Access Requirements
The POA must have direct access to the post office directory. Therefore, the POA must be able to 
log in to the server where the post office is located and must be able to write to the databases and 
directories located in the post office. 

Although the recommended configuration is for the POA and the post office to be on the same 
platform and preferably on the same server, some variation is possible. The table below summarizes 
the various combinations of POA and post office platforms and indicates which combinations work 
for direct access and which ones do not for GroupWise 7.x:

Table 35-1   POAs and Platforms Supported for Direct Access

1 For these combinations, an NFS* connection is required, which is not a supported configuration 
for the agents.

 NetWare POA Linux POA Windows POA

Post Office on NetWare Yes Not supported1 Yes

Post Office on Linux Not supported1 Yes Yes

Post Office on Windows  No2 Yes Yes

Post Office on 
Macintosh 

No3 No3 No3
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2 The NetWare POA cannot service a post office on a Windows server because Windows does not 
support the required cross-platform connection.

3 Post offices cannot be created on Macintosh computers.
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36Configuring the POA

For detailed instructions about installing and starting the POA for the first time, see “Installing 
GroupWise Agents” in the GroupWise 7 Installation Guide. 

As your GroupWise® system grows and evolves, you might need to modify POA configuration to 
meet the changing needs of the post office it services. The following topics help you configure the 
POA:

Table 36-1   Configuring the POA

36.1  Performing Basic POA Configuration
POA configuration information is stored as properties of its POA object in eDirectoryTM. The 
following topics help you modify the POA object in ConsoleOne® and change POA configuration to 
meet changing system configurations:

Section 36.1.1, “Creating a POA Object in eDirectory,” on page 476
Section 36.1.2, “Configuring the POA in ConsoleOne,” on page 477

Section 36.1, “Performing 
Basic POA Configuration,” on 
page 475

Creating a POA Object in eDirectory
Configuring the POA in ConsoleOne
Changing the Link Protocol between the Post Office and the 

Domain
Binding the POA to a Specific IP Address
Moving the POA to a Different Server
Adjusting the POA for a New Post Office Location
Adjusting the POA Logging Level and Other Log Settings

Section 36.2, “Configuring 
User Access to the Post 
Office,” on page 486

Using Client/Server Access to the Post Office
Simplifying Client/Server Access with a GroupWise Name Server
Supporting IMAP Clients
Supporting SOAP Clients
Supporting CAP Clients
Checking What GroupWise Clients Are in Use
Supporting Forced Mailbox Caching
Restricting Message Size between Post Offices

Section 36.3, “Configuring 
Post Office Security,” on 
page 496

Securing Client/Server Access through a Proxy Server
Securing the Post Office with SSL Connections to the POA
Providing LDAP Authentication for GroupWise Users
Enabling Intruder Detection
Configuring Trusted Application Support

Section 36.4, “Configuring 
Post Office Maintenance,” on 
page 507

Scheduling Database Maintenance
Scheduling Disk Space Management
Performing Nightly User Upkeep
Configuring the POA 475
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Section 36.1.3, “Changing the Link Protocol between the Post Office and the Domain,” on 
page 481
Section 36.1.4, “Binding the POA to a Specific IP Address,” on page 483
Section 36.1.5, “Moving the POA to a Different Server,” on page 484
Section 36.1.6, “Adjusting the POA for a New Post Office Location,” on page 484
Section 36.1.7, “Adjusting the POA Logging Level and Other Log Settings,” on page 485

36.1.1  Creating a POA Object in eDirectory
When you create a new post office, one POA object is automatically created for it. You can set up 
additional POAs for an existing post office if message traffic in the post office is heavy. To 
accomplish this, you must create additional POA objects as well.

To create a new POA object in Novell® eDirectory:

1 In ConsoleOne, browse to and right-click the Post Office object for which you want to create a 
new POA object, then click New > Object.

2 Double-click GroupWise Agent to display the Create GroupWise Agent dialog box.

3 Type a unique name for the new POA. The name can include as many as 8 characters. Do not 
use any of the following invalid characters in the name: 

You use this name with the /name startup switch when you start the new POA.
The Type field is automatically set to Post Office.

4 Select Define Additional Properties.
5 Click OK.

The POA object is automatically placed within the Post Office object.
6 Review the information displayed for the first four fields on the Identification page to ensure 

that you are creating the correct type of Agent object in the correct location.

ASCII characters 0-13 Comma ,

Asterisk * Double quote "

At sign @ Extended ASCII characters that are graphical or typographical symbols; 
accented characters in the extended range can be used

Braces { } Parentheses ( )

Colon : Period .
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7 In the Description field, type one or more lines of text describing the POA.
This description displays on the POA server console as the POA runs. When you run multiple 
POAs on the same server, the description should uniquely identify each one. If multiple 
administrators work at the server where the POA runs, the description could include a note 
about who to contact before stopping the POA.

8 In the Platform field, select the platform (NetWare, Linux, or Windows) where the POA will 
run.

9 Continue with Section 36.1.2, “Configuring the POA in ConsoleOne,” on page 477.

36.1.2  Configuring the POA in ConsoleOne
The advantage to configuring the POA in ConsoleOne, as opposed to using startup switches in a 
POA startup file, is that the POA configuration settings are stored in eDirectory.

1 In ConsoleOne, expand the eDirectory container where the Post Office object is located.
2 Expand the Post Office object.
3 Right-click the POA object, then click Properties.

The table below summarizes the POA configuration settings in the POA object properties pages and 
how they correspond to POA startup switches (as described in Chapter 39, “Using POA Startup 
Switches,” on page 565). The table also includes settings on the Post Office object that correspond 
to POA startup switches. 

Table 36-2   POA Configuration Settings

ConsoleOne Properties Pages 
and Settings Corresponding Tasks and Startup Switches

POA Identification Page 
Configuring the POA 477
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Domain.PO
Distinguished Name
Name
Agent Type
Description
Platform

See Section 36.1.1, “Creating a POA Object in eDirectory,” on 
page 476.

POA Agent Settings Page 

Message File Processing See Section 38.2.2, “Configuring a Dedicated Message File Processing 
POA,” on page 553. 
See also /nomf, /nomfhigh, and /nomflow.

Message Handler Threads See Section 38.2.1, “Adjusting the Number of POA Threads for 
Message File Processing,” on page 552. 
See also /threads.

Enable TCP/IP (for C/S) See Section 36.2.1, “Using Client/Server Access to the Post Office,” on 
page 486 and Section 38.1.3, “Configuring a Dedicated Client/Server 
POA,” on page 550. 
See also /notcpip.

TCP Handler Threads See Section 38.1.2, “Adjusting the Number of Connections for Client/
Server Processing,” on page 549. 
See also /tcpthreads.

Max Physical Connections
Max Application Connections

See Section 38.1.2, “Adjusting the Number of Connections for Client/
Server Processing,” on page 549. 
See also /maxphysconns and /maxappconns.

Enable Caching See /nocache.

CPU Utilization (NLM)

Delay Time (NLM)

See Section 38.5, “Optimizing CPU Utilization for the NetWare POA,” on 
page 562. 
See also /cpu and /sleep.

Max Thread Usage for Priming 
and Moves

See Section 36.2.7, “Supporting Forced Mailbox Caching,” on 
page 494.
See also /primingmax.

Enable IMAP
Max IMAP Threads

See Section 36.2.3, “Supporting IMAP Clients,” on page 490.
See also /imap and /imapmaxthreads.

Enable SOAP
Max SOAP Threads

See Section 36.2.4, “Supporting SOAP Clients,” on page 491.
See also /soap and /soapmaxthreads.

Enable SNMP
SNMP Community "Get"

String

See Section 37.6, “Using an SNMP Management Console,” on 
page 540.
See also /nosnmp.

Disable Administration 
 Task Processing

See /noada.

HTTP User Name
HTTP Password

See Section 37.2.1, “Setting Up the POA Web Console,” on page 531.
See also /httpuser and /httppassword.

Network Address Page 

ConsoleOne Properties Pages 
and Settings Corresponding Tasks and Startup Switches
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TCP/IP Address
IPX/SPX Address

See Section 36.2.1, “Using Client/Server Access to the Post Office,” on 
page 486 and Section , “Using TCP/IP Links between the Post Office 
and the Domain,” on page 481.
See also /ip.

Proxy Server Address See Section 36.3.1, “Securing Client/Server Access through a Proxy 
Server,” on page 496.

Bind Exclusively to 
 TCP/IP Address

See Section 36.1.4, “Binding the POA to a Specific IP Address,” on 
page 483
See also /ip.

Message Transfer See Section , “Using TCP/IP Links between the Post Office and the 
Domain,” on page 481.
See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, /
mtpsendmax, and /mtpssl.

HTTP See Section 37.2.1, “Setting Up the POA Web Console,” on page 531.
See also /httpport and /httpssl.

Local Intranet Client/Server
Internet Proxy Client/Server

See Section 36.2.1, “Using Client/Server Access to the Post Office,” on 
page 486 and Section , “Using TCP/IP Links between the Post Office 
and the Domain,” on page 481. 
See also /port, /internalclientssl, and /externalclientssl.

IMAP See Section 36.2.3, “Supporting IMAP Clients,” on page 490.
See also /imapport, /imapssl, and /imapsslport.

SOAP See Section 36.2.4, “Supporting SOAP Clients,” on page 491.
See also /soapport and /soapssl.

QuickFinder Page 

Enable QuickFinder Indexing
Start QuickFinder Indexing
QuickFinder Interval

See Section 38.3.1, “Regulating Indexing,” on page 555 and 
Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556. 
See also /qfbaseoffset, /qfbaseoffsetinminute, /qfinterval, /
qfintervalinminute, and /noqf.

Maintenance Page 

Enable Auto DB Recovery See /norecover.

Maintenance Handler
Threads

See Section 38.4.1, “Adjusting the Number of POA Threads for 
Database Maintenance,” on page 559.
See also /gwchkthreads and /nogwchk.

Perform User Upkeep
Start User Upkeep
Generate Address Book for 

Remote
Start Address Book 

Generation

See Section 36.4.3, “Performing Nightly User Upkeep,” on page 513. 
See also /nuuoffset, /nonuu, /rdaboffset, and /nordab.

Disk Check Interval
Disk Check Delay

See Section 36.4.2, “Scheduling Disk Space Management,” on 
page 510.

POA Log Settings Page 

ConsoleOne Properties Pages 
and Settings Corresponding Tasks and Startup Switches
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After you install the POA software, you can further configure the POA using a startup file. See 
Chapter 39, “Using POA Startup Switches,” on page 565 to survey the many ways the POA can be 
configured.

Log File Path
Logging Level
Max Log File Age
Max Log Disk Space

See Section 37.3, “Using POA Log Files,” on page 538. 
See also /log, /logdays, /logdiskoff, /loglevel, and /logmax.

POA Scheduled Events 
Page 

Disk Check Event See Section 36.4.2, “Scheduling Disk Space Management,” on 
page 510.

Mailbox/Library Maintenance 
Event

See Section 36.4.1, “Scheduling Database Maintenance,” on page 507.

POA SSL Settings Page 

Certificate File
SSL Key File
Password

See Section 36.3.3, “Securing the Post Office with SSL Connections to 
the POA,” on page 498.
See also /certfile, /keyfile, /keypassword.

Post Office Settings Page 

Remote User Name
Remote Password

See /user and /password.

Post Office Client Access 
Settings Page 

Lock Out Older GroupWise
Clients

Minimum Client Release
Version

Minimum Client Release Date

See Section 36.2.6, “Checking What GroupWise Clients Are in Use,” on 
page 492.
See also /gwclientreleasedate, /gwclientreleaseversion, and /
enforceclientversion.

Enable Intruder Detection
Incorrect Logins Allowed
Incorrect Login Reset Time
Lockout Reset Time

See Section 36.3.5, “Enabling Intruder Detection,” on page 506.
See also /intruderlockout, /incorrectloginattempts, /
attemptsresetinterval, and /lockoutresetinterval.

Post Office Security Page 

LDAP Authentication See Section 36.3.4, “Providing LDAP Authentication for GroupWise 
Users,” on page 501. 
See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /
ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, /ldapsslkey,/
ldaptimeout, and /noldapx. 
See also /ldapippooln, /ldappoolresettime, /ldapportpooln, /ldapsslpooln, 
and /ldapsslkeypooln

ConsoleOne Properties Pages 
and Settings Corresponding Tasks and Startup Switches
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36.1.3  Changing the Link Protocol between the Post Office and 
the Domain
How messages are transferred between the POA and the MTA is determined by the link protocol in 
use between the post office and the domain. For a review of link protocols, see Section 10.1.3, “Link 
Protocols for Direct Links,” on page 141.

If you need to change from one link protocol to another, some reconfiguration of the POA and its 
link to the domain is necessary.

“Using TCP/IP Links between the Post Office and the Domain” on page 481
“Using Mapped or UNC Links between the Post Office and the Domain” on page 483

NOTE: The Linux POA requires TCP/IP links between the post office and the domain.

Using TCP/IP Links between the Post Office and the Domain

To change from a mapped or UNC link to a TCP/IP link between a post office and its domain, you 
must perform the following two tasks:

“Configuring the Agents for TCP/IP” on page 481
“Changing the Link between the Post Office and the Domain to TCP/IP” on page 482

Configuring the Agents for TCP/IP

1 If the MTA in the domain is not yet set up for TCP/IP communication, follow the instructions 
in “Configuring the MTA for TCP/IP” on page 618.

2 To make sure the POA is properly set up for TCP/IP communication, follow the instructions in 
Section 36.2.1, “Using Client/Server Access to the Post Office,” on page 486.
Only one POA per post office needs to communicate with the MTA. If the post office has 
multiple POAs, have a POA that performs message file processing communicate with the MTA 
for best performance. For information about message file processing, see Section 35.5, “Role 
of the Post Office Agent,” on page 469. 

3 In ConsoleOne, browse to and right-click the POA object, then click Properties.
4 Click GroupWise > Network Address to display the Network Address page.
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5 In the Message Transfer field, specify the TCP port on which the POA will listen for incoming 
messages from the MTA.
The default message transfer port for the POA to listen on is 7101.

6 Click OK to save the TCP/IP information and return to the main ConsoleOne window. 

Corresponding Startup Switches 
You can also use the /mtpinipaddr and /mtpinport startup switches in the POA startup file to set the 
incoming IP address and port.

Changing the Link between the Post Office and the Domain to TCP/IP

1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration. 
2 In the drop-down list, select the domain where the post office resides.
3 Click Post Office Links, then double-click the post office for which you want to change the link 

protocol.
4 In the Protocol field, select TCP/IP.

5 Make sure the information displayed in the Edit Post Office Link dialog box matches the 
information on the Network Address page for the POA.

6 Click OK.
7 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.
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ConsoleOne then notifies the POA and MTA to restart using the new link protocol. 

For a sample message flow for this configuration, see “TCP/IP Link Open: Transfer between Post 
Offices Successful” in “Message Delivery to a Different Post Office” in GroupWise 7 
Troubleshooting 3: Message Flow and Directory Structure.

Corresponding Startup Switches 
You can also use the /mtpoutipaddr and /mtpoutport startup switches in the POA startup file to set 
the outgoing IP address and port.

Using Mapped or UNC Links between the Post Office and the Domain

To change from a TCP/IP link to a mapped or UNC link between a post office and its domain:

1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration.
2 In the drop-down list, select the domain where the post office resides.
3 Click Post Office Links, then double-click the post office for which you want to change the link 

protocol.
4 In the Protocol field, select Mapped or UNC. 
5 Provide the location of the post office in the format appropriate to the selected protocol.
6 Click OK.
7 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.

ConsoleOne then notifies the POA and MTA to restart using the new link protocol. 

36.1.4  Binding the POA to a Specific IP Address
You can now cause the POA to bind to a specified IP address when the server where it runs uses 
multiple IP addresses. The specified IP address is associated with all ports used by the agent. 
Without an exclusive bind, the POA binds to all IP addresses available on the server. 

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.
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3 Select Bind Exclusively to TCP/IP Address, then click OK to save your change.

Corresponding Startup Switches 
You can also use the /ip and /mtpoutport startup switch in the POA startup file to establish an 
exclusive bind to the specified IP address.

36.1.5  Moving the POA to a Different Server
As your GroupWise system grows and evolves, you might need to move a POA from one server to 
another. For example, you might decide to run the POA on a different platform, or perhaps you want 
to move it to a server that has more memory.

1 When moving the POA, pay special attention to the following details:
For a POA configured for client/server processing, reconfigure the POA object with the 
new IP address and port number for the POA to use on the new server. See Section 36.2.1, 
“Using Client/Server Access to the Post Office,” on page 486. 
For the NetWare POA, if it was originally on the same server where the post office is 
located and you are moving it to a different server, add the /dn switch or the /user and /
password switches to the POA startup file to give the NetWare POA access to the server 
where the post office is located. You can also provide user and password information on 
the Post Office Settings page.

2 Install the POA on the new server, as described in “Installing GroupWise Agents” in the 
GroupWise 7 Installation Guide.

3 Start the new POA, as described in the following sections in the GroupWise 7 Installation 
Guide:

“Starting the NetWare GroupWise Agents”
“Starting the Linux Agents with a User Interface”
“Starting the Windows GroupWise Agents”

4 Observe the new POA to see that it is running smoothly, as described in Chapter 37, 
“Monitoring the POA,” on page 515. 

5 Stop the old POA.
6 If you are no longer using the old server for any GroupWise agents, you can remove them to 

reclaim the disk space, as described in the following sections in the GroupWise 7 Installation 
Guide: 

“Uninstalling the NetWare GroupWise Agents”
“Uninstalling the Linux GroupWise Agents”
“Uninstalling the Windows GroupWise Agents”

36.1.6  Adjusting the POA for a New Post Office Location
If you move a post office from one server to another, you also need to edit the POA startup file to 
provide the new location of the post office directory.

1 Stop the POA for the old post office location if it is still running.
2 Use an ASCII text editor to edit the POA startup file.

The POA startup file is named after the post office name, plus a .poa extension. 
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3 Adjust the setting of the /home switch to point to the new location of the post office directory.
4 Save the POA startup file.
5 Start the POA for the new post office location, as described in the following sections in the 

GroupWise 7 Installation Guide:
“Starting the NetWare GroupWise Agents”
“Starting the Linux Agents with a User Interface”
“Starting the Windows GroupWise Agents”

6 Adjust the link between the post office and the domain. See Section 41.1.7, “Adjusting the 
MTA for a New Location of a Domain or Post Office,” on page 626. 

36.1.7  Adjusting the POA Logging Level and Other Log 
Settings
When installing or troubleshooting the POA, a logging level of Verbose can be useful. However, 
when the POA is running smoothly, you can set the logging level down to Normal to conserve disk 
space occupied by log files. 

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Log Settings to display the Log Settings page.

3 Set the desired settings for logging. 

NetWare 
and 
Windows:

Only the first 8 characters of the post office name are used in the filename. The 
startup file is typically located in the directory where the POA software is installed.

Linux: The full post office name is used in the filename. However, all letters are lowercase 
and any spaces in the post office name are removed. The startup file is located in the 
/opt/novell/groupwise/agents/share directory.
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For more information about log settings and log files, see Section 37.3, “Using POA Log 
Files,” on page 538.

Corresponding Startup Switches
 You can also use the /log, /loglevel, /logdays, /logmax, and /logdiskoff switches in the POA startup 
file to configure logging.

POA Web Console 
You can view and search POA log files on the Log Files page.

36.2  Configuring User Access to the Post Office
As described in Section 35.4, “Post Office Access Mode,” on page 468, the GroupWise 6.x client 
defaults to client/server access mode. The following topics help you configure the POA to customize 
the types of client/server access provided to the post office:

Section 36.2.1, “Using Client/Server Access to the Post Office,” on page 486
Section 36.2.2, “Simplifying Client/Server Access with a GroupWise Name Server,” on 
page 488
Section 36.2.3, “Supporting IMAP Clients,” on page 490
Section 36.2.4, “Supporting SOAP Clients,” on page 491
Section 36.2.5, “Supporting CAP Clients,” on page 492
Section 36.2.6, “Checking What GroupWise Clients Are in Use,” on page 492
Section 36.2.7, “Supporting Forced Mailbox Caching,” on page 494
Section 36.2.8, “Restricting Message Size between Post Offices,” on page 495

36.2.1  Using Client/Server Access to the Post Office
To make sure the GroupWise client has proper client/server access to the post office:

1 Make sure TCP/IP is properly set up on the server where the POA is running.
2 In ConsoleOne, browse to and right-click the POA object, then click Properties.
3 Click GroupWise > Agent Settings to display the Agent Settings page.
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4 Make sure that Enable TCP/IP (for Client/Server) is selected. 
The default numbers of physical connections and application connections are appropriate for a 
post office with as many as 500 users. If you are configuring the POA to service more than 500 
users, see Section 38.1.2, “Adjusting the Number of Connections for Client/Server 
Processing,” on page 549 for more detailed recommendations. Configuring the POA with 
insufficient connections can result in error conditions.

5 Click GroupWise > Network Address.

6 On the Network Address page, click the pencil icon for the TCP/IP Address field to display the 
Edit Network Address dialog box.
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7 Select IP Address, then specify the IP address, in dotted decimal format, of the server where the 
POA is running.
or
Select DNS Host Name, then provide the DNS hostname of the server where the POA is 
running.

IMPORTANT: The POA must run on a server that has a static IP address. DHCP cannot be 
used to dynamically assign an IP address for it.

Specifying the DNS hostname rather than the IP address makes it easier to move the POA from 
one server to another, should the need arise at a later time. You can assign a new IP address to 
the hostname in DNS, without needing to change the POA configuration information in 
ConsoleOne.

8 Click OK.
9 To use a TCP port number other than the default port of 1677, type the port number in the Local 

Intranet Client/Server Port field.
If multiple POAs will run on the same server, each POA must have a unique TCP port number.

10 For optimum security, select Required in the SSL drop-down list for local intranet client/server 
connections, Internet client/server connections, or both. For more information, see 
Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on page 498.

11 Click OK to save the network address and port information and return to the main ConsoleOne 
window.
ConsoleOne then notifies the POA to restart with client/server processing enabled.

For a sample message flow for this configuration, see “Message Delivery in the Local Post Office” 
in GroupWise 7 Troubleshooting 3: Message Flow and Directory Structure. 

Corresponding Startup Switches
 You can also use the /port switch in the POA startup file to provide the client/server port number. 
On a server with multiple IP addresses, you can use the /ip switch to bind the POA to a specific 
address.

POA Web Console
 You can view the TCP/IP address and port information for the POA on the Configuration page 
under the Client/Server Settings heading.

36.2.2  Simplifying Client/Server Access with a GroupWise 
Name Server
If GroupWise users are set up correctly in eDirectory, the GroupWise client can determine which 
post office to access for each user based on the information stored in eDirectory. This lets the 
GroupWise client start automatically in client/server mode without users needing to know and 
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provide any IP address information. However, some GroupWise users might be on platforms where 
eDirectory is not in use. To fill the same function for non-eDirectory users, you can set up a 
GroupWise name server.

A GroupWise name server redirects each GroupWise client user to the IP address and port number 
of the POA that services the user’s post office. By setting up a GroupWise name server, non-
eDirectory GroupWise client users do not need to know and provide any IP address information 
when they start the GroupWise client in client/server mode. The GroupWise name server takes care 
of this for them.

“Required Hostnames” on page 489
“Required Port Number” on page 489
“How a GroupWise Name Server Helps the GroupWise Client Start” on page 489
“Setting Up a GroupWise Name Server” on page 489

Required Hostnames

The primary GroupWise name server must be designated using the hostname ngwnameserver. You 
can also designate a backup GroupWise name server using the hostname ngwnameserver2.

Required Port Number

Each server designated as a GroupWise name server must have a POA running on it that uses the 
default port number of 1677. Other agents can run on the same server, but one POA must use the 
default port number of 1677 in order for the GroupWise name server to function. For setup 
instructions, see Section 36.2.1, “Using Client/Server Access to the Post Office,” on page 486.

How a GroupWise Name Server Helps the GroupWise Client Start

After a server has been designated as ngwnameserver, and a POA using the default port number of 
1677 is running on that server, the GroupWise client can connect to the POA of the appropriate post 
office by contacting the POA located on ngwnameserver. If ngwnameserver is not available, the 
client next attempts to contact the backup name server, ngwnameserver2. If no GroupWise name 
server is available, the user must provide the IP address and port number of the appropriate POA in 
order to start the GroupWise client in client/server mode.

Setting Up a GroupWise Name Server

1 Make sure that TCP/IP is set up and functioning on your network.
2 Know the IP address of the server you want to set up as a GroupWise name server. 
3 Make sure the POA on that server uses the default TCP port of 1677.
4 If you want a backup GroupWise name server, identify the IP address of a second server where 

the POA uses the default TCP port of 1677.
5 Use your tool of choice for modifying DNS.

NetWare: You can use INETCFG.

Linux: You can use the YaST Control Center.

Windows: You can use DNS Manager.
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6 Create an entry for the IP address of the first POA and give it the hostname ngwnameserver.
7 If you want a backup name server, create an entry for the IP address of the second 

POA and give it the hostname ngwnameserver2. 
You must use the hostnames ngwnameserver and ngwnameserver2. Any other hostnames are 
not recognized as GroupWise name servers. 

8 Save your changes. 

As soon as the hostname information replicates throughout your system, GroupWise client users can 
start the GroupWise client in client/server mode without specifying a TCP/IP address and port 
number. 

36.2.3  Supporting IMAP Clients
You can configure the POA so that IMAP (Internet Messaging Application Protocol) clients such as 
Netscape Mail, Eudora Pro, Microsoft Outlook, and Entourage* can connect to the post office much 
like the GroupWise client does.

NOTE: IMAP clients connecting to your GroupWise system from outside your firewall must 
connect through the Internet Agent, as described in Section 46.3, “Configuring POP3/IMAP4 
Services,” on page 739, rather than through the POA. Connecting directly through the POA provides 
faster access for internal IMAP clients.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties. 
2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Select Enable IMAP.
The default maximum number of IMAP threads is 40. This is adequate for most post offices, 
because each IMAP thread can service multiple IMAP clients. New threads are started 
automatically to service clients until the maximum number is reached.

4 To secure IMAP connections to the post office, click GroupWise > Network Address, then 
select Required in the IMAP SSL drop-down list. 
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For additional instructions about using SSL connections, see Chapter 71, “Encryption and 
Certificates,” on page 1117.

5 Click OK to save the IMAP settings and return to the main ConsoleOne window.
ConsoleOne then notifies the POA to restart with IMAP enabled.

Corresponding Startup Switches 
You can also use the /imap, /imapmaxthreads, /imapport, /imapssl, /imapsslport, and /imapreadlimit 
startup switches in the POA startup file to configure the POA to support IMAP clients.

POA Web Console 
You can see whether IMAP is enabled on the Configuration page under the General Settings 
heading.

36.2.4  Supporting SOAP Clients
Simple Object Access Protocol (SOAP) is used by e-mail clients such as EvolutionTM to access 
mailboxes. You can now configure the POA to communicate with SOAP-enabled e-mail clients as it 
has already been doing for IMAP e-mail clients.

1 In ConsoleOne, browse to and select the POA object to configure, then click Properties.
2 Click GroupWise > Agent Settings.

3 Fill in the following fields:
Enable SOAP: Select Enable SOAP to turn on SOAP processing.
Max SOAP Threads: Specify the maximum number of SOAP threads you want the POA to 
start. The default maximum number of SOAP threads is 20. You can set a lower SOAP thread 
maximum to conserve resources for other processes, but you cannot set the maximum above 
20. You might want to lower the maximum number of SOAP threads if SOAP processing is 
monopolizing system resources that you would prefer to have available for other processes. 
However, insufficient SOAP threads can cause slow response for SOAP client users.

4 Click Apply to save the SOAP thread settings.
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5 To secure SOAP connections to the post office, click GroupWise > Network Address, then 
select Enabled in the SSL drop-down list.
The default SOAP port is 7191 and must be unique on the server. You can change the port 
number if necessary. 
For additional instructions about using SSL connections, see Chapter 71, “Encryption and 
Certificates,” on page 1117.

6 Click OK.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Users of Evolution 2.0 and later can find instructions for connecting to a GroupWise system in the 
Evolution online help. For more information about using Evolution to access a GroupWise mailbox, 
see “Evolution” in “Non-GroupWise Clients” in the GroupWise 7 Interoperability Guide.

Corresponding Startup Switches 
You can also use the /soap, /soapmaxthreads, /soapport, /soapssl, and /soapthreads startup switches 
in the POA startup file to configure the POA to support SOAP clients. In addition, you can use the /
evocontrol startup switch to configure the POA to allow only specified versions of Evolution to 
connect to the post office.

POA Web Console 
You can see whether SOAP is enabled on the Configuration page under the General Settings 
heading.

36.2.5  Supporting CAP Clients
You can configure the POA so that CAP (Calendar Access Protocol) clients can connect to the post 
office much like the GroupWise client does. You can use the /cap, /capmaxthreads, /capport, and /
capssl startup switches in the POA startup file to configure the POA to support CAP clients.

POA Web Console 
You can see whether CAP is enabled on the Configuration page under the General Settings heading.

36.2.6  Checking What GroupWise Clients Are in Use
You can configure the POA to identify GroupWise client users who are running GroupWise clients 
that do not correspond to a specified release version and/or date. You can also force them to update 
to the specified version.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties. 
2 Click GroupWise > Client Access Settings to display the Client Access Settings page.
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3 Specify the approved GroupWise release version, if any.
Only 6.x and later versions of the client are supported for lockout.

4 Specify the approved GroupWise release date, if any
You can specify the minimum version, the minimum date, or both. If you specify both 
minimums, any user for which both minimums are not true is identified as running an older 
GroupWise client.

5 Select Lock Out Older GroupWise Clients for the version and/or date if you want to force users 
to update in order to access their GroupWise mailboxes.
If you lock out older clients, client users receive an error message and are unable to access their 
mailboxes until they upgrade their GroupWise client software to the minimum required version 
and/or date.

6 Click OK to save the GroupWise version and/or date settings.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect. 

Corresponding Startup Switches
 You can also use the /gwclientreleaseversion, /gwclientreleasedate, and /enforceclientversion 
startup switches in the POA startup file to configure the POA to check client version and/or date 
information.

POA Web Console 
On the Status page of the POA Web console, click C/S Users to display the Current Users page, 
which lists all GroupWise users who are currently accessing the post office. Users who are running 
GroupWise clients older than the approved version and/or date are highlighted in red in the list. 
Users who are running newer versions are shown in blue.

Historical Note: The capability of identifying client version and date information was first 
introduced in GroupWise 5.5 Enhancement Pack Support Pack 1. Any clients with versions and 
dates earlier than GroupWise 5.5 Enhancement Pack Support Pack 1 do not appear at all on the 
Current Users page of the POA Web console.
Configuring the POA 493



494 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
36.2.7  Supporting Forced Mailbox Caching 
GroupWise client users have the option to download their GroupWise mailboxes to their 
workstations so they can work without being continuously connected to the network. This is called 
Caching mode. For more information, see Section 64.1.2, “Caching Mode,” on page 1035.

When client users change to Caching mode, the contents of their mailboxes must be copied to their 
hard drives. This process is called “priming” the mailbox. If users individually decide to use 
Caching mode, the POA easily handles the process.

If you force all users in the post office to start using Caching mode, as described in Section , 
“Allowing or Forcing Use of Caching Mode,” on page 1036, multiple users might attempt to prime 
their mailboxes at the same time. This creates a load on the POA that can cause unacceptable 
response to other users.

To configure the POA to handle multiple requests to prime mailboxes:

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Set Max Thread Usage for Priming and Moves as needed.
By default, the POA allocates only 20% of its TCP handler threads for priming mailboxes for 
users who are using Caching mode for the first time. In a default configuration, this would be 
only one thread. You might want to specify 60 or 80 so that 60% to 80% of POA threads are 
used for priming mailboxes. You might also want to increase the number of TCP handler 
threads the POA can start in order to handle the temporarily heavy load while users are priming 
their mailboxes. See Section 38.1.2, “Adjusting the Number of Connections for Client/Server 
Processing,” on page 549.

4 Click OK to save the new setting.
ConsoleOne then notifies the POA to restart so the new setting can be put into effect. 
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Corresponding Startup Switches
 You can also use the /primingmax switch in the POA startup file to configure the POA to handle 
multiple requests to prime mailboxes.

POA Web Console 
You can change the POA’s ability to respond to caching requests for the current POA session on the 
Configuration page. Under the Client/Server Settings heading, click Max Thread Usage for Priming 
and Live Moves. To increase the number of client/server threads, click Client/Server Processing 
Threads under the Performance Settings heading.

36.2.8  Restricting Message Size between Post Offices
You can configure the POA to restrict the size of messages that users are permitted to send outside 
the post office.

1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration.

2 In the drop-down list, select the domain where the post office resides, then click Post Office 
Links.

3 Double-click the post office where you want to restrict message size.
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4 In the Maximum Send Message Size field, specify in megabytes the size of the largest message 
you want users to be able to send outside the post office, then click OK.

5 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.
ConsoleOne then notifies the POA to restart using the new maximum message size limit. 

If a user’s message is not sent out of the post office because of this restriction, the user receives an e-
mail message with a subject line of:

Delivery disallowed

plus the subject of the original message. This message provides information to the user about why 
and where the message was disallowed. However, the message is still delivered to recipients in the 
sender’s own post office.

There are additional ways to restrict the size of messages that users can send, as described in 
Section 12.3.4, “Restricting the Size of Messages That Users Can Send,” on page 185.

Corresponding Startup Switches 
You can also use the /mtpsendmax startup switch in the POA startup file to restrict message size.

POA Web Console 
You can view the maximum message size on the Configuration page. You can change the maximum 
message size for the current POA session using the Message Transfer Protocol link on the 
Configuration page.

36.3  Configuring Post Office Security
You can configure the POA in various ways to meet the security needs of the post office.

Section 36.3.1, “Securing Client/Server Access through a Proxy Server,” on page 496
Section 36.3.2, “Controlling Client Redirection Inside and Outside Your Firewall,” on 
page 498
Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on page 498
Section 36.3.4, “Providing LDAP Authentication for GroupWise Users,” on page 501
Section 36.3.5, “Enabling Intruder Detection,” on page 506
Section 36.3.6, “Configuring Trusted Application Support,” on page 507

36.3.1  Securing Client/Server Access through a Proxy Server
If the server where the POA runs is behind your firewall, you can link it to a proxy server in order to 
provide client/server access to the post office for GroupWise client users who are outside the 
firewall. You could also use generic proxy, network address translation (NAT), and port address 
translation (PAT) to achieve the same results.

If the POA is configured with both an internal IP address and a proxy (external) IP address, the POA 
returns both IP addresses to the GroupWise client when it attempts to log in. The client tries the 
internal address first, and if that does not succeed, it tries the proxy address, then it records which 
address succeeded. If the user moves from inside the firewall to outside the firewall, the client might 
fail to log in on the first attempt, but succeeds on the second attempt.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
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2 Click GroupWise > Network Address to display the POA Network Address page.

3 Make sure the POA is already configured for client/server processing as explained in 
Section 36.2.1, “Using Client/Server Access to the Post Office,” on page 486.

4 Click the pencil icon for the Proxy Server Address field to display the Edit Network Address 
dialog box.

5 Select IP Address, then specify the external IP address, in dotted decimal format, of the server 
that GroupWise client users access from outside your firewall.
Typically, this is the public IP address presented externally by your proxy server, generic proxy, 
NAT, or PAT.
or
Select DNS Host Name, then provide the DNS hostname of that server.

6 Click OK.
7 If you want to use a different port number for the proxy server than you are using for client/

server access to the POA itself, provide the port number in the Internet Proxy Client/Server 
field.

8 Click OK to save the proxy server network address and port and return to the main ConsoleOne 
window.
ConsoleOne then notifies the POA to restart and begin communicating with the proxy server.

POA Web Console 
You can list all POAs in your GroupWise system, along with their proxy server addresses. On the 
Configuration page, click IP Addresses Redirection Table under the General Settings heading.
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36.3.2  Controlling Client Redirection Inside and Outside Your 
Firewall
When a user tries to access his or her mailbox without providing the IP address of the POA for his or 
her post office, any POA or a GroupWise name server POA can redirect the request to the POA for 
the user’s post office. 

A POA that is configured with both an internal IP address and a proxy IP address automatically 
redirects internal users to internal IP addresses and external users to proxy IP addresses. However, if 
you want to control which users are redirected to which IP addresses based on other criteria than 
user location, you can configure a post office with one POA to always redirect users to internal IP 
addresses and a second POA to always redirect users to proxy IP addresses. Users are then 
redirected based on which POA IP address they provide in the GroupWise Startup dialog box when 
they start the GroupWise client to access their mailboxes.

1 Configure the initial POA for the post office with the IP address that you want for internal 
users. For instructions, see Section 36.2.1, “Using Client/Server Access to the Post Office,” on 
page 486.

Do not fill in the Proxy Server Address field on the Network Address page of the POA object.
2 Create a second POA object in the post office and give it a unique name, such as POA_PRX. 

For instructions, see Section 36.1.1, “Creating a POA Object in eDirectory,” on page 476.
3 Configure this second POA with a proxy IP address. For instructions, see Section 36.3.1, 

“Securing Client/Server Access through a Proxy Server,” on page 496.
Do not fill in the TCP/IP Address field on the Network Address page of the POA object.

4 Create a startup file for the new instance of the POA.
4a Use the /name switch to specify the name of the POA object that you created in Step 2.
4b Use the /ip switch to specify the IP address of the server where this instance of the POA 

runs.
4c Use the /port switch to specify the client/server port that this instance of the POA listens 

on. 
This information needs to be specified in the POA startup file because this information is 
not specified in ConsoleOne for this instance of the POA.

5 Start the new instance of the POA.
6 Give users that you want to be redirected to internal IP addresses the IP address you used in 

Step 1.
7 Give users that you want to be redirected to proxy IP addresses the IP address you used in 

Step 3.

36.3.3  Securing the Post Office with SSL Connections to the 
POA
Secure Sockets Layer (SSL) ensures secure communication between the POA and other programs 
by encrypting the complete communication flow between the programs. For background 
information about SSL and how to set it up on your system, see Chapter 71, “Encryption and 
Certificates,” on page 1117.

To configure the POA to use SSL:
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1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.

3 To use SSL connections between the POA and GroupWise clients located inside your firewall, 
select Enabled in the Local Intranet Client/Server SSL drop-down list to let the GroupWise 
client determine whether an SSL connection or non-SSL connection is used. (Non-SSL 
connections are still protected by native GroupWise encryption.)
or
For optimum security, select Required in the Local Intranet Client/Server SSL drop-down list if 
you want the POA to force SSL connections, so that non-SSL connections are denied. 

IMPORTANT: Clients older than GroupWise 6.5 cannot connect to the POA if SSL is 
required.

4 To use SSL connections between the POA and GroupWise clients located outside your firewall 
(for example, across the Internet), select Enabled in the Internet Client/Server SSL drop-down 
list to let the GroupWise client determine whether an SSL connection or non-SSL connection is 
used. (Non-SSL connections are still protected by native GroupWise encryption.)
or
For optimum security, select Required in the Internet Client/Server SSL drop-down list if you 
want the POA to force SSL connections, so that non-SSL connections are denied. 

IMPORTANT: Clients older than GroupWise 6.5 cannot connect to the POA if SSL is 
required.

5 To use SSL connections between the POA and IMAP clients, select Enabled in the IMAP SSL 
drop-down list to let the IMAP client determine whether an SSL connection or non-SSL 
connection is used.
or
For optimum security, select Required in the IMAP SSL drop-down list if you want the POA to 
force SSL connections, so that non-SSL connections from IMAP clients are denied. 
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6 To use SSL connections between the POA and SOAP clients, select Enabled in the SOAP SSL 
drop-down list to let the SOAP client determine whether an SSL connection or non-SSL 
connection is used.

7 To use SSL connections between the POA and its MTA, select Enabled in the Message 
Transfer SSL drop-down list.
The POA must use a TCP/IP link with the MTA in order to enable SSL for the connection. See 
“Using TCP/IP Links between the Post Office and the Domain” on page 481.
The MTA must also have SSL enabled for the connection to be secure. See Section 41.2.3, 
“Securing the Domain with SSL Connections to the MTA,” on page 629. If the MTA does not 
have SSL enabled, the POA falls back to native GroupWise encryption.

8 To use SSL connections between the POA and the POA Web console displayed in your Web 
browser, select Enabled in the HTTP SSL drop-down list.
To set up the POA Web console, see Section 37.2.1, “Setting Up the POA Web Console,” on 
page 531.

9 Click Apply to save the settings on the Network Address page.
10 Click GroupWise > SSL Settings to display the SSL Settings page.

For background information about certificate files and SSL key files, see Chapter 71, 
“Encryption and Certificates,” on page 1117.
By default, the POA looks for the certificate file and SSL key file in the same directory where 
the POA executable is located, unless you provide a full pathname.

11 In the Certificate File field, browse to and select the public certificate file provided to you by 
your CA.

12 In the SSL Key File field:
12a Browse to and select your private key file.
12b Click Set Password.
12c Provide the password that was used to encrypt the private key file when it was created.
12d Click Set Password.
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13 Click OK to save the SSL settings.
ConsoleOne then notifies the POA to restart and access the certificate and key files.

Corresponding Startup Switches
 You can also use the /certfile, /keyfile, /keypassword, /httpssl, /mtpssl, /imapssl, and /imapsslport 
switches in the POA startup file to configure the POA to use SSL.

POA Web Console 
You can view SSL information for the POA on the Status and Configuration pages. In addition, 
when you list the client/server users that are accessing the post office, SSL information is displayed 
for each user.

36.3.4  Providing LDAP Authentication for GroupWise Users
By default, GroupWise client users’ passwords are stored in GroupWise user databases, and the 
POA authenticates users to their GroupWise mailboxes by using those GroupWise passwords. For 
background information about passwords, see Chapter 70, “GroupWise Passwords,” on page 1111.

By enabling LDAP authentication for the POA, users’ password information can be retrieved from 
any network directory that supports LDAP, including eDirectory. For background information about 
LDAP, see Section 72.3, “Authenticating to GroupWise with Passwords Stored in an LDAP 
Directory,” on page 1127.

When you enable LDAP authentication, it is important to provide fast, reliable access to the LDAP 
directory because GroupWise client users cannot access their mailboxes until they have been 
authenticated. The following sections provide instructions for configuring the POA to make the 
most efficient use of the LDAP servers available on your system:

“Providing LDAP Server Configuration Information” on page 501
“Enabling LDAP Authentication for a Post Office” on page 503
“Configuring a Pool of LDAP Servers” on page 504
“Specifying Failover LDAP Servers (Non-SSL Only)” on page 505

NOTE: If multiple eDirectory trees are involved, refer to TID 10067272 in the Novell Support 
Knowledgebase (http://www.novell.com/support/supportcentral) for additional instructions.

Providing LDAP Server Configuration Information

Information about your available LDAP servers must be provided in ConsoleOne before you can 
enable LDAP authentication for users.

1 In ConsoleOne, click Tools > GroupWise System Operations > LDAP Servers to display the 
Configure LDAP Servers dialog box.
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2 Click Add to add an LDAP server and provide configuration information about it.

3 In the Name field, type the name by which you want the LDAP server to be known in your 
GroupWise system.

4 In the Description field, provide additional information about the LDAP server as needed.
5 If the LDAP server requires an SSL connection, select Use SSL, then browse to and select the 

trusted root certificate of the LDAP server. 
If you do not specify a full path, the POA looks in the following locations for the trusted root 
certificate:

For more information about the trusted root certificate, see Section 71.3, “Trusted Root 
Certificates and LDAP Authentication,” on page 1123.

6 Click the pencil icon for the LDAP Server Address field.

7 Select IP Address, then specify the IP address, in dotted decimal format, of the LDAP server.
or

NetWare: POA installation directory

Linux: /opt/novell/groupwise/agents/lib/nldap

Windows: POA installation directory
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Select DNS Host Name, then provide the DNS hostname of the LDAP server.
The default LDAP port is 389 for non-SSL connections and 636 for SSL connections.

8 If the default port number is already in use, specify a unique LDAP port number. 
9 Click OK to save the LDAP server address and port information.

10 In the User Authentication Method field, select Bind or Compare.
For a comparison of these methods, see Section 72.3, “Authenticating to GroupWise with 
Passwords Stored in an LDAP Directory,” on page 1127.

11 Click OK to save the configuration information for the LDAP server.
12 Repeat Step 2 through Step 11 for each LDAP server that you want to make available to 

GroupWise for LDAP authentication.
Providing configuration information for multiple LDAP servers creates a pool of LDAP 
servers, which provides fault tolerance and load balancing to ensure fast, reliable mailbox 
access for GroupWise users.

13 Continue with Section , “Enabling LDAP Authentication for a Post Office,” on page 503

Corresponding Startup Switches 
You can also use the /ldapipaddr, /ldapport, /ldapuserauthmethod, /ldapssl, and /ldapsslkey startup 
switches in the POA startup file to provide the LDAP server information.

Enabling LDAP Authentication for a Post Office

To configure the POA to perform LDAP authentication for the users in a post office:

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties. 
2 Click GroupWise > Security to display the Security page.

3 For Security Level, select High. 
4 In the High Security Options box, select LDAP Authentication. 
5 If you want the POA to access the LDAP server with specific rights to the LDAP directory, 

specify a username that has those rights.
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If you are using a Novell LDAP server, you can browse for an eDirectory User object. The 
information returned from eDirectory uses the following format:
cn=username,ou=orgunit,o=organization
If you are using another LDAP server, you must type the information in the format used by that 
LDAP server.
If the LDAP username for the POA requires a password, click Set Password, type the password 
twice for verification, then click Set Password.
For more information about LDAP usernames, see Section 72.3, “Authenticating to GroupWise 
with Passwords Stored in an LDAP Directory,” on page 1127.

6 If you want to prevent GroupWise users from changing their LDAP passwords by using the 
Password dialog box in the GroupWise client, select Disable LDAP Password Changing. 
This option is deselected by default, so that if users change their passwords in the GroupWise 
client through the Security Options dialog box (GroupWise Windows client > Tools > Options 
> Security) or on the Passwords page (GroupWise WebAccess client > Options > Password), 
their LDAP passwords are changed to match the new passwords provided in the GroupWise 
client. 

7 If the LDAP server is configured for bind connections, as described in “Providing LDAP 
Server Configuration Information” on page 501, specify the number of seconds the POA 
should maintain an inactive connection to the LDAP server.
The default is 30 seconds.

8 If you have only one LDAP server, click OK to save the security settings for the post office. 
You have provided all the necessary information to provide LDAP authentication for users in 
the post office.
or
If you have multiple LDAP servers and want to configure them into an LDAP server pool, click 
Apply, then continue with “Configuring a Pool of LDAP Servers” on page 504.
or
If you have multiple LDAP servers and want to configure them for failover, click OK to save 
the security settings for the post office, then continue with “Specifying Failover LDAP Servers 
(Non-SSL Only)” on page 505.

Corresponding Startup Switches 
You can also use the /ldapuser, /ldappwd, /ldapdisablepwdchg, and /ldaptimeout startup switches in 
the POA startup file to configure POA access to the LDAP server. By default, the POA looks up 
users’ distinguished names in eDirectory. On NetWare, you can use the /noldapx startup switch to 
have the POA look up users by their e-mail addresses instead of by their distinguished names.

POA Web Console 
You can see if LDAP is enabled on the Configuration page. Under the General Settings heading, 
click LDAP Authentication to view LDAP settings and change some of them for the current POA 
session. 

Configuring a Pool of LDAP Servers

You can configure the POA to contact a different LDAP server each time it needs to access the 
LDAP directory. This provides load balancing and fault tolerance because each LDAP server in the 
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pool is contacted equally often by the POA. The LDAP server pool can include as many as five 
servers.

1 Make sure you have enabled LDAP Authentication as described in “Enabling LDAP 
Authentication for a Post Office” on page 503.

2 In the LDAP Pool Server Reset Timeout field, specify the number of minutes the POA should 
wait before trying to contact an LDAP server in the pool that failed to respond to the previous 
contact.
The default is 5 minutes.

3 Click Select Servers to define the specific pool of LDAP servers that you want to be available 
to users in this post office for LDAP authentication.

4 Select one or more LDAP servers in the Available Servers list, then click the arrow button to 
move them into the Selected Servers list.

5 Click OK to save the list of LDAP servers.
6 Click OK to save the security settings for the post office.

ConsoleOne then notifies the POA to restart so the new LDAP settings can be put into effect. 

Corresponding Startup Switches 
You can also use the /ldapippooln and /ldappoolresettime startup switches in the POA startup file to 
configure the LDAP server pool and the timeout interval. If you choose to configure the LDAP 
server pool in the startup file rather than in ConsoleOne, additional switches must be provided to 
complete the configuration (/ldapportpooln, /ldapsslpooln, and /ldapsslkeypooln). Configuring the 
pool in ConsoleOne is the recommended approach.

If you previously set up LDAP authentication on the post office Security page in ConsoleOne and 
then you add the pooling startup switches to the POA startup file, the pooling switches override any 
LDAP information provided in ConsoleOne.

Specifying Failover LDAP Servers (Non-SSL Only)

If the POA does not need to use an SSL connection to your LDAP servers, you can use the /
ldapipaddr switch to list multiple LDAP servers. Then, if the primary LDAP server fails to respond, 
the POA tries the next LDAP server in the list, and so on until it is able to access the LDAP 
directory. This provides failover LDAP servers for the primary LDAP server but does not provide 
load balancing, because the primary LDAP server is always contacted first.

1 Make sure you have provided the basic LDAP information on the post office Security page in 
ConsoleOne, as described in “Enabling LDAP Authentication for a Post Office” on page 503.

2 Edit the POA startup file (post_office.poa) with an ASCII text editor.
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For more information about the POA startup file, see Chapter 39, “Using POA Startup 
Switches,” on page 565.

3 Use the /ldapipaddr startup switch to list addresses for multiple LDAP servers. Use a space 
between addresses.
For example:
/ldapipaddr-172.16.5.18 172.16.15.19 172.16.5.20

IMPORTANT: Do not include any LDAP servers that require an SSL connection. There is 
currently no way to specify multiple SSL key files unless you are using pooled LDAP servers, 
as described in “Configuring a Pool of LDAP Servers” on page 504.

4 Save the POA startup file, then exit the text editor.
5 Stop the POA, then start the POA so that it reads the updated startup file.

36.3.5  Enabling Intruder Detection
You can configure the POA to detect system break-in attempts in the form of repeated unsuccessful 
logins. This feature can be especially helpful when allowing Remote client users to establish client/
server connections to MTAs in your system. See Section 41.2.2, “Enabling Live Remote,” on 
page 629.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties. 
2 Click GroupWise > Client Access Settings to display the Client Access Settings page.

3 Select Enable Intruder Detection.
4 Specify how many unsuccessful login attempts are allowed before the user is locked out.

The default is 5: valid values range from 3 to 10.
5 Specify in minutes how long unsuccessful login attempts are counted.

The default is 15; valid values range from 15 to 60.
6 Specify in minutes how long the user login is disabled.
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The default is 30; the minimum setting is 15.
7 Click OK to save the intruder detection settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect. 

If a user gets locked out by intruder detection, his or her GroupWise account is disabled. To restore 
access for the user in ConsoleOne, right-click the User object, click GroupWise > Account, then 
deselect Disable Logins. At restore access for the user at the POA Web console, click Configuration 
> Intruder Detection, then clear the lockout. 

Corresponding Startup Switches 
You can also use the /intruderlockout, /incorrectloginattempts, /attemptsresetinterval, and /
lockoutresetinterval startup switches in the POA startup file to configure the POA for intruder 
detection.

POA Web Console 
You can view current intruder detection settings on the Configuration page and change them using 
the Intruder Detection link.

36.3.6  Configuring Trusted Application Support
For background information about setting up trusted applications in ConsoleOne, see Section 4.12, 
“Trusted Applications,” on page 69.

36.4  Configuring Post Office Maintenance
You can configure the POA to manage databases and disk space in the post office on a regular basis:

Section 36.4.1, “Scheduling Database Maintenance,” on page 507
Section 36.4.2, “Scheduling Disk Space Management,” on page 510
Section 36.4.3, “Performing Nightly User Upkeep,” on page 513

36.4.1  Scheduling Database Maintenance
By default, the POA performs one recurring database maintenance event. At 12:00 a.m. each Friday, 
the POA performs a structural check of all user, message, and document databases in the post office. 
You can modify this default database maintenance event, or create additional database maintenance 
events for the POA to perform on a regular basis.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Scheduled Events to display the Scheduled Events page.
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The Scheduled Events page lists a pool of POA events available to all POAs in your 
GroupWise system.

3 To modify the default database maintenance event, which affects all POAs that have this 
database maintenance event enabled, select Default POA Mailbox/Library Maintenance Event, 
then click Edit. 
or
To create a new database maintenance event, which is added to the pool of POA events that can 
be enabled for any POA in your GroupWise system, click Create, then type a name for the new 
database maintenance event. Select Mailbox/Library Maintenance in the Type field.

NOTE: If the Create button is dimmed and you have a View button rather than an Edit button, 
you are connected to a secondary domain in a GroupWise system where Restrict System 
Operations to Primary Domain has been selected under System Preferences. For more 
information, see Section 4.2, “System Preferences,” on page 53.
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4 In the Trigger box, specify when you want the database maintenance event to take place.
You can have the database maintenance event take place once a week, once a day, or at any 
other regular interval, at whatever time you choose.
Below the Trigger box is listed the pool of POA database maintenance actions that are 
available for inclusion in all POA database maintenance events in your GroupWise system.

5 To modify the default database maintenance action, select Default POA Mailbox/Library 
Maintenance Actions, then click Edit. 
or
To create a new database maintenance action, click Create, then type a name for the new 
database maintenance action.
Database maintenance actions and options you can schedule include: 

For more detailed descriptions of the above actions, click Help in the Scheduled Event Actions 
dialog box. See also Chapter 27, “Maintaining User/Resource and Message Databases,” on 
page 385 and Chapter 28, “Maintaining Library Databases and Documents,” on page 391.

6 Select and configure the database maintenance action to perform for the database maintenance 
event.

7 Click OK three times to close the various scheduled event dialog boxes and save the modified 
database maintenance event.
ConsoleOne then notifies the POA to restart so the new or modified database maintenance 
event can be put into effect.

POA Web Console 
You can see what database maintenance events the POA is scheduled to perform at the bottom of the 
Configuration page.

Actions Options on Actions

Analyze/Fix Databases 

Structure
Index check
Contents
Collect statistics
Fix problems
Reset user disk space totals

Analyze/Fix Library 

Verify library
Fix document/version/element
Verify document files
Validate security
Synchronize username
Reassign orphaned documents
Reset word lists

Databases 

User
Message
Document

Logging 

Log file
Verbose log level

Results mailed to 

Administrator
Individual users

Exclude 

Selected users

Notification 

Action status
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36.4.2  Scheduling Disk Space Management
By default, the POA performs one recurring disk space management event. Every 5 minutes, the 
POA checks to make sure there is at least 100 MB of free disk space in the post office directory. If 
there is ever less than 100 MB of free disk space, the POA performs a Reduce operation on the user 
and message databases in the post office. You can modify this default disk space management event, 
or create additional disk space management events for the POA to perform on a regular basis.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Maintenance to display the POA Maintenance page.

3 To change the interval at which the selected POA checks for free disk space in its post office, 
adjust the number of minutes in the Disk Check Interval field as needed.
The default is 5 minutes, which could be much too frequent if plenty of disk space is readily 
available.
When a disk space problem is encountered, the time interval no longer applies until after the 
situation has been corrected. Instead, the POA continually checks available disk space to 
determine if it can restart message threads that have been suspended because of the low disk 
space condition.

4 To change the amount of time the POA allows to pass before notifying the administrator again 
of an already reported problem condition, adjust the number of hours in the Disk Check Delay 
field as needed.
The default is 2 hours.

5 Client Apply to save the maintenance settings.
6 Click GroupWise > Scheduled Events to display the Scheduled Events page.
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The Scheduled Events page lists a pool of POA events available to all POAs in your 
GroupWise system.

7 To modify the default disk space management event, which affects all POAs that have this disk 
space management event enabled, select Default POA Disk Check Event, then click Edit.
or
To create a new disk space management event, which is added to the pool of POA events that 
can be enabled for any POA in your GroupWise system, click Create, then type a name for the 
new disk space management event. Select Disk Check in the Type field.

NOTE: If the Create button is dimmed and you have a View button rather than an Edit button, 
you are connected to a secondary domain in a GroupWise system where Restrict System 
Operations to Primary Domain has been selected under System Preferences. For more 
information, see Section 4.2, “System Preferences,” on page 53.

8 In the Trigger box, select Percent or MB to determine whether you want the amount of 
available disk space measured by percentage or by megabytes.
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9 In the Trigger Actions At field, specify the minimum amount of available disk space you want 
to have in the post office. When the minimum amount is reached, the Disk Check actions are 
triggered

10 In the Stop Mail Processing At field, specify the minimum amount of available disk space at 
which you want the POA to stop receiving and processing messages.
Below the Trigger box is listed the pool of disk space management actions that are available for 
inclusion in all POA disk space management events in your GroupWise system.

11 To modify the action that the default disk space management event includes, select Default 
POA Disk Check Actions, then click Edit.
or
To create a new disk space management action, click Create, then type a name for the new disk 
space management action.
Disk space management actions and options you can schedule include: 

For more detailed descriptions of the above actions, click Help in the Scheduled Event Actions 
dialog box. See also Chapter 30, “Managing Database Disk Space,” on page 399.

12 Select and configure the disk space management action to perform.
13 Click OK twice to close the scheduled event dialog boxes and save the modified disk space 

management event.
ConsoleOne then notifies the POA to restart so the new or modified disk space management 
event can be put into effect.

You might want to create several disk space management events with different triggers and actions. 
For example, at 250 MB, you could mail a warning to the administrator; at 200 MB, you could have 
the POA perform a Reduce Only; at 150 MB, you could have the POA perform an Expire and 
Reduce.

Actions Options on Actions

Reduce/Expire Messages 

Reduce only
Expire and reduce
- Items older than
- Downloaded items older than
- Items larger than
- Trash older than
- Reduce mailbox to
- Reduce mailbox to limited size
Include
- Received items
- Sent items
- Calendar items
- Only backed-up items

Archive/Delete Documents 

Delete Activity Logs 

Databases 

User
Message
Document

Logging 

Log file
Verbose log level

Results 

Administrator
Individual users

Misc 

Support options

Exclude 

Selected users
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For some specific suggestions on implementing disk space management, see Section 12.3, 
“Managing Disk Space Usage in the Post Office,” on page 182.

POA Web Console 
You can view the currently scheduled disk check events on the Scheduled Events page.

36.4.3  Performing Nightly User Upkeep
To keep GroupWise users’ mailboxes and calendars up to date, the following activities must be 
performed each day:

Delete expired items from users’ mailboxes
Empty expired items from the Trash
Synchronize each user’s Frequent Contacts Address Book with the GroupWise Address Book
Synchronize user addresses in personal groups with the GroupWise Address Book, in case 
users have been moved, renamed, or deleted
Advance uncompleted tasks to the next day

The first two activities used to be performed by the GroupWise client, but to minimize user wait 
time, the client no longer deletes expired items. You can configure the POA to take care of these user 
upkeep activities once a day, at a convenient time.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Maintenance to display the POA Maintenance page.

3 Select Perform User Upkeep.
4 In the Start User Upkeep field, specify the number of hours after midnight for the POA to start 

performing user upkeep.
The default is 1 hour.

5 If you have Remote or Caching users, select Generate Address Book for Remote.
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6 Specify the number of hours after midnight for the POA to generate the daily copy of the 
system Address Book for Remote and Caching users.
The default is 0 hours (that is, at midnight).
If you want to generate the system Address Book for download more often than once a day, you 
can delete the existing wprof50.db file from the \wpcsout\ofs subdirectory of the post 
office. A new downloadable system Address Book will be automatically generated for users in 
the post office.
In addition to this feature, starting in GroupWise 7, the POA automatically tracks changes to 
the GroupWise Address Book and provides automatic synchronization, as described in 
Section 6.5, “Controlling Address Book Synchronization for Remote Client Users,” on 
page 91.

7 Click OK to save the new nightly user maintenance settings.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches 
You can also configure nightly user upkeep using startup switches in the POA startup file. By 
default, nightly user upkeep is enabled. Use the /nuuoffset and /rdaboffset switches to specify the 
start times. 

POA Web Console 
You can view the current user upkeep schedule on the Scheduled Events page.
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37Monitoring the POA

By monitoring the POA, you can determine whether or not its current configuration is meeting the 
needs of the post office it services. You have a variety of tools to help you monitor the operation of 
the POA: 

Section 37.1, “Using the POA Server Console,” on page 515
Section 37.2, “Using the POA Web Console,” on page 530
Section 37.3, “Using POA Log Files,” on page 538
Section 37.4, “Using GroupWise Monitor,” on page 539
Section 37.5, “Using Novell Remote Manager,” on page 540
Section 37.6, “Using an SNMP Management Console,” on page 540
Section 37.7, “Notifying the GroupWise Administrator,” on page 544
Section 37.8, “Using the POA Error Message Documentation,” on page 545
Section 37.9, “Employing POA Troubleshooting Techniques,” on page 545
Section 37.10, “Using Platform-Specific POA Monitoring Tools,” on page 546

37.1  Using the POA Server Console
The following topics help you monitor and control the POA from the POA server console:

Section 37.1.1, “Monitoring the POA from the POA Server Console,” on page 515
Section 37.1.2, “Controlling the POA from the POA Server Console,” on page 520

37.1.1  Monitoring the POA from the POA Server Console
The POA server console provides information, status, and message statistics about the POA to help 
you assess its current functioning.

Figure 37-1   POA Server Console
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The POA server console consists of several components:

“POA Information Box” on page 516
“POA Status Box” on page 517
“POA Statistics Box” on page 518
“POA Log Message Box” on page 518
“POA Admin Thread Status Box” on page 519

Do not exit the POA server console unless you want to stop the POA.

POA Information Box

The POA Information box identifies the POA whose POA server console you are viewing, which is 
especially helpful when multiple POAs are running on the same server.

PostOffice.Domain:  Displays the name of the post office serviced by this POA, and what domain it 
is linked to.

Description:  Displays the description provided in the Description field in the POA Identification 
page in ConsoleOne. When you run multiple POAs on the same server, the description should 
uniquely identify each one. If multiple administrators work at the server where the POA runs, the 
description could include a note about who to contact before stopping the POA.

Up Time:  Displays the length of time the POA has been running.

POA Web Console 
The Status page also displays this information.

NetWare The POA server console always displays on the NetWare® server console.

Linux: You must use the --show startup switch in order to display the Linux POA server console. 
See “Starting the Linux Agents with a User Interface” in “Installing GroupWise Agents” in 
the GroupWise 7 Installation Guide.

Windows: You can suppress the Windows POA server console by running the POA as a service. See 
“Starting the Windows GroupWise Agents” in “Installing GroupWise Agents” in the 
GroupWise 7 Installation Guide.

NetWare: At a NetWare server console, you can use Alt+Esc to change screens. In a remote 
console window, you can use Alt+F1 to select a screen to view. You can use these 
keystrokes to display the POA server console if it is not immediately visible on the 
NetWare console.

Linux: You can minimize the POA server console, but do not close it unless you want to stop the 
POA.

Windows: You can minimize the POA server console, but do not close it unless you want to stop the 
POA.
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POA Status Box

The POA Status box displays the current status of the POA and its backlog. The information 
displayed varies depending on whether the POA is processing client/server connections, message 
files, both, or neither.

Processing:  Displays a rotating bar when the POA is running. If the bar is not rotating, the POA has 
stopped. For assistance, see “Post Office Agent Problems” in GroupWise 7 Troubleshooting 2: 
Solutions to Common Problems.

Busy:  Displays the number of POA threads currently in use (busy) for client/server connections, 
message files, or both, depending on POA configuration. In a typical POA configuration, the 
number to the left of the colon is the number of busy client/server threads and the number to the 
right of the colon is the number of busy message handler threads. You can change the total number 
of threads available. See Section 38.1.2, “Adjusting the Number of Connections for Client/Server 
Processing,” on page 549 and Section 38.2.1, “Adjusting the Number of POA Threads for Message 
File Processing,” on page 552.

User Connections (for client/server processing):  Displays the number of active application 
(“virtual”) TCP/IP connections between the POA and the GroupWise® clients run by GroupWise 
users. You can change the maximum number of user connections. See Section 38.1.2, “Adjusting the 
Number of Connections for Client/Server Processing,” on page 549.

Physical Connections (for client/server processing):  Displays the number of active physical 
TCP/IP connections between the post office and the GroupWise clients run by GroupWise users. 
You can change the maximum number of physical connections. See Section 38.1.2, “Adjusting the 
Number of Connections for Client/Server Processing,” on page 549.

Priority Queues (for message file processing):  Displays the number of messages waiting in the 
high priority message queues. You can control the number of threads processing message files. See 
Section 38.2.1, “Adjusting the Number of POA Threads for Message File Processing,” on page 552.

Normal Queues (for message file processing):  Displays the number of messages waiting in the 
normal priority message queues. You can control the number of threads processing message files. 
See Section 38.2.1, “Adjusting the Number of POA Threads for Message File Processing,” on 
page 552.

File Queues (for message file processing):  Displays the total number of messages waiting in all 
message queues, when client/server information and message file information are displayed 
together.

The number of messages displayed as waiting in message queues is not an exact count. For example, 
if the POA detects numerous messages to process in the priority 4 queue (normal messages), it does 
not scan and count messages in lower priority queues. Therefore, actual counts of message files 
waiting in queues could be higher than the counts displayed in the Status box. 

For information about the various message queues in the post office, see “Post Office Directory” in 
GroupWise 7 Troubleshooting 3: Message Flow and Directory Structure. 

POA Web Console 
The Status page also displays the status information listed above. In addition, you can display 
detailed information about specific queue contents. 
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POA Statistics Box

The POA Statistics box displays statistics showing the current workload of the POA. The 
information displayed varies depending on whether the POA is processing client/server connections, 
message files, both, or neither.

C/S Requests (for client/server processing):  Displays the number of active client/server requests 
between GroupWise clients and the POA.

Requests Pending (for client/server processing):  Displays the number of client/server requests 
from GroupWise clients the POA has not yet been able to respond to. If the number is large, see 
“POA Statistics Box Shows Requests Pending” in “Post Office Agent Problems” in GroupWise 7 
Troubleshooting 2: Solutions to Common Problems.

Users Timed Out (for client/server processing):  Displays the number of GroupWise clients no 
longer communicating with the POA. If the number is large, see “POA Statistics Box Shows Users 
Timed Out” in “Post Office Agent Problems” in GroupWise 7 Troubleshooting 3: Message Flow and 
Directory Structure.

Message Files (for message file processing):  Displays the total number of messages processed by 
the POA. This includes user messages, status messages, and service requests processed by the POA.

Undeliverable (for message file processing):  Displays the number of messages that could not be 
delivered because the user was not found in that post office or because of other similar problems. 
Senders of undeliverable messages are notified. For assistance, see “Message Has Undeliverable 
Status” in “Strategies for Message Delivery Problems” in GroupWise 7 Troubleshooting 2: Solutions 
to Common Problems.

Problem Messages (for message file processing):  Displays the number of invalid message files 
that have problems not related to user error. It also displays requests the POA cannot process 
because of error conditions. For assistance, see “Message Is Dropped in the problem Directory” in 
“Strategies for Message Delivery Problems” in GroupWise 7 Troubleshooting 2: Solutions to 
Common Problems.

Users Delivered:  Displays the number of user messages delivered to recipients in the post office. A 
message with six recipients in the local post office is counted six times.

Statuses:  Displays the number of status messages delivered to recipients in the post office.

Rules Executed:  Displays the number of users’ rules executed by the POA.

POA Web Console 
The Status page also displays this information. In addition, you can display detailed information 
about client/server connections and message file processing.

POA Log Message Box

The POA Log Message box displays the same information that is being written to the POA log file. 
The amount of information displayed in the POA Log Message box depends on the current log 
settings for the POA. See Section 37.3, “Using POA Log Files,” on page 538. The information 
scrolls up automatically.

Windows Note: To stop the automatic scrolling, click Log, then deselect Auto Scroll. You can then 
use the scroll bar to browse through the contents of the log message box.
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POA Web Console 
You can view and search POA log files on the Log Files page.

Informational Messages

When you first start the POA, you typically see informational messages that list current agent 
settings, current number of threads, TCP/IP options (client/server), and scheduled events. As the 
POA runs, it continues to provide status and delivery information in the POA Log Message box.

Error Messages

If the POA encounters a problem processing a message, it displays an error message in the POA Log 
Message box. See “Post Office Agent Error Messages” in GroupWise 7 Troubleshooting 1: Error 
Messages.

POA Admin Thread Status Box

The POA admin thread updates the post office database (wphost.db) when users and/or user 
information are added, modified, or removed, and repairs it when damage is detected.

To display the POA Admin Thread Status box from the POA server console, click 
Configuration > Admin Status.

NetWare Note: Use Options (F10) > Admin Status. 

Figure 37-2   Admin Status Dialog Box

The following tasks pertain specifically to the POA admin thread:

“Suspending/Resuming the POA Admin Thread” on page 521
“Displaying POA Admin Thread Status” on page 525
“Recovering the Post Office Database Automatically or Immediately” on page 526

POA Web Console 
You can display POA admin thread status on the Configuration page. Under the General Settings 
heading, click Admin Task Processing. You can also change the admin settings for the current POA 
session.
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37.1.2  Controlling the POA from the POA Server Console
You can perform the following tasks to monitor and control the POA from the POA server console at 
the server where the POA is running:

“Stopping the POA” on page 520
“Suspending/Resuming the POA Admin Thread” on page 521
“Displaying the POA Software Date” on page 522
“Displaying Current POA Settings” on page 522
“Displaying Detailed Statistics about POA Functioning” on page 523
“Displaying Client/Server Information” on page 523
“Listing Message Queue Activity” on page 524
“Displaying Message Transfer Status” on page 524
“Restarting the MTP Thread” on page 525
“Displaying POA Admin Thread Status” on page 525
“Recovering the Post Office Database Automatically or Immediately” on page 526
“Recovering User and Message Databases Automatically” on page 527
“Updating QuickFinder Indexes” on page 527
“Compressing QuickFinder Indexes” on page 528
“Regenerating QuickFinder Indexes” on page 528
“Browsing the Current POA Log File” on page 528
“Viewing a Selected POA Log File” on page 529
“Cycling the POA Log File” on page 529
“Adjusting POA Log Settings” on page 530
“Editing the POA Startup File” on page 530
“Accessing Online Help for the POA” on page 530

Stopping the POA

You might need to stop and restart the POA for the following reasons:

Updating the agent software
Troubleshooting message flow problems
Backing up GroupWise databases
Rebuilding GroupWise databases

To stop the POA from the POA server console:

1 Click File > Exit > Yes.

NetWare: Use Exit (F7). If the POA does not respond to Exit, you can use the unload 
command to stop the POA. However, this stops all instances of the POA running on 
the server.
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2 Restart the POA, as described in the following sections in the GroupWise 7 Installation Guide:
“Starting the NetWare GroupWise Agents”
“Starting the Linux GroupWise Agents as Daemons”
“Starting the Windows GroupWise Agents”

Stopping the Linux POA When It Is Running As a Daemon

To stop the Linux POA when it is running in the background as a daemon and you started it using 
the grpwise script:

1 Make sure you are logged in as root.
2 Change to the /etc/init.d directory.
3 Enter the following command:
./grpwise stop

4 Use the following command to verify that the POA has stopped.
./grpwise status

To stop the Linux POA when it is running in the background as a daemon and you started it 
manually (not using the grpwise script):

1 Determine the process IDs (PIDs) of the POA:

ps -eaf | grep gwpoa

The PIDs for all gwpoa processes are listed.

You can also obtain this information from the Environment page of the POA Web console.
2 Kill the first POA process listed:

Syntax:
 kill PID
Example:
 kill 1483
It might take a few seconds for all POA processes to terminate.

3 Use the ps command to verify that the POA has stopped.
ps -eaf | grep gwpoa

Suspending/Resuming the POA Admin Thread

You can cause the POA to stop accessing the post office database (wphost.db) without stopping 
the POA completely. For example, you could suspend the POA admin thread while backing up the 
post office database.

To suspend the POA admin thread:

Linux: If the Linux POA does not respond to Exit, you can kill the POA process, as 
described below, but include the -9 option.

Windows: If the Windows POA does not respond to Exit, you can close the POA server console 
to stop the POA or use the Task Manager to terminate the POA task.
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1 At the POA server console, click Configuration > Admin Status.
2 Click Suspend.

NetWare Note: Use Options (F10) > Admin Status > Suspend. 

The POA admin thread no longer accesses the post office database until you resume processing.

To resume the POA admin thread:

1 At the POA server console, click Configuration > Admin Status.
2 Click Resume.

NetWare Note: Use Options (F10) > Admin Status > Resume. 

POA Web Console 
You can suspend and resume the POA admin thread from the Configuration page. Under the General 
Settings heading, click Admin Task Processing > Suspend or Resume > Submit.

Displaying the POA Software Date

It is important to keep the POA software up-to-date. You can display the date of the POA software 
from the POA server console.

1 At the server where the POA is running, display the POA server console.
2 Click Help > About POA. 

NetWare Note: To check the date of the NetWare® POA, you must list the gwpoa.nlm file in the 
agent installation directory (typically, in the sys:\system directory) or use the modules 
gwpoa.nlm command at the server console prompt.

POA Web Console 
You can check the POA software date on the Environment page.

Displaying Current POA Settings

You can list the current configuration settings of the POA at the POA server console.

1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Agent Settings. 

The configuration information displays in the log message box and is written to the log file.
NetWare Note: Use Show Configuration (F4) > Show Configuration.
If information you need scrolls out of the log message box, you can scroll back to it. See 
“Browsing the Current POA Log File” on page 528. 

For information about POA configuration settings, see Chapter 36, “Configuring the POA,” on 
page 475 and Chapter 39, “Using POA Startup Switches,” on page 565.

POA Web Console 
You can check the current POA settings on the Configuration page.
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Displaying Detailed Statistics about POA Functioning

The POA server console displays essential information about the functioning of the POA. More 
detailed information is also available.

1 At the server where the POA is running, display the POA server console.
2 Click Statistics > Misc. Statistics.

NetWare Note: This feature is not available in the NetWare POA. 
3 Review the Detailed Statistics dialog box. The following statistics are displayed and written to 

the log file for the current POA up time:
Databases rebuilt
Users deleted
Users moved
Moved messages processed
Statuses processed

POA Web Console 
You can display statistics on the Status page.

Displaying Client/Server Information

When the POA and the GroupWise clients communicate in client/server mode, you can display 
statistics to indicate the performance level of the TCP/IP communication.

1 At the server where the POA is running, display the POA server console.
2 Click Statistics > Client/Server.

NetWare Note: Use Configuration (F4) > Display Client/Server Information.
3 In the menu, click the type of statistics to display. 

The selected type of statistics for the current POA up time are listed in the message log box and 
are written to the POA log file.
If information you need scrolls out of the log message box, you can scroll back to it. See 
“Browsing the Current POA Log File” on page 528. 
All Statistics: Lists the information for General Statistics, Throughput, Physical Connections, 
and Application Connections, as described below. 
General Statistics: Lists the DNS address and IP address of the server, along with the TCP 
port for the POA, the number of messages received, sent, and aborted, and the number of 
physical and application connections active and allowed.
Show Throughput:  Lists the total number of messages processed by the POA for all users. 
Statistics are provided for the current elapsed time and as a per second average.
Clear Throughput:  Resets the current elapsed time to zero.
Physical Connections:  Lists the currently active physical connections. Physical connections 
are active TCP connections created whenever GroupWise users do something that requires 
communication and closed when the specific activities have been completed. By listing the 
physical connections, you can see what users are actively using GroupWise and how much 
throughput each user is generating. Users’ IP addresses are also listed.
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Application Connections:  Lists the currently active application connections. Every user that 
starts GroupWise has an application connection for as long as GroupWise is running, even if 
GroupWise is not actively in use at the moment. By listing the application connections, you can 
see what users have started GroupWise and how much throughput each user is generating. 
Users’ IP addresses are also listed.
Show Redirection List: Lists all POAs in your GroupWise system and indicates whether each 
is configured for TCP/IP. The list includes the IP address of each POA and the IP address of its 
proxy server outside the firewall, if applicable. This redirection information is obtained from 
the post office database (wphost.db). 
Check Redirection List: Attempts to contact each POA in your GroupWise system and 
reports the results. If a POA is listed as “Connection Failed,” see “Post Office Agent Problems” 
in GroupWise 7 Troubleshooting 2: Solutions to Common Problems. 

POA Web Console 
You can display client/server information on the Configuration page. You can list client/server users 
from the Status page using the C/S Users and Remote/Caching Users links.

Listing Message Queue Activity

The POA uses eight queues to process message files. You can view the activity in each of these 
queues. For more information about message queues, see “Post Office Directory” in GroupWise 7 
Troubleshooting 3: Message Flow and Directory Structure.

1 At the server where the POA is running, display the POA server console.
2 Click Actions > View MF Queues.

NetWare Note: Use Options (F10) > Actions > View MF Queues.
3 View the queue activity in the message log box. Use the scroll bar if necessary to scroll through 

the information. 
If information you need scrolls out of the log message box, you can scroll back to it. See 
“Browsing the Current POA Log File” on page 528. 
The information is also written to the POA log file.

You can check queue activity on the Status page. Under the Thread Status heading, click the type of 
thread to view queue activity for.

Displaying Message Transfer Status

When the POA links to the MTA by way of TCP/IP, you can view the status of the TCP/IP link from 
the POA server console.

1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Message Transfer Status.

NetWare Note: Use Options (F10) > Message Transfer Status.
3 View the following information about the TCP/IP link: 

Outbound TCP/IP Address: Displays the TCP/IP address and port where the MTA listens for 
messages from the POA.
Inbound TCP/IP Address: Displays the TCP/IP address and port where the POA listens for 
messages from the MTA. 
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Hold Directory: Displays the path to the directory where the POA stores messages if the TCP/
IP link to the MTA is closed.
Current Status: Lists the current status of the TCP/IP link.

Open: The POA and the MTA are successfully communicating by way of TCP/IP.
Closed: The POA is unable to contact the MTA by way of TCP/IP
Unavailable: The POA is not yet configured for TCP/IP communication with the MTA.
Unknown:  The POA is unable to contact the MTA in any way.

Messages Written: Displays the number of messages the POA has sent.
Message Read:  Displays the number of messages the POA has received.
Last Closure Reason: Provides an explanation for why the post office was last closed. For 
assistance resolving closure reasons, see “Post Office Agent Error Messages” in GroupWise 7 
Troubleshooting 1: Error Messages. 

POA Web Console 
You can display message transfer status on the MTP Status page.

Restarting the MTP Thread

When the POA links to the MTA by way of TCP/IP, you can restart the Message Transfer Protocol 
(MTP) thread that provides the link between the POA and the MTA.

1 At the server where the POA is running, display the POA server console.
2 Click Actions > Restart MTP.

NetWare Note: Use Options (F10) > Actions > Restart MTP.

POA Web Console 
You can restart the MTA thread from the Configuration page. Click Message Transfer Protocol > 
Restart MTP > Submit. In addition, you can control the send and receive threads separately on the 
MTP Status page. In the Send or Receive column, click the current status > Stop/Start MTP Send/
Receive > Submit.

Displaying POA Admin Thread Status

Status information for the POA admin thread is displayed in a separate dialog box, rather than on the 
main POA server console.

1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Admin Status. 

NetWare Note: Use Options (F10) > Admin Status.
The following admin status information is displayed:
Admin Message Box 
The Admin Message box provides the following information about the workload of the POA 
admin thread:
Completed: Number of administrative message successfully processed.
Errors: Number of administrative messages not processed because of errors.
In Queue: Number of administrative messages waiting in the queue to be processed.
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Send Admin Mail: Select this options to send a message to the administrator whenever a 
critical error occurs. See Section 37.7, “Notifying the GroupWise Administrator,” on page 544. 
Admin Database Box 
The Admin Database box provides the following information about the post office database 
(wphost.db): 
Status: Displays one of the following statuses:

Normal: The POA admin thread is able to access the post office database normally.
Recovering: The POA admin thread is recovering the post office database.
DB Error: The POA admin thread has detected a critical database error. The post office 
database cannot be recovered. Rebuild the post office database in ConsoleOne®. See 
Section 26.3, “Rebuilding Domain or Post Office Databases,” on page 381.
The POA admin thread does not process any more administrative messages until the 
database status has returned to Normal.
Unknown: The POA admin thread cannot determine the status of the post office database. 
Exit the POA, then restart it, checking for errors on startup.

DB Sort Language:  Displays the language code for the language that determines the sort 
order of lists displayed in ConsoleOne and the GroupWise system Address Book. 
Recovery Count:  Displays the number of recoveries performed on the post office database by 
this POA for the current POA session.
Admin Thread Box 
The Admin Thread box displays the following information:
Status: Displays one of the following statuses:

Running: The POA admin thread is active.
Suspended: The POA admin thread is not processing administrative messages.
Starting: The POA admin thread is initializing.
Terminated: The POA admin thread is not running.

POA Web Console 
You can display POA admin thread status from the Configuration page. Under the General Settings 
heading, click Admin Task Processing.

Recovering the Post Office Database Automatically or Immediately

The POA admin thread can recover the post office database (wphost.db) when it detects a 
problem.

To enable/disable automatic post office database recovery:

1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Admin Status > Automatic Recovery to toggle this feature on or off for 

the current POA session.
NetWare Note: Use Options (F10) > Admin Status > Automatic Recovery.

To change the setting permanently, see Section 36.1.2, “Configuring the POA in ConsoleOne,” on 
page 477.

To recover the post office database immediately: 
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1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Admin Status > Perform DB Recovery.

NetWare Note: Use Options (F10) > Admin Status > Perform DB Recovery.

For additional database repair procedures, see Chapter 26, “Maintaining Domain and Post Office 
Databases,” on page 377.

POA Web Console 
You can recover the post office database from the Configuration page. Under the General Settings 
heading, click Admin Task Processing. Select Automatic Recovery or Perform DB Recovery as 
needed.

Recovering User and Message Databases Automatically

The POA can recover user databases (userxxx.db) and message databases (msgnnn.db) 
automatically when it detects a problem because databases can be open during the recover process. 
This procedure is a “recover” rather than a “rebuild,” because a “rebuild” requires that all users and 
agents are out of the database being rebuilt. See Chapter 27, “Maintaining User/Resource and 
Message Databases,” on page 385.

To enable/disable automatic message and user database recovery:

1 At the server where the POA is running, display the POA server console.
2 Click Actions > Auto Rebuild to toggle this feature on or off for the current POA session. 

NetWare Note: Use Options (F4) > Actions > Enable Auto Rebuild.

To change the setting permanently, see Section 36.1.2, “Configuring the POA in ConsoleOne,” on 
page 477.

POA Web Console 
You can see whether automatic message and user database recovery is enabled on the Configuration 
page under the Performance Settings heading.

Updating QuickFinder Indexes

GroupWise uses QuickFinderTM technology to index messages and documents stored in post offices. 
You can start indexing from the POA server console. For example, if you just imported a large 
number of documents, you could start indexing immediately, rather than waiting for the next 
scheduled indexing cycle. 

To update QuickFinder indexes for the post office:

1 At the server where the POA is running, display the POA server console.
2 Click Actions > QuickFinder > Update Indexes.

NetWare Note: Use Options (F10) > Actions > Update QuickFinder Indexes.

To avoid overloading the POA with indexing processing, a maximum of 1000 items are indexed per 
database. If a very large number of messages are received regularly, or if a user with a very large 
mailbox is moved to a different post office (requiring the user’s messages to be added into the new 
post office indexes), you might need to repeat this action multiple times in order to get all messages 
indexed. If too many repetitions are required to complete the indexing task, see Section 38.3.3, 
“Customizing Indexing,” on page 557 for assistance.
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You can set up indexing to occur at regular intervals. See Section 38.3.1, “Regulating Indexing,” on 
page 555. 

If the indexing load on the POA is heavy, you can set up a separate POA just for indexing. See 
Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556.

POA Web Console 
You can update QuickFinder indexes from the Configuration page. Under the General Settings 
heading, click QuickFinder Indexing.

Compressing QuickFinder Indexes

QuickFinder indexes are automatically compressed at midnight each night to conserve disk space. 
You can start compression at any other time from the POA server console. For example, if you just 
imported and indexed a large number of documents and are running low on disk space, you could 
compress the indexes immediately, rather than waiting for it to happen at midnight.

To compress QuickFinder indexes for the post office:

1 At the server where the POA is running, display the POA server console.
2 Click Actions > QuickFinder > Compress Indexes.

NetWare Note: Use Options (F10) > Actions > Compress QuickFinder Indexes. 

POA Web Console 
You can compress QuickFinder indexes from the Configuration page. Under the General Settings 
heading, click QuickFinder Indexing.

Regenerating QuickFinder Indexes

If QuickFinder indexes become damaged, you can easily delete and re-create them.

To recreate QuickFinder indexes for the post office:

1 At the server where the POA is running, display the POA server console.
2 Click Actions > QuickFinder > Delete and Regenerate Indexes.

NetWare Note: Use Options (F10) > Actions > Delete and QuickFinder Indexes. 
You can also press Ctrl+Q.

POA Web Console 
You can recreate QuickFinder indexes from the Configuration page. Under the General Settings 
heading, click QuickFinder Indexing.

Browsing the Current POA Log File

In the log message box, the POA displays the same information being written to the POA log file. 
The amount of information depends on the current log settings for the POA. 

The information automatically scrolls up the screen as additional information is written. You can 
stop the automatic scrolling so you can manually scroll back through earlier information. 

To browse the current POA log file and control scrolling:

1 At the server where the POA is running, display the POA server console.
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2 Click Log > Auto Scroll to toggle automatic scrolling on or off.
NetWare Note: Use View Log File (F9). 

For explanations of messages in the POA log file, see “Post Office Agent Error Messages” in 
GroupWise 7 Troubleshooting 1: Error Messages.

See also Section 37.3, “Using POA Log Files,” on page 538.

POA Web Console 
You can browse and search POA log files on the Log Files page.

Viewing a Selected POA Log File

Reviewing log files is an important way to monitor the functioning of the POA.

1 At the server where the POA is running, display the POA server console.
2 Click Log > View Log. 

NetWare Note: Use Options (F10) > View Log Files. 
The following information is provided: 
Log Files:  Lists the current POA log files, ordered from the oldest log file at the top to the 
newest log file at the bottom. The current log file is marked with an asterisk (*). 
Date/Time: Displays the date and time of each POA log file.
Space Used: Displays the amount of disk space currently occupied by that POA’s log files. You 
can control the amount of space consumed by POA log files during the current POA session. 
You can also control the default amount of disk space for POA log files in the POA Log 
Settings page in ConsoleOne or in the POA startup file. See Section 37.3.1, “Configuring POA 
Log Settings and Switches,” on page 538. 
Log File Directory: Displays the full path of the directory where the POA writes its log files. 
See Section 37.3.1, “Configuring POA Log Settings and Switches,” on page 538.

3 In the log file list, select the POA log file you want to view.
Windows Note: For the Windows POA, you can select the viewer to use by providing the full 
path to the viewer program. The default viewer is Notepad.

4 Click View.

For explanations of messages in the POA log file, see “Post Office Agent Error Messages” in 
GroupWise 7 Troubleshooting 1: Error Messages.

See also Section 37.3, “Using POA Log Files,” on page 538.

POA Web Console 
You can view and search POA log files on the Log Files page.

Cycling the POA Log File

You can have the POA start a new log file as needed.

1 At the server where the POA is running, display the POA server console.
2 Click Log > Cycle Log. 

NetWare Note: Use Options (F10) > Cycle Log. 
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Adjusting POA Log Settings

Default log settings are established when you start the POA. However, you can adjust the POA log 
settings for the current session from the POA server console. This overrides any settings provided in 
ConsoleOne or in the POA startup file. The modified settings remain in effect until you restart the 
POA, at which time the log settings specified in ConsoleOne or the startup file take effect again.

1 At the server where the POA is running, display the POA server console.
2 Click Log > Log Settings.

NetWare Note: Use Options (F10) > Logging Options.
3 Adjust the values as needed for the current POA session.

See Section 37.3, “Using POA Log Files,” on page 538.

POA Web Console 
You can adjust POA log settings from the Configuration page. Click the Log Settings heading. 

Editing the POA Startup File

You can change the configuration of the POA by editing the POA startup file from the POA server 
console.

1 At the server where the POA is running, display the POA server console.
2 Click Configuration > Edit Startup File.

NetWare Note: Use Options (F10) > Actions > Edit Startup File.
3 Make the necessary changes, then save and exit the startup file.
4 Stop and restart the POA.

Accessing Online Help for the POA

Click Help on the menu bar for information about the POA server console. Click the Help button in 
any dialog box for additional information. 

NetWare Note: Press F1 for information in any dialog box or menu.

37.2  Using the POA Web Console
The POA Web console enables you to monitor and control the POA from any location where you 
have access to a Web browser and the Internet. This provides substantially more flexible access than 
the POA server console, which can only be accessed from the server where the POA is running.

Section 37.2.1, “Setting Up the POA Web Console,” on page 531
Section 37.2.2, “Accessing the POA Web Console,” on page 532
Section 37.2.3, “Monitoring the POA from the POA Web Console,” on page 533
Section 37.2.4, “Controlling the POA from the POA Web Console,” on page 536
7 Administration Guide



novdocx (en)  11 D
ecem

ber 2007
37.2.1  Setting Up the POA Web Console
The default HTTP port for the POA Web console is established during POA installation. You can 
change the port number and increase security after installation in ConsoleOne.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.

If you configured the POA for TCP/IP links during installation, the TCP/IP Address field 
should display the POA server’s network address. If it does not, follow the instructions in 
Section , “Using TCP/IP Links between the Post Office and the Domain,” on page 481. The 
POA must be configured for TCP/IP in order to provide the POA Web console.

3 Make a note of the IP address or DNS hostname in the TCP/IP Address field. You need this 
information to access the POA Web console.
The HTTP Port field displays the default port number of 7181.

4 If the default HTTP port number is already in use on the POA server, specify a unique port 
number.

5 Make a note of the HTTP port number. You need this information to access the POA Web 
console.

6 If you want to use an SSL connection for the POA Web console, which provides optimum 
security, select Enabled in the HTTP SSL drop-down list. 
For additional instructions about using SSL connections, see Chapter 71, “Encryption and 
Certificates,” on page 1117.

7 Click Apply to save your changes on the Network Address page.
If you want to limit access to the POA Web console, you can provide a username and password.

8 Click GroupWise > Agent Settings, then scroll down to HTTP Settings.
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9 In the HTTP Settings box:
9a In the HTTP User Name field, specify a unique username.
9b Click Set Password.
9c Type the password twice for verification.
9d Click Set Password.

Unless you are using an SSL connection, do not use a Novell® eDirectoryTM username and 
password because the information passes over the insecure connection between your Web 
browser and the POA.
For convenience, use the same username and password for all agents that you plan to 
monitor from GroupWise Monitor. This saves you from having to provide the username 
and password information as Monitor accesses each agent.

10 Click OK to save the POA Web console settings.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches 
You can also use the /httpport, /httpuser, /httppassword, and /httpssl startup switches in the POA 
startup file to enable and secure the POA Web console. In addition, you can use the /httprefresh 
switch to control how often the POA refreshes the information provided to your Web browser.

37.2.2  Accessing the POA Web Console
To monitor the POA from your Web browser, view the URL where the POA is located by supplying 
the network address and port number as displayed on the Network Address page in ConsoleOne. For 
example:
http://172.16.5.18:1677
http://172.16.5.18:7181
http://server1:7181
https://server2:1677

When viewing the POA Web console, you can specify either the client/server port or the HTTP port.
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Figure 37-3   POA Web Console

37.2.3  Monitoring the POA from the POA Web Console
The POA Web console provides several pages of information to help you monitor the performance 
of the POA. The bar at the top of the POA Web console displays the name of the POA and its post 
office. Below this bar appears the POA Web console menu that lists the pages of information 
available in the POA Web console. Online help throughout the POA Web console helps you 
interpret the information being displayed and use the links provided.

“Monitoring POA Status” on page 533
“Checking the POA Operating System Environment” on page 534
“Viewing and Searching POA Log Files” on page 535
“Listing POA Scheduled Events” on page 535
“Checking Link Status to the MTA” on page 536

Monitoring POA Status

When you first access the POA Web console, the Status page is displayed. Online help on the Status 
page helps you interpret the status information being displayed.
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Figure 37-4   POA Web Console with the Status Page Displayed

Click any hyperlinked status items for additional details. The status information is much the same as 
that provided at the POA server console, as described in Section 37.1.1, “Monitoring the POA from 
the POA Server Console,” on page 515.

Checking the POA Operating System Environment

On the POA Web console menu, click Environment to display information about the operating 
system where the POA is running. On a NetWare server, the following information is displayed:

Figure 37-5   POA Web Console Environment Page for a NetWare Server

On a Linux server, the following information is displayed:

Figure 37-6   POA Web Console Environment Page for a Linux Server
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On a Windows server, the following information is displayed:

Figure 37-7   POA Web Console Environment Page for a Windows Server

Viewing and Searching POA Log Files

On the POA Web console menu, click Log Files to display and search POA log files.

Figure 37-8   POA Web Console with the Log Files Page Displayed

To view a particular log file, select the log file, then click View Events. 

To search all log files for a particular string, type the string in the Events Containing field, select 
Select All, then click View Events. You can also manually select multiple log files to search.

The results of the search are displayed on a separate page that can be printed.

Listing POA Scheduled Events

On the POA Web console menu, click Scheduled Events to view currently scheduled events and 
their status information.
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Figure 37-9   POA Web Console with the Scheduled Events Page Displayed

QuickFinder indexing and remote downloadable Address Book generation can be controlled using 
links from the Configuration page. The Configuration page also displays information about disk 
check events and database maintenance events. However, scheduled events must be created and 
modified using ConsoleOne.

Checking Link Status to the MTA

On the POA Web console menu, click MTP Status to view status information about the link between 
the POA for the post office and MTA for the domain.

Figure 37-10   POA Web Console with the MTP Status Page Displayed

The Outbound TCP/IP link displays the MTA Web console where you can get status information 
about the MTA. The Hold link displays the contents of the MTA input queue, so you can find out if 
messages are waiting for processing by the MTA.

37.2.4  Controlling the POA from the POA Web Console
At the POA Web console, you can change some POA configuration settings for the current POA 
session. You can also stop and start some specific POA threads.

“Changing POA Configuration Settings” on page 537
“Controlling the POA Admin Thread” on page 537
“Controlling the POA MTP Threads” on page 538
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Changing POA Configuration Settings

On the POA Web console menu, click Configuration. Online help on the Configuration page helps 
you interpret the configuration information being displayed.

Figure 37-11   POA Web Console with the Configuration Page Displayed

Click any hyperlinked configuration items to change settings for the current agent session. The 
settings that can be modified are much the same as those that can be changed at the POA server 
console, as described in Section 37.1.2, “Controlling the POA from the POA Server Console,” on 
page 520.

Controlling the POA Admin Thread

On the Configuration page, click Admin Task Processing.

Figure 37-12   POA Web Console with the Admin Task Status Page Displayed
Monitoring the POA 537



538 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
Modify the functioning of the POA admin thread as needed, then click Submit. The changes remain 
in effect for the current POA session.

Controlling the POA MTP Threads

On the Configuration page, click Message Transfer Protocol.

Figure 37-13   POA Web Console with the Message Transfer Protocol Settings Page Displayed

On this page, you can restart MTA processing between the POA and the MTA. On the MTP status 
page, you can restart the send and receive threads separately.

37.3  Using POA Log Files
Error messages and other information about POA functioning are written to log files as well as 
displaying on the POA server console. Log files can provide a wealth of information for resolving 
problems with POA functioning or message flow. This section covers the following subjects to help 
you get the most from POA log files:

Section 37.3.1, “Configuring POA Log Settings and Switches,” on page 538
Section 37.3.2, “Viewing POA Log Files,” on page 539
Section 37.3.3, “Interpreting POA Log File Information,” on page 539

37.3.1  Configuring POA Log Settings and Switches
The following aspects of logging are configurable: 

Log File Path (/log) 
Disk Logging (/logdiskoff)
Logging Level (/loglevel) 
Maximum Log File Age (/logdays) 
Maximum Log File Size (/logmax)

You can configure the log settings in the following ways: 

Using ConsoleOne to establish defaults (see Section 36.1.7, “Adjusting the POA Logging 
Level and Other Log Settings,” on page 485)
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Using startup switches to override ConsoleOne settings (see Section 39, “Using POA Startup 
Switches,” on page 565)
Using the POA server console to override log settings for the current POA session (see 
Section , “Adjusting POA Log Settings,” on page 530)
Using the POA Web console to override other settings for the current POA session (see 
Section 37.2.4, “Controlling the POA from the POA Web Console,” on page 536)

37.3.2  Viewing POA Log Files
You can view the contents of the POA log file from the POA server console and Web console. See 
the following tasks presented in Section 37.1.1, “Monitoring the POA from the POA Server 
Console,” on page 515:

“Browsing the Current POA Log File” on page 528
“Viewing a Selected POA Log File” on page 529
“Cycling the POA Log File” on page 529
“Viewing and Searching POA Log Files” on page 535

37.3.3  Interpreting POA Log File Information
On startup, the POA records the POA settings currently in effect. Thereafter, it logs events that take 
place, including errors. To look up error messages that appear in POA log files, see “Post Office 
Agent Error Messages” in GroupWise 7 Troubleshooting 3: Message Flow and Directory Structure.

Because the POA consists of multiple threads, you might find it useful to retrieve the log file into an 
editor and sort it on the thread ID that follows the date and time information. Sorting groups all 
messages together for the same POA thread. You can also use the search capability of the POA Web 
console to gather information about a specific POA thread. See “Viewing and Searching POA Log 
Files” on page 535.

37.4  Using GroupWise Monitor
GroupWise Monitor is a monitoring and management tool that allows you to monitor GroupWise 
agents and gateways from any location where you are connected to the Internet and have access to a 
Web browser. The POA Web console can be accessed from GroupWise Monitor, enabling you to 
monitor all POAs in your GroupWise system from one convenient location. In addition, GroupWise 
Monitor can notify you when agent problems arise.
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Figure 37-14   GroupWise Monitor Web Console

For installation and setup instructions, see “Installing GroupWise Monitor” in the GroupWise 7 
Installation Guide. For usage instructions, see Part XIII, “Monitor,” on page 963.

37.5  Using Novell Remote Manager
If the POA is running on NetWare 6.5 or on Novell Open Enterprise Server (OES), you can use the 
IP Address Management feature in Novell Remote Manager (Manage Server > IP Address 
Management) to view the IP address and port configuration for the POA. This is also true for other 
GroupWise agents (MTA, Internet Agent, and WebAccess Agent) running on NetWare 6.5/OES 
servers.

IMPORTANT: If the POA is running in protected mode on NetWare, it does not display in Novell 
Remote Manager.

You access Novell Remote Manager by entering the following URL in a Web browser:
http://server_address:8008

For example:
http://172.16.5.18:8008

For more information about using Novell Remote Manager, see the NetWare 6.5 Documentation 
Web site (http://www.novell.com/documentation/nw65) and the Novell Open Enterprise Server 
Documentation Web site (http://www.novell.com/documentation/oes).

37.6  Using an SNMP Management Console
You can monitor the POA from the Management and Monitoring component of Novell ZENworks® 
for Servers or any other SNMP management and monitoring program. When properly configured, 
the POA sends SNMP traps to network management consoles for display along with other SNMP 
monitored programs.

Although the POA is SNMP-enabled by default, the server where the POA is installed must be 
properly configured to support SNMP, and the POA object in eDirectory must be properly 
configured as well. To set up SNMP services for your server, complete the following tasks:

Section 37.6.1, “Setting Up SNMP Services for the POA,” on page 541
Section 37.6.2, “Copying and Compiling the POA MIB File,” on page 543
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Section 37.6.3, “Configuring the POA for SNMP Monitoring,” on page 544

37.6.1  Setting Up SNMP Services for the POA
Select the instructions for the platform where the POA runs:

“Setting Up SNMP Services for the NetWare POA” on page 541
“Setting Up SNMP Services for the Linux POA” on page 541
“Setting Up SNMP Services for the Windows POA” on page 542

Setting Up SNMP Services for the NetWare POA

The NetWare POA supports SNMP through the SNMP services loaded on the NetWare server. 
SNMP services are provided through the SNMP NLMTM. The SNMP NLM initiates and responds to 
requests for monitoring information and generates trap messages.

If the SNMP NLM is not loaded before the NetWare POA, the POA still loads and functions 
normally, but SNMP support is disabled. The POA does not attempt to auto-load snmp.nlm. 

To load the SNMP NLM manually:

1 Go to the console of each NetWare server where you want to implement SNMP services.

These servers should already have the GroupWise agents installed.
2 Type the command to load the SNMP NLM:

        Syntax: 
load snmp v control=x monitor=y trap=z

where v represents Verbose, meaning to display informational messages, and x, y and z are 
replaced with your system SNMP community strings for SNMP SETs, GETs and TRAPs).

       Example: 
load snmp v control=private monitor=public trap=all

The configuration for the SNMP NLM is found in snmp.cfg and traptarg.cfg in the sys:\etc 
directory. View the contents of these files for more information.
The TCP/IP NLM automatically loads snmp.nlm, using default values for the community 
strings. If your system uses different community string values, load snmp.nlm before tcpip.nlm. 

3 If the SNMP NLM is already loaded, you can add the control and trap parameters by typing the 
following at the console prompt:
snmp control= trap=

To automatically load these commands, include them in the autoexec.ncf file.
For more information about implementing SNMP services, see your NetWare documentation. 

4 Skip to Section 37.6.2, “Copying and Compiling the POA MIB File,” on page 543.

Setting Up SNMP Services for the Linux POA

The Linux POA is compatible with NET-SNMP. An older version of SNMP called UCD-SNMP 
cannot be used with the Linux POA. NET-SNMP comes with OES Linux, but it does not come with 
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SLES 9. If you are using SLES 9, you must update to NET-SNMP in order to use SNMP to monitor 
the Linux POA.

1 Make sure you are logged in as root.
2 If NET-SNMP is not already set up on your Linux server, use the following command to 

configure SNMP:
snmpconf -g basic_setup

The snmpconf command creates the snmpd.conf file in one of the following directories, 
depending on your version of Linux:
/usr/share/snmp
/usr/local/share/snmp
~/.snmp

3 Locate the snmpd.conf file on your Linux server.
4 In a text editor, open the snmpd.conf file and add the following line:
dlmod Gwsnmp /opt/novell/groupwise/agents/lib/libgwsnmp.so

5 Save the snmpd.conf file and exit the text editor.
6 Restart the SNMP daemon (snmpd) to put the changes into effect.
7 Skip to Section 37.6.2, “Copying and Compiling the POA MIB File,” on page 543.

Setting Up SNMP Services for the Windows POA

SNMP support is provided for up to eight Windows POAs on the same Windows server. Upon 
startup, each instance of the POA is dynamically assigned a row in its SNMP table. View the 
contents of the POA MIB for a description of the SNMP variables in the table. See Section 37.6.2, 
“Copying and Compiling the POA MIB File,” on page 543 for more information about MIB files.

To set up SNMP services for the Windows POA, complete the following tasks:

“Installing Windows SNMP Support” on page 542
“Installing GroupWise Agent SNMP Support” on page 542

Installing Windows SNMP Support

For Windows, the SNMP service is usually not included during the initial operating system 
installation. The SNMP service can be easily added at any time. To add or configure the SNMP 
service, you must be logged in as a member of the Administrator group.

For example, to add the SNMP service to a Windows 2000 server:

1 From the Control Panel, double-click Add/Remove Programs. 
2 Click Add/Remove Windows Components. 
3 Select Management and Monitoring Tools.
4 Click Details, then select Simple Network Management Protocol.

Continue with “Installing GroupWise Agent SNMP Support” on page 542.

Installing GroupWise Agent SNMP Support

The GroupWise Agent Installation program includes an option for installing SNMP support. 
However, if the server where you installed the agents did not yet have SNMP set up, that installation 
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option was not available. Now that you have set up SNMP, you can install GroupWise agent SNMP 
support.

At the Windows server where you want to install the GroupWise agent SNMP support:

1 Run setup.exe at the root of the GroupWise 7 Administrator for NetWare/Windows CD. 
Click Install Products > GroupWise Agents > Install GroupWise Agents.

or

Run install.exe from the agents subdirectory on the GroupWise 7 Administrator for 
NetWare/Windows CD or in your software distribution directory if you have updated it with the 
latest GroupWise software. 

2 In the Installation Path dialog box, browse to and select the path where the agent software is 
installed, then select Install and Configure SNMP for GroupWise Agents.

3 To shorten the install time, deselect Install GroupWise Agent Software. 
4 Continue through the rest of the installation process as prompted by the Agent Installation 

program.
The Agent Installation program copies the SNMP support files to the agent installation 
directory, makes the appropriate Windows registry entries, and restarts the Windows SNMP 
service.

5 Continue with Copying and Compiling the POA MIB File.

37.6.2  Copying and Compiling the POA MIB File
An SNMP-enabled POA returns information contained in a Management Information Base (MIB). 
The MIB is an ASCII data structure that defines the information gathered. It also defines the 
properties that can be monitored and managed on the SNMP-enabled POA. 

Before you can monitor an SNMP-enabled POA, you must compile the gwpoa.mib file using your 
SNMP management program.

1 Copy the gwpoa.mib file to the location required by your SNMP management program. 

ZENworks Server Management users can access the gwpoa.mib file in the software 
distribution directory.

2 Compile or import the gwpoa.mib file as required by your SNMP management program.
For example, to compile the gwpoa.mib file for ZENworks Server Management:
2a In ConsoleOne, right-click the Site Server object, then click Properties > MIB Pool.
2b Click Modify Pool > Add.
2c Browse to and select the gwpoa.mib file, then click OK.
2d Click Compile.

NetWare 
and 
Windows:

The GroupWise MIBs are located on the GroupWise 7 Administrator for NetWare/
Windows CD in the \agents\snmp directory or in the 
software_distribution_directory\agents\snmp directory if you have 
updated it with the latest GroupWise software.

Linux: The GroupWise MIBs are located on the GroupWise Administrator for Linux CD in the /
agents/snmp directory.
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2e Make sure that the server where the POA is running is configured to send SNMP traps to 
the ZENworks Server Management Site Server.

Refer to your SNMP management program documentation for specific instructions. 
3 Continue with Configuring the POA for SNMP Monitoring.

37.6.3  Configuring the POA for SNMP Monitoring
In order for SNMP monitoring programs to monitor the POA, the POA must be configured with a 
network address and SNMP community string.

1 Browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.
3 Click the pencil icon to provide the TCP/IP address or IPXTM/SPXTM address of the server 

where the POA runs, then click Apply.
4 Click GroupWise > Agent Settings page, then scroll to the bottom of the settings list.
5 Provide your system SNMP community GET string, then click OK.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.
The POA should now be visible to your SNMP monitoring program.

37.7  Notifying the GroupWise Administrator
If you want to be notified with an e-mail message whenever POAs encounter critical errors, you can 
designate yourself as an administrator of the domain where the post offices are located.

1 In ConsoleOne, browse to and right-click the Domain object, then click Properties to display 
the Identification page.

NetWare: Add the IP address or hostname of the ZENworks Server Management Site 
Server to the traptarg.cfg file in the sys:\etc directory.

Windows: Add the IP address or hostname of the ZENworks Server Management Site 
Server to the list of trap destinations. For example, from the Windows 2000 
Control Panel, double-click Administrative Tools, then click Services > SNMP 
Service > Properties > Traps. 
7 Administration Guide



novdocx (en)  11 D
ecem

ber 2007
2 In the Administrator field, browse to and select your GroupWise user ID.
A domain can have a single administrator, or you can create a group of users to function as 
administrators.

3 Click OK to save the administrator information. 
The selected user or group then begins receiving e-mail messages whenever POAs servicing 
post offices in the domain encounter critical errors. 

Corresponding Startup Switches
 By default, the POA generates error mail if an administrator has been assigned for the domain. 
Error mail can be turned off using the /noerrormail switch in the POA startup file.

POA Web Console 
Another way to receive e-mail notification of POA problems is to use GroupWise Monitor to access 
the POA Web console. See Section 59.5.1, “Configuring E-Mail Notification,” on page 979.

37.8  Using the POA Error Message 
Documentation
POA error messages are documented with the source and explanation of the error, possible causes of 
the error, and actions to take to resolve the error. See “Post Office Agent Error Messages” in 
GroupWise 7 Troubleshooting 1: Error Messages.

37.9  Employing POA Troubleshooting 
Techniques
If you are having a problem with the POA but are not receiving a specific error message, or if the 
suggested actions for the specific error did not resolve the problem, you can review more general 
troubleshooting strategies for dealing with POA problems. See “Strategies for Agent Problems” in 
GroupWise 7 Troubleshooting 2: Solutions to Common Problems.
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37.10  Using Platform-Specific POA Monitoring 
Tools
Each operating system where the GroupWise POA runs provides tools for monitoring programs.

NetWare: You can use the NetWare Monitor NLM to monitor the effects of the POA on the NetWare 
server. NetWare 6.x/OES provides monitoring tools that you can use from your Web 
browser. Processor, resource, and memory utilization can be compared to other non-
GroupWise NLM programs to determine if the POA NLM program is monopolizing 
resources. See your NetWare documentation for additional monitoring suggestions.

Linux: You can use SNMP tools like snmpget and snmpwalk that allow you to retrieve the data 
about all the services registered with the SNMP service. These tools are part of the NET-
SNMP package. See your Linux documentation for additional monitoring suggestions.

Windows: You can use the Performance Monitor in Windows Administrator Tools to gather similar 
information. See your Windows documentation for additional monitoring suggestions.
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38Optimizing the POA

You can adjust how the POA functions to optimize its performance. Before attempting optimization, 
you should run the POA long enough to observe its efficiency and its impact on other network 
applications running on the same server. See Chapter 37, “Monitoring the POA,” on page 515.

Also, remember that optimizing your network hardware and operating system can make a difference 
in POA performance.

The following topics help you optimize the POA:

Section 38.1, “Optimizing Client/Server Processing,” on page 547
Section 38.2, “Optimizing Message File Processing,” on page 552
Section 38.3, “Optimizing Indexing,” on page 554
Section 38.4, “Optimizing Database Maintenance,” on page 559
Section 38.5, “Optimizing CPU Utilization for the NetWare POA,” on page 562

38.1  Optimizing Client/Server Processing
If you run only one POA for the post office, you can adjust the number of POA threads and 
connections for client/server processing. If client/server processing needs are extremely heavy for a 
post office, you can set up a dedicated client/server POA to meet those needs.

Section 38.1.1, “Adjusting the Number of POA Threads for Client/Server Processing,” on 
page 547
Section 38.1.2, “Adjusting the Number of Connections for Client/Server Processing,” on 
page 549
Section 38.1.3, “Configuring a Dedicated Client/Server POA,” on page 550

38.1.1  Adjusting the Number of POA Threads for Client/Server 
Processing
If the POA is configured with client/server processing enabled, it starts TCP handler threads to 
respond to current client/server requests, up to the number of threads specified by the TCP Handler 
Threads option. To respond to occasional heavy loads, the POA can increase the number of TCP 
handler threads above the specified amount if CPU utilization is below the threshold established by 
the CPU Utilization setting. When the POA rereads its configuration information, the number of 
TCP handler threads drops back within the configured limit. You can determine how often this 
happens by checking the Client/Server Pending Requests History page at the POA Web console.

If the POA is frequently not keeping up with the client/server requests from GroupWise® client 
users, you can increase the maximum number of TCP handler threads so the POA can create 
additional threads as needed. The default is 6 TCP handler threads; valid values range from 1 to 40.

If GroupWise client users cannot connect to the POA immediately or if response is sluggish, you can 
increase the number of threads.

1 In ConsoleOne®, browse to and right-click the POA object, then click Properties.
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2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Increase the number in the TCP Handler Threads field to increase the maximum number of 
threads the POA can create for client/server processing.
The optimum number of threads for a POA is affected by many factors, including available 
system resources, number of users in Caching mode, number of users priming Caching 
mailboxes, and so on. 
Plan on at least one TCP handler thread per 20-30 client/server users. Or, you can increase the 
number of TCP handler threads in increments of three to five threads until acceptable 
throughput is reached. Another approach would be to set the value high initially and then 
monitor thread usage with the C/S Handler Threads link on the Status page of the POA Web 
console. If some of the threads always have a count of 0 (zero), meaning they are never used, 
you can decrease the number of TCP handler threads accordingly. 

4 Click OK to save the new thread setting.
ConsoleOne then notifies the POA to restart so the new thread setting can be put into effect.

Corresponding Startup Switches 
You can also use the /tcpthreads switch in the POA startup file to adjust the number of POA threads.

POA Web Console 
The Status page helps you assess whether the POA is currently meeting the client/server needs of the 
post office. Under the Thread Status heading, click C/S Handler Threads to display the workload 
and status of the client/server handler threads.

You can change the number of client/server handler threads on the Configuration page. Under 
Performance Settings, click Client/Server Processing Threads.
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38.1.2  Adjusting the Number of Connections for Client/Server 
Processing
Connections are the number of “sockets” through which client/server requests are communicated 
from the GroupWise client to the POA.

Application connections:  Each GroupWise user uses one application connection when he or 
she starts GroupWise. Depending on what activities the user is doing in the GroupWise client, 
additional application connections are used. For example, the GroupWise Address Book and 
GroupWise Notify use individual application connections. The default maximum number of 
application connections is 2048. You should plan about 3 to 4 application connections per user, 
so the default is appropriate for a post office of about 500 users.
Physical connections:  Each GroupWise user could have zero or multiple active physical 
connections. One physical connection can accommodate multiple application connections. 
Inactive physical connections periodically time out and are then closed by the clients and the 
POA. The default maximum number of physical connections is 1024. You should plan about 1 
to 2 physical connections per user, so the default is appropriate for a post office of about 500 
users.

If the POA is configured with too few connections to accommodate the number of users in the post 
office, the POA can encounter an error condition such as “GWPOA: Application connection table 
full”.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Increase the number in the Max Physical Connections field to increase the amount of TCP/IP 
traffic the POA can accommodate.

4 Increase the number in the Max App Connections field to increase the number of activities the 
attached users can perform concurrently.

5 Click OK to save the new connection settings.
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ConsoleOne then notifies the POA to restart so the new connection settings can be put into 
effect.

Corresponding Startup Switches 
You can also use the /maxappconns and /maxphysconns switches in the POA startup file to adjust 
the POA client/server processing.

POA Web Console 
The Status page helps you assess whether the POA is currently meeting the client/server needs of the 
post office. Under the Statistics heading, click C/S Requests Pending. You can also manually select 
multiple log files to search in order to display a history of times during the last 24 hours when the 
POA was unable to respond immediately to client/server requests.

38.1.3  Configuring a Dedicated Client/Server POA
When GroupWise users access the post office in client/server mode, the responsiveness of the 
GroupWise client depends entirely on the ability of the POA to handle the load placed upon it by the 
users. When you configure a dedicated client/server POA, GroupWise client users do not compete 
with other POA activities.

Because many POA functions are disabled when a POA is dedicated to client/server processing, you 
must run at least one other POA for the post office to take care of the POA functions that the 
dedicated client/server POA is not performing. This additional POA could be a multipurpose POA, 
or you could configure additional POAs dedicated to specific types of processing.

To configure a dedicated client/server POA:

1 Create a new POA object for the post office as described in Section 36.1.1, “Creating a POA 
Object in eDirectory,” on page 476. 

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > Agent Settings to display the Agent Settings page.

4 Make sure Enable TCP/IP (for Client/Server) is selected.
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5 Increase the number in the TCP Handler Threads field as needed to increase the maximum 
number of threads the POA can create.
The optimum number of threads for a POA is affected by many factors, including available 
system resources, number of users in Caching mode, number of users priming Caching 
mailboxes, and so on. 
Plan on at least one TCP handler thread per 20-30 client/server users. Or, you can increase the 
number of TCP handler threads in increments of three to five threads until acceptable 
throughput is reached. Another approach would be to set the value high initially and then 
monitor thread usage with the C/S Handler Threads link on the Status page of the POA Web 
console. If some of the threads always have a count of 0 (zero), meaning they are never used, 
you can decrease the number of TCP handler threads accordingly. 

6 Increase the number in the Max Physical Connections field as needed to increase the amount of 
TCP/IP traffic the POA can accommodate.
Plan on one to two physical connections per user in the post office.

7 Increase the number in the Max App Connections field as needed to increase the number of 
activities the attached users can perform concurrently.
Plan on three to four application connections per user in the post office.

8 Set Message File Processing to Off. Make sure another POA handles message file processing.
9 Select Disable Administration Task Processing, so that this POA does not run an admin thread. 

Make sure that another POA handles administration tasks.
10 Click Apply to save the updated information on the Agent Settings page.
11 Click GroupWise > QuickFinder. 
12 Deselect Enable QuickFinder Indexing, then click Apply. Make sure another POA handles 

indexing.
13 Click GroupWise > Maintenance.
14 Deselect Enable Automatic Database Recovery. Make sure another POA handles database 

recovery.
15 Set Maintenance Handler Threads to 0 (zero). Make sure another POA handles database 

maintenance and disk space management.
16 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure 

another POA handles these tasks.
17 Click OK to save the new settings for dedicated client/server processing.
18 Install the POA software on a different server from where the original POA for the post office is 

already running. See “Installing GroupWise Agents” in the GroupWise 7 Installation Guide.
19 Add the /name switch to the POA startup file and specify the name designated when you 

created the new POA object. Also add the /name switch to the startup file for the original POA. 
20 Start the dedicated client/server POA.

Corresponding Startup Switches 
You can also use the /nomf, /noqf, /norecover, /nogwchk, /nonuu, and /nordab switches in the POA 
startup file to disable non-client/server processing, then use the /tcpthreads, /maxappconns, and /
maxphysconns switches to adjust the POA client/server processing.
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38.2  Optimizing Message File Processing
If you run only one POA for the post office, you can adjust the number of POA threads for message 
file processing. If message file processing needs are extremely heavy for a post office, you can set 
up a dedicated message file processing POA to meet those needs.

Section 38.2.1, “Adjusting the Number of POA Threads for Message File Processing,” on 
page 552
Section 38.2.2, “Configuring a Dedicated Message File Processing POA,” on page 553

38.2.1  Adjusting the Number of POA Threads for Message File 
Processing
If the POA is configured for message file processing, it starts the number of threads specified by the 
Message Handler Threads option. Message handler threads deliver messages to users mailboxes. 
The default number of message handler threads is 6; valid values range from 1 to 30.

The more message threads the POA uses, the faster it can process messages. However, the more 
threads the POA uses, the fewer resources are available to other processes running on the server.

To adjust the number of POA message handler threads:

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Increase the number in the Message Handler Threads field.
For example, you could increase the number of threads in increments of three to five threads 
until acceptable throughput is reached. The optimum number of threads for a POA is affected 
by many factors, including available system resources.

4 Click OK to save the new thread setting.
ConsoleOne then notifies the POA to restart so the new setting can be put into effect. 
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Corresponding Startup Switches 
You can also use the /threads switch in the POA startup file to adjust the number of message handler 
threads.

POA Web Console 
The Status page helps you assess whether the POA is currently meeting the message file processing 
needs of the post office. Under the Thread Status heading, click Message File Processing Threads to 
display the workload and status of the message handler threads.

You can change the number of message handler threads on the Configuration page. Under 
Performance Settings, click Message File Processing Threads.

38.2.2  Configuring a Dedicated Message File Processing POA
If client/server processing is being handled by a dedicated client/server POA, you can set up one or 
more other POAs to handle other POA functions such as message file processing.

1 Create a new POA object for the post office as described in Section 36.1.1, “Creating a POA 
Object in eDirectory,” on page 476. 

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > Agent Settings to display the Agent Settings page.

4 Set Message File Processing to the desired level for this message file processing POA.
If you are using just one message file processing POA, set Message File Processing to All.
For additional load balancing, you could set up two message file processing POAs, one with 
Message File Processing set to High to handle Busy Searches and requests from Remote client 
users promptly, and a second with Message File Processing set to Low to handle regular 
message delivery in the post office.

5 Increase the number in the Message Handler Threads field as needed.
You can configure as many as 30 message handler threads. The optimum number is affected by 
many factors, including available system resources.
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6 Deselect Enable TCP/IP (for Client/Server). Make sure another POA handles client/server 
processing.

7 Select Disable Administration Task Processing, so that this POA does not run an admin thread. 
Make sure that another POA handles administration tasks.

8 Click Apply to save the updated information on the Agent Settings page.
9 Click GroupWise > QuickFinder.

10 Deselect Enable QuickFinder Indexing, then click Apply. Make sure another POA handles 
indexing.

11 Click GroupWise > Maintenance.
12 Deselect Enable Automatic Database Recovery. Make sure another POA handles database 

recovery.
13 Set Maintenance Handler Threads to 0 (zero). Make sure another POA handles database 

maintenance and disk space management.
14 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure 

another POA handles these tasks.
15 Click OK to save the new settings for dedicated message file processing.
16 Install the POA software on a different server from where the original POA for the post office is 

already running. See “Installing GroupWise Agents” in the GroupWise 7 Installation Guide.
17 Add the /name switch to the POA startup file and specify the name designated when the new 

POA object was created. Also add the /name switch to the startup file for the original POA. 
18 Start the dedicated message file processing POA.

Corresponding Startup Switches 
You can also use the /notcpip, /noqf, /norecover, /nogwchk, /nonuu, and /nordab switches in the 
POA startup file to disable non-message file processing, then use the /nomfhigh and /nomflow 
switches in the POA startup file to adjust the POA message file processing.

38.3  Optimizing Indexing
If you run only one POA for the post office, you can adjust the indexing schedule. If indexing needs 
are extremely heavy for a post office, you can set up a dedicated indexing POA to meet those needs.

Section 38.3.1, “Regulating Indexing,” on page 555
Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556
Section 38.3.3, “Customizing Indexing,” on page 557

NOTE: To facilitate the Find feature in the GroupWise client, the POA searches unindexed 
messages as well as those that have already been indexed, so that all messages are immediately 
available to users whenever they perform a search. The POA does not search unindexed documents, 
so documents cannot be located using the client Find feature until after indexing has been 
performed.
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38.3.1  Regulating Indexing
By default, the POA indexes messages and documents in the post office every 24 hours at 8:00 p.m. 
You can modify this interval if users need messages and documents indexed more quickly. To start 
indexing immediately, see “Updating QuickFinder Indexes” on page 527.

To adjust the interval at which indexing occurs:

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > QuickFinder to display the QuickFinder page.

3 Make sure Enable QuickFinder Indexing is selected.
4 In the Start QuickFinder Indexing field, specify the number of hours and minutes after 

midnight you want the POA to start its indexing cycle.
For example, if you set QuickFinder Interval to 6 and Start QuickFinder Indexing to 1 hour, 
indexing cycles would occur at 1:00 a.m., 7:00 a.m., 1:00 p.m., and 7:00 p.m.

5 Decrease the number of hours and minutes in the QuickFinder Interval field so indexing occurs 
more frequently.
The interval is measured from the start of one indexing cycle to the next, so that indexing starts 
at regular intervals, no matter how long each indexing session takes. By default, the start point 
of the cycle is 8:00 p.m.
To avoid overloading the POA with indexing processing, a maximum of 1000 items are 
indexed per database for each indexing cycle. If a very large number of messages are received 
regularly, you should configure the POA with frequent indexing cycles in order to get all 
messages indexed in a timely manner.
To handle occasional heavy indexing requirements, you can start indexing manually. See 
“Updating QuickFinder Indexes” on page 527.

6 Click OK to save the new indexing settings.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect. 
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Corresponding Startup Switches 
You can also use the /qfinterval, /qfintervalinminute, /qfbaseoffset, and /qfbaseoffsetinminute 
switches in the POA startup file to regulate indexing.

POA Web Console 
You can control indexing for the current POA session on the Configuration page. Under the General 
Settings heading, click QuickFinder Indexing. If indexing is currently in progress, you can check the 
status of the indexing process on the Scheduled Events page.

38.3.2  Configuring a Dedicated Indexing POA
If your GroupWise client users rely heavily on indexed documents, you can set up a dedicated 
indexing POA so that indexing can be done quickly without impacting other POA functions. The 
steps provided in this section would be appropriate for a basic indexing POA. For a discussion of 
more complex configuration options, see Section 23.3, “Indexing Documents,” on page 351.

To configure a basic dedicated indexing POA:

1 Create a new POA object for the post office as described in Section 36.1.1, “Creating a POA 
Object in eDirectory,” on page 476. 

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > QuickFinder to display the QuickFinder page.

4 Make sure Enable QuickFinder Indexing is selected. 
5 In the Start QuickFinder Indexing field, specify the number of hours and minutes after 

midnight you want the POA to start its indexing cycle.
The default is 20, meaning at 8:00 p.m.

6 Set QuickFinder Update Interval low enough to keep up with the indexing demands of your 
GroupWise client users.
To avoid overloading the POA with indexing processing, a maximum of 1000 items are 
indexed per database for each indexing cycle. If a very large number of messages are received 
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regularly, you should configure the POA with very frequent indexing cycles in order to get all 
messages indexed in a timely manner.
For continuous QuickFinderTM indexing, set QuickFinder Update Interval to 0 (zero).

7 Click Apply to save the updated QuickFinder settings.
8 Click GroupWise > Agent Settings.
9 Set Message File Processing to Off. Make sure another POA handles message file processing.

10 Deselect Enable TCP/IP (for Client/Server) and set TCP Handler Threads to 0. Make sure 
another POA handles client/server processing.

11 Select Disable Administration Task Processing, so that this POA does not run an admin thread. 
Make sure that another POA handles administration tasks.

12 Click Apply to save the updated agent settings.
13 Click GroupWise > Maintenance.
14 Deselect Enable Automatic Database Recovery. Make sure another POA handles database 

recovery.
15 Set Maintenance Handler Threads to 0 (zero). Make sure another POA handles database 

maintenance and disk space management.
16 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure 

another POA handles these tasks.
17 Click OK to save the new settings for dedicated indexing.
18 Install the POA software on a different server from where the original POA for the post office is 

already running. See “Installing GroupWise Agents” in the GroupWise 7 Installation Guide. 
19 Add the /name switch to the POA startup file and specify the name designated when the new 

POA object was created. Also add the /name switch to the startup file for the original POA.
20 Start the dedicated indexing POA. 

Corresponding Startup Switches 
You can also use the /nomf, /notcpip, /norecover, /nonuu, and /nordab switches in the POA startup 
file to disable unwanted processing, then use the /qfinterval, /qfintervalinminute, /qfbaseoffset, and /
qfbaseoffsetinminute switches to control the indexing schedule.

38.3.3  Customizing Indexing
By default, the POA indexes 500 items in a user or library database, then moves on to the next 
database during each QuickFinder indexing cycle. The indexing cycle is established on the 
QuickFinder property page of the POA object. By default, QuickFinder indexing is performed once 
a day at 8:00 p.m. If a database has more than 500 items that need to be indexed, items beyond 500 
wait for the next indexing cycle.

Occasionally, circumstances arise where indexing needs are especially heavy for a short period of 
time. This can occur when you move users to a different post office or if the QuickFinder indexes for 
a post office become damaged. Startup switches are available for temporary use in the POA startup 
file to customize the way the POA handles indexing. In general, they are not intended for long-term 
use. You might want to set up a separate POA just to handle the temporary indexing needs, as 
described in Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556, and use these 
switches only with the dedicated indexing POA.
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Because the switches are placed in the POA startup file, you must stop and then start the POA to put 
the settings into effect.

“Determining What to Index” on page 558
“Determining Indexing Priority” on page 558
“Reclaiming Disk Space” on page 559

Determining What to Index

You can configure the POA to index just user mailbox contents or just library contents. Use the /
qfnousers switch to focus on indexing library contents. Use the /qfnolibs switch to focus on indexing 
user mailbox contents. Use the /qfnopreproc switch to suppress even the generation of document 
word lists that are normally written to user databases that reference documents. 

When you have a large number of user databases that need to be indexed, you can configure the 
POA to index a specific range of databases based on user FIDs. For a task of this magnitude, you 
should run multiple dedicated indexing POAs with each POA configured to process a specific range 
of databases. Use the /qfuserfidbeg and /qfuserfidend switches to define the range for each POA. 
You can determine the FID numbers of the databases by listing the user databases (userxxx.db) 
in the ofuser directory. The xxx part of the user database name is the FID.

You could also use these switches to single out a specific user database for indexing. Specify the 
same FID for both switches. To determine a user’s FID, click Help > About GroupWise in the 
GroupWise client. In Online mode, the FID is displayed after the username. In Caching or Remote 
mode, the FID is the last three characters of the Caching or Remote directory (for example, 
c:\novell\groupwise\gwstr7bh).

Determining Indexing Priority

The POA carries on many processes at once. If you are not using a dedicated indexing POA, you can 
configure the POA to make indexing a higher or lower priority task than responding to users’ 
activities in their mailboxes. You can also control how many items the POA indexes in each 
database that it processes. Use the /qflevel switch to control indexing priority. The table below 
explains the priority levels:

Table 38-1   QuickFinder Indexing Priority Levels

Priority Level Description

0 Index a maximum of 1000 items at a time, rather than the default of 500.

1 Index a maximum of 500 items at time, using a low-priority thread. This keeps frequent 
daytime indexing cycles from interfering with users’ activities in their mailboxes.

2 Index a maximum of 1000 items at a time, using a medium-priority thread. This allows 
additional items in each database to be processed in each indexing cycle. Using a 
medium-priority thread makes indexing more important than some user activities in 
mailboxes. Users might notice some slowness in response from the GroupWise client.

3 Index a maximum of 2000 items at a time, using a high-priority thread. Using a high- 
priority thread makes indexing more important than many user activities in mailboxes. 
Users will notice some slowness in response from the GroupWise client. This is 
warranted only when the immediate completion of indexing is extremely important.
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If you have users who consistently receive more items than are processed during your current daily 
indexing cycle, you could implement an appropriate /qflevel setting for permanent use.

Reclaiming Disk Space

The POA uses .idx files to store compressed indexes. It uses .inc files to store incremental 
indexes that have not yet been compressed. At regular intervals, the POA compresses the contents of 
the .inc files and adds the data to the .idx files. Afterwards, it retains the previous .idx and 
.inc files for a period of time. Use the /qfdeleteold switch to delete the previous versions of the 
.idx and .inc files to conserve disk space during periods of heavy indexing. It is primarily 
applicable when using /qflevel=1 where indexing is a lower priority task. For /qflevel=2 and /
qflevel=3, indexing itself is a higher priority than compression and deletion cleanup tasks.

38.4  Optimizing Database Maintenance
If you run only one POA for the post office, you can adjust the number of database maintenance 
threads. If database maintenance needs are extremely heavy for a post office, you can set up a 
dedicated database maintenance POA to meet those needs.

Section 38.4.1, “Adjusting the Number of POA Threads for Database Maintenance,” on 
page 559
Section 38.4.2, “Configuring a Dedicated Database Maintenance POA,” on page 560

38.4.1  Adjusting the Number of POA Threads for Database 
Maintenance
The POA by default performs a certain amount of database maintenance. In addition, you can create 
your own customized maintenance events as described in Section 36.4.1, “Scheduling Database 
Maintenance,” on page 507 and Section 36.4.2, “Scheduling Disk Space Management,” on 
page 510.

By default, the POA starts one thread to handle all POA scheduled events and also all usage of the 
Mailbox/Library Maintenance feature in ConsoleOne. 

To adjust the number of POA database maintenance handler threads:

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Maintenance to display the Maintenance page.

999 Index constantly until all databases have been indexed, then wait until the next indexing 
cycle set on the QuickFinder property page of the POA object before starting to index 
again.

Priority Level Description
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3 Increase the number in the Maintenance Handler Threads field.
4 Click OK to save the new thread setting.

ConsoleOne then notifies the POA to restart so the new setting can be put into effect. 

Corresponding Startup Switches
 You can also use the /gwchkthreads switch in the POA startup file to increase the number of POA 
threads started for database maintenance activities.

POA Web Console 
The Status page helps you assess whether the POA is currently meeting the database maintenance 
needs of the post office. Under the Thread Status heading, click GWCheck Worker Threads to 
display the workload and status of the database maintenance handler threads.

You can change the number of database maintenance handler threads on the Configuration page. 
Under Performance Settings, click Maximum GWCheck Processing Threads.

38.4.2  Configuring a Dedicated Database Maintenance POA
If a large amount of database maintenance needs to be performed for a post office, you can set up a 
dedicated database maintenance POA so that the database maintenance activities do not impact 
other POA activities, such as responding to GroupWise client users.

1 Create a new POA object for the post office as described in Section 36.1.1, “Creating a POA 
Object in eDirectory,” on page 476. 

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > Maintenance to display the Maintenance page.
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4 Make sure Enable Automatic Database Recovery is selected.
5 Set Maintenance Handler Threads as needed. 

The maximum number of threads you can start for database maintenance is 8.
6 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure 

another POA handles these tasks.
7 Set Disk Check Interval and Disk Check Delay as appropriate for the database maintenance 

events you plan to schedule.
8 Click Apply to save the updated information on the Maintenance page.
9 Click GroupWise > Scheduled Events, then create database maintenance events as needed, as 

described in Section 36.4.1, “Scheduling Database Maintenance,” on page 507 and 
Section 36.4.2, “Scheduling Disk Space Management,” on page 510.

10 Click GroupWise > Agent Settings.
11 Deselect Enable TCP/IP (for Client/Server) and set TCP Handler Threads to 0. Make sure 

another POA handles client/server processing.
12 Click Apply to save the updated information on the Agent Settings page.
13 Click GroupWise > QuickFinder.
14 Deselect Enable QuickFinder Indexing. Make sure another POA handles indexing.
15 Click OK to save the new settings for dedicated database maintenance processing.
16 Install the POA software on a different server from where the original POA for the post office is 

already running. See “Installing GroupWise Agents” in the GroupWise 7 Installation Guide.
17 Add the /name switch to the POA startup file and specify the name designated when you 

created the new POA object. Also add the /name switch to the startup file for the original POA. 
18 Start the dedicated database maintenance POA. 

Corresponding Startup Switches 
You can also use the /nomf, /notcpip, /noqf, /nonuu, and /nordab switches in the POA startup file to 
disable unwanted processing, then use the /gwchkthreads switch to increase the number of database 
maintenance handler threads.
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38.5  Optimizing CPU Utilization for the NetWare 
POA
To ensure that it does not dominate the NetWare server CPU, the NetWare POA has a CPU 
utilization threshold. The default CPU utilization threshold for the NetWare POA is 85 percent. You 
can change this threshold using the CPU Utilization option. If CPU utilization exceeds the threshold 
by 5 percent, any idle NetWare POA threads remain idle for the number of milliseconds set by the 
Delay Time option. This cycle continues until CPU utilization drops below the CPU utilization 
threshold.

To determine the optimum utilization setting for your network, you must consider the following 
factors:

Amount of available memory
Demands of other network applications
Type of throughput you want the NetWare POA to provide

As you raise the utilization threshold, NetWare POA efficiency increases; however, other network 
applications have fewer available resources. As you decrease the utilization threshold, NetWare 
POA efficiency is reduced; however, the NetWare POA cooperates better with other applications 
running on the same server. The best way to determine these settings for your network is to 
experiment. 

To adjust the NetWare POA CPU utilization and delay time:

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

3 Increase the number in the CPU Utilization field to allow the NetWare POA to use more server 
resources.
or
Decrease the number in the CPU Utilization field to give the NetWare POA fewer server 
resources so those resources can be used by other programs on the server.
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4 Decrease the number in the Delay Time field to allow NetWare POA threads to take on new 
tasks more quickly.
or
Increase the number in the Delay Time field to force NetWare POA threads to pause before 
taking on new tasks.

5 Click OK to save the new CPU utilization settings.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches 
You can also use the /cpu and /sleep switches in the POA startup file to adjust CPU utilization and 
delay time.
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39Using POA Startup Switches

You can override settings provided in ConsoleOne® by using startup switches in the POA startup 
file. When you run the Agent Installation program, an initial POA startup file is created in the agent 
installation directory. It is named using the first 8 characters of the post office name with a .poa 
extension. This initial startup file includes the /home startup switch set to the location of the post 
office directory.

Startup switches specified on the command line override those in the startup file. Startup switches in 
the startup file override corresponding settings in ConsoleOne.

The table below summarizes POA startup switches for all platforms and how they correspond to 
configuration settings in ConsoleOne. 

Switch start with: a b c d e f g h i j k l m n o p q r s t u v w x y z

Table 39-1   POA Startup Switches

NetWare POA Linux POA Windows POA ConsoleOne Settings

@filename @filename @filename N/A

/attemptsresetinterval --attemptsresetinterval /attemptsresetinterval Incorrect Login Reset Time

/certfile --certfile /certfile Certificate File

/cap --cap /cap Enable CAP

/capmaxthreads --capmaxthreads /capmaxthreads Max CAP Threads

/capport --capport /capport CAP Port

/capssl --capssl /capssl CAP SSL

/cluster --cluster N/A N/A

/cpu N/A N/A CPU Utilization

/dn N/A N/A N/A

/enforceclientversion --enforceclientversion /enforceclientversion Lock Out Older GroupWise 
Clients

/evocontrol --evocontrol /evocontrol N/A

/externalclientssl --externalclientssl /externalclientssl Internet Client/Server SSL

/gwchkthreads --gwchkthreads /gwchkthreads Maintenance Handler 
Threads

/gwclientreleasedate --gwclientreleasedate /gwclientreleasedate Minimum Client Release 
Date

/
gwclientreleaseversion

--gwclientreleaseversion /
gwclientreleaseversion

Minimum Client Release 
Version

/help --help /help N/A
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/home --home /home N/A

/httppassword --httppassword /httppassword HTTP Password

/httpport --httpport /httpport HTTP Port

/httprefresh --httprefresh /httprefresh N/A

/httpssl --httpssl /httpssl HTTP SSL

/httpuser --httpuser /httpuser HTTP User Name

/imap --imap /imap IMAP

/imapmaxthreads --imapmaxthreads /imapmaxthreads Max IMAP Threads

/imapport --imapport /imapport IMAP Port

/imapreadlimit --imapreadlimit /imapreadlimit N/A

/imapssl --imapssl /imapssl IMAP SSL

/imapsslport --imapsslport /imapsslport IMAP SSL Port

/incorrectloginattempts --incorrectloginattempts /incorrectloginattempts Incorrect Logins Allowed

/internalclientssl --internalclientssl /internalclientssl Local Intranet Client SSL

/intruderlockout --intruderlockout /intruderlockout Enable Intruder Detection

/ip --ip /ip N/A

/keyfile --keyfile /keyfile SSL Key File

/keypassword --keypassword /keypassword SSL Key File Password

/language --language /language N/A

/ldapdisablepwdchg --ldapdisablepwdchg /ldapdisablepwdchg Disable LDAP Password 
Changing

/ldapipaddr --ldapipaddr /ldapipaddr LDAP Server Address

/ldapippooln --ldapippooln /ldapippooln Select LDAP Servers

/ldappoolresettime --ldappoolresettime /ldappoolresettime LDAP Pool Server Reset 
Timeout

/ldapport --ldapport /ldapport LDAP Server Address

/ldapportpooln --ldapportpooln /ldapportpooln LDAP Server Address

/ldappwd --ldappwd /ldappwd LDAP Password

/ldapssl --ldapssl /ldapssl Use SSL

/ldapsslpooln --ldapsslpooln /ldapsslpooln Use SSL

/ldapsslkey --ldapsslkey /ldapsslkey SSL Key File

/ldapsslkeypooln --ldapsslkeypooln /ldapsslkeypooln SSL Key File

/ldaptimeout --ldaptimeout /ldaptimeout Inactive Connection Timeout

NetWare POA Linux POA Windows POA ConsoleOne Settings
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/ldapuser --ldapuser /ldapuser LDAP User Name

/ldapuserauthmethod --ldapuserauthmethod /ldapuserauthmethod User Authentication Method

/lockoutresetinterval --lockoutresetinterval /lockoutresetinterval Lockout Reset Time

/log --log /log Log File Path

/logdays --logdays /logdays Max Log File Age

/logdiskoff --logdiskoff /logdiskoff Logging Level

/loglevel --loglevel /loglevel Logging Level

/logmax --logmax /logmax Max Log Disk Space

/maxappconns --maxappconns /maxappconns Max Application Connections

/maxphysconns --maxphysconns /maxphysconns Max Physical Connections

/mtpinipaddr --mtpinipaddr /mtpinipaddr IP Address (POA)

/mtpinport --mtpinport /mtpinport Message Transfer Port 
(POA)

/mtpoutipaddr --mtpoutipaddr /mtpoutipaddr IP Address (MTA)

/mtpoutport --mtpoutport /mtpoutport Message Transfer Port 
(MTA)

/mtpsendmax --mtpsendmax /mtpsendmax Maximum Send Message 
Size

/mtpssl --mtpssl /mtpssl Message Transfer SSL

/name --name /name N/A

/noada --noada /noada N/A

/nocache --nocache /nocache Enable Caching

/noconfig --noconfig /noconfig N/A

/noerrormail --noerrormail /noerrormail N/A

/nogwchk --nogwchk /nogwchk N/A

/noldapx --noldapx /noldapx N/A

/nomf --nomf /nomf Message File Processing

/nomfhigh --nomfhigh /nomfhigh Message File Processing

/nomflow --nomflow /nomflow Message File Processing

/nomtp --nomtp /nomtp N/A

/nonuu --nonuu /nonuu Perform User Upkeep

/noqf --noqf /noqf Enable QuickFinder Indexing

/nordab --nordab /nordab Generate Address 
Books for Remote

NetWare POA Linux POA Windows POA ConsoleOne Settings
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/norecover --norecover /norecover Enable Auto DB Recovery

/nosnmp --nosnmp /nosnmp Enable SNMP

/notcpip --notcpip /notcpip Enable TCP/IP 
(for C/S)

/nuuoffset --nuuoffset /nuuoffset Start User Upkeep

/password --password /password Remote Password

/port --port /port Client/Server Port

/primingmax --primingmax /primingmax Max Thread Usage for 
Priming and Moves

/qfbaseoffset --qfbaseoffset /qfbaseoffset Start QuickFinder Indexing

/qfbaseoffsetinminute --qfbaseoffsetinminute /qfbaseoffsetinminute Start QuickFinder Indexing

/qfdeleteold --qfdeleteold /qfdeleteold N/A

/qfinterval --qfinterval /qfinterval QuickFinder Interval

/qfintervalinminute --qfintervalinminute /qfintervalinminute QuickFinder Interval

/qflevel --qflevel /qflevel N/A

/qfnolibs --qfnolibs /qfnolibs N/A

/qfnopreproc --qfnopreproc /qfnopreproc N/A

/qfnousers --qfnousers /qfnousers N/A

/qfuserfidbeg --qfuserfidbeg /qfuserfidbeg N/A

/qfuserfidend --qfuserfidend /qfuserfidend N/A

/rdaboffset --rdaboffset /rdaboffset Start Address Book
Generation

/rights --rights /rights N/A

N/A --show N/A N/A

/sleep N/A N/A Delay Time (NLM)

/soap --soap /soap Enable SOAP

/soapmaxthreads --soapmaxthreads /soapmaxthreads Max SOAP Threads

/soapport --soapport /soapport SOAP Port

/soapsizelimit --soapsizelimit /soapsizelimit N/A

/soapssl --soapssl /soapssl SOAP SSL

/soapthreads --soapthreads /soapthreads N/A

/tcpthreads --tcpthreads /tcpthreads TCP Handler Threads

/threads --threads /threads Message Handler Threads

/user --user /user Remote User Name

NetWare POA Linux POA Windows POA ConsoleOne Settings
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39.1  @filename
Specifies the location of the POA startup file.

The startup file must reside on the same server where the POA is installed.

39.2  /attemptsresetinterval
Specifies the length of time during which unsuccessful login attempts are counted, leading to 
lockout. The default is 30 minutes; valid values range from 15 to 60. See Section 36.3.5, “Enabling 
Intruder Detection,” on page 506.

See also /intruderlockout, /incorrectloginattempts, and /lockoutresetinterval.

39.3  /cap
Enables CAP (Calendar Access Protocol) so that the POA can communicate with CAP clients. See 
Section 36.2.5, “Supporting CAP Clients,” on page 492.

See also /capmaxthreads, /capport, and /capssl. 

NetWare: The full path must be included if the file does not reside in the same directory with the POA 
program.

Linux: The startup file always resides in the /opt/novell/groupwise/agents/share 
directory.

Windows: The full path must be included if the file does not reside in the same directory with the POA 
program.

NetWare POA Linux POA Windows POA

Syntax: @[vol:][\dir\]file @[/dir/]file @[drive:][\dir\]file

Example: load gwpoa @sales.poa
load gwpoa @sys:\agt\sales.poa

./gwpoa @../share/
lnxpost.poa

gwpoa.exe @sales.poa
gwpoa.exe @d:\agt\sales.poa

NetWare POA Linux POA Windows POA

Syntax: /attemptsresetinterval-minutes --attemptsresetinterval minutes /attemptsresetinterval-
minutes

Example: /attemptsresetinterval-15 --attemptsresetinterval 45 /attemptsresetinterval-60

NetWare POA Linux POA Windows POA

Syntax: /cap-enabled or disabled --cap enabled or disabled /cap-enabled or disabled

Example: /cap-enabled --cap enabled /cap-enabled
Using POA Startup Switches 569



570 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
39.4  /capmaxthreads
Specifies the maximum number of CAP threads the POA can create to service CAP clients. The 
default is 50. This setting is appropriate for most systems. See Section 36.2.5, “Supporting CAP 
Clients,” on page 492.

See also /cap, /capport, /capssl.

39.5  /capport
Sets the TCP port number used for the POA to communicate with CAP clients. The default is 1026. 
See Section 36.2.5, “Supporting CAP Clients,” on page 492.

See also /cap, /capmaxthreads, and /capssl.

39.6  /capssl
Sets the availability of secure SSL communication between the POA and CAP clients. Valid settings 
are enabled and disabled. CAP uses TLS (Transport Layer Security) to negotiate the SSL 
connection. See Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on 
page 498.

See also /imap, /imapmaxthreads, and /imapport.

39.7  /certfile
Specifies the full path to the public certificate file used to provide secure SSL communication 
between the POA and other programs. See Section 36.3.3, “Securing the Post Office with SSL 
Connections to the POA,” on page 498.

NetWare POA Linux POA Windows POA

Syntax: /capmaxthreads-number --capmaxthreads number /capmaxthreads-number

Example: /capmaxthreads-30 --capmaxthreads 40 /capmaxthreads-40

NetWare POA Linux POA Windows POA

Syntax: /capport-port_number --capport port_number /capport-port_number

Example: /capport-1027 --capport 1028 /capport-1028

NetWare POA Linux POA Windows POA

Syntax: /capssl-setting --capssl setting /capssl-setting

Example: /capssl-enabled --capssl enabled /capssl-enabled
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See also /keyfile and /keypassword. 

39.8  /cluster
Informs the POA that it is running in a cluster. When the POA is clustered, the GroupWise client 
waits longer for reconnection. For information about clustering the POA, see the GroupWise 7 
Interoperability Guide.

If you are running the NetWare POA on the latest version of NetWare 6.x and Novell Cluster 
ServicesTM, the POA can detect the cluster automatically.

See also /ip.

39.9  /cpu
Sets the CPU utilization threshold for the NetWare® POA. The default is 85 per cent. See 
Section 38.5, “Optimizing CPU Utilization for the NetWare POA,” on page 562.

See also /sleep.

39.10  /dn
Specifies the Novell® eDirectoryTM distinguished name of the NetWare POA object to facilitate 
logging into remote servers. It can be used instead of the /user and /password switches.

NetWare POA Linux POA Windows POA

Syntax: /certfile-[svr\][vol:]\dir\file
/certfile-\\svr\vol\dir\file

--certfile /dir/file /certfile-[drive:]\dir\file
/certfile-\\svr\sharename\dir\file

Example: /certfile-\ssl\gw.crt
/certfile-server2\sys:\ssl\gw.crt
/certfile-\\server2\sys\ssl\gw.crt

--certfile /certs/gw.crt /certfile-\ssl\gw.crt
/certfile-m:\ssl\gw.crt
certfile-\\server2\c\ssl\gw.crt

NetWare POA Linux POA Windows POA

Syntax: /cluster --cluster N/A

NetWare POA Linux POA Windows POA

Syntax: /cpu-percentage N/A N/A

Example: /cpu-55 N/A N/A

NetWare POA Linux POA Windows POA

Syntax: /dn-distinguished_name N/A N/A

Example: /dn-POA.sales.provo2 N/A N/A
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39.11  /enforceclientversion
Enforces the minimum client release version and/or date so that users of older clients are forced to 
update in order to access their GroupWise® mailboxes. Valid settings are version, date, both, and 
disabled. See Section 36.2.6, “Checking What GroupWise Clients Are in Use,” on page 492.

See also /gwclientreleasedate, and /gwclientreleaseversion.

39.12  /evocontrol
Determines which versions of Evolution are allowed to access the post office. Users might 
experience problems using Evolution to connect to their GroupWise mailboxes if they are using 
Evolution 2.6.0 or earlier. In addition, earlier versions of Evolution can cause high utilization on 
GroupWise servers. To encourage users to update to the latest version of Evolution, you can use the 
/evocontrol switch to configure the POA to allow only specified versions of Evolution. For 
information about configuring a post office to support Evolution, see Section 36.2.4, “Supporting 
SOAP Clients,” on page 491.

You can put as many as 10 entries in the startup file, so that you can list as many as 10 version of 
Evolution. Entries beyond 10 are ignored. You can view the current entries at the POA Web console 
with the other SOAP settings. The POA log file lists the settings in the Soap Session section.

39.13  /externalclientssl
Sets the availability of SSL communication between the POA and GroupWise clients that are 
running outside your firewall. Valid values are enabled, required, and disabled. See Section 36.3.3, 
“Securing the Post Office with SSL Connections to the POA,” on page 498.

NetWare POA Linux POA Windows POA

Syntax: /enforceclientversion-setting --enforceclientversion setting /enforceclientversion-setting

Exampl
e: 

/enforceclientversion-version --enforceclientversion date /enforceclientversion-both

NetWare POA Linux POA Windows POA

Syntax: /evocontrol-Evolution-
version.date

/evocontrol-Evolution-
Data-Server-version-
date

--evocontrol-Evolution-
version.date

--evocontrol-Evolution-Data-
Server-version-date

/evocontrol-Evolution-
version.date

/evocontrol-Evolution-Data-
Server-version-date

Example: /evocontrol-Evolution-
1.10-2006-12-04

/evocontrol-Evolution-
Data-Server-1.10-2006-
12-04

--evocontrol Evolution-1.10-
2006-12-04

--evocontrol Evolution-Data-
Server-1.10-2006-12-04

/evocontrol-Evolution-1.10-
2006-12-04

/evocontrol-Evolution-Data-
Server-1.10-2006-12-04

NetWare POA Linux POA Windows POA

Syntax: /externalclientssl-setting --externalclientssl setting /externalclientssl-setting
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See also /certfile, /keyfile, /keypassword, and /port. 

39.14  /gwchkthreads
Specifies the number of threads the POA starts for Mailbox/Library Maintenance activities. The 
default is 4; valid values range from 1 to 8. See Section 38.4.1, “Adjusting the Number of POA 
Threads for Database Maintenance,” on page 559.

See also /nogwchk.

39.15  /gwclientreleasedate
Specifies the date of the approved GroupWise client software for your system. See Section 36.2.6, 
“Checking What GroupWise Clients Are in Use,” on page 492.

See also /gwclientreleaseversion and /enforceclientversion.

39.16  /gwclientreleaseversion
Specifies the version of the approved GroupWise client software for your system. See 
Section 36.2.6, “Checking What GroupWise Clients Are in Use,” on page 492.

See also /gwclientreleasedate and /enforceclientversion.

Example: /externalclientssl-enabled --externalclientssl disabled /externalclientssl-required

NetWare POA Linux POA Windows POA

Syntax: /gwchkthreads-number --gwchkthreads number /gwchkthreads-number

Example: /gwchkthreads-5 --gwchkthreads 6 /gwchkthreads-8

NetWare POA Linux POA Windows POA

Syntax: /gwclientreleasedate-mm-dd-
yyyy

--gwclientreleasedate mm-
dd-yyyy

/gwclientreleasedate-mm-dd-
yyyy

Example
: 

/gwclientreleasedate-04-02-
2001

--gwclientreleasedate 04-28-
2004

/gwclientreleasedate-04-02-
2001

NetWare POA Linux POA Windows POA

Syntax: /gwclientreleaseversion-n.n.n --gwclientreleaseversion 
n.n.n

/gwclientreleaseversion-n.n.n

Example
: 

/gwclientreleaseversion-6.0.0 --gwclientreleaseversion 
6.5.1

/gwclientreleaseversion-6.0.0

NetWare POA Linux POA Windows POA
Using POA Startup Switches 573



574 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
39.17  /help
Displays the POA startup switch Help information. When this switch is used, the POA does not 
start.

39.18  /home
Specifies the post office directory, where the POA can find the message and user databases to 
service. There is no default location. You must use this switch in order to start the POA.

39.19  /httppassword
Specifies the password for the POA to prompt for before allowing POA status information to be 
displayed in your Web browser. Do not use an existing eDirectory password because the information 
passes over the insecure connection between your Web browser and the POA. See Section 37.2, 
“Using the POA Web Console,” on page 530.

See also /httpuser, /httpport, /httprefresh, and /httpssl. 

39.20  /httpport
Sets the HTTP port number used for the POA to communicate with your Web browser. The default 
is 7181; the setting must be unique. See Section 37.2, “Using the POA Web Console,” on page 530.

NetWare POA Linux POA Windows POA

Syntax: /help or /? --help /help or /?

Example: load gwpoa /help ./gwpoa --help gwpoa.exe /help

NetWare POA Linux POA Windows POA

Syntax: /home-[svr\][vol:]\dir
/home-\\svr\vol\dir

--home /dir /home-[drive:]\dir
/home-\\svr\sharename\dir

Example: /home-\sales
/home-mail:\sales
/home-server2\mail:\sales
/home-\\server2\mail\sales

--home /gwsystem/sales /home-\sales
/home-m:\sales
/home-\\server2\c\sales

NetWare POA Linux POA Windows POA

Syntax: /httppassword-
unique_password

--httppassword 
unique_password

/httppassword-
unique_password

Exampl
e: 

/httppassword-AgentWatch --httppassword AgentWatch /httppassword-AgentWatch

NetWare POA Linux POA Windows POA

Syntax: /httpport-port_number --httpport port_number /httpport-port_number
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See also /httpuser, /httppassword, /httprefresh, and /httpssl.

39.21  /httprefresh
Specifies the rate at which the POA refreshes the status information in your Web browser. The 
default is 60 seconds. See Section 37.2, “Using the POA Web Console,” on page 530.

See also /httpuser, /httppassword, /httpport, and /httpssl. 

39.22  /httpssl
Sets the availability of secure SSL communication between the POA and the POA Web console 
displayed in your Web browser. Valid values are enabled and disabled. See Section 36.3.3, 
“Securing the Post Office with SSL Connections to the POA,” on page 498.

See also /certfile, /keyfile, and /keypassword. 

39.23  /httpuser
Specifies the username for the POA to prompt for before allowing POA status information to be 
displayed in a Web browser. Providing a username is optional. Do not use an existing eDirectory 
username because the information passes over the insecure connection between your Web browser 
and the POA. See Section 37.2, “Using the POA Web Console,” on page 530.

See also /httppassword, /httpport, /httprefresh, and /httpssl.

Example: /httpport-7182 --httpport 7183 /httpport-7184

NetWare POA Linux POA Windows POA

Syntax: /httprefresh-seconds --httprefresh seconds /httprefresh-seconds

Example: /httprefresh-30 --httprefresh 90 /httprefresh-120

NetWare POA Linux POA Windows POA

Syntax: /httpssl-setting --httpssl setting /httpssl-setting

Example: /httpssl-enabled --httpssl enabled /httpssl-enabled

NetWare POA Linux POA Windows POA

Syntax: /httpuser-unique_name --httprefresh unique_name /httprefresh-unique_name

Example: /httpuser-GWWebCon --httpuser GWWebCon /httpuser-GWWebCon

NetWare POA Linux POA Windows POA
Using POA Startup Switches 575



576 GroupWise 

novdocx (en)  11 D
ecem

ber 2007
39.24  /imap
Enables IMAP so that the POA can communicate with IMAP clients. Valid settings are enabled and 
disabled. See Section 36.2.3, “Supporting IMAP Clients,” on page 490.

See also /imapmaxthreads, /imapport, /imapssl, /imapsslport, and /imapreadlimit. 

39.25  /imapmaxthreads
Specifies the maximum number of IMAP threads the POA can create to service IMAP clients. The 
default is 40. This setting is appropriate for most systems. See Section 36.2.3, “Supporting IMAP 
Clients,” on page 490.

See also /imap, /imapport, /imapssl, /imapsslport, and /imapreadlimit.

39.26  /imapreadlimit
Specifies in thousands the maximum number of messages that can be downloaded by an IMAP 
client. For example, specifying 10 represents 10,000. The default is 20,000.

See also /imap, /imapmaxthreads, /imapport, /imapssl, and /imapsslport.

39.27  /imapport
Sets the TCP port number used for the POA to communicate with IMAP clients when using a non-
SSL connection. The default is 143. See Section 36.2.3, “Supporting IMAP Clients,” on page 490.

NetWare POA Linux POA Windows POA

Syntax: /imap-enabled or disabled --imap enabled or disabled /imap-enabled or disabled

Example: /imap-enabled --imap disabled /imap-enabled

NetWare POA Linux POA Windows POA

Syntax: /imapmaxthreads-number --imapmaxthreads number /imapmaxthreads-number

Example: /imapmaxthreads-40 --imapmaxthreads 30 /imapmaxthreads-40

NetWare POA Linux POA Windows POA

Syntax: /imapreadlimit-number --imapreadlimit number /imapreadlimit-number

Example: /imapreadlimit-10 --imapreadlimit 20 /imapreadlimit-50

NetWare POA Linux POA Windows POA

Syntax: /imapport-port_number --imapport port_number /imapport-port_number

Example: /imapport-145 --imapport 146 /imapport-147
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See also /imap, /imapmaxthreads, /imapssl, /imapsslport, and /imapreadlimit.

39.28  /imapssl
Sets the availability of secure SSL communication between the POA and IMAP clients. Valid 
settings are enable and disable. See Section 36.3.3, “Securing the Post Office with SSL Connections 
to the POA,” on page 498.

See also /imap, /imapmaxthreads, /imapport, /imapsslport, and /imapreadlimit.

39.29  /imapsslport
Sets the TCP port number used for the POA to communicate with IMAP clients when using an SSL 
connection. The default is 993. See Section 36.2.3, “Supporting IMAP Clients,” on page 490.

See also/imap, /imapmaxthreads, /imapport, /imapssl, and /imapreadlimit.

39.30  /incorrectloginattempts
Specifies the number of unsuccessful login attempts after which lockout occurs. The default is 5 
attempts; valid values range from 3 to 10. See Section 36.3.5, “Enabling Intruder Detection,” on 
page 506.

See also /intruderlockout, /attemptsresetinterval, and /lockoutresetinterval.

39.31  /internalclientssl
Sets the availability of secure SSL communication between the POA and GroupWise clients that are 
running inside your firewall. Valid values are enabled, required, and disabled. See Section 36.3.3, 
“Securing the Post Office with SSL Connections to the POA,” on page 498.

NetWare POA Linux POA Windows POA

Syntax: /imapssl-setting --imapssl setting /imapssl-setting

Example: /imapssl-enable --imapssl enable /imapssl-enable

NetWare POA Linux POA Windows POA

Syntax: /imapsslport-port_number --imapsslport port_number /imapsslport-port_number

Example: /imapsslport-994 --imapsslport 995 /imapsslport-996

NetWare POA Linux POA Windows POA

Syntax: /incorrectloginattempts-
number

--incorrectloginattempts 
number

/incorrectloginattempts-
number

Exampl
e: 

/incorrectloginattempts-3 --incorrectloginattempts 10 /incorrectloginattempts-10
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See also /certfile, /keyfile, /keypassword, and /port. 

39.32  /intruderlockout
Turns on intruder lockout processing, using defaults that can be overridden by the /
incorrectloginattempts, /attemptsresetinterval, and /lockoutresetinterval switches. See 
Section 36.3.5, “Enabling Intruder Detection,” on page 506.

39.33  /ip
Binds the POA to a specific IP address when the server where it runs uses multiple IP addresses, 
such as in a clustering environment. The specified IP address is associated with all ports used by the 
POA (HTTP, IMAP, LDAP, and so on.) Without the /ip switch, the POA binds to all available IP 
addresses and users can access the post office through all available IP addresses. See Section 36.1.4, 
“Binding the POA to a Specific IP Address,” on page 483.

See also “Editing Clustered Agent Startup Files” in “Novell Cluster Services on NetWare” in the 
GroupWise 7 Interoperability Guide.

See also /cluster.

39.34  /keyfile
Specifies the full path to the private file used to provide secure SSL communication between the 
POA and other programs. See Section 36.3.3, “Securing the Post Office with SSL Connections to 
the POA,” on page 498.

NetWare POA Linux POA Windows POA

Syntax: /internalclientssl-setting --internalclientssl setting /internalclientssl-setting

Example: /internalclientssl-enabled --internalclientssl required /internalclientssl-required

NetWare POA Linux POA Windows POA

Syntax: /intruderlockout --intruderlockout /intruderlockout

NetWare POA Linux POA Windows POA

Syntax: /ip-IP_address
/ip-”full_DNS_name”

--ip IP_address
--ip ”full_DNS_name”

/ip-IP_address
/ip-”full_DNS_name”

Example
: 

/ip-172.16.5.18
/ip-”poasvr.provo.novell.com”

--ip 172.16.5.18
--ip ”poasvr.provo.novell.com”

/ip-172.16.5.18
/ip-”poasvr.provo.novell.com”

NetWare POA Linux POA Windows POA

Syntax: /keyfile-[svr\][vol:]\dir\file
/keyfile-\\svr\vol\dir\file

--keyfile /dir/file /keyfile-[drive:]\dir\file
/keyfile-\\svr\sharename\dir\file
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See also /certfile and /keypassword. 

39.35  /keypassword
Specifies the password used to encrypt the private SSL key file when it was created. See 
Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on page 498.

See also /certfile and /keyfile. 

39.36  /language
Specifies the language to run the POA in, using a two-letter language code as listed below. You must 
install the POA in the selected language in order for the POA to display in the selected language.

The initial default is the language used in the post office. If that language has not been installed, the 
second default is the language used by the operating system. If that language has not been installed, 
the third default is English. You only need to use this switch if you need to override these defaults.

The table below lists the valid language codes. Contact your local Novell sales office for 
information about language availability.

Example: /keyfile-\ssl\gw.key
/keyfile-server2\sys:\ssl\gw.key
/keyfile-\\server2\sys\ssl\gw.key

--keyfile /certs/gw.key /keyfile-\ssl\gw.key
/keyfile-m:\ssl\gw.key
/keyfile-\\server2\c\ssl\gw.key

NetWare POA Linux POA Windows POA

Syntax: /keypassword-password --keypassword password /keypassword-password

Example: /keypassword-gwssl --keypassword gwssl /keypassword-gwssl

NetWare POA Linux POA Windows POA

Syntax: /language-code --language code /language-code

Example: /language-de --language de /language-fr

Language Language
Code Language Language

Code

Arabic AR Hungarian MA

Chinese-Simplified CS Italian IT

Chinese-Traditional CT Japanese NI

Czechoslovakian CZ Korean KR

Danish DK Norwegian NO

Dutch NL Polish PL

NetWare POA Linux POA Windows POA
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For more information, see Chapter 7, “Multilingual GroupWise Systems,” on page 105.

39.37  /ldapdisablepwdchg
Prevents GroupWise users from changing their LDAP passwords by using the Password dialog box 
in the GroupWise client. See Section , “Enabling LDAP Authentication for a Post Office,” on 
page 503.

See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapssl, /ldapsslkey, and 
/ldaptimeout.

39.38  /ldapipaddr
Specifies the LDAP server’s network address as either an IP address or a DNS hostname. You can 
specify multiple network addresses to provide failover capabilities for your LDAP servers. See 
Section , “Specifying Failover LDAP Servers (Non-SSL Only),” on page 505.

If you specify multiple LDAP servers, use a space between each address. When so configured, the 
POA tries to contact the first LDAP server in order to authenticate a user to GroupWise. If that 
LDAP server is down, the POA tries the next LDAP server in the list, and so on until it is able to 
authenticate.

See also /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, /
ldapsslkey, and /ldaptimeout.

English-United States US Portuguese-Brazil BR

Finnish SU Russian RU

French-France FR Spanish ES

German-Germany DE Swedish SV

Hebrew HE

NetWare POA Linux POA Windows POA

Syntax: /ldapdisablepwdchg --ldapdisablepwdchg /ldapdisablepwdchg

NetWare POA Linux POA Windows POA

Syntax: /ldapipaddr-network_address --ldapipaddr 
network_address

/ldapipaddr-network_address

Example
: 

/ldapipaddr-172.16.5.18
/ldapipaddr-server1 server2

--ldapipaddr 172.16.5.19
--ldapipaddr server1 server2

/ldapipaddr-172.16.5.20
/ldapipaddr-server1 server2

Language Language
Code Language Language

Code
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39.39  /ldapippooln
Specifies a pooled LDAP server’s network address as either an IP address or a DNS hostname. As 
many as five LDAP servers can participate together as a pool; therefore, n ranges from 1 to 5. See 
“Configuring a Pool of LDAP Servers” on page 504.

See also /ldapportpooln, /ldapsslpooln, /ldapsslkeypooln, and /ldappoolresettime.

39.40  /ldappoolresettime
Specifies the number of minutes between the time when the POA receives an error response from a 
pooled LDAP server and the time when that LDAP server is reinstated into the pool of available 
LDAP servers. The default is 5 minutes; valid values range from 1 to 30. See “Configuring a Pool of 
LDAP Servers” on page 504.

See also /ldapippooln, /ldapportpooln, /ldapsslpooln, and /ldapsslkeypooln.

39.41  /ldapport
Specifies the port number that the LDAP server listens on for authentication. The default is 389. See 
Section 36.3.4, “Providing LDAP Authentication for GroupWise Users,” on page 501.

See also /ldapipaddr, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, /
ldapsslkey, and /ldaptimeout.

39.42  /ldapportpooln
Specifies the port number that pooled LDAP server n listens on for authentication. The default is 
389. See “Configuring a Pool of LDAP Servers” on page 504.

NetWare POA Linux POA Windows POA

Syntax: /ldapippooln-network_address --ldapippooln 
network_address

/ldapippooln-network_address

Example
: 

/ldapippool1-172.16.5.18
/ldapippool2-server1
/ldapippool3-172.16.5.19

--ldapippool1 172.16.5.18
--ldapippool2 server1
--ldapippool3 172.16.5.19

/ldapippool1-172.16.5.18
/ldapippool2-server1
/ldapippool3-172.16.5.19

NetWare POA Linux POA Windows POA

Syntax: /ldappoolresettime-minutes --ldappoolresettime minutes /ldappoolresettime-minutes

Example: /ldappoolresettime-10 --ldappoolresettime 20 /ldappoolresettime-30

NetWare POA Linux POA Windows POA

Syntax: /ldapport-port_number --ldapport port_number /ldapport-port_number

Example: /ldapport-390 --ldapport 391 /ldapport-392
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See also /ldapippooln, /ldappoolresettime, /ldapsslpooln, and /ldapsslkeypooln.

39.43  /ldappwd
Provides the password for the LDAP user that the POA uses to log in to the LDAP server. See 
Section 36.3.4, “Providing LDAP Authentication for GroupWise Users,” on page 501.

See also /ldapipaddr, /ldapport, /ldapuser, /ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, /
ldapsslkey, and /ldaptimeout.

39.44  /ldapssl
Indicates to the POA that the LDAP server it is logging in to is using SSL. See Section 36.3.4, 
“Providing LDAP Authentication for GroupWise Users,” on page 501.

See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
ldapsslkey and /ldaptimeout.

39.45  /ldapsslpooln
Indicates to the POA that the pooled LDAP server it is logging in to is using SSL. See “Configuring 
a Pool of LDAP Servers” on page 504.

See also /ldapippooln, /ldapportpooln, /ldappoolresettime, and /ldapsslkeypooln.

NetWare POA Linux POA Windows POA

Syntax: /ldapportpooln-port --ldapportpooln port /ldapportpooln-port

Example: /ldapportpool2-390 --ldapportpool3 391 /ldapportpool4-392

NetWare POA Linux POA Windows POA

Syntax: /ldappwd-LDAP_password --ldappwd LDAP_password /ldappwd-LDAP_password

Example: /ldappwd-gwldap --ldappwd gwldap /ldappwd-gwldap

NetWare POA Linux POA Windows POA

Syntax: /ldapssl --ldapssl /ldapssl

NetWare POA Linux POA Windows POA

Syntax: /ldapsslpooln --ldapsslpooln /ldapsslpooln

Example: /ldapsslpool2 --ldapsslpool3 /ldapsslpool4
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39.46  /ldapsslkey
Specifies the full path to the SSL key file used with LDAP authentication. See Section 36.3.4, 
“Providing LDAP Authentication for GroupWise Users,” on page 501.

See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
ldapssl and /ldaptimeout.

39.47  /ldapsslkeypooln
Specifies the full path to the SSL key file used with pooled LDAP server n for authentication. See 
“Configuring a Pool of LDAP Servers” on page 504.

See also /ldapippooln, /ldapportpooln, /ldappoolresettime, and /ldapsslpooln.

39.48  /ldaptimeout
Specifies the number of seconds that the POA connection to the LDAP server can be idle before the 
POA drops the connection. The default is 30 seconds. See Section 36.3.4, “Providing LDAP 
Authentication for GroupWise Users,” on page 501.

NetWare POA Linux POA Windows POA

Syntax: /ldapsslkey-[svr\][vol:]\dir\file
/ldapsslkey-\\svr\vol\dir\file

--ldapsslkey /dir/file /ldapsslkey-[drive:]\dir\file
/ldapsslkey-

\\svr\sharename\dir\file

Example
: 

/ldapsslkey-\ldap\gwkey.der
/ldapsslkey-

server2\sys:\ldap\gwkey.der
/ldapsslkey-

\\server2\sys\ldap\gwkey.der

--ldapsslkey /certs/
gwkey.der

/ldapsslkey-\ldap\gwkey.der
/ldapsslkey-m:\ldap\gwkey.der
/ldapsslkey-

\\server2\c\ldap\gwkey.der

NetWare POA Linux POA Windows POA

Syntax: /ldapsslkeypooln-
[svr\][vol:]\dir\file

/ldapsslkeypooln-
\\svr\vol\dir\file

--ldapsslkeypooln-/dir/file /ldapsslkeypooln-[drive:]\dir\file
/ldapsslkeypooln-

\\svr\sharename\dir\file

Example
: 

/ldapsslkeypool4-
\ldap\gwkey.der

/ldapsslkeypool4-
svr2\sys:\ldap\gwkey.der

/ldapsslkeypool4-
\\svr2\sys\ldap\gwkey.der

--ldapsslkeypool4 /certs/
gwkey.der

/ldapsslkeypool4-
\ldap\gwkey.der

/ldapsslkeypool4-
m:\ldap\gwkey.der

/ldapsslkeypool4-
\\svr2\c\ldap\gwkey.der

NetWare POA Linux POA Windows POA

Syntax: /ldaptimeout-seconds --ldaptimeout seconds /ldaptimeout-seconds

Example: /ldaptimeout-60 --ldaptimeout 70 /ldaptimeout-80
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See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
ldapssl, and /ldapsslkey.

39.49  /ldapuser
Specifies the username that the POA can use to log in to the LDAP server in order to authenticate 
GroupWise client users. See Section 36.3.4, “Providing LDAP Authentication for GroupWise 
Users,” on page 501.

See also /ldapipaddr, /ldapport, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, and /
ldapsslkey, and /ldaptimeout.

39.50  /ldapuserauthmethod
Specifies the LDAP user authentication method you want the POA to use when accessing an LDAP 
server. Valid settings are bind and compare. See Section 36.3.4, “Providing LDAP Authentication 
for GroupWise Users,” on page 501.

See also /ldapuser, /ldapipaddr, /ldapport, /ldappwd, /ldapdisablepwdchg, /ldapssl, and /ldapsslkey, 
and /ldaptimeout.

39.51  /lockoutresetinterval
Specifies the length of time the user login is disabled after lockout. The default is 30 minutes; the 
minimum setting is 15; there is no maximum setting. The login can also be manually re-enabled in 
ConsoleOne in the GroupWise Account page of the User object. If /lockoutresetinterval is set to 0 
(zero), the login must be re-enabled manually through ConsoleOne. See Section 36.3.5, “Enabling 
Intruder Detection,” on page 506.

See also /intruderlockout, /incorrectloginattempts, and /attemptsresetinterval.

NetWare POA Linux POA Windows POA

Syntax: /ldapuser-LDAP_user_ID --ldapuser LDAP_user_ID /ldapuser-LDAP_user_ID

Example: /ldapuser-GWAuth --ldapuser GWAuth /ldapuser-GWAuth

NetWare POA Linux POA Windows POA

Syntax: /ldapuserauthmethod-
method

--ldapuserauthmethod method /ldapuserauthmethod-method

Example
: 

/ldapuserauthmethod-bind --ldapuserauthmethod bind /ldapuserauthmethod-
compare

NetWare POA Linux POA Windows POA

Syntax: /lockoutresetinterval-minutes --lockoutresetinterval minutes /lockoutresetinterval-minutes

Exampl
e: 

/lockoutresetinterval-15 --lockoutresetinterval 60 /lockoutresetinterval-90
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39.52  /log
Specifies the directory where the POA stores its log files. The default location varies by platform.

For more information, see Section 37.3, “Using POA Log Files,” on page 538. 

Typically you would find multiple log files in the specified directory. The first 4 characters represent 
the date. The next 3 characters identify the agent. A three-digit extension allows for multiple log 
files created on the same day. For example, a log file named 0518poa.001 would indicate that it 
is a POA log file, created on May 18. If you restarted the POA on the same day, a new log file would 
be started, named 0518poa.002.

See also /loglevel, /logdiskoff, /logdays, and /logmax.

39.53  /logdays
Specifies how many days to keep POA log files on disk. The default is 7 days. See Section 37.3, 
“Using POA Log Files,” on page 538. 

See also /log, /loglevel, /logdiskoff, and /logmax.

39.54  /logdiskoff
Turns off disk logging for the POA so no information about the functioning of the POA is stored on 
disk. The default is for logging to be turned on. See Section 37.3, “Using POA Log Files,” on 
page 538. 

NetWare: post_office\wpcsout\ofs

Linux: /var/log/novell/groupwise/post_office_name.poa

Windows: post_office\wpcsout\ofs

NetWare POA Linux POA Windows POA

Syntax: /log-[svr\][vol:]\dir
/log-\\svr\vol\dir

--log /dir /log-[drive:]\dir
/log-\\svr\sharename\dir

Example: /log-\agt\log
/log-\\server2\mail:\agt\log
/log-\\server2\mail\agt\log

--log /gwsystem/logs /log-\agt\log
/log-m:\agt\log
/log-\\server2\c\mail\agt\log

NetWare POA Linux POA Windows POA

Syntax: /logdays-days --logdays days /logdays-days

Example: /logdays-5 --logdays 10 /logdays-14

NetWare POA Linux POA Windows POA

Syntax: /logdiskoff --logdiskoff /logdiskoff
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See also /loglevel. 

39.55  /loglevel
Controls the amount of information logged by the POA. Logged information is displayed in the log 
message box and written to the POA log file during the current agent session. The default is Normal, 
which displays only the essential information suitable for a smoothly running POA. Use Verbose to 
display the essential information, plus additional information helpful for troubleshooting. Verbose 
logging does not degrade POA performance, but log files saved to disk consume more disk space 
when verbose logging is in use. See Section 37.3, “Using POA Log Files,” on page 538. 

See also /log, /logdiskoff, /logdays, and /logmax.

39.56  /logmax
Sets the maximum amount of disk space for all POA log files. When the specified disk space is 
consumed, the POA deletes existing log files, starting with the oldest. The default is 65536 KB (100 
MB). See Section 37.3, “Using POA Log Files,” on page 538. 

See also /log, /loglevel, /logdiskoff, and /logdays.

39.57  /maxappconns
Sets the maximum number of application connections allowed between the POA and the GroupWise 
clients run by GroupWise users. The default maximum number of application connections is 2048. 
See Section 38.1.2, “Adjusting the Number of Connections for Client/Server Processing,” on 
page 549.

See also /maxphysconns. 

NetWare POA Linux POA Windows POA

Syntax: /loglevel-level --loglevel level /loglevel-level

Example: /loglevel-verbose --loglevel verbose /loglevel-verbose

NetWare POA Linux POA Windows POA

Syntax: /logmax-kilobytes --logmax kilobytes /logmax-kilobytes

Example: /logmax-32000 --logmax 130000 /logmax-16000

NetWare POA Linux POA Windows POA

Syntax: /maxappconns-number --maxappconns number /maxappconns-number

Example: /maxappconns-3072 --maxappconns 4096 /maxappconns-5120
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39.58  /maxphysconns
Sets the maximum number of physical TCP/IP connections allowed between the POA and the 
GroupWise clients run by GroupWise users. The default maximum number of physical connections 
is 1024. See Section 38.1.2, “Adjusting the Number of Connections for Client/Server Processing,” 
on page 549.

See also /maxappconns. 

39.59  /mtpinipaddr
Specifies the network address of the server where the POA runs, as either an IP address or a DNS 
hostname. See Section , “Using TCP/IP Links between the Post Office and the Domain,” on 
page 481.

See also /mtpinport, /mtpoutipaddr, /mtpoutport, /mtpsendmax, and /nomtp.

39.60  /mtpinport
Sets the message transfer port number the POA listens on for messages from the MTA. The default 
is 7101. See Section , “Using TCP/IP Links between the Post Office and the Domain,” on page 481.

See also /mtpinipaddr, /mtpoutipaddr, /mtpoutport, /mtpsendmax, and /nomtp.

39.61  /mtpoutipaddr
Specifies the network address of the server where the MTA for the domain runs, as either an IP 
address or a DNS hostname. See Section , “Using TCP/IP Links between the Post Office and the 
Domain,” on page 481.

NetWare POA Linux POA Windows POA

Syntax: /maxphysconns-number --maxphysconns number /maxphysconns-number

Example: /maxphysconns-2048 --maxphysconns 4096 /maxphysconns-5120

NetWare POA Linux POA Windows POA

Syntax: /mtpinipaddr-network_addr --mtpinipaddr network_addr /mtpinipaddr-network_addr

Example: /mtpinipaddr-172.16.5.18

/mtpinipaddr-server1

--mtpinipaddr 172.16.5.19

--mtpinipaddr server2

/mtpinipaddr-172.16.5.20

/mtpinipaddr-server3

NetWare POA Linux POA Windows POA

Syntax: /mtpinport-port_number --mtpinport port_number /mtpinport-port_number

Example: /mtpinport-7201 --mtpinport 7202 /mtpinport-7203
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See also /mtpinipaddr, /mtpinport, /mtpoutport, /mtpsendmax, and /nomtp.

39.62  /mtpoutport
Specifies the message transfer port number the MTA listens on for messages from the POA. The 
default is 7100. See Section , “Using TCP/IP Links between the Post Office and the Domain,” on 
page 481.

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpsendmax, and /nomtp.

39.63  /mtpsendmax
Sets the maximum size in megabytes for messages being sent outside the post office. By default, 
messages of any size can be transferred to the MTA. See Section 36.2.8, “Restricting Message Size 
between Post Offices,” on page 495.

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, and /nomtp.

39.64  /mtpssl
Sets the availability of secure SSL communication between the POA and its MTA. Valid settings are 
enabled and disabled. See Section 36.3.3, “Securing the Post Office with SSL Connections to the 
POA,” on page 498.

NetWare POA Linux POA Windows POA

Syntax: /mtpoutipaddr-
network_address

--mtpoutipaddr 
network_address

/mtpoutipaddr-
network_address

Exampl
e: 

/mtpoutipaddr-172.16.5.18

/mtpoutipaddr-server2

--mtpoutipaddr 172.16.5.19

--mtpoutipaddr server3

/mtpoutipaddr-172.16.5.19

/mtpoutipaddr-server4

NetWare POA Linux POA Windows POA

Syntax: /mtpoutport-port_number --mtpoutport port_number /mtpoutport-port_number

Example: /mtpoutport-7200 --mtpoutport 7300 /mtpoutport-7400

NetWare POA Linux POA Windows POA

Syntax: /mtpsendmax-megabytes --mtpsendmax megabytes /mtpsendmax-megabytes

Example: /mtpsendmax-2 --mtpsendmax 4 /mtpsendmax-6

NetWare POA Linux POA Windows POA

Syntax: /mtpssl-setting --mtpssl setting /mtpssl-setting

Example: /mtpssl-enabled --mtpssl enabled /mtpssl-enabled
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See also /certfile, /keyfile and /keypassword. 

39.65  /name
Specifies the object name of the POA object in the post office. If you have multiple POAs 
configured for the same post office, you must use this switch to specify which POA configuration to 
use when the POA starts. Several useful configurations include multiple POAs for a single post 
office, as described in the following sections:

Section 38.1.3, “Configuring a Dedicated Client/Server POA,” on page 550
Section 38.2.2, “Configuring a Dedicated Message File Processing POA,” on page 553
Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556
Section 38.4.2, “Configuring a Dedicated Database Maintenance POA,” on page 560

39.66  /noada
Disables the POA admin thread. For an explanation of the POA admin thread, see Section , “POA 
Admin Thread Status Box,” on page 519.

The POA admin thread must run for at least one POA for each post office. However, it can be 
disabled for POAs with specialized functioning where the database update and repair activities of 
the POA admin thread could interfere with other, more urgent processing.

Historical Note: In GroupWise 5.2 and earlier, a separate agent, the Administration Agent (ADA), 
handled the functions now consolidated into the POA admin thread. Hence the switch name, /noada. 

39.67  /nocache
Disables database caching. The default is for caching to be turned on. Use this switch if your backup 
system cannot back up open files.

NetWare POA Linux POA Windows POA

Syntax: /name-object_name --name object_name /name-object_name

Example: /name-POA2 --name POA2 /name-POA2

NetWare POA Linux POA Windows POA

Syntax: /noada --noada /noada

NetWare POA Linux POA Windows POA

Syntax: /nocache --nocache /nocache
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39.68  /noconfig
Ignores any configuration information provided for the POA in ConsoleOne and uses only settings 
from the POA startup file. The default is for the POA to use the information provided in 
ConsoleOne, overridden as needed by settings provided in the startup file or on the command line.

39.69  /noerrormail
Prevents problem files from being sent to the GroupWise administrator. The default is for error mail 
to be sent to the administrator. See Section 37.7, “Notifying the GroupWise Administrator,” on 
page 544.

39.70  /nogwchk
Turns off Mailbox/Library Maintenance processing for the POA. The default is for the POA to 
perform Mailbox/Library Maintenance tasks requested from ConsoleOne and configured as POA 
scheduled events.

See also /gwchkthreads.

39.71  /noldapx
Configures the NetWare POA to look up users in eDirectory by their e-mail addresses instead of by 
their distinguished names. This allows LDAP authentication to be done against external trees. This 
is accomplished by preventing the LDAPX NLM from loading on the NetWare server where the 
POA is running

See also /ldapipaddr, /ldapport, /ldapuser, /ldappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
ldapssl, /ldapsslkey, and /ldaptimeout.

NetWare POA Linux POA Windows POA

Syntax: /noconfig --noconfig /noconfig

NetWare POA Linux POA Windows POA

Syntax: /noerrormail --noerrormail /noerrormail

NetWare POA Linux POA Windows POA

Syntax: /nogwchk --nogwchk /nogwchk

NetWare POA Linux POA Windows POA

Syntax: /noldapx N/A N/A
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39.72  /nomf
Turns off all message file processing for the POA. The default is for the POA to process all message 
files.

Two specialized configurations that require turning off message files are described in Section 38.1.3, 
“Configuring a Dedicated Client/Server POA,” on page 550 and Section 38.3.2, “Configuring a 
Dedicated Indexing POA,” on page 556.

See also /nomfhigh and /nomflow.

39.73  /nomfhigh
Turns off processing high priority messages files (message queues 0 and 1). For information about 
message queues, see “Post Office Directory” in GroupWise 7 Troubleshooting 3: Message Flow and 
Directory Structure.

See also /nomf and /nomflow.

39.74  /nomflow
Turns off processing lower priority messages files (message queues 2 through 7). For information 
about message queues, see “Post Office Directory” in GroupWise 7 Troubleshooting 3: Message 
Flow and Directory Structure.

See also /nomf and /nomfhigh.

39.75  /nomtp
Disables Message Transfer Protocol, so that a TCP/IP link cannot be used between the POA and the 
MTA. See Section 36.1.3, “Changing the Link Protocol between the Post Office and the Domain,” 
on page 481. 

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, and /mtpsendmax.

NetWare POA Linux POA Windows POA

Syntax: /nomf --nomf /nomf

NetWare POA Linux POA Windows POA

Syntax: /nomfhigh --nomfhigh /nomfhigh

NetWare POA Linux POA Windows POA

Syntax: /nomflow --nomflow /nomflow

NetWare POA Linux POA Windows POA

Syntax: /nomtp --nomtp /nomtp
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39.76  /nonuu
Disables nightly user upkeep. See Section 36.4.3, “Performing Nightly User Upkeep,” on page 513.

See also /nuuoffset.

39.77  /noqf
Disables the periodic QuickFinderTM indexing done by the POA. The default is for periodic indexing 
to be turned on. See Section 38.3.1, “Regulating Indexing,” on page 555.

See also /qfinterval, /qfintervalinminute, /qfbaseoffset, and /qfbaseoffsetinminute.

39.78  /nordab
Disables daily generation of the system Address Book for Remote users. See Section 36.4.3, 
“Performing Nightly User Upkeep,” on page 513. 

See also /rdaboffset.

39.79  /norecover
Disables automatic database recovery. The default is for automatic database recovery to be turned 
on. 

If the POA detects a problem with a database when automatic database recovery has been turned off, 
the POA notifies the administrator, but it does not recover the problem database. The administrator 
can then recover or rebuild the database as needed. See Chapter 26, “Maintaining Domain and Post 
Office Databases,” on page 377.

Two specialized configurations that require turning off automatic database recovery are described in 
Section 38.1.3, “Configuring a Dedicated Client/Server POA,” on page 550 and Section 38.3.2, 
“Configuring a Dedicated Indexing POA,” on page 556.

NetWare POA Linux POA Windows POA

Syntax: /nonuu --nonuu /nonuu

NetWare POA Linux POA Windows POA

Syntax: /noqf --noqf /noqf

NetWare POA Linux POA Windows POA

Syntax: /nordab --nordab /nordab

NetWare POA Linux POA Windows POA

Syntax: /norecover --norecover /norecover
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39.80  /nosnmp
Disables SNMP for the POA. The default is to have SNMP enabled. See Section 37.6, “Using an 
SNMP Management Console,” on page 540.

39.81  /notcpip
Disables TCP/IP communication for the POA. The default is to have TCP/IP communication 
enabled. Use this switch if you do not want this POA to communicate with GroupWise clients using 
TCP/IP. 

Two specialized configurations that require turning off automatic database recovery are described in 
Section 38.2.2, “Configuring a Dedicated Message File Processing POA,” on page 553 and 
Section 38.3.2, “Configuring a Dedicated Indexing POA,” on page 556.

39.82  /nuuoffset
Specifies the number of hours after midnight for the POA to start performing user upkeep. The 
default is 1 hour; valid values range from 0 to 23. See Section 36.4.3, “Performing Nightly User 
Upkeep,” on page 513. 

See also /nonuu.

39.83  /password
Provides the password for the POA to use when accessing post offices or document storage areas on 
remote servers. You can also provide user and password information on the Post Office Settings 
page in ConsoleOne.

NetWare POA Linux POA Windows POA

Syntax: /nosnmp --nosnmp /nosnmp

NetWare POA Linux POA Windows POA

Syntax: /notcpip --notcpip /notcpip

NetWare POA Linux POA Windows POA

Syntax: /nuuoffset-hours --nuuoffset hours /nuuoffset-hours

Example: /nuuoffset-2 --nuuoffset 3 /nuuoffset-4

NetWare POA Linux POA Windows POA

Syntax: /password-NetWare_password --password 
network_password

/password-
network_password

Example
: 

/password-GWise --password GWise /password-GWise
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See also /user and /dn.

39.84  /port
Sets the TCP port number used for the POA to communicate with GroupWise clients in client/server 
access mode. The default is 1677. See Section 36.2.1, “Using Client/Server Access to the Post 
Office,” on page 486.

See also /ip.

39.85  /primingmax
Sets the maximum number of TCP handler threads that POA can use for priming users’ Caching 
mailboxes. The default is 20 per cent. See Section 36.2.7, “Supporting Forced Mailbox Caching,” on 
page 494.

See also /tcpthreads.

39.86  /qfbaseoffset
Specifies the number of hours after midnight for the POA to start its indexing cycle as specified by 
the /qfinterval or /qfintervalinminute switch. The default is 20 hours (meaning at 8:00 p.m.); valid 
values range from 0 to 23. See Section 38.3.1, “Regulating Indexing,” on page 555.

See also /qfbaseoffsetinminute, /qfinterval, /qfintervalinminute, and /noqf.

39.87  /qfbaseoffsetinminute
Specifies the number of minutes after midnight for the POA to start its indexing cycle as specified 
by the /qfinterval or /qfintervalinminute switch. The default is 20 hours (1200 minutes, meaning at 
8:00 p.m.). The maximum setting is 1440 (24 hours). See Section 38.3.1, “Regulating Indexing,” on 
page 555.

NetWare POA Linux POA Windows POA

Syntax: /port-port_number --port port_number /port-port_number

Example: /port-1678 --port 1679 /port-1680

NetWare POA Linux POA Windows POA

Syntax: /primingmax-percentage --primingmax percentage /primingmax-percentage

Example: /primingmax-40 --primingmax 50 /primingmax-60

NetWare POA Linux POA Windows POA

Syntax: /qfbaseoffset-hours --qfbaseoffset hours /qfbaseoffset-hours

Example: /qfbaseoffset-1 --qfbaseoffset 2 /qfbaseoffset-3
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See also /qfbaseoffset, /qfinterval, /qfintervalinminute, and /noqf.

39.88  /qfdeleteold
Deletes previous versions of QuickFinder .idx and .inc files to conserve disk space during 
periods of heavy indexing. In general, it is applicable for use only with /qflevel=1, where indexing 
activities are a lower priority task that user activities in their mailboxes. See “Reclaiming Disk 
Space” on page 559.

See also /qflevel, /qfnolibs, /qfnopreproc, /qfnousers, /qfusefidbeg, and /qfuserfidend.

39.89  /qfinterval
Specifies the interval in hours for the POA to update the QuickFinder indexes in the post office. The 
default is 24 hours. See Section 38.3.1, “Regulating Indexing,” on page 555.

See also /qfbaseoffset, /qfbaseoffsetinminute, /qfintervalinminute, and /noqf.

39.90  /qfintervalinminute
Specifies the interval in minutes for the POA to update the QuickFinder indexes in the post office. 
The default is 24 hours (1440 minutes). See Section 38.3.1, “Regulating Indexing,” on page 555.

See also /qfinterval, /qfbaseoffset, /qfbaseoffsetinminute, and /noqf.

NetWare POA Linux POA Windows POA

Syntax: /qfbaseoffsetinminute-
minutes

--qfbaseoffsetinminute minutes /qfbaseoffsetinminute-minutes

Exampl
e: 

/qfbaseoffset-30 --qfbaseoffset 45 /qfbaseoffset-90

NetWare POA Linux POA Windows POA

Syntax: /qfdeleteold --qfdeleteold /qfdeleteold

NetWare POA Linux POA Windows POA

Syntax: /qfinterval-hours --qfinterval hours /qfinterval-hours

Example: /qfinterval-12 --qfinterval-6 /qfinterval-2

NetWare POA Linux POA Windows POA

Syntax: /qfintervalinminute-minutes --qfintervalinminute minutes /qfintervalinminute-minutes

Example: /qfintervalinminute-90 --qfintervalinminute 30 /qfintervalinminute-120
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39.91  /qflevel
Customizes the way the POA performs indexing. Valid levels are 0 through 3 and 999. See 
“Determining Indexing Priority” on page 558

The following table describes the functionality of each level:

Table 39-2   QuickFinder Indexing Priority Levels

See also /qfdeleteold, /qfnolibs, /qfnopreproc, /qfnousers, /qfusefidbeg, and /qfuserfidend.

39.92  /qfnolibs
Suppresses QuickFinder indexing of documents in libraries in favor of indexing user mailbox 
contents. For full suppression, use /qfnopreproc as well. See “Determining What to Index” on 
page 558

See also /qfdeleteold, /qflevel, /qfnopreproc, /qfnousers, /qfusefidbeg, and /qfuserfidend.

NetWare POA Linux POA Windows POA

Syntax: /qflevel-level --qflevel level /qflevel-level

Example: /qflevel-1 --qflevel 3 /qflevel-999

Priority Level Description

0 Index a maximum of 1000 items at a time, rather than the default of 500.

1 Index a maximum of 500 items at time using a low priority thread. This keeps frequent 
daytime indexing cycles from interfering with users’ activities in their mailboxes.

2 Index a maximum of 1000 items at a time using a medium priority thread. This allows 
additional items in each database to be processed in each indexing cycle. Use of a 
medium priority thread makes indexing more important than some user activities in their 
mailboxes. Users might notice some slowness in response from the GroupWise client.

3 Index a maximum of 2000 items at a time using a high priority thread. Use of a high 
priority thread makes indexing more important than many users activities in their 
mailboxes. Users will notice some slowness in response from the GroupWise client. 
This is warranted only when the completion of the indexing immediately is extremely 
important.

999 Index constantly until all databases have been indexed, then wait until the next indexing 
cycle set on the QuickFinder property page of the POA object before starting to index 
again.

NetWare POA Linux POA Windows POA

Syntax: /qfnolibs --qfnolibs /qfnolibs
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39.93  /qfnopreproc
Suppresses generation of document word lists that are normally written to user databases when 
libraries are indexed. Use with /qfnolibs. See “Determining What to Index” on page 558.

See also /qfdeleteold, /qflevel, /qfnolibs, /qfnousers, /qfusefidbeg, and /qfuserfidend.

39.94  /qfnousers
Suppresses QuickFinder indexing of user mailbox box contents in favor of indexing documents in 
libraries. See “Determining What to Index” on page 558.

See also /qfdeleteold, /qflevel, /qfnolibs, /qfnopreproc, /qfusefidbeg, and /qfuserfidend.

39.95  /qfuserfidbeg
Specifies the beginning of a range of FIDs associated with user databases (userxxx.db) that you 
want to index. The xxx in the user database filename is the FID. To determine what FIDs are in use, 
list the contents of the ofuser directory in the post office directory. See “Determining What to 
Index” on page 558.

See also /qfdeleteold, /qflevel, /qfnolibs, /qfnopreproc, /qfnousers, and /qfuserfidend.

39.96  /qfuserfidend
Specifies the end of a range of FIDs associated with user databases (userxxx.db) that you want 
to index. The xxx in the user database filename is the FID. To determine what FIDs are in use, list the 
contents of the ofuser directory in the post office directory. See “Determining What to Index” on 
page 558.

NetWare POA Linux POA Windows POA

Syntax: /qfnopreproc --qfnopreproc /qfnopreproc

NetWare POA Linux POA Windows POA

Syntax: /qfnousers --qfnousers /qfnouser

NetWare POA Linux POA Windows POA

Syntax: /qfuserfidbeg-fid --qfuserfidbeg fid /qfuserfidbeg-fid

Example: /qfuserfidbeg-4l7 --qfuserfidbeg 7ck /qfuserfidbeg-7j6

NetWare POA Linux POA Windows POA

Syntax: /qfuserfidend-fid --qfuserfidend fid /qfuserfidend-fid

Example: /qfuserfidbeg-u5p --qfuserfidbeg x9c /qfuserfidbeg-zzf
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If you want to index just one user database, use the same FID with the /qfuserfidbeg switch and the /
qfuserfidend switch. To determine a user’s FID, click Help > About GroupWise in the GroupWise 
client. In Online mode, the FID is displayed after the username. In Caching or Remote mode, the 
FID is the last three characters of the Caching or Remote directory (for example, 
c:\novell\groupwise\gwstr7bh).

See also /qfdeleteold, /qflevel, /qfnolibs, /qfnopreproc, /qfnousers, and /qfuserfidbeg.

39.97  /rdaboffset
Specifies the number of hours after midnight for the POA to generate the daily copy of the system 
Address Book for Remote users. The default is 0; valid values range from 0 to 23. See 
Section 36.4.3, “Performing Nightly User Upkeep,” on page 513.

See also /nordab.

39.98  /rights
Verifies that the POA has the required network rights or permissions to all directories where it needs 
access in the post office directory.

When started with this switch, the POA lists directories it is checking, which can be a lengthy 
process. Use this switch on an as needed basis, not in the POA startup file. If the POA encounters 
inadequate rights or permissions, it indicates the problem and shuts down.

39.99  --show
Starts the Linux POA with a server console interface similar to that provided for the NetWare and 
Windows POAs. This user interface requires that the X Window System and Open Motif be running 
on the Linux server. 

The --show switch cannot be used in the POA startup file. Therefore, the POA never runs with a user 
interface if it is started automatically whenever the server restarts.

NetWare POA Linux POA Windows POA

Syntax: /rdaboffset-hours --rdaboffset hours /rdaboffset-hours

Example: /rdaboffset-2 --rdaboffset 3 /rdaboffset-4

NetWare POA Linux POA Windows POA

Syntax: /rights --rights /rights

NetWare POA Linux POA Windows POA

Syntax: N/A --show N/A
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39.100  /sleep
Sets how long NetWare POA threads remain dormant when the CPU utilization threshold has been 
exceeded. The default is 100 milliseconds. See Section 38.5, “Optimizing CPU Utilization for the 
NetWare POA,” on page 562.

See also /cpu.

39.101  /soap
Enables SOAP so that the POA can communicate with SOAP clients. Valid settings are enabled and 
disabled. See Section 36.2.4, “Supporting SOAP Clients,” on page 491.

See also /soapmaxthreads, /soapport, /soapsizelimit, soapssl, and /soapthreads. 

39.102  /soapmaxthreads
Specifies the maximum number of SOAP threads the POA can create to service SOAP clients. The 
default is 6; the maximum is 20. This setting is appropriate for most systems. See Section 36.2.4, 
“Supporting SOAP Clients,” on page 491.

See also /soap, /soapport, /soapsizelimit, soapssl, and /soapthreads.

39.103  /soapport
Sets the TCP port number used for the POA to communicate with SOAP clients. The default is 
7191. See Section 36.2.4, “Supporting SOAP Clients,” on page 491.

NetWare POA Linux POA Windows POA

Syntax: /sleep-milliseconds N/A N/A

Example: /sleep-300 N/A N/A

NetWare POA Linux POA Windows POA

Syntax: /soap-enabled or disabled --soap enabled or disabled /soap-enabled or disabled

Example: /soap-enabled --soap enabled /soap-disabled

NetWare POA Linux POA Windows POA

Syntax: /soapmaxthreads-number --soapmaxthreads number /soapmaxthreads-number

Example: /soapmaxthreads-5 --soapmaxthreads 10 /soapmaxthreads-20

NetWare POA Linux POA Windows POA

Syntax: /soapport-port_number --soapport port_number /soapport-port_number

Example: /soapport-145 --soapport 146 /soapport-147
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See also /soap, /soapmaxthreads, /soapsizelimit, soapssl, and /soapthreads.

39.104  /soapsizelimit
Sets the maximum amount of data that the POA can return in a single request from a SOAP client. 
The default is 1024 KB (1 MB), which is the recommended setting.

See also /soap, /soapmaxthreads, /soapport, soapssl, and /soapthreads.

39.105  /soapssl
Sets the availability of secure SSL communication between the POA and SOAP clients. Valid 
settings are enable and disable. See Section 36.3.3, “Securing the Post Office with SSL Connections 
to the POA,” on page 498.

See also /soap, /soapmaxthreads, /soapport, /soapsizelimit, and /soapthreads.

39.106  /soapthreads
Sets the initial number of SOAP threads that the POA starts to service SOAP clients. The default is 
3. The POA automatically starts additional threads as needed. See Section 36.2.4, “Supporting 
SOAP Clients,” on page 491.

See also /soap, /soapmaxthreads, /soapport, /soapsizelimit, and /soapssl.

39.107  /tcpthreads
Specifies the maximum number of TCP handler threads the POA can create to service client/server 
requests. The default is 6; valid values range from 1 to 40. Plan on about one TCP handler thread per 
20-30 client/server users. See Section 38.1.1, “Adjusting the Number of POA Threads for Client/
Server Processing,” on page 547.

NetWare POA Linux POA Windows POA

Syntax: /soapsizelimit-kilobytes --soapsizelimit kilobytes /soapsizelimit-kilobytes

Example: /soapsizelimit-2048 --soapsizelimit 2048 /soapsizelimit-2048

NetWare POA Linux POA Windows POA

Syntax: /soapssl-setting --soapssl setting /soapssl-setting

Example: /soapssl-enable --soapssl enable /soapssl-enable

NetWare POA Linux POA Windows POA

Syntax: /soapthreads-number --soapthreads number /soapthreads-number

Example: /soapthreads-10 --soapthreads 20 /soapthreads-30
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See also /primingmax.

39.108  /threads
Specifies the maximum number of message handler threads the POA can create. The default is 8; 
valid values range from 1 to 30. See Section 38.2.1, “Adjusting the Number of POA Threads for 
Message File Processing,” on page 552.

39.109  /user
Provides the network user ID for the POA to use when accessing post offices and/or document 
storage areas on remote servers. You can also provide user and password information on the Post 
Office Settings page in ConsoleOne. For the NetWare POA, see “Creating a NetWare Account for 
Agent Access (Optional)” in “Installing GroupWise Agents” in the GroupWise 7 Installation Guide. 

See also /password and /dn.

Windows Note: The Windows POA gains access to the post office directory when it starts. However, 
a particular user might attempt to access a remote document storage area to which the POA does not 
yet have a drive mapping available. By default, the POA attempts to map a drive using the same user 
ID and password it used to access the post office directory. If the user ID and password for the 
remote storage area are different from the post office, then use the /user and /password switches to 
specify the needed user ID and password. You can also provide user and password information on 

NetWare POA Linux POA Windows POA

Syntax: /tcpthreads-number --tcpthreads number /tcpthreads-number

Example: /tcpthreads-10 --tcpthreads 20 /tcpthreads-20

NetWare POA Linux POA Windows POA

Syntax: /threads-number --threads number /threads-number

Example: /threads-10 --threads 20 /threads-30

NetWare POA Linux POA Windows POA

Syntax: /user-eDirectory_user_ID --user Linux_user_ID /user-Windows_user_ID

Example: /user-GWAgents --user GWAgents /user-GWAgents

NetWare: The eDirectory_user_ID is a user that the POA can use to log in to the remote NetWare 
server.

Linux: On OES Linux, the Linux_user_ID is a LUM-enabled user that the POA can use to log in to 
the remote OES Linux server. On SLES Linux, it is a standard Linux user.

Windows: The Windows_user_ID is a user that the POA can use to log in to the remote Windows 
server.
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the Post Office Settings page in ConsoleOne. However, it is preferable to use the same user ID and 
password on all servers where the POA needs access. 
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