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About This Guide

This Novell GroupWise 2012 Administration Guide helps you maintain all components of your
GroupWise system. The guide is divided into the following sections:

*

*

*

Part I, “System,” on page 35

Part II, “Domains,” on page 129

Part III, “Post Offices,” on page 171

Part IV, “Users,” on page 217

Part V, “Resources,” on page 263

Part VI, “Distribution Lists, Groups, and Organizational Roles,” on page 279
Part VII, “Libraries and Documents,” on page 313
Part VIII, “Databases,” on page 395

Part IX, “Post Office Agent,” on page 469

Part X, “Message Transfer Agent,” on page 619
Part XI, “Document Viewer Agent,” on page 709
Part XII, “Internet Agent,” on page 741

Part XIII, “WebAccess,” on page 893

Part XIV, “Calendar Publishing Host,” on page 921
Part XV, “Monitor,” on page 939

Part XVI, “Client,” on page 1013

Part XVII, “Security Administration,” on page 1095
Part XVIII, “Security Policies,” on page 1149

Part XIX, “Appendixes,” on page 1161

For troubleshooting assistance, see:

*

*

*

GroupWise 2012 Troubleshooting 1: Error Messages

GroupWise 2012 Troubleshooting 2: Solutions to Common Problems
GroupWise 2012 Troubleshooting 3: Message Flow and Directory Structure
Novell Support and Knowledgebase (http://www.novell.com/support)

To search the GroupWise documentation from the Novell Support Web site, click Advanced
Search, select Documentation in the Search In drop-down list, select GroupWise in the Products
drop-down list, type the search string, then click Search.

GroupWise Support Forums (http://forums.novell.com/forumdisplay.php?&f=356)
GroupWise Support Community (http://www.novell.com/support/products/groupwise)

GroupWise Cool Solutions (http://www.novell.com/coolsolutions/gwmag/index.html)
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Audience

This guide is intended for those who administer a GroupWise system on Linux or Windows. Some
background knowledge of the host operating system is assumed.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comment feature at the bottom of each page of the
online documentation.

Additional Documentation

For additional GroupWise documentation, see the following guides at the Novell GroupWise 2012
documentation Web site (http://www.novell.com/documentation/beta/groupwise2012):

¢ Installation Guide

¢ Server Migration Guide

¢ Administration Guide

¢ Multi-System Administration Guide

¢ Interoperability Guide

¢ Troubleshooting Guides

¢ GroupWise User Frequently Asked Questions (FAQ)
¢ GroupWise User Guides

¢ GroupWise User Quick Starts
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¢ Chapter 1, “GroupWise System Administration,” on page 37
¢ Chapter 2, “ConsoleOne Administration Tool,” on page 39

¢ Chapter 3, “GroupWise View,” on page 61

¢ Chapter 4, “GroupWise System Operations,” on page 69

¢ Chapter 5, “GroupWise Utilities,” on page 95

¢ Chapter 6, “GroupWise Address Book,” on page 105

¢ Chapter 7, “Multilingual GroupWise Systems,” on page 123

For additional assistance in managing your GroupWise system, see GroupWise Best Practices (http://
wiki.novell.com/index.php/GroupWise).
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GroupWise System Administration

As a GroupWise system administrator, it is your responsibility to keep your GroupWise system
running smoothly for your GroupWise users. This GroupWise 2012 Administration Guide provides a
wealth of information to help you accomplish this task. This System section provides an overview of
the GroupWise administration tool, ConsoleOne, and its capabilities. It summarizes administrative
tasks that affect your GroupWise system as a whole and provides links to more specialized
instructions.

The following sections of the Administration Guide detail the eDirectory objects where GroupWise
information is stored. Instructions are provided for creating and managing all GroupWise object

types.
¢ “Domains” on page 129
¢ “Post Offices” on page 171
¢ “Users” on page 217
¢ “Resources” on page 263

¢ “Distribution Lists, Groups, and Organizational Roles” on page 279

The following sections of the Administration Guide detail the GroupWise software components that
make your GroupWise system run. Instructions are provided for configuring, monitoring, and
optimizing each software component.

¢ “Post Office Agent” on page 469

¢ “Message Transfer Agent” on page 619

¢ “Document Viewer Agent” on page 709

¢ “Internet Agent” on page 741

¢ “WebAccess” on page 893

¢ “Monitor” on page 939

¢ “Calendar Publishing Host” on page 921

The following additional sections of the Administration Guide provide supporting details and
background information:

¢ “Libraries and Documents” on page 313

¢ “Databases” on page 395

¢ “Client” on page 1013

¢ “Security Administration” on page 1095

¢ “Security Policies” on page 1149
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2.1

ConsoleOne Administration Tool

GroupWise is administered using ConsoleOne, a Java-based tool for managing your network and its
resources. When you create your GroupWise system, GroupWise snap-ins are added to your
ConsoleOne installation and GroupWise objects are created in Novell eDirectory. As you manage
your GroupWise system, you use ConsoleOne to create additional GroupWise objects, modify
GroupWise object properties, and so on.

IMPORTANT: Because the GroupWise snap-ins to ConsoleOne are required in order to work with
GroupWise objects, you cannot use other network management tools, such as Novell iManager, to
administer your GroupWise system. Also, you should not use older network management tools, such
as NetWare Administrator, to administer your GroupWise system, unless your GroupWise system
includes legacy gateways that require such tools to administer the corresponding Gateway objects
and their properties.

Because GroupWise is a cross-platform product, you might have components of your GroupWise
system located on Linux servers, Windows servers, and legacy NetWare servers. You can run
ConsoleOne on Linux or Windows to manage GroupWise domains and post offices located on any of
these platforms.

¢ Section 2.1, “ConsoleOne on Linux,” on page 39

¢ Section 2.2, “ConsoleOne on Windows,” on page 46

¢ Section 2.3, “ConsoleOne in a Multiple-Platform Environment,” on page 48

¢ Section 2.4, “Remote Access to ConsoleOne on a Linux Server,” on page 56

NOTE: Starting in GroupWise 2012, NetWare is not a supported platform for the GroupWise agents.
However, the GroupWise Windows agents can be used to access domains and post offices located on
NetWare servers. ConsoleOne can still administer GroupWise databases located on NetWare servers.

ConsoleOne on Linux

¢ Section 2.1.1, “Installing Linux ConsoleOne,” on page 40

¢ Section 2.1.2, “Installing the GroupWise Administrator Snap-Ins to Linux ConsoleOne,” on
page 40

¢ Section 2.1.3, “Enabling File Locking on OES Linux,” on page 41
¢ Section 2.1.4, “Starting Linux ConsoleOne,” on page 41
¢ Section 2.1.5, “Mounting a Linux File System for a Domain or a Post Office,” on page 42

¢ Section 2.1.6, “Changing the Linux Mount Directory,” on page 46
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2.1.1 Installing Linux ConsoleOne

You can install Linux ConsoleOne on any server that meets the system requirements listed in
“GroupWise Administration Requirements” in “GroupWise Product Overview” in the GroupWise
2012 Installation Guide.

You must install the version of Linux ConsoleOne that is included in the downloaded GroupWise 2012
software image in the consoleone/Linux subdirectory. Under some circumstances, an older version
of ConsoleOne might already be installed.

1 In a terminal window, become root by entering su - and the root password.

2 Make the downloaded GroupWise 2012 software image available on the Linux server where you
want to install ConsoleOne.

3 Install the IBM JRE that is required for use with ConsoleOne:
3a Change to the admin subdirectory of the software image.
3b Install IBM JRE 1.5:

rpm -i NOVLclLinuxjre-1.5.0-11.i586.rpm
4 Change to the consoleone/Linux subdirectory of the software image.
5 Check to see if an older version of ConsoleOne is already installed on the Linux server:
ls /usr/ConsoleOne

6 (Conditional) If the consoleOne directory exists, uninstall ConsoleOne:

./cl-uninstall

7 Install the GroupWise 2012 version of ConsoleOne:

./cl-install
8 Enter the numbers for the languages that you want to install.
9 Enter 3 to install the LDAP snap-in.

10 Decline the installation of the bundled JRE 1.4.2, which is incompatible with the JRE installed in
Step 3 above.

ConsoleOne, along with other supporting packages, is then installed to /usr/ConsoleOne.

11 Continue with Installing the GroupWise Administrator Snap-Ins to Linux ConsoleOne.

2.1.2 Installing the GroupWise Administrator Snap-Ins to Linux ConsoleOne

After Linux ConsoleOne is installed, use the GroupWise Installation program to install the
GroupWise Administrator snap-ins to ConsoleOne to the ConsoleOne installation on that server.

1 Mount the primary domain directory of your GroupWise system to the server where you are
installing the GroupWise Administrator snap-ins to ConsoleOne.

If you need assistance with this task, see Section 2.1.5, “Mounting a Linux File System for a
Domain or a Post Office,” on page 42

2 Change to the root of the GroupWise 2012 software image.
3 Start the GroupWise Installation program:
./install

4 Select the language in which you want to run the GroupWise Installation program, then click
OK.
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Click Install Products > GroupWise Administration.
Click Install Administration, then click OK when installation is complete.
Click Configure Administration.

Review the introduction, then click Next.

© 0 N o O

Accept the License Agreement, then click Next.
10 Click Next to accept the default software distribution directory:

/opt/novell/groupwise/software
11 Select GroupWise Administration, then click Next.
12 When the software has been copied to the software distribution directory, click Next.
13 Click Next to accept the default of Updating an existing GroupWise system.

14 Browse to and select the primary domain directory for your GroupWise system, then click
Update.

15 Exit the GroupWise Administration program.

For convenience, ConsoleOne and the GroupWise Administrator snap-ins should be installed on
each Linux server where a domain is located. For some administration tasks, ConsoleOne on the
local server needs to have remote servers mounted. For more information, see Section 2.1.5,
“Mounting a Linux File System for a Domain or a Post Office,” on page 42.

16 (Conditional) If you installed ConsoleOne on Open Enterprise Server (OES) Linux, continue
with Enabling File Locking on OES Linux

or

(Conditional) If you installed ConsoleOne on SUSE Linux Enterprise Server (SLES), skip to
Section 2.1.4, “Starting Linux ConsoleOne,” on page 41

2.1.3 Enabling File Locking on OES Linux

(Conditional) If you have installed ConsoleOne on OES Linux:
1 As root, edit the following file:
/etc/opt/novell /ncpserv.cont
2 Add the following line at the bottom of the file:
CROSS PROTOCOL LOCKS 1
3 Restart the Novell eDirectory daemon:
rcndsd restart

4 Continue with Starting Linux ConsoleOne.

2.1.4  Starting Linux ConsoleOne

1 Make sure that any domain directories and post office directories that you want to access from
ConsoleOne are mounted to your local Linux server.

If you need assistance with this task, see Section 2.1.5, “Mounting a Linux File System for a
Domain or a Post Office,” on page 42

2 As root, enter the following command:

/usr/ConsoleOne/bin/ConsoleOne
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2.15

IMPORTANT: Do not start ConsoleOne using the desktop icon. You cannot access the properties of
GroupWise objects in eDirectory if you start ConsoleOne from the Linux desktop.

Mounting a Linux File System for a Domain or a Post Office

To administer a domain that is located on a remote Linux server, you must mount the domain
directory to the local Linux server. To administer a post office that is located on a remote Linux
server, the domain directory for the owning domain and the post office directory must both be
mounted to the local Linux server. In addition, you might also want to mount the primary domain
server to each secondary domain server, so that administrative messages can flow from one
secondary domain to another through the primary domain.

¢ “Working with the Linux Mount Directory” on page 42

¢ “Mounting an OES Linux File System Using NetWare Core Protocol (NCP)” on page 42

¢ “Mounting a SLES File System Using Samba” on page 43

Working with the Linux Mount Directory

The first time you run Linux ConsoleOne on a server, you are prompted to provide a Linux mount
directory on that server. The default location is /mnt. For more information, see “Linux Mount
Directory” in “Planning a Basic GroupWise System” in the GroupWise 2012 Installation Guide. For
convenience, you can later change the Linux mount directory, as described in Section 2.1.6,
“Changing the Linux Mount Directory,” on page 46.

Underneath the Linux mount directory, you must create a subdirectory for each file system where a
domain or post office resides on a remote Linux server, that you want to be able to access from Linux
ConsoleOne on the local Linux server. For example, if you have a domain directory named provol on
a remote Linux server, you would create a provol subdirectory under /mnt on the local Linux server
where you want to run ConsoleOne.

Mounting an OES Linux File System Using NetWare Core Protocol (NCP)

¢ “Configuring NCP” on page 42
¢ “Mounting an NCP Volume” on page 43

Configuring NCP
1 In a terminal window on the OES Linux server, become root by entering su - and the root
password.

2 If you are creating a new domain or post office, create the directory where you want to create the
GroupWise domain and/or post office.

or

If you are not creating a new domain or post office, make sure you know where the existing
directory is located.

3 Enter the following command to create the NCP volume:

ncpcon create volume volume name /directory

3a Replace volume name with a unique name for the location where you want to create the
GroupWise domain and/or post office.

3b Replace directory with the directory referenced in Step 2.
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4 Verify that the volume has been created:

more /etc/opt/novell/ncpserv.conf

The new volume should be listed at the end of the NCP server configuration file.

5 Restart the Novell eDirectory daemon:

rcndsd restart

6 Continue with Mounting an NCP Volume.

Mounting an NCP Volume
1 Use the following command to mount the NCP volume to the OES Linux server:

ncpmount -S fully qualified hostname -V volume name -A ip address
-U fully gqualified administrator user /linux mount directory

la Replace fully qualified hostname with the name of the remote Linux server that you
are mounting to the local Linux server, such as provol.novell.com.

1b Replace volume name with the name of the NCP volume that you created in Step 3 in
“Configuring NCP” on page 42.

1c Replace ip address with the IP address of the remote server specified in Step 1a above.

1d Replace linux mount_directory with the full path for the directory that you created in
“Working with the Linux Mount Directory” on page 42.

2 Create a script in the /mnt directory containing the resulting mount command, then run the
script.

3 Change to the domain or post office directory that you have mounted, then enter the following
command:

touch test

This creates a file named test across the mount and shows that ConsoleOne can also write
across the mount.

4 To make the mount persistent, so that it is automatically available whenever you reboot the
Linux server, edit the /etc/fstab (http://en.wikipedia.org/wiki/Fstab) file with the same
information that you used in the mount command.

Mounting a SLES File System Using Samba

¢ “Identifying the Directory Structure for the Samba Share” on page 44

¢ “Preparing Your Firewall to Allow Samba Connections” on page 44

¢ “Configuring the Samba Server” on page 44

¢ “Configuring the Samba Web Administration Tool (SWAT)” on page 44
¢ “Accessing SWAT” on page 44

¢ “Setting the Samba Password” on page 45

¢ “Creating a Samba Share” on page 45

¢ “Mounting a Samba Share” on page 45
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Identifying the Directory Structure for the Samba Share

1 In a terminal window on the SLES server, become root by entering su - and the root password.

2 If you are creating a new domain or post office, create the directory structure new domain and/
or post office.

or

If you are not creating a new domain or post office, make sure you know where the existing
directory is located.

3 Continue with Preparing Your Firewall to Allow Samba Connections.

Preparing Your Firewall to Allow Samba Connections

1 In YaST, click Security and Users > Firewall, then click Interfaces.
2 Click Change, select Internal Zone, then click OK.
3 Click Next to view the summary, then click Finish.

4 Continue with Configuring the Samba Server.

Configuring the Samba Server

1 In YaST, click Network Services > Samba Server.
2 Specify a workgroup or domain name, then click Next.

For use in your GroupWise system, the Samba server does not need to be part of a workgroup or
domain, so it does not matter what you put in this field. For example, you could use
GWSYSTEM.

3 Select Not a Domain Controller, then click Next.
For use in your GroupWise system, the Samba server does not need to be a domain controller.
4 Under Service Start, select During Boot.

Because you prepared the firewall in “Preparing Your Firewall to Allow Samba Connections” on
page 44, the Firewall Settings section shows that the firewall port for Samba is already open.

5 Click OK to finish the basic configuration of the Samba server.
6 Continue with Configuring the Samba Web Administration Tool (SWAT).

Configuring the Samba Web Administration Tool (SWAT)

1 In YaST, click Network Services > Network Services (xinetd).

2 Select Enable.

3 In the Currently Available Services list, select swat, then click Toggle Status (On or Off).
SWAT is off by default; this turns it on.

4 Click Finish.

5 Continue with Accessing SWAT.

Accessing SWAT
1 Display SWAT in your Web browser with the following URL:

http://localhost:901

2 Specify the root user name and password, then click OK.
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On the SWAT toolbar, click Status to verify that smbd and nmbd are running.
It is not necessary for winbindd to be running.

Continue with Setting the Samba Password.

Setting the Samba Password

1

2

3

On the SWAT toolbar, click Password.
The User Name field defaults to root.
Type, then retype, the root password, then click Add New User.

This sets up root as a Samba user, so that Samba mounts have the read/write access required by
ConsoleOne.

Continue with Creating a Samba Share.

Creating a Samba Share

1
2

~N o o1 b~

On the SWAT toolbar, click Shares.

In the Create Share field, type a unique name for the share, such as gwsystem, then click Create
Share.

In the Path field, specify the directory referenced in “Identifying the Directory Structure for the
Samba Share” on page 44.

In the Read Only field, select No.
In the Available field, select Yes.
Click Commit Changes.

Continue with Mounting a Samba Share.

Mounting a Samba Share

1

2

Use the appropriate command to mount the Samba share to the SLES server where you want to
run ConsoleOne:

SLES 11: mount -t cifs //fully qualified hostname/windows share name
/linux_mount directory -o username=root,noserverino

The noserverino option uses client-generated inode numbers instead of server-generated
inode numbers, which produces a more reliable CIFS mount.

SLES 10: mount -t smbfs //fully qualified hostname/windows_ share name
/linux_mount directory -o username=root

NOTE: The SLES 11 mount command does not accept smbfs as a valid mount type. CIFS (http://
en.wikipedia.org/wiki/Cifs) (Common Internet File System) is an update to the SMB (http://
en.wikipedia.org/wiki/Server_Message_Block) (Samba) protocol.

la Replace fully qualified hostname with the name of the server that you are mounting
the local server, such as provol.novell.com.

1b Replace share name with the name of the Samba share that you created in “Creating a
Samba Share” on page 45.

1c Replace 1inux mount_directory with the full path for the directory that you created in
“Identifying the Directory Structure for the Samba Share” on page 44.

Create a script in the /mnt directory with the resulting mount command, then run the script.
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2.2

2.2.1

3 Change to the domain or post office directory that you have mounted, then enter the following
command:

touch test

This creates a file named test across the mount and shows that ConsoleOne will also be able to
write across the mount.

4 To make the mount persistent, so that it is automatically available whenever you reboot the
Linux server, edit the /etc/fstab (http://en.wikipedia.org/wiki/Fstab) file with the same
information that you used in the mount command.

Changing the Linux Mount Directory

During creation of your basic GroupWise system, you established a Linux mount directory on the
server where you created your basic GroupWise system, as described in “Selecting a Linux Mount
Directory” in “Installing a Basic GroupWise System” in the GroupWise 2012 Installation Guide. The
mount directory information is stored in the . consoleone/SnapinPrefs. ser file in the /root
directory, which is the home directory for the root user.

To change the mount directory later in ConsoleOne:

1 Click Tools > GroupWise System Operations.
2 Click System Preferences > Linux Settings.

3 In the Linux Mount Directory field, browse to and select the desired mount directory, then click
OK.

ConsoleOne on Windows

You can run Windows ConsoleOne on any Windows server or workstation that meets the
requirements listed in “GroupWise Administration Requirements” in the GroupWise 2012 Installation
Guide.

¢ Section 2.2.1, “Installing ConsoleOne and the GroupWise Snap-Ins on Windows,” on page 46

¢ Section 2.2.2, “Configuring Your Windows Machine for ConsoleOne,” on page 47

¢ Section 2.2.3, “Starting ConsoleOne on Windows,” on page 47

¢ Section 2.2.4, “Mapping a Drive for a New Domain or Post Office,” on page 47

Installing ConsoleOne and the GroupWise Snap-Ins on Windows

When you created your basic GroupWise system using the GroupWise Installation program
(install.exe), the GroupWise Administrator snap-ins to ConsoleOne were installed to the
ConsoleOne installation on that server, along with ConsoleOne itself if necessary.

After you set up your basic GroupWise system, you can use the GroupWise Installation program to
install ConsoleOne and the GroupWise Administrator snap-ins from the GroupWise 2012 software
image to additional Windows servers and workstations as needed.

1 Make the downloaded GroupWise 2012 software image available on the Windows machine
where you want to install ConsoleOne and the GroupWise Administrator snap-ins.
2 Start the GroupWise Installation program (setup.exe) at the root of the software image.

3 Select the language in which you want to run the GroupWise Installation program, then click
OK.
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2.2.2

2.2.3

2.24

Click Install GroupWise System, then click Yes to accept the License Agreement.
Click Next to accept the default of a Standard installation.

Click Install individual components, deselect GroupWise Agents, then click Next.
Deselect Copy files to a software distribution directory, then click Next.

o N o o0 b~

(Conditional) If ConsoleOne is not already installed on the Windows machine, click Install
ConsoleOne, then follow the prompts to install ConsoleOne.

9 Click Next to accept the default location of the ConsoleOne software:

c:\novell\consoleone\1l.2

or

Browse to and select the actual location of the ConsoleOne software on the Windows machine,
then click Next.

10 Review the settings you have selected, then click Install.
11 When the installation is completed, click Finish.

12 Download and install the LDAP snap-in for ConsoleOne from Novell Downloads (http://
download.novell.com/Download?buildid=FCT5LqrhcGI~).

Configuring Your Windows Machine for ConsoleOne

To ensure GroupWise database integrity across the network:

1 Right-click N on the Windows taskbar, then click Novell Client Properties.
2 Click Advanced Settings.

3 Set File Caching to Off.

4 Set File Commit to On.

5 Click OK to save the new Novell Client settings, then reboot the Windows machine to put the
new settings into effect.

Starting ConsoleOne on Windows

When you install ConsoleOne, a ConsoleOne icon is automatically created on your Windows desktop
for starting ConsoleOne. You can also start it from the Windows Start menu.

Mapping a Drive for a New Domain or Post Office

In order to create a new domain in ConsoleOne, you must map a drive to the Windows server where
you want to create the domain. If you want to create a new post office, you must also map a drive to
the Windows server where you want to create the post office.

1 Right-click the Computer object, then click Map network drive.

2 In the Drive field, select the drive letter to use for the Windows server where you want to create
the new domain or post office.

3 In the Folder field, specify the location of the server in the following format:

\\ip address\share name

Replace ip _address with the IP address of the Windows server. Replace share name with the
name of the share that you have set up on the remote Windows server.
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4 Select Reconnect at logon.

5 (Conditional) If the user name and password required to access the remote Windows server are
different from the user name and password for the local Windows server, select Connect using
different credentials.

6 Click Finish.

7 (Conditional) If prompted, specify the administrator user name and password for the remote
Windows server, then click OK.

The mapped drive appears in Windows Explorer and can now be accessed from Windows
ConsoleOne.

ConsoleOne in a Multiple-Platform Environment

If your GroupWise system includes both Linux and Windows, you can administer Linux domains
and post office from Windows ConsoleOne and administer Windows domains and post offices from
Linux ConsoleOne.

NOTE: If your GroupWise system still includes NetWare domains and post offices, see “Migrating
Away from NetWare” in “Update” in the GroupWise 2012 Installation Guide for NetWare-specific
considerations.

This section helps you set up the cross-platform connections that enable ConsoleOne to successfully
access GroupWise databases on any platform.

¢ Section 2.3.1, “Using Linux ConsoleOne to Access Domains and Post Offices on Windows,” on
page 48

¢ Section 2.3.2, “Using Windows ConsoleOne to Access Domains and Post Offices on Linux,” on
page 50

Using Linux ConsoleOne to Access Domains and Post Offices on
Windows

In order for you to be able to use Linux ConsoleOne to administer domains and post offices that are
located on Windows, the domain and post office directories on the Windows servers must be
mounted as Linux filesystems.

¢ “Working with the Linux Mount Directory” on page 49

¢+ “Making a Windows Server Visible in Linux ConsoleOne” on page 49

¢ “Accessing a Domain or Post Office on NetWare or Windows from Linux ConsoleOne” on
page 50
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Working with the Linux Mount Directory

The first time you run Linux ConsoleOne on a server, you are prompted to provide a Linux mount
directory on that server. The default location is /mnt. For more information, see “Linux Mount
Directory” in “Planning a Basic GroupWise System” in the GroupWise 2012 Installation Guide. For
convenience, you can later change the Linux mount directory, as described in Section 2.1.6,
“Changing the Linux Mount Directory,” on page 46.

Underneath the Linux mount directory, you must create a subdirectory for each directory where a
domain or post office resides on a Windows server, that you want to be able to access from Linux
ConsoleOne. For example, if you have a domain directory named provol on a Windows server, you
would create a provol subdirectory under /mnt on the Linux server where you want to run
ConsoleOne.

Making a Windows Server Visible in Linux ConsoleOne

1 Use the appropriate command to mount the Windows share to the Linux server where you want
to run ConsoleOne:

SLES 11: mount -t cifs //fully qualified hostname/windows share name
/linux mount directory
-0 username=windows_administrator,noserverino

The noserverino option uses client-generated inode numbers instead of server-generated
inode numbers, which produces a more reliable CIFS mount.

SLES 10: mount -t smbfs //fully qualified hostname/windows share name
/linux mount directory -o username=windows administrator

NOTE: The SLES 11 mount command does not accept smbfs as a valid mount type. CIFS (http://
en.wikipedia.org/wiki/Cifs) (Common Internet File System) is an update to the SMB (http://
en.wikipedia.org/wiki/Server_Message_Block) (Samba) protocol.

la Replace fully qualified hostname with the name of the Windows server that you are
mounting the Linux server where you want to run ConsoleOne, such as
provol.novell.com.

1b Replace share name with the name of the Windows share on the Windows server, such as
C.

1c Replace linux mount_directory with the full path for the directory that you created in
“Working with the Linux Mount Directory” on page 49.

1d Replace windows_administrator with the user name of the administrator user of the
Windows server, such as Administrator

2 Create a script in the /mnt directory with the resulting mount command, then run the script.
3 Change to the domain or post office directory that you have mounted, then enter the following

command:

touch test

This creates a file named test across the mount and shows that Linux ConsoleOne will also be
able to write across the mount.

4 To make the mount persistent, so that it is automatically available whenever you reboot the
Linux server, edit the /etc/fstab (http://en.wikipedia.org/wiki/Fstab) file with the same
information that you used in the mount command.
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Accessing a Domain or Post Office on NetWare or Windows from Linux
ConsoleOne

After you have made the Windows server visible from Linux:

1 Mount the domain directory to the Linux server.

2 In Linux ConsoleOne, authenticate to the eDirectory tree where the Domain object is located.
3 Click Tools > GroupWise System Operations > Select Domain.

4 Browse to and select the domain directory, then click OK.

You can now use Linux ConsoleOne to administer all GroupWise objects that belong to the domain
that is located on Windows.

Using Windows ConsoleOne to Access Domains and Post Offices on
Linux

In order for you to be able to use Windows ConsoleOne to administer domains and post offices that
are located on Linux, the Linux servers where the domains and post offices are located must be
accessible from Windows. To make a Linux server visible from Windows, you need to configure it so
that you can map a drive to it as if it were a Windows server. There are a variety of ways to
accomplish this.
¢ “Using NetWare Core Protocol to Connect from Windows to an OES Linux Server” on page 50
¢ “Using Samba to Connect from Windows to an OES Linux Server” on page 52

¢ “Using Samba to Connect from Windows to a SLES Server” on page 54

Using NetWare Core Protocol to Connect from Windows to an OES Linux Server

On OES Linuy, if you are using the ext3 or reiserfs filesystem, you use Novell Core Protocol (NCP) to
configure the Linux server for access from Windows. Then, on Windows, you use the Novell Map
Network Drive feature to map a drive from Windows to the Linux filesystem where the domain or
post office is located.

¢ “Configuring the OES Linux Server for NCP Access from Windows” on page 50

¢+ “Mapping a Windows Drive to the NCP Volume” on page 51

Configuring the OES Linux Server for NCP Access from Windows

1 In a terminal window on the OES server, become root by entering su - and the root password.

2 If you are creating a new domain or post office on the OES Linux server, create the base directory
where you want to use Windows ConsoleOne to create the domain and/or post office directory
structure.

or

If you are not creating a new domain or post office on the OES Linux server, make sure you
know where the existing base directory is located.

3 Enter the following command to create the NCP volume on the OES Linux server:
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ncpcon create volume volume name /directory

3a Replace volume name with a unique name for the location where you want to create the
domain and/or post office directory structure

3b Replace directory with the directory referenced in Step 2 above.

4 Verify that the volume has been created:

more /etc/opt/novell/ncpserv.conf

The new volume should be listed at the end of the NCP server configuration file.

5 Enable cross-protocol locks so that Windows ConsoleOne can safely access GroupWise
databases across the connection between Windows and Linux:

5a Enter the following command

ncpcon set cross_protocol locks=1

or

Add the following line at the bottom of the ncpserve. conf file:

CROSS_PROTOCOL_LOCKS 1

5b Restart the Novell eDirectory daemon:

rcndsd restart

6 Continue with Mapping a Windows Drive to the NCP Volume.
Mapping a Windows Drive to the NCP Volume

1 On the Windows server, right-click M on the Windows taskbar, then click Novell Map Network
Drive.

2 Select the drive letter to map to the NCP volume on the OES Linux server.
3 Specify the network path to the NCP volume in the following format:

\\1inux hostname\ncp volume

3a Replace linux hostname with the hostname of the OES Linux server.
3b Replace ncp volume with the name of the NCP volume that you just created.

4 For the network user name, specify the fully qualified administrator user name for eDirectory.,
such as admin.users.novell.

5 Select Check to always map this drive letter when you start Windows.
6 Click Map.
7 (Conditional) If prompted, log in to eDirectory:
7a In the Password, specify the eDirectory password for the administrator user.

7b In the Context field, specify the eDirectory context where the administrator User object is
located.

8 Click OK.

The mapped drive to the OES Linux server opens in Windows Explorer and can now be accessed
from Windows ConsoleOne.
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Using Samba to Connect from Windows to an OES Linux Server

On OES Linuy, if you are using the Novell Storage Services (NSS) filesystem, you use Samba to create
the connection between Linux and Windows. Then, on Windows, you use the Novell Map Network
Drive feature to map a drive from Windows to the Samba share.

¢ “Identifying the Directory Structure for the Samba Share” on page 52

¢ “Installing Samba” on page 52

¢ “Logging In to iManager” on page 52

¢ “Configuring the eDirectory Universal Password for Samba” on page 53

¢ “Setting the eDirectory Universal Password for the Samba Administrator User” on page 53

¢ “Creating a Samba Share” on page 53

¢ “Setting the eDirectory Rights for the Samba Share” on page 53

¢ “Testing Samba on the OES Server” on page 53

¢+ “Mapping a Windows Drive to the Samba Share on the OES Linux Server” on page 54

Identifying the Directory Structure for the Samba Share
1 In a terminal window on the OES Linux server, become root by entering su - and the root
password.

2 If you are creating a new domain or post office, create the base directory for the new domain
and/or post office.

or

If you are not creating a new domain or post office, make sure you know where the existing
directory is located.

3 Continue with Installing Samba.

Installing Samba
If you installed Samba when you installed OES Linux, skip to “Logging In to iManager” on page 52.
If you did not install Samba when you installed OES Linux, install it now:

1 Start YaST.

2 Under Groups, click Open Enterprise Server, then click OES Install and Configuration.

3 Under OES Services, select Novell Samba, then click Accept.

4 Follow the prompts to install Novell Samba.
5 Continue with Logging In to iManager.

Logging In to iManager
1 Access the following URL:

https://ip address/nps/servlet/webacc?taskid=fw Startup

Replace ip_address with the IP address of the OES Linux server.

2 Specify the eDirectory administrator user name, such as admin.users.novell, the password for
the user name, and the IP address of the eDirectory tree, then click Login.

3 Continue with Configuring the eDirectory Universal Password for Samba.
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Configuring the eDirectory Universal Password for Samba

1 IniManager, click Passwords > Password Policies.
2 Click Samba Default Password Policy.

3 On the Policy Assignment tab, browse to and click the name of the administrator User object that

you want to administer the Samba share, then click OK to add the user to the list.
4 Click OK to complete the process.

5 Continue with Setting the eDirectory Universal Password for the Samba Administrator User.

Setting the eDirectory Universal Password for the Samba Administrator User

1 Under Passwords, click Set Universal Password.
2 Browse to and click the name of the Samba administrator User object, then click OK.

3 Specify the password for the Samba administrator user, retype the password for confirmation,
then click OK.

4 Click Passwords to close the Passwords menu.

5 Continue with Creating a Samba Share.

Creating a Samba Share

1 Click File Protocols, then click Samba.
2 Browse to and click the name of the Server object where you are setting up the Samba share.

3 On the Shares tab, create a new Samba share for the directory on the Linux server reference in
“Identifying the Directory Structure for the Samba Share” on page 52:

3a Click New.

3b Specify a unique name for the Samba share, such as gwsystem.

3c Specify the full path name on the Linux server for the domain or post office, click OK to add

the location to the list of Samba shares, then click Close.
3d Click File Protocols to close the File Protocols menu.

4 Continue with Setting the eDirectory Rights for the Samba Share.

Setting the eDirectory Rights for the Samba Share

1 Click Files and Folders, then click Properties.

2 Browse to and click the name of the Linux partition or directory where you created the new
share, then click OK.

3 Click Rights.

4 In the Add Trustee field, browse to and click the name of the Samba administrator User object,
then click OK.

5 Grant all file system rights to the Samba administrator user, then click OK.

6 Continue with Testing Samba on the OES Server.

Testing Samba on the OES Server
1 Double-click the Home Directory icon on the Linux desktop.

2 Click \E|
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3 In the Location field, type smb://user_nameeip_address
3a Replace user_name with the user name of the Samba administrator user.
3b Replace ip address with the IP address of the Linux server.

The File Browser should display all Samba shares, including the new one that you created
for the domain and/or post office.

4 Continue with Mapping a Windows Drive to the Samba Share on the OES Linux Server.

Mapping a Windows Drive to the Samba Share on the OES Linux Server

1 In Windows Explorer, right-click the Computer object, then click Map network drive.
2 In the Drive field, select the drive letter for the new Samba share.
3 In the Folder field, specify the location of the Samba share in the following format:
\\ip address\share name
3a Replace ip address with the IP address of the Linux server.
3b Replace share name with the name of the new Samba share.
4 Select Reconnect at logon.
5 Select Connect using different credentials.
6 Specify the Samba administrator user name and password, then click OK.

The Samba share for the OES Linux file system opens in Windows Explorer and can now be
accessed from Windows ConsoleOne.

Using Samba to Connect from Windows to a SLES Server

On SLES, you use YaST and the Samba Web Administration Tool (SWAT) to configure Samba. Then
you use the Windows Map Network Drive feature to map a drive from Windows to the Samba share.

¢ “lIdentifying the Directory Structure for the Samba Share” on page 54

¢ “Preparing Your Firewall to Allow Samba Connections” on page 55

¢ “Configuring the Samba Server” on page 55

¢ “Configuring the Samba Web Administration Tool (SWAT)” on page 55

¢ “Accessing SWAT” on page 55

¢ “Creating a Samba Share” on page 55

¢+ “Mapping a Windows Drive to the Samba Share on the SLES Server” on page 56

Identifying the Directory Structure for the Samba Share

1 In a terminal window on the OES server, become root by entering su - and the root password.

2 If you are creating a new domain or post office, create the base directory for the new domain
and/or post office directory structure.

or

If you are not creating a new domain or post office, make sure you know where the existing
directory is located.

3 Continue with Preparing Your Firewall to Allow Samba Connections.

54 GroupWise 2012 Administration Guide



Preparing Your Firewall to Allow Samba Connections

1 In YaST, click Security and Users > Firewall, then click Interfaces.
2 Click Change, select Internal Zone, then click OK.
3 Click Next to view the summary, then click Finish.

4 Continue with Configuring the Samba Server.

Configuring the Samba Server

1 In YaST, click Network Services > Samba Server.
2 Specify a workgroup or domain name, then click Next.

For use in your GroupWise system, the Samba server does not need to be part of a workgroup or
domain, so it does not really matter what you put in this field. For example, you could use
GWSYSTEM.

3 Select Not a Domain Controller, then click Next.
For use in your GroupWise system, the Samba server does not need to be a domain controller.
4 Under Service Start, select During Boot.

Because you prepared the firewall in “Preparing Your Firewall to Allow Samba Connections” on
page 55, the firewall port for Samba is already open.

5 Click OK to finish the basic configuration of the Samba server.
6 Continue with Configuring the Samba Web Administration Tool (SWAT).

Configuring the Samba Web Administration Tool (SWAT)

1 In YaST, click Network Services > Network Services (xinetd).

2 Select Enable.

3 In the Currently Available Services list, select swat, then click Toggle Status (On or Off).
SWAT is off by default. This turns it on.

4 Click Finish.

5 Continue with Accessing SWAT.

Accessing SWAT

1 Display SWAT in your Web browser with the following URL:

http://localhost:901

2 Specify the root user name and password, then click OK.
3 On the SWAT toolbar, click Status to verify that smbd and nmbd are running.
It is not necessary for winbindd to be running.

4 Continue with Creating a Samba Share.

Creating a Samba Share

1 On the SWAT toolbar, click Shares.

2 In the Create Share field, type a unique name for the share, such as gwsystem, then click Create
Share.
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3 In the Path field, specify the directory that you created in “Identifying the Directory Structure for
the Samba Share” on page 54.

4 In the Read Only field, select No.
5 In the Available field, select Yes.
6 Click Commit Changes.

Mapping a Windows Drive to the Samba Share on the SLES Server

1 On the Windows desktop, right-click the Computer object, then click Map network drive.
2 In the Drive field, select the drive letter for the new Samba share.

3 In the Folder field, specify the location of the Samba share in the following format:

\\ip address\share name

3a Replace ip address with the IP address of the Linux server.
3b Replace share name with the name of the new Samba share.
4 Select Reconnect at logon.
5 Select Connect using different credentials.
6 Specify the Samba administrator user name and password, then click OK.

The Samba share on the SLES server opens in Windows Explorer and can now be accessed from
Windows ConsoleOne.

Remote Access to ConsoleOne on a Linux Server

If your GroupWise system includes domains on Linux servers, file system mounts are required for a
few specific GroupWise administration tasks. However, you can perform the bulk of typical domain,
post office, and user administration without needing file system mounts between Linux servers
where domains and post offices reside. You can perform these administration tasks from either Linux
or Windows.

¢ Section 2.4.1, “Administrative Tasks Requiring File System Mounts,” on page 56

¢ Section 2.4.2, “Remote ConsoleOne Access with a VNC Client,” on page 57

¢ Section 2.4.3, “Remote ConsoleOne Access with a Secure Shell (SSH) Connection,” on page 58

Administrative Tasks Requiring File System Mounts

ConsoleOne requires file system mounts to both the primary domain database and a secondary
domain database simultaneously to perform the following tasks:

¢ Create Domain

¢ Rebuild Domain Database

¢ Sync Primary with Secondary

¢ Replace Primary with Secondary

¢ Merge/Release

For more information, see Section 4.1.2, “Understanding the Need for Domain Connections,” on
page 71.
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2.4.2

Aside from these fairly specialized administrative tasks, you can connect directly to a secondary
domain database on a Linux server from either Linux or Windows, and then run Linux ConsoleOne
to conveniently perform other GroupWise administration tasks remotely.

Remote ConsoleOne Access with a VNC Client

Remote administration can be made possible by using a VNC (Virtual Network Connection) client
where you want to run ConsoleOne (on either Linux or Windows) and by enabling Remote
Administration on each remote Linux server where you need to access a domain database.

¢ “Selecting a VNC Client” on page 57

¢ “Enabling Remote Administration” on page 57

¢ “Using Your VNC Client on Linux or Windows to Run ConsoleOne on the Linux Server” on
page 58

Selecting a VNC Client

Many VNC clients are available for use on Linux and Windows. To investigate your options, you can
google “VNC clients”. Review their capabilities and select one that appeals to you. RealVNC is a
common favorite. Install the VNC client where you want to run ConsoleOne with direct access to
remote Linux servers.

Enabling Remote Administration

By default, Linux servers do not allow remote administration for understandable security reasons. To
use your VNC client, you must enable Remote Administration on each remote Linux server.
1 InYaST:
la (Conditional) On OES, click Network Devices > Remote Administration.
or
1b (Conditional) On SLES, click Network Services > Remote Administration.
2 Select Allow Remote Administration.

If your firewall is properly configured, Open Port in Firewall is selected by default. The default
port number used for remote administration is 5901.

3 (Conditional) If Open Port in Firewall is not selected:
3a Click Abort to cancel Remote Administration setup.
3b Click Security and Users > Firewall.
3c In the left pane, click Interfaces, then click Change to configure the firewall interface.

3d In the Interface Zone drop-down list, select the zone appropriate for the Linux server where
you are enabling Remote Administration, then click OK.

3e Click Next to list your current firewall settings, then click Finish to put the updated setting
into effect.

3f Return to Step 1 to enable Remote Administration.

4 After enabling Remote Administration, click Finish to put the settings into effect.
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2.4.3

Using Your VNC Client on Linux or Windows to Run ConsoleOne on the Linux
Server

After you have enabled Remote Administration on the remote Linux servers:

1

o 01~ W

Access the remote Linux server in your VNC client by providing the remote server’s IP address
and the remote administration port number, for example:

137.16.5.18:5901

In the window that opens on the remote Linux server, start ConsoleOne:

/usr/ConsoleOne/bin/ConsoleOne

Authenticate to the eDirectory tree to start ConsoleOne as usual.
Attach to the domain on the Linux server.
Proceed with your GroupWise administration tasks.

When you are finished with GroupWise administration on the remote Linux server, exit
ConsoleOne.

Close the window where you have been running ConsoleOne, to close the connection with the
remote Linux server.

Remote ConsoleOne Access with a Secure Shell (SSH) Connection

As an alternative to the Remote Administration feature in YaST, you can use a secure shell (SSH)
connection to a remote Linux server in order to run ConsoleOne on the remote Linux server.

*

*

*

“Configuring a Linux Server to Allow a Secure Shell Connection” on page 58
“Using a Secure Shell Connection on Linux to Run ConsoleOne on the Linux Server” on page 59

“Using a Secure Shell Connection on Windows to Run ConsoleOne on the Linux Server” on
page 59

Configuring a Linux Server to Allow a Secure Shell Connection

*

*

“On OES 11 and SLES 11” on page 58
“On OES 2 and SLES 10” on page 59

On OES 11 and SLES 11

1
2

3
4

In YaST, click Network Service > SSHD Configuration.
Ensure that Allow X11 Forwarding is selected.
This is the default setting.
Click Finish to enable SSHD.
Configure your firewall to allow the SSHD connection:
4a Under Security and Users, click Firewall.
4b Click Allowed Services.
4c In the Service to Allow drop-down list, select Secure Shell Server, then click Add.
4d Click Next, then click Finish.
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On OES 2 and SLES 10

1 Check the /etc/ssh/sshd_config file to ensure that X11Forwarding is set to yes.
This is the default setting.
2 Configure your firewall to allow the SSH connection:
2a Under Security and Users, click Firewall.
2b Click Allowed Services.
2c¢ In the Service to Allow drop-down list, select SSH, then click Add.
2d Click Next, then click Finish.

Using a Secure Shell Connection on Linux to Run ConsoleOne on the Linux
Server

1 Enter the following command to establish a secure shell connection to the remote Linux server

ssh -X network address

Replace network address with the IP address or DNS hostname of the remote Linux server.
2 Enter the password to access the remote Linux server as root.

The command prompt changes to the name of the remote Linux server.

3 Start ConsoleOne on the Linux server:

/usr/ConsoleOne/bin/ConsoleOne

Authenticate to the eDirectory tree as usual.
Connect to the domain on the Linux server.

Proceed with your GroupWise administration tasks.

~N o o1 b~

When you are finished with GroupWise administration on the remote Linux server, exit
ConsoleOne.

8 Exit the terminal window where you have been connected to the remote Linux server, to close
the secure shell session.

Using a Secure Shell Connection on Windows to Run ConsoleOne on the Linux
Server

Because Windows does not include an X server, setting up a secure shell from Windows to Linux
requires additional software that is not free nor especially easy to set up. If you still want to pursue

this option, refer to the Cool Solutions article, “Remote Management Using SSH and X-Forwarding
on Windows” (http://www.novell.com/coolsolutions/feature/19258 . html).

ConsoleOne Administration Tool
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3.1

GroupWise View

When administering GroupWise in ConsoleOne, you can use the standard Novell eDirectory View or
you can use the GroupWise View. The following sections discuss the GroupWise View and how to
use it:

¢ Section 3.1, “eDirectory View versus GroupWise View,” on page 61

¢ Section 3.2, “GroupWise Object Icons,” on page 62

¢ Section 3.3, “Customizing the GroupWise View,” on page 64

*

Section 3.4, “Searching in the GroupWise View,” on page 66

*

Section 3.5, “Performing Administrative Tasks from the GroupWise View,” on page 67

NOTE: The ConsoleOne illustrations used in the guide show ConsoleOne on Windows. ConsoleOne
on Linux looks different but provides substantially the same functionality.

eDirectory View versus GroupWise View

The eDirectory View displays the GroupWise objects in their contexts in the eDirectory tree, as
shown in the following example:

Novell ConsoleOne
File Edit View Tools

OEE

Help
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&8 Engineers J sales
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& Company Car 1
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% E:E::E? & Conference Room 2012
% Sales 3 Group Meeting Room
S Starr @ LeaveCalendar
- valtham1 & Lunchraom
-8 Waltham32 @ Proval

(=42 Movall @ Provo2

=[5 Security & Provo3

(-1 Groupwise Systern & waltharn1
& waltham2

%Adm\mstraliun

24 items %

r_lser admin Docdey Nowvell

[Tree: CORP_TREE
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The GroupWise View filters out all non-GroupWise objects and shows how the GroupWise objects
relate to each other in the GroupWise system, as shown in the following example.

Movell ConsoleQne

File Edit Wiew Tools Help
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In the left pane, all Domain objects are displayed under the GroupWise system, and all Post Office
objects are subordinate to the domains where they reside. You can select the GroupWise system, a
domain, or a post office in the left pane and then use the drop-down list of GroupWise objects on the
toolbar to display associated objects (Users, Resources, Message Transfer Agents, and so on) in the
right pane. In the above example, the GroupWise System is selected in the left pane and the

GroupWise Object list is set to Users, so the right pane is displaying all users in the entire GroupWise

system.

3.2

GroupWise Object Icons

The following table lists all the GroupWise objects that are displayed in the eDirectory View or
GroupWise View in ConsoleOne.

Icon  GroupWise Object

Additional Information

GroupWise System

®

Primary Domain

&

Secondary Domain
Current Domain

External Domain

Represents the GroupWise system you are currently connected to. The
GroupWise system’s nhame is displayed in the lower left corner of the
ConsoleOne window.

Represents the system’s primary domain. To ensure consistency, all replication
of GroupWise information to the GroupWise domain and post office databases
takes place through the primary domain. For additional information, see Part Il,
“Domains,” on page 129.

Represents any additional domains, other than the primary, created in the
GroupWise system. For additional information, see Part Il, “Domains,” on
page 129.

Represents the domain to which ConsoleOne is currently connected. For
information about changing the current domain, see Section 9.1, “Connecting to
a Domain,” on page 145.

Represents a domain from another GroupWise system.
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Icon

GroupWise Object

Additional Information

<

B 8 0 0 & P &6 F F

L

&

Non-GroupWise
Domain

Post Office

External Post Office

User

External Entity

External User

Resource

External Resource

Distribution List

Group

Organizational Role

Library

Nickname

Message Transfer
Agent

Post Office Agent

Gateway

Represents all or part of a non-GroupWise system.

Represents a collection of user accounts (mailboxes). For additional information,
see Part Ill, “Post Offices,” on page 171.

Represents a post office in an external GroupWise system or a hon-GroupWise
system.

Represents an eDirectory user who has been given a GroupWise account in a
post office. For additional information, see Part IV, “Users,” on page 217.

Represents a user not listed in eDirectory who has been given a GroupWise
account in a post office. For additional information, see Part IV, “Users,” on
page 217.

Represents a user in an external GroupWise system or a hon-GroupWise
system.

Represents a conference room or some other resource that can be scheduled by
users. For additional information, see Part V, “Resources,” on page 263.

Represents a resource that belongs to an external GroupWise system or a non-
GroupWise system.

Represents a group of users or resources that can all be addressed by using the
distribution list's name. For additional information, see Part VI, “Distribution
Lists, Groups, and Organizational Roles,” on page 279.

Represents an eDirectory group. eDirectory groups, like distribution lists, can be
addressed by using the group’s name. Any members of the group who have
GroupWise accounts receive the message. For additional information, see

Part VI, “Distribution Lists, Groups, and Organizational Roles,” on page 279.

Represents an eDirectory organizational role. eDirectory organizational roles,
like distribution lists, can be addressed by using the organizational role’s name.
Any members of the role who have GroupWise accounts receive the message.
For additional information, see Part VI, “Distribution Lists, Groups, and
Organizational Roles,” on page 279.

Represents a collection of documents. For additional information, see
Chapter 21, “Document Management Services Overview,” on page 315.

Represents an additional address associated with a user, resource, or
distribution list. For additional information, see Part IV, “Users,” on page 217,
Part V, “Resources,” on page 263, or Part VI, “Distribution Lists, Groups, and
Organizational Roles,” on page 279.

Represents a Message Transfer Agent (MTA) associated with a domain. For
additional information, see Part X, “Message Transfer Agent,” on page 619.

Represents a Post Office Agent (POA) associated with a post office. For
additional information, see Part IX, “Post Office Agent,” on page 469.

Represents a method of linking to another email system or transport. For
additional information, see the GroupWise gateway guides (http://
www.novell.com/documentation/gwgateways).

GroupWise gateways are legacy products that are not supported with the current
GroupWise version.

GroupWise View
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3.3

3.3.1

Customizing the GroupWise View

You can change the column display, order, and width to customize the GroupWise View.

Changes are preserved from one ConsoleOne session to the next. In addition, your last view is
persistent from session to session. For example, if you last used the Distribution Lists view, the next
time you start ConsoleOne and open the GroupWise View, the Distribution Lists view is displayed. If
the last-used view is not applicable (for example, you had the Gateways view open and when the
new ConsoleOne session starts you select a Post Office object), the GroupWise View defaults to the
Users view.

¢ Section 3.3.1, “Changing the Column Display and Order,” on page 64
¢ Section 3.3.2, “Changing the Column Widths,” on page 66

Changing the Column Display and Order

For each view (Users, Distribution Lists, Gateways, Post Offices, and so on), you can determine which
columns are displayed and the order in which they are displayed.

1 Select GroupWise System in the left (tree) pane, then select the view (for example, Users).

Nowvell ConsoleOne
File Edit View Tools Help
P B0 E 4E s =
0& my wiorid Object ID Dorrain Natne | Post Office .| Last Harme | Given Mare |
E‘ 9 MDS 13 adharmapalan Provo3 hdarketing Dharmapalan  Ahmar I;‘
E‘?‘ CORFP_TREE a aramirex Provo2 Sales Ramirez Art
% Groupifise a askoczylas  Provol Developrment  Skoczylas Alfons
‘% Navell a bgelsoming  Provod Marketing Gensoming  Benjii
m Security - a chotton Provod Marketing Batton Charles
g ®® Provol a thaughey Provod Marketing Haughey Flavian =l
- % Development a fthatmpson Provo3 Marketing Thompson Fred
: @ Provoz2 a gsmith Provol Development  Staith Grace
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% Marketing a jpangilinan Provol Development  Pangilinan Joe
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2 (Conditional) If you are changing the Users view, use the drop-down list to select how you want
to sort users (ID Sort, User Name Sort, First Name Sort, or Last Name Sort).

The Users view allows you to sort by ID, user name, first name, or last name. Each of these is
treated as a separate Users view for which you can determine the column display and order. The
views for different objects offer different sort options.
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3 Click View > Edit Columns to display the Select GroupWise View Columns dialog box.

Given Mame

Admin Defined 12
Admin Defined 13
Admin Defined 14

Select GroupWise View Columns E|
Selected Columns Available Fields
Object ID Accourt 1D -
Datnzin Marme Airin Defined 1 Cancel
Post Office Mame Admin Defined 10 Help
Last Mame Admin Defined 11

ﬂ Adirin Defined 15
Admin Defined 16
) | |Admin Defined 17
Admin Defined 18
Admin Defined 19
Admin Defined 2
Admin Defined 20
Admin Defined 5
Admin Defined 4
Admin Defined 5
S (=l

13

4 To add a column, select the column in the Available Fields list, then click the left-arrow to add it to

the Selected Columns list.
Many kinds of useful information can be added to an object’s display in ConsoleOne.
For users, displayable information includes:
¢ Current mailbox size
+ File ID (FID)
¢ Last client login time
¢ Move error
For POAs, displayable information includes:
¢ Port numbers
¢ Thread numbers
¢ Log level

* Platform

5 To determine the display order, select a column in the Selected Columns list, then click the up-

arrow and down-arrow to move it to the desired position.

6 To remove a column, select the column in the Selected Columns list, then click the right-arrow to

add it to the Available Fields list.

7 When you are finished, click OK to save your changes.
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3.3.2

Changing the Column Widths

You can change column widths in a view by dragging the right or left edge of the column label.
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3.4 Searching in the GroupWise View

You can search for a specific entry in a view. The search is performed on the first column. For
example, if the Resources view is displayed, you can search for a specific resource based on its object
ID. If the Users view (with Last Name Sort selected) is displayed, you can search for a specific user
based on the user’s last name.

With the Users view, if you have First Name Sort or Last Name Sort selected, you can search for a
complete user name (both first and last name) by using a comma as a delimiter between the names. A
space after the comma is optional.

For example, if the Users view displays first names in the first column and last names in the second
column, you can type John,Smith to go directly to that user name. If the columns were reversed, you
could use Smith,John.

To perform a search:

1 Change to the view you want to search.
2 Select the first entry in the view.

3 Type the text to search for.

66 GroupWise 2012 Administration Guide



3.5

As you type text, a text box appears in the lower right corner of the GroupWise View.

Novell ConsoleOne
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Performing Administrative Tasks from the GroupWise View

You can perform many GroupWise administrative tasks from the GroupWise View as well as from
the eDirectory View. For example, you can:

¢ Create new objects.
¢ Modify the properties of an object.
¢ Move, rename, or delete an object from the GroupWise system.

¢ Use the GroupWise utilities, system operations, and diagnostic options on the Tools menu.
In addition, external objects must be created and managed in the GroupWise View because they are,
by definition, external to eDirectory and have no eDirectory context. For example, if you install the

GroupWise Internet Agent (GWIA) and want to simplify addressing for your users by adding the
Internet as a non-GroupWise domain, you must perform the task in the GroupWise View.
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4.1

GroupWise System Operations

The GroupWise system operations in ConsoleOne allow you to perform various tasks to maintain
and optimize your GroupWise system. The following sections provide information about the system
operations included on the Tools menu (Tools > GroupWise System Operations):

¢ Section 4.1, “Select Domain,” on page 69

¢ Section 4.2, “System Preferences,” on page 72

¢ Section 4.3, “eDirectory User Synchronization,” on page 79

¢ Section 4.4, “"Admin-Defined Fields,” on page 79

¢ Section 4.5, “Pending Operations,” on page 80

¢ Section 4.6, “Addressing Rules,” on page 80

¢ Section 4.7, “Time Zones,” on page 81

¢ Section 4.8, “External System Synchronization,” on page 84

+ Section 4.9, “Software Directory Management,” on page 84

¢ Section 4.10, “Restore Area Management,” on page 89

¢ Section 4.11, “Internet Addressing,” on page 89

¢ Section 4.12, “Trusted Applications,” on page 90

¢ Section 4.13, “LDAP Servers,” on page 93

¢ Section 4.14, “Global Signatures,” on page 94

NOTE: If the majority of the items on the GroupWise System Operations menu are dimmed, you are
connected to a secondary domain in a GroupWise system where Restrict System Operations to Primary
Domain has been selected under System Preferences. This option is selected by default. For more
information, see Section 4.2, “System Preferences,” on page 72.

Select Domain

By default, ConsoleOne must be connected to a GroupWise domain in order for you to administer
your GroupWise system. Being connected to a GroupWise domain ensures that information is
replicated not only in Novell eDirectory but also in the GroupWise domain and post office databases.
¢ Section 4.1.1, “Selecting a Domain to Connect To,” on page 70
¢ Section 4.1.2, “Understanding the Need for Domain Connections,” on page 71

¢ Section 4.1.3, “Handling Cross-Platform Domain Connections,” on page 71
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4.1.1 Selecting a Domain to Connect To

You can be connected to any domain in the GroupWise system. Being connected to a domain means
that ConsoleOne has write access to the domain database (wpdomain.db).

As shown in the following example, the domain to which you are currently connected is indicated by
a plug on the domain’s icon. In addition, the connected domain is listed at the bottom of the
ConsoleOne window.

Movell ConsoleQne

70

File Edit Wiew Tools Help
T Q5|5 @| @] 48 vees Sosa ]
Ohject ID Domait Marme |Pos‘t office .. ‘ Last Mame | Given Mame ‘
a adhartnapalan Provod Marketing Dharmapalan  Shnan -
CORP_TREE 6 aramirez Provo2 Sales Rarmirez Art
% Groupiiise a askoczylas  Provodl Developtert  Skoczylas Alfong
8 bgelsomino  Prowo3 Marketing Gensomino Benjii
a choltan Prowo3 Marketing Biottan Charles
& thaughey Prowo3 Marketing Haughey Flavian = |
% Develapmant a fthompson Prowvod Marketing Thompson Fred
@ Prava? a gstmith Provot Developmerit Sinith Grace
Eh Sales 6 hzarmienta  Provo2 Sales Sarmiento Heather
@ Provo3 a jesata Provo3 harketing DeZoto Janet
% Marketing 8 jpangilingn Provot Development  Pangilinan Joe
a jstevens Prowo2 Sales Stevens Jason
& racoub Prowviod Marketing Yacouk Ishirizel
a khuang Proeeod Developmert  Huang Kuo-Chang
a tnbarnard Provot Developmerit Barnard Maitt
a mdelatarre Prowvo2 Sales ce la Torre hiartha
a mlamarouwx  Proved harketing Lamaroux hdarie ﬂ
|Cnrpuraie il |van1 |\UBD-I\N\I’\SYS\gwsy5‘tEm\pmVD1

To change the domain to which you are connected:

1 In ConsoleOne, click Tools > GroupWise System Operations > Select Domain.
X

GroupWise Administrator

Domain Path:
|\UBD\gwsys‘tem\prDvo1

o

Enter a valid path to a domain database and click OK, or click
Gancel to continue.

Cancel

2 Browse to and select the domain directory, then click OK to connect to the domain.

You can also connect to a domain by right-clicking the domain in the GroupWise View and
clicking Connect. However, in certain cross-platform situations, the Select Domain feature must
be used to create the connection.
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4.1.3

Understanding the Need for Domain Connections

Some administrative tasks require you to be connected to a specific domain but others do not. In
general, operations that create new GroupWise container objects or delete GroupWise container
objects require you to be connected to the domain where the object resides. Operations that add or
delete leaf objects or modify the properties of an existing object do not require you to be connected to
the object’s domain.

In addition to eDirectory considerations, administrative tasks that require file system access to
domain directories require direct connections.

¢ Create Domain: When you create a new domain, you must be attached to the primary domain
and have direct access to the server where you want to create the new secondary domain so that
ConsoleOne can create the new secondary domain database.

¢ Rebuild Domain Database: When you rebuild a secondary domain database, ConsoleOne
needs direct access to the primary domain in order to rebuild the secondary domain database.

¢ Sync Primary with Secondary: If your primary domain becomes out of date for some reason,
ConsoleOne requires direct access to the primary domain and a secondary domain in order to
update the data in the primary domain database based on the data available in the secondary
domain database.

+ Replace Primary with Secondary: If you have structural problems with your primary domain
database, ConsoleOne requires direct access to the primary domain and a secondary domain in
order to reconstruct the primary domain database from the data available in the secondary
domain database.

¢ Merge/Release: If you are combining or separating GroupWise systems, ConsoleOne requires
direct access to the primary domain and a secondary domain that is being merged or released.

Handling Cross-Platform Domain Connections

How the write access between ConsoleOne and a domain database is achieved depends on the
platform where you are running ConsoleOne and the platform where the domain is located.

ConsoleOne Domain Platform Connection Options

Platform
Linux Linux server Local directory
ConsoleOne ) o
Mounted file system where the mount point directory matches the
domain directory on the mounted file system
Windows server Mounted file system where the mount point directory matches the
Windows server hostname and share
Windows Linux server Samba mount where the path to the domain on the Linux server is
ConsoleOne prefixed by the Linux server hosthame from the point of view of
ConsoleOne
Windows server Local drive

Mapped drive

Instructions for mounting file systems and setting up Samba shares are provided in Chapter 2,
“ConsoleOne Administration Tool,” on page 39.
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The database location is stored internally in UNC path format (\\ server\volume\directory) butis
displayed on the Domain object Identification page in ConsoleOne based on the platform of
ConsoleOne and the database location.

ConsoleOne Domain Platform Database Location

Platform
Linux Linux server /domain directory
ConsoleOne
Windows server /mnt/windows server/share/domain directory
Windows Linux server \\1linux server\domain directory
ConsoleOne
Windows server \\windows server\share\domain directory

When you click Connect in the GroupWise View, ConsoleOne uses the domain’s UNC path to
automatically connect you to the correct domain if possible; otherwise, you must use the Select
Domain feature to manually browse to and select the domain database in order to connect to the
domain.

4.2 System Preferences

You can use the GroupWise system preferences to configure the defaults for various GroupWise
system settings.

1 In ConsoleOne, click Tools > GroupWise System Operations > System Preferences.

GroupWise System Preferences @

Adrin Lockout Settings Archive Service Settings
&5 || Routing Options | External Access Rights | Mickname Settings

Set access rights automatically:
|:| ‘When creating a Groupiwise user

When creating or modifying objects, For networl 1D use:
() Full Distinguished Mame
(&) Common Name

[] Display Identity Manager (DirsML) warnings

The GroupWise System Preferences dialog box contains the following tabs:

¢ Admin Preferences: Controls how rights are assigned and what network ID format is used
when creating new GroupWise users. By default, rights are assigned automatically and the
fully distinguished name format is used.

¢ Routing Options: Controls default message routing for your GroupWise system. By default,
no routing domain is assigned.

¢ External Access Rights: Controls the access that users on external GroupWise systems have
to your GroupWise users’ information. By default, Busy Search and status tracking
information is not returned to users on external GroupWise systems.

¢ Nickname Settings: Controls how addressing is handled after you move a user from one
post office to another. By default, nicknames representing old addresses are not
automatically created when users are moved.
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¢ Default Password: Assigns a default password for new GroupWise user accounts. By
default, you must manually assign a password for each GroupWise account you create.

¢ Admin Lockout Settings: Controls access to the GroupWise administration functions in
ConsoleOne. By default, there are no restrictions.

¢ Archive Service Settings: Sets the default archive service for your GroupWise system.
Archive services are third-party applications that can function as GroupWise trusted
applications, such as Messaging Architects M+Archive Email Archiving Software (http://
www.messagingarchitects.com/products/m-archive-email-archiving.html). When you
install an archive service to a server, the archive service is added to the list of archive service
trusted applications that displays in ConsoleOne.

¢ Linux Settings (Linux ConsoleOne Only): Establishes the mount directory where
ConsoleOne can find mounted file systems where domains and post offices are located.

2 Change the system preferences as needed.
3 Click OK to save the changes.

4.2.1 Admin Preferences

1 In the GroupWise System Preferences dialog box, click the Admin Preferences tab to modify any
of the following options:

GroupWise System Preferences E‘

Admin Lockout Settings Archive Service Settings
* i| Routing Options | External Access Rights | Mickname Settings

Sek access rights automatically:
|:| ‘When creating a Grouphiise user

‘When creating or modifying objects, for network 1D use:
(%) Full Distinguished Mame
() Comman Narme

[] Display Identity Manager (DirsML) warnings

Set Access Rights Automatically: Users require specific eDirectory and file system rights in
order to use GroupWise (see Chapter 89, “GroupWise User Rights,” on page 1141). Select this
option to automatically grant these rights when creating a GroupWise account for users.

Appropriate eDirectory object rights enable the GroupWise client to log in to the user’s post
office without prompting the user for the post office location (IP address, UNC path, or mapped
drive.)

Appropriate file system rights enable the GroupWise client to directly access the post office
directory rather than use client/server access.

When Creating or Modifying Objects, For Network ID Use: Select Full Distinguished Name (for
example, paul.engineering.ny) when users' mailboxes reside on a NetWare server and users
have an eDirectory connection to the server where the post office resides.

Starting in GroupWise 2012, NetWare is no longer a supported GroupWise platform. However,
Novell eDirectory is still required (version 8.7 or later). The supported versions of eDirectory use
full distinguished names for network IDs.

Do not select Common Name (for example, paul).

Display Identity Manager (DirXML) Warnings: The Identity Manager Driver for GroupWise
provides data integration between GroupWise users and groups in eDirectory. For example, you
can have an email account automatically created as soon as an employee is hired. The same
driver can also disable an email account when a user is no longer active.
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If you are using the Identity Manager Driver for GroupWise, some GroupWise operations that
you perform in ConsoleOne require you to take preliminary actions with the driver. For
example, if you recover a deleted account, you need to stop the driver before recovering the
account and restart it after the operation is complete.

This option enables you to receive a warning message whenever you perform a GroupWise
operation in ConsoleOne that is affected by the Identity Manager driver. The warning message
includes instructions about the actions you need to take with the driver before continuing with
the GroupWise operation. If you are using the Identity Manager Driver for GroupWise, we
strongly recommend that you enable this option. If you are not using the driver, you can disable
the option to avoid receiving unnecessary messages.

For more information, see “GroupWise DirXML Driver for Novell Identity Manager” in the
GroupWise 2012 Interoperability Guide.

2 Click OK to save the changes.

4.2.2 Routing Options

1 In the GroupWise System Preferences dialog box, click the Routing Options tab to modify any of
the following options:

GroupWise System Preferences El

Default Password | Admin Lockout Settings Archive Service Settings
Admin Preferences || Routing Options || External Access Rights | Mickname Settings

Default Routing Damain;

[1MTAs send directy ko ather GrouptWise systems

Default Routing Domain: If a domain’s MTA cannot resolve a message’s address, the message
is routed to this default domain’s MTA. The default domain’s MTA can then be configured to
handle the undeliverable messages. This might involve routing the message to another
GroupWise domain or to an Internet address (by performing a DNS lookup). Browse to and
select the GroupWise domain you want to use as the default routing domain.

Force All Messages to this Domain: This option applies only if you select a default routing
domain. Select this option to force all messages to be routed through the default routing domain
regardless of the links you have configured for your GroupWise system’s domains.

MTAs Send Directly to Other GroupWise Systems: Select this option if you want all MTAs in
your GroupWise system to perform DNS lookups and route messages out across the Internet. If
you deselect this option, you can designate individual MTAs to perform DNS lookups and route
messages to the Internet. For more information, see “Using Dynamic Internet Links” in
“Connecting to Other GroupWise Systems” in the GroupWise 2012 Multi-System Administration
Guide.

2 Click OK to save the changes.

4.2.3 External Access Rights

1 In the GroupWise System Preferences dialog box, click the External Access Rights tab to modify
any of the following options:
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4.2.4

GroupWise System Preferences El

Default Password Adrin Lockout Settinas
Admin Preferences | Routing Options |; E

Archi\_f_'_e Service Settings
* || Nickname Settings

[] Allovs external busy search

[] Allaws external status tracking

Allow External Busy Search: Select this option to enable users in other GroupWise systems to
perform Busy Searches on your GroupWise users’ Calendars.

Allow External Status Tracking: Select this option to enable users in other GroupWise systems
to receive message status information (such as whether a message has been delivered, opened,
and so on) when messages arrive in your GroupWise system.

2 Click OK to save the changes.

Nickname Settings

A nickname is an additional GroupWise address that can be associated with a user, resource, or
distribution list. For background information, see Section 14.7.4, “Creating a Nickname for a User,”
on page 252.

1 In the GroupWise System Preferences dialog box, click the Nickname Settings tab to modify any
of the following options:

GroupWise System Preferences

Default Password Admin Lockout Settings
Admin Preferences | Routing Options | External Access Rights

Auko-create on User Mave
(%) Never
) Blways
() Prompt

4

Auto-Create on User Move: Whenever you move a user, GroupWise can automatically create a
nickname with the user’s old post office. This enables messages sent to the old address to be
automatically forwarded to the user’s new address. Select whether or not you want GroupWise
to never create nicknames, always create nicknames, or prompt you during the move process.

Expire After: This option applies only if you selected Always or Prompt. If you want the
nickname to be automatically removed after a period of time, specify the time period (in days).
Valid values range from 1 to 365 days. A setting of 0 indicates that the nickname will not be
automatically removed.

2 Click OK to save the changes.
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4.2.5

Default Password

1 In the GroupWise System Preferences dialog box, click the Default Password tab to modify any of

the following options:

GroupWise System Preferences El

Admin Preferences | Routing ©ptions | External Access Rights || Mickname Settings
__P_’?_ff_'-_'_‘f_E?ff}f}f?[\?!__ Admin Lockout Settings Archive Service Settings

Default password For new users:

Default Password for New Users: Specify the default password you want assigned to new
GroupWise user accounts.

2 Click OK to save the changes.

4.2.6  Admin Lockout Settings

1 In the GroupWise System Preferences dialog box, click the Admin Lockout Settings tab to modify

any of the following options:

GroupWise System Preferences El

Admin Preferences | Routing Ootions | External Access Rights | Nickname Settings
Default Password i Archive Service Settings

Restrict System Cperations ko Primary Domain
[ Lock Out Glder GroupWise Administration Snapins

Winimum Snapin Release Yersion (x.x.x):

Winimum Snapin Release Date:

B

Restrict System Operations to Primary Domain: Disable this option to allow an administrator
to perform system operations (Tools > GroupWise System Operations) when he or she is not
connected to the primary domain. This option is enabled by default, which means that all
operations except Select Domain, Pending Operations, Software Directory Management, and Restore
Area Management are unavailable when connected to a secondary domain.

Lock Out Older GroupWise Administration Snap-Ins: Enable this option to prevent
administrators from using older GroupWise ConsoleOne snap-ins for accessing GroupWise
objects in eDirectory. You can override these system lockout settings for individual domains
(Domain object > GroupWise > Admin Lockout Settings).

In versions of GroupWise earlier than 2012, there are four GroupWise snap-ins to ConsoleOne,
one for general administration, one for Internet Agent (GWIA) administration, and two for
WebAccess administration. In GroupWise 2012, WebAccess configuration information is no
longer stored in eDirectory, so no WebAccess eDirectory objects are needed. The ability to lock
out older GroupWise snap-ins starts with GroupWise 6.5.

In the Minimum Snap-In Release Version (x.x.x) field, specify the version number of the oldest
GroupWise snap-ins that can be used to administer your GroupWise system.
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In the Minimum Snap-in Release Date field, select the date of the oldest GroupWise snap-ins that
can be used to administer your GroupWise system.

You can specify the minimum version, the minimum date, or both. If you specify both
minimums, any administrator using snap-ins that are older than both minimums cannot use the
GroupWise snap-ins. However, such an administrator can still run ConsoleOne for other
purposes but must update the GroupWise snap-ins before GroupWise administration features
are available again. Default admin lockout settings can be overridden on individual domains as
needed.

The date for GroupWise 2012 is January 17, 2012.

IMPORTANT: The specified release version and release date affect the Identity Manager
GroupWise Driver as well as the ConsoleOne snap-ins. If you are using Identity Manager with
GroupWise, do not specify a release version or date that is newer than the release version and
date of the Identity Manager GroupWise Driver that you are running.

2 Click OK to save the changes.

Archive Service Settings

When you use a message retention service with GroupWise, as described in Chapter 33, “Retaining
User Messages,” on page 441, you have the option of associating an archive service with the message
retention service. The message retention service and its associated archive service must be set up as a
GroupWise trusted application, as described in Section 4.12, “Trusted Applications,” on page 90.
Different archive services provide differing storage alternatives (memory, disk, or tape, for example)
and differing alternatives for speed and cost. You can configure multiple archive services for your
GroupWise system.

+ “Selecting the System Default Archive Service” on page 77
¢ “Overriding the System Default Archive Service” on page 78

Selecting the System Default Archive Service

1 In the GroupWise System Preferences dialog box, click the Archive Service Settings tab to select
the system default archive service for your GroupWise system.

GroupWise System Preferences El
Admin Preferences | Routing Options | External Access Rights | Mickname Settinas
Defauk Password | Admin Lockout Settings |} Archive Service Satiings
Archive Service Trusted Applications:
<Mone> v

Archive Service Trusted Applications: Lists the third-party archive services that are available to
your GroupWise system as trusted applications.

Select the archive service that you want to use as the default for your GroupWise system. You
can override the system default on individual post offices.

2 Click OK to save your selection.
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Overriding the System Default Archive Service

1 Browse to and right-click the Post Office object where you want to override the default, then
click Properties

2 Click GroupWise > Post Office Settings.
3 In the Default Archive Service Trusted Application field, select Override.
4 Select the archive service for that post office, then click OK.

4.2.8 Linux Settings (Linux ConsoleOne Only)

1 Inthe GroupWise System Preferences dialog box, on Linux, click the Linux Settings tab to specify
the mount directory.

= GroupWise System Preferences x

Archive Service Settings | Linux Settings |

Default Password |' Admin Lockout Settings
External Access Rights r Nickname Settings
Admin Preferences r’ Routing Options

Linux Mount Directory:

[ e [

Enter a walid path to the mount directory and click OF, or click
Cancel to continue.

| OK || Cancel H Help |

Mount Directory: Specify the mount directory where ConsoleOne can find mounted file
systems where domains and post offices are located.

GroupWise databases can be located on Linux servers or Windows servers. In the Linux mount
directory, you create directories that have the same names as the servers that are mounted to
those mount points. You do this for each server where a domain or post office is located that you
want to access from ConsoleOne. The following table illustrates the correspondence between
UNC paths and mount point directories for GroupWise database locations on Linux and
Windows, assuming the typical mount point directory of /mnt:

Platform GroupWise Domain UNC Path Corresponding Linux
Mount Point
Linux \\linux server\gw partition\domain directory /mnt/linux server/

gw _partition

Windows \\windows server\gw share\domain directory /mnt/windows_server/
gw_share

GroupWise administrators can have different mount points depending on the workstation or
server where they are running ConsoleOne. The mount directory information is stored in a user-
specific preferences file (. consoleone/SnapinPrefs. ser in each GroupWise administrator’s
home directory).

2 Click OK to save the changes.
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4.4

eDirectory User Synchronization

For user information to be displayed in the GroupWise Address Book, the information must be
stored not only in eDirectory but also in the GroupWise domain and post office databases. If you add
or modify user information using an installation of ConsoleOne with the GroupWise Administrator
snap-in, the GroupWise Administrator snap-in adds the user information to the GroupWise
databases. However, if you add or modify user information using a ConsoleOne installation that is
not running the GroupWise Administrator snap-in, the user information is not changed in the
GroupWise databases. This is also true if you add or modify user information using Novell iManager
or older administration tools such as NetWare Administrator to manage a legacy GroupWise
domain.

To ensure that the user information stored in the GroupWise databases is always synchronized with
the user information in eDirectory, you can set up eDirectory user synchronization. For detailed
information see Section 42.4.1, “Using eDirectory User Synchronization,” on page 652.

Admin-Defined Fields

eDirectory includes user information that is not associated to GroupWise user fields. By default, such
eDirectory fields are not displayed in the GroupWise Address Book. However, you can use the
Admin-Defined Fields feature to map eDirectory user fields to GroupWise fields so that they can be
displayed in the GroupWise Address Book.

1 Click Tools > System Operations > Admin-Defined Fields.

Administrator-Defined Fields @
Current Field Mappings:
GroupWise field eDirectory Property

Admin Defined 1 <unused:= ~
Admin Defined 2 <unused=

Admin Defined 3 <unuseds=

Admin Defined 4 <unuseds=

Admin Defined 5 <unuseds=

Admin Defined & <unuseds=
Admin Defined 7 <unused:

Admin Defined 8 <unused: -
Admin Defined 3 <unused:
Admin Defined 10 <unused:

Admin Defined 11 <unused::

Admin Defined 12 “unused:

Admin Defined 13 “unused:

Admin Defined 14 “unused:

Admin Defined 15 <unused:s

Admin Defined 16 <unused:=

Admin Defined 17 <unused:=

Admin Defined 18 <unused:=

Admin Defined 19 <unused:= 2

eDirectory fields that you associate with GroupWise fields here are available for use in all
domains throughout your GroupWise system. You can also customize the GroupWise Address
Book for individual domains, as described in Section 6.1.1, “Adding eDirectory Fields to the
Address Book,” on page 106

2 Select the first available admin-defined field, then click Edit.

3 Select the eDirectory property that you want to associated with the admin-defined field, then
click OK.

4 To remove an admin-defined field, select the field, then click Clear.

You are prompted for whether to remove the corresponding values from user records. This
might be a time-consuming process.
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5 Click Yes to clean up all obsolete references to deleted admin-defined fields in all user records.
or
Click No to perform the cleanup later.

At any time, you can click Cleanup to remove obsolete references to deleted admin-defined fields
from all user records. It is a good practice to run Cleanup periodically to ensure that the admin-
defined fields in ConsoleOne match the admin-defined fields that appear in user records.

4.5 Pending Operations

Pending operations are the results of administrative operations, such as adding GroupWise objects
and modifying GroupWise object properties, that have not yet been permanently written to the
appropriate GroupWise databases. While operations are pending, GroupWise data is not in a
consistent state.

For example, you can maintain any domain’s objects you have administrative rights over. However,
because a secondary domain owns its own objects, any operation you perform from the primary
domain on a secondary domain’s objects must be validated by the secondary domain. While the
operation is being validated, the Pending Operations dialog box displays object details and the
pending operation.

While the operation is pending, the object is marked Unsafe in the primary domain database. The
Operation field in the dialog box displays the pending operation. An unsafe object can have other
operations performed on it, such as being added to a distribution list; however, the object record is
not distributed to other domains and post offices in the system until it is marked Safe.

All pending operations require confirmation that the operation was either successfully performed or
could not be performed. If the operation was successful, the pending operation is removed from the
list, the record is marked in the database as Safe, and the record is distributed to all other domains
and post offices in your system. If the operation could not be performed, the pending operation
remains in the list where you can monitor and manage it.

1 In ConsoleOne, connect to the domain whose pending operations you want to view, as described
in Section 4.1, “Select Domain,” on page 69.

2 Make sure the agents are running for the domain and/or post office where you are checking for
pending operations

3 Click Tools > GroupWise System Operations > Pending Operations.

While an operation is being validated, the Pending Operations dialog box displays the object
and the operation waiting completion and confirmation.

4 For more detailed information, select the pending operation, then click View.

5 If conditions on the network have changed so that a pending operation might now succeed,
select the pending operation, then click Retry.

6 If you want to cancel a pending operating that has not yet taken place, select the pending
operation, then click Undo.

4.6 Addressing Rules

You can use the Addressing Rules feature to configure GroupWise so that users can enter shortened
forms of email addresses for use through GroupWise gateways.

80 GroupWise 2012 Administration Guide



4.7

4.7.1

NOTE: GroupWise gateways are legacy products that are not supported with the current GroupWise

version.

Time Zones

When you create a domain or post office, you select the time zone in which it is located. This ensures
that GroupWise users in other time zones receive Calendar events and tracking information adjusted

for local time.

The time zone list includes predefined definitions for each time zone. Most time zones include

multiple definitions to account for different locations within the time zone. Each time zone definition
allows you to specify the Daylight Saving Time dates and bias (1 hour, 30 minutes, etc.).

You can modify existing time zone definitions, add new definitions, or delete definitions.

¢ Section 4.7.1, “Modifying a Time Zone Definition,” on page 81

¢ Section 4.7.2, “Adding a Time Zone Definition,” on page 82

¢ Section 4.7.3, “Deleting a Time Zone Definition,” on page 83

Modifying a Time Zone Definition

1 In ConsoleOne, click Tools > GroupWise System Operations > Time Zones.

Configure Time Zones

Time: Zanes:

GMT) Cazahlanca, Monrovia
i Aean Time, in, Edinburgt )
(GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Yienna
(GMT+01:00) Belarade, Bratizlava, Budapest, Liukljana, Prague
(GMT+01:00) Brussels, Copenhagen, Madrid, Paris, Vilnius
(GMT+01:00) Sarajevo, Skopje, Sofia, Warsaw, Fagreh
(GMT+02:00) &thens, lstanbul, Minsk
(GMT+02:00) Bucharest
(GMT+02:00) Cairo
(GMT+02:00) Harare, Pretoris
(GMT+02:00) Helzinki, Riga, Talinn
(GMT+02:00) lsrael

Daylight Saving Titne

Start DatedTime:  Last Sunday of March at 2:00 A
End DateiTime:  Last Sunday of October st 3:00 AM

2 Select the time zone to modify, then click Edit to display the Edit Time Zone dialog box.

Time Zone Mame:  (GMT-05:00) |Eastem Time (L5 & Canada)|

Offset From GMT: @ haurs lIl@ minukes
Abbreviation:

Ohserve Daylight Savings Time

| oK

StartDay: |Second | [Sunday | of [march

| at [zooan |

Last Day: ‘First v| |Sunday V| af |Novamber

o] at fzoo_|

Bias: g hours lIl% minutes

3 Modify any of the following fields:

GroupWise System Operations

81



82

Time Zone Name: Provide a name for the time zone definition (for example, some of the major
cities in the time zone). We suggest you include a reference (+ or -) to GMT, for example (GMT-
07:00). The time zone list is sorted by the GMT offset.

Offset from GMT: Specify the hours and minutes that the time zone is offset from Greenwich
Mean Time. The offset from GMT keeps your different locations synchronized. For example, if a
conference call is scheduled for 4:00 p.m. June 1 in Salt Lake City, the call would appear on a
schedule in Adelaide at 8:30 a.m. June 2. If you are in the western hemisphere (west of the
Greenwich Meridian and east of the International Date Line) be sure the hour offset is negative (-
). If you are in the eastern hemisphere (east of the Greenwich meridian and west of the
International Date Line) be sure the hour offset is positive.

Abbreviation: Specify an abbreviation for the time zone. For example, the abbreviation for
Atlantic Standard Time could be AST; the abbreviation for Atlantic Daylight Time could be
ADT.

Observe Daylight Saving Time: If the time zone observes daylight saving time, click the
Observe Daylight Saving Time box, then fill out the remaining fields.

Start Day: Select the week, day, month, and hour daylight saving time starts.
Last Day: Select the week, day, month, and hour daylight saving time ends.
Bias: Enter the number of hours and minutes that the clock changes at the daylight saving time

start day, such as 1 hour or 1 hour 30 minutes.

Example:

Start day: Second Sunday of March at 2:00 am.
Last day: First Sunday of November at 2:00 am.
Bias: 1 hour 0 minutes

4 Click OK to save the changes.

4.7.2 Adding a Time Zone Definition

1 In ConsoleOne, click Tools > GroupWise System Operations > Time Zones.

Configure Time Zones

Time: Zanes:

Cloze

at Tiene; Dubling, Edinburgh, Liskon, London
(G am, Berlin, Bern, Rome, Sto , Wienna

kL

(GMT+01:00) Belarade, Bratizlava, Budapest, Liukljana, Prague

(GMT+01:00) Brussels, Copenhagen, Madrid, Paris, Yilhius Delete
(GMT+01:00) Sarajevo, Skopje, Sofia, Warsaw, Zagreh

(GMT+02:00) Ahers, Istarbul, Mirsk it

(GMT+02:00) Bucharest

(GRT+02:00) Cairo

(GMT+02:00) Harare, Pretoria

(GMT+02:00) Helsinki, Riga, Talinn

(GT+02:00) Israel |

Daylight Saving Tine

Start DatefTime:  Last Sunday of March at 2:00 &AM
End DatefTime:  Last Sunday of October at 3:00 &AM

2 Click Add to display the Add Time Zone dialog box.
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Add Time Zone

Time Zone Mame:  (GRT) |

Offset framm GMT. 1} %‘ hours: 0 %{ minutes
Abbreviation:

™ Observe Daylight Savings Time

Cancel

dil,

Help

j |Sunday j of ‘Apri\

Start Day:  [First

| et [zooem

j |Sunday
Bias: 1 %‘ hours: 0 %{ minutes

Last Day:  |Last = of |october

| & [2008m

3 Fill in the following fields:

Time Zone Name: Provide a name for the time zone definition (for example, some of the major

cities in the time zone). We suggest you include a reference (+ or -) to GMT, for example (GMT-
07:00). The time zone list is sorted by the GMT offset.

Offset from GMT: Specify the hours and minutes that the time zone is offset from Greenwich

Mean Time. The offset from GMT keeps your different locations synchronized. For example, if a

conference call is scheduled for 4:00 p.m. June 1 in Salt Lake City, the call would appear on a
schedule in Adelaide at 8:30 a.m. June 2. If you are in the western hemisphere (west of the

Greenwich Meridian and east of the International Date Line) be sure the hour offset is negative (-
)- If you are in the eastern hemisphere (east of the Greenwich meridian and west of the

International Date Line) be sure the hour offset is positive.

Abbreviation: Specify an abbreviation for the time zone. For example, the abbreviation for
Atlantic Standard Time could be AST; the abbreviation for Atlantic Daylight Time could be

ADT.

Observe Daylight Saving Time: If the time zone observes daylight saving time, click the
Observe Daylight Saving Time box, then fill out the remaining fields:

¢ Start Day: Select the day and time that daylight saving time starts.

¢ Last Day: Select the day and time that daylight saving time ends.

¢ Bias: Select the number of hours and minutes that the clock changes at the daylight saving

time start day, such asl hour or 1 hour 30 minutes.

4 Click OK to add the definition to the time zone list.

Deleting a Time Zone Definition

When you delete a time zone from the list, you can no longer select it for a domain or post office.

1 In ConsoleOne, click Tools > GroupWise System Operations > Time Zones.
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Configure Time Zones

Time Zones:

(GMT) Casablanca, Monrovia - 4
¥ GMT) Greenwich Mean Time; Dublin, Edinburgh, Lishon, London 4
(GMT+01:00) Amsterdarm, Berlin, Bern, Rome, Stockholm, Yienna
(GMT+01:00) Belgrade, Bratizlava, Budapest, Ljubljana, Prague
(GMT+01:00) Brussels, Copenhagen, Madrid, Paris, Yilnius Delets
(GMT+01:00) Sarajevo, Skopie, Sofiia, Warsaw, Zagreh

(GMT+I2:00) Mhens, stanbul, Minsk Help
(GMT+02:00) Bucharest

(GMT+02:00) Cairg

(GMT+02:00) Harare, Pretoris

(GMT-+02:00) Helsinki, Riga, Talinn

(GMT+02:00) Israel |

Daylight Saving Time

Start DatedTime:  Last Sunday of March at 2:00 Ak
End DateiTime:  Last Sunday of October at 3:00 AM

2 Select the time zone to remove from the list, click Delete, then click Yes to confirm the deletion.

4.8 External System Synchronization

The External System Synchronization feature lets you automatically synchronize information
between your system and an external GroupWise system connected to your system. For information
about connecting GroupWise systems and keeping information synchronized between them, see
“Connecting to Other GroupWise Systems” in the GroupWise 2012 Multi-System Administration Guide.

4.9 Software Directory Management

The Software Directory Management feature lets you manage GroupWise software distribution
directories. A software distribution directory is simply a copy or partial copy of the downloaded
GroupWise 2012 software image located on a network server. Diagrams of the contents of software
distribution directories are provided in “Directory Structure Diagrams” in GroupWise 2012
Troubleshooting 3: Message Flow and Directory Structure:

¢ “Linux Software Distribution Directory”
+ “Windows Software Distribution Directory”
From this network location, you can distribute the GroupWise Windows client software to users or

install additional GroupWise software such as the Message Transfer Agent, Post Office Agent,
Internet Agent, WebAccess Application, Calendar Publishing Host Application, and Monitor.

When you install GroupWise, one software distribution directory is created automatically. Using
Software Directory Management, you can create additional software distribution directories, update
existing software distribution directories, or delete existing software distribution directories. A single
software distribution directory can service multiple post offices and can contain software for multiple
platforms.

¢ Section 4.9.1, “Creating a Software Distribution Directory,” on page 85

¢ Section 4.9.2, “Updating a Software Distribution Directory,” on page 87

¢ Section 4.9.3, “Deleting a Software Distribution Directory,” on page 88

84 GroupWise 2012 Administration Guide


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_msadmin/gw2012_guide_msadmin.pdf#acteyas
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_msadmin/gw2012_guide_msadmin.pdf#a2zvyc4
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#A3vxdw1
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#a4ehibh
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#a4ehibh
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#bqtgbqq
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#bqtgbn1

49.1

Creating a Software Distribution Directory

During installation on a Linux server, the initial software installation directory is created
automatically in /opt/novell/groupwise/software and the GroupWise agent software is
automatically copied there. You can select additional GroupWise software components to copy into
the initial software distribution directory.

During installation on a Windows server, the default location for the software distribution directory
is c:\grpwise\software, but you can change the location as needed. You can select any GroupWise
software components to copy into the initial software distribution directory.

After installation, you can create additional software distribution directories on any servers where
you want the GroupWise software to be easily accessible for future installations.

IMPORTANT: In general, for simplicity of administration in a multiple-platform environment, use
Linux ConsoleOne to create and maintain software distribution directories on Linux servers. Use
Windows ConsoleOne to create and maintain software distribution directories on Windows servers.

1 In ConsoleOne, click Tools > GroupWise System Operations > Software Directory Management to
display the Software Distribution Directory Management dialog box.

Softwa re Distribution Directory Management x|
Software Distribution Directories: e
Name | UNC Path |
Corporate OES Wibd-oestoptinovelllgroupwisesoftware Create
Corporate Windows  \\jbd-winlc\arpwiselsoftware =
Delete
Update
Help

The Software Distribution Directories list includes all software distribution directories defined in
your GroupWise system.

2 Click Create to display the Create Software Distribution Directory dialog box.

Create Software Distribution Directory ll
Description: Cancel |
Help |
[ Lacation
UNC Path;

AppleTalk Path {optional):

Linux Path {optional):

I~ Copy software From:

% Softivare Distribution Direckary:

ICnrpnratE OES LI
= Pathy:

1]
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3 Fill in the following fields:

Name: Specify a name to identify the software distribution directory within your GroupWise
system. For example, whenever you create a post office, you associate it with a software
distribution directory. The software distribution directory’s name, not its location, appears in the
list of directories from which you can select. The name can include any characters; there are no
restrictions.

Description: Specify an optional description for the software distribution directory. You might
want to use this description to indicate the software version or to give other pertinent
information.

Location: Specify the location where you want to create the new software distribution directory.
If you specify a path to a directory that does not exist, ConsoleOne creates the directory for you.

Linux In the UNC Path field, specify the location where you want to create the new software

ConsoleOne:  distribution directory in UNC path format. Linux ConsoleOne automatically converts the
UNC path format into a Linux path from the point of view where you are running
ConsoleOne

The GroupWise Windows client software can be distributed from a Linux server rather
than a Windows server, if the required cross-platform connection as been established, as
described in Section 77.1, “Using GroupWise AutoUpdate and SetuplP to Distribute the
GroupWise Windows Client,” on page 1069. However, you must use Windows
ConsoleOne in order to specify the UNC path as required to access the Windows client
software, because Linux ConsoleOne converts the UNC path into a Linux path, which
makes the Windows client software inaccessible from the point of view of Windows.

The AutoUpdate functionality does not apply to the GroupWise Linux client.

GroupWise Linux administration, agents, and applications can be installed on new Linux
servers after the software has been distributed to those servers.

In the Linux Path field, specify the location of the software distribution directory as a
Linux path from the point of view of the Linux POA that needs to access it. This is
required when the software distribution directory is on a Linux server.

Windows In the UNC Path field, specify the location where you want to create the new software
ConsoleOne:  distribution directory in UNC path format. Do not use mapped drive format.

If you enable AutoUpdate, as described in Section 77.1, “Using GroupWise AutoUpdate
and SetuplP to Distribute the GroupWise Windows Client,” on page 1069, the
GroupWise Windows client checks this location for software updates.

IMPORTANT: If the Windows client software is located in a software distribution directory
on a Linux server, you must use Windows ConsoleOne in order to specify the UNC path
to access the Windows client software. Linux ConsoleOne converts the UNC path into a
Linux path, which makes the Windows client software inaccessible from the point of view
of Windows.

GroupWise Windows administration, agents, and applications can be installed on new
Windows servers after the software has been distributed to those servers.

Copy Software From: Select this option to copy GroupWise software from the existing location
to the new location, then choose from the following source locations:

¢ Software Distribution Directory: If you want to copy software from an existing software
distribution directory, select this option, then select the software distribution directory. All
directories are copied.

¢ Path: If you want to copy software from a location that is not defined as a software
distribution directory in your GroupWise system, such as the downloaded GroupWise 2012
software image, select this option, then browse to and select the correct path.
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49.2

4 Click OK to create the software distribution directory and add it to the list.

(8 software Distribution Directory Management x|
Software Distribution Direckariss: e
Name | NG Path |
Corporate OES \|jbd-oesioptinovellgroupwiselsoftware i Creats
(Corporate SLES ibd-Imdoptinovell groupwiselsoftware =
(Corporate Windows || jbd-winlclarpwise\software —I
Delete
Update
Help

5 Click Close to exit the dialog box.

Each time it starts, the POA checks to make sure it can access the software distribution directory that
is assigned to its post office. If it encounters a problem accessing its software distribution directory,
the POA notifies you of the problem through the POA agent console and the POA log file. This helps
ensure that each software distribution directory is always available.

Updating a Software Distribution Directory

When you install updated GroupWise software, the installation process includes updating one
software distribution directory. After installation, you use the Software Directory Management
feature to copy the updated software to all other software distribution directories in your GroupWise

system.

1 In ConsoleOne, click Tools > GroupWise System Operations > Software Directory Management to
display the Software Distribution Directory Management dialog box.

Software Distribution Directory Management LI
Software Distribution Direchories: Close
Name | LNC Path |
(Corporate QES \\ibd-oestoptinovellgroupwiselsoftware : Create I
(Corporate SLES Wibd-nxioptinovellgroupwiseisaftware =
(Corporate Windows  {libd-win\clarpwise\software _I
Delete
Update
Help

The Software Distribution Directories list includes all software distribution directories defined in
your GroupWise system.

2 Select the software distribution directory to update, then click Update to display the Update
Software Distribution Directory dialog box.
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Update Software Distribution Directory x|

I i ok |
{+ Software Distribution Ditectory: Cancel |
ICDrporate QES ﬂ Help |
) Pathi
| [ |

[~ Force auto-update check by Groupiiise components

3 Fill in the following fields:
Update by Copying From: Select this option, then choose from the following source locations:

¢ Software Distribution Directory: If you want to copy updated software from an existing
software distribution directory, select this option, then select the software distribution
directory. All files and subdirectories are copied.

¢ Path: If you want to copy updated software from a location that is not defined as a software
distribution directory in your GroupWise system, such as the downloaded GroupWise 2012
software image, select this option, then browse for and select the correct path.

Force Auto-Update Check by GroupWise Components: This option causes the GroupWise Post
Office Agent to check the software distribution directory for a new version of the GroupWise
Windows client. If a new version is found, the next time a user starts the GroupWise Windows
client, he or she is prompted to update the client software.

Select this option to automatically inform users whenever updated software is available.

Even if you do not select the Update by Copying From option, you can still select this option, then
click OK. This forces an auto-update check of the client software version, but the software
distribution directory’s files are not updated.

To determine the current client software version in ConsoleOne, click Tools > GroupWise
Diagnostics > Record Enumerations to display a list of record types in the domain database. From
the drop-down list, select Areas by ID, select a software distribution directory, then click Info to
list detailed information about the software distribution directory. Look at the Software Version
field to determine the GroupWise client software version.

4 Click OK to update the directory’s software.

4.9.3 Deleting a Software Distribution Directory

When you delete a software distribution directory, the directory is removed from the file system and
no longer appears in the list of software distribution directories. You cannot delete a software
distribution directory if any post offices are still configured to access it.

To delete a software distribution directory:

1 In ConsoleOne, click Tools > GroupWise System Operations > Software Directory Management to
display the Software Distribution Directory Management dialog box.
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Software Distribution Directory Management

Software Distribution Directories:
Name | UNC Path
(Corporate OES \ibd-oestoptinovel|groupwiselsoftware

(Corporate SLES WibdHnxioptinovellgroupwise\saftware B

(Corporate Windows — {1ibd-win\clarpwise\software
Delete
Update
Help

The Software Distribution Directories list includes all software distribution directories defined in
your GroupWise system.

2 Select the directory to delete, click Delete, then click Yes to confirm the deletion.

4,10 Restore Area Management

A restore area is a location you designate to hold a backup copy of a post office so that you or
GroupWise users can access it to retrieve mailbox items that are unavailable in your live GroupWise
system. The Restore Area Management feature lets you manage your GroupWise system’s restore
areas.

Detailed information for using restore areas is provided in Section 32.5, “Restoring Deleted Mailbox
Items,” on page 435. Information about backing up post offices is provided in Section 31.2, “Backing
Up a Post Office,” on page 431.

4.11 Internet Addressing

By default, GroupWise uses a proprietary address format consisting of a user’s ID, post office, and
domain (userID.post_office.domain). After you install the GroupWise Internet Agent (GWIA), you can
configure your GroupWise system to handle one or more formats of Internet email addresses. For
setup instructions, see Chapter 52, “Configuring Internet Addressing,” on page 743.
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4.12 Trusted Applications

Trusted applications are third-party programs that can log into Post Office Agents (POAs) and
Internet Agents (GWIAs) in order to access GroupWise mailboxes without needing personal user
passwords. Trusted applications might perform such services as message retention or
synchronization with mobile devices. The Trusted Application feature allows you to edit and delete
trusted applications that are available in your GroupWise system.

For information about creating and installing trusted applications, search for GroupWise Trusted
Application API at the Novell Developer Kit Web site (http://developer.novell.com/wiki/index.php/
Category:Novell_Developer_Kit). For security guidelines for managing trusted applications, see
Section 93.6, “Protecting Trusted Applications,” on page 1154

¢ Section 4.12.1, “Creating a Trusted Application and Key,” on page 90

¢ Section 4.12.2, “Editing a Trusted Application,” on page 92
¢ Section 4.12.3, “Deleting a Trusted Application,” on page 93

4.12.1 Creating a Trusted Application and Key

A trusted application key allows a third-party program to authenticate to the POA or the GWIA and
obtain GroupWise information that would otherwise be available only by logging in to GroupWise
mailboxes. You can create a trusted application and its associated key in ConsoleOne for use with
both Linux and Windows trusted applications.

1 Click Tools > GroupWise System Operations > Trusted Applications to display the Configure Trusted
Applications dialog box.

2 Click Create.

Edit Trusted Application gl
Mame: 1 |
Description:

TCR{IP Address: 7]
[[] Requires SsL
[] Provides Message Retention Service
74
Lacation for key File: [ =
Mame of key file: | |
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3 Fill in the following fields as needed for your trusted application:
Name: Specify the name of the trusted application as you want it to be listed in ConsoleOne.
Description: Specify a description for the trusted application.

TCP/IP Address: If you want to restrict the location from which the trusted application can run,
specify the IP address of the server from which the application can run. To do so, click the Edit
(pencil) button, then specify the IP address or DNS hostname of the trusted application’s server.

If you want to allow the trusted application to be run from any server, do not specify an IP
address or DNS hostname.

IMPORTANT: If you are creating the trusted application for use with the Data Synchronizer
Connector for GroupWise, as described in “GroupWise Trusted Application” in “Mobility Pack
Installation” in the Mobility Pack Installation Guide, do not specify an IP address or DNS
hostname.

Requires SSL: Select this option to require a secure (SSL) connection between the trusted
application and POAs and GWIAs.

Provides Message Retention Service: Select this option if the purpose of the trusted application
is to retain GroupWise user messages by copying them from GroupWise mailboxes into another
storage medium.

Turning on this option defines the trusted application as a Message Retention Service
application. However, in order for GroupWise mailboxes to support message retention, you
must also turn on the Enable Message Retention Service option in GroupWise Client Options (Tools
> GroupWise Utilities > Client Options > Environment > Retention). You can enable individual
mailboxes, all mailboxes in a post office, or all mailboxes in a domain by selecting the
appropriate object (User, Post Office, or Domain) before selecting Client Options. For more
information, see Chapter 76, “Setting Defaults for the GroupWise Client Options,” on page 1025.

For information about the complete process required to use a trusted application for message
retention, see Chapter 33, “Retaining User Messages,” on page 441.

Allow Access to Archive Service: Select this option if your message retention service interacts
with an archive service. Different archive services provide differing storage alternatives
(memory, disk, or tape, for example) and differing alternatives for speed and cost. You can
configure multiple archive services for your GroupWise system.

For more information about configuring GroupWise to work with an archive service, see
Section 4.2.7, “Archive Service Settings,” on page 77.

Archive Service Address: If the trusted application for the message retention service uses the
GroupWise Stubbing API (http://developer.novell.com/wiki/index.php/GroupWise_Stubbing),
specify the IP address or DNS hostname of the server where the archive service is running. This
allows the POA to interact directly with the archive service in support of the message retention
service. The advantage to this configuration is that the archive service can be behind the firewall
along with the POA. If retrieval is required, the POA accesses the archive service and provides
the retrieved data to the GroupWise client.

If the message retention trusted application does not use the GroupWise Stubbing API, do not
specify an IP address or DNS hostname. Without the Stubbing AP], the trusted application
communicates with the POA to create stubs for archived messages. The stubs contain the URLs
for the archived messages. When a GroupWise user clicks the stub for an archived message, the
GroupWise client accesses the URL to retrieve the archived message.

Archive Service Requires SSL: Select this option if you want to use a secure connection
between the message retention service and the archive service.

Location for Key File: Browse to and select the directory where you want to create the trusted
application key file.
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Name of Key File: Specify the name of the trusted application key file to create. The third-party
program must be designed to successfully access the trusted application key file where you
create it.

4 Click OK to save the trusted application configuration information.

For information about how the POA handles trusted application processing of message files, see
Section 36.3.6, “Configuring Trusted Application Support,” on page 517.

4.12.2 Editing a Trusted Application

You can edit a trusted application’s description, IP address, port, and SSL settings.

1 Click Tools > GroupWise System Operations > Trusted Applications to display the Configure Trusted
Applications dialog box.

2 In the Trusted Applications list, select the application you want to edit, then click Edit.

Edit Trusted Application g|
Mame: IntellisynciMabileSuite
Description: [rtellisync Mobile Suite For Groupiise
TCR{IP Address: %)

[] Requires S5L

|:| Provides Message Retention Service

Vd

[ QK H Cancel ][ Help ]

3 Modify the following fields as needed for your trusted application:
Name: This field displays the trusted application’s name. You cannot change the name.
Description: Specify a description for the trusted application.

TCP/IP Address: If you want to restrict the location from which the trusted application can run,
specify the IP address of the server from which the application can run. To do so, click the Edit
(pencil) button, then specify the IP address or DNS hostname of the trusted application’s server.

If you want to allow the trusted application to be run from any server, do not specify an IP
address or DNS hostname.

Requires SSL: Select this option to require a secure (SSL) connection between the trusted
application and POAs and GWIAs.
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Provides Message Retention Service: Select this option if the purpose of the trusted application
is to retain GroupWise user messages by copying them from GroupWise mailboxes into another
storage medium.

Turning on this option defines the trusted application as a Message Retention Service
application. However, in order for GroupWise mailboxes to support message retention, you
must also turn on the Enable Message Retention Service option in GroupWise Client Options (Tools
> GroupWise Utilities > Client Options > Environment > Retention). You can enable individual
mailboxes, all mailboxes in a post office, or all mailboxes in a domain by selecting the
appropriate object (User, Post Office, or Domain) before selecting Client Options. For more
information, see Chapter 76, “Setting Defaults for the GroupWise Client Options,” on page 1025.

For information about the complete process required to use a trusted application for message
retention, see Chapter 33, “Retaining User Messages,” on page 441.

Allow Access to Archive Service: Select this option if you have also installed an archive service,
as described in Section 4.2.7, “Archive Service Settings,” on page 77. Specify the IP address or
DNS hostname of the server where the archive service is running. Select Archive Service Requires
SSL if you want to use a secure connection between the message retention service and the
archive service.

4 Click OK to save the trusted application configuration information.

For information about how the POA handles trusted application processing of message files, see
Section 36.3.6, “Configuring Trusted Application Support,” on page 517.

4.12.3 Deleting a Trusted Application

1 Click Tools > GroupWise System Operations > Trusted Applications to display the Configure Trusted
Applications dialog box.

Configure Trusted Applications |

Trusted Applications: Close

E3

rikellisynctMobileSuits

Create
Edit

Delete

Help

2 In the Trusted Applications list, select the application you want to delete, click Delete, then click Yes
to confirm the deletion.

413 LDAP Servers

The LDAP Servers feature lets you define the LDAP servers you want to use for LDAP authentication
to GroupWise mailboxes. For setup instructions, see “Providing LDAP Authentication for
GroupWise Users” on page 510.
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4.14 Global Signatures

You can build a list of globally available signatures that can be automatically appended to messages
sent by GroupWise client users. The global signature is appended to messages after any personal
signatures that users create for themselves. For setup instructions, see Section 14.3, “Adding a Global
Signature to Users’ Messages,” on page 231.
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5.1

GroupWise Utilities

The GroupWise utilities in ConsoleOne are used to perform various maintenance and configuration
tasks for your GroupWise system. The following sections provide information about the system
utilities included on the Tools menu (Tools > GroupWise System Ultilities):

¢ Section 5.1, “Mailbox/Library Maintenance,” on page 95

¢ Section 5.2, “System Maintenance,” on page 96

¢ Section 5.3, “Backup/Restore Mailbox,” on page 96

¢ Section 5.4, “Recover Deleted Account,” on page 96

¢ Section 5.5, “Client Options,” on page 96

¢ Section 5.6, “Expired Records,” on page 96

¢ Section 5.7, “Email Address Lookup,” on page 96

¢ Section 5.8, “Synchronize,” on page 97

¢ Section 5.9, “User Move Status,” on page 97

¢ Section 5.10, “Link Configuration,” on page 97

¢ Section 5.11, “Document Properties Maintenance,” on page 97

¢ Section 5.12, “New System,” on page 98

¢ Section 5.13, “Check eDirectory Schema,” on page 98

¢ Section 5.14, “Gateway Alias Migration,” on page 98

¢ Section 5.15, “GW / eDirectory Association,” on page 99

¢ Section 5.16, “Standalone GroupWise Utilities,” on page 103
In addition to the system utilities included on the Tools menu in ConsoleOne, GroupWise includes
the following standalone utilities:

¢ GroupWise Check Utility (GWCheck)

¢ GroupWise Backup Time Stamp Utility (GWTMSTMP)

¢ GroupWise Database Copy Utility (DBCOPY)

¢ GroupWise Generate CSR Utility (GWCSRGEN)

Mailbox/Library Maintenance

You can use the Mailbox/Library Maintenance utility to check the integrity of and repair user/
resource, message, and library databases, and to free disk space in post offices.

For detailed information and instructions, see Chapter 27, “Maintaining User/Resource and Message
Databases,” on page 409, Chapter 28, “Maintaining Library Databases and Documents,” on page 415,
and Chapter 30, “Managing Database Disk Space,” on page 423.
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5.2

5.3

5.4

5.5

5.6

5.7

System Maintenance

You can use the System Maintenance utility to check the integrity of and repair domain and post
office databases.

For detailed information and instructions, see Chapter 26, “Maintaining Domain and Post Office
Databases,” on page 401.

Backup/Restore Mailbox

You can use the Backup/Restore Mailbox utility to restore an individual user’s Mailbox items from a
backup copy of the post office database.

For detailed information and instructions, see Chapter 31, “Backing Up GroupWise Databases,” on
page 431 and Chapter 32, “Restoring GroupWise Databases from Backup,” on page 433.

Recover Deleted Account

If you have a reliable backup procedure in place, you can use the Recover Deleted Account utility to
restore recently deleted user and resource accounts from the backup version of the GroupWise
primary domain database. After the account has been re-created, you can then restore the
corresponding mailbox and its contents to complete the process. Membership in distribution lists and
ownership of resources must be manually re-established.

For complete instructions, see Section 32.6, “Recovering Deleted GroupWise Accounts,” on page 438.

Client Options

You can use the Client Options utility to set the default options (preferences) for the GroupWise
client. You can set options at the domain, post office, or user level. Options set at the domain level
apply to all users in the domain, and options set at the post office level apply to all users in the post
office. If you don’t want users to change options, you can lock the options.

For detailed information and instructions, see Chapter 76, “Setting Defaults for the GroupWise Client
Options,” on page 1025.

Expired Records

You can use the Expired Records utility to view and manage the GroupWise user accounts that have
an expiration date assigned to them.

For detailed information and instructions, see Chapter 14.11, “Removing GroupWise Accounts,” on
page 255.

Email Address Lookup

You can use the Email Address Lookup utility to search for the GroupWise object (User, Resource,
Distribution List) that an email address is associated with. You can then view the object’s
information. For more information, see Section 14.7.1, “Ensuring Unique Email Addresses,” on
page 248.
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5.8

5.9

5.10

5.11

Synchronize

GroupWise automatically replicates information (domain, post office, user, resource, and so on) to all
domain and post office databases throughout your GroupWise system. This ensures that the
information in each database is synchronized.

Situations might occur, however, that result in information not being replicated to all domain and
post office databases. If you think that some information has not been replicated correctly, you can
cause the information to be replicated again so that it becomes synchronized throughout your entire
GroupWise system. For example, if you notice that a user’s information is incorrect in the Address
Book, you can synchronize that user’s eDirectory User object so that his or her information is
replicated to all domain and post office databases again.

For detailed information and instructions, see Chapter 29, “Synchronizing Database Information,” on
page 419.

User Move Status

You can use the User Move Status utility to track progress as you move users from one post office to
another. Using the User Move Status utility, you can:

¢ List users that are currently being moved and filter the list by domain, post office, and object.

¢ View the current status of the move for each object and see any errors that have occurred.

¢ Immediately retry a move where some of the information on the user inventory list failed to
arrive at the destination post office. By default, the POA retries automatically every 12 hours for
seven days to move all the information included on the user inventory list.

¢ Stop the POA from continuing its automatic retries.
¢ Restart (from the beginning) a move that has stopped before successful completion.

¢ Refresh the list to display current move status and clear completed moves from the list.

For more information, see Section 14.4.5, “Monitoring User Move Status,” on page 240.

Link Configuration

GroupWise domains and post offices must be properly linked in order for messages to flow
throughout your GroupWise system. You can use the Link Configuration utility to ensure that your
domains and post offices are properly linked and to optimize the links if necessary. For detailed
information and instructions, see Chapter 10, “Managing the Links between Domains and Post
Offices,” on page 155.

Document Properties Maintenance

Each document stored in the GroupWise Document Management Services (DMS) has properties
associated with it. These properties identify the document, determine its disposition (archive, delete,
keep), set its level of security, and provide information for locating it in searches. Certain document
properties are standard in GroupWise. You can also customize DMS for your organization by
defining additional properties. For detailed information and instructions, see Section 23.2.1,
“Customizing Document Properties,” on page 362.

NOTE: On Linux, Document Properties Maintenance is not available in ConsoleOne.
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5.12

5.13

5.14

New System

You can use the New System utility to create a new GroupWise system.

The process for creating a new GroupWise system is similar to the process of creating your initial
GroupWise system (see “Installing a Basic GroupWise System” in the GroupWise 2012 Installation
Guide), except that you don’t install the software from the downloaded GroupWise 2012 software
image. Instead, during creation of the new system, you are asked to specify an existing software
distribution directory to use in the new system. If you don’t want to share software distribution
directories between systems, you should create a new distribution directory. For information about
creating software distribution directories, see Section 4.9, “Software Directory Management,” on
page 84.

Check eDirectory Schema

GroupWise systems include GroupWise-specific objects that are not available in eDirectory until the
eDirectory schema for the tree has been extended for these objects. Schema extension takes place
automatically when you create a GroupWise system using the GroupWise Setup Advisor. You can
check an eDirectory tree to determine whether its schema has been extended for GroupWise.

1 In ConsoleOne, select a tree to check.
2 Click Tools > GroupWise Utilities > Check eDirectory Schema.

If the eDirectory tree has not yet been extended for GroupWise, the eDirectory Schema
Extension dialog box lists the changes that are required for GroupWise.

3 Click Yes to extend the schema for GroupWise so that you can create GroupWise objects in the
selected tree.

or

Click No if you decide you do not want to be able to create GroupWise objects in the selected
tree.

If the schema of the tree has already been extended for GroupWise objects, a message notifies you of
this and you can immediately create new GroupWise objects in the selected tree.

Gateway Alias Migration

If you have been using SMTP gateway aliases to handle email addresses that do not fit the default
format expected by the Internet Agent (GWIA) or to customize users’ Internet addresses, the
Gateway Alias Migration utility can convert the user names in those gateway aliases into preferred
email IDs. The Preferred E-Mail ID feature was first introduced in GroupWise 6.5 and is the
suggested method for overriding the current email address format, as described in Section 14.7.2,
“Changing a User’s Internet Addressing Settings,” on page 249. The Gateway Alias Migration utility
can also update users’ preferred Internet domain names based on their existing gateway aliases.

For usage instructions, see Section 52.3, “Transitioning from SMTP Gateway Aliases to Internet
Addressing,” on page 754.
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2.15

5.15.1

GW / eDirectory Association

The GW / eDirectory Association menu includes the following options:

¢ Section 5.15.1, “Graft GroupWise Objects,” on page 99

¢ Section 5.15.2, “Invalid Associations,” on page 100

¢ Section 5.15.3, “Associate Objects,” on page 101

¢ Section 5.15.4, “Disassociate GroupWise Attributes,” on page 102
¢ Section 5.15.5, “Convert External Entity to User,” on page 102

¢ Section 5.15.6, “Convert User to External Entity,” on page 103

Graft GroupWise Objects

You can use the Graft GroupWise Objects utility to create GroupWise objects in the eDirectory tree
from the information in your GroupWise domain database. The utility creates Domain, Post Office,
and Gateway objects as well as User, Resource, and Distribution List objects. When grafting
GroupWise user information from the GroupWise database into eDirectory, you can match the
GroupWise user information to an existing User object, or you can create a new GroupWise External
Entity object and convert it into an eDirectory User object, as described in Section 5.15.5, “Convert
External Entity to User,” on page 102.

Grafting GroupWise objects from the GroupWise database into eDirectory can be useful in the
following situations:
¢ The GroupWise database includes information that is not included in eDirectory.

* You want to move GroupWise information (domains, post offices, gateways, users, or resources)
from one eDirectory tree to another.

To graft GroupWise objects:

1 In ConsoleOne, select a container in the eDirectory view.

2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Graft GroupWise Object to display
the Graft GroupWise Objects dialog box.

Graft GroupWise Objects &l

Graft GroupWise Objects

Novell
This advisor helps you create GrouphWise objects in eDirectary
from the infarmation in the GroupYise directory (domain
database).
@ )
U '5 Which Groupwise ohjects do you want to graf?

& Domaing, post offices, and gateways

 Users, resources, distribution lists, and libraries

‘ Met = | Cancel | Heli |

3 Follow the on-screen prompts. If you need information about a dialog box, click the Help button.
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5.15.2

Invalid Associations

Normally, a GroupWise object in eDirectory points to corresponding information in the GroupWise
domain database. In turn, the information in the GroupWise domain database points back to its
corresponding object in eDirectory.

Occasionally, a situation might arise where information in the GroupWise domain database no longer
points to the same eDirectory object that points to it. This results in an invalid association between
the information in the two directories.

You can use the Invalid Associations utility to correct invalid associations between information in the
GroupWise domain database and eDirectory.

To check for invalid associations:

1 In the eDirectory View in ConsoleOne, select the container whose objects you want to check for
invalid associations (for example, an Organization, Organizational Unit, Domain, or Post

Office).

2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Invalid Associations to display the

Invalid Associations dialog box.

Invalid Associations El

P —o—9

III

Belowy iz & list of the invalid associstions of Provo3. Select the eDirectory object(s) to
dizagzociste or delete.

Il - GrouphVize object Il - Linked to ohject
DOC TREE/Crem.Gr..|Crem CORP_TREEiGrem.novell
DOC_TREEFacilities.. |Orem Facilities CORP_TREEIFacilities.n

The object in column | has an invalid association to the Grouphise object in column Il The
Groupise object is currently sssociated to the object in column Il

| | Cancel | Help ‘

The dialog box lists each invalid association for the objects in the selected container. The dialog

box fields are described below:

¢ Object in Question (Column I): This field lists the eDirectory object that has an invalid
association to a GroupWise object. The eDirectory object points to the GroupWise object
listed in Column II, but the GroupWise object, according to the GroupWise domain
database, does not point back to the eDirectory object.

¢ GroupWise Object (Column II): This field lists the GroupWise object to which the
eDirectory object listed in Column I is associated.
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¢ Linked to Object (Column III): This field lists the eDirectory object to which the
GroupWise object listed in Column II has a valid association.

3 To remove the invalid association by disassociating the eDirectory object in Column I with the
GroupWise object in Column 1I, select the association, then click Disassociate.

4 To remove the invalid association by deleting the eDirectory object listed in Column I, select the
association, then click Delete.

Associate Objects

You can use the Associate Objects utility to associate GroupWise information with an eDirectory
object.

For example, if you delete a user’s eDirectory account but not his or her GroupWise account, the
user’s GroupWise information is retained as a GroupWise External User object in the GroupWise
database and can be viewed in the GroupWise View. You can then associate the GroupWise External
User object with another eDirectory User object. In essence, you are moving the GroupWise
information from one eDirectory User object to another.

In some circumstances, it is possible for the link between an eDirectory User object and its
GroupWise information to be lost. If this occurs, the GroupWise information, which still exists in the
GroupWise database, appears as a GroupWise External User object in the GroupWise View. You can
use the Associate Objects utility to reassociate the GroupWise information with the eDirectory User
object.

The Associate Objects utility can be used to associate the following objects:

¢ GroupWise User or External User objects with eDirectory User objects

¢ GroupWise External Entity objects with eDirectory External Entity objects

Associating GroupWise User or External User Objects with eDirectory User
Objects

1 In the GroupWise View in ConsoleOne, select the GroupWise User or External User object you
want.

or
In the eDirectory View, select the eDirectory User object you want.
2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Associate Objects.

3 If you selected a GroupWise User or External User object in Step 1, select the eDirectory User
object you want to associate with it.

or

If you selected an eDirectory User object in Step 1, select the GroupWise User object you want to
associate with it.

4 Click OK to create the association.

If the eDirectory User object is already associated with another GroupWise object, you receive a
warning message indicating this. If you continue, the eDirectory User object is associated with
the selected GroupWise object and its association with the other GroupWise object is removed.

If the GroupWise User or External User object is already associated with another eDirectory
User object, you receive a warning message indicating this. If you continue, the GroupWise User
object is associated with the selected eDirectory object and its association with the other
eDirectory object is removed.
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5.15.5

Associating GroupWise External Entity Objects with eDirectory External Entity
Objects

1 In the GroupWise View in ConsoleOne, select the GroupWise External Entity object you want.
or
In the eDirectory View, select the eDirectory External Entity object you want.

2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Associate Objects.

3 Ifyou selected a GroupWise External Entity object in Step 1, select the eDirectory External Entity
object you want to associate with it.

or

If you selected an eDirectory External Entity object in Step 1, select the GroupWise External
Entity object you want to associate with it.

4 Click OK to create the association.

If the eDirectory External Entity object is already associated with another GroupWise object, you
receive a warning message indicating this. If you continue, the eDirectory External Entity object
is associated with the selected GroupWise object and its association with the other GroupWise
object is removed.

If the GroupWise External Entity object is already associated with another eDirectory External
Entity object, you receive a warning message indicating this. If you continue, the GroupWise
External Entity object is associated with the selected eDirectory object and its association with
the other eDirectory object is removed.

Disassociate GroupWise Attributes

You can use the Disassociate GroupWise Attributes utility to disassociate GroupWise information
from an eDirectory User object. This results in two separate eDirectory objects:
¢ The User object, which no longer includes any GroupWise information.

¢ A GroupWise External User object, which represents the user’s record in the GroupWise
database and is displayed only in the GroupWise View. The External User object allows the user
to continue to have access to GroupWise and also enables you to graft the user record to another
eDirectory User object. For more information, see Section 5.15.1, “Graft GroupWise Objects,” on
page 99.

To disassociate the GroupWise attributes from an eDirectory User object:

1 In ConsoleOne, select the User object whose GroupWise attributes you want to remove.

2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Disassociate GroupWise Attributes.

Convert External Entity to User

You can use the Convert External Entity to User utility to convert a GroupWise External Entity object
to an eDirectory User object.

1 In ConsoleOne, select the GroupWise External Entity object that you want to convert to an
eDirectory User object.
2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Convert External Entity to User.

3 C(lick Yes to confirm that you want the conversion performed.
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5.16

5.16.1

5.16.2

Convert User to External Entity

You can use the Convert User to External Entity utility to convert a User object to a GroupWise
External Entity object.

1 In ConsoleOne, select the User object that you want to convert to an GroupWise External Entity
object.
2 Click Tools > GroupWise Utilities > GW / eDirectory Associations > Convert User to External Entity.

3 Click Yes to confirm that you want the conversion performed.

Standalone GroupWise Utilities

Although ConsoleOne provides the primary administrative tool for managing your GroupWise
system, additional standalone utilities are provided to meet specialized needs. These utilities
perform tasks that might be necessary in environments where ConsoleOne is not available.

¢ Section 5.16.1, “GroupWise Check Utility (GWCheck),” on page 103

¢ Section 5.16.2, “GroupWise Backup Time Stamp Utility (GWTMSTMP),” on page 103

¢ Section 5.16.3, “GroupWise Database Copy Utility (DBCOPY),” on page 104

¢ Section 5.16.4, “GroupWise Generate CSR Utility (GWCSRGEN),” on page 104

GroupWise Check Utility (GWCheck)

GroupWise Check is a standalone version of the ConsoleOne Mailbox/Library Maintenance utility.
Like the Mailbox/Library Maintenance utility, GroupWise Check checks and repairs GroupWise user,
message, library, and resource databases. However, in addition to checking post office, user, and
library databases, it also checks users’ remote, caching, and archive databases.

For information about using GroupWise Check, see Section 34.1, “GroupWise Check,” on page 447.

GroupWise Backup Time Stamp Utility (GWTMSTMP)

The GroupWise Backup Time Stamp utility (GWTMSTMP) can be used to place a time stamp on a
GroupWise user database to indicate the last time the database was backed up. If a user deletes an
item from his or her mailbox and purges it from the Trash, the item is only deleted from the user’s
database if the time stamp shows that the item would have already been backed up. Otherwise, the
item remains in the user’s database until the database is backed up, at which time it is deleted from
the working database.

For information about using the GroupWise Backup Time Stamp utility, see Section 34.2,
“GroupWise Time Stamp Utility,” on page 457.

GroupWise Utilities 103



5.16.3

5.16.4

GroupWise Database Copy Utility (DBCOPY)

The GroupWise Database Copy utility (DBCOPY) copies files from a live GroupWise system to a
static location for backup. During the copy process, DBCOPY prevents the files from being modified,
using the same locking mechanism used by other GroupWise programs that access databases. This
ensures that the backed-up versions are consistent with the originals even when large databases take
a substantial amount of time to copy.

For information about using the GroupWise Database Copy utility, see Section 34.3, “GroupWise
Database Copy Utility,” on page 463.

GroupWise Generate CSR Utility (GWCSRGEN)

To provide secure communication through an SSL (Secure Socket Layer) connection, the GroupWise
Agents (MTA, POA, DVA, and GWIA) require access to a server certificate and private key.

You can use the GroupWise Generate CSR utility (GWCSRGEN) to generate a Certificate Signing
Request (CSR) file and a Private Key file.

The CSR file, which is Base64 encoded, contains the information required for a Certificate Authority
(CA) to issue you a server certificate. This server certificate, when paired with the private key
generated by the GroupWise Generate CSR utility, enables GroupWise agents to use SSL connections.

For information about SSL and certificates, see Section 83.2, “Server Certificates and SSL Encryption,”
on page 1107.
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6.1

GroupWise Address Book

The GroupWise Address Book plays a central role in a GroupWise user’s experience with addressing
messages. The default configuration of the GroupWise Address Book is often sufficient for a typical
GroupWise system, but a variety of customization options are available to enable the GroupWise
Address Book to meet user needs.

¢ Section 6.1, “Customizing Address Book Fields,” on page 105

¢ Section 6.2, “Controlling Object Visibility,” on page 110

¢ Section 6.3, “Updating Address Book Information,” on page 110

¢ Section 6.4, “Controlling Users’ Frequent Contacts Address Books,” on page 111

¢ Section 6.5, “Controlling Address Book Synchronization for Caching and Remote Client Users,”
on page 112

¢ Section 6.6, “Publishing Email Addresses to eDirectory.,” on page 113
¢ Section 6.7, “Enabling Wildcard Addressing,” on page 114
¢ Section 6.8, “Adding External Users to the GroupWise Address Book,” on page 116

NOTE: In addition to the administrator-controlled changes you can make to the Address Book,
GroupWise users can make individual changes such as creating personal address books, sharing
personal address books, and accessing LDAP address books. For information about the Address
Book functionality available to users, see:

¢ “Contacts and Address Books” in the GroupWise 2012 Windows Client User Guide

¢ “Contacts and Address Books” in the GroupWise 2012 WebAccess User Guide

Address books are not available in WebAccess Mobile.

Customizing Address Book Fields

The GroupWise clients displays specific fields in the GroupWise Address Book by default:

Windows Client WebAccess
Name Name

E-Mail Address E-Mail Address
Title

Office Phone Number

NOTE: Address Book fields in GroupWise WebAccess are set permanently and cannot be changed
by you or by users.
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6.1.1

106

Windows client users can add more columns to their own Address Book. In the client, users right-
click the Address Book column header, then select a column from the drop-down list or click More
Columns to display a longer list of possible columns.

In ConsoleOne, you can add columns to the list that is displayed in the GroupWise clients when users
click More Columns. This is configured at the domain level.

NOTE: The Address Book configuration you establish becomes the default configuration for new
GroupWise users in the domain. Changes to Address Book configuration do not affect existing users.

¢ Section 6.1.1, “Adding eDirectory Fields to the Address Book,” on page 106
¢ Section 6.1.2, “Adding LDAP Fields to the Address Book,” on page 107

¢ Section 6.1.3, “Changing the Default Sort Order,” on page 108

¢ Section 6.1.4, “Changing the Default Field Order,” on page 109

¢ Section 6.1.5, “Removing Fields from the Address Book,” on page 109

¢ Section 6.1.6, “Preventing the User Description Field from Displaying in the Address Book,” on

page 109

Adding eDirectory Fields to the Address Book

Adding an eDirectory field makes the field available in the GroupWise Address Book. Individual
users can determine which available fields they want to display when they view the GroupWise
Address Book in the GroupWise client.

1 In ConsoleOne, right-click the Domain object whose Address Book you want to modify, then

click Properties.

2 Click GroupWise > Address Book to display the Address Book page.

Properties of Waltham1

Sart address book by:

Address Baok Fields:
Given Mame (required)
Last Name (required)
Phone

Department

Title

Fax

Cbject ID

Paost OFfice Name
Domain Marme
Distinguished Mame
Metwork 1D

File: 1D

|:| Da Mot Display User Comments

NDS Rights + | Gther | Rights to Files and Folders |

First Mame, Last Mame

Availshle Fields:
Aecount 1D
ity
Company
Description
Haome Phone
Location

= Midde Initial
Mabile Phong

=p  (Other Phone
FPager Number
Personal Title
PO Box
Postal Code
Cualifier

Skate or Province

*administrator-defined field

Map Additional Fields

3

Page Options. ..

Cancel

The Address Book Fields list shows all fields that are available for selection in the Address Book in

the GroupWise client.
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The Available Fields list shows additional predefined GroupWise user fields that can be added to
the Address Book. Novell eDirectory also includes user information that is not associated to
GroupWise user fields. You can use the Map Additional Fields button to map eDirectory user
fields to GroupWise fields so that they can be displayed in the GroupWise Address Book.

3 To add a field that is not displayed in the Available Fields list, click Map Additional Fields, select an
unmapped Admin-defined field, click Edit, select the eDirectory property to map to the Admin-
defined field, then click OK twice to add it to the Available Fields list.

To add fields independent of a specific domain’s Address Book, use Tools > GroupWise System
Operations > Admin-Defined Fields to display the Administrator-Defined Fields dialog box. The
fields defined in this dialog box are available for selection and display in the Address Book
belonging to any domain. For more information, see Section 4.4, “Admin-Defined Fields,” on
page 79.

4 In the Awvailable Fields list, select the field you want to make available in the Address Book, then
click the left-arrow to move it to the Address Book Fields list.

The field is added to the bottom of the list. The Address Book displays the fields in the order
they are listed.

5 If necessary, select the field, then use the up-arrow and down-arrow to move the field to the
appropriate location in the list.

6 If the field is an Administrator-defined field and you want to change how the field is labeled in
the Address Book, select the field, click Edit Label, specify a new label in the Address Book Label
field, then click OK.

Administrator-defined fields are marked with an asterisk (*). You can only edit an
Administrator-defined field that is in the Address Book Fields list.

7 When you are finished, click OK in the Address Book page to save your changes.

Adding LDAP Fields to the Address Book

A number of LDAP fields available in ConsoleOne are not listed on the Address Book property page
of the Domain object. These LDAP fields can also be added to the GroupWise Address Book by
making them visible in eDirectory.

1 In ConsoleOne, right-click your Tree object, then click Properties.

Properties of CORP_TREE

HDS Rights v | Other | General | Rights to Files and Folders |
Trustees of this Ohbject

The following are sssigned trustees of: [Root]

" [Public]
# 7] [This]

a admin Docdey Movell

Add Trustee...

Delete Trustee. .

Azsigned Rights...

Effective Rights...

i §

Page Options.. (o34 Cancel Apply Help
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2 Select Public, click Assigned Rights, then click Add Property.

Add Property

X

RROTTET ¥
Supported Services
Supported Typetaces
Surname
Sweinfo
SvcType
SvcTypelD
Synchronization Tolerance
Synhchronized Up To
T
Telephone kurmber
Tinezone

Transitive Yectar
Trustees Of New Ohjsct
Type Crestor Map

uiD

[ Show all properties

Help

Ok ‘ Cancel

=

=]

In the Add Property dialog box, all capitalized property names sort ahead of all uncapitalized

property names.

3 Select Show All Properties, scroll down to locate the property you want to add to the GroupWise
Address Book, select the property (for example, Title), then click OK.

Rights assigned to: [Public]

On object: [Root]

Property

I [0 Attributes Rights]
0 [Ertry Rights]

Right=

™ supervizor
¥ Compare
¥ Read

I~ wirite

I Add Selt

[™ Inheritable

Acdd Property...
Delete Property

oK | Cancel ‘ Help |

X

4 With the new property highlighted, select Inheritable, then click OK twice to save the new

property settings.

When you return to the Address Book property page of the Domain object, you can select the new
property to display in the GroupWise Address Book, as described in Section 6.1.1, “Adding
eDirectory Fields to the Address Book,” on page 106.

Changing the Default Sort Order

NOTE: The Sort Address Book By field on the Address Book page of the Domain object is obsolete and
no longer affects Address Book sorting in the GroupWise clients.

The sort order determines whether addresses in the Address Book are sorted by first name or last
name. The sort order you establish becomes the default for the Address Book and remains in effect

until individual users change it.
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The preset default sort order for the Address Book is First Name/Last Name. You can change the
default sort order to Last Name/First Name.

On the Address Book page of the Domain object:

1 In the Sort Address Book By list, select the sort order you want to be the default.
2 Click OK to save your changes.

6.1.4 Changing the Default Field Order

The field order determines the order in which the GroupWise fields are displayed in the Address
Book. The field order you establish becomes the default for the Address Book and remains in effect
until individual users change the order.

On the Address Book page of the Domain object:

1 In the Address Book Fields list, select a field whose position you want to change, then use the up-
arrow and down-arrow to move the field to its new position.

2 Repeat Step 1 until you have established the field order you want.
3 Click OK to save your changes.

6.1.5 Removing Fields from the Address Book

If there are fields in the Address Book that are not used or that you don’t want displayed to users,
you can remove them.

On the Address Book page of the Domain object:

1 In the Address Book Fields list, select the field you want to remove, then click the right-arrow to
move the field to the Available Fields list.
The fields in the Available Fields list are not displayed in the Address Book.

2 Repeat Step 1 to remove additional fields you don’t want to use.

3 Click OK to save your changes.

6.1.6  Preventing the User Description Field from Displaying in the Address
Book

The GroupWise Address Book provides detailed user information as well as email addresses. A
user’s detailed information includes a comments field that displays the information stored in the
User object Description field (User object > General > Identification). If you have included information in
the Description field that you don’t want displayed in the GroupWise Address Book, you can prevent
the field’s contents from being displayed.

TIP: To view a user’s detailed information, including the comments field, in the Address Book, select
the user’s address, then click View > Details.

On the Address Book page of the Domain object:

1 Enable the Do Not Display User Comments option.
2 Click OK to save your changes.
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6.2 Controlling Object Visibility

An object’s visibility determines which post office databases the object’s information is distributed to.
A post office’s users can only see an object’s information in the Address Book if the object’s
information has been distributed to its post office.

Visibility applies to the following objects: user, external user, external entity, resource, external
resource, distribution list, eDirectory group, eDirectory organizational role, and nickname.

IMPORTANT: Unlike the other objects listed above, nicknames that have been distributed to a post
office do not actually appear in the post office’s Address Book. Users must type the nickname’s
address in the message rather than select it from the Address Book.

You can choose from the following visibility levels:

¢ System: The object is visible in every post office Address Book throughout the system; if
external system synchronization is turned on, it is also available for distribution to other
GroupWise systems. This is the default for users, external users, resources, external resources,
external entities, and nicknames.

¢ Domain: The object is visible only in the Address Book of the post offices located in the object’s
domain.

¢ Post Office: The object is visible only in the Address Book of the object’s post office. This is the
default for distribution lists, groups, and organizational roles.

¢ None: The object is not visible in the Address Book of any post offices.
For information about setting visibility for various GroupWise objects, see:

¢ Section 14.7.3, “Changing a User’s Visibility in the Address Book,” on page 251

¢ Section 16.7.2, “Changing a Resource’s Visibility in the Address Book,” on page 275

¢ Section 18.9.2, “Changing a Distribution List’s Visibility in the Address Book,” on page 296

¢ Section 19.3, “Changing a Group’s Visibility in the Address Book,” on page 304

¢ Section 20.3, “Changing an Organizational Role’s Visibility in the Address Book,” on page 309

6.3 Updating Address Book Information

Each post office database includes all the information displayed in the GroupWise Address Book that
is stored in the domain. By keeping the information in the post office, the post office’s users have
quick access to it. Whenever changes are made in eDirectory that affect Address Book information,
the information is replicated to each domain database and each post office database.

If information in a post office’s Address Book is out-of-date or missing, you can synchronize the
missing information with eDirectory or rebuild the post office database to obtain updated
information from the domain.

¢ Section 6.3.1, “Synchronizing Information,” on page 111

¢ Section 6.3.2, “Rebuilding the Post Office Database,” on page 111
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6.3.1

6.3.2

6.4

Synchronizing Information

The information for each object (user, resource, distribution list, and so on) in the GroupWise
Address Book is contained in eDirectory. When an object’s information is incorrect in a post office’s
Address Book, you can synchronize the object’s information in the Address Book with the
information stored in eDirectory. This causes the correct information to be replicated to each domain
and post office database in the GroupWise system. For instructions, see Chapter 29, “Synchronizing
Database Information,” on page 419.

Rebuilding the Post Office Database

If the post office Address Book is missing a lot of information, or if you are having other difficulties
with information in the Address Book, you might want to rebuild the post office database. This
causes all information to be replicated to the post office database from the domain database. For
instructions, see Section 26.3, “Rebuilding Domain or Post Office Databases,” on page 405.

Controlling Users’ Frequent Contacts Address Books

By default, email addresses of those to whom users send messages are automatically added to their
Frequent Contacts address books. Users can also choose to automatically save email addresses of
those from whom they receive messages. You can restrict the types of addresses that users can collect
in their Frequent Contacts address books.

1 In ConsoleOne, select a Domain, Post Office, or User object.

2 Click Tools > GroupWise Utilities > Client Options

3 Click Environment > Address Book.

Environment Options: Development 5[
Cleanup | Appearance | Retention | Junk Mail | Calendar
General | Client Access | Wigws | File Location

hovell Wibe I Tutorial Conferencing I Reeply Format

Frequent Contacts
[+ Enable auta-saving d‘qﬁll

[~ Save addresses of items that are received
I~ From external sources (Internet)
I~ From internal sources

™ Gl if ry mame o I0isin Ehe: Tas fisld

[ Save addresses of items that are sent
[V To external sources (Intsrnet)

¥ Tointernal sources

[ 8llows creation of User Defined Fields in the Personal Address Book

Restore Default Settings

Ok I Cancel Help |

4 With Enable Auto-Saving selected, adjust the auto-save options as needed.
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Save Addresses of Items That Are Received: Select this option to allow users to automatically
add external and internal email address from items that they receive to their Frequent Contacts
address books. If desired, you can restrict users to collecting email addresses only if the user’s
name or email address appears in the 1o field, as opposed to the CC or BC fields.

Save Addresses of Items That Are Sent: Select this option to allow users to automatically add
external and internal email address from items that they send to their Frequent Contacts address
books.

or

Deselect Enable Auto-Saving to change the default so that email addresses are not collected unless
users enable that functionality.

5 To prevent users from changing your Frequent Contacts address book settings, click the Lock
button.

6 Click OK to save the Frequent Contacts address book settings.

6.5 Controlling Address Book Synchronization for Caching and
Remote Client Users

By default, the POA automatically updates the post office database (wphost . db) with changes to the
Address Book as they occur. As a result, whenever a Caching or Remote client connects to the
GroupWise system, it automatically downloads any updates to the Address Book that have occurred
since the last time it connected. This means that Caching or Remote client users always have an up-
to-date Address Book to work with.

Because the Address Book updates are stored as records in the post office database, this feature
causes the post office database to grow in size as time passes. Therefore, in ConsoleOne, you can
specify the maximum number of days you want to store the incremental update records. The longer
the incremental update records are stored, the larger the post office database becomes, which can
impact available disk space and backup time. You can also disable this functionality, if necessary.

1 Browse to and right-click a Post Office object, then click Properties.
2 Click GroupWise > Post Office Settings.

Properties of Sales x|

GroupWise w | MDS Rights - | Cther | Right= to Files and Folders |
Post Office Seftings

Software Distribution Direckary:

Access Mode: ICI\ent,l’Servar Only

=1
Delivery Mode: IUse App Thresholds LI

Address Book Update Settings
¥ Create deltas for Address Book updates

Max Age for Address Book Updates: I 15 ﬂ days

[~ Disable Live Move

Restore Area: {Mat Set)
Default Archive Service Trusted Application: (Mot Set)
[~ Override |<Nune> ;I
Remote File Server Settings
Remate User Mame: |
Remote Password: Set Password
Page Options. .. I 0K Cancel Apply Help
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3 In the Max Age for Address Book Updates field, specify the number of days you want to retain
Address Book update records.

The default is 15 days. The maximum number of days is 90.
4 (Optional) Deselect Create Deltas for Address Book Updates to disable this feature.
5 Click OK to save the setting.
Caching and Remote client users should not deselect Refresh Address Books and Rules Every nn Days
because rules are still downloaded according to this schedule. Even if users do not want to download
their rules, they still should not deselect this option because it turns off the Address Book delta sync.

They can, however, set the option to a greater number of days to cause the download of the full
Address Book to occur less frequently.

Publishing Email Addresses to eDirectory.

The GroupWise databases and eDirectory both contain information about users” email address
formats. When you change settings for users” GroupWise email addresses, you can publish the
changes to eDirectory so that user email address information matches in both places.

1 In ConsoleOne, click Tools > GroupWise System Operations > Internet Addressing.

2 Click Publish to eDirectory.

Internet Addressing E|
Internet Domains | Addressing Formats Publi
(%) Publish the Preferred EMail Address only
Far each Internet Domain

() Publish all allowed addresses

() Publish the following addresses:

[[] Publish Mickname addresses

[] Publish Gateway Alias addresses

By default, users’ preferred email addresses are published to eDirectory only in the format
established in the Preferred Address Format field on the Addressing Formats tab. This publishes
one email address per user in the format established for your GroupWise system.

3 Select additional options to publish additional email addresses, as needed.

4 Click OK to save the address publishing settings.
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6.7

6.7.1

Enabling Wildcard Addressing

By default, users address messages by selecting users and distribution lists from the Address Book. If
you enable wildcard addressing, users can send items to all users in a post office, domain,
GroupWise system, or connected GroupWise system by using asterisks (*) as wildcards in email
addresses.

You can limit wildcard addressing to a specific level (system, domain, or post office) or allow
unlimited wildcard addressing. The default is to limit the wildcard addressing to post office only,
meaning that a user can use wild card addressing to send to all users on his or her post office only.
You can change the default for individual users, post offices, or domains.

With wildcard addressing, the sender only sees whether the item was delivered to a domain, post
office, or system (by viewing the item’s properties). The properties do not show the individual user
names or additional statuses. Recipients can reply to the sender only. Reply to All is unavailable.

¢ Section 6.7.1, “Setting Wildcard Addressing Levels,” on page 114
¢ Section 6.7.2, “Wildcard Addressing Syntax,” on page 115

NOTE: Wildcard addressing cannot be used for assigning shared folders or shared address books,
granting proxy rights, performing busy searches, or sending routing slips.

Setting Wildcard Addressing Levels

By default, wildcard addressing is enabled at the post office level for all users in your GroupWise
system. You can change the level (post office, domain, or system) or disable wildcard addressing.

Wildcard addressing levels can be applied to a single user, to all users in a post office, or to all users
in a domain.

To set wildcard addressing defaults:

1 In ConsoleOne, select a Domain, Post Office, or User object.
2 Click Tools > GroupWise Utilities > Client Options to display the GroupWise Client Options dialog
box.

Groupl.l\ﬁse Client Options x|

Environment Send Documents

&

Security Calendar

Close | Help |

3 Click Send to display the Send Options dialog box.
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6.7.2

Send Options: Development @
5 Mail || Appt || Task | Note || Security | Disk Space Mgmt | Global Signature
Classification
Hormal 2 [] Expiration date
-
Priarity s
O
@ standard [] Delay delivery
O Low ”
-
[] Reply requested ‘Wildcard Addressing
- Limited to post office v -
= Sl
MIME Encoding
Matify recipients E,-
uTF-8 v
[] Canwvert attachments -
[] Allew use of "Reply ta all" in rules E’-
Allows use of "Internet mail" tracking [ Allows reply rules to loop
Restare Default Settings

4 In the Wildcard Addressing list, select from the following options:

¢ Not Allowed: Select this option to disable wildcard addressing.

¢ Limited to Post Office (Default): Select this option to limit wildcard addressing to the

user’s post office. The user can use wildcard addressing to send items to users in his or her

post office only.

¢ Limited to Domain: Select this option to limit wildcard addressing to the user’s domain.
The user can use wildcard addressing to send items to users in his or her domain only.

¢ Limited to System: Select this option to limit wildcard addressing to the user’s GroupWise
system. The user can use wildcard addressing to send items to all users in his or her system
only. This excludes external users (users from other systems) who have been added to your
GroupWise address book.

¢ Unlimited: Select this option to allow unlimited use of wildcard addressing. The user can
use wildcard addressing to send to all users (including external users and non-visible users)
defined in the GroupWise address book.

5 Click OK to save the changes.

Wildcard Addressing Syntax

The following table shows the syntax for wildcard addressing.

Wildcard Addressing Setting To send an item to...

Type in the To field...

Limited to Post Office

Limited to Domain

All users in your post office
All users in your post office
All users in your domain

All users in another post office in your
domain

*
*
* %

*.post_office
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Wildcard Addressing Setting To send an item to...

Type in the To field...

Limited to System

All users in your post office
All users in your domain

All users in another post office in your
domain

All users in a post office in another domain

*
* *

*.post_office

* post_office.domain

All users in another domain *.domain

All users in your GroupWise system * ok
Unlimited All users in your post office *

All users in your domain **

All users in a different post office in your *.post_office

domain

All users in a post office in another domain.  *.post_office.domain
You can also use this for external post
offices and external domains.

All users in a another domain. You can also *.domain
use this for external domains.

All users in the GroupWise address book (all *.*.*
users in the same system, all external users,
and all non-visible users)

6.8 Adding External Users to the GroupWise Address Book

The GroupWise Address Book lists all users that belong to your GroupWise system. When users
receive incoming messages, the senders are added to users’ Frequent Contacts Address Books to
facilitate replying to users who are not included in the GroupWise Address Book. If necessary, you
can configure GroupWise so that external (non-GroupWise) users appear in the GroupWise Address
Book and are therefore available to all GroupWise users.

The following sections help you add non-GroupWise users to the GroupWise Address Book:

¢ Section 6.8.1, “Creating a Non-GroupWise Domain to Represent the Internet,” on page 116
¢ Section 6.8.2, “Linking to the Non-GroupWise Domain,” on page 117

¢ Section 6.8.3, “Creating a Non-GroupWise Post Office to Represent an Internet Host,” on
page 119

¢ Section 6.8.4, “Creating External Users,” on page 120

¢ Section 6.8.5, “Configuring External Users and Resources to Appear in GroupWise Busy
Searches,” on page 121

6.8.1 Creating a Non-GroupWise Domain to Represent the Internet

1 In ConsoleOne, right-click GroupWise System (in the left pane), then click New > Non-GroupWise
Domain.

116  GroupWise 2012 Administration Guide



Create Non-GroupWise Domain

Damain name:

Titme Zone: m

|(GMT-D? 007 Mourtain Time (US & Canads) j Help
[=]

Link To Datnair:

|Provo1

[ Creste another domain

2 Fill in the fields:

Domain Name: Specify a name that has not been used for another domain in your system (for
example, Internet).

Time Zone: This should match the time zone for the Internet Agent (GWIA). If it does not, select
the correct time zone.

Link to Domain: Select a domain where the GWIA is running.
3 Click OK to create the non-GroupWise domain.
The non-GroupWise domain appears under GroupWise System in the left pane.

4 Continue with Linking to the Non-GroupWise Domain.

6.8.2 Linking to the Non-GroupWise Domain

After you have created the non-GroupWise domain, you must modify the link between the domain
where the Internet Agent (GWIA) is running and the non-GroupWise domain. This enables the
GroupWise system to route all Internet messages to the MTA of the GWIA domain. The MTA can
then route the messages to the GWIA, which sends them to the Internet.

To modify the link to the non-GroupWise domain:

1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration to display the Link
Configuration tool.

By default, the Link Configuration tool displays the links for the domain that you are currently
connected to.

GroupWise Link Configuration Tool - K:\gwsystem\provo1
File Edit Search View ‘Window Help

8 mE 7 ala B[S Feer emey =1 (1]

Domain: Proval [=l=]x]
| ouboundLinks from Prowot
rDirect Indirect rGatews: Undefined

% Internet
%, Provoz
%, Provo3

rindirect

2 If the GWIA domain is not the currently displayed domain, select it from the list of domains on
the toolbar.

The non-GroupWise domain should be displayed in the Direct column. In the graphic displayed
under step 1, Internet is the non-GroupWise domain.
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3 Double-click the non-GroupWise domain to display the Edit Domain Link dialog box.
If you are prompted that the mapped path is empty, click Yes to dismiss the prompt and display

the Edit Domain Link dialog box.

Edit Domain Link

Description:  How Provol connects to Provod
Link Type: Direct =
Settings

Protocol:  {Mapped =

Path: |K:\gwsvs‘tem\prov04

Maximum send message size: 0 %‘ MBytes
0 =fmBytes

Delay message size:

Transfer Pull Info | External Link Info

J Scheduling...

4 In the Link Type field, select Gateway.

After you select Gateway, the dialog boxes changes to display the settings required for a gateway
link.

Edit Domain Link X
Descriptior:  How Provad conhects to Internet
Lirk Type: Gateweay

Cancel
Setti
ings Help

Gateway Link e - |

Gatevveay Access String: |

Return Link: |vam

Maximum send message size: a %‘ MEytes
0 2Bytes

Delay message size:

NOTE: GroupWise gateways are legacy products that are not supported with the current
GroupWise version.

5 Fill in the following fields:

Gateway Link: Select the GWIA.

Gateway Access String: If you want to specify the conversion format (RFC-822 or MIME) for
messages sent to the domain, include the -1fc822 or -mime parameter. If you do not use either of
these parameters, the GWIA converts messages to the format specified in its startup file. The
default is for MIME conversion (as specified by the GWIA’s /mime startup switch).

Return Link: Leave this field as is. It does not apply to the GWIA.

Maximum Send Message Size: If you want to limit the size of messages that the MTA for the
GWIA domain passes to the GWIA, specify the maximum size. This is applied to all messages. If
you want to limit the size of messages sent by specific users or groups of users, you can also use
the Access Control feature. For details, see Section 54.1, “Controlling User Access to the
Internet,” on page 787.

Delay Message Size: If you want the MTA to delay routing of large messages to the GWIA,
specify the message size. Any messages that exceed the message size are assigned a lower
priority by the MTA and are processed after the higher priority messages.
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6.8.3

6 Click OK to save the changes.

The non-GroupWise domain is moved from the Direct column to the Gateway column. For a

description of the link symbols next to the domain names, see the Help in the Link

Configuration tool.

GroupWise Link Configuration Tool - K:lgwsystem\provo1
File Edit Search Wiew Window Help

@ ‘%“3‘ ﬂ QJ&‘ ?;“ﬁﬂ [Provat (Primary)

Domain: Provol
Quthound Links from Provol

rDirect Indirect

= E1ES

%, Prove2
%, Proved

Inkaund Links to Praval

rDirect

- Gatews Undefine o
5, ¢ Internet (GWIA)

%, Prove?
%, Proved

rindirect

7 Click the File menu, click Exit, then click Yes to exit the Link Configuration tool and save your

changes.

8 Continue with Creating a Non-GroupWise Post Office to Represent an Internet Host.

Creating a Non-GroupWise Post Office to Represent an Internet Host

When you create a post office to represent an Internet host, the post office name cannot be identical to
the hostname because the period that separates the hostname components (for example, novell.com)
is not a valid character for post office names. GroupWise reserves the period for its addressing syntax

of user_ID.post_office.domain. Therefore, you should choose a name that is closely related to the

hostname.

To create a non-GroupWise post office:

1 In ConsoleOne, right-click the non-GroupWise domain that represents the Internet, then click
New > External Post Office.

Create External GroupWise Post Office

Post office niame:

Time Zone

Cancel

o |

|(GMT-D? 00) Mourtsin Time (US & Canada)

[ Create ancther post office

ﬂ Help

2 Fill in the following fields:

Post Office Name: Specify a name to associate the post office with the Internet host. Do not use

the fully qualified hostname.

Time Zone: Select the time zone in which the Internet host is located.

3 Click OK to create the post office.

The non-GroupWise post office is added under the non-GroupWise domain.

4 Right-click the new non-GroupWise post office, then click Properties.

5 Click GroupWise > Internet Addressing.
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Properties of ExampleHost &‘

piise
A el ce e |
Crwerride referred Address format:
N H|
Ilat Defined
Allorwiee] Address Formats
r W
=
4
r
=
Mot Defined
Internet domain name:
-
Mot Defined
Page Options: | Cancel | ‘ Help |

6 If you want to override the GroupWise system allowed address formats, select Override next to
Allowed Address Formats, then select the allowed address formats for this Internet host.

7 Next to Internet Domain Name, select Override, then specify the actual name of the Internet host
that the external post office represents.

8 Click OK to save your changes.

9 Continue with Creating External Users.

6.8.4 Creating External Users

By creating external users, you add them to the GroupWise Address Book for easy selection by
GroupWise users when addressing messages.

To add an Internet user to a post office:

1 In ConsoleOne, right-click the post office that represents the user’s Internet host, then click New
> External User.

Create GroupWise External User

Uszer Hame:
[l

[ Creste ancther external uzer

Cancel

|

Help

2 In the User Name field, specify the exact user portion of the user’s Internet address. If the address
is jsmith@novell.com, the portion you would specify is jsmith.

3 Click OK to create the external user.

4 Provide personal information about the external user:
4a Right-click the new External User object.
4b Fill in the desired fields on the Identification page.
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Because the user is displayed in the GroupWise Address Book, you might want to define
the user’s first name and last name. This is especially important if the allowed address
formats for the Internet host include first name and last name information.

4c Click OK to save the user’s personal information.

If you have only a few users on some Internet hosts, you can create a single external post office for
these users, then define their Internet domain names on the Identification pages of the External User
objects instead of on the External Post Office object.

6.8.5 Configuring External Users and Resources to Appear in GroupWise
Busy Searches

You can define the URL where free/busy schedule status is published for a user or resource in an
external email system. This enables GroupWise users to receive Busy Search results from this external
user or resource along with Busy Search results from other GroupWise users.

1 In ConsoleOne, right-click an External User object or an External Resource object, then click
Properties.
2 Click GroupWise > Internet Free Busy Search.

3 Specify the URL where free/busy schedule status for the user or resource is published, then click
OK.
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1.1

Multilingual GroupWise Systems

GroupWise is a multilingual email product that meets the needs of users around the world. The
following sections provide guidance if your GroupWise system includes users who speak a variety of

languages:

¢ Section 7.1, “GroupWise User Languages,” on page 123

¢ Section 7.2, “GroupWise Administration and Agent Languages,” on page 124

¢ Section 7.3, “International Character Considerations,” on page 125

¢ Section 7.4, “MIME Encoding,” on page 125

¢ Section 7.5, “Multi-Language Workstations,” on page 127

See also Chapter 78, “Supporting the GroupWise Client in Multiple Languages,” on page 1087.

GroupWise User Languages

Users can run GroupWise in the following languages:

Language Code Language Code
Arabic** AR Italian IT
Bulgarian BG Japanese JA
Chinese - Simplified CS Korean KO
Chinese - Traditional CT Norwegian NO
Czech Cz Polish PL
Danish DA Portuguese PT
Dutch NL Russian RU
English EN Slovak* SK
Finnish Fl Slovenian* SL
French FR Spanish ES
German DE Swedish SV
Hungarian HU Turkish TR

NOTE: Languages marked with an asterisk (¥) are available for the GroupWise Windows client, but
not for GroupWise WebAccess. Languages marked with a double asterisk (**) are available for the
GroupWise Windows client and for GroupWise WebAccess in a desktop browser, but are not
available on tablet devices or mobile devices where a more simple interface is used.
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1.2

Language codes are used to identify language-specific files and directories. They are also used as the
values of the client language (/1) startup option. Users can select the languages they want when they
install the GroupWise client.

Users should have at least 200 MB available on their workstations to install the GroupWise client
software in one language. Users need an additional 20 MB of disk space for each additional language
they install.

By default, the GroupWise client starts in the language of the operating system, if it is available. If the
operating system language is not available, the next default language is English. When you start the
GroupWise client, you can use the /1 startup switch to override the English default and select an
interface language from those that have been installed.

The online help available in the GroupWise clients is provided in all languages into which the client
software is translated. The GroupWise client user guides available from the GroupWise clients and
on the GroupWise Documentation Web site are translated only into the administration languages. If
you try to access a user guide from a client that is running in a language into which the user guide
has not been translated, you can select any of the available languages.

By default, the GroupWise clients use UTF-8 for MIME encoding. This accommodates the character
sets used by all supported languages.

GroupWise Administration and Agent Languages

You can run the GroupWise Installation program, administer your GroupWise system in
ConsoleOne, and run the GroupWise agents in the following languages:

Language Code
English EN
French FR
German DE
Portuguese PT
Spanish ES

Language codes are used to identify language-specific files and directories. They are also used as the
values of the GroupWise agent /language startup switches.

When you select a language for a domain, it determines the sorting order for items in the GroupWise
Address Book. This language becomes the default for post offices that belong to the domain. You can
override the domain language at the post office level if necessary.

For example, if you set the domain and post office language to English, the Address Book items are
sorted according to English sort order rules. This is true even if some users in the post office are
running non-English GroupWise clients such as German or Japanese. Their client interface and Help
files are in German or Japanese, but the sort order is according to English standards.

By default, the agents start in the language selected for the domain. If that language has not been
installed, the agents start in the language used by the operating system. If that language has not been
installed, the agents start in English. You can also use the /language agent startup switch to select the
language for the agent to start in.
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7.4

The POA also includes language-specific files in all client languages so that information returned
from the POA to the GroupWise client, such as message status and undeliverable messages, is
displayed in the language of the GroupWise client rather than the language in which the POA
interface is being displayed.

Currently, the DVA is available only in English.

International Character Considerations

GroupWise client users have complete flexibility in the characters they use in composing messages.
Accented characters used by various European languages and double-byte characters used by
various Asian and Middle Eastern languages are all acceptable in the GroupWise client and can even
be combined in the same message text.

As an administrator, you must take the following limitations into account:

¢ Double-byte Asian and Middle Eastern characters should not be used in directory names and
file names within your GroupWise system. This limitation is based on operating system
capabilities. You should also not use double-byte characters in passwords. You can use double-
byte characters in GroupWise user names, domain names, post office names, and so on.

¢ If you choose to use double-byte characters or extended characters such as accented characters
in GroupWise user names or domain names, users must have Preferred E-mail IDs that contain
only characters that are valid in the SMTP RFC. For instructions, see Section 14.7.2, “Changing a
User’s Internet Addressing Settings,” on page 249.

MIME Encoding

MIME (Multipurpose Internet Mail Extensions) encoding must be used when messages are sent
across the Internet, so that characters display correctly for users on computers that are configured for
different languages. In ConsoleOne, you can set the default MIME encoding (for example, UTF-§,
Windows Default, ISO Default, and so on) that is used by the GroupWise clients.

1 In ConsoleOne, browse to and select the domain, post office, or user where you want to change
the maximum mailbox size.

2 Click Tools > GroupWise Ultilities.
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3 Click Client Options > Send.

Send Options: Development E|
SEHdODtIUHS Mail | Appt | Task | Mote | Security | Disk Space Mgmt | Global Signature
Classification
Normal 3 [[] Expiration date
-
Pricrity b
O
@ standard [[] Delay delivery
) Low ”
-
[ reply requested ‘wildcard Addressing
) Limited to post office b -
. & |
MIME Encoding
Motify recipients E,'
s 3
[[] Convert attachments -
[] Allow use of "Reply ta all" in rules ﬁ'
Allows use of "Internet mail" tracking [ Allow reply rules to loop
Restare Default Settings

4 In the MIME Encoding box on the Send Options tab, select the desired default MIME encoding,
then click OK to save the setting.

GroupWise users can override the default MIME encoding in GroupWise, as described in:

¢ “Changing the MIME Encoding for Email You Send” in “Email” in the GroupWise 2012 Windows
Client User Guide

¢ “Changing the MIME Encoding of a Message” in “Email” in the GroupWise 2012 WebAccess User
Guide

The Windows client supports 24 character sets for MIME encoding. GroupWise WebAccess and
ConsoleOne support 16 character sets, marked with asterisks in the table below.

Languages/Alphabets Character Sets

Windows Default*
ISO Default*
UTF-8*

Arabic
Arabic
Baltic
Baltic

Central European

Windows 1256*
1ISO 8859-6
Windows 1257*
1ISO 8859-4

Windows 1250*

Central European ISO 8859-2
Chinese Simplified GB2312*
Chinese Traditional Big 5
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1.5

Languages/Alphabets Character Sets

Cyrillic KOI8-R*
Cyrillic ISO 8859-5
Hebrew Windows 1255*
Hebrew ISO 8859-8
Japanese 1ISO 2022-JP*
Japanese Shift-JIS
Korean EUC-KR*

Thai Windows 874*
Turkish Windows 1254*
Turkish ISO 8859-9

Western European
Western European

Western European

Windows 1252
1ISO 8859-1

ISO 8859-15

The GWIA also has options for controlling MIME encoding when messages are set to and from the

Internet, as described in:

¢ ConsoleOne settings:Section 53.1.4, “Determining Format Options for Messages,” on page 763

¢ Startup switches: Section 59.6.4, “Message Formatting and Encoding,” on page 868

Multi-Language Workstations

If GroupWise users receive messages in multiple languages, their workstations need to be configured

to handle the character sets used by these languages.
On Windows 7:

1 In the Control Panel, click Change Display Languages.
2 In the Display Language box, click Install/Uninstall Languages.

3 Follow the on-screen instructions to install the required language files.
On Windows Vista:

1 In the Control Panel, double-click Regional and Language Options, then click Keyboards and
Languages.
2 Under Display Languages, click Install/Uninstall Languages.

3 Follow the on-screen instructions to install the required language files.
On Windows XP:

1 In the Control Panel, double-click Regional and Language Options, then click Languages.

2 If you receive messages in Arabic, Hebrew, or other complex languages, select Install Files for
Complex Script and Right-to-Left Languages.
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3 If you receive messages in Chinese, Japanese, or other similar languages, select Install Files for
East Asian Languages.

4 Click OK to install the required language files.
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I Domains

¢ Chapter 8, “Creating a New Domain,” on page 131
¢ Chapter 9, “Managing Domains,” on page 145
¢ Chapter 10, “Managing the Links between Domains and Post Offices,” on page 155
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8.1

Creating a New Domain

As your GroupWise system grows, you might need to add new domains.

¢ Section 8.1, “Understanding the Purpose of Domains,” on page 131
¢ Section 8.2, “Planning a New Domain,” on page 132

¢ Section 8.3, “Setting Up the New Domain,” on page 138

¢ Section 8.4, “What’s Next,” on page 142

¢ Section 8.5, “New Domain Summary Sheet,” on page 142

IMPORTANT: If you are creating a new domain in a clustered GroupWise system, see the GroupWise
2012 Interoperability Guide before you create the domain:

Understanding the Purpose of Domains

The domain functions as the main administrative unit for your GroupWise system. Each GroupWise
system has one primary domain, which was created when you first installed GroupWise. All other
domains that you add are secondary domains.

The domain serves as a logical grouping of one or more post offices and is used for addressing and
routing messages. Each GroupWise user has a unique GroupWise address that consists of a user ID,
the user’s post office name, the GroupWise domain name, and, optionally, an Internet domain name.

The following diagram illustrates the logical organization of a GroupWise system with multiple
domains and post offices. All of the objects under the domain belong to that domain. All of the
objects under a post office belong to that post office.

GroupWise
System
]
| 1

Primary Secondary
Domain Message Domain Message

\.l @, Transfer \l ) Transfer

=¥ Agent =¥" Agent
ﬂ Post Post ﬂ Post Post
'm/ Office Office " ) "@1/ Office Office “Q/

Post
Office
Agent

¥ ¥ ¥

GroupWise Users

Post Post Post
Office Office Office
Agent Agent Agent

vV ¥ ¥

GroupWise Users

V¥V W§ ¥ V¥

GroupWise Users GroupWise Users
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Messages are moved from user to user through your GroupWise system by the GroupWise agents.
As illustrated above, each domain must have a Message Transfer Agent (MTA). The MTA transfers
messages between domains and between post offices in the same domain. Each post office must have
at least one Post Office Agent (POA). The POA delivers messages to users’ mailboxes and performs a
variety of post office and mailbox maintenance activities.

When you add a new domain to your GroupWise system, links define how messages are routed from
one domain to another. When you add the first secondary domain, the links between the primary and
secondary domains are very simple. As the number of domains grows, the links among them can
become quite complex. Links are discussed in detail in Chapter 10, “Managing the Links between
Domains and Post Offices,” on page 155.

Physically, a domain consists of a set of directories that house all the information stored in the
domain. To view the structure of a domain directory, see “Domain Directory” in GroupWise 2012
Troubleshooting 3: Message Flow and Directory Structure. The domain directory does not contain
mailboxes or messages, but it does contain other vital information. For an overview, see Section 41.3,
“Information Stored in the Domain,” on page 622. Domain directories can be located on Linux and
Windows servers.

8.2 Planning a New Domain

After you have your basic GroupWise system up and running, you can expand it by adding one or
more secondary domains. The GroupWise architecture lets you create a simple, single domain
system, or a complex system that links dozens of secondary domains across a campus, a city, or
around the world.

This section provides the information you need in order to decide when, where, and how to set up a
new domain. The items in the worksheet are listed in the order you enter them when setting up your
domain. This planning section does not follow the same order as the worksheet, but all worksheet
items are covered. The “New Domain Summary Sheet” on page 142 lists all the information you
need. You should print the worksheet and fill it out as you complete the tasks listed below.

¢ Section 8.2.1, “Determining When to Add a New Domain,” on page 133

¢ Section 8.2.2, “Deciding Who Will Administer the New Domain,” on page 133

¢ Section 8.2.3, “Planning Post Offices in the New Domain,” on page 134

¢ Section 8.2.4, “Determining the Context for the Domain Object,” on page 134

¢ Section 8.2.5, “Choosing the Domain Name,” on page 136

¢ Section 8.2.6, “Deciding Where to Create the Domain Directory,” on page 136

¢ Section 8.2.7, “Deciding Where to Install the Agent Software,” on page 137

¢ Section 8.2.8, “Deciding How to Link the New Domain,” on page 137

¢ Section 8.2.9, “Selecting the Domain Language,” on page 138

¢ Section 8.2.10, “Selecting the Domain Time Zone,” on page 138

After you have completed the tasks and filled out the “New Domain Summary Sheet” on page 142,
you are ready to continue with Section 8.3, “Setting Up the New Domain,” on page 138.
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8.2.1

8.2.2

Determining When to Add a New Domain

How do you know when you should add a domain? The answer to this depends on your
administration policies and on physical and logical network organization.

Although a single domain can contain as many post offices and users as you want to add, there are
some conditions that indicate the need for a new domain:

¢ Administrative Convenience: To spread out the administrative workload, you can create one or
more new domains with their own administrators. Each new domain can be managed by a
different administrator as long as each administrator has sufficient rights to connect to it and
write to the domain database.

¢ Remote Sites: If communication between servers is slow, or if you have remote sites, you can
add a new domain to minimize mail traffic between the servers. For example, if you have
locations in three separate cities, you might have an organization that represents each location.
You could then create a domain in each organization. You could administer all of the domains
from one location or you could assign a different administrator for each one.

¢ Demand on the MTA: Each domain has its own MTA that routes messages between post offices
within its domain. If your current domain has many post offices that are placing a heavy
workload on the MTA, you might want to create another domain to handle additional post
offices.

¢ Multiple eDirectory Trees: All of the objects that are logically subordinate to a GroupWise
domain must be in the same Novell eDirectory tree as the domain. If you have users in other
eDirectory trees that need GroupWise accounts, you must create secondary domains and post
offices in each tree.

For additional guidance, visit the GroupWise Best Practices Wiki (http://wiki.novell.com/index.php/
GroupWise).

Deciding Who Will Administer the New Domain

Any user who is an Admin equivalent can administer GroupWise. The person who creates the new
domain should be an Admin equivalent user so that he or she has the necessary rights to create
objects and directories. You can then assign a different user as a domain administrator and limit
rights to other objects if necessary. For more information, see Chapter 87, “GroupWise Administrator
Rights,” on page 1127.

Depending upon the size, complexity, and layout of your eDirectory tree, you might choose a
centralized administration model with one person administering both eDirectory and GroupWise, or
you might choose a distributed administration model with the administration workload shared by
two or more individuals. With a distributed administration model, each administrator obtains rights
to the GroupWise objects and directory structures over which he or she has jurisdiction. If you want
to restrict access to some network operations or to certain domains, you can limit access rights to
domains the user should not administer.

The user assigned as the domain administrator must be able to create or modify objects in the domain
and will receive an email message whenever an agent encounters a problem. You can designate
yourself, one or more other users, or a distribution list as an administrator.

NEW DOMAIN SUMMARY SHEET

Under Domain Administrator, enter the ID of the user or distribution list that will administer this domain.
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8.2.3

8.2.4

Planning Post Offices in the New Domain

Before adding the new domain, you should plan the post offices that you want to belong to the
domain. Review Section 11.2, “Planning a New Post Office,” on page 174 as part of planning your
new domain.

Determining the Context for the Domain Object

When deciding where to place the new Domain object in the eDirectory tree, you should consider
how you can most easily administer GroupWise and how the domain and its associated post offices
fit into the logical organization of your eDirectory tree.

Domains and their associated objects, including Post Offices, Users, Resources, and Distribution
Lists, must be located in the same eDirectory tree. If you have multiple trees, you must create a
separate domain in each tree. The domains can all belong to the same GroupWise system, even
though they are located in different trees.

You can place the domain in any Organization or Organizational Unit container in any context in an
eDirectory tree. The following sections provide some examples of how domains can be placed in the
eDirectory tree:

¢ “GroupWise Objects Reflect Physical Locations” on page 134

¢ “GroupWise Objects Reflect Company Organization” on page 135

¢ “GroupWise Objects Are Grouped with Servers” on page 135

¢ “GroupWise Objects Are Located in a Separate GroupWise Container” on page 135

NEW DOMAIN SUMMARY SHEET

Under Tree Name, specify the name of the eDirectory tree where you plan to create the new domain.

Under eDirectory Container, specify the name of the eDirectory container where you plan to create the
new domain.

GroupWise Objects Reflect Physical Locations

The GroupWise system below focuses on the physical layout of the company. Because most mail
traffic is probably generated by users in the same location, the mail traffic across the WAN is
minimized. An organizational unit is created for each site. A domain is created under each
organizational unit, corresponding to the city. The sites can be administered centrally or at each site.
Administrator rights can be assigned at the domain level.

El-2% Corporate

E|‘:’I§ Laos Angeles

L w8 La-Domi

- mda Lot

=78 Mew Yark
w- i Mv-Po1-1
-8 NY-Dom1
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GroupWise Objects Reflect Company Organization

The following GroupWise system focuses on departmental organization, as does the eDirectory tree.
GroupWise domains and post offices parallel eDirectory organizational units, placing the domains
and post offices within the organizational units containing the users that belong to them.

S Corparate
E”@ Accounting
- =-1 Acct-Dom
G Acct PO
E‘:'@ Develapment
- #-® Dev-Dom
- =-Ja DevPOT
‘:'lﬁ Manufacturing
-8 Sales

GroupWise Objects Are Grouped with Servers

Because domains and post offices have directory structures on network servers, you could also
choose to place the Domain and Post Office objects in the same context as the servers where the
directories reside, as shown in the following example.

-4 Corporate

----- @ Accounting

----- 8 Development

‘:'lﬁ Manufacturing

w-*F Sales

=718 Serers
w1 Acct-Dom
-G Acct- PO
w8 Dev-Dam
w- G Dev-PO1
...... B PRvw-cw
o3 PRY-GW_NSSVOL
w3 PRYV-GW_SYS

GroupWise Objects Are Located in a Separate GroupWise Container

Domains and post offices can also be created in their own organizational unit. Administratively, this
approach makes it easier to restrict a GroupWise administrator’s object and property rights to
GroupWise objects only. For information about GroupWise Administrator rights, see Section 8.2.2,
“Deciding Who Will Administer the New Domain,” on page 133.
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8.2.5

8.2.6

The GroupWise View in ConsoleOne

Regardless of where you choose to place Domain objects in the eDirectory tree, you can get a
consolidated view of your GroupWise system using the GroupWise View in ConsoleOne. For
instructions, see Chapter 3, “GroupWise View,” on page 61.

Choosing the Domain Name

The domain requires a unique name. The name is used as the Domain object’s name in eDirectory. It
is also used for addressing and routing purposes in your GroupWise system, and might appear in the
GroupWise Address Book.

The domain name can reflect a location, company name or branch name, or some other element that
makes sense for your organization. For example, you might want the domain name to be the location
(for example, Provo) while the post office name is one of the company’s departments (for example,
Research). Name the new domain carefully. After it is created, the name cannot be changed.

The domain name should consist of a single string. Use underscores (_) rather than spaces as
separators between words to facilitate addressing across the Internet.

Do not use any of the following invalid characters in the domain name:

ASCII characters 0-31 Comma,

Asterisk * Double quote “

At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces {} Period.

Colon: Slash /

NEW DOMAIN SUMMARY SHEET

Under Domain Name, specify the domain name.

Under Domain Description, provide a description for the new domain.

Deciding Where to Create the Domain Directory

Logically, the Domain object resides in eDirectory and is administered through ConsoleOne.
Physically, the domain has a directory structure for databases, message queues, and other files. The
domain directory structure can be created on any of the supported platforms listed in “GroupWise
Administration Requirements” in the GroupWise 2012 Installation Guide. The server where you create
the domain directory structure can be in the same tree as the Domain object or in another tree.

Many different configurations are possible. When deciding where to create the domain directory, you
should consider the following.

¢ Domain Directory Space Requirements: The domain directory is not a large consumer of disk
space. For guidance on domain directory space requirements, visit the GroupWise Best Practices
Wiki (http://wiki.novell.com/index.php/GroupWise).
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8.2.7

8.2.8

¢ Access by the MTA: For best performance, the MTA should be installed on the same server as
the domain directory. This is required on Linux. Remote installation is possible on Windows, but
not recommended.

¢ Security from User Access: Users never need access to the domain directory so you should
create it in a location you can easily secure; otherwise, you could have files inadvertently moved
or deleted.

Choose an empty directory for the new domain. If you want, the directory can reflect the name of the
domain, for example, Provol for one of several domains located in Provo. Use the following
platform-specific conventions:

Linux: Use only lowercase characters.
Windows:  No limitations.
Choose the name and path carefully. After the domain directory is created, it is difficult to rename it.

If the directory you specify does not exist, it can be created when you create the domain. If you create
the directory in advance, it is easy to browse to it as you create the domain.

IMPORTANT: Do not create the domain directory under another domain or post office directory.

NEW DOMAIN SUMMARY SHEET

Under Domain Database Location, enter the full path for the domain directory.

Deciding Where to Install the Agent Software

You must run a new instance of the MTA for each new domain. To review the functions of the MTA
for the domain, see Section 41.4, “Role of the Message Transfer Agent,” on page 624. For complete
installation instructions and system requirements, see “Installing GroupWise Agents” in the
GroupWise 2012 Installation Guide.

You can install the MTA on Linux or Windows. You should install it on the same server where you
plan to create the domain directory structure.

NEW DOMAIN SUMMARY SHEET

Under Agent Platform, enter the platform of the server where the MTA will run (Linux or Windows).

Deciding How to Link the New Domain

Domain links tell the MTAs how to route messages between domains. Properly configured links
optimize message flow throughout your GroupWise system. For a review of link types, see
Section 10.1.1, “Domain-to-Domain Links,” on page 155.

When you create the new domain, you link it to one existing domain. By default, this link is a direct
link using TCP/IP as the link protocol, which means the new domain’s MTA communicates with the
existing domain’s MTA through TCP/IP. This is the recommended configuration, and is required on
Linux.
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8.2.9

8.2.10

138

8.3

On Windows, you can configure the direct link to use a UNC path or a mapped drive as the link
protocol, which means the new domain’s MTA transfers information to and from the existing domain
by accessing the existing domain’s directory, rather than by communicating with the other domain’s
MTA.

NEW DOMAIN SUMMARY SHEET

Under Link to Domain, specify the existing domain that you want to link the new domain to, then specify the link
protocol (TCP/IP or UNC path).

After you create the new domain, you can configure links to additional domains as needed. See
Section 10.2, “Using the Link Configuration Tool,” on page 161.

Selecting the Domain Language

The domain language determines the default sort order for items in the GroupWise Address Book for
users in post offices that belong to the domain. For more information, see Section 11.2.8, “Selecting
the Post Office Language,” on page 179.

NEW DOMAIN SUMMARY SHEET

Under Domain Language, specify the domain language.

Selecting the Domain Time Zone

When a message is sent from a user in one time zone to a user in another time zone, GroupWise
adjusts the message’s time so that it is correct for the recipient’s time zone. For example, if a user in
New York (GMT -05:00, Eastern Time) schedules a user in Los Angeles (GMT -08:00, Pacific Time) for
a conference call at 4:00 p.m. Eastern Time, the appointment is scheduled in the Los Angeles user’s
calendar at 1:00 p.m. Pacific Time.

The domain time zone becomes the default time zone for each post office in the domain.

NEW DOMAIN SUMMARY SHEET

Under Domain Time Zone, enter the time zone.

Setting Up the New Domain

You should have already reviewed Section 8.2, “Planning a New Domain,” on page 132 and filled out
the New Domain Summary Sheet. Complete the following tasks to create the new domain:

¢ Section 8.3.1, “Creating the New Domain,” on page 139

¢ Section 8.3.2, “Configuring the MTA for the New Domain,” on page 141

¢ Section 8.3.3, “Installing and Starting the New MTA,” on page 141
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8.3.1 Creating the New Domain

1 Make sure you are logged in to the tree where you want to create the domain (Tree Name on the
New Domain Summary Sheet).

2 (Conditional) If you are creating the domain on a different machine from where you are running

ConsoleOne, make sure that ConsoleOne has write access to the location where you want to
create the domain.

Linux: Mount the file system where you want to create the new domain. For assistance, see

Section 2.1, “ConsoleOne on Linux,” on page 39.

Windows: Map a drive to the location where you want to create the new domain.

3 In ConsoleOne, click Tools > GroupWise Utilities > Check eDirectory Schema to make sure that the
tree’s schema has been extended to accommodate GroupWise objects.

4 Connect to the primary domain.

If you need assistance with this task in a GroupWise system that includes domains on Linux
servers, see Section 4.1, “Select Domain,” on page 69.

5 Browse to and right-click the eDirectory container where you want to create the domain
(eDirectory Container on the New Domain Summary Sheet), then click New > Object.

New Object ®
Creste object in:
£ CORP_TREE/GroupWise OK

Class: cancel
L Groupnise Distribution List
Lk, piiise Domain Helpy
I'a GrouptVise External Ertity o

AT

it

:"' Grougwise Library
(i Groupvvise Post Office
3 GrouptVise Resource
‘? hitpServer

>

6 Double-click GroupWise Domain, then fill in the fields in the Create GroupWise Domain dialog
box from your New Domain Summary Sheet.

Create GroupWise Domain El
|Domain name: l:l
Domain Database Location: w
[ J Help
Language:

[Engiish - s |
Titne ane:

[@MT-05:00) Eastern Time (US & Canada) |
Message Transter Agent Platform:

|Linux j

Link To Domain:
|Provo1 j

[+ Configure link
[ Define additional properties

| Create anather domain

Domain Name

Domain Database Location
Domain Language
Domain Time Zone

Link to Domain
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7 Make sure the Configure Links and Define Additional Properties options are selected, then click OK
to display the Link Configuration Wizard.

Link Configuration Wizard [1_(‘

MTA Link

The Message Transfer Agent (MTA) can link to the other domain thraugh
a TCPAP connection to the other domain's MTA, or a direct conhection to
the ather domain's directory

How do you weant the MTA to link to the ather domain?
" Direct link

& TCPAP link

P canes ‘ | ek ‘

8 Follow the on-screen instructions to define how the new domain links to the existing domain,
listed in the Link to Domain field. When you have finished defining the link, ConsoleOne creates
the Domain object and displays the domain Identification page.

Properties of Provo1 E\
Groupviise DS Rights = | Gtrer | Rights to Files and Folders |

Domain; Praval
Description: ‘
UNC Path: [\ JBD-GWwmailigwsystern|provol =3
Language: ‘Eng\ish -us M |
Domain Type: Primary
Time Zane: |(GMT-07:00) Mounkain Time (LI5 & Canada] ~|
Database Version: 1z

L § T3
Administrator: ‘ |

‘Wiew Client Cptions

9 Fill in the fields that have not been filled in for you from your New Domain Summary Sheet:

Domain Description
Domain Administrator
10 Click OK to save the domain information.

11 Continue with Configuring the MTA for the New Domain.
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8.3.2

8.3.3

Configuring the MTA for the New Domain

Although there are many MTA settings, the default settings are sufficient to get your domain
operational. However, there are a few important settings that you can conveniently modify before
you install the agent software.

1 In ConsoleOne, double-click the new Domain object.
2 Right-click the MTA object, then click Properties to display the MTA Identification page.

A x|

NDS Rights « | Cther | Rights to Fies and Folders |
Domain: Pravod
Distinguished Marme: MTA Provo3.Groupiise
Matme: MTA
Sgent Type: Message Transfer
Description: rroupWise Mezsage Transfer Agent
Platfarm: |L\nux j
Page Options: Cancel Help

3 Specify a description for the MTA.
This description displays on the MTA agent console as the MTA runs.

4 Select the platform where the MTA will run (Agent Platform on the New Domain Summary
Sheet).

5 (Conditional) If you have multiple domains in your GroupWise system and want to use TCP/IP
to link to the other domains (Link to Domain on the New Domain Summary Sheet), follow the

instructions in “Using TCP/IP Links between Domains” on page 632.

6 (Conditional) If you have created the domain in a clustered environment, follow the instructions

in the appropriate section of the GroupWise 2012 Interoperability Guide.

7 To ensure that user information in the new domain stays synchronized with user information

eDirectory, follow the instructions in Section 42.4.1, “Using eDirectory User Synchronization,”

on page 652.

8 For more MTA configuration options, see Section 9.7, “Changing the MTA Configuration to
Meet Domain Needs,” on page 154.

9 Click OK to save the MTA configuration information.
10 Continue with Installing and Starting the New MTA

Installing and Starting the New MTA

1 Install and start the MTA for the new domain on the server where you created the domain
directory structure.
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For instructions, see “Installing GroupWise Agents” in the GroupWise 2012 Installation Guide.
2 Continue with What's Next.

8.4 What's Next

After you have added the new domain and started its MTA, you are ready to continue to expand and
enhance your GroupWise system by:

¢ Configuring the Address Book for the new domain.

See “GroupWise Address Book” on page 105.
¢ Adding post offices to the new domain.
See “Post Offices” on page 171.
¢ Configuring the MTA for optimal performance.
See “Message Transfer Agent” on page 619.
¢ Connecting domains and GroupWise systems across the Internet using the GWIA.
See “Internet Agent” on page 741.
¢ Setting up GroupWise Monitor to monitor the GroupWise agents.
See “Monitor” on page 939.

8.5 New Domain Summary Sheet

142

Field Value for Your Explanation
GroupWise System
Tree Name: Section 8.2.4, “Determining the
Context for the Domain Object,” on
page 134
eDirectory Section 8.2.4, “Determining the
Container: Context for the Domain Object,” on

Domain Name:

Domain Database
Location:

Domain Language:

Domain Time Zone:

page 134

Section 8.2.5, “Choosing the
Domain Name,” on page 136

Section 8.2.6, “Deciding Where to
Create the Domain Directory,” on
page 136

Section 8.2.9, “Selecting the
Domain Language,” on page 138

Section 8.2.10, “Selecting the
Domain Time Zone,” on page 138
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Field Value for Your
GroupWise System

Explanation

Link to Domain:
Link Protocol:
* TCP/IP
Address:

Port:
+ UNC path

Domain
Description:

Domain
Administrator:

Agent Platform:

¢ Linux MTA
+ Windows MTA

Section 8.2.8, “Deciding How to
Link the New Domain,” on page 137

Section 8.2.5, “Choosing the
Domain Name,” on page 136

Section 8.2.2, “Deciding Who Will
Administer the New Domain,” on
page 133

Section 8.2.7, “Deciding Where to
Install the Agent Software,” on
page 137
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9.1

Managing Domains

As your GroupWise system grows and evolves, you might need to perform the following
maintenance activities on domains:

¢ Section 9.1, “Connecting to a Domain,” on page 145

¢ Section 9.2, “Editing Domain Properties,” on page 146

¢ Section 9.3, “Converting a Secondary Domain to a Primary Domain,” on page 150

¢ Section 9.4, “Replacing the Primary Domain Database with a Secondary Domain Database,” on
page 151

¢ Section 9.5, “Moving a Domain,” on page 152
¢ Section 9.6, “Deleting a Domain,” on page 153
¢ Section 9.7, “Changing the MTA Configuration to Meet Domain Needs,” on page 154

See also Chapter 26, “Maintaining Domain and Post Office Databases,” on page 401.

Connecting to a Domain

Whenever you change domain information, it is efficient to connect directly to the domain before you
begin making modifications. This enables ConsoleOne to write directly to the domain database
(wpdomain.db). Performing administrative tasks in a domain while not connected to it increases the
amount of administrative message traffic sent between domains.

IMPORTANT: In a large GroupWise system, especially where some domains are on Linux servers
and some domains are on Windows servers, and where you might be running ConsoleOne on a
different platform from where the domain directory is located, a direct connection might not be
convenient. Although they are efficient, direct connections are not required for most GroupWise
administration tasks. For more information, see Section 4.1.2, “Understanding the Need for Domain
Connections,” on page 71.

To change your domain connection:

1 In ConsoleOne in the GroupWise View, right-click the Domain object, then click Connect.

The GroupWise View identifies the domain to which you are connected by adding a plug
symbol to the domain icon.

Managing Domains 145


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#A3ec28k

146

The domain marked with the red underscore is the primary domain.

or

In the Console View, click Tools > GroupWise System Operations, click Select Domain, browse to and
select the domain directory, then click OK.

Under certain circumstances, this connection method is required. See Section 4.1, “Select
Domain,” on page 69.

9.2 Editing Domain Properties

After creating a domain, you can change some domain properties. Other domain properties cannot

be changed.

1 In ConsoleOne, browse to and right-click a Domain object, then click Properties to display the
domain Identification page.

Properties of Provo1 E‘
DS Rights + | Cther | Rights to Files and Folders |

Darnain: Prowol
Diescription: ‘
UNC Path: [\\IBD-GW\mail,gwsystem|provol =
Language: ‘Enghsh -us v |
Domain Type: Primary
Time Zone! ‘(GMT—U?:DU) Mountain Time (U3 & Canada) b |
Database Version: 12

- ) 7
Adrministrator: ‘ |

Wiew Client Cptions

2 Change editable fields as needed.

For information about individual fields, see Section 8.2, “Planning a New Domain,” on page 132
or use online help when editing the domain information.
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3 Click GroupWise > Post Offices to display the Post Offices page.

Properties of Provo2

{ GroupWise

| MDs Rights = | Gtrer | Rigtts to Files and Folders |

Groupwize Post Otfices:

Sales Groupiise
Support. Groupise

Page Options...

| Cancel | ‘ Help

All post offices in the domain are listed, no matter where their Novell eDirectory objects are

placed in the tree. This is a convenient place to delete post offices from the domain.

4 Click GroupWise > Address Book to display the Address Book page.

Properties of Provo2

Sort address book by

Address Book Fields:

MD'S Rights + | Cther | Right= to Files and Folders |

|F\r51 Mame, Last Mame ﬂ

Avsilable Fields:

Given Name (redguired)
Last Mame (required)
Fhone

Ohject ID

Post Otfice Mame
Drarnain Marme
Department

Title:

Metwork 1D

File ID

Fax

1|3

[ Do Mot Display User Comemerts

e

Account 1D
COmpary
Description
Distinguizhed Mame
hiicddile Initial

- Personal Title
Cualifier
=»

Map Addtional Fields

*Administrator-cefined field

X

Page Options...

| Cancel | ‘ Help

5 Use this page to configure the Address Book to control how it appears to GroupWise client users
in all post offices in the domain. See Section 6.1, “Customizing Address Book Fields,” on
page 105 for more information.
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6 Click GroupWise > Addressing Rules to display the Addressing Rules page.

Properties of Provo2 @

| Mo Rights = | Gther | Rights to Files and Folders |

i GroupWise

Addressing rules used by this domain:

Page Options.. ‘ Cahcel | | Help ‘

This page lists all addressing rules that have been set up for the domain. Addressing rules are
typically used with GroupWise gateways.

NOTE: GroupWise gateways are legacy products and are not supported with the current
GroupWise version.

7 Click GroupWise > Internet Addressing to display the Internet Addressing page.

Properties of Provo2 EI

NDS Rights + | Cther | Rights to Files and Folders |
nternet Addressing

Crwerricle Preferred Address format: -

i |

Defined at: Corporate Mail

Allowed Address Formats
r W

=
=
=
-
Defined at: Corporste Mail

Internet damain name:

-

Defined at: Corporate Mail

[ For incoming mail, recipierts are known exclusively by this Irternet domain name
Internet Agent for outbound SMTPMIME messages:
-

Defined at: Corporste Mail

Altternate Internet Agent for outbound SMTRMIME messages:

=Mong= < et

=
Page Options.... | Cancel | | Help |

Use this page to override any Internet addressing settings established at the system level. See
Section 52, “Configuring Internet Addressing,” on page 743 for more information.

8 Click GroupWise > Default WebAccess to display the Default WebAccess page.
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NOTE: This page applies only to domains that have not yet been updated to GroupWise 2012.

GroupWise 2012 does not include the WebAccess Agent.

{Group ‘| nos Riohts + | Gther | Rights to Files and Folders |
i Default Vebfcoess |

Owverride Default YWebAccess Gatevway:

r Fd

Page Options. .. |

Cancel

Help

Use this page to designate the default WebAccess Agent (gateway) for the legacy domain.

9 Click GroupWise > Admin Lockout Settings.

Properties of Provo2

TGroupiise | NDS Rights + | Other | Rights to Files and Folders |
i falrnin Lockaut Setfings |

Override
[ -
Defined st Corporste Mail
Minimum Snapin Release Version (x x x)
i
Mat Defined

Minimum Snapin Release Date
o
Ilat Defined

X

Page Options... |

Cancel

Help

Use this page to control the version of the GroupWise Administrator snap-ins to ConsoleOne

that is allowed to access GroupWise databases. See Section 4.2.6, “Admin Lockout Settings,” on

page 76 for more information.

10 Click OK to save the new domain settings.
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9.3 Converting a Secondary Domain to a Primary Domain

You can change which domain is primary if it becomes more convenient to administer the primary
domain from a different location. You can, however, have only one primary domain at a time. When
you convert a secondary domain to primary, the old primary domain becomes a secondary domain.

To convert a secondary domain to primary:

1 In ConsoleOne, connect to the primary domain.

If you need assistance with this task in a GroupWise system that includes domains on Linux
servers, see Section 4.1, “Select Domain,” on page 69.

2 Make sure there are no pending operations for the primary domain, as described in Section 4.5,
“Pending Operations,” on page 80.

3 Browse to and select the secondary domain you want to convert.

4 Click Tools > GroupWise Utilities > System Maintenance.

GroupWise System Maintenance E|

O valdate Database Run

" Recover Database Cloze

" Rehbuild Database

" Reclaim Unuzed Space ﬂ
" Rebuild Indexes for Listing

~

7 Sync Primary with Secondary

= Eonvert Secandary 10 Primary

" Release Secondary

~

~

Description;
Convertto primary promotes a secondary damain ta
primary. The existing primary domain far the system
hecomes a secondary domain

5 Click Convert Secondary to Primary.
6 Specify the path to the secondary domain database, then click OK.

The GroupWise View in ConsoleOne displays the primary domain with a red underscore.

=80 Prova?
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9.4

Replacing the Primary Domain Database with a Secondary
Domain Database

If the primary domain database (wpdomain.db) has become so damaged that it cannot be rebuilt, and
if you do not have a current backup of it, you can replace the primary domain database with the
contents of a secondary domain database. You should only do this if you are confident that the
secondary domain database is completely synchronized with current GroupWise domain
information.

To replace the primary domain database with the contents of a secondary domain database:

1 Make sure you have full administrative rights to the primary domain database directory.
2 Stop the MTA for the primary domain.
3 In ConsoleOne, connect to the secondary domain where the current database is located.

If you need assistance with this task in a GroupWise system that includes domains on Linux
servers, see Section 4.1, “Select Domain,” on page 69.

4 Browse to and select the Domain object for the secondary domain.

5 Click Tools > GroupWise Utilities > System Maintenance.

G roupWise System Maintenance

£ Walidate Database
' Recover Database
¢ Rebuid Database

€ Reeclaim Unused Space

" Rebuild Indexes For Listing

£ Refresh Views

€ Sync Primary with Secondary,

" Convert Secondary, to Primary:

= Release Secondary

{ Merge External Domain

+ Replace Primary with Secondary
Description:

Replace primany with secondary allows a lost primary

datahase to he recovered using the information in the
secondary domain.

6 Click Replace Primary with Secondary > Run.
7 When prompted, make sure the Path to Database field displays the path to the primary domain.

8 (Conditional) If an incorrect path is displayed, browse to and select the path to the primary
domain database, then click OK.

ConsoleOne then updates the primary domain database with the current contents of the selected
secondary domain database.

9 When the primary domain database has been replaced, restart the MTA for the primary domain.
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9.5

Moving a Domain

You cannot use ConsoleOne to move a Domain object to a different location in the eDirectory tree
because it is a container object. Only leaf objects can be moved. If you need to change the context,
graft the GroupWise domain to its corresponding eDirectory object in the new container location. See
Section 5.15, “GW / eDirectory Association,” on page 99 for more information about grafting objects.

You can, however, move the domain directory and the domain database (wpdomain.db) by copying
the domain directory structure and all its contents to the new location.

IMPORTANT: These instructions are for moving the domain from one location to another on the
same platform. If you want to move a domain from a Windows server to a Linux server, follow the
instructions in the GroupWise Server Migration Guide.

1

Back up the domain, as described in Chapter 31, “Backing Up GroupWise Databases,” on
page 431.

In ConsoleOne, browse to and right-click the domain to move, then click Properties to display the
domain Identification page.

In the UNC Path field, change the path to the location where you want to move the domain, then
click OK to save the new location.

The format of the path in the UNC Path field depends on whether you are running Linux
ConsoleOne or Windows ConsoleOne, and on whether the domain is on Linux or Windows.
Retain the original format of the path in your modified version of the location.

The location change is propagated throughout your GroupWise system.

Stop the MTA, and if applicable, other agents (Internet Agent and Monitor Agent) that are
running for the domain.

(Conditional) On Linux:
5a In a terminal window, log in as root, then provide the root password.

5b Use cp to copy the domain directory and database to the new location:

cp -r domain directory destination
(Conditional) On Windows:
6a Use xcopy with the /s and /e options to copy the domain directory and database to the

new location:

xcopy domain directory /s /e destination

These options re-create the same directory structure even if directories are empty.
6b Give rights to all objects that need to access the domain database.

For example, if the new location is on a different server, the Windows MTA and GroupWise
administrators who run ConsoleOne need adequate rights to the new location, as described
in Chapter 87, “GroupWise Administrator Rights,” on page 1127.

Edit the MTA and other agent startup files to reflect the changes, then restart the MTA and other
agents.

See Section 42.1.7, “Adjusting the MTA for a New Location of a Domain or Post Office,” on
page 640.

When you are sure the domain is functioning properly in its new location, delete the original
domain directory and its contents.
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9.6

If you need to move the MTA along with its domain, see Section 42.1.6, “Moving the MTA to a
Different Server,” on page 640.

Deleting a Domain

You can delete a domain only when it no longer owns subordinate GroupWise objects. For example,
you cannot delete the primary domain of your GroupWise system if it still owns secondary domains.

You cannot delete a secondary domain if it still owns post offices. However, MTA and Gateway
objects are automatically deleted along with the Domain object. Keep the MTA running until after

you have deleted the domain, so that it can process the object deletion requests.

1 In ConsoleOne, connect to the primary domain.

If you need assistance with this task in a GroupWise system that includes domains on Linux

servers, see Section 4.1, “Select Domain,” on page 69.

2 Browse to and right-click the Domain object you want to delete, then click Properties to display
the domain Identification page.

Properties of Provo1 E
Groupwise - i| NDS Rights + | Cther | Right= to Files and Folders |
Identification
Darnain: Prowol
Description:
UMC Path: \VIBD-Giuwymail gwsystem|provol
Language: English - LS W
Domain Type: Primary
Time Zone: {GMT-07:00) Mountain Time (U5 & Canada) »
Database Version: 1z
Adrministrator: hxd
View Client Options

3 Verify that the current directory path displayed on the domain Identification page is correct.
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9.7

4 Click Post Offices, then move or delete any post offices that belong to this domain, as described in
Section 12.10, “Moving a Post Office,” on page 212 and Section 12.11, “Deleting a Post Office,”
on page 214.

Properties of Provo2 E‘

{GroupWise ~ | NDS Rights = | Cther | Rights to Files and Folders |
iPostOffices ¢

Groupwize Post Otfices: ‘

Sales Groupiise
Support. Groupise

Page Options... | Cancel | ‘ Help |

5 Right-click the Domain object, then click Delete to delete the Domain object from eDirectory.
6 When prompted, click Yes to delete the corresponding domain directory structure.

7 Stop the MTA for the domain, as described in the following sections in the GroupWise 2012
Installation Guide:

¢ “Stopping the Linux GroupWise Agents”
¢ “Stopping the Windows GroupWise Agents”

8 Uninstall the MTA software if applicable, as described in the following sections in the GroupWise
2012 Installation Guide:

¢ “Uninstalling the Linux GroupWise Agents”
¢ “Uninstalling the Windows GroupWise Agents”

Changing the MTA Configuration to Meet Domain Needs

Because the MTA transfers messages between domains and between post offices in the same domain,
it affects the domain itself, local users in post offices belonging to the domain, and users who
exchanges messages with local users in the domain. Proper MTA configuration is essential for a
smoothly running GroupWise system. Complete details about the MTA are provided in Part X,
“Message Transfer Agent,” on page 619. As you create and manage domains, you should keep in
mind the following aspects of MTA configuration:

¢ Section 42.2.1, “Restricting Message Size between Domains,” on page 642

¢ Section 42.2.2, “Securing the Domain with SSL Connections to the MTA,” on page 643
¢ Section 42.3.2, “Scheduling Direct Domain Links,” on page 647

¢ Section 44.1, “Optimizing TCP/IP Links,” on page 685

GroupWise 2012 Administration Guide


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#gw2012guideinst
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#gw2012guideinst
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#bnquavn
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#b3fk9uk
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#gw2012guideinst
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#gw2012guideinst
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#b3gxdns
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#b3fk9ww

10.1

10.1.1

Managing the Links between Domains
and Post Offices

When you create a new secondary domain in your GroupWise system or a new post office in a
domain, you configure one direct link to connect the new domain or post office to a domain in your
GroupWise system. For simple configurations, this initial link might be adequate. For more complex
configurations, you must modify link types and protocols to achieve optimum message flow
throughout your GroupWise system.

The following topics help you manage links between domains and post offices:

¢ Section 10.1, “Understanding Link Configuration,” on page 155
¢ Section 10.2, “Using the Link Configuration Tool,” on page 161
¢ Section 10.3, “Interpreting Link Symbols,” on page 168

¢ Section 10.4, “Modifying Links,” on page 169

Understanding Link Configuration

In GroupWise, a link is defined as the information required to route messages between domains, post
offices, and gateways in a GroupWise system. Initial links are created when domains, post offices,
and gateways are created. The following topics help you understand link configuration:

¢ Section 10.1.1, “Domain-to-Domain Links,” on page 155

¢ Section 10.1.2, “Domain-to-Post-Office Links,” on page 158

¢ Section 10.1.3, “Link Protocols for Direct Links,” on page 159

Domain-to-Domain Links

The primary role of the MTA is to route messages from one domain to another. Domain links tell the
MTA how to route messages between domains. Domain links are stored in the domain database
(wpdomain.db). There are three types of links between source and destination domains:

¢ “Direct Links” on page 156

¢ “Indirect Links” on page 156

¢ “Gateway Links” on page 158

As an alternative to configuring individual links between individual domains throughout your
GroupWise system, you can establish a system of one or more routing domains. See Section 42.3.1,
“Using Routing Domains,” on page 645.
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Direct Links

In a direct link between domains, the source domain’s MTA communicates directly with the
destination domain’s MTA. If it is using a TCP/IP link, the source domain MTA communicates
messages to the destination domain MTA by way of TCP/IP, which does not require disk access by
the source MTA in the destination domain. This is the recommended configuration, and is the only
option for domains on Linux.

If a Windows domain is using a mapped or UNC link, the source domain MTA writes message files
into the destination domain MTA input queue, which does require disk access by the source MTA in
the destination domain. For additional details about the configuration options for direct links, see
Section 10.1.3, “Link Protocols for Direct Links,” on page 159.

Domain A Domain B

i ~ UNCPath _ i’
\ " Mapped Drive \

TCP/IP

Direct links can be used between all domains. This is a very efficient configuration but might not be
practical in a large system.

Domain 1

:&‘i’

T X

Domain 4 T~~——"Domain 3

Indirect Links

In an indirect link between domains, the source domain’s MTA routes messages through one or more
intermediate MTAs in other domains to reach the destination domain’s MTA. In other words, an
indirect link is a series of two or more direct links.

In large systems, direct links between each pair of domains might be impractical, so indirect links can
be common. Properly configured links optimize message flow throughout your GroupWise system.
A variety of indirect link configurations are possible, including:

¢ “Simple Indirect Links” on page 157

¢ “Star Configuration” on page 157

+ “Two-Way Ring Configuration” on page 158

¢ “Combination Configuration” on page 158
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Simple Indirect Links

In simplest form, an indirect link can be used to pass messages between two domains that are not
directly linked.

Domain A

N
’ A

'l . .
, Indllrect AN
) 4 Link A
Fy /
\: \
Domain B Domain C

UNC Path
Mapped Drive
TCP/IP

UNC Path
Mapped Drive
TCP/IP

Star Configuration

In a star configuration, one central domain is linked directly to all other domains in the system. All
other domains are indirectly linked to each other through the central domain.

Domain 2

Domain 6 ]l Domain 3

l '\Eomaml//V '\l

//\

Domaln 5 Domaln 4

If you have more than ten domains, you might want to designate the central domain as a routing
domain. The sole function of a routing domain is to transfer messages between other domains; it has
no post offices of its own. See Section 42.3.1, “Using Routing Domains,” on page 645.

The major drawback of the star configuration is that the central domain is a single point of failure.
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10.1.2

Two-Way Ring Configuration

In a two-way ring configuration, each domain is directly linked to the next and previous domains in
the ring and indirectly linked to all other domains in the system.

Domain 1
Domain 5 Domain 2

Y %

;) %
Domain 4 *~~~—"Domain 3

An advantage of the two-way ring configuration is that it has no single point of failure. A
disadvantage is that, depending on the size of the system, a message might go through several
domains before arriving at its destination. A two-way ring works well in a system with five domains
or less because transferring a message never requires more than two hops.

Combination Configuration

These three basic link configurations can be combined in any way to meet the needs of your
GroupWise system.

Gateway Links

In a gateway link between domains, the sending domain’s MTA must route the message through a
gateway to reach its destination. Gateways can be used to:

¢ Link domains within your GroupWise system. See “Using Gateway Links between Domains” on
page 636.

¢ Link your GroupWise system to another GroupWise system through an external domain. See
“Using Direct Links” in “Connecting to Other GroupWise Systems” in the GroupWise 2012 Multi-
System Administration Guide

For more information, see the GroupWise Gateways Documentation Web site (http://
www.novell.com/documentation/gwgateways).

NOTE: GroupWise gateways are legacy products and are not supported with the current GroupWise
version.

You cannot locate a post office across a gateway link from its domain.

Domain-to-Post-Office Links

Between a domain and its post offices, all links must be direct links. There are no alternative link
types between a domain and its post offices.
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10.1.3

Link Protocols for Direct Links

The link protocol of a direct link between domains determines how the MTAs for the domains
communicate with each other across the link. When you create a new domain, you must link it to an
existing domain. This creates the initial domain-to-domain link.

Between a domain and a post office, the link protocol determines how the MTA transfers messages to
the post office. Messages do not flow directly from one post office to another within a domain.
Instead, they are routed through the domain. When you create a new post office, you must specify
which domain it belongs to. This creates the initial domain-to-post-office link.

There are three link protocols for direct links between domains and between a domain and its post
offices:

¢ “TCP/IP Links” on page 159
¢ “Mapped Links” on page 159
¢ “UNC Links” on page 160

NOTE: On Linux, TCP/IP links are required. On Windows, they are recommended.

TCP/IP Links

¢ “Domain-to-Domain TCP/IP Links” on page 159
¢ “Domain-to-Post-Office TCP/IP Links” on page 159

Domain-to-Domain TCP/IP Links

In a TCP/IP link between domains, the source MTA and the destination MTA communicate by way of
TCP/IP rather than by writing message files into queue directories. The source MTA establishes a
TCP/IP link with the destination MTA and transmits whatever messages need to go to that domain.
The destination MTA receives the messages and routes them on to local post offices or to other
domains as needed. During the process, message files are created in the gwinprog directory for
backup purposes and are deleted when the TCP/IP communication process is completed.

Domain-to-Post-Office TCP/IP Links

In a TCP/IP link between a domain and a post office, you must configure both the POA and the MTA
for TCP/IP. The source MTA establishes a TCP/IP link with the destination POA and transmits
whatever messages need to go to that post office. The destination POA receives the messages and
delivers them into mailboxes in the post office. During this process, message files are created in the
POA input queue for backup purposes and are deleted when delivery is completed.

Mapped Links

Mapped links apply only to domains on Windows servers.
¢ “Domain-to-Domain Mapped Links” on page 159
¢ “Domain-to-Post-Office Mapped Links” on page 160
Domain-to-Domain Mapped Links

In a mapped link between domains, the location of the destination domain is specified in the
following format:
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drive:\domain directory
The source MTA writes message files into its output queue at the following location:
drive:\domain directory\wpcsin

The files are sent as input for the destination domain’s MTA. Because drive mappings are
changeable, you can move the domain directory structure, map its new location to the original drive
letter, and the domain-to-domain link is still intact.

Domain-to-Post-Office Mapped Links

In a mapped link between a domain and a post office, the location of the post office is specified in the
following format:

drive:\post _office directory
The MTA writes message files into its output queue at the following location:

drive:\post office directory\wpcsout

The files are sent as input for the post office’s POA. Because drive mappings are changeable, you can
move the post office directory structure, map its new location to the original drive letter, and the
domain-to-post-office link is still intact.

UNC Links

UNC links apply only to domains on Windows servers.

¢ “Domain-to-Domain UNC Links” on page 160
¢ “Domain-to-Post-Office UNC Links” on page 160

Domain-to-Domain UNC Links

In a UNC link between domains, the location of the destination domain is specified in the following
format:

\\server\volume\domain directory
The source MTA writes message files into its output queue at the following location:
\\server\volume\domain directory\wpcsin

The files are sent as input for the destination domain’s MTA. Because UNC paths represent absolute
locations on your network, if you move the domain to a new location, you need to edit the link to
match.

Domain-to-Post-Office UNC Links

In a UNC link between a domain and a post office, the location of the post office is specified in the
following format:

\\server\volume\post office directory
The MTA writes message files into its output queue at the following location:
\\server\volume\post office directory\wpcsout

The files are sent as input for the post office’s POA. Because UNC paths represent absolute locations
in your network, if you move the post office to a new location, you need to edit the link to match.
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10.2  Using the Link Configuration Tool

The Link Configuration tool helps you manage the links between the domains and post offices in
your GroupWise system. The following topics help you perform basic link management tasks:

*
*

*

10.2.1

Section 10.2.1, “Starting the Link Configuration Tool,” on page 161

Section 10.2.2, “Editing a Domain Link,” on page 162

Section 10.2.3, “Editing Multiple Domain Links,” on page 163

Section 10.2.4, “Editing a Post Office Link,” on page 165

Section 10.2.5, “Viewing the Path of an Indirect Link between Domains,” on page 165
Section 10.2.6, “Viewing the Indirect Links Passing through a Domain,” on page 166
Section 10.2.7, “Viewing the Gateway Links Passing through a Gateway,” on page 167

Section 10.2.8, “Saving and Synchronizing Link Configuration Information,” on page 168

Starting the Link Configuration Tool

The Link Configuration tool is provided to help you change from default links to whatever link
configuration best suits your GroupWise system.

1
2

In ConsoleOne, select the Domain object whose links you want to modify.

Click Tools > GroupWise Utilities > Link Configuration to display the Link Configuration Tool
window.

GroupWise Link Configuration Tool - K:\gwsystem\provo1
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The most frequently used features of the Link Configuration tool are available on the toolbar:

Button Menu Equivalent Function

File > Open Open a different domain database (wpdomain.db) to modify links in
a different domain

File > Save Save the current link configuration information to the domain
database

E Edit > Undo Undo your changes to the link configuration (since the last save)

Help > Help Display online Help for the Link Configuration tool
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Button Menu Equivalent Function

Search > Find Search for a specified domain

Double-click object Display details of the selected object

View > Domain Links View domain links for the selected domain
View > Post Office Links  View post office links for the selected domain

3 Continue with a specific link management task:
¢ Section 10.2.2, “Editing a Domain Link,” on page 162
¢ Section 10.2.3, “Editing Multiple Domain Links,” on page 163
¢ Section 10.2.4, “Editing a Post Office Link,” on page 165
¢ Section 10.2.5, “Viewing the Path of an Indirect Link between Domains,” on page 165
¢ Section 10.2.6, “Viewing the Indirect Links Passing through a Domain,” on page 166
¢ Section 10.2.7, “Viewing the Gateway Links Passing through a Gateway,” on page 167

10.2.2  Editing a Domain Link

After starting the Link Configuration tool:

1 From the drop-down list, select the domain whose links you want to edit.
2 Click View > Domain Links to display domain links.

Outbound and inbound links for the selected domain are listed.

GroupWise Link Confipuration Tool - K:\gwsystem\provo1
File Edit Search View Window Help
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3 Double-click a domain in the Outbound Links list to edit the link to that domain from the selected
domain.

or
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10.2.3

Double-click a domain in the Inbound Links list to edit the link from that domain to the selected
domain.

Edit Domain Link K

Description:  How Provol connects ta ProvoZ

Link Type: &
Settings
Protocol: TCRIIP W
IP Address: | jbd-gw.provo.navell.com : 7100
[] &verride
Maximum send message size: 0 % MBytes
Delay message size: 0 MEBEytes

[ Transfer Pull Info. .. ] [ External Link Info... ]

TIP: You can also open the Edit Domain Link dialog box by dragging a domain from one link
type to another.

Select the link type:
¢ “Direct Links” on page 156
¢ “Indirect Links” on page 156
¢ “Gateway Links” on page 158
For a direct link, select the link protocol:
¢ “Mapped Links” on page 159
¢ “UNC Links” on page 160
¢ “TCP/IP Links” on page 159
Provide the location of the domain in the format appropriate to the selected protocol.
Click OK.
Repeat Step 1 through Step 7 for whatever links you need to modify.

As a time-saving measure, you can make a new domain’s links the same as an existing domain’s
links. Click Edit > Default Links, then click the domain whose links you want to use as a pattern
for the new domain. Select Outbound and/or Inbound as needed, then click OK.

To look at the same link information from different points of view, you can start the Link
Configuration tool multiple times to open multiple Link Configuration Tool windows.

To exit the Link Configuration Tool and save your changes, click File > Exit > Yes.

Editing Multiple Domain Links

When your GroupWise system includes indirect links, it is not unusual for several domains to link to
the same domain. As a time-saving measure, you can create links from multiple domains to the same

domain in one operation.
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After starting the Link Configuration tool:
1 Click Edit > Multiple Link Edits.

Multiple Link Edits - Qutbound Links

Domainz to be linked: Indirect link through: Link to:
Internet Internet Internet |:|
Prowvol Frovol Provol
Cancel
Prowo? Frovo? Provo2
Prowo3 Frovod Provo3
Help
Provod Provod Provod

Select Al Select Al

2 In the Domains to Be Linked column, select the source domains whose outgoing links you want to
modify.

3 In the Indirect Link Through column, select the intermediate domain through which you want the
indirect links to pass.

4 In the Link To column, select one or more destination domains.

5 Click OK.

6 Fill in the fields in the Edit Domain Link dialog box for each direct link between a source domain
and the intermediate domain, as described in Section 10.2.2, “Editing a Domain Link,” on
page 162, then click OK.

Edit Domain Link

Description:  How Provol connects to Provoz

Link Type:
Settings
Protocol:

TP Address: |bd-gw.prove.novell.com @ 7100 ]
[ override

Maximum send message size: II'% MBytes
Delay message size: II'% MBytes

[ Transfer Pull Info. .. ] [ External Link Info... ]

The Edit Domain Link dialog box continues to appear until you have defined all the direct links
between the source domains and the intermediate domain.

IMPORTANT: After defining links from the source domains to the intermediate domain, make sure
the links from the intermediate domain to other domains are set up the way you want them.
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10.2.4  Editing a Post Office Link

After starting the Link Configuration tool:

1 From the drop-down list, select the domain whose post office link you want to edit.
2 Click View > Post Office Links to display post office links.

GroupWise Link Configuration Tool - K:\awsystem\provo1 |:HE‘E|
File Edit Search View Window Help
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Sales Provo2 libd-win:1677,7 101
%n Support 173.16.5.13:1677,7101

3 Double-click a post office to edit the link from the domain to the post office.

Edit Post Office Link X
Post Office: Development Ok |
Protocol Tcrap |

Cancel
Fost Office Agert. [POA |
Help
IP Acidress: \ibd-gw.provo.novell.com Tm

Client!Server Port: 1677
Maximutn send message size: 1] %‘ MEytes

4 Select the link protocol for the direct link.
¢ “Mapped Links” on page 159
¢ “UNC Links” on page 160
¢ “TCP/IP Links” on page 159
5 Provide the location of the post office in the format appropriate to the selected protocol.

6 For a TCP/IP link, provide the message transfer port number where you want the POA to listen
for incoming messages from the MTA.

The default message transfer port for the POA is 7101.
7 Click OK.

8 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.

10.2.5 Viewing the Path of an Indirect Link between Domains

The more hops between two indirectly linked domains, the longer it takes a message to travel
between them. To make sure the number of hops between two indirectly linked domains is as small
as possible, you can list the route a message would take from one domain to the other in ConsoleOne.

After starting the Link Configuration tool:

1 Select a domain from the drop-down list.

2 Select a domain in the Indirect links list.
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Click View > Link Path to see a list of the hops between the two domains.

GroupWise Link Configuration Tool - K:\gwsystem\provo1

File Edit Search View ‘Window Help
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Link path: Provo1 --> Provo4

Provo2
Provod

You can also use GroupWise Monitor to trace the path a message would take between two domains.
See Section 71.3.1, “Link Trace Report,” on page 979.

10.2.6  Viewing the Indirect Links Passing through a Domain

If a domain serves as a hop in an indirect link, making changes to that domain could affect all indirect

links passing through that domain. You can list all the indirect links that pass through a domain in
ConsoleOne.

After starting the Link Configuration tool:
1 Click View > Link Hop to list all domains in your system.

Selact GroupWise Object

3]
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10.2.7

2 Double-click a domain to list the indirect links passing through it.

GroupWise Link Configuration Tool - K:\ewsystem\provo1
File Edit Search View Window Help
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3 If you need to reroute a link, right-click the link, then click Edit to open the Edit Domain Link
dialog box and make changes as needed.

You can also use GroupWise Monitor to check the links passing through a selected domain. See

Section 71.3.2, “Link Configuration Report,” on page 980. However, you cannot change link
information using Monitor.

Viewing the Gateway Links Passing through a Gateway

Before making changes to a gateway, you can list all the links that pass through the gateway.

After starting the Link Configuration tool:

1 Click View > Gateway Hop to list all gateways in your system.

Filter:

Select GroupWise Object
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2 Double-click a gateway to list the domains linked through that gateway.

GroupWise Link Configuration Tool - K:\ewsystem\provo1 EJ[E|E|
File Edit Search View Window Help
3| BB ® @8 %[ Forey =
Gateway Hop: GWIA == E
Domain Gatevvay Dest Domain Mame
provot _________________[g0F Internet |

3 If you need to reroute a link, right-click the link, then click Edit to open the Edit Domain Link
dialog box and make changes as needed.

10.2.8  Saving and Synchronizing Link Configuration Information

Whenever you modify link configuration information, a cautionary symbol (see Section 10.3.2, “Link
Status Symbols,” on page 169) appears next to the modified link until you save the current link
configuration by clicking Edit > Save. If you are making extensive changes to link configuration
information, you should save regularly. When you save, the information is written out to the domain
database (wpdomain.db) for the domain to which you are currently connected. You can change to a
different domain database without exiting the Link Configuration tool by clicking File > Open.

The MTA routinely synchronizes the information in the domain databases throughout your
GroupWise system. If you are making extensive changes to link configuration information, you can
synchronize the information immediately by clicking Edit > Synchronize.

10.3 Interpreting Link Symbols

As you modify links, you see symbols that represent the various link types. Along with the link type
symbols, you sometimes see link status symbols.

¢ Section 10.3.1, “Link Type Symbols,” on page 168
¢ Section 10.3.2, “Link Status Symbols,” on page 169

10.3.1 Link Type Symbols

Link Type Meaning

Symbol

. Direct link

1 Indirect link

% Gateway link

% TCP/IP link to domain

S TCP/IP link to post office
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Link Type Meaning
Symbol

N Undefined link

10.3.2  Link Status Symbols

Link Meaning

Status

Symbol

¢ Link modification not yet saved

% Link modification not yet synchronized
i Insufficient rights to modify link

? Rights not yet checked

10.4  Modifying Links

In Part IX, “Post Office Agent,” on page 469 and Part X, “Message Transfer Agent,” on page 619,
detailed instructions for changing link types are provided as outlined below:

Changing the Link Protocol between the Post Office and the Domain

¢ “Using TCP/IP Links between the Post Office and the Domain” on page 487
¢ “Using Mapped or UNC Links between the Post Office and the Domain” on page 489

Changing the Link Protocol between Domains

¢ “Using TCP/IP Links between Domains” on page 632
¢ “Using Mapped or UNC Links between Domains” on page 635

+ “Using Gateway Links between Domains” on page 636

Customizing Link Configuration

¢ “Using Routing Domains” on page 645
¢ “Scheduling Direct Domain Links” on page 647
¢ “Using a Transfer Pull Configuration (Windows Only)” on page 650
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I I I Post Offices

¢ Chapter 11, “Creating a New Post Office,” on page 173
¢ Chapter 12, “Managing Post Offices,” on page 189
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Creating a New Post Office

As your GroupWise system grows, you typically need to add new post offices.

¢ Section 11.1, “Understanding the Purpose of Post Offices,” on page 173
¢ Section 11.2, “Planning a New Post Office,” on page 174

¢ Section 11.3, “Setting Up the New Post Office,” on page 181

¢ Section 11.4, “What's Next,” on page 186

¢ Section 11.5, “New Post Office Summary Sheet,” on page 187

IMPORTANT: If you are creating a new post office in a clustered GroupWise system, see the
GroupWise 2012 Interoperability Guide before you create the post office:

11.1 Understanding the Purpose of Post Offices

The post office serves as an administrative unit for a group of users and is used for addressing
messages. Each GroupWise user has a unique GroupWise address that consists of a user ID, the
user’s post office name, the GroupWise domain name, and, optionally, an Internet domain name.

The following diagram illustrates the logical organization of a GroupWise domain with multiple post
offices. The two post offices belong to the domain. All of the objects under each post office belong to
that post office.

Domain
Message

— (&) Transfer

=7 Agent
Post ﬁ Post
Office Office
Agent 4 / 4 Agent

fq Post Office Post Office ‘

NS (77D

CCFIIVYY CEr IV

GroupWise GroupWise GroupWise GroupWise GroupWise GroupWise  GroupWise
Resources Users Distribution Resources Users Distribution  Library
Lists Lists

As illustrated above, each post office must have at least one Post Office Agent (POA) running for it.
The POA delivers messages to users’ mailboxes and performs a variety of post office and mailbox
maintenance activities.
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11.2

11.2.1

When you add a new post office, you must link it to a domain. The link defines how messages travel
between the post office and its domain. Links are discussed in detail in Chapter 10, “Managing the
Links between Domains and Post Offices,” on page 155.

Physically, a post office consists of a set of directories that house all the information stored in the post
office. To view the structure of the post office directory, see “Post Office Directory” in GroupWise 2012
Troubleshooting 3: Message Flow and Directory Structure. The post office directory contains user
mailboxes and messages, as well as other vital information. For an overview, see Section 35.3,
“Information Stored in the Post Office,” on page 472.

Planning a New Post Office

This section provides the information you need in order to decide when, where, and how to create a
new post office. The “New Post Office Summary Sheet” on page 187 lists all the information you need
as you set up your post office. The items in the summary sheet are listed in the order you enter them
when setting up your post office. This planning section does not follow the same order as the
summary sheet, but all summary sheet items are covered. You should print the summary sheet and
fill it out as you complete the tasks listed below.

¢ Section 11.2.1, “Determining When to Add a Post Office,” on page 174

¢ Section 11.2.2, “Selecting the Domain That the Post Office Belongs To,” on page 176

¢ Section 11.2.3, “Determining the Context for the Post Office Object,” on page 176

¢ Section 11.2.4, “Choosing the Post Office Name,” on page 176

¢ Section 11.2.5, “Deciding Where to Create the Post Office Directory,” on page 177

¢ Section 11.2.6, “Deciding Where to Install the Agent Software,” on page 178

¢ Section 11.2.7, “Deciding How to Link the New Post Office,” on page 178

¢ Section 11.2.8, “Selecting the Post Office Language,” on page 179

¢ Section 11.2.9, “Selecting the Post Office Time Zone,” on page 179

¢ Section 11.2.10, “Selecting a Software Distribution Directory,” on page 179

¢ Section 11.2.11, “Selecting a Post Office Security Level,” on page 180

¢ Section 11.2.12, “Deciding if You Want to Create a Library for the New Post Office,” on page 180

After you have completed the tasks and filled out the “New Post Office Summary Sheet” on page 187,
you are ready to continue with Section 11.3, “Setting Up the New Post Office,” on page 181.

Determining When to Add a Post Office

After you have your basic GroupWise system up and running, you can expand it to accommodate
additional users. How do you know when you should add a post office? The answer to this depends
on your company organization, the number of users on your network, and the physical limitations of
your network servers.

¢ Physical Organization: If your network spans several sites, you might want to create post offices
(if not domains) at each physical location. This reduces the demands on long distance network
links.

¢ Logical Organization: Processing messages within a post office is faster and typically generates
less network traffic than messages traveling between different post offices. As you expand
GroupWise, you might find it useful to add post offices in order to group users who frequently
send mail to each other.
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Grouping users into post offices, based upon company organization or job function, makes
administrative tasks, such as creating distribution lists, limiting Address Book visibility, and
distributing shared folders, easier. For example, some employees might work in corporate
functions like accounting and human resources. Other employees might be involved in sales and
marketing and frequently attend meetings together, requiring frequent busy searches. Some
areas, for example the production floor, might not need a workstation or user account for each
individual.

¢ Number of Users: A GroupWise post office can support more than 10,000 users. However, the
number of users that a single post office can support effectively is influenced by many factors,
including:

¢ User activity level

A post office where most users send and receive a large number of messages would support
fewer users effectively than would a post office where users send messages only
occasionally.

+ User access methods

A post office where most users use the Windows client in Online mode would support
fewer users effectively than would a post office where most users use Caching mode.

Users who synchronize their mobile devices with their GroupWise mailboxes also increase
the load on the post office.

¢ Server disk speed/throughput

The POA's activities are very disk intensive. A post office on a very high-speed server or
SAN can support more users effectively than a post office on slower hardware.

¢ Number of post offices on a single server

Having only one post office on a server is highly recommended. If hardware constraints
require multiple post offices on a single server, each post office would effectively support
fewer users than if the post office was located on its own server.

¢ Number of users affected by a down server or POA

If a problem occurs with a server or POA, fewer users are affected when the post office is
smaller.

¢ Maintenance time requirements

The time required to perform post office and mailbox maintenance activities including
backups can become excessive for a very large post office.

¢ Room for growth

The ideal size for a new post office allows room to grow while maintaining optimal
performance.

¢ Demand on the POA: The POA is a very flexible component of your GroupWise system. Many
aspects of its functioning are configurable, to meet the particular needs of the post office it
services, no matter what the size. See Chapter 36, “Configuring the POA,” on page 481 and
Chapter 38, “Optimizing the POA,” on page 559.

In addition, you can choose to run multiple POAs for the same post office, in order to specialize
its functioning, as described in:

¢ Section 38.1.3, “Configuring a Dedicated Client/Server POA (Windows Only),” on page 562

¢ Section 38.2.2, “Configuring a Dedicated Message File Processing POA (Windows Only),”
on page 565

¢ Section 39.5, “Configuring a Dedicated Indexing POA (Windows Only),” on page 577

¢ Section 38.4.2, “Configuring a Dedicated Database Maintenance POA (Windows Only),” on
page 568
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11.2.2

11.2.3

11.2.4

As a result, the choice is up to you whether you prefer a single, large post office, perhaps with
multiple POAs, or multiple smaller post offices, each with its own POA. For additional guidance
with determining post office size, visit the GroupWise Best Practices Wiki (http://wiki.novell.com/
index.php/GroupWise).

Selecting the Domain That the Post Office Belongs To

A post office is associated with a specific domain, even though it might reside in a different
organizational unit in the eDirectory tree. If you have just one domain, the new post office will
belong to it. If you want to create a new domain as well as a new post office, see Chapter 8, “Creating
a New Domain,” on page 131.

Domains function as the main administration units for the GroupWise system. Post office
information is stored in the domain database, as well as in the post office database. Changes are
distributed to each post office database from the domain.

NEW POST OFFICE SUMMARY SHEET

Under GroupWise Domain, specify the GroupWise domain that the new post office will belong to.

Determining the Context for the Post Office Object

The eDirectory context of the Post Office object determines how you administer the post office. The
post office can be created in any Organization or Organizational Unit container in any context as long
as it is in the same tree as the domain. The same principles apply to placing Post Office objects in the
eDirectory tree as apply for Domain objects. Review Section 8.2.4, “Determining the Context for the
Domain Object,” on page 134 to help you plan the context for the Post Office object.

NEW POST OFFICE SUMMARY SHEET

Under Tree Name, specify the name of the eDirectory tree of the domain that will own the new post office.

Under eDirectory Container, specify the name of the eDirectory container where you want to create the new
post office.

Choosing the Post Office Name

The post office must be given a unique name. The name is used for addressing and routing purposes
within GroupWise, and might appear in the GroupWise Address Book.

The post office name can reflect a location, organization, department, and so on. For example, you
might want the domain name to be the location (for example, Provo) while the post office name is one
of the company’s departments (for example, Research). Name the new post office carefully. After it is
created, the name cannot be changed.

The post office name should consist of a single string. Use underscores (_) rather than spaces as
separators between words to facilitate addressing across the Internet.

Do not use any of the following invalid characters in the post office name:

ASCII characters 0-31 Comma,

Asterisk * Double quote "
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11.2.5

At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()
Braces { } Period .
Colon : Slash /

NEW POST OFFICE SUMMARY SHEET

Under Post Office Name, specify the post office name.

Under Post Office Description, provide a description for the post office to help you identify its function in the
system.

Deciding Where to Create the Post Office Directory

Logically, the Post Office object resides in eDirectory and is administered through ConsoleOne.
Physically, the post office has a directory structure for databases, message queues, and other files.
The post office directory structure can be created on any of the supported platforms listed in
“GroupWise Administration Requirements” in the GroupWise 2012 Installation Guide. The server
where you create the post office directory structure can be in the same tree as the Post Office object or
in another tree.

When you are planning the post office directory location and which users will belong to the post
office, consider the following:

¢ Post Office Directory Space Requirements: The post office directory can be a large consumer of
disk space. The amount of disk space required is influenced by many factors, including:
¢ Number of users in the post office
¢ Activity level of users
¢ Number and typical size of attachments
¢ Online mode vs. Caching mode for Windows client users
¢ Archive and deletion policies
¢ Libraries and document storage

For guidance on post office directory space requirements, visit the GroupWise Best Practices
Wiki (http://wiki.novell.com/index.php/GroupWise).

For details about managing post office disk space, see Section 12.3, “Managing Disk Space Usage
in the Post Office,” on page 196.

¢ Access by the POA: For best performance, the POA should be installed on the same server as
the post office directory. This is required on Linux. Remote installation is possible on Windows,
but not recommended.

¢ Security from User Access: Users typically access their mailboxes through a TCP/IP connection
to the POA. Therefore, users do not need access to the post office directory. You should create it
in a location you can easily secure; otherwise, you could have files inadvertently moved or
deleted.
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11.2.6

11.2.7

Choose an empty directory for the new post office. If you want, the directory can reflect the name of
the post office, for example research for the Research post office. Use the following platform-specific
conventions:

Linux: Use only lowercase characters.

Windows: No limitations.

Choose the name and path carefully. After the post office directory is created, it is difficult to rename
it. If the directory you specify does not exist, it is created when you create the post office. If you create
the directory in advance, it is easy to browse to it as you create the post office.

IMPORTANT: Do not create the post office directory under domain directory or another post office
directory.

NEW POST OFFICE SUMMARY SHEET

Under Post Office Database Location, specify the full path for the post office directory.

Deciding Where to Install the Agent Software

You must run a new instance of the POA for each new post office. To review the functions of the POA
for the post office, see Section 35.5, “Role of the Post Office Agent,” on page 477. For complete POA
installation instructions and system requirements, see “Installing GroupWise Agents” in the
GroupWise 2012 Installation Guide.

You can install the POA on Linux or Windows. You should install it on the same server where you
plan to create the post office directory structure.

NEW POST OFFICE SUMMARY SHEET

Under Agent Platform, specify the platform where the POA will run (Linux or Windows).

Deciding How to Link the New Post Office

When you create a new post office, you have the opportunity to choose the type of link to use
between the new post office and its domain. For a review of link types, see Section 10.1.2, “Domain-
to-Post-Office Links,” on page 158.

When you create the new post, you link it to its domain. By default, this link is a direct link using
TCP/IP as the link protocol, which means the new post office’s POA communicates with the domain’s
MTA through TCP/IP. This is the recommended configuration, and is required on Linux.

On Windows, you can configure the direct link to use a UNC path or a mapped drive as the link
protocol, which means the new post office’s POA transfers information to and from the existing
domain by accessing the existing domain’s directory, rather than by communicating with the other
domain’s MTA.

NEW POST OFFICE SUMMARY SHEET

Under Link to Domain, indicate the type of link you plan to set up between the new post office and its domain.
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11.2.8

11.2.9

11.2.10

Selecting the Post Office Language

The post office language determines the sort order for items in the GroupWise Address Book.

The post office defaults to the same language as its domain unless you specify otherwise. For
example, if you set the domain and post office language to English-US, the Address Book items are
sorted according to English-US sort order rules. This is true even if some users in the post office are
running non-English GroupWise clients such as German or Japanese. Their client interface and Help
files are in German or Japanese, but the Address Book sort order is according to English-US
standards. Time, date, and number formats for the non-English clients defaults to the workstation
language.

NEW POST OFFICE SUMMARY SHEET

Under Post Office Language, specify the post office language.

Selecting the Post Office Time Zone

When a message is sent from a user in one time zone to a user in another time zone, GroupWise
adjusts the message’s time so that it is correct for the recipient’s time zone. For example, if a user in
New York (GMT -05:00, Eastern Time) schedules a user in Los Angeles (GMT -08:00, Pacific Time) for
a conference call at 4:00 p.m. Eastern Time, the appointment is scheduled in the Los Angeles user’s
calendar at 1:00 p.m. Pacific Time.

The post office defaults to the same time zone as its domain unless you specify otherwise.

NEW POST OFFICE SUMMARY SHEET

Under Time Zone, specify the time zone for the new post office.

Selecting a Software Distribution Directory

An initial software distribution directory was created when your GroupWise system was first set up,
as described in “GroupWise Software Distribution Directory” in “Installing a Basic GroupWise
System” in the GroupWise 2012 Installation Guide.

The software distribution directory contains files that users need in order to set up the GroupWise
Windows client on their workstations. Additional software distribution directories might have been
created since that time to accommodate users in various locations, as described in Section 4.9,
“Software Directory Management,” on page 84.

You can select the most convenient software distribution directory for the new post office.

NEW POST OFFICE SUMMARY SHEET

Under Software Distribution Directory, specify the name of the software distribution directory from which users
in the new post office will install the GroupWise client software on their Windows workstations.
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11.2.11

11.2.12

Selecting a Post Office Security Level

Post office security settings affect two types of GroupWise users:

¢ Users who do not have personal GroupWise passwords set on their mailboxes

¢ Users who use LDAP passwords (that is, passwords required to log in to the network through
an LDAP server) instead of personal GroupWise passwords to access their mailboxes

After a user sets a personal GroupWise password on his or her mailbox, the post office security level
no longer applies. The user is always prompted for the GroupWise password unless the
administrator has set certain client options in ConsoleOne to prevent the password prompt, as
described in Section 82.1.3, “Managing GroupWise Passwords,” on page 1100.

In the absence of personal GroupWise passwords on user mailboxes, the post office security level
takes effect. By default, a new post office is created with High Security, which provides protection to
GroupWise mailboxes through types of authentication other than personal GroupWise passwords. In
a High Security post office, you can choose between eDirectory authentication and LDAP
authentication:

¢ eDirectory Authentication: If you use eDirectory authentication for a post office, users must be
logged in to the network through eDirectory in order to access their GroupWise mailboxes.

¢ LDAP Authentication: If you use LDAP authentication for a post office, users must successfully
authenticate to an LDAP server, such as for network login, in order to access their GroupWise
mailboxes.

For more information, see Section 36.3, “Configuring Post Office Security,” on page 505 and
Section 82.1, “Mailbox Passwords,” on page 1099.

IMPORTANT: In a Low Security post office, mailboxes are completely unprotected. Without a
personal GroupWise password, any user’s mailbox could be accessed by another user who knows
how to use the @u-userID startup switch. This security level is not recommended.

NEW POST OFFICE SUMMARY SHEET

Under Post Office Security Level, mark the security level for the post office. If you choose High Security,
indicate the type of authentication you plan to use.

Deciding if You Want to Create a Library for the New Post Office

If you anticipate that users on this post office will require document management services, you can
create a library at the same time you create the post office. The library is created with all of the default
library options including Store Documents at Post Office. Using a document storage area is
preferable to storing documents at the post office because a document storage area can be moved.
You should appropriately configure the library immediately after it is created, before users begin to
store documents there.

NEW POST OFFICE SUMMARY SHEET

Under Create Library, indicate whether or not you want to immediately create a library for the new post office.
You can always add a library to the post office at a later time.

If you decide to create a library for the post office, see Part VII, “Libraries and Documents,” on
page 313 for instructions on configuring the library.
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11.3  Setting Up the New Post Office

You should have already reviewed Section 11.2, “Planning a New Post Office,” on page 174 and filled
out the New Post Office Summary Sheet. Complete the following tasks to create a new post office.

¢ Section 11.3.1, “Creating the New Post Office,” on page 181

*

Section 11.3.2, “Configuring the POA for the New Post Office,” on page 185
Section 11.3.3, “Installing and Starting the New POA,” on page 186

*

*

Section 11.3.4, “Setting Up User Access to the New Post Office,” on page 186

11.3.1  Creating the New Post Office

1 Make sure that you are logged in to the tree where you want to create the post office.

This must be the same tree as the domain that the post office belongs to (Tree Name on the New
Post Office Summary Sheet).

2 (Conditional) If you are creating the post office on a different machine from where you are
running ConsoleOne, make sure that ConsoleOne has write access to the location where you
want to create the post office.

Linux: Mount the file system where you want to create the new post office. For assistance, see
Section 2.1, “ConsoleOne on Linux,” on page 39.
Windows: Map a drive to the location where you want to create the new post office.

3 In ConsoleOne, browse to and right-click the eDirectory container where you want to create the
post office (eDirectory Container on the New Post Office Summary Sheet), then click New > Object.

New Object E|
Create object in:
&2 CORP_TREE/GraupWise oK
Class: cancel
&8 Groupwise Distribution List j
@ Groupiize Domain Hala
Groupize External Entity JiE]

Groupise Library

ughiize Post Office

[=Y Grougise Resource
‘:? hitpServer
e -]

P,
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4 Double-click GroupWise Post Office, then fill in the fields in the Create GroupWise Post Office
dialog box from your New Post Office Summary Sheet.

Create GroupWise Post Office le

Fast office name:

Grouptiise Domain: Cancel

[Provol Groupiwise 2]
p

Fost Office Database Location:

Language:

[Enolish - U ~|

Time Zone:

|(GMT-D?:DD) Mountain Time {U3 & Canada) - |

Software Distribution Directary;

|GW Linuy; Software v|

Post Office Agent: Platform:

| Linux A |

Configure link
[] create Library
[] Define additional properties
[[] Create anather post office

Post Office Name

GroupWise Domain

Post Office Database Location
Post Office Language

Post Office Time Zone

Software Distribution Directory
Create Library

5 Make sure the Configure Links and Define Additional Properties options are selected, then click OK
to display the Link Configuration Wizard.

Link Configuration Wizard b__(‘

Post Office Link

The Message Transfer Agent (MTA) can link to the post office through a
TCPAP connection to the Post Office Agent (POA) or a direct connection
to the post office directory.

Novell

How do you want the MTA to link to the post office?
" Direct link

=" TCPAP link

) ‘ | Hely ‘

6 Follow the on-screen instructions to define how the post office links to its domain (Link to
Domain on the New Post Office Summary Sheet).
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When you finish defining the link, ConsoleOne creates the Post Office object and displays the

post office Identification page.

Properties of Development

Post Office:

Description:

UNC Path:
Language:
Time Zone:

Database Version:

MDS Rights « | Cther | Rights to Files and Folders |

3

\Provol Development

[\\IBD-GW\mailygwsystem|dey

‘Enghsh -Us

‘(GMT-D?:DD) Maountain Time {US & Canada)

12

[ Wiew Client Options ] [ Configure Mon-DOS Name Space Access

Page Options. ..

Cancel

7 Provide a description for the new post office (Description on the New Post Office Summary

Sheet).

8 Click GroupWise > Post Office Settings to display the Post Office Settings page.

Properties of Management

Software Distribution

Access Mode!

Delivery Mode:

Restare Area:

[] Override

Remote Password:

Remote User Name: |

MD'S Rights | Other I Rights to Files and Folders |

X

Directory: |GW Software

|CIientJ‘Server anly

|Llse App Thresholds

Max Age for Address Book Updates: {:} days

[[] isable Live Move

(Mot Set)

Default Archive Service Trusted Application: (Mot Set)

Remate File Server Settings

Set Password

Page Options...

Cancel

9 Select the software distribution directory for the post office (Software Distribution Directory on
the New Post Office Summary Sheet).

Creating a New Post Office

183



10 Click GroupWise > Security to display the Security page.

Properties of Legal

GroupWise ~ | NDSRights ~ | Other | Rights to Files and Folders |
Security

Security Level
™ Low

3

% High
High Security Options

[ eDirectory Authertication

LDAP Server

LDAP User Name: | ﬂ

LDAP Passwaord: Set Password

[™ Disakle LDAP Password Changing

Inactive Conhection Timeout: 30 il SECONHE
LDAP Pool Server Reset Timeout 4 él mirLtes
LDAP Server Quarantine Threshold, 2 il

Select Servers

Page Options... [e]l% | Cancel | Apply ‘ Help |

11 Provide the post office security level and authentication type for the post office (Post Office
Security Level on the New Post Office Summary Sheet.

12 Click OK to save the post office information.
13 Continue with Configuring the POA for the New Post Office.

184  GroupWise 2012 Administration Guide



11.3.2

Configuring the POA for the New Post Office

Although there are many POA settings, the default settings are sufficient to get your post office
operational. However, there are a few important settings that you can conveniently modify before
you install the agent software.

1 In ConsoleOne, double-click the new Post Office object.

2 Right-click the POA object, then click Properties to display the POA Identification page.

{GroupWise ~ | NDS Rights ~ | Cther I Rights to Files and Foldsrs |
i ldertification
Domain. PO: Provid Developmert
Distinguizhed Narme: POA Development. Grouphyise
Marme: POA
Agent Type: Post Office
Description: Froup\v’\ﬂse Post Office Agert
Flatfarm: |Linux j
Page Options Cancel Help

3 Provide a description for the POA.
The description displays on the POA agent console as the POA runs.

4 Select the platform where the POA will run (Agent Platform on the New Post Office Summary
Sheet).

5 (Conditional) If you have created the post office in a clustered environment, follow the
instructions in the appropriate section of the GroupWise 2012 Interoperability Guide.

6 Click OK to save the POA configuration information.

For more POA configuration options, see Section 12.12, “Changing POA Configuration to Meet
Post Office Needs,” on page 215.

Because the security of POA connections with the GroupWise Windows client is vital to the
security of your GroupWise system, the following message appears:

GroupWise Administrator 5'

SEL will not be used for Internet Client'Server connections until a proxy server has been specified

Would you like to enter one now?
i Mo |

7 (Optional) Click Yes to open the Network Address tab of the POA so that you can enable SSL for
the POA, as described in Section 36.3.3, “Securing the Post Office with SSL Connections to the
POA,” on page 508, and to set up an external IP address for it, as described in Section 36.3.1,
“Securing Client/Server Access through an External Proxy Server,” on page 506.

or

Click No to configure SSL later.
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11.3.3

11.3.4

11.4

You continue to receive this message each time you modify the properties of the POA object
until you configure SSL and an external address for the POA. However, you can continue with
installing and starting the new POA without immediately establishing the recommended
security configuration.

8 Continue with Installing and Starting the New POA.

Installing and Starting the New POA

1 Install and start the POA for the new post office on the server where you created the post office
directory structure.

For instructions, see “Installing GroupWise Agents” in the GroupWise 2012 Installation Guide.
2 Continue with Setting Up User Access to the New Post Office.

Setting Up User Access to the New Post Office

The post office Access Mode determines how GroupWise client users access their mailboxes. By
default, the GroupWise Windows client use Client/Server Access Mode to the post office. Client/
Server Access Mode provides the following benefits:

¢ Client/server access provides the greatest level of security. Users do not need rights to the post
office directory because the GroupWise client does not write directly to databases in the post
office. All database updates are performed by the POA.

¢ Client/server access eliminates the need for separate network logins and passwords. This avoids
problems with login restrictions, changing passwords, and insufficient network rights.

¢ Client/server access allows the GroupWise client to maintain multiple simultaneous connections
to the post office.

+ With client/server access mode, proxy rights can be granted to any user visible in the Address
Book.

Historical Note: In GroupWise 5.x, the GroupWise client allowed the user to enter a path to the post
office directory during login to facilitate Direct Access mode. The GroupWise 6.x and later Windows
client no longer offers that login option. However, you can force the GroupWise 6.x and later
Windows client to use Direct Access mode by starting it with the /ph switch and providing the path
to the post office directory. However, this access mode is not recommended.

If you have not already done so, establish the recommended security configuration for the POA by
following the instructions in:

¢ Section 36.3.1, “Securing Client/Server Access through an External Proxy Server,” on page 506

¢ Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on page 508

What's Next

After you have created the new post office and started its POA, you are ready to expand the post
office by:

¢ Adding users to the post office.

See “Users” on page 217.

+ Defining groups of users (distribution lists) that GroupWise users can select when addressing
messages.

186  GroupWise 2012 Administration Guide


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#a8pam03
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_install/gw2012_guide_install.pdf#gw2012guideinst

See “Distribution Lists, Groups, and Organizational Roles” on page 279.

¢ Defining resources (for example, conference rooms or company cars) that users can schedule.
See “Resources” on page 263.

¢ Defining libraries and setting up Document Management Services.
See “Libraries and Documents” on page 313.

¢ Setting up the GroupWise Windows client software so that GroupWise users can run the client
from Windows workstations.

See “Client” on page 1013.
¢ Configuring the POA for optimal performance and security.

See “Post Office Agent” on page 469.

11.5 New Post Office Summary Sheet

Item Value for Your GroupWise Explanation
System

Tree Name: Section 11.2.3, “Determining the
Context for the Post Office
Object,” on page 176

eDirectory Container: Section 11.2.3, “Determining the
Context for the Post Office
Object,” on page 176

Post Office Name: Section 11.2.4, “Choosing the
Post Office Name,” on page 176

GroupWise Domain: Section 11.2.2, “Selecting the
Domain That the Post Office
Belongs To,” on page 176

Post Office Database Section 11.2.5, “Deciding Where
Location: to Create the Post Office
Directory,” on page 177

Post Office Section 11.2.8, “Selecting the
Language: Post Office Language,” on
page 179
Post Office Time Section 11.2.9, “Selecting the
Zone: Post Office Time Zone,” on
page 179
Software Distribution Section 11.2.10, “Selecting a
Directory: Software Distribution Directory,”
on page 179
Create Library: Section 11.2.12, “Deciding if You
Want to Create a Library for the
¢ No New Post Office,” on page 180
* Yes
Post Office Section 11.2.4, “Choosing the
Description: Post Office Name,” on page 176
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Item

Value for Your GroupWise
System

Explanation

Post Office Security
Level:

¢ Low
+ High

+ eDirectory
authenticatio
n

* LDAP
authenticatio
n

Agent Platform:

¢ Linux POA

¢+ Windows POA
Link to Domain:

¢ TCP/IP

+ Mapped

+ UNC

Section 11.2.11, “Selecting a
Post Office Security Level,” on
page 180

Section 11.2.6, “Deciding Where
to Install the Agent Software,” on
page 178

Section 11.2.7, “Deciding How to
Link the New Post Office,” on
page 178
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2 Managing Post Offices

12.1

As your GroupWise system grows and evolves, you might need to perform the following
maintenance activities on post offices:

¢ Section 12.1, “Connecting to the Domain That Owns a Post Office,” on page 189

¢ Section 12.2, “Editing Post Office Properties,” on page 190

¢ Section 12.3, “Managing Disk Space Usage in the Post Office,” on page 196

¢ Section 12.4, “Auditing Mailbox License Usage in the Post Office,” on page 207

¢ Section 12.5, “Viewing Current Client Usage in the Post Office,” on page 209

¢ Section 12.6, “Tracking and Restricting Client Access to the Post Office,” on page 209

¢ Section 12.7, “Securing the Post Office with LDAP Authentication,” on page 211

¢ Section 12.8, “Refreshing the Client View Files in the Post Office,” on page 211

¢ Section 12.9, “Disabling a Post Office,” on page 212

¢ Section 12.10, “Moving a Post Office,” on page 212

¢ Section 12.11, “Deleting a Post Office,” on page 214

¢ Section 12.12, “Changing POA Configuration to Meet Post Office Needs,” on page 215

See also Section 26, “Maintaining Domain and Post Office Databases,” on page 401 and Section 31,
“Backing Up GroupWise Databases,” on page 431.

Proper database maintenance and backups allow recovery from accidental deletions, as described in
Section 32.5, “Restoring Deleted Mailbox Items,” on page 435 and Section 32.6, “Recovering Deleted
GroupWise Accounts,” on page 438.

Connecting to the Domain That Owns a Post Office

Whenever you change post office information, it is most efficient to connect directly to the domain
that the post office belongs to before you begin making modifications. Performing administrative
tasks in a post office while not connected to the post office’s domain increases the amount of
administrative message traffic sent between domains.

For instructions, see Section 9.1, “Connecting to a Domain,” on page 145.
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12.2  Editing Post Office Properties

After creating a post office, you can change some post office properties. Other post office properties
cannot be changed.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties to display
the post office Identification page.

Properties of Development rz‘
NDS Rights + | Gther | Rights to Files and Folders |
Post Cffice: |Provol.Development ]
Description: ‘ ‘
UMNC Path: ‘IUBD-GW\mail\gwsystem\dev |__]
Language: ‘Eng\ish -us W |
Time Zone! ‘(GMT-U?:DU) Mountain Time (U3 & Canada) b |
Database Version: 12
[ ‘Wiew Client: Options ] [ Configure Non-D035 Name Space Access

2 Change editable fields as needed.

For information about individual fields, see Section 11.3, “Setting Up the New Post Office,” on
page 181 or use online help when editing the post office.

3 Click GroupWise > Post Office Settings to display the Post Office Settings page.

Properties of Management r'5_<|

NDS Rights = | Other | Rights to Files and Folders |

i Post Office Settings |

Software Distribution Directory: |GW Software e |
Access Mode: |CIientJ‘Sarver only 3 |
Delivery Mode: |Use App Thresholds b |
Max Age For Address Book Updates: {:} days
[[] Cisable Live Mave
Restore Area: (Mot Set)
Default Archive Service Trusted Application: (Mot Set)

[] Owerride | |

Remate File Server Settings

Remote User Name: | |

Remote Password: Set Password

190  GroupWise 2012 Administration Guide



Basic post office settings are discussed in the following sections:

¢ Section 11.2.10, “Selecting a Software Distribution Directory,” on page 179

¢ Section 11.3.4, “Setting Up User Access to the New Post Office,” on page 186
More advanced post office settings are discussed in the following sections:

¢ Section 6.5, “Controlling Address Book Synchronization for Caching and Remote Client
Users,” on page 112

¢ Section 14.4, “Moving GroupWise Accounts,” on page 234
¢ Section 32.5, “Restoring Deleted Mailbox Items,” on page 435
¢ Section 4.2.7, “Archive Service Settings,” on page 77

¢ Section 36.1.7, “Configuring the POA for Remote Server Login (Windows Only),” on
page 492

4 Click GroupWise > Client Access Settings to display the Client Access Settings page.

ment @

NDS Rights v | Gther | Rights to Files and Folders |

Lock Qut Qlder Groupiize Clients

[ Minimum Client Release Version (x.x.x): |

[ Minimurm Cliert Release Date: |

[ Dizable Logins
I Enahle Intruder Detection

Incorrect Loging Allowed: 3 il (3-10)
Incorrect Login Reset Time: 15 il minutes (15-60)
Lockout Reset Time: 15 il minutes (15+)

Page Options... Ok | Cancel | Lpply ‘ Help |

The client access settings are discussed in the following sections:
¢ Section 12.6, “Tracking and Restricting Client Access to the Post Office,” on page 209
¢ Section 12.9, “Disabling a Post Office,” on page 212
¢ Section 36.3.5, “Enabling Intruder Detection,” on page 516
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5 Click GroupWise > Membership to display the Membership page.

Properties of Development f'5_<\

NDS Rights = | Gther | Rights to Files and Folders |

Users;

WDharrmapalan Development Provo
Atendenhall. Development.Frova
WRamirez.Development.Provo
wSkoczylas. Development Provo
BGelzomino.Development Provo
CBolton.Development.Provo
FHaughey Development. Provo
FThompson.Development Provo
Hwwong.Development.Prova
«JDeSoto.Development. Provo
1Stevens.Development.Provao
tacoub Development Provo
KHuang.Development.Prova
LTanaka.Development.Frova
MJones. Development Provo
MLamaroux.Developrment Provo
MdelaTorre.Development. Provo
RSteadman.Developrment.Provo
SMurphy. Development.Provo

nt | \ |

Page Options... | Cancel | ‘ Help |

All users in the post office are listed, no matter where their Novell eDirectory objects are located
in the tree. Here you can add, delete, and move users in the post office. See “Users” on page 217.

6 Click GroupWise > Resources to display the Resources page.

Properties of Development E‘
Groupwise ~ | NDS Rights vl Cther | Right= to Files and Folders |
Resources
Resources: ‘

Cotnpany Car 1 .Grougvise
Company Car 2.Groupiiise
Conference Room 201 2. GroupWise
Group Meeting Room Groupiize
Lunchroom .Groupifise

[ese |

Ok | Cancel | Apply ‘ Help |

All resources in the post office are listed, no matter where their eDirectory objects are located in
the tree. This is a convenient place to delete resources from the post office. See “Resources” on
page 263
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7 Click GroupWise > Distribution Lists to display the Distribution Lists page.

Properties of Development @

{GroupWise | NDS Rights ~ | Ciher | Rights to Files and Folders |

Distribution Lists:

Engineers Groupifise

Groupise Administrators Docdey Movell
Help Desk.Docdey Movell

Programmer s Groupiise

Secretaries Groughize

Testers Grouplifise

Page Options... [e]l% | Cancel | Apply ‘ Help |

All distribution lists in the post office are listed, no matter where their eDirectory objects are
located in the tree. This is a convenient place to delete distribution lists from the post office. See
“Distribution Lists, Groups, and Organizational Roles” on page 279.

8 Click GroupWise > Libraries to display the Libraries page.

Properties of Development E‘

DS Rights | Cther | Right= to Files and Folders |

Libraties: ‘

Development Library Groupiiise

Page Options... Ok | Cancel | Apply ‘ Help |

All libraries belonging to the post office are listed, no matter where their eDirectory objects are
located in the tree. This is a convenient place to delete libraries. See Part VII, “Libraries and
Documents,” on page 313.
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9 Click GroupWise > Gateway Aliases to display the Aliases page.

Properties of Development fz\

{GroupWise = {| NDS Rights ~ | other | Rights o Files and Folders |
Cateway Allses ;

Gatevvay Alisses:

nt | \ |

Page Options... [e]l% | Cancel | Apply ‘ Help |

Many non-GroupWise systems do not use the same address syntax as GroupWise. Or, in some
cases, they might not support the same address characters or address length. A gateway alias is
simply an alternate address that conforms to the format requirements of the non-GroupWise
system that the gateway connects to. An alias might be required in order to exchange messages
with the non-GroupWise system, or it might be required when synchronizing directory (user)
information between the two systems.

Alias requirements vary depending on the non-GroupWise system to which your gateway
connects. For alias information specific to your gateway, see the GroupWise guide for that
gateway on the GroupWise Gateways Documentation Web site (http://www.novell.com/
documentation/gwgateways).

For more information about gateway aliases, see Section 52.3, “Transitioning from SMTP
Gateway Aliases to Internet Addressing,” on page 754.

10 Click GroupWise > Internet Addressing to display the Internet Addressing page.

rties of Development ['$_<\

i| hDS Rights | Gther | Rights to Files and Folders |

Qwerride Preferred Address format:

o H|

Defined st Corporate Mail

Allowwed Address Formats
r ¥

-
-
-

r
Defined st Corpotate Mail

Internet domain name:

r
Defined st Corpotate Mail
[ For incoming meil, recipients are known exclugively by this Internet dormain name
Page Options... oK Cancel Apply Help
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Here you provide information used to determine the Internet addressing settings for the post
office. See Section 52, “Configuring Internet Addressing,” on page 743 for more information.

11 Click GroupWise > Security to display the Security page.

Properties of Legal E
Groupwige » | NDS Rights ~ | Cther | Rights to Files and Folders |
Security
Security Level
" Low
% High
High Security Optiohs
[ eDirectory Autherdication
v [BA i
LDAP Server
LDAP User Mame: | E
LDAP Password Set Paszwaord
[ Disable LDAP Passwiord Changing
Inactive Conhection Timeout: a0 il SEConds
LDAP Pool Server Reset Timeout i il minutes
LDAP Server Quarshting Threshold, 2 il
Select Servers
Page Options... oK | Cancel | Apply ‘ Help |

For instructions on setting the security level for the post office, see Section 11.2.11, “Selecting a

Post Office Security Level,” on page 180.

12 Click GroupWise > Default WebAccess to display the Default WebAccess page.

NOTE: This page applies only to post offices that have not yet been updated to GroupWise 2012.

GroupWise 2012 does not include the WebAccess Agent.

lopment E
DS Rights ~ | Cther | Rigtts to Files and Folders |
i Default WiehAccess |
Override Default Webiccess Gatewsay:
™ Z|
Mot Defined
Page Options: Ok | Cancel | Lpply ‘ Help |

Use this page to designate the default WebAccess gateway for the legacy post office.

13 Click OK to save changes to the post office properties.
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12.3

12.3.1

Managing Disk Space Usage in the Post Office

Many users are prone to save every message and attachment they ever receive. You can moderate this
behavior by implementing disk space management:

¢ Section 12.3.1, “Understanding Disk Space Usage and Mailbox Size Limits,” on page 196

¢ Section 12.3.2, “Preparing to Implement Disk Space Management,” on page 197

¢ Section 12.3.3, “Setting Mailbox Size Limits,” on page 198

¢ Section 12.3.4, “Enforcing Mailbox Size Limits,” on page 200

¢ Section 12.3.5, “Restricting the Size of Messages That Users Can Send,” on page 201

¢ Section 12.3.6, “Preventing the Post Office from Running Out of Disk Space,” on page 203

¢ Section 12.3.7, “An Alternative to Disk Space Management in the Post Office,” on page 206

¢ Section 12.3.8, “Forcing Caching Mode,” on page 206

Understanding Disk Space Usage and Mailbox Size Limits

The concept of mailbox size is different for Windows client users than it is for you as an
administrator. Users are most interested in the functional size of their mailboxes; that is, the number
of items that they can store in their mailboxes. Administrators are usually more concerned about the
physical disk space that mailboxes occupy.

Functional mailbox size is computed by adding the bytes occupied by individual messages. Users are
notified when they exceed the functional mailbox size limit that you have set for them. Users can then
identify items to delete or archive.

+ Windows client users can use Tools > Check Mailbox Size to list items in the Trash folder, the Sent
Items folder, the Mailbox folder, the Work in Progress folder, and any posted items. Item size is
displayed in bytes and the list is sorted from largest to smallest, to easily identify candidates for
deletion or archiving.

¢ WebAccess users always have the Size column visible.

When users have deleted or archived sufficient items, their functional mailbox size limit problem is
resolved.

As an administrator, you want to set functional mailbox size limits that are reasonable for users and
that make efficient use of the physical disk space that you have available. You are more concerned
about physical disk space usage in the post office. Physical disk space usage is much more complex
than counting the bytes occupied by individual messages.

The following factors influence physical disk space usage:

¢ In atypical post office, 85% of disk space is occupied by attachments in the offiles directory
structure. Attachments are compressed by 40% to allow more data to be stored in less space.

¢ A large message sent to multiple users in the same post office is only stored on disk once, but
counts against mailbox size for all recipients. If it is sent to multiple post offices, a copy is stored
in each post office

¢ A large distribution list can cause even a small message to take up substantial disk space. If all
recipients are in the same post office, only one copy is stored, but if there are recipients in
multiple post offices, a copy is stored in each post office

¢ User databases (userxxx. db files) might contain large numbers of contacts and folders. Contacts
and folders affect the size of the user databases, which have a maximum size of 4 GB, but do not
count against the mailbox size for users.
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¢ Shared folders count only against the owner’s mailbox size, even though sharing with users in
other post offices uses disk space in those post offices as well.

¢ A message is stored until the last recipient deletes and empties it. As a result, you might attempt
to reduce post office disk space usage by reducing certain users’ mailboxes, but disk space usage
does not change. This can occur because large messages eliminated from the reduced mailboxes
still exist in other mailboxes.

Because of the complexity of these factors, you might consider a progressive strategy to determine
the appropriate functional mailbox limits for your users.

For a new post office, you could check the physical disk space occupied by the post office before
users start accumulating email and initially set no functional mailbox limits. After a period of time
(for example, a month), see how much the post office has grown. Run a report, as described in
Section 30.1, “Gathering Mailbox Statistics,” on page 423, to assess the rate of mailbox growth, then
start setting functional mailbox limits based on user needs and available physical disk space. To set
mailbox limits, skip to Section 12.3.3, “Setting Mailbox Size Limits,” on page 198.

For an existing post office, where users have never had functional mailbox limits set in the past,
continue with Preparing to Implement Disk Space Management.

12.3.2  Preparing to Implement Disk Space Management

If you are implementing disk space management in an existing GroupWise system, you must begin
by setting the initial size information on all users” mailboxes.

To establish current mailbox size:

1 In ConsoleOne, browse to and select a Post Office object.
2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

[] Attachment File Check
Fix problems
Lipdate iser disk space tofas

Nowvell GroupWise Mailbox/Library Maintenance E|
(%) GroupWise Objects: Action: Run
Post Offices 3 Analyze/Fix Databases w
D sructrs (e ]
Contents
[] Collect statistics

Help

() Object Type
Databases | Logging | Results | Misc || Exclude
[v] User

[[] Message
[[] Dacument

Options file: <default>

3 In the GroupWise Objects field, select Post Offices.
4 In the Action field, select Analyze/Fix Databases.
5 As options to the action, select Contents, Fix Problems, and Update User Disk Space Totals.
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Make sure all other options are deselected.
6 On the Databases tab, select User.
Make sure all other types of databases are deselected.

7 Click Run, then click OK to acknowledge that the Mailbox/Library Maintenance task has been
sent to the POA.

After the POA has performed the task, current mailbox size information becomes available on
each user’s mailbox. The information is updated regularly as the user receives and deletes
messages.

8 To generate a report of current mailbox information, follow the instructions in Section 30.1,
“Gathering Mailbox Statistics,” on page 423.

9 Repeat Step 1 through Step 8 for each post office where you want to implement disk space
management.

10 Continue with Setting Mailbox Size Limits.

Setting Mailbox Size Limits

After initial size information is recorded on each user’s mailbox, you can establish a limit on the
amount of disk space each user’s mailbox is allowed to occupy. You can set a single limit for an entire
domain. You can set different limits for each post office. You can even set individual user limits if
necessary.

If you are implementing disk space management in an existing GroupWise system where users are
accustomed to unlimited disk space, you should warn them about the coming change. After you
establish the mailbox size limits as described in this section, users whose mailboxes exceed the
established limit cannot send messages until the size of their mailboxes is reduced. Users might want
to manually delete and archive items in advance in order to avoid this interruption in their use of
GroupWise.

To establish mailbox size limits:

1 In ConsoleOne, browse to and select a Domain, Post Office, or User object.
2 Click Tools > GroupWise Utilities > Client Options.

Groupll\ﬁse Client Options x|

Environment Send Documents

B <

Security Calendar

Close Help |

198  GroupWise 2012 Administration Guide



3 Click Send > Disk Space Management.

Send Options: Development

Send Options || Mail | Appt || Task || Note | Security | Disk Space Mamt | Global Signature

Mailbox size: linnit: 1] {:} ME
R [«] ,,
Threshold for warning users: n] = .
Maximum send messat i [«
Je sizet 1] = KE
[ Limits apply to cache

[[] Motify the administrator when threshold limit is exceeded
[ Metify the administratar when size limit is exceeded

Restare Default Settings

oK ] [ Cancel ] [ Help

4 Select User Limits.
5 Specify the maximum number of megabytes allowed for each user’s mailbox.

For guidance in setting mailbox size limits, visit the GroupWise Best Practices Wiki (http://
wiki.novell.com/index.php/GroupWise).

The maximum size limit that you can set for mailboxes is 4 TB.

6 Specify as a percentage the point where you want to warn users that their mailboxes are getting
full.

After users receive a warning message, they can continue to send messages until the size limit is
reached. After the size limit is reached, users must reduce the size of their mailboxes in order to
send additional messages.

7 (Optional) Specify in kilobytes the largest message that users can send.

IMPORTANT: By restricting message size, you can influence how fast users’ mailboxes fill up.
However, if users have valid reasons for sending messages that exceed this limit, the limit can
become a hindrance to users getting their work done.

8 Click OK > Close to save the disk space management settings.

9 (Conditional) If you are adding disk space management to an existing GroupWise system where
users’ mailboxes are already over the desired size limit, continue with Enforcing Mailbox Size
Limits.
or

(Conditional) If you are implementing disk space management in a new system where users
have not yet begun to use their mailboxes, see “Using Mailbox Storage Size Information” in
“Maintaining GroupWise” in the GroupWise 2012 Windows Client User Guide to see how setting a
mailbox size limit affects users” activities in the GroupWise client.
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12.3.4

200

Enforcing Mailbox Size Limits

If existing GroupWise users are having difficulty fitting their mailboxes into the established mailbox
size limits, you can assist them by reducing the size of their mailboxes for them.

When users archive and empty messages in their mailboxes, the messages are marked for removal
from the database (“expired”), but the disk space that the expired messages occupied in the
databases is retained and used again for new messages. As a result, archiving and deleting messages

does not affect the overall size of the databases.

The Expire/Reduce Messages option of Mailbox/Library Maintenance enables you to expire
additional messages and reduce the size of the databases by reclaiming the free space in the
databases that is created when messages are expired. You should inform users before you run this
process so they have a chance to archive or delete messages. Unread messages are not expired.

1 In ConsoleOne, browse to and select a Post Office object.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

(¥ Grougise Objects:

Post Otfices ¥
S )|

" Ohject Type
o

-

—

Options file: <defaul=

Novell GroupWise Mailbox/Library Maintenance

Action:

Run

|Exp\ra.l'Raduce Meszages

=

Cloze

Retrieve. .. ‘

X

' tems older than

' Downloaded items older than

[ tems larger than

B0 : days
[ 3

30 il days

1000 il KE Helo

Save...

' Trash alder than
I Reduce maikox to
I Reduce maikox to limited size
Include:
[¥ Received tems
[ Sert tems
[ Calendar tems
™ Only backed-up items
[~ Only retained items

Datahases 1 Logglng] Resuns] M\sc] Excludel

=
-
-

‘ B0 ildays
a000 iIKB

3 In the Action field, select Expire/Reduce.

4 Set the Expire and Reduce options as desired, making sure that Reduce Mailbox to Limited Size is

selected.

5 Click Run, then click OK to acknowledge that the Mailbox/Library Maintenance task has been

sent to the POA.

After the POA has performed the task, users mailboxes fit within the mailbox size limit you have

established.

6 Repeat Step 1 through Step 5 for each post office where you want to reduce user mailboxes to the
established mailbox size limit.

To see how setting a mailbox size limit affects user activities in the GroupWise client, see “Using
Mailbox Storage Size Information” in “Maintaining GroupWise” in the GroupWise 2012 Windows

Client User Guide.
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12.3.5

Restricting the Size of Messages That Users Can Send

By restricting message size, you can influence how fast user mailboxes fill up. However, if users have
valid reasons for sending messages that exceed this limit, the limit can become a hindrance to users
getting their work done.

For HTML-formatted messages, the MIME portion of the message counts in the message size. MIME
files can be large. If a user cannot send an HTML-formatted message, he or she could use plain text
instead, in order to decrease the size of the message so that it falls within the message size restriction.

There are four levels at which you can restrict message size:

¢ “Within the Post Office” on page 201
+ “Between Post Offices” on page 202
¢ “Between Domains” on page 202

¢ “Between Your GroupWise System and the Internet” on page 202

Within the Post Office

You can use Client Options to restrict the size of messages that users can send within their local post
office.

1 In ConsoleOne, browse to and select a Domain, Post Office, or User object.

2 Click Tools > GroupWise Utilities > Client Options.

x

Enviranment Send Documents

G

Security Calendar

Close Help |
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3 Click Send > Disk Space Management.

Send Options: Development

Send Options || Mail | Appt || Task || Note | Security | Disk Space Mamt | Global Signature

Mailbox size: linnit: 1] {:} ME
R [«] ,,
Threshold for warning users: n] = .
Maximum send messat i [«
Je sizet 1] = KE
[ Limits apply to cache

[[] Motify the administrator when threshold limit is exceeded
[ Metify the administratar when size limit is exceeded
Restare Default Settings

oK ] [ Cancel ] [ Help

4 Select User Limits.
5 Specify in kilobytes the largest message that users can send.

6 Click OK, then click Close to save the maximum message size setting.

Between Post Offices

You can configure the POA to restrict the size of messages that it allows to pass outside the local post
office. See Section 36.2.7, “Restricting Message Size between Post Offices,” on page 504 for setup
instructions.

Between Domains

You can configure the MTA to restrict the size of messages that it allows to pass outside the local
domain. See Section 42.2.1, “Restricting Message Size between Domains,” on page 642 for setup
instructions.

Between Your GroupWise System and the Internet

You can configure the Internet Agent (GWIA) to restrict the size of messages that it allows to pass to
and from your GroupWise system by setting the size limits in a customized class of service. See
Section 54.1, “Controlling User Access to the Internet,” on page 787 for setup instructions.
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12.3.6  Preventing the Post Office from Running Out of Disk Space

In spite of the best disk space management plans, it is still possible that some unforeseen situation
could result in a post office running out of disk space. To prevent this occurrence, you can configure
the POA to stop processing messages, so that disk space usage in the post office cannot increase until
the disk space problem is resolved.

1 In ConsoleOne, browse to and select a Post Office object, right-click its POA object, then click
Properties.

2 Click GroupWise > Maintenance, then adjust the settings in the Disk Check Interval and Disk Check
Delay fields as described in Section 36.4.2, “Scheduling Disk Space Management,” on page 520.

3 Click GroupWise > Scheduled Events.

DS Rights | Cther | Rights to Files and Folders |
Scheduled events used by this agent:
Default Daly Maintenance Event
Default Disk Check Event
Diefault Weekly Maintenance Event

The Default Disk Space Management Actions trigger a Reduce on user and message databases at
4 GB and stop mail processing at 200 MB. You can edit the Default Disk Space Management
Actions so that all post offices are affected, or you can create a new set of Disk Space
Management actions to assign to specific post offices.
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4 Click Create to create a new scheduled event to handle an unacceptably low disk space

condition.

Create Scheduled Event. E|
Mame: [ ]
Event Type: |D\sk Check e |

Trigger
() Percent Trigger actions at: Ijl@ ME
@ MB Stop mail processing at: ljl@ MB
Actions
[[] Default Disk Space Management Actions Create

5 Type a unique name for the new scheduled event, then select Disk Check as the event type.

6 In the Trigger Actions At field, specify the amount of free post office disk space at which to take
preventive measures.

7 Click Create to define your own disk check actions, then give the new action a unique name.

Scheduled Event Action [zl
Mame: |Low Disk Space Actions | QK
Action: |ExpirEjRE\:|u[E Messages v |

() Reduce only

a
Ttems alder than =

Downloaded items older than
[] 1tems larger than

Trash alder than

[«]
[~]
e
[«]
[+
[+]
[~
[

[] Reduce mailbox ta

[ Reduce mailbax to limited size
Include

Recelved items

Sent items

Calendar items

[] only backed-up items

[] nly retained items

DﬂtﬂhﬂSESlLDgglng Results | Misc | Exclude | Motification

8 Configure the actions for the POA to take in order to relieve the low disk space condition.

Use the Results or Notification tab if you want to receive notification about the POA’s response to
the low disk space condition.
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9 Click OK to return to the Create Scheduled Event dialog box.

Edit Scheduled Event ]
Mame: |Stnp Message Processing |
Event Type: |Disk Check hd |

Trigger
O Percent Trigger actions at: _ 100fF e
(&) MB Stop mail processing at: @ ME
Actions
[] Default Disk Space Management Actions Create
Law Disk Space Actions
QF ] [ Cancel ] [ Help

10 In the Stop Mail Processing At field, specify the amount of free post office disk space at which you
want the POA to stop processing messages.

11 Click OK to create the new disk space management event and return to the Scheduled Events
page.

Properties of POA El

GroupWise  + | NDSRights + | Gther | Rights to Files and Folders |
Scheduled Everts

Scheduled events used by this agent:
Default Daily Maintenance Event
Default Disk Check Event

Default Weekly Maintenance Event

[ Create ][ Edit H Delete ]

o) (oo ) oy ] (oo

12 Select the new disk space management event.
13 Click OK to close the Scheduled Events page.

ConsoleOne then notifies the POA to restart so the new disk space management event can be put
into effect.

For additional instructions, see Section 36.4.2, “Scheduling Disk Space Management,” on
page 520.
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12.3.7  An Alternative to Disk Space Management in the Post Office

If you want to place more responsibility for disk space management onto GroupWise client users,
you can require that they run the client in Caching mode, where all messages can be stored on user
workstations, or other personal locations, rather than in the post office. For an overview of Caching
mode, see “Using Caching Mode” in the GroupWise 2012 Windows Client User Guide.

IMPORTANT: Do not force Caching mode for a post office that supports Outlook clients along with
GroupWise clients.

12.3.8  Forcing Caching Mode

You can force Caching mode for an entire domain, for specific post offices, or for individual users as
necessary.

When you initially force caching mode, users’ Caching mailboxes are identical with their Online
mailboxes. However, as you employ disk space management processes in the post office and reduce
the size of users’ Online mailboxes, more and more of the users’ mailbox items exist only in their
Caching mailboxes.

IMPORTANT: Make sure that users understand their responsibilities to back up their Caching
mailboxes, as described in “Backing Up Email” in “Maintaining GroupWise” in the GroupWise 2012
Windows Client User Guide.

To force Caching mode:

1 In ConsoleOne, browse to and select a Domain, Post Office, or User object.

2 Click Tools > GroupWise Utilities > Client Options.

Grouplllﬁse Client Options x|
$ % [
o =
Enviranment Send Documents
Security Calendar
Close Help |

3 Click Environment > Client Access.

Cliert Login Made

[¥ Allow use of "Remate” made d"

[¥ Allow use of "Caching” mode

[~ Force "Caching” mode after 14 iFays

[¥ By defautt, show Ingin mode drop-down list on client toolbar

4 In the Client Login Mode box, select Force Use of Caching Mode.
5 Click OK, then click Close to save the Caching mode setting.

206  GroupWise 2012 Administration Guide


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#ab7qohr
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#ab32nt1
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#aasxsfg
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#baba8ro
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#ab32nt1
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_userwin/gw2012_guide_userwin.pdf#ab32nt1

12.4

If you are helping existing users, who might have sizeable mailboxes, to start using Caching mode
exclusively, you can configure the POA to respond efficiently when multiple users need to download
their entire mailboxes for the first time. See Section 36.2.6, “Supporting Forced Mailbox Caching,” on
page 503 for setup instructions.

Auditing Mailbox License Usage in the Post Office

You can run an audit report in a post office to see:

¢ Which mailboxes have been accessed using full client licenses

¢ Which mailboxes have been accessed using limited client licenses

+ Which mailboxes are active (have been accessed at least one time)

¢ Which mailboxes have never been active

¢ Which mailboxes have been inactive for a specified period of time
A mailbox requires a full client license (and is marked as a full client license mailbox) if it has been
accessed by any of the following;:

¢ The GroupWise Windows client (grpwise.exe)

¢ GroupWise Notify (notify.exe) or GroupWise Address Book (addrbook . exe)

¢ A third-party plug-in to the GroupWise client API
A mailbox requires a limited client license only (and is marked as a limited client license mailbox) if
access to it has been limited to the following:

¢ GroupWise WebAccess (including mobile devices)

¢ GroupWise Windows client or WebAccess via the Proxy feature

+ GroupWise Windows client or WebAccess via the Busy Search feature

¢ A mobile device that is synchronizing GroupWise data by using Novell Data Synchronizer

¢ A POP client

¢ An IMAP client

¢ A SOAP client or a third-party plug-in to the GroupWise SOAP protocol
A mailbox is considered active for licensing purposes if its owner has performed at least one of the
following actions in the mailbox:

¢ Sending a message

¢ Opening a message

¢ Deleting a message

¢ Accessing the mailbox from a non-GroupWise client (for example, a POP3 email client) through

the Internet Agent (GWIA)

A mailbox is considered inactive for licensing purposes even if its owner has performed one or more
of the following actions (or similar actions):

¢ Starting and stopping the GroupWise client without doing anything in the mailbox

¢ Making changes under Tools > Options

¢ Creating, modifying, or deleting rules

¢ Granting proxy access so that a user other than the mailbox owner is performing tasks that
would otherwise indicate an active mailbox
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The mailboxes of GroupWise users and external entities require full client licenses.
To generate an audit report for the post office:

1 In ConsoleOne, browse to and select the Post Office object.
2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

@ novell GroupWise Mailbox/Library Maintenance x|
(¥ GroupWwise Objects: Action:
I—M Ffires = IAnaIyzefF\x Databases =1
Close
7 = [V structure
I Index check S
[~ Contents
[~ Collect statistics S&VE.
[ Attachment File Check
Hell
P prtons 5 ]
I Update user disk space totals
" Object Type
& User/Resource Databases | Lagging | Resuls | Misc | Exclude |
[V User
€ Libraty. 7 Message
I I~ Document
Options file: <default>
3 In the Action field, select Audit Report.
Hovell GroupWise Mailbox/Library Maintenance x|
& GroupiWise Objects: Action: Run
Post Offices -
Close:
Log accounts without activity For previous
l_EU él days Retrieve...
Save...
Help

" Object Typs

& UserfResouree
% User

€ Library, I Message:

I~ Dot

Databases | Logging | Reslts | Misc |

Options file: <default>

4 In the Log Accounts without Activity for nn Days field, select the number of days you want to use
for the inactivity report.

The Mailbox/Library Maintenance feature uses the default setting (60 days) to flag all mailboxes
that have not had any activity within the last 60 days. Select a different number to change the
time period of the log you generate for the audit report. For example, you could generate a log
report for the last 30 days. However, if you view the audit information by using Tools >
GroupWise Diagnostics > Information on a System, Domain, or Post Office object, the information
is always listed for the 60-day default time period.

208  GroupWise 2012 Administration Guide



12.5

12.6

5 (Conditional) If you want write the report to a log file, click the Logging tab, then specify a name
for the log file.

By default, the results are sent as an email message to the domain’s GroupWise administrator.
6 (Conditional) If you want to send the results to additional users:
6a Click the Results tab.
6b Specify the users’ email addresses as a comma-delimited list in the CC field.
6¢c Click Message to add personalized text to the message, then click OK.

7 Click Run, then click OK to acknowledge that the Mailbox/Library Maintenance task has been
sent to the POA.

After the POA has performed the task, the audit report is generated in the format (log file or
email message) you specified. The audit report lists all users who are currently considered
inactive and flags those that have been inactive for longer than the number of days specified in
the Log Accounts without Activity for nn Days field.

Audit reports are stored as part of the information available on Post Office and Domain objects in
ConsoleOne. Right-click a Domain or Post Office object, then click Tools > GroupWise Diagnostics >
Information. The information stored on the Domain object is cumulative for all post office in the
domain for which audit reports have been run.

Audit reports can also be scheduled to run on a regular basis by properly configuring the POA to
perform a Mailbox/Library Maintenance event. See Section 36.4.1, “Scheduling Database
Maintenance,” on page 517.

Viewing Current Client Usage in the Post Office

ConsoleOne can display the number of users who are using the Windows client. The client version is
also displayed.

1 In ConsoleOne, select a Post Office object, a Domain object, or the GroupWise System object.

2 Click Tools > Diagnostics > Information to display the client statistics for the selected object.

3 Click Close when you are finished.

Tracking and Restricting Client Access to the Post Office

By default, the post office allows multiple versions of the GroupWise Windows client to access it.
Using the Web console available for the post office’s POA, you can see the version number of each
GroupWise client that logs in to the post office in client/server access mode (TCP/IP to the POA). This
information is displayed on the POA Web console’s C/S Users page. For more information, see
Section 37.2, “Using the POA Web Console,” on page 539.

IMPORTANT: Because the POA provides the version tracking and enforces the client lockout, this
functionality applies only to GroupWise clients that are accessing the post office in Client/Server
Access Mode (not Direct Access Mode).

To help you better monitor and track which versions of the GroupWise client are being used to access
the post office, you can specify a preferred GroupWise client version for the post office. Any version
that does not match the preferred version is highlighted on the POA Web console’s C/S Users page.
Older versions are shown in red, and newer versions are shown in blue.
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In addition, to restrict which versions of the GroupWise client can access the post office, you can
choose to lock out any GroupWise clients that are older than the preferred version. If you want to
lock out all GroupWise clients (for example, to rebuild the post office database), see Section 12.9,
“Disabling a Post Office,” on page 212.

To specify a preferred GroupWise client version for the post office and to enable the POA to lock out
specific GroupWise client versions:

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties.

2 Click GroupWise > Client Access Settings to display the Client Access Settings page.

Properties of Development @\

QGroup\nﬁse ~i| nos Rights - | Cther | Rights to Files and Folders |
‘e e Sale

Lock Qut Older Growgise Clierts

[ Minimum Client Release Yersion (xux) |

7

I~ Minimum Client Release Date |

[ Dizahle Logins
[+ Enble Intrucer Detection

Incarrect Logins Allowed: 3 él (3-10)
Incorrect Login Reset Time: 148 il minutes (15-60)
Lockout Reset Time: 158 il minutes (15+)

Page Options: Ok Cancel Lpply Help

3 Fill in the following fields:

Minimum Client Release Version: Specify the version to use as the post office’s preferred
GroupWise client version. Any version that does not match the preferred version is highlighted
on the POA Web console’s C/S Users page. Older versions are shown in red, and newer versions
are shown in blue. The version number syntax should match what is displayed in the
GroupWise client’s About GroupWise dialog box.

For GroupWise 2012, specify 12.

Minimum Client Release Date: This field is available only if you specify a release version. You
can use this field to associate an expected release date with the release version. The C/S Users
page highlights any dates that do not match the one entered here.

Lock Out Older GroupWise Clients: Select this option for either or both of the above options to
lock out any GroupWise clients (Client/Server Access Mode only) that are older than the version
and/or date specified in the Release Version and Release Date fields. For example, if you entered
8.0.0 in the Release Version field and October 24, 2008 12:00 AM in the Release Date field and
selected this option for both, any GroupWise client that is older than version 8.0 or is dated
before October 24, 2008 12:00 AM is not allowed access to the post office.

The date for GroupWise 2012 is January 17, 2012.
4 Click OK to save the changes.
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12.7

12.8

Securing the Post Office with LDAP Authentication

For user convenience, you can configure the post office for LDAP authentication, which enables users
to use their LDAP (network) passwords to access their GroupWise mailboxes, rather than having
separate GroupWise passwords. The POA performs the LDAP authentication for users in the post
office. For setup instructions, see Section 36.3.4, “Providing LDAP Authentication for GroupWise
Users,” on page 510.

Refreshing the Client View Files in the Post Office

The GroupWise Windows client software includes view files that control the appearance of the client
interface. When you copy the client software to a software distribution directory, the view files are
included. A copy of the view files is also stored in each post office.

When you use AutoUpdate to force Windows client software updates, as described in Section 77.1,
“Using GroupWise AutoUpdate and SetuplP to Distribute the GroupWise Windows Client,” on
page 1069, the AutoUpdate process makes one attempt to update the view files in the post office
based on the latest client software in the software distribution directory. If that attempt fails, the
problem is recorded in the POA log file and you can then manually update the view files in the post
office.

1 In ConsoleOne, browse to and select the Post Office object whose view files you want to update,
then click Tools > GroupWise Utilities > System Maintenance.

GroupWise System Maintenance @

" alidate Database Run

" Recover Database Close

" Rehbuild Database
Helj
" Reclaim Unuzed Space ﬁ

" Rebuild Indexes for Listing

 fe

Description
Refresh the client views from the Software Distribution
Area the post office is assigned to use.

2 Select Refresh Views, click Run, click Yes, then click OK.

The POA then retrieves the latest view files from the software distribution directory associated
with the selected post office.

IMPORTANT: If you have created custom view files with the same names as standard view
files, they will be overwritten when the post office view files are refreshed from the software
distribution directory. If you have such customized view files, you must back them up and then
restore them so that your customizations are not lost because of the refresh.

Managing Post Offices 211



12.9

12.10

Disabling a Post Office

Disabling a post office restricts users from starting the GroupWise Windows client and accessing the
post office. However, users who are already running the GroupWise client can continue to access the
post office; after they exit, they cannot access the post office again until the post office is enabled.

A post office must be disabled if you are rebuilding the post office database (wphost.db). You might
also want to disable a post office when you are doing a complete GroupWise system backup. That
ensures that all data is consistent at the time of the backup.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties.
2 Click GroupWise > Client Access Settings to display the Client Access Settings page.

Properties of Development @\

QGroup\nﬁse ~i| nos Rights - | Cther | Rights to Files and Folders |
‘e e Sale

Lock Qut Older Growgise Clierts

[ Minimum Client Release Yersion (xux) |

7

I~ Minimum Client Release Date |

[ Dizahle Logins
[+ Enble Intrucer Detection

Incarrect Logins Allowed: 3 él (3-10)
Incorrect Login Reset Time: 148 il minutes (15-60)
Lockout Reset Time: 158 il minutes (15+)

Page Options: Ok | Cancel | Lpply ‘ Help |

3 Select Disable Logins, then click OK to disable the post office.

4 (Conditional) To re-enable logins and make the post office available again, deselect Disable
Logins.

Moving a Post Office

You cannot move a Post Office object in ConsoleOne because it is a container object. Only leaf objects
can be moved. If you need to change the context, graft the GroupWise post office to its corresponding
eDirectory object in the new container location. See Section 5.15, “GW / eDirectory Association,” on
page 99 for more information on grafting objects.

You can, however, move the post office directory, the post office database (wphost . db), and the other
databases that reside in the post office by copying the post office directory structure and all its
contents to the new location.

IMPORTANT: These instructions are for moving the post office from one location to another on the
same platform. If you want to move a post office from a Windows server to a Linux server, follow the
instructions in the GroupWise Server Migration Guide.

212  GroupWise 2012 Administration Guide


http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#A3edzdk
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_tsh3/gw2012_guide_tsh3.pdf#A3edzdk
http://www.novell.com/documentation/groupwise2012/pdfdoc/gw2012_guide_svrmig/gw2012_guide_svrmig.pdf#Ab32nt1

To move a post office directory structure and all its contents:
1 Make sure all users are out of the post office, then disable logins to the post office. See
Section 12.9, “Disabling a Post Office,” on page 212.
2 Back up the post office. See Chapter 31, “Backing Up GroupWise Databases,” on page 431.
3 In ConsoleOne, display the Identification page of the post office to move.

4 In the UNC Path field, change the UNC path to the location where you want to move the post
office, then click OK to save the new location.

The format of the path in the UNC Path field depends on whether you are running Linux
ConsoleOne or Windows ConsoleOne, and on whether the post office is on Linux or Windows.
Retain the original format of the path in your modified version of the location.

The location change is then propagated up to the domain.
5 Stop the POA for the post office.
6 (Conditional) On Linux:
6a In a terminal window, log in as root, then provide the root password.

6b Use cp to copy the post office directory and database to the new location:

cp -r post office directory destination
7 (Conditional) On Windows:

7a Use xcopy with the /s and /e options to move the post office directory and its contents:

xcopy post office directory /s /e destination

These options re-create the same directory structure even if directories are empty.
7b Give rights to objects that need to access the post office database.

For example, if the new location is on a different server, the POA and the GroupWise
administrators who run ConsoleOne need adequate rights to the new location, as described
in Chapter 87, “GroupWise Administrator Rights,” on page 1127.

8 Edit the POA startup file by changing the setting of the /home switch, then restart the POA.
See Section 36.1.6, “Adjusting the POA for a New Post Office Location,” on page 491.

9 When you are sure the post office is functioning properly, delete the original post office
directories.

If you need to move the POA along with its post office, see Section 36.1.5, “Moving the POA to a
Different Server,” on page 490.
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Deleting a Post Office

You cannot delete a post office until you have deleted or moved all objects that belong to it. Keep the
POA running until after you have deleted the post office, so that it can process the object deletion
requests.

1 In ConsoleOne, browse to and right-click the Post Office object to delete, then click Properties.

Properties of Development: E|
GroupWise ¥ 1| NDS Fighis + | Cther | Richts ta Files and Folders |
w Idertification
Post Office Seftings
Client Acoess Seftings Proval Development
Membership
Resources
Distribution Lists
Lisraries WIBD-GWmailigwsystem|dey
Gateway Aliaszes English - US “
Internet Addressing —
Security (GEMT-07:00) Mountain Time (LS & Canada) v
Default Webiccess 12
Calendar Publishing
[ ‘Wiew Client Options ] [ Configure Mon-DOS Mame Space Access ]

Click GroupWise > Resources, then delete any resources that still belong to the post office.

See Section 16.6, “Deleting a Resource,” on page 274. You must delete resources before users,
because users who own resources cannot be deleted without assigning a new owner in the same
post office.

Click GroupWise > Membership, then delete or move any users that still belong to the post office.

See Section 14.11, “Removing GroupWise Accounts,” on page 255 and Section 14.4, “Moving
GroupWise Accounts,” on page 234.

Click GroupWise > Distribution Lists, then delete any distribution lists that still belong to the post
office.

See Section 18.8, “Deleting a Distribution List,” on page 294.

Click GroupWise > Libraries, then delete any libraries that still belong to the post office.
See Section 22.6.7, “Deleting a Library,” on page 354.

Click OK to perform the deletions.

As an alternative, it is very easy to perform such deletions in the GroupWise View. Select the
Post Office object in the GroupWise View, then use the drop-down list of objects to display
objects of each type that still belong to the post office. Delete any residual objects in the Console
View.

In ConsoleOne, browse to and right-click the Domain object that owns the post office to delete,
then click Properties.

Click GroupWise > Post Offices, select the post office to delete, then click Delete.
Stop the POA for the post office.
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12.12

10

Uninstall the POA software if applicable, as described in the following sections in the GroupWise

2012 Installation Guide:

¢ “Uninstalling the Linux GroupWise Agents”
¢ “Uninstalling the Windows GroupWise Agents”

Changing POA Configuration to Meet Post Office Needs

Because the POA delivers messages to mailboxes, responds in real time to client/server users, and
maintains all databases located in the post office, its functioning affects the post office and all users
who belong to the post office. Proper POA configuration is essential for a smoothly running
GroupWise system. Complete details about the POA are provided in Part IX, “Post Office Agent,” on
page 469. As you create and manage post offices, you should keep in mind the following aspects of
POA configuration:

*

*

*

Section 36.3.3, “Securing the Post Office with SSL Connections to the POA,” on page 508
Section 36.3.4, “Providing LDAP Authentication for GroupWise Users,” on page 510
Section 36.3.5, “Enabling Intruder Detection,” on page 516

Section 36.2.3, “Supporting IMAP Clients,” on page 498

Section 36.2.4, “Supporting SOAP Clients,” on page 499

Section 38.1, “Optimizing Client/Server Processing,” on page 559

Section 36.4.1, “Scheduling Database Maintenance,” on page 517

Section 36.4.3, “Performing Nightly User Upkeep,” on page 523

Section 36.2.7, “Restricting Message Size between Post Offices,” on page 504
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V Users

¢ Chapter 13, “Creating GroupWise Accounts,” on page 219
¢ Chapter 14, “Managing GroupWise Accounts and Users,” on page 229
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Creating GroupWise Accounts

For users to be able to use GroupWise, you must give them GroupWise accounts. A GroupWise
account defines the user in the GroupWise system by providing the user with a GroupWise user ID
and GroupWise mailbox.

You can give GroupWise accounts to Novell eDirectory users during or after their creation in
eDirectory. You can also give GroupWise accounts to users who do not have eDirectory accounts.
Refer to the following sections for details:

¢ Section 13.1, “Establishing a Default Password for All New GroupWise Accounts,” on page 219
¢ Section 13.2, “Creating GroupWise Accounts for eDirectory Users,” on page 220

¢ Section 13.3, “Creating GroupWise Accounts for Non-eDirectory Users,” on page 224

¢ Section 13.4, “Educating Your New Users,” on page 226

13.1 Establishing a Default Password for All New GroupWise
Accounts

To save time and energy when you are creating new GroupWise accounts, you can establish a default
password to use for all new accounts.

1 In ConsoleOne, click Tools > GroupWise System Operations > System Preferences > Default Password.

GroupWise System Preferences @l

Routing Options | External Access Rights | Mickname Settings
: Admin Lockaut Settings Archive Service Settings

Default password For new users:

2 Type the password you want to use as the default, then click OK.

3 Explain to users how to set their own passwords in GroupWise, as described in:
¢ “Assigning a Password to Your Mailbox” in the GroupWise 2012 Windows Client User Guide
¢ “Changing Your Password” in the GroupWise 2012 WebAccess User Guide

Users cannot change their passwords using GroupWise WebAccess Mobile on tablet devices.
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13.2 Creating GroupWise Accounts for eDirectory Users

Depending on your needs, you can choose from the following methods to create GroupWise accounts
for eDirectory users:

¢ Creating a Single GroupWise Account: You can create a GroupWise account for a single
eDirectory user by editing the GroupWise information on his or her User object. This method
lets you create the GroupWise account on any post office, select the GroupWise user ID, and
configure optional GroupWise information. It provides the most flexibility in creating a user’s
GroupWise account.

¢ Creating Multiple GroupWise Accounts: You can create GroupWise accounts for multiple
eDirectory users by editing the membership information on a Post Office object. This method
allows you to quickly add multiple users to the same post office at one time. However, you
cannot select the user’s GroupWise user ID; instead, the user’s eDirectory user name is
automatically used as his or her GroupWise user ID. In addition, to configure other optional
GroupWise information for a user, you need to modify each User object.

13.2.1 Creating a Single GroupWise Account

To create a GroupWise account for an eDirectory user:
1 In ConsoleOne, right-click the User object, then click Properties.
2 Click GroupWise > Account to display the Account page.

Properties of scarter El

Security vI Lodin Methods vI General Restrictions v| Memberships v| Security Equal To ME{ EE

Post Office: @
Mailbo 10 scarter

wisibility

External Sync Override:

Account I0;

File: 100

ol

Expiration Date:

Gakteway Access:

LOAP Authentication:

Restore Area:

3 Fill in the following fields:
Post Office: Select the post office where you want the user’s mailbox created.

Mailbox ID: The mailbox ID (also referred to as the GroupWise user ID or user name) defaults
to the eDirectory user name. You can change it if necessary.
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Do not use any of the following invalid characters in the mailbox ID:

ASCII characters 0-31 Comma,

Asterisk * Double quote “

At sign @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces { } Period .

Colon : Slash /

IMPORTANT: Each user’s mailbox ID becomes part of the user’s email address. Characters that
are valid and even desirable in a mailbox ID, such as accented characters, might not be valid in
an email address. For some users, you might need to set up a preferred email ID in order to
ensure that they have a valid email address. For instructions, see Section 14.7.2, “Changing a
User’s Internet Addressing Settings,” on page 249.

Click Apply to create the account.

You must create the account by clicking Apply (or OK) before you can modify any of the other
fields, including the GroupWise password.

If desired, modify any of the following optional fields:

Visibility: Select the level at which you want the user to be visible in the Address Book. System
enables the user to be visible to all users in your GroupWise system. Domain enables the user to
be visible to all users in the same domain as the user. Post Office enables the user to be visible to
all users on the same post office as the user. Setting the visibility level to None means that no
users can see the user in the Address Book. However, even if the user is not displayed in the
Address Book, other users can send messages to the user by typing the user’s ID (mailbox ID) in
a message’s To field.

External Sync Override: This option applies only if your GroupWise system links to and
synchronizes with an external system, as described in “Connecting to Other GroupWise
Systems” in the GroupWise 2012 Multi-System Administration Guide.

¢ Synchronize According to Visibility: The user information is synchronized to external
systems only if visibility is set to System.

¢ Synchronize Regardless of Visibility: The user information is synchronized to external
systems regardless of the object visibility.

¢ Don’t Synchronize Regardless of Visibility The user information is not synchronized to
external systems.

Account ID: This option applies only if you have a GroupWise gateway that supports
accounting. For more information about gateway accounting, see your GroupWise gateway
documentation (http://www.novell.com/documentation/gwgateways).

File ID: This three-letter ID is randomly generated and is non-editable. It is used for various
internal purposes within the GroupWise system, including ensuring that files associated with
the user have unique names.

Expiration Date: If you want the user’s GroupWise account to no longer work after a certain
date, specify the expiration date. This date applies to the user’s GroupWise account only; it is
independent of the eDirectory account expiration date (User object > Restrictions > Login
Restrictions). For more information, see Section 14.11.2, “Expiring a GroupWise Account,” on
page 257.
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13.2.2

Gateway Access: This option applies only if you have GroupWise gateways that support access
restrictions. For more information, see your GroupWise gateway documentation (http://
www.novell.com/documentation/gwgateways).

Disable Logins: Select this option to prevent the user from accessing his or her GroupWise
mailbox. For more information, see Section 14.9, “Disabling and Enabling GroupWise
Accounts,” on page 254.

LDAP Authentication: This option applies only if you are using LDAP to authenticate users to
GroupWise, as described in Section 36.3.4, “Providing LDAP Authentication for GroupWise
Users,” on page 510, and if the LDAP server is not a Novell LDAP server. If this is the case,
specify the user’s LDAP authentication ID.

Restore Area: This field applies only if you are using the GroupWise backup and restore
features. If so, this field indicates the location where the user’s mailbox is being backed up. For
details, see Chapter 32, “Restoring GroupWise Databases from Backup,” on page 433.

View Client Options: Click View Client Options as a convenient shortcut for Tools > GroupWise
Utilities > Client Options in order to modify client options for the currently selected user. For
more information, see Chapter 76, “Setting Defaults for the GroupWise Client Options,” on
page 1025.

Change GroupWise Password: Click this option to assign a password to the user’s GroupWise
account or change the current password. The user is prompted for this password each time he or
she logs in to GroupWise.

To be able to skip this option by setting a default password, see Section 13.1, “Establishing a
Default Password for All New GroupWise Accounts,” on page 219.

Delete GroupWise Account: Click this option to delete the user’s GroupWise account. This
includes the user’s mailbox and all items in the mailbox. The user’s eDirectory account is not
affected. For more information, see Section 14.11, “Removing GroupWise Accounts,” on
page 255

E-Mail Address: Displays the default email address for the user. Click the drop-down list to
specify a custom email address.

GroupWise Resource objects and Distribution List objects have this field on their Identification
page. User objects have this GroupWise field on their General page along with other eDirectory
user information.

6 Click Apply to save the changes.

7 Click GroupWise > General > Identification to display the user’s current eDirectory information.

This information appears in the GroupWise Address Book, as described in Chapter 6,
“GroupWise Address Book,” on page 105. If you keep private information in the Description field
of the User object, you can prevent this information from appearing the GroupWise Address
Book. See Section 6.1.6, “Preventing the User Description Field from Displaying in the Address
Book,” on page 109.

8 Make sure that the user’s eDirectory information is current, then click OK.

Creating Multiple GroupWise Accounts

If you have multiple eDirectory users who will have GroupWise accounts on the same post office,
you can use the Post Office object’'s Membership page to quickly add the users and create their
accounts. Each user’s GroupWise user ID will be the same as his or her eDirectory user name.

To create GroupWise accounts for multiple eDirectory users:

1 In ConsoleOne, right-click the Post Office object, then click Properties.
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2 Click GroupWise > Membership to display the Membership page.

Properties of Management &
NDS Rights ~ | Cther | Rights ta Files and Folders |

3 Click Add, select the eDirectory user you want to add to the post office, then click OK to add the
user to the post office’s membership list.

By default, the user’s eDirectory user name is used as the GroupWise ID.

A GroupWise user ID cannot contain any of the following invalid characters:

ASCII characters 0-31 Comma ,

Asterisk * Double quote “

At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces { } Period .

Colon: Slash /

IMPORTANT: Each user’s GroupWise ID becomes part of the user’s email address. Characters
that are valid and even desirable in a GroupWise ID, such as accented characters, might not be
valid in an email address. For some users, you might need to set up a preferred email ID in order
to ensure that they have a valid email address. For instructions, see Section 14.7.2, “Changing a
User’s Internet Addressing Settings,” on page 249.
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4 Repeat Step 3 to create additional GroupWise accounts in the post office.

Properties of Development ﬁ‘

{GroupWise ~ | NDS Rights = | Cther | Rights to Files and Folders |

Users:
askaczylas.Users Docdey Novel
gsmith. Users, Docdew. havell
ipangilinan.Users. Docdew Movel
khuang,Users, Docdey, Movell
rbarnard.Users. Docdey MNovell
mpalu.Users.Docdey Mawvel
thu, Users Docdey, Novel
xdominguez. Users, Docdey, Novell

5 When you are finished, click OK to save the changes.

13.3 Creating GroupWise Accounts for Non-eDirectory Users

If you have users who do not have eDirectory accounts, you can still assign them GroupWise
accounts by defining them as GroupWise external entities in eDirectory. Defining a user as a
GroupWise external entity provides the user with access to GroupWise only; it does not enable the
user to log in to eDirectory. External entities have eDirectory objects, but they are not considered
eDirectory users for licensing purposes.

To create a GroupWise account for a non-eDirectory user:
1 In ConsoleOne, right-click the eDirectory container where you want to create the user’s
GroupWise External Entity object, then click New > Object to display the New Object dialog box.

2 Select GroupWise External Entity, then click OK to display the Create GroupWise External Entity
dialog box.

Create GroupWise External Entity El

Groupiize Ohject ID:
[

Last Mame:

Cancel

ddi

| Help
Groupise Post Office:

External Metwork ID:

[ Define additional properties
[ Creste another External Ertity

3 Fill in the following fields:

GroupWise Object ID: Specify the user’s GroupWise ID. The user’s ID along with the user’s
post office and domain, provide the user with a unique name within the GroupWise system
(userID.po.domain).
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Do not use any of the following invalid characters in the GroupWise object ID:

ASCII characters 0-31 Comma,

Asterisk * Double quote “

At sign @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces { } Period .

Colon : Slash /

IMPORTANT: Each user’s GroupWise ID becomes part of the user’s email address. Characters
that are valid and even desirable in a GroupWise ID, such as accented characters, might not be
valid in an email address. For some users, you might need to set up a preferred email ID in order
to ensure that they have a valid email address. For instructions, see Section 14.7.2, “Changing a
User’s Internet Addressing Settings,” on page 249.

Last Name: Specify the user’s last name.

GroupWise Post Office: Select the post office where you want the user’s mailbox.

External Network ID: Specify the user’s network ID for the network that he or she logs in to.
4 Select Define Additional Properties, then click OK to display the GroupWise Identification page.

Properties of eedington @\

Genatal v | Festrictions vl Memberships vI Security Equal To Me I Login Script | NDSE Rights - “ EE
| Idertification

Metwork 10: eedington

Description:

Given Mame:

Last Mame: Edington

Title:

Department:

Phone:

Fax:

Mobile Phone:

Horme Phone:

E-Mail Address: eedington@Corparate. net @

Wiew Client Options

5 If desired, fill in any of the fields on the Identification page.

This information appears in the GroupWise Address Book, as described in Section 6.1,
“Customizing Address Book Fields,” on page 105. If you want to keep private information in the
Description field, you can prevent this information from appearing the GroupWise Address
Book. See Section 6.1.6, “Preventing the User Description Field from Displaying in the Address
Book,” on page 109.
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13.4

13.4.1

6 If you want the external entity user to be able to access his or her GroupWise mailbox using
LDAP authentication, as described in Section 36.3.4, “Providing LDAP Authentication for
GroupWise Users,” on page 510, click GroupWise > Account, then provide the fully distinguished
name of the user’s External Entity object in LDAP format (for example,
cn=user id,ou=orgunit,o=organization).

7 Click OK to save the information.

The user is given a GroupWise mailbox in the post office you selected and can access his or her
mailbox through the GroupWise client.

Educating Your New Users

After users can log in to their GroupWise accounts, all of the GroupWise client’s features are at their
fingertips, but some new users do not know how to get started. You can give your users the following
suggestions to encourage them to explore GroupWise.

¢ Section 13.4.1, “GroupWise Windows Client,” on page 226

¢ Section 13.4.2, “GroupWise WebAccess,” on page 227

¢ Section 13.4.3, “GroupWise WebAccess Mobile,” on page 227
You can also provide users with Quick Starts that cover specialized GroupWise functionality:

¢ Calendar Publishing Quick Start (http://www.novell.com/documentation/groupwise2012/pdfdoc/

gw2012_gs_calpubuser/gw2012_gs_calpubuser.pdf)

¢ GroupWise and Skype Quick Start (http://www.novell.com/documentation/groupwise2012/
pdfdoc/gw2012_qs_skype/gw2012_gs_skype.pdf)

¢ GroupWise and Messenger Quick Start (http://www.novell.com/documentation/groupwise2012/
pdfdoc/gw2012_gs_messenger22/gw2012_qs_messenger22.pdf)

¢ GroupWise and Vibe Quick Start (http://www.novell.com/documentation/groupwise2012/pdfdoc/
gw2012_gs_vibe/gw2012_qgs_vibe.pdf)

¢ WebAccess Basic Interface Quick Start (http://www.novell.com/documentation/groupwise2012/
pdfdoc/gw2012_gs_webaccbasic/gw2012_qs_webaccbasic.pdf) for mobile device users

You can also refer users to the GroupWise 2012 User Frequently Asked Questions (http://
www.novell.com/documentation/groupwise2012/gw2012_guide_userfaq/data/
gw2012_guide_userfaq.html).

NOTE: For convenience in printing, all GroupWise User Guides are available in PDF format at the
GroupWise 2012 Documentation Web site (http://www.novell.com/documentation/groupwise2012).

GroupWise Windows Client

In the GroupWise Windows client:

¢ Click Help > Help Topics to learn to perform common GroupWise tasks.
¢ Click Help > What’s New to learn about the latest new GroupWise features.

¢ Click Help > Training and Tutorials to display the BrainStorm, Inc. QuickHelp for GroupWise 2012
(http://www.brainstorminc.com/landing/product-integration/novell/gw-2012-quickhelp.aspx)
or customized training materials provided for your users.
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Use ConsoleOne to change the URL that displays when users click Help > Training and Tutorials.
In ConsoleOne, use Client Options > Environment > Tutorial to specify the URL for your
customized training materials.

¢ Click Help > User Guide to view the GroupWise 2012 Windows Client User Guide in HTML format.
The guide includes more background information on GroupWise features than the Help does.

13.4.2 GroupWise WebAccess

In GroupWise WebAccess:

¢ Click Help to learn to perform common GroupWise tasks.
¢ Click Help > What’s New in GroupWise 2012 to learn about the latest new GroupWise features.

¢ Click Help > Novell GroupWise 2012 Documentation Web Site to access the GroupWise 2012
WebAccess Mobile User Guide. The guide includes more background information on GroupWise
features than the Help does.

13.4.3  GroupWise WebAccess Mobile

In GroupWise WebAccess Mobile:

¢ Click Help to learn to perform common GroupWise tasks.
¢ Click Help > What’s New in GroupWise 2012 to learn about the latest new GroupWise features.

¢ Click Help > Novell GroupWise 2012 Documentation Web Site to access the GroupWise 2012
WebAccess User Guide. The guide includes more background information on GroupWise features
than the Help does.
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Managing GroupWise Accounts and
Users

As your GroupWise system grows, you will need to add users and manage their GroupWise
accounts.

¢ Section 14.1, “Adding a User to a Distribution List,” on page 229

¢ Section 14.2, “Allowing Users to Modify Distribution Lists,” on page 230

¢ Section 14.3, “Adding a Global Signature to Users’ Messages,” on page 231

¢ Section 14.4, “Moving GroupWise Accounts,” on page 234

¢ Section 14.5, “Renaming Users and Their GroupWise Accounts,” on page 242

¢ Section 14.6, “Managing Mailbox Passwords,” on page 243

¢ Section 14.7, “Managing User Email Addresses,” on page 247

¢ Section 14.8, “Checking GroupWise Account Usage,” on page 253

¢ Section 14.9, “Disabling and Enabling GroupWise Accounts,” on page 254

¢ Section 14.10, “Unlocking GroupWise Accounts,” on page 254

¢ Section 14.11, “Removing GroupWise Accounts,” on page 255

See also:

¢ Chapter 26, “Maintaining Domain and Post Office Databases,” on page 401
¢ Chapter 27, “Maintaining User/Resource and Message Databases,” on page 409
¢ Chapter 31, “Backing Up GroupWise Databases,” on page 431

Proper database maintenance and backups allow recovery from accidental deletions, as described in
the following sections:

¢ Section 32.5, “Restoring Deleted Mailbox Items,” on page 435
¢ Section 32.6, “Recovering Deleted GroupWise Accounts,” on page 438

14.1 Adding a User to a Distribution List

GroupWise distribution lists are sets of users and resources that can be addressed as a single entity.
When a GroupWise user addresses an item (message, appointment, task, or note) to a distribution
list, each user or resource that is a member receives a copy of the item.

To add a user to a distribution list:

1 In ConsoleOne, right-click the User object, then click Properties.
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2 Click GroupWise > Distribution Lists to display the Distribution Lists page.

Properties of mpalu rz‘
Securty v| Login Methods vl General v| Groupwige « | Restrictions vl Memberships vl Security Equal To M( EE
Distribution Lists
IMembership Participation
Salesmen@Provoz. Sakes To
-
Page Options, ., [ [=]9 ] [ Cancel ] [ Apply ] [ Help ]

3 Click Add, select the distribution list that you want to add the user to, then click OK.

Properties of mpalu E‘
Security v| Login Methods vI General v| GroupWise - | Restrictions vI Memberships vI Security Egqual To M{ EE
Distribution Lists
Membership Participation
Salesment@ProvoZ, Sakes To
-
Page Options. .. [ QK ] [ Cancel ] [ Apply ] [ Help

By default, the user is added as a primary recipient (To recipient).

4 If you want to change the resource’s recipient type, select the distribution list, click Participation,
then click To, CC, or BC.

5 Click OK to save your changes.

14.2  Allowing Users to Modify Distribution Lists

Because distribution lists are created in ConsoleOne, users by default cannot modify them. However,
in ConsoleOne, you can grant rights to selected users to modify specific distribution lists. For setup
instructions, see Section 18.6, “Enabling Users to Modify a Distribution List,” on page 291.
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14.3

14.3.1

Adding a Global Signature to Users’ Messages

You can build a list of globally available signatures to be automatically appended to messages sent by
GroupWise client users. Global signatures are created in HTML format. For users who prefer the
Plain Text compose view in the GroupWise client, a plain text version of the signature is appended
instead of the HTML version. When this occurs, HTML formatting and embedded images are lost,
but you can customize the plain text version as needed to compensate for the loss of HTML
formatting.

For Windows client users, the global signature is appended by the client to messages after any
personal signatures that users create for themselves. It is appended after the user clicks Send. If S/
MIME encryption is enabled, the global signature is encrypted along with the rest of the message.
Windows client users can choose whether global signatures are appended only for recipients outside
the local GroupWise system or for all recipients, local as well as external. For Windows client users,
you can assign a global signature based on users, resources, post offices, and domains.

For all client users, the Internet Agent (GWIA) can append global signatures to the end of messages
for recipients outside the local GroupWise system. However, the GWIA does not append global
signatures to S/MIME-encoded messages, nor does it duplicate global signatures already appended
by the Windows client. You can assign a default global signature for all users in your system and then
override that default by editing the properties of each GWIA object

¢ Section 14.3.1, “Creating Global Signatures,” on page 231

¢ Section 14.3.2, “Selecting a Default Global Signature for All Outgoing Messages,” on page 232

¢ Section 14.3.3, “Assigning Global Signatures to GWIAs,” on page 233

¢ Section 14.3.4, “Assigning Global Signatures to Windows Client Users,” on page 233

*

Section 14.3.5, “Excluding Global Signatures,” on page 234

NOTE: If a user sends an external message with a subject only (no message body), a global signature
is not appended. This is working as designed. The presence of a global signature on an external
message with an empty message body would prevent the GWIA /flatfwd switch from functioning
correctly.

Creating Global Signatures

1 Click Tools > GroupWise System Operations > Global Signatures.

Global Signatures El
Global Signatures:
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Click Create to create a new global signature.

Global Signature El
Mame: | |
HTML
(2]
Plain Text

3 Specify a descriptive name for the signature.

4 Compose the signature using the basic HTML editing tools provided, then click OK to add the
new signature to the list in the Global Signatures dialog box.

5 If you want to check or edit the text version of the signature that was automatically generated:
5a Select the new signature, then click Edit.

5b Modify the text version of the signature as needed, then click OK.
6 Click OK in the Global Signatures list dialog box to save the list.

14.3.2  Selecting a Default Global Signature for All Outgoing Messages

If you want the GWIA to append a global signature to all outgoing messages:

1 Click Tools > GroupWise System Operations > Global Signatures.
2 Click Settings.

Global Signature Settings E

Select a default Global Signature to insert in
outhound messages:

Cancel

Help

3 In the drop-down list, select the default global signature, then click OK.
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14.3.3  Assigning Global Signatures to GWIAs

If your organization needs more than one global signature on outgoing messages, you can assign
different global signatures to GWIAs as needed.

1 Browse to and right-click an GWIA object, then click Properties.
2 Click SMTP/MIME > Message Formatting.

erties of GW| E|

LDAP | POPIMMEP4 | Server Directories | Access Contral ~ | Resftach | Post Office Links | Gr{ [T]¥]
Message Formattin

Inbound Settings
Mumber of inbound conversion threacs: 4 $|

Outhound Settings:

Mumber of outbound conversion threads: 4 %‘

Defautt message encoding:
" Basic RFC-522

-
=" hIME
Message text ling wrapping:
[¥ Enable quoted printable text line wrapping
Line wrap length for message text on outhound mail: W%'
[ Enable flat-forwarding

Defautt Globsal Sighature to insert in outhound messages: Defined at: Carporate Mail
I override

[™ 2pply Global Sighature to relay messages

[ Dizable mapping =-priority fields

Page Cptions... Ok ‘ Cancel | Apply ‘ Help |

3 Under Default Global Signature to Insert in Outbound Messages, select Override, then select the
global signature that you want this GWIA to append to messages.

4 Click OK to save the setting.

14.3.4  Assigning Global Signatures to Windows Client Users

For Windows client users, you can assign different global signatures to different sets of users by
domain, post office, and individual user.

A global signature set at the post office level overrides the global signature set at the domain level. A
global signature set at the user level overrides the global signature set at the post office and domain
level.

1 Browse to and select the domain, post office, or set of users to which you want to assign a global
signature.

2 Click Tools > GroupWise Utilities > Client Options.
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14.3.5

14.4

3 Double-click Send, then click Global Signature.

Send Options: Development §|
Sendd Options | Mail | Appt | Task | Mote | Security | Disk Space Mant |

Glokal Signsture

|<None=

Restore Default Seftings

| Cancel | Help |

4 In the Global Signature drop-down list, select the global signature that you want to use.

By default, the selected signature is applied only to messages that are being sent outside your
GroupWise system.

5 Select Apply Signature to All Messages if you want to also use global signatures internally.
6 Click OK to save the settings.

Excluding Global Signatures

You might have a domain, post office, or set of users where you do not want the global signature to
be added to messages. You can suppress global signatures at the domain, post office, or user level.

1 Browse to and select the domain, post office, or users for which you want to suppress a global
signature.

2 Click Tools > GroupWise Utilities > Client Options.

3 Double-click Send, then click Global Signature.

4 In the Global Signature drop-down list, select <None>, then click OK.

Moving GroupWise Accounts

Expansion or consolidation of your GroupWise system can make it necessary for you to move
GroupWise accounts from one post office to another.

When you move a GroupWise account, the user’s mailbox is physically moved from one post office
directory to another. The user’s Novell eDirectory object, including the GroupWise account
information, remains in the same eDirectory container.
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14.4.1

14.4.2

When you move a user’s GroupWise account, all items are moved correctly and all associations
(proxy rights, shared folder access, and so on) are resolved so that the move is transparent to the user.
Occasionally, some client options the user has set (GroupWise client > Tools > Options) might be lost
and must be re-created for the new mailbox.

The following sections provide information you should know before performing a move and
instructions to help you perform the move.

¢ Section 14.4.1, “Live Move vs. File Transfer Move,” on page 235

¢ Section 14.4.2, “Preparing for a User Move,” on page 235

¢ Section 14.4.3, “Moving a GroupWise Account to Another Post Office in the Same eDirectory
Tree,” on page 236

¢ Section 14.4.4, “Moving a GroupWise Account to Another Post Office in a Different eDirectory
Tree,” on page 238

¢ Section 14.4.5, “Monitoring User Move Status,” on page 240

Live Move vs. File Transfer Move

GroupWise provides two types of moves: a live move and a file transfer move.

A live move uses a TCP/IP connection between Post Office Agents (POAs) to move a user from one
post office to another. In general, a live move is significantly faster (approximately 5 to 10 times) than
a file transfer move. However, it does require that TCP/IP is functioning efficiently between the two
POAs.

A file transfer move uses the transfer of message files (using POAs and MTAs) rather than a TCP/IP
connection between POAs. A file transfer move is required if you are moving a user across a WAN
link where TCP/IP might not be efficient.

By default, when you initiate a user move, the post office’s POA attempts to establish a live move
session with the destination post office’s POA. If it cannot, a file transfer move is used instead.

If desired, you can disable the live move capability (Post Office object > GroupWise > Identification >
Disable Live Move). Any moves to or from the post office would be done by file transfer.

Preparing for a User Move

Proper preparation can make the process of moving users go more smoothly. Consider the following
before moving a user’s GroupWise account:

¢ Make sure the POAs for the user’s current post office and destination post office are running.

See Chapter 37, “Monitoring the POA,” on page 525.

¢ Configure both POAs for verbose logging, in case troubleshooting is required during the user
move process.

See Section 37.3, “Using POA Log Files,” on page 551.

¢ If you are performing the user move during off hours, optimize both POAs for the user move
process. On the Agent Settings property page of the POA object in ConsoleOne, set Max Thread
Usage for Priming and Moves to 80%. Set Client/Server Handler Threads to 40. If you must move
multiple users during regular work hours, you can set up additional POA instances customized
for the user move process. This would prevent the user move process from impacting users’
regular activities in their mailboxes.
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14.4.3

See Section 38.2.2, “Configuring a Dedicated Message File Processing POA (Windows Only),”
on page 565.

Make sure the Message Transfer Agent (MTA) for the user’s current domain and destination
domain (if different) are running.

See Chapter 43, “Monitoring the MTA,” on page 659.
Make sure that all links between POAs and MTAs are all open.

See Section 10.2, “Using the Link Configuration Tool,” on page 161, Section 71.3.1, “Link Trace
Report,” on page 979, and Section 71.3.2, “Link Configuration Report,” on page 980.

Make sure that all domain databases along the route for the user move are valid.
See Section 26.1, “Validating Domain or Post Office Databases,” on page 401.

Make sure that the mailbox to move is valid. Select the Structure, Index, and Contents options in
GroupWise Check (GWCheck) or in Mailbox/Library Maintenance in ConsoleOne.

See Section 27.1, “Analyzing and Fixing User and Message Databases,” on page 409.

Enable automatic creation of nicknames for moved users, so that replies and forwarded
messages can be delivered successfully after the user has been moved.

See Section 4.2.4, “Nickname Settings,” on page 75.

A user who owns a resource cannot be moved. If the user owns a resource, reassign ownership
of the resource to another user who is on the same post office as the resource. You can do this
beforehand, or when initiating the user move.

See Section 16.2, “Changing a Resource’s Owner,” on page 271

(Optional) To reduce the number of mailbox items that must be moved, consider asking the user
to clean up his or her mailbox by deleting or archiving items. Have the user empty the Trash so
that deleted items are not moved with the user.

(Optional) Have the user exit the GroupWise client and GroupWise Notify before you initiate
the move. When the move is initiated, the user’s POA first creates an inventory list of all
information in the user’s mailbox. This inventory list is sent to the new post office’s POA so that
it can verify when all items have been received. If the user has not exited when the move begins,
the user is automatically logged out so that the inventory list can be built. However, after the
move has been initiated, the user can log in to his or her new mailbox even if the move is not
complete.

Moving a GroupWise Account to Another Post Office in the Same
eDirectory Tree

The following steps apply only if the user’s current post office and destination post office are located
in the same eDirectory tree. If not, see Section 14.4.4, “Moving a GroupWise Account to Another Post
Office in a Different eDirectory Tree,” on page 238.

To move a user’s GroupWise account to a different post office in the same eDirectory tree:

1 In ConsoleOne, connect to the domain that owns the destination post office where you are

moving the user.

If you need assistance with this task in a GroupWise system that includes domains on Linux
servers, see Section 4.1, “Select Domain,” on page 69.

2 In the GroupWise View, right-click the User object or GroupWise External Entity, then click Move

to display the GroupWise Move dialog box.
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If you want to move multiple users from the same post office to another post office, select all the
User objects, right-click the selected objects, then click Move.

GroupWise Move cbolton

Move to post office:

2|

‘ Cancel | Help |

3 Select the post office to which you want to move the user’s account, then click OK.

If the user owns a resource, the following dialog box appears.

Choose New Owner

Provol.Development jpangilinan. The USer owns resources.
Flease choose another userto be the owner for these resources.

Cwher: | g

‘ Cancel | Hela |

4 Select a new owner for the resource, then click OK.

5 Keep track of the user move process using the User Move utility. See Section 14.4.5, “Monitoring
User Move Status,” on page 240

Resolving Addressing Issues Caused By Moving an Account

The user’s new address information is immediately replicated to each post office throughout your
system so that the GroupWise Address Book contains the user’s updated address. Any user who
selects the moved user from the GroupWise Address Book can successfully send messages to the
user.

However, some users might have the user’s old address (GroupWise user ID) in their Frequent
Contacts Address Book. In this case, if the sender types the moved user’s name in the To field rather
than selecting it from the Address Book, GroupWise uses the old address stored in the Frequent
Contacts Address Book instead of the new address in the GroupWise Address Book. This results in
the message being undeliverable. The POA automatically resolves this issue when it performs its
nightly user upkeep (see Section 36.4.3, “Performing Nightly User Upkeep,” on page 523). During the
nightly user upkeep process, the POA ensures that all addresses in a user’s Frequent Contacts
Address Book are valid addresses in the GroupWise Address Book.

If you want to ensure that messages sent to the user’s old address are delivered even before the POA
cleans up the Frequent Contacts Address Book, you can create a nickname using the old GroupWise
user ID. For information about creating a nickname, see Section 14.7.4, “Creating a Nickname for a
User,” on page 252. To have a nickname created automatically when the user is moved, see

Section 4.2, “System Preferences,” on page 72.
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Moving a GroupWise Account to Another Post Office in a Different
eDirectory Tree

A GroupWise system can span multiple eDirectory trees, provided that all components for a single
domain (post offices, users, resources, and so on) are all in the same eDirectory tree. For example, a
user cannot be located in one tree and his or her post office in another.

If necessary, you can move a user’s account from a post office in one eDirectory tree to a post office in
another eDirectory tree as long as the post offices are in the same GroupWise system. This requires
the user to have a User object (or GroupWise External Entity object) in the eDirectory tree to which
his or her GroupWise account is being moved.

To move a user’s GroupWise account to a post office in a different eDirectory tree:

1 Make sure the user has a User object or GroupWise External Entity object in the eDirectory tree

to which his or her GroupWise account is being moved.

In ConsoleOne, right-click the User object or GroupWise External Entity object (in the
GroupWise View) > click Move to display the GroupWise Move dialog box.

If you want to move multiple users from the same post office to another post office, select all the
User objects, right-click the selected objects > click Move.

GroupWise Move cbolton

Mowe to post office:

‘ Cahcel | Help |

Select the post office to which you want to move the user’s account, then click OK.

If the user owns a resource, the following dialog box appears.

Choose New Owner

Provol.Developmentjpangilinan. The user owns resources.
Flease choose anather userto he the owner forthese resources.

Dvner: | g

‘ Cancel | Help |

4 Select a new owner for the resource, then click OK.

5 Keep track of the user move process by using the User Move utility to determine when the user

has been successfully moved. See Section 14.4.5, “Monitoring User Move Status,” on page 240.

In the destination eDirectory tree, right-click the User object or GroupWise External Entity object
where the GroupWise account will be assigned, then click Properties. This is the object referred to
in Step 1.
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7 Click GroupWise > Account to display the Account page.

Properties of scarter E‘

Past OFfice: ]

Mailbox 10 scarter
Wisibility:

External Sync Owerride:

Account 10

File ID:

|

Expiration Date:

Gateway Access:

LDAP Authentication:

Restore Areat

8 In the Post Office field, select the post office that the user’s GroupWise account was moved to.

9 In the Muailbox ID field, make sure that the mailbox ID is the same as the user’s mailbox ID
(GroupWise user ID) on his or her original post office.

10 Click OK.

A dialog box appears asking if you want to match the GroupWise account to this eDirectory
user.

11 Click Yes.

Resolving Addressing Issues Caused By Moving an Account

The user’s new address information is immediately replicated to each post office throughout your
system so that the GroupWise Address Book contains the user’s updated address. Any user who
selects the moved user from the GroupWise Address Book can successfully send messages to the
user.

However, some users might have the moved user’s old address (GroupWise user ID) in their
Frequent Contacts Address Book. In this case, if the sender types the moved user’s name in the To
field instead of selecting it from the Address Book, GroupWise uses the old address stored in the

Frequent Contacts Address Book instead of the new address in the GroupWise Address Book. This

results in the message being undeliverable. The POA automatically resolves this issue when it
performs its nightly user upkeep (see Section 36.4.3, “Performing Nightly User Upkeep,” on
page 523). During the nightly user upkeep process, the POA ensures that all addresses in a user’s
Frequent Contacts Address Book are valid addresses in the GroupWise Address Book.

If you want to ensure that messages sent to the user’s old address are delivered even before the POA
cleans up the Frequent Contacts Address Book, you can create a nickname using the old GroupWise
user ID. For information about creating a nickname, see Section 14.7.4, “Creating a Nickname for a

User,” on page 252. To have a nickname created automatically when the user is moved, see
Section 4.2, “System Preferences,” on page 72.
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Monitoring User Move Status

The User Move Status utility helps you track progress as you move users and resources from one post
office to another. It displays the user moves associated with the object you selected before displaying
the User Move Status dialog box. For example, if you selected a Domain object, all user moves for the
selected domain are displayed, but not user moves for other domains.

While a GroupWise user account is being moved, the POA in the source post office and the POA in
the destination post office communicate back and forth. You can track the move process progresses
through various steps and statuses:

1 In ConsoleOne, select a Post Office or Domain object.

All moves occurring within the selected location will be listed.
2 Click Tools > GroupWise Utilities > User Move Status.

User Move Status r?l

Fitter: nf
\ | | \ |
Domain | Post Office I Ohject D ‘ Last Move Status I Error I - -
Provol Development choltton Move request sert U

Refresh

Cancel
Help

At the beginning of the move process, most buttons are dim, because it would not be safe for you
to perform those actions at that point in the move process. When those actions are safe, the
buttons become active.

User Move Status ﬁl

Fiter: | Infa
J

Domain Post Office Ohject D Last Move Status Error —
Mwﬁ!ﬁ ﬂi Completed retrieving tems i Retry/Restart. ..
Force Complete.
Clear Status
Refresh

Cancel
Help

3 To restrict the number of users and resources in the list, type distinguishing information in any
of the Filter fields, then press Enter to filter the list.

4 During the move, click Refresh to update the status information.

IMPORTANT: The list does not refresh automatically.
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During the move, you might observe some of the following statuses:

*

Filter

Destination post office updated: The destination POA has updated the destination post
office database with the user’s account information. At this point, the user account exists in
the new location and appears in the Address Book with the new location information.

Source post office updated: The source POA has updated the user in the source post office
database to show the new destination post office. At this point, the user can no longer
access the mailbox at the old location.

Moving mailbox information: The POAs have finished exchanging administrative
information and are ready to move items from the old mailbox to the new mailbox.

Sending mailbox inventory list: The source POA sends the destination POA a list of all the
mailbox items that it should expect to receive.

Send item request: The destination POA starts requesting items from the source POA and
the source POA responds to the requests

Retry mailbox item retrieval: The destination POA was unable to retrieve an item and is
retrying. The POA continues to retry every 12 hours for 7 days, then considers the move
complete. To complete the move without waiting, click Force Complete. Typically, items that
cannot be moved were not accessible to the user in the first place, so nothing is missed in
the destination mailbox.

Completed retrieving items: The destination POA has received all of the items on its
mailbox inventory list.

Move completed: After all of the user’s mailbox items have arrived in the destination post
office, the user’s original account in the source post office is deleted and the user move is
finished.

User Move Status EI

| | | | | |

Daomain | Post Office ] Dhject 0 ‘ Last Move Status

Errar

Proval Development cholton Move completed 3 :

Clear All Complete
Refresh

Cancel
Help

The User Move Status utility cannot gather status information for destination post offices that
are running POAs older than GroupWise 6.5. Status information for users moving to older post
offices displays as Unavailable.

5 If something disrupts the user move process, select the problem user or resource, then click

Retry/Restart.

Retry/Restart on User Move

% Retry the last step of the mailhox move

" Skip retry on the current mailbo item

" Stop deferred retries

" Restart the entire mailbox move

Ok Cancel | Help |
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6 Select the option appropriate to the problem you are having, then click OK.

Retry the Last Step of the Mailbox Move: Select this option to retry whatever step the user
move process has stopped on. This is equivalent to performing one of the POA’s automatic
retries manually and immediately. Ideally, the step completes successfully on the retry and

processing continues normally.

Skip Retry on the Current Mailbox Item: Select this option to skip a particular mailbox item
that cannot be successfully moved. The need for this action can usually be avoided by running
Mailbox/Library Maintenance on the mailbox before moving the user account. Ideally, the user
move processing should continue normally after skipping the problem item.

Stop Deferred Retries: Select this option to stop the POA from retrying to send items that have
not been successfully received. This completes the user move process even though some
individual items have not been moved successfully.

Restart the Entire Mailbox Move: Select this option if something major disrupts the user move
process and you want to start over from the beginning. Because nothing is deleted from the
source mailbox until everything has been received in the destination mailbox, you can safely
restart a move at any time for any reason.

After you have moved a user in ConsoleOne, you can display detailed information about items
belonging to that account that have not yet been moved to the destination post office, perhaps
because problems were encountered when trying to move them. This information can help
determine the importance of moving residual items that are still pending after all other items
have been successfully moved.

7 Assess the importance of items that are still pending.

7a Select an account for which the move has not completed, then click Pending Items.

You can determine the record type (item, folder, Address Book contact, and so on), the item
type (mail, appointment, task, and so on), how old the item is, the sender of the item, and
the Subject line of the item. Not all columns in the Pending Items dialog box apply to all
record types and item types, so some columns might be empty.

7b Click Request to request pending items.
Pending items are retrieved in groups of 25.
7c Click Yes to request the first group of pending items, then click OK.

You might need to wait for a while before the pending item lists displays because the
request goes out through the destination domain to the source domain to the source post
office, where the source POA sends the requested information back to the destination
domain. Do not click Request again before the list appears or you receive the same list twice.

When the pending items appear, you can select an item, then click Info to display detailed
information about the item. You can also click Refresh to reread the domain database to
determine if additional items have been moved.

7d If you and the user whose mailbox is being moved decide that the pending items are
expendable, click Force Complete to finish the move process.

Renaming Users and Their GroupWise Accounts

When you rename a user, the user’s GroupWise user ID (mailbox ID) changes but the user remains in
the same post office. All of the user’s associations remain unchanged. For example, the user retains
ownership of any resources and documents while other users who had proxy rights to the user’s
mailbox retain proxy rights.

1 Make sure the user has exited the GroupWise client and GroupWise Notify.
2 Make sure the domain’s MTA and post office’s POA are running.
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14.6.1

3 In the GroupWise View, right-click the User object, then click Rename to display the GroupWise
Rename dialog box.

GroupWise Rename sjones

Mew Groupiize name:

Cancel | Help |

4 Specifty the GroupWise user ID.

5 Click OK to rename the user.

Resolving Addressing Issues Caused By Renaming a User

The user’s new information is immediately replicated to each post office throughout your system so
that the GroupWise Address Book contains the user’s updated address. Any user who selects the
renamed user from the GroupWise Address Book can successfully send messages to the renamed
user.

However, some users might have the user’s old address (GroupWise user ID) in their Frequent
Contacts Address Books. In this case, if the sender types the renamed user’s name in the To field
instead of selecting it from the Address Book, GroupWise uses the old address stored in the Frequent
Contacts Address Book instead of the new address in the GroupWise Address Book. This results in
the message being undeliverable. The POA automatically resolves this issue when it performs its
nightly user upkeep (see Section 36.4.3, “Performing Nightly User Upkeep,” on page 523). During the
nightly user upkeep process, the POA ensures that all addresses in a user’s Frequent Contacts
Address Book are valid addresses in the GroupWise Address Book.

If you want to ensure that messages sent to the user’s old address are delivered even before the POA
cleans up the Frequent Contacts Address Book, you can create a nickname using the old GroupWise
user ID. For information about creating a nickname, see Section 14.7.4, “Creating a Nickname for a
User,” on page 252.

Managing Mailbox Passwords

The following sections provide information to help you manage GroupWise mailbox passwords:

¢ Section 14.6.1, “Creating or Changing a Mailbox Password,” on page 243
¢ Section 14.6.2, “Removing a Mailbox Password,” on page 245
¢ Section 14.6.3, “Bypassing the GroupWise Password,” on page 246

For background information about GroupWise passwords, see Chapter 82, “GroupWise Passwords,”
on page 1099.

Creating or Changing a Mailbox Password

As administrator, you can use ConsoleOne to create a user’s mailbox password or change a user’s
existing password. If a user can log in to GroupWise, he or she can also change the mailbox password
through the Security Options dialog box (GroupWise Windows client > Tools > Options > Security) or
on the Passwords page (GroupWise WebAccess > Options > Password.
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To create or change a user’s mailbox password:

1 In ConsoleOne, right-click the User object (or GroupWise External Entity object), then click
Properties.

2 Click GroupWise > Account to display the Account page.

Properties of gsmith

Gereral v Restrictions ~ | Memberships v | Security Equal ToMe | Login Script | NDS Rights ~ |{ G

Post Office: \Provm Development

Mailbo: 1D \

Wisibilty: [System |
External Sync Owerride: ‘Synchromze accarding to visihility ﬂ
Accourt ID: \

File ID: mah

Expitation Date: [~ Enakle |

Gatesvay Acoess: ‘

[ Disable Loging

LDAP Authertication: [

Restore Ares: (Mot Set)

Change GrougWise Password Delete Groupise Account |

Page Options... | Cancel | ‘ Help |

3 Click Change GroupWise Password to display the Security Options dialog box.

Security Options

Enter new passwiord:
Retype password:
| Help

Cancel

did

[™ Clear user's password

4 Enter and reenter a new password.
5 Click OK.
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Removing a Mailbox Password

If you want to remove a user’s mailbox password but not assign a new password, you can clear the

password.

1 In ConsoleOne, right-click the User object (or GroupWise External Entity object), then click

Properties.

2 Click GroupWise > Account to display the Account page.

Properties of gsmith

{ Account

Post Crfice
Mailbon: ID:
Wisihility:
External Sync Owerride:
Accourt ID:
File: ICx
Expiration Date:
Gateway Sccess:

[ Disable Logins
LDAP Authertication:

Restore Area:

zeneral v| roupwise + | Restrictions vI Memberships vI Security Equal To Me I Login Script | MNDS Rights - “ EE

\vam Development

‘Sy’s‘tem ﬂ
‘Synchromze according to visibility j
\
mah
[ Enable
\
|
(Mat Set)

Change GrougWise Password

Delete Groupyize Sccount |

Page Options:

Cancel | ‘ Help |

3 Click Change GroupWise Password to display the Security Options dialog box.

Security Options

Enter neww password:

Retype password:

Cancel

[ Clear user's password

Help

4 Select the Clear User’s Password option.

5 Click OK.

NOTE: A mailbox with no password cannot be accessed using GroupWise WebAccess.
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Bypassing the GroupWise Password

By default, if a user must enter a password when logging in to GroupWise, he or she is prompted for

the password.

The GroupWise client includes several options that users can choose from to enable them to log in
without providing a password. These options, located on the Security Options dialog box
(GroupWise client > Tools > Options > Security), are described in the following table:

GroupWise Client Option

Description

No Password Required with eDirectory

Use Single Sign-On

Use Collaboration Single Sign-On
(CASA)

This option is available only when logged in to Novell eDirectory.

When GroupWise starts, it automatically logs in to the GroupWise
account associated with the user who is logged in to eDirectory at the
workstation. No GroupWise password is required.

This option is available only when using Novell Single Sign-on 2.0 and
SecureLogin 3.0 and later products.

When GroupWise starts, it uses the GroupWise password stored by
Novell Single Sign-on or SecurelLogin.

This option is available only when using Novell Common
Authentication Services Adapter (CASA) 1.0 and later.

When GroupWise starts, it uses the GroupWise password stored by
Novell CASA.

As shown in the table, these options appear only if certain conditions are met, such as the user having
Novell Single Sign-on or SecureLogin installed. If you don’t want the option to be available to users
even if the condition is met, you can disable the option. Doing so removes it from the GroupWise

client’s Password dialog box.

To disable one or more of the password options:

1 In ConsoleOne, click a Domain object if you want to disable password options for all users in the

domain.

or

Click a Post Office object if you want to disable password options for all users in the post office.

or

Click a User object or GroupWise External Entity object if you want to disable password options

for the individual user.

2 With the appropriate GroupWise object selected, click Tools > GroupWise Utilities > Client Options
to display the GroupWise Client Options dialog box.

Groupll\ﬁse Client Options x|

Enviranment Send Docurments

B <

Security Calendar

Close Help |
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3

8

Click Security to display the Security Options dialog box.

Security Options: Management §|

iPassnond | wacros | Notfy

[ Allow passward caching

[[] Use ebirectory authentication instead of password

Enable single sign-on
[[] use Callaboration Single Sign-on (CASA)

[ Restare Defaulk Settings ]

On the Password tab, select Allow Password Caching if you want Windows 95/98 users to be able to
use the GroupWise client’s Remember My Password option.

NOTE: This option applies only to older GroupWise clients running on older Windows
versions, such as Windows 2000 and earlier, which are not supported for the GroupWise 2012
Windows client.

Select Allow eDirectory Authentication Instead of Password if you want eDirectory users to be able
to use the GroupWise client’s No Password Required with eDirectory option.

This option is available only if eDirectory authentication is enabled for the post office, as
described in Section 11.2.11, “Selecting a Post Office Security Level,” on page 180.

Deselect Allow Novell Single Sign-on if you don’t want Single Sign-on or SecureLogin users to be
able to use the GroupWise client’s Use Novell Single Sign-on option.

Select Use Collaboration Single Sign-On (CASA) if you want users of Novell collaboration products
(GroupWise, Messenger, iFolder, and iPrint) to be able to use the same password for all
collaboration products.

Click OK to save your changes.

For more information about addressing formats, see Chapter 52, “Configuring Internet Addressing,”
on page 743.

Managing User Email Addresses

To ensure that user addresses meet your needs, GroupWise enables you to determine the format and
visibility of addresses, as well as create additional names for users. The following sections provide
details:

*

*

*

*

Section 14.7.1, “Ensuring Unique Email Addresses,” on page 248

Section 14.7.2, “Changing a User’s Internet Addressing Settings,” on page 249
Section 14.7.3, “Changing a User’s Visibility in the Address Book,” on page 251
Section 14.7.4, “Creating a Nickname for a User,” on page 252
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14.7.1  Ensuring Unique Email Addresses

Starting with GroupWise 7, you can use the same email ID for more than one user in your GroupWise
system, if each user is in a different Internet domain. Rather than requiring that each email ID be
unique in your GroupWise system, each combination of email ID and Internet domain must be
unique. This provides more flexibility for handling the situation where two people have the same
name.

When adding or changing users’” email addresses you can check to make sure that the email address
you want to use for a particular user is not already in use.

1 In ConsoleOne, click Tools > GroupWise Utilities > Email Address Lookup to display the Email
Address Lookup dialog box.

Email Address Lookup E|
Enter an emsail address to look up and press search.
Email Address: ||
DomanMame | Post Office Name ObjectiD | ObiectType |
| Ok | Help |

2 In the Email Address field, specify the email address. You can specify the user ID only (for
example, jsmith) or the entire address (for example, jsmith@novell.com).

3 Click Search.
All objects whose email address match the one you specified are displayed.

4 If desired, select an object, then click Info to see details about the object.

248  GroupWise 2012 Administration Guide



14.7.2 Changing a User’s Internet Addressing Settings

By default, a user inherits his or her Internet address settings (preferred Internet address format,
allowed address formats, and Internet domain name) from the user’s post office, domain, or
GroupWise system. For more information, see Chapter 52, “Configuring Internet Addressing,” on
page 743.

If necessary, you can override these settings for individual users.

1 In ConsoleOne, right-click the User object (or GroupWise External Entity object), then click
Properties.

2 Click GroupWise > Internet Addressing to display the Internet Addressing page.

Properties of gsmith E|
Security = | Login Methods = | Genersl = | {GroupWise = || Restrictions ~ | Memberships = | Securily Equal T¢ G
MGG eteey
Overtide | Preferred Address Format:
[F
Preferred EMall 10t
@Internet domain name
Defined at: Provol
Allowed Address Formats
O
Defined at: Corporate Mal
Internet domain name:
O
Defined at: Corporate Mail
Far incoming mail, recipients are known exclusively by this Internet domain name
View EMail Addresses

3 To override one of the settings, select the Override box, then change the setting.

Preferred Address Format: The preferred address format determines how the user’s address is
displayed in the GroupWise Address Book and in sent messages.

Preferred E-Mail ID: At the user and resource level, the preferred address format can be
completely overridden by explicitly defining the user portion of the address format
(user@Internet domain name). The user portion must include only RFC-compliant characters. The
following characters are valid:

Numbers 0-9

Uppercase letters A-Z

Lowercase letters a-z

Plus sign +

Hyphen -

Underscore _

Tilde ~

The user portion must be unique within its Internet domain. This means that a user can be used
multiple times in your GroupWise system, if it is used only once in each Internet domain.

If you have two users with the same name in the same Internet domain, you can further modify
the user portion. For example, if you have selected First Name.Last Name@Internet domain name as
your system’s preferred address format and you have two John Petersons in the same Internet
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domain, you would have two users with the same address (John.Peterson@novell.com). You
could use this field to differentiate them by including their middle initials in their addresses
(John.S.Peterson@novell.com and John.A.Peterson@novell.com).

Allowed Address Formats: The allowed address formats determine which address formats can
be used to send messages to the user. For example, using John Peterson as the user, Research as
the post office, and novell.com as the Internet domain, if you select all five formats, John
Peterson would receive messages sent using any of the following addresses:

jpeterson.research@novell.com
jpeterson@novell.com
john.peterson@novell.com
peterson.john@novell.com
jpeterson@novell.com

Internet Domain Name: The Internet domain name, along with the preferred address format, is
used when constructing the email address that is displayed in the GroupWise Address Book and
in the To field of sent messages.

Only the Internet domain names that have been defined are displayed in the list. Internet
domain names must be defined at the system level (Tools > GroupWise System Operations > Internet
Addressing). For more information, see Section 52, “Configuring Internet Addressing,” on

page 743.

If you override the Internet domain name, the For Incoming Mail, Recipients are Known Exclusively
by This Internet Domain Name option becomes available. Enable this option if you only want the
user to be able to receive messages addressed with this Internet domain name. If you don’t
enable this option, the user receives messages addressed using any of the Internet domain
names assigned to your GroupWise system.

View E-Mail Addresses: Click View E-Mail Addresses to display a list of the various email
address formats that can successfully deliver email to this user, including any nicknames or
gateway aliases that have been defined for this user. For more information, see:

¢ Section 52.1.4, “Preferred Address Format,” on page 744 and Section 52.1.5, “Allowed
Address Formats,” on page 747

¢ Section 14.7.4, “Creating a Nickname for a User,” on page 252

¢ Section 52.3, “Transitioning from SMTP Gateway Aliases to Internet Addressing,” on
page 754

4 Click OK to save your changes.
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Changing a User’s Visibility in the Address Book

A user’s visibility level determines the extent to which the user’s address is visible throughout your
GroupWise system. You can make the user visible in the Address Book throughout your entire
GroupWise system, you can limit visibility to the user’s domain or post office only, or you can make it
so that no users can see the user in the Address Book.

Making a user visible in the Address Book simply makes it easier to address items to the user.
Regardless of a user’s visibility, other users can send items to the user if they know the user’s

GroupWise user ID.

1 In ConsoleOne, right-click the User object (or GroupWise External Entity object), then click

Properties.

2 Click GroupWise > Account to display the Account page.

Properties of gsmith

Seneral =

Past Crffice:
Maillooos D
Wisibility:
External Sync Cverride;
Accourt D
File: ICx
Expiration Date:
Gatevvay booess:

[™ Dizakle Loging
LDAP Authertication:

Restore Area:

3

‘Provm Development

‘Sys‘lem

‘Sy’nchromze according to visibility

mah

I” Enable |

(Mot Set)

Change Grougwize Password

Delete Groupvize Account |

Page Options...

| Cancel | ‘ Help

3 In the Visibility field, select the desired visibility level.

System (Default): All users in your GroupWise system can see the user’s information in the

Address Book.

Domain: Only users in the same domain as the user can see the user’s information in the

Address Book.

Post Office: Only users in the same post office as the user can see the user’s information in the

Address Book.

None: No users can see the user’s information in the Address Book. Users need to know the
user’s GroupWise user ID to send items to him or her.

4 Click OK to save your changes.

Managing GroupWise Accounts and Users 251



14.7.4

Creating a Nickname for a User

Each user has a GroupWise address consisting of the user ID, post office, and domain
(user_ID.post_office.domain). You can create one or more nicknames for a user to give the user an
additional GroupWise address. Each part of the GroupWise address (user_ID, post_office, and domain)
can be different from the user’s actual address. Adjustments to the user’s GroupWise address are also
applied to the user’s Internet email address (user_ID@internet_domain).

Nicknames are useful in the following situations:

* You rename a uset, as described in Section 14.5, “Renaming Users and Their GroupWise

Accounts,” on page 242. You can create a nickname that retains the old user ID, so that messages
with the old user ID in the email address are routed to the new email address.

You move a user, as described in Section 14.4, “Moving GroupWise Accounts,” on page 234. You
can create a nickname that retains the old post office location. As messages to the moved user
arrive in your GroupWise system, the email address is routed to the new post office location.
You can configure ConsoleOne to automatically create nicknames when you move users, as
described in Section 4.2.4, “Nickname Settings,” on page 75.

You need to restrict a user’s visibility in the GroupWise Address Book, as described in

Section 6.2, “Controlling Object Visibility,” on page 110, and at the same time, you need to make
the user visible in one or more specific Address Books outside of the restricted visibility. You can
create a nickname that provides the specific visibility that is ruled out by the required restriction.

In ConsoleOne, you can list all the nicknames in your GroupWise system in the GroupWise View. In
the GroupWise client, you can display nicknames in the GroupWise Address Book if you enable Filter
for Contacts. When addressing a message, users need to know a nickname in order to use it.

To create a nickname for a user:

1 In ConsoleOne, right-click the User object or GroupWise External Entity object, then click

Properties.

2 Click GroupWise > Nicknames to display the Nicknames page.

X

Properties of gsmith

General v “+"| Restrictions v| Memmberships vI Security Equal To Me | Login Scrigt I ND'S Rights + H

i Micknames

Ohject 1D | Domain ‘ Post Office |

sdd | | |

Page Options Cancel | | Help |
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3 Click Add to display the Create Nickname dialog box.

Create Nickname El
Cresting nicknatne for gstith.sers Docdey Movell
Domain PO | @
Object I |
Visikiity |5ystem k|

Given Mame: |

Last Name: |

Expiration Date: [ Enable |

Cancel Help

4 Fill in the following fields:

Domain.PO: Select the post office that you want to own the nickname. This can be any post
office in your GroupWise system; it does not need to be the user’s post office.

Object ID: Specify the name to use as the user_ID portion of the nickname. The nickname must
be unique.

Visibility: Select the Address Book visibility for the nickname. This determines where the

nickname is available (system, domain, or post office). However, nicknames are not displayed in
the Address Book unless you filter for them. In order to address a message to a nickname, a user
must specify the nickname address, and the nickname must be available in the user’s post office.

External Sync Override: This option applies only if your GroupWise system links to and
synchronizes with an external GroupWise system, as described in “Connecting to Other
GroupWise Systems” in the GroupWise 2012 Multi-System Administration Guide.

¢ Synchronize According to Visibility: The nickname is synchronized to external
GroupWise systems only if Address Book visibility is set to System.

¢ Synchronize Regardless of Visibility: The nickname is synchronized to external
GroupWise systems regardless of Address Book visibility.

¢ Don’t Synchronize Regardless of Visibility The nickname is never synchronized to
external systems.

Given Name: Specify the user’s first name.
Last Name: Specify the user’s last name.

Expiration Date: If you want the nickname to be removed by the Expire Records feature after a
certain date, as described in Section 14.11.3, “Managing Expired or Expiring GroupWise
Accounts,” on page 258, select Enable, then select the desired date.

5 Click OK to add the nickname to the list.
6 Click OK to save the changes to the User object or GroupWise External Entity object.

Checking GroupWise Account Usage

You can identify GroupWise accounts that have been inactive for a specified period of time. See
Section 12.4, “Auditing Mailbox License Usage in the Post Office,” on page 207.

You can measure message traffic from individual GroupWise mailboxes. See Section 71.3.5, “User
Traffic Report,” on page 986.
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14.9

14.10

Disabling and Enabling GroupWise Accounts

You can disable a GroupWise account so that the user cannot access his or her mailbox until you
enable the account again. This might be necessary when a user leaves the company and no longer
needs access to the mailbox.

1 In ConsoleOne, right-click the User object (or GroupWise External Entity object), then click
Properties.

2 Click GroupWise > Account to display the Account page.

Properties of gsmith &

Gereral roupWiise v | Restrictions = | Memberships + | Security Equal To Me | Login Script | NDS Rights = |( G

Post Office: \Provm Development

Mailbo: 1D \

Wisibilty: [System |
External Sync Owerride: ‘Synchromze accarding to visihility ﬂ
Accourt ID: \

File ID: mah

Expitation Date: [~ Enakle |

Gatesvay Acoess: ‘

[ Disable Loging

LDAP Authertication: [

Restore Ares: (Mot Set)
Change GrougWise Password Delete Groupise Account |
Page Options... | Cancel | Help

3 Select Disable Logins, then click OK.

4 (Conditional) If the user is logged in to his or her Online mailbox when you disable logins,
disconnect the user, as described in “Disconnecting a User Session from the POA” on page 551.

5 To enable the user’s account when access is again permitted, deselect Disable Logins, then click
OK.

While a user’s account is disabled, other users to whom proxy rights have been granted can still
access the mailbox. This is convenient for reviewing the contents of the mailbox of a departed
employee and pulling out those messages that are of use to the incoming employee.

Unlocking GroupWise Accounts

A GroupWise user’s account is automatically disabled (locked) if you have enabled intruder
detection, as described in Section 36.3.5, “Enabling Intruder Detection,” on page 516, and if the user
exceeds the number of unsuccessful login attempts that you have allowed. When a user is locked out,
access is automatically granted again after the incorrect login reset time interval has passed. If a user
needs quicker access, you can unlock the GroupWise account in ConsoleOne or in the POA Web
console.
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14.11.1

In ConsoleOne:

1 Right-click the User object (or GroupWise External Entity object), then click Properties.
2 Click GroupWise > Account to display the Account page.
3 Deselect Disable Logins, then click OK.

In the POA Web console:

1 Click Status.

2 In the Statistics section, click Intruder Detection.
3 Click the user ID of the locked out user.

4 Select Reset Lockout, then click Submit.

As soon as the POA receives the changed setting, the user can again log in.

Removing GroupWise Accounts

You can remove a user’s GroupWise account by deleting or expiring it. Deleting an account removes
the entire account (address, mailbox, items, and so on) from the GroupWise system. Expiring an
account deactivates the account so that it cannot be accessed, but does not remove it from the system.
The following sections provide information to help you delete or expire GroupWise accounts

¢ Section 14.11.1, “Deleting a GroupWise Account,” on page 255

¢ Section 14.11.2, “Expiring a GroupWise Account,” on page 257
¢ Section 14.11.3, “Managing Expired or Expiring GroupWise Accounts,” on page 258
If you delete a GroupWise account by accident, or need to retrieve a deleted account for some other

reason, see Section 32.6, “Recovering Deleted GroupWise Accounts,” on page 438. For additional
user repair options, see Section 5.15, “GW / eDirectory Association,” on page 99.

NOTE: When you remove a GroupWise account, any personal databases, such as an archive, a
Caching mailbox, or a Remote mailbox, that are associated with the account are unaffected by the
account deletion. Such databases are not located where ConsoleOne could delete them, so they must
be deleted manually.

Deleting a GroupWise Account

When you delete a user’s GroupWise account, the user’s mailbox is deleted and the user is removed
from the GroupWise system. If the user owns library documents, see “Ensuring that a User’s Library
Documents Remain Accessible” on page 257 before deleting the user. Otherwise, refer to one of the
following sections:

¢ “Deleting an eDirectory User’s GroupWise Account” on page 255

¢ “Deleting a Non-eDirectory User’s GroupWise Account” on page 256

Deleting an eDirectory User’'s GroupWise Account

1 Make sure the user has exited the GroupWise client and GroupWise Notify.
2 Make sure the POA for the user’s post office is running.

If the POA is not running, the user mailbox is not deleted until the next time the POA runs.
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3 In ConsoleOne, right-click the User object, then click Delete.

or

Select multiple User objects, right-click the selected object, then click Delete.
4 Click Yes to display the Delete Options dialog box.

Delete Options El
jpangilinan.Users.Docdey.Movell has Groupyvise
and eDirectory accounts. Please indicate your
delete preferences below:

Groupklise Account
Delete
[[] Expire
elirectory Account
Delete

5 In the GroupWise Account box, select Delete.

6 In the eDirectory Account box, deselect Delete.

7 Click OK to delete the eDirectory user’'s GroupWise account.
or

If you selected multiple User objects, click OK to All to apply the same deletion options to all
accounts. If you click OK rather than OK to All, you can select deletion options for each account
individually as it is deleted.

8 If a user was a resource owner, the following dialog box appears. Select a new user to be the
resource’s owner, then click OK.

Choose New Owner

Provol.Development jpangilinan. The USer owns resources.
Flease choose another userto be the owner for these resources.

Cwher: | ﬂ

‘ Cancel | Hela |

Deleting a Non-eDirectory User’s GroupWise Account

Non-eDirectory users are given GroupWise accounts by adding the users to eDirectory as
GroupWise external entities (see Section 13.3, “Creating GroupWise Accounts for Non-eDirectory
Users,” on page 224). You remove a non-eDirectory user’s GroupWise account by deleting the user’s
GroupWise External Entity object from eDirectory.

NOTE: Remember that external entities do have eDirectory objects, but they are not considered
eDirectory users for licensing purposes.

As with eDirectory users, when you remove a non-eDirectory user’s GroupWise account, the user’s
mailbox is deleted and the user is removed from the GroupWise system.

To delete a non-eDirectory user’s GroupWise account:

1 Make sure the user has exited the GroupWise client and GroupWise Notify.
2 Make sure the POA for the user’s post office is running.

If the POA is not running, the user’s mailbox will not be deleted until the next time the POA
runs.
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3 In ConsoleOne, right-click the user’s GroupWise External Entity object, then click Delete.

4 Click Yes to confirm the deletion.

Ensuring that a User’s Library Documents Remain Accessible

When you delete a user’s GroupWise account, GroupWise does not delete any library documents to
which the user has Author or Creator status. These documents remain in the library as “orphaned”
documents, meaning that no one can access the documents.

If you or other users need access to the documents, you have the following choices:

¢ Rather than deleting the user, change the user’s GroupWise mailbox password so that he or she
can’t log in. Other users can continue accessing the documents, and you can log in as the user to
manage the documents. For information about changing a user’s password, see Section 14.6.1,
“Creating or Changing a Mailbox Password,” on page 243.

¢ Rather than deleting the user or changing the user’s password, disable the user’s ability to log in.
This is done on the user’s GroupWise Account page (User object > GroupWise > Accounts >
Disable Logins).

¢ Delete the user, then reassign the orphaned documents to another user. For information, see
Section 28.2, “Analyzing and Fixing Library and Document Information,” on page 416.

Expiring a GroupWise Account

Rather than delete a user’s GroupWise account, you can expire the account. The account, including
the user’s mailbox and all items, remains in GroupWise but cannot be accessed by the user. If
necessary, the user’s account can be reactivated at a later date, as described in Section 14.11.3,
“Managing Expired or Expiring GroupWise Accounts,” on page 258. This option is useful for
providing GroupWise accounts to temporary or contract employees who come and go.

You can set a user’s GroupWise account to expire immediately or at a future date and time.

1 Make sure the user has exited the GroupWise client and GroupWise Notify.

2 In ConsoleOne, right-click the User object or GroupWise External Entity object with the account
you want to expire, then click Properties.
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3 Click GroupWise > Account to display the Account page.

Properties of gsmith

Seneral =

Past Crffice:
Maillooos D
Wisibility:
External Sync Cverride;
Accourt D
File: ICx
Expiration Date:
Gatevvay booess:

[™ Dizakle Loging
LDAP Authertication:

Restore Area:

Change Grougwize Password

estrictions vI Memberships vI Security Equal To Me I Login Script | NDZ Rights “ EE

‘Provm Development
‘Sys‘lem j
‘Sy’nchromze according to visibility ﬂ

mah

I” Enable |

(Mot Set)

Delete Groupvize Account |

Page Options...

| Cancel | ‘ Help

4 In the Expiration Date field, select the Enable check box to turn on the option.

5 If you want the account to expire immediately, leave the date and time set to the current date and

time.

or

If you want the account to expire at a later date, select the desired date and time.

6 Click OK.

NOTE: To immediately expire an account assigned to an eDirectory user, you can also right-click the
User object, click Delete, select the Expire GroupWise Account option, then click OK. This method is
not available for non-eDirectory (GroupWise External Entity object) users.

Managing Expired or Expiring GroupWise Accounts

Expired GroupWise accounts remain expired until you reactivate them or delete them. Refer to the
following sections for information to help you manage expired accounts:

¢ “Identifying Expired or Expiring Accounts” on page 259

¢ “Changing an Account’s Expiration Date” on page 260

¢ “Reactivating an Expired Account” on page 260
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Identifying Expired or Expiring Accounts

Rather than search through all your User or GroupWise External Entity objects in eDirectory to
identify which ones have expired or expiring accounts, you can use the Expired Records option to
quickly list expired accounts for your entire system, a single domain, or a single post office.
Depending on the date you choose, you can see expired accounts only or both expired and expiring
accounts.

1 In the GroupWise View, select the post office, domain, or GroupWise system that contains the
accounts you want to view.

2 Click Tools > GroupWise Utilities > Expired Records to display the Expired Records dialog box.

Expired Records E|
Expired records in:  Proval
Expired as of: 10/27 12010
Expired Lsers:

Last Mame First Mamne Object ID Expiration Date Object Type Post Office Domain
Dominguez wander wdominguez  10/27/2010 User Development  Provol
Select all

The Expired As Of field defaults to the current date. Only accounts that have expired as of this
date are displayed in the list. To see accounts that will expire in the future, you need to change
the date in the Expired As Of field.

3 To change the date in the Expired As Of field, click View Date.
4 C(Click the calendar icon, select the desired date and time, then click OK.

For example, in the dialog box shown above, the current date is 1/18/2012 (January 1, 2012). To
see what accounts will expire by June 30, 2012, you would change the Expired As Of date to 6/30/
2012.

5 Click OK to return to the Expired Records page.

6 When you are finished viewing expired or expiring accounts, click OK to close the Expired
Accounts dialog box.
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Changing an Account’s Expiration Date

1
Properties.

Properties of gsmith

General w | GroupWise

; Account
Past Crffice:
Maillooos D
Wisibility:
External Sync Cverride;
Accourt D
File: ICx
Expiration Date:
Gatevvay booess:

[™ Dizakle Loging
LDAP Authertication:

Restore Area:

In ConsoleOne, right-click the User object or GroupWise External Entity object, then click

Click GroupWise > Account to display the Account page.

3

Restrictions vI Memberships vI Security Equal To Me I Login Script | NDZ Rights “ EE

‘Provm Development

‘Sys‘lem

K1 IEY

‘Sy’nchromze according to visibility

mah

I” Enable |

(Mot Set)

Change Grougwize Password Delete Groupvize Account |

Page Options... |

Cancel | Help

3 In the Expiration Date field, change the time and date.
4 Click OK.

Reactivating an Expired Account

1 In ConsoleOne, right-click the User object or GroupWise External Entity object with the expired

GroupWise account, then click Properties.

Click GroupWise > Account to display the Account page.

Properties of gsmith

General + | GroupWise
Post Office:
Mailioa: ID:
Wisihility:
External Sync Owerride:
Accourt ID:
File IC:
Expiration Date:
Gatesvay Scoess:

[ Digable Logins
LDAP Authertication:

Restore Area:

Restrictions ~ | Memberships v | Security Equal ToMe | Login Script | NDS Rights ~ |{ G

\Provm Development

‘Syﬁem j
‘Synchromze accarding to visihbility ﬂ
|
mah
I” Enable |
|
\
(Mot Set)

Change GroupgWise Password Delete GroupWise Account |

Page Options...

Cancel | Help
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3 In the Expiration Date field, deselect the Enable check box to turn off the option.
4 Click OK.
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V Resources

¢ Chapter 15, “Creating Resources,” on page 265
¢ Chapter 16, “Managing Resources,” on page 269

Resources 263
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15.1

15.1.1

15.1.2

Creating Resources

A resource is an item or place, such as a computer, company vehicle, or conference room, that users
can schedule or check out.

¢ Section 15.1, “Understanding Resources,” on page 265
¢ Section 15.2, “Planning Resources,” on page 266

¢ Section 15.3, “Creating a New Resource,” on page 267

Understanding Resources

The following sections provide information to help you learn about GroupWise resources:

¢ Section 15.1.1, “Resource Objects,” on page 265
¢ Section 15.1.2, “Resource Types,” on page 265
¢ Section 15.1.3, “Resource Mailboxes,” on page 266

¢ Section 15.1.4, “Resource Owners,” on page 266

Resource Objects

Each resource you want to make available must be added as a Resource object in Novell eDirectory.
The name that you give the Resource object becomes the name by which the resource is displayed in
the GroupWise Address Book.

Resource objects ( '*) can be located in any eDirectory container that is in the same tree as the
resource’s domain.

Resource Types

You can identify the resource as a general resource, as a place, or as a role.

When a user schedules a resource that is defined as a place, the resource name is automatically added
to the Place field in the appointment.

Starting in GroupWise 2012 SP2, a role resource represents a position in an organization that can be
reassigned from one owner to the next. As owners change, the role resource mailbox retains all
information associated with the role. Unlike general resources and place resources, role resources are
included in a Reply to All.
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15.1.3

15.1.4

15.2

Resource Mailboxes

Like a user, a resource must be assigned to a post office so that it can be given an account (address,
mailbox, and so on). You assign the resource to a post office when you create the Resource object.

A resource’s account enables it to receive scheduling requests (sent as appointments). The owner
assigned to the resource can access the resource’s mailbox to accept or decline the requests. For
example, you might want to have all your conference rooms defined as place resources. When
sending a meeting appointment, users can schedule the conference room as well as the meeting
attendees. The place resource, just like the other users scheduled for the meeting, receives an
appointment in its mailbox which can be accepted or declined by the owner.

When scheduling a resource, users can perform a busy search to see when the resource is available.

Even though a resource is assigned to a single post office, all users in your GroupWise system can
schedule the resource.

Resources can receive all item types (mail messages, phone messages, appointments, tasks, and
notes). Generally, if your purpose in defining resources is to allow them to be scheduled through
GroupWise, they only receive appointments.

Resources can also send items. If a resource sends an item to an Internet user, both the To field and the
From field are populated with the resource name when the Internet user receives the message.

Resource Owners

When you create a resource, you assign an owner to it. The owner must belong to the same post office
as the resource and is responsible for accepting or declining requests to schedule the resource. The
owner can do this by proxying to the resource’s mailbox and opening the scheduling requests, or by
setting up rules to manage the resource automatically. For more information, see Section 16.1,
“Creating Rules for a Resource,” on page 269.

The owner automatically receives proxy rights to the resource’s mailbox. The owner can also grant
proxy rights to another user to manage the resources.

The owner cannot log in directly to the resource mailbox. However, the owner can set a password on
the resource mailbox to facilitate secure access by an IMAP client. After proxying in to the resource
mailbox, click Tools > Options > Security > Password to set a password on the resource mailbox.

For more information about how owners can manage resources, see “Managing Resources” in
“Contacts and Address Books” in the GroupWise 2012 Windows Client User Guide.

Planning Resources

Before creating a new resource, make sure that the user who will own the resource has been created
and belongs to the same post office where you are planning to create the resource.
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15.3 Creating a New Resource

1 In ConsoleOne, right-click the container where you want to create the Resource object, then click
New > Resource to display the Create GroupWise Resource dialog box.

Create GroupWise Resource El
Resource Mame: |
I

GroupiWise Post Office: Cancel

i=

Help
Qwher

& |=

[ Define additional properties

[ Create ancther resaurce

2 Fill in the following fields:

Resource Name: Specify a descriptive name. Because the name is used as part of the resource’s
GroupWise email address, do not use any of the following invalid characters in the resource
name:

ASCII characters 0-31 Comma,

Asterisk * Double quote "

At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces { } Period .

Colon : Slash /

IMPORTANT: Characters that are valid and even desirable in a resource name, such as accented
characters, might not be valid in an email address. For some resources, you might need to set up
a preferred email ID in order to ensure that they have a valid email address. For instructions, see
Section 16.7.1, “Changing a Resource’s Internet Addressing Settings,” on page 274.

GroupWise Post Office: Select the post office where the resource will be located.

Owner: Select the user who will be responsible for accepting or declining requests to use the
resource. The owner must have a GroupWise account on the same post office as the resource.
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3 Select Define Additional Properties, then click OK.

Properties of Conference Room 2021 E‘

fi General I MNDS Rights + | Cther I Rights to Files and Folders I

Eenice N
Distinguished Mame: Conference Room 2021, GroupiWise
Post OFfice: Provol,Development
Owner: gsmith
File ID:: Giv
Description:
Wisibility: Syskem 1~
Resource Type: Resource M
Phane!
E-Mail Address: Conference Room 2021@Carparate.net

View Client Options

4 On the Identification page, fill in the following fields:

Description: Specify a description to help users identify the use of the resource. The description
is displayed if the user chooses to view information about the resource in the Address Book.

If you define the resource type as a place, the description is automatically added to the Place field
in the appointment. A good description can help users locate the place more easily.

Visibility: Select the level at which the resource will be visible in the Address Book. System
causes the resource to be visible to all users in your GroupWise system. Domain causes the
resource to be visible to all users in the same domain as the resource. Post Office causes the
resource to be visible to all users on the same post office as the resource. None causes the
resource to not be visible at any level. However, even if the resource is not displayed in a user’s
Address Book, he or she can schedule the resource by typing the resource name in an
appointment’s To field.

Resource Type: You can identify the resource as a general resource, as a place, or as a role. When
a user schedules a place resource, the resource description is automatically added to the Place
field in the appointment. A role resource is treated more like a user than a general resource or a
place resource, and can be included in a Reply to All.

Phone: If the resource has a telephone number associated with it, such as a conference room
with a telephone number, specify the phone number.

E-Mail Address: Displays the default email address for the resource. Click the drop-down list to
specify a custom email address. For example, if you created a resource with spaces in its name,
you need to remove the spaces to create a valid email address.

View Client Options: Click View Client Options as a convenient shortcut for Tools > GroupWise
Utilities > Client Options in order to modify client options for the currently selected resource. For
more information, see Chapter 76, “Setting Defaults for the GroupWise Client Options,” on
page 1025.

5 Click OK to save the resource information.

6 Skip to Section 16.1, “Creating Rules for a Resource,” on page 269.
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16.1.1

Managing Resources

The following sections provide information to help you manage the resources in your GroupWise
system:

¢ Section 16.1, “Creating Rules for a Resource,” on page 269

¢ Section 16.2, “Changing a Resource’s Owner,” on page 271

¢ Section 16.3, “Adding a Resource to a Distribution List,” on page 272

¢ Section 16.4, “Moving a Resource,” on page 273

¢ Section 16.5, “Renaming a Resource,” on page 273

¢ Section 16.6, “Deleting a Resource,” on page 274

¢ Section 16.7, “Managing Resource Email Addresses,” on page 274

A resource’s mailbox, just like a user’s mailbox, is a combination of the information stored in its user
database and the message databases located at its post office. Occasionally, you might want to
perform maintenance tasks on the resource’s mailbox to ensure the integrity of the databases. For
details about performing maintenance on a resource’s mailbox, see Chapter 27, “Maintaining User/
Resource and Message Databases,” on page 409.

Creating Rules for a Resource

Schedulable resources such as conference rooms need effective auto-accept/decline rules to help
compensate for times when appointment schedulers fail to use Busy Search.

If you are the resource owner, you can proxy to the resource mailbox in order to set up the rules. If
you are not the resource owner, be sure that the resource owner understands how to set up effective
rules for the resource.

¢ Section 16.1.1, “Creating an Auto-Accept Rule,” on page 269

¢ Section 16.1.2, “Creating an Auto-Decline Rule,” on page 270

Creating an Auto-Accept Rule

Creating an auto-accept rule provides confirmation to the appointment scheduler that the resource as
accepted the appointment.

1 In the GroupWise Windows client, in the resource mailbox, click Tools > Rules, then click New.

2 Type a name for the auto-accept rule.

3 Select Received.

4 Select Appointment.

5 In the Appointment conflict exists drop-down list, select No.
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6

7

8

9

Create an action to accept the appointment:
6a Click Add Action.
6b Click Accept.
6c Select a Show As setting.
6d (Optional) Type a comment to include with the acceptance.
6e Click OK.

Create an action to notify the appointment scheduler that the resource has accepted the
appointment:

7a Click Add Action.

7b Click Reply.

7c Click OK to accept the default of replying only to the appointment scheduler.
7d In the Subject field, indicate that the resource has accepted the appointment.

7e (Optional) In the Message field, provide any additional information that might be helpful to
the appointment scheduler.

7f Click OK.

Test the rule by scheduling an appointment that includes the resource for a time when the
resource is available.

Continue with Creating an Auto-Decline Rule.

Creating an Auto-Decline Rule

Creating an auto-decline rule notifies the appointment scheduler that the resource is not available. By
notifying users in addition to the appointment scheduler, the likelihood of a perceived double-
booking of the resource is minimized.

o 00~ W N P

In the GroupWise Windows client, in the resource mailbox, click Tools > Rules, then click New.
Type a name for the auto-decline rule.
Select Received.
Select Appointment.
In the Appointment conflict exists drop-down list, select Yes.
Create an action to decline the appointment:
6a Click Add Action.
6b Click Delete/Decline.
6¢ (Optional) Type a comment about the resource declining the appointment.
6d Click OK.

Create an action to notify the appointment scheduler that the resource has declined the
appointment:

7a Click Add Action.

7b Click Reply.

7c Click OK to accept the default of replying only to the appointment scheduler.
or

Select Reply to all (sender and recipients) to make sure that everyone involved with the
appointment is notified that the resource has declined the appointment.
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7d In the Subject field, indicate that the resource has declined the appointment.

7e (Optional) In the Message field, provide any additional information that might be helpful to
the appointment scheduler.

7f (Optional) In the CC field or the BC field, include one or more additional users such as the
resource owner to notify when a resource declines an appointment.

7g Click OK.

8 Test the rule by scheduling an appointment that includes the resource for a time when the
resource is not available.

16.2 Changing a Resource’s Owner

You can change a resource’s owner whenever necessary. The owner must be a user assigned to the
same post office as the resource. If you need to give ownership of the resource to a user on a different
post office, you must move the resource to that post office. For details, see Section 16.4, “Moving a
Resource,” on page 273.

The new owner automatically receives proxy rights to the resource’s mailbox. Proxy rights are
removed for the old owner.

Make sure that the new resource owner understands the auto-accept/decline rules that are associated
with the resource.
1 In ConsoleOne, right-click the Resource object, then click Properties.

2 On the Identification page, browse to and select the new owner, then click OK to display the
user’s name in the Owner field.

Properties of Conference Room 2012 El
GroupWise « | General | MODS Rights - | Cther | Rights to Files and Folders I
Identification
Distinguizhed Narme: Conference Room 201 2.Groupiise
Post Crfice: |Pruv01 ‘Dievelopment
Onamer: |askuczylas %
File ID: 417
Descrigtion:
vishity [system =]
Resource Type: |Resuur:e j
Phone: |
Page Options... Ok Cancel Apply Help

3 Click OK to save your changes.
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16.3 Adding a Resource to a Distribution List

Just like users, resources can be added to distribution lists.

1 In ConsoleOne, right-click the Resource object, then click Properties.

2 Click GroupWise > Distribution Lists to display the Distribution Lists page.

Properties of Conference Room 2012 rg|
;GroupWise v General | MNDS Rights - | Cither | Right= to Files and Folders |
 Distribution Lists §
Mermbership | Participation
add | | > |
Page Options... Ok | Cancel | Apply | Help |

3 Click Add, select the distribution list that you want to add the resource to, then click OK.

Properties of Conference Room 2012 El

GroupWise | Gereral | NDS Rigrts + | ciher | Rights to Files and Folders |
Distribution Lists

Metnbership | Participation
ProgrammersgProvol Development To

add | | > |

Page Options... [e]l% | Cancel | Apply | Help |

By default, the resource is added as a primary recipient (To recipient).

4 If you want to change the resource’s recipient type, select the distribution list, click Participation,
then click To, CC, or BC.

5 Click OK to save your changes.
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16.5

Moving a Resource

If necessary, you can move a resource from one post office to another. For example, you might need to
move a resource if you are removing the resource’s post office or if you need to reassign ownership of
the resource to a user on another post office.

The resource retains the same name in the new post office as it has in the current post office. If
another user, resource, or distribution list assigned to the new post office has the same name, you
must rename one of them before you move the resource. For details, see Section 16.5, “Renaming a
Resource,” on page 273.

When you move the resource, all items in its mailbox are moved to the new post office, which means
that all schedules for the resource are kept intact.

To move a resource:

1 In ConsoleOne, right-click the Resource object in the GroupWise View, then click Move to
display the GroupWise Move dialog box.

IMPORTANT: You must select the Resource object in the GroupWise View. If you select the
object in the standard ConsoleOne View, you will move the Resource object from one container
to another, not the resource from one post office to another.

GroupWise Move Conference Room 2012

Maove ta post office:

‘ Cancel | Help |

2 Select the post office to which you want to move the resource, then click OK to display the
Choose New Owner dialog box.

Choose New Owner

Proval Development Conference Room 2012, Please choose
another uger to be the owner for this resource.

Orwvner: | g

‘ Cancel | Help |

3 Select the user who will be the resource’s owner, then click OK to move the resource.

Renaming a Resource

Situations might arise where you need to give a resource a new name. For example, you might need
to move the resource to another post office that already has a user, resource, or distribution list with
the same name.

1 In ConsoleOne, right-click the Resource object in the GroupWise View, then click Rename to
display the Rename dialog box
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16.7

16.7.1

2 In the New Name field, specify the new name for the resource.
3 Make sure the Save Old Name box is not selected.
Saving the old name causes duplicate resources to appear in the Address Book.

4 Click OK to rename the resource.

Deleting a Resource

When you delete a resource, all information is removed for the resource, including any schedules
that have been established for the resource.

1 In ConsoleOne, right-click the Resource object in the GroupWise View, then click Delete.

2 Click Yes to confirm the deletion.

Managing Resource Email Addresses

To ensure that resource addresses meet your needs, GroupWise enables you to determine the format
and visibility of addresses, as well as create additional names for resources. The following sections
provide details:

¢ Section 16.7.1, “Changing a Resource’s Internet Addressing Settings,” on page 274

¢ Section 16.7.2, “Changing a Resource’s Visibility in the Address Book,” on page 275

¢ Section 16.7.3, “Creating a Nickname for a Resource,” on page 276

Changing a Resource’s Internet Addressing Settings

By default, a resource inherits its Internet address settings (preferred Internet address format,
allowed address formats, and Internet domain name) from its post office, domain, or GroupWise
system. If necessary, you can override these settings.

1 In ConsoleOne, right-click the Resource object, then click Properties.

2 Click GroupWise, then click Internet Addressing to display the Internet Addressing page.

Properties of Conference Room 2021 E‘

Genersl | NDS Rights = | Gther | Rights to Files and Folders |
Overtide | Preferred Address Format:

[F]

Preferred EMail 1D

@Internet domain name

Defined at: Prowol

Allowed Address Formats
O

Defined at: Caorporate Mail

Internet domain name:
O

Defined at: Corporate Mail

Far incoming mail, recipients are known exclusively by this Internet domain name
View EMail Addresses
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3 To override one of the settings, select the Override box, then change the setting.

Preferred Address Format: The preferred address format determines how the resource’s
address are displayed in the GroupWise Address Book and in sent messages.

At the resource level, only three preferred address formats are available. The address formats
that include first name, last name, and first initial do not apply to resource, so they are not
available.

You can completely override the address format by explicitly defining the user portion of the
address (user@Internet domain name). The user portion can include any RFC-compliant characters
(no spaces, commas, and so on). The resource name portion must be unique within its Internet
domain. This means that a resource name can be used multiple times in your GroupWise
system, if it is used only once in each Internet domain.

Allowed Address Formats: The allowed address formats determine which address formats can
be used to send messages to the resource.

Only the UserID.Post Office@Internet domain name and UserID@Internet domain name formats are
valid for resources. The formats that include first name, last name, and first initial are not valid.

For example, assume that you use R1 as the resource ID, Research as the post office, and
novell.com as the Internet domain. If you select the two valid formats, the resource receives
messages sent using either of the following addresses:

rl.research@novell.com
rl@novell.com

Internet Domain Name: The Internet domain name, along with the preferred address format, is
used when constructing the email address that is displayed in the GroupWise Address Book and
in the To field of sent messages.

Only the Internet domain names that have been defined are displayed in the list. Internet
domain names must be defined at the system level (Tools > GroupWise System Operations > Internet
Addressing). For more information, see Section 52, “Configuring Internet Addressing,” on

page 743.

If you override the Internet domain name, the For Incoming Mail, Recipients are Known Exclusively
by This Internet Domain Name option becomes available. Enable this option if you only want the
resource to be able to receive messages addressed with this Internet domain name. If you don’t
enable this option, the resource receives messages addressed using any of the Internet domain
names assigned to your GroupWise system.

View E-Mail Addresses: Click View E-Mail Addresses to display a list of the various email
address formats that can successfully deliver email to this resource, including any nicknames or
gateway aliases that have been defined for this resource. For more information, see:

¢ Section 52.1.4, “Preferred Address Format,” on page 744 and Section 52.1.5, “Allowed
Address Formats,” on page 747

¢ Section 14.7.4, “Creating a Nickname for a User,” on page 252

¢ Section 52.3, “Transitioning from SMTP Gateway Aliases to Internet Addressing,” on
page 754

4 Click OK to save your changes.

Changing a Resource’s Visibility in the Address Book

A resource’s visibility level determines which users see the resource in their Address Books. You can
control the availability of a resource by displaying it in the Address Books of all users in your
GroupWise system, in the Address Books of those users in the resource’s domain only, in the Address
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Books of those users on the resource’s post office only, or in no Address Books. Even if the resource is
not displayed in their Address Books, users can schedule the resource if they know the resource’s
name.

To change a resource’s visibility:

1 In ConsoleOne, right-click the Resource object, then click Properties.

Properties of Conference Room 2021 E‘
eneral I MDS Rights + I Cther I Rights to Files and Folders I
Distinguished Mame: Conference Room 2021, GroupWise
Post Office; Provol.Development
Owner: gsmith
File ID: [
Description:
Wisibility: System M
Resource Type: Resource b
Phane!
E-Mail Address: Conference Room 20Z21@Corporate.net @
‘Wiew Client Cptions

2 In the Visibility field, select the desired visibility level.
System: The resource is displayed in the Address Books of all users in your GroupWise system.
Domain: The resource is displayed in the Address Books of all users in the resource’s domain.

Post Office: The resource is displayed in the Address Books of all users on the resource’s post
office.

None: The resource is not displayed in any Address Books. Users need to know the resource’s
name to schedule it.

3 Click OK to save your changes.

16.7.3  Creating a Nickname for a Resource

Each resource has a specific GroupWise address consisting of the resource’s name, post office, and
domain (resource_name.post_office.domain). You can assign one or more nicknames to a resource to
give it an additional address. Each part of the address (resource_name, post_office, and domain) can be
different than the resource’s actual address.

Nicknames are useful in the following situations:

+ You rename a resource, as described in Section 16.5, “Renaming a Resource,” on page 273. You
can create a nickname that retains the old resource name, so that messages with the old resource
name in the email address are routed to the new email address.
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* You move a resource, as described in Section 16.4, “Moving a Resource,” on page 273. You can
create a nickname that retains the old post office location. As messages to the moved resource
arrive in your GroupWise system, the email address is routed to the new post office location. .

¢ You need to restrict a resource’s visibility in the GroupWise Address Book, as described in

Section 6.2, “Controlling Object Visibility,” on page 110, and at the same time, you need to make
the resource visible in one or more specific Address Books outside of the restricted visibility. You
can create a nickname that provides the specific visibility that is ruled out by the required

restriction.

In ConsoleOne, you can list all the nicknames in your GroupWise system in the GroupWise View. In

the GroupWise client, you can display resource nicknames in the GroupWise Address Book if you
enable Filter for Resources. When addressing a message, users need to know a nickname in order to

use it.

To create a nickname for a resource:

1 In ConsoleOne, right-click the Resource object, then click Properties.

2 Click GroupWise > Nicknames to display the Nicknames page.

Properties of Conference Room 2012 El

GroupWwise « | Genersl | MNDS Rights: vl Cther | Rights to Files and Folders I
i Micknames
Ohject 1D | Domain ‘ Post Office
sdd | | |
Page Options | Cancel | | Help |

3 Click Add to display the Create Nickname dialog box.

Create Nickname &l

Cresting nickname for Conference Rootn 201 2.Groupiise

Damain PO: | E

Ohject ID [

Wisibilty: [system |

Given Mame: |

Last Name: |

Expiration Date: ™ Enakle

Cancel Help

4 Fill in the following fields:

Domain.PO: Select the post office that you want to own the nickname. This can be any post

office in your GroupWise system; it does not need to be the resource’s post office.
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Object ID: Specify the name to use as the resource_name portion of the nickname. The nickname
must be unique.

Visibility: Select the Address Book visibility for the nickname. This determines where the

nickname is available (system, domain, or post office). However, nicknames are not displayed in
the Address Book unless you filter for them. In order to address a message to a nickname, a user
must specify the nickname address, and the nickname must be available in the user’s post office.

External Sync Override: This option applies only if your GroupWise system links to and
synchronizes with an external GroupWise system, as described in “Connecting to Other
GroupWise Systems” in the GroupWise 2012 Multi-System Administration Guide.

¢ Synchronize According to Visibility: The nickname is synchronized to external
GroupWise systems only if Address Book visibility is set to System.

¢ Synchronize Regardless of Visibility: The nickname is synchronized to external
GroupWise systems regardless of Address Book visibility.

¢ Don’t Synchronize Regardless of Visibility The nickname is never synchronized to
external systems.

Given Name: This field is not used for resource nicknames.
Last Name: This field is not used for resource nicknames.

Expiration Date: If you want the nickname to no longer work after a certain date, click Enable
and then select the desired date.

5 Click OK to add the nickname to the list.
6 Click OK to save the changes to the Resource object.
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V Distribution Lists, Groups, and
Organizational Roles

*

Chapter 17, “Understanding Distribution Lists, Groups, and Organizational Roles,” on page 281

*

Chapter 18, “Creating and Managing Distribution Lists,” on page 285

*

Chapter 19, “Using eDirectory Groups as GroupWise Distribution Lists,” on page 301

*

Chapter 20, “Using eDirectory Organizational Roles as GroupWise Distribution Lists,” on
page 307
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17.1

17.2

Understanding Distribution Lists,
Groups, and Organizational Roles

Distribution lists are specific to GroupWise. Groups and organizational roles are eDirectory objects
that can be configured to work with GroupWise.

Distribution lists, groups, and organizational roles are all sets of users and (optionally) resources that
can be addressed as a single entity. When a GroupWise user addresses an item (message,
appointment, task, or note) to a distribution list, group, or organizational role, each user or resource
that is a member receives the item if he or she has a GroupWise account.

The following sections provide information to help you learn about distribution lists, groups, and
organizational roles:

¢ Section 17.1, “Public vs. Personal Address Lists,” on page 281

¢ Section 17.2, “Distribution Lists,” on page 281

¢ Section 17.3, “eDirectory Groups and Organizational Roles,” on page 282

Public vs. Personal Address Lists

Distribution lists and groups are public address lists, meaning that they are administrator-defined
lists available to all users in your GroupWise system.

If users want to create personal address lists, they can create personal groups in the GroupWise
client. When a user creates personal groups, the groups are saved in his or her mailbox and are
available for use only by that user. They cannot be shared by, or transferred to, other users.

If a user wants to send to all users in a particular post office or domain, he or she can use wildcard
addressing, if it has been enabled. See Section 6.7, “Enabling Wildcard Addressing,” on page 114.

Distribution Lists

A distribution list is specific to GroupWise. It is a public address list that you, as the GroupWise
administrator, can create to facilitate easier addressing within your GroupWise system. Distribution
lists can only contain users that have GroupWise accounts.

Each distribution list you want to create must be added as a Distribution List object in eDirectory. The
name that you give the Distribution List object becomes the name by which the distribution list is
displayed in the GroupWise Address Book.

Distribution List objects can be located in any eDirectory container that is in the same tree as the
distribution list's domain.
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Because a distribution list is an addressable entity, you must assign it to a post office when you create
it. This ensures that the distribution list has a standard GroupWise address
(distribution_list_name.post_office.domain).

Regardless of the distribution list’s post office, all GroupWise users can use the distribution list when
addressing a message.

You can determine which users see the distribution list in the Address Book. System visibility enables
all users in your GroupWise system to see the distribution list. Domain visibility enables all users in
the distribution list's domain to see the distribution list. Post Office visibility enables all users in the

distribution list’s post office to see the distribution list. Setting the visibility level to None means that
no users see the distribution list in the Address Book.

Users who cannot see the distribution list in the Address Book can still use the distribution list by
typing the distribution list name in the To field of the message.

A distribution list can contain users and resources as well as other distribution lists, groups, and
organizational roles. Members do not need to be on the same post office as the distribution list’s post
office.

For details about distribution lists, see Chapter 18, “Creating and Managing Distribution Lists,” on
page 285.

eDirectory Groups and Organizational Roles

eDirectory groups and organizational roles are general eDirectory objects that can be created to
facilitate easier administration of eDirectory users who have common needs or who share a common
role or responsibility.

If you have eDirectory groups or organizational roles that you want GroupWise users to be able to
address messages to, you need to make them available in your GroupWise system. When doing so,
you can choose the groups and roles that you want available, and choose which users they are
available to.

If a group or role contains both eDirectory users with GroupWise accounts and eDirectory users
without GroupWise accounts, only those users with GroupWise accounts receive messages
addressed to the group or role.

As mentioned previously, Group and Organizational Role objects are not specific to GroupWise. For
information about creating these objects, see your eDirectory documentation.

The name given to the Group object or Organizational Role object becomes the name by which it is
displayed in the GroupWise Address Book when you make it available. You make a group or role
available in your GroupWise system by assigning it to a post office. This ensures that the group or
role has a standard GroupWise address (name.post_office.domain). Regardless of the post office where
the group or role is assigned, all GroupWise users can use it when addressing a message.

You can determine which users see the group or role in the Address Book. System visibility enables
all users in your GroupWise system to see the group or role. Domain visibility enables all users in the
distribution list's domain to see the group or role. Post Office visibility enables all users in the
distribution list’s post office to see the group or role. Setting the visibility level to None means that no
users can see the group or role in the Address Book.

Users who cannot see the group or role in the Address Book can still use it by typing the name in the
To field of the message.
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For details about eDirectory groups and organizational roles, see Chapter 19, “Using eDirectory
Groups as GroupWise Distribution Lists,” on page 301 and Chapter 20, “Using eDirectory
Organizational Roles as GroupWise Distribution Lists,” on page 307.
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Creating and Managing Distribution
Lists

A GroupWise distribution list can contain GroupWise users, resources, and other distribution lists.
When creating the distribution list, you can determine each entry’s participation in the list (primary
recipient, carbon copy recipient, or blind copy recipient). Distribution lists are created in the
GroupWise Address Book. When a GroupWise user addresses an item (message, appointment, task,
or note) to a distribution list, group, or organizational role, each user or resource that is a member
receives the item if he or she has a GroupWise account.

¢ Section 18.1, “Creating a New Distribution List,” on page 285

¢ Section 18.2, “Adding Members to a Distribution List,” on page 289

¢ Section 18.3, “Removing Members from a Distribution List,” on page 290

¢ Section 18.4, “Moving a Distribution List,” on page 290

¢ Section 18.5, “Renaming a Distribution List,” on page 291

¢ Section 18.6, “Enabling Users to Modify a Distribution List,” on page 291

¢ Section 18.7, “Controlling Access to a Distribution List,” on page 293

¢ Section 18.8, “Deleting a Distribution List,” on page 294

¢ Section 18.9, “Managing Email Addresses,” on page 294

¢ Section 18.10, “Adding External Users to a Distribution List,” on page 299

18.1 Creating a New Distribution List

1 In ConsoleOne, right-click the eDirectory container where you want to create the Distribution
List object, then click New > Distribution List.

Create GroupWise Distribution List

Distribution List Narne: I:I
I

Groupitise Post Office: Cancel
‘ ﬂ Help

[ Define addtional propertiss

I™ Creste another distribution list

2 Fill in the following fields:

Distribution List Name: Specify a descriptive name. Because the name is used as part of the
distribution list's GroupWise email address, do not use any of the following invalid characters in
the distribution list name:

ASCI| characters 0-31 Comma,,

Asterisk * Double quote "
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At sign @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()
Braces { } Period .
Colon : Slash /

IMPORTANT: Characters that are valid and even desirable in a distribution list name, such as
accented characters, might not be valid in an email address. For some distribution lists you
might need to set up a preferred email ID in order to ensure that they have a valid email address.
For instructions, see Section 18.9.1, “Changing a Distribution List’s Internet Addressing
Settings,” on page 295.

GroupWise Post Office: Select the post office the distribution list will be assigned to. The
distribution list can contain members of other post offices.

3 Select Define Additional Properties, then click OK.

Groupwicge - :| NDS Rights ~ | Cther | Rights to Files and Folders |

 Iekerdification
Distinguished Mame: Salesmen. GroupWise
Post Office: Provo2.Sales
Description:
Wisibility: Pzt Office e
Replication Override: Replicate according to visibility »
E-Mail Address: %

4 On the Identification page, fill in the following fields:

Description: Specify a description to help you identify the purpose or members of the
distribution list.

Visibility: Select the level at which the distribution list will be visible in the Address Book.
System enables the distribution list to be visible to all users in your GroupWise system. Domain
enables the distribution list to be visible to all users in the same domain as the distribution list.
Post Office enables the distribution list to be visible to all users on the same post office as the
distribution list. Setting the visibility level to None means that no users can see the distribution
list in the Address Book.

Replication Override: By default, distribution lists are replicated throughout your GroupWise
system based on the selected visibility level. With the default visibility level, distribution lists are
visible in the GroupWise Address Book for local post office users only and are not replicated to
other post offices.
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If you set Visibility to Domain, the distribution list is replicated to all post offices in the domain,
but not to post offices belonging to other domains. If you set Visibility to System, the distribution
list is replicated to all post offices in your GroupWise system. This default behavior corresponds
to the Replicate According to Visibility setting.

Select Replicate Everywhere Regardless of Visibility if you want the distribution list replicated
throughout your GroupWise system regardless of the selected visibility level. With this setting,
the distribution list is made available in all post offices, although it is still only visible in the
GroupWise Address Book according to the selected visibility level. The availability of the
distribution list in all post offices means that it can be nested into other distribution lists that are
visible in any post office, and that users in any post office can manually specify the distribution
list name in the To field of an item.

E-Mail Address: Displays the default email address for the distribution list. Click the drop-
down list to specify a custom email address. For example, if you created a distribution list with
spaces in its name, you need to remove the spaces to create a valid email address.

5 Click GroupWise > Membership to display the Membership page.

Properties of Programmers: gl
GroupWise v | NDS Rights v | Gther | Rights to Files and Folders |
Metnbership
Membership:
Mernbers | Participation | First Mame Lazt Matne

Add |

Page Options... Ok | Cancel | Apply Help
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6 Click Add, select the user, resource, distribution list, eDirectory group, or organizational role you
want to add as a member, then click OK to add the member to the list.

Properties of Programmers: f‘57|

GroupWise ~ | NDS Rights ~ | Gther | Rights to Files and Folders |
Metnbership

Membership:

Members | Participation | First Mame Last Mame
askoczylas Development Provol To Alfons Skoczylas

add | | > |

Page Options... [e]l% | Cancel | Apply | Help |

By default, the member is added as a primary recipient (To: recipient).

7 If you want to change the member’s recipient type, select the member, click Participation, then
click To, CC, or BC.

8 Repeat Step 6 and Step 7 to add additional members.
9 Click OK to save your changes.
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18.2 Adding Members to a Distribution List

Distribution lists can contain users, resources, groups, organizational roles, and other distribution
lists.

1 In ConsoleOne, right-click the Distribution List object, then click Properties.
2 Click GroupWise > Membership to display the Membership page.

Properties of Programmers: gl
GroupWise v | NDS Rights v | Gther | Rights to Files and Folders |
Metnbership
Membership:
Mernbers | Participation | First Mame Lazt Matne

Add |

Page Options... [e]l% | Cancel | Apply | Help |

3 Click Add, select the user, resource, distribution list, group, or organizational role you want to
add as a member, then click OK to add the member to the list.

If you want to add an external user that is not listed for selection, see Section 18.10, “Adding
External Users to a Distribution List,” on page 299.

Properties of Programmers r'5_<|

Groupwige « | NDS Rights - | Cther I Rights to Files and Folders |
Metmbership

Metmbership:

Mernbers | Participation | First Mame Last Marne

askoczylas Development Provol To Alfons Skoczylas

add | | > |

Page Options Ok | Cancel | Apply | Help |

By default, the selected member is added as a primary recipient (To: recipient).
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18.4

4 If you want to change the member’s recipient type, select the member, click Participation, then
click To, CC, or BC.

5 Repeat Step 3 and Step 4 to add additional members.
6 Click OK to save your changes.
Distribution lists are typically managed by an administrator in ConsoleOne. Starting in GroupWise 7,

users can be granted rights to modify distribution lists, as described in Section 18.6, “Enabling Users
to Modify a Distribution List,” on page 291.

In addition, GroupWise client users can create shared address books and then create groups within
those shared address books so that the groups are available to all users with whom the address book
has been shared. The creator of the shared address book can give other users read only rights, or can
choose to grant them additional rights for adding, editing, and deleting information. For more
information about shared address books, see “Sharing an Address Book with Another User” in
“Contacts and Address Books” in the GroupWise 2012 Windows Client User Guide.

Removing Members from a Distribution List

When you remove users’ or resources’ GroupWise accounts, delete groups, delete organizational
roles, or delete distribution lists, they are automatically removed from any distribution lists in which
they have membership.

To manually remove members from a distribution list:

1 In ConsoleOne, right-click the Distribution List object, then click Properties.
2 Click GroupWise > Membership to display the Membership page.

3 Select the member you want to remove from the list, then click Delete.

Moving a Distribution List

If necessary, you can move a distribution list from one post office to another. For example, you might
need to move a distribution list from a post office you are removing.

The distribution list retains the same name on the new post office as it has on the current post office.
If another user, resource, or distribution list assigned to the new post office has the same name, you
must rename one of them before you move the distribution list. For details, see Section 18.5,
“Renaming a Distribution List,” on page 291.

To move a distribution list:

1 In ConsoleOne, right-click the Distribution List object in the GroupWise View, then click Move to
display the GroupWise Move dialog box.
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IMPORTANT: You must select the Distribution List object in the GroupWise View. If you select
the object in the standard Console View, you will move the Distribution List object from one
container to another, not the distribution list from one post office to another.

GroupWise Move Programmers

Mave ta post otfice:

‘ Cancel | Help |

2 Select the post office to which you want to move the distribution list, then click OK to move the
distribution list.

18.5 Renaming a Distribution List

Situations might arise where you need to give a distribution list a new name. For example, you might
need to move the distribution list to another post office that already has a user, resource, or
distribution list with the same name.

To rename a distribution list:

1 In ConsoleOne, right-click the Distribution List object in the GroupWise View, then click Rename
to display the Rename dialog box.

ey name: |

— Cancel
I~ Save old name
Help

2 In the New Name field, specify the new name for the distribution list.

3 Make sure the Save Old Name box is not selected. Saving the old name causes duplicate
distribution lists to appear in the Address Book.

4 Click OK to rename the distribution list.

18.6  Enabling Users to Modify a Distribution List

In ConsoleOne, you can grant rights to users to modify distribution lists from the GroupWise
Windows client. However, users cannot create or delete distribution lists; that can be done only in
ConsoleOne by an administrator.

To grant edit rights to a specific distribution list to one or more users:

1 Browse to and right-click a Distribution List object, then click Properties.
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2 Click GroupWise > Administration.

Properties of Programmers: fql

{GroupWiise + | NDS Rigrts = | Giher | Rights to Files and Folders |

Ohject ID [ Past Office [ Dormain \

Achd
Page Options... | Cancel | | Help |

3 Click Add, then select one or more users who can edit the distribution list.
4 Click OK to grant the edit rights.
5 Notify the users that they have rights to modify the distribution list.

To give a specific user rights to edit one or more distribution lists:

1 Browse to and right-click a User object, then click Properties.
2 Click GroupWise > Distribution List Administration.

Properties of mbarnard rz‘
Security v| Login Methods vl Gengtal » P Restrictions v| Metberships v| Secur( EE
i Distribution List Administration :
Ohject I0 ‘ Post Office | Dotnain |
Add
Page Options: | Cancel | ‘ Help |

3 Click Add, then select one or more distribution lists for the user to edit.
4 Click OK to grant the edit rights.
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5 Notify the user that he or she has rights to modify the distribution lists.
In the GroupWise client, the editable distribution list does not appear any different to the user
who has rights to edit it, except that Add and Remove are active for that user.

In Online mode, the user can edit the distribution list in the GroupWise Address Book. In Caching
mode, the user cannot edit the distribution list in the GroupWise Address Book. However, the user
can edit the distribution list in the Address Selector in a new message.

Controlling Access to a Distribution List

By default, all GroupWise users can send to all distribution lists that appear in the GroupWise
Address Book. If necessary, you can restrict which users are allowed to send to a specific distribution
list. The restricted distribution list still appears in the GroupWise Address Book, but if unauthorized
users try to send to the restricted distribution list, they receive an error indicating that they do not
have the rights to use the restricted distribution list.

To restrict access to a distribution list:
1 Browse to and right-click a Distribution List object, then click Properties.

2 Click GroupWise > Access Control.

Properties of DistList El

GroupWise v | NDS Rights = | Other | Rights to Files and Folders |
Access Control

Object ID Post Office Domain

3 Click Add, select one or more users who are allowed to send to the restricted distribution list,
then click OK to add the users to the Access Control list.

4 (Optional) Click Add, select Distribution Lists, select one or more distribution lists that are
allowed to send to the restricted distribution list, then click OK to add the distribution lists to the
Access Control list.

5 Click OK to grant the rights to the listed users and distribution lists for sending to the restricted
distribution list.

6 Notify the users that they have rights to send to the restricted distribution list.
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18.9

In addition to the users that you add to the Access Control list, users to whom you have granted edit
rights, as described in Section 18.6, “Enabling Users to Modify a Distribution List,” on page 291, can
also send to the restricted distribution list, even if you do not explicitly add them to the Access
Control list.

NOTE: This functionality was introduced in GroupWise 8 Support Pack 2. If you still run GroupWise
8 clients in your GroupWise 2012 system, you must update all GroupWise 8 clients to Support Pack 2
or later in order for this feature to function for GroupWise 8 client users.

Deleting a Distribution List

To delete a single distribution list:

1 In ConsoleOne, right-click the Distribution List object, then click Delete.

2 Click Yes to confirm the deletion.
To delete multiple distribution lists that belong to the same post office:

1 In ConsoleOne, right-click the Post Office object, then click Properties.
2 Click GroupWise > Distribution Lists.
3 Select one or more distribution lists, then click Delete.

4 Click OK to complete the deletion.

Managing Email Addresses

To ensure that distribution list addresses meet your needs, GroupWise enables you to determine the
format and visibility of addresses, as well as create additional names for distribution lists. The
following sections provide details:

¢ Section 18.9.1, “Changing a Distribution List’s Internet Addressing Settings,” on page 295

¢ Section 18.9.2, “Changing a Distribution List’s Visibility in the Address Book,” on page 296

¢ Section 18.9.3, “Creating a Nickname for a Distribution List,” on page 297
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Changing a Distribution List’s Internet Addressing Settings

By default, a distribution list inherits its Internet address settings (preferred Internet address format,
allowed address formats, and Internet domain name) from its post office, domain, or GroupWise
system. If necessary, you can override these settings for a distribution list.

1 In ConsoleOne, right-click the Distribution List object, then click Properties.
2 Click GroupWise, then click Internet Addressing to display the Internet Addressing page.

Properties of Salesmen @‘

: NDS Fights = | ther | Fights to Files and Folders |

; Group!
Aeme ceiee |

Override | Preferred Address Format:

O
Preferred EMail 1D:
@Internet domain name
Defined at: Caorporate Mail

Allowed Address Formats
UserID. Post Office@Internet domain name

UserID@Internet domain narne
[[] Last Mame. First Name@Internet domain name
["] First rame.Last Name@Internet domain name

[ First Initial Last Hame@Internet domain name

Inkernet domain name:

O
Defined at: Corporate Mail
For incoming mail, recipients are known exclusively by this Internet domain name
View EMail Addresses

3 To override one of the settings, select the Override box, then change the setting.

Preferred Address Format: The preferred address format determines how the distribution list’s
address is displayed in the GroupWise Address Book and in sent messages.

At the distribution list level, only three preferred address formats are available. The address
formats that include first name, last name, and first initial do not apply to distribution lists, so
they are not available.

You can completely override the address format by explicitly defining the user portion of the
address (user@Internet domain name). The user portion can include any RFC-compliant characters
(no spaces, commas, and so on). The distribution list name portion must be unique within its
Internet domain. This means that a distribution list name can be used multiple times in your
GroupWise system, provided it is used only once in each Internet domain.

Allowed Address Formats: The allowed address formats determine which address formats can
be used to send messages to the distribution list.

Only the UserID.Post Office@Internet domain name and UserID@Internet domain name formats are
valid for distribution lists. The formats that include first name, last name, and first initial are not
valid.

For example, assume that you use DL1 as the distribution list ID, Research as the post office, and
novell.com as the Internet domain. If you select the two valid formats, members of the
distribution list receive messages sent using either of the following addresses:

dll.research@novell.com
dll@novell.com
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Internet Domain Name: The Internet domain name, along with the preferred address format, is
used when constructing the email address that is displayed in the GroupWise Address Book and
in the To field of sent messages.

Only the Internet domain names that have been defined are displayed in the list. Internet
domain names must be defined at the system level (Tools > GroupWise System Operations > Internet
Addressing). For more information, see Section 52, “Configuring Internet Addressing,” on

page 743.

If you override the Internet domain name, the For Incoming Mail, Recipients are Known Exclusively
by This Internet Domain Name option becomes available. Enable this option if you only want the
distribution list to be able to receive messages addressed with this Internet domain name. If you
don’t enable this option, the distribution list receive messages addressed using any of the
Internet domain names assigned to your GroupWise system.

View E-Mail Addresses: Click View E-Mail Addresses at the bottom of the Internet Addressing
page to display a list of the various email address formats that can successfully deliver email to
this distribution list, including any nicknames or gateway aliases that have been defined for this
distribution list. For more information, see:

¢ Section 52.1.4, “Preferred Address Format,” on page 744 and Section 52.1.5, “Allowed
Address Formats,” on page 747

¢ Section 14.7.4, “Creating a Nickname for a User,” on page 252

¢ Section 52.3, “Transitioning from SMTP Gateway Aliases to Internet Addressing,” on
page 754

4 Click OK to save your changes.

18.9.2  Changing a Distribution List’s Visibility in the Address Book

A distribution list’s visibility level determines which users see the distribution list in the Address
Books. You can control the availability of a distribution list by displaying it in the Address Book for
all users in your GroupWise system, in the Address Book for those users in the distribution list’s
domain only, in the Address Book for those users on the distribution list’s post office only, or not
displaying it at all.

1 In ConsoleOne, right-click the Distribution List object, then click Properties.

Properties of Salesmen E‘
{GroupWise ~ | NDS Rights = | Cther | Rights to Files and Folders |

Distinguished Mame: Salesmen, Grouphise
Post Office: ProvoZ.5ales
Description:
Visibility: Post Office v
Replication Override: Replicate according o visibility N
E-Mail Address: @
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2 In the Visibility field, select the desired visibility level.

System: The distribution list is displayed in the Address Book for all users in your GroupWise
system.

Domain: The distribution list is displayed in the Address Book for all users in the distribution
list’s domain.

Post Office: The distribution list is displayed in the Address Book for all users on the
distribution list’s post office.

None: The distribution list not displayed in the Address Book.
3 Click OK to save your changes.

18.9.3  Creating a Nickname for a Distribution List

Each distribution list has a specific GroupWise address consisting of the distribution list's name, post
office, and domain (distribution_list_name.post_office.domain). You can assign one or more nicknames
to a distribution list to give it an additional address. Each part of the address (distribution_list_name,
post_office, and domain) can be different than the distribution list’s actual address.

Nicknames are useful in the following situations:

¢ You rename a distribution list, as described in Section 18.5, “Renaming a Distribution List,” on
page 291. You can create a nickname that retains the old distribution list name, so that messages
with the old distribution list name in the email address are routed to the new email address.

¢ You move a distribution list, as described in Section 18.4, “Moving a Distribution List,” on
page 290. You can create a nickname that retains the old post office location. As messages to the
moved distribution list arrive in your GroupWise system, the email address is routed to the new
post office location.

* You need to restrict a distribution list’s visibility in the GroupWise Address Book, as described in
Section 6.2, “Controlling Object Visibility,” on page 110, and at the same time, you need to make
the distribution list visible in one or more specific Address Books outside of the restricted
visibility. You can create a nickname that provides the specific visibility that is ruled out by the
required restriction.

In ConsoleOne, you can list all the nicknames in your GroupWise system in the GroupWise View. In
the GroupWise client, you can display resource nicknames in the GroupWise Address Book if you
enable Filter for Resources. When addressing a message, users need to know a nickname in order to
use it.

To create a nickname for a distribution list:

1 In ConsoleOne, right-click the Distribution List object, then click Properties.
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2 Click GroupWise > Nicknames to display the Nicknames page.

Properties of Programmers: PZ|
~)| DS Rights = | Other | Rights to Files and Folders |
Ohject 1D | Dormain ‘ Post Office |
i | | |
Page Options... | Cancel | | Help |

3 Click Add to display the Create Nickname dialog box.

Create Nickname El

Creating nickname for Programmers Groupiise

Doormein PO | E

Ohject I: |

“igihility: |Svs‘tem j

Given MName: |

Last Mame: |

Expiration Date: [~ Enskle |

Cancel Help

4 Fill in the following fields:

Domain.PO: Select the post office that you want to own the nickname. This can be any post
office in your GroupWise system; it does not need to be the distribution list’s post office.

Object ID: Specify the name to use as the distribution_list_name portion of the nickname. The
name must be unique.

Visibility: Select the Address Book visibility for the nickname. This determines where the

nickname is available (system, domain, or post office). However, nicknames are not displayed in
the Address Book unless you filter for them. In order to address a message to a nickname, a user
must specify the nickname address, and the nickname must be available in the user’s post office.

External Sync Override: This option applies only if your GroupWise system links to and
synchronizes with an external system, as described in “Connecting to Other GroupWise
Systems” in the GroupWise 2012 Multi-System Administration Guide.

¢ Synchronize According to Visibility: The nickname information is synchronized to
external systems only if visibility is set to System.

¢ Synchronize Regardless of Visibility: The nickname information is synchronized to
external systems regardless of the object visibility.
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¢ Don’t Synchronize Regardless of Visibility The nickname information is not
synchronized to external systems.

Given Name: This field is not used for distribution list nicknames.
Last Name: This field is not used for distribution list nicknames.

Expiration Date: If you want the nickname to no longer work after a certain date, click Enable
and then select the desired date.

5 Click OK to add the nickname to the list.
6 Click OK to save the changes to the Distribution List object.

18.10 Adding External Users to a Distribution List

Members of distribution lists must have corresponding eDirectory objects. If you want to add users to
a distribution list, and the users do not belong to your GroupWise system, you must create objects to
represent these external users within your GroupWise system.

¢ Section 18.10.1, “Creating an External Domain,” on page 299
¢ Section 18.10.2, “Creating an External Post Office,” on page 299
¢ Section 18.10.3, “Creating an External User,” on page 299

For more information, see Section 6.8, “Adding External Users to the GroupWise Address Book,” on
page 116.

18.10.1 Creating an External Domain

You create an external domain to represent the world outside your GroupWise system.

1 In ConsoleOne, right-click GroupWise System, then click New > External Domain.

2 Provide a unique name for the domain, then click OK.

18.10.2 Creating an External Post Office

You create an external post office in the external domain to hold External User objects.

1 In ConsoleOne, right-click the External Domain object, then click New > External Post Offfice.

2 Provide a unique name for the post office, then click OK.

18.10.3  Creating an External User

You create an external user so that it can be selected when adding members to a distribution list.

In ConsoleOne, right-click the External Post Office object, then click New > External User.
Provide a unique name for the user, then click OK.

Right-click the new External User object, then click Properties.

On the Identification page, fill in at least the first and last names.

Click GroupWise > Internet Addressing.

Select Override.

~N o oA WN P

Select the preferred addressing format depending on how you want email to this user to be
addressed.
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or
Provide a preferred email ID.
8 Click OK to save the user information.

9 Follow the instructions in Section 18.2, “Adding Members to a Distribution List,” on page 289 to
add the external user to a distribution list.
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Using eDirectory Groups as GroupWise
Distribution Lists

Novell eDirectory groups can be configured to function as GroupWise distribution lists.

¢ Section 19.1, “Setting Up an eDirectory Group for Use in GroupWise,” on page 301

¢ Section 19.2, “Seeing Which Members of an eDirectory Group Have GroupWise Accounts,” on
page 303

¢ Section 19.3, “Changing a Group’s Visibility in the Address Book,” on page 304
¢ Section 19.4, “Moving a Group,” on page 304
¢ Section 19.5, “Renaming a Group,” on page 305

¢ Section 19.6, “Removing a Group from GroupWise,” on page 305

19.1 Setting Up an eDirectory Group for Use in GroupWise

By default, eDirectory groups are not automatically available for use as distribution lists in
GroupWise. To make an eDirectory group available as a GroupWise distribution list, you need to
assign it to a GroupWise post office.

1 In ConsoleOne, right-click the eDirectory Group object, then click Properties.

Group objects and Distribution List objects have similar icons in ConsoleOne.

Icon Object

@ eDirectory Group object

m GroupWise Distribution List object
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2 Click GroupWise > Account to display the Account page.

Properties of Help Desk E\
Genersl v | Members | Security Equal To Me |{ GroupWise §| NDS Rights + | Cther | Rights to Files and Folders |
ihcoount
Post Office: ]
Wisibility: Post Office b

3 Fill in the following fields:

Post Office: Select the post office where you want to assign the group. You can choose any post
office you want. If you plan to limit visibility of the group to users on a specific post office or in a
specific domain, you should select that post office or a post office in the desired domain.

Visibility: Select the level at which the group is visible in the Address Book. System enables the
group to be visible to all users in your GroupWise system. Domain enables the group to be
visible to all users in the same domain as the group. Post Office enables the group to be visible to
all users on the same post office as the group. Setting the visibility to None means that the group
is not visible at any level. However, even if the group is not displayed in a user’s Address Book,
he or she can use the group by typing the group’s name in a message’s To field.

4 Click OK to save the changes.

The group is now treated like a GroupWise distribution list and is visible in the GroupWise View
when you filter on distribution lists. However, its icon does not change.

When GroupWise users send messages to the group, only those group members who have
GroupWise accounts receive messages.

For information about using dynamic groups with GroupWise, see TID 3074853 in the Novell
Support Knowledgebase (http://www.novell.com/support).
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19.2

Seeing Which Members of an eDirectory Group Have

GroupWise Accounts

eDirectory groups can include members who have GroupWise accounts and members who do not

have GroupWise accounts. When the group is used to address a message, only those members who
have GroupWise accounts receive the message.

To see which members have GroupWise accounts and which ones do not:

1 In ConsoleOne, select the Group object, then click Tools > GroupWise Diagnostics > Display Object.

GroupWise Diagnostics El

Groupiize infortnation for selected abject

b
Fatnily

Description

alue

MG Yisibility
macifiersMame
GLID

Role Occupant

MG GroupiMise 1D

e

Last Mocdified At Proval
Lazt hocified By (CORP_TREE) adtmin.Docdey Movel
Uniliztec a
Distrilation List Type Rolz
Hemizphere 1
GUID T1C31030-166F -0000-BA0D-5CO0E0000E00
Mermber To Provod Development.mpalu
Damain katne Prowol =
| 2ot hecditioabion Thuwasdau lamees A8 00T L9042 ikl ST 0700
<T | »
~w
eDirectory infarmation for selected object
Descriptian Walug
Equivalent To Me gslater Users Docdey Nowvell -

Zlucas Users Docdey Movell

mpalu.Users Docoey Nowvell

1

CM=admin,OU=Docdey O=Movell

S0FCOOYENSESDS116ED1 D0C04F4TEERC

gslster Users Docdey Nowvell

Zlucas Users Docdey Movell

mpalu.Users Docoey Nowvell

Provol Development Help Desk{110}3C0SEBE0-0928-0000-E7 45-7B0065007 500 =
»

FRi—avmin O I=Maedans =Rl |

OK

The Member To field in the top window displays the members who have GroupWise accounts.

The Role Occupant field in the bottom window displays all members.

2 When you have finished viewing the information, click OK.
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19.3

19.4

Changing a Group’s Visibility in the Address Book

An eDirectory group’s visibility level determines which users see the group in the Address Books.
You can control the availability of a group by displaying it in the Address Book for all users in your
GroupWise system, in the Address Book for those users in the group’s domain only, in the Address
Book for those users on the group’s post office only, or not displaying it at all.

1 In ConsoleOne, right-click the Group object, then click Properties.
2 Click GroupWise > Account to display the Account page:

Properties of Help Desk E‘

Genersl v | Members | Security Equal To Me | hDS Rights ~ | Cther | Rights to Files and Folders |

Post Office: L]

<

Wisibility: Post Office

3 In the Visibility field, select the desired visibility level.
System: The group is displayed in the Address Book for all users in your GroupWise system.
Domain: The group is displayed in the Address Book for all users in the group’s domain.
Post Office: The group is displayed in the Address Book for all users on the group’s post office.
None: The group is not displayed in the Address Book.

4 Click OK to save your changes.

Moving a Group

If necessary, you can move an eDirectory group from one post office to another. For example, you
might need to move a group from a post office you are removing.

The group retains the same name on the new post office as it has on the current post office. If another
object (user, resource, distribution list, group, or organizational role) assigned to the new post office
has the same name, you must rename one of them before you move the group. For details, see
Section 18.5, “Renaming a Distribution List,” on page 291.

To move an eDirectory group from one post office to another:

1 In ConsoleOne, right-click the Group object in the GroupWise View, then click Move to display
the GroupWise Move dialog box.
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IMPORTANT: You must select the eDirectory Group object in the GroupWise View by listing
GroupWise distribution lists. If you select the Group object in the standard Console View, you
move the Group object from one eDirectory container to another, not the group/distribution list
from one post office to another.

GroupWise Move Help Desk

Mave ta post otfice:

‘ Cancel | Help |

2 Select the post office to which you want to move the group, then click OK to move the group.

19.5 Renaming a Group

Situations might arise where you need to give an eDirectory group a new name. For example, you
might need to move the group to another post office that already has an object (user, resource,
distribution list, group, or organizational unit) with the same name.

When you rename an eDirectory group, you rename the Group object. This means that not only are
you changing the name in GroupWise, but also in eDirectory.

1 In ConsoleOne, right-click the Group object, then click Rename to display the Rename dialog box.

gy name: |

S Cancel
I save old name
Help

2 In the New Name field, specify the new name for the group.

3 Make sure the Save Old Name box is not selected. Saving the old name causes duplicate groups to
appear in the Address Book.

4 Click OK to rename the group.

19.6  Removing a Group from GroupWise

If you decide that you no longer want an eDirectory group to be a distribution list in GroupWise, you
can remove its association with a GroupWise post office, so that it returns to being just an eDirectory

group.
1 In ConsoleOne, right-click the Group object, click Delete, then click Yes to confirm that you want
to delete the object.
2 In the eDirectory Account box, deselect Delete to retain the Group object in eDirectory.
The Delete option in the GroupWise Account box is selected by default and cannot be deselected.

3 Click OK twice to complete the deletion.
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20.1

Using eDirectory Organizational Roles
as GroupWise Distribution Lists

Organizational roles can be configured to function as GroupWise distribution lists.

¢ Section 20.1, “Setting Up an Organizational Role for Use in GroupWise,” on page 307

¢ Section 20.2, “Seeing Which Members of an Organizational Role Have GroupWise Accounts,”

on page 308

¢ Section 20.3, “Changing an Organizational Role’s Visibility in the Address Book,” on page 309

¢ Section 20.4, “Moving an Organizational Role,” on page 310

*

*

Section 20.5, “Renaming an Organizational Role,” on page 310

Section 20.6, “Removing an Organizational Role from GroupWise,” on page 311

Setting Up an Organizational Role for Use in GroupWise

By default, Novell eDirectory organizational roles are not automatically available for use as
distribution lists in GroupWise. To make an organizational role available, you need to assign it to a

GroupWise post office.

1 In ConsoleOne, right-click the Organizational Role object, then click Properties.

2 Click the GroupWise tab to display the Account page.

Properties of GroupWise Admini

General v | Security Equal To M

Past Office:

Wisibility:

7| MDs Rights ~ | Other | Fights to Files and Folders |

|Provo1 Development

[post ofice

3

Page Options...

Cancel

Help

3 Fill in the following fields:
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Post Office: Select the post office where you want to assign the organizational role. You can
choose any post office you want. If you plan to limit visibility of the organizational role to users
on a specific post office or in a specific domain, you should select that post office or a post office
in the desired domain.

Visibility: Select the level at which the role is visible in the Address Book. Systemn enables the
role to be visible to all users in your GroupWise system. Domain enables the role to be visible to
all users in the same domain as the role. Post Office enables the role to be visible to all users on
the same post office as the role. Setting the visibility to None means that the role is not visible at
any level. However, even if the role is not displayed in a user’s Address Book, he or she can use
the role by typing the role’s name in a message’s To field.

4 Click OK to save the changes.

The organizational role is now treated like a GroupWise distribution list and is visible in the
GroupWise View when you filter on distribution lists. However, its icon does not change.

When GroupWise users send messages to the organization role, only those role members who have
GroupWise accounts receive messages.

20.2 Seeing Which Members of an Organizational Role Have

308

GroupWise Accounts

eDirectory organizational roles can include members who have GroupWise accounts and members
who do not have GroupWise accounts. When the organizational role is used to address a message,
only those members who have GroupWise accounts receive the message.

To see which members have GroupWise accounts and which ones do not:

1 In ConsoleOne, select the Organizational Role object, then click Tools > GroupWise Diagnostics >

Display Object.
GroupWise Diagnostics E\
Grouptise information for selected object

Descriptian “allug

Last Moclified At Provol

Last Madified By [CORP_TREE) admin.Docdey Movel

Unlisted a

Distribution List Type Role

Hemisphere 1

el DYBAC3AD-1661-0000-BAOD-SCO0BDO00B00

Merber To Provo2 Sales moelstorre

Domain Mame Proval =

|t Meifimation Thiwarau lam e A8 0T 9042 Lk 2T 0700

<T | »

v

eDirectory information for selected object

Descriptian | “allug
Equivalent To Me mdelatorre Users Docdewv Movell -
gslater Users Docdey Movell
zlucas Users. Docdey Movell

MG Sisibility 1

tnocifisrsMarme CM=acinin OU=Docdey D=Movell

LI 008A1F445EETDE118ED1 00C04F4TEERC
Role Occupart mdelstorre Users Docdew MNovell

gelater Users Docdey MNovell
zlucas Users. Docdey Movell
MNGW: Groupiize ID Provot Development Groupiize Administrators{1105C0SEEE0-0925-0000-67 45-7B0063007 =
»

m.TnmamE»m PRl arbin O 1=Mim s C—hlasll ‘

Ok
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The top window displays the members who have GroupWise accounts. The bottom window
displays all members.

2 When you have finished viewing the information, click OK.

20.3 Charllging an Organizational Role’s Visibility in the Address
Boo

An organizational role’s visibility level determines which users see the role in the Address Books.
You can control the availability of a role by displaying it in the Address Book for all users in your
GroupWise system, in the Address Book for those users in the role’s domain only, in the Address
Book for those users on the role’s post office only, or not displaying it at all.

1 In ConsoleOne, right-click the Organizational Role object, then click Properties.
2 Click GroupWise > Account to display the Account page:

Properties of GroupWise Administrators El
General v I Security Egual To M DS Rights « | Other I Rights to Files and Folders |
Post Office: |Prov01 Developrment
Wisihility: |Post Office j
Page Options... | Cancel | | Help

3 In the Visibility field, select the desired visibility level.

System: The organizational role is displayed in the Address Book for all users in your
GroupWise system.

Domain: The organizational role is displayed in the Address Book for all users in the role’s
domain.

Post Office: The organizational role is displayed in the Address Book for all users on the role’s
post office.

None: The organizational role is not displayed in the Address Book.

4 Click OK to save your changes.
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20.4  Moving an Organizational Role

If necessary, you can move an organizational role from one post office to another. For example, you
might need to move an organizational role from a post office you are removing.

The organizational role retains the same name on the new post office as it has on the current post
office. If another object (user, resource, distribution list, group, or organizational role) assigned to the
new post office has the same name, you will need to rename one of them before you move the
organizational role. For details, see Section 18.5, “Renaming a Distribution List,” on page 291.

To move an organizational role from one post office to another:

1 In ConsoleOne, right-click the Organizational Role object in the GroupWise View, then click
Move to display the GroupWise Move dialog box.

IMPORTANT: You must select the Organizational Role object in the GroupWise View by listing
GroupWise distribution lists. If you select the Organizational Role object in the standard
Console View, you move the Organizational Role object from one eDirectory container to
another, not the organizational role/distribution list from one post office to another.

GroupWise Move GroupWise Administrators El

Move to post office:

k|

| Cancel | Hela |

2 Select the post office to which you want to move the organizational role, then click OK to move
the organizational role.

20.5 Renaming an Organizational Role

Situations might arise where you need to give an organizational role a new name. For example, you
might need to move the organizational role to another post office that already has an object (user,
resource, distribution list, group, or organizational unit) with the same name.

When you rename an organizational role, you rename the Organizational Role object. This means
that you are not only changing the name in GroupWise, but also in eDirectory.

To rename an organizational role:

1 In ConsoleOne, right-click the Organizational Role object, then click Rename to display the
GroupWise Rename dialog box.

2 In the New Name field, specify the new name for the organizational role.

3 Click OK to rename the organizational role.
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20.6 Removing an Organizational Role from GroupWise

If you decide that you no longer want an organizational role to be a public address list in GroupWise,
you can remove its association with a GroupWise post office, so that it returns to being just an
eDirectory organizational role.

1 In ConsoleOne, right-click the Organizational Role object, click Delete, then click Yes to confirm
that you want to delete the object.

2 In the eDirectory Account box, deselect Delete to retain the Organizational Role object in
eDirectory.

The Delete option in the GroupWise Account box is selected by default and cannot be deselected.
3 Click OK twice to complete the deletion.
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Libraries and Documents

*

Chapter 21, “Document Management Services Overview,” on page 315

*

Chapter 22, “Creating and Managing Libraries,” on page 323

*

Chapter 23, “Creating and Managing Documents,” on page 359

*

Chapter 24, “Integrations,” on page 387
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Document Management Services
Overview

GroupWise Document Management Services (DMS) lets users create documents with integrated
applications, save them, then easily locate a specific document later without knowing the application,
a specific document name, or the document’s physical location. Users can create, share, locate, edit,
view, and check out documents that are created under the management of GroupWise DMS.

A GroupWise DMS system consists of the following components:

¢ Section 21.1, “Libraries,” on page 316
¢ Section 21.2, “Document Storage Areas,” on page 317
¢ Section 21.3, “Documents,” on page 318

¢ Section 21.4, “Integrations,” on page 321
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21.1 Libraries

A library is a set of documents and a database that allows the documents to be managed as a unit. A
library must belong to a specific post office but can be accessed by users in other post offices. The
GroupWise client enables users to store and manage their documents in the library. The GroupWise
Post Office Agent (POA) transfers documents between the GroupWise client and the library.

316

Library

W

Post Office

LY

POA

v

|

| |
c\_

GrouéWise
Client

c\_
GroupWise
Client

A

@
GroupWise
Client

|

S
Integrated Integrated Integrated
Application Application Application
User User User

In ConsoleOne, a library can be viewed where it resides in the Novell eDirectory tree.

Novell Console(ne [’._\['E|E|
Fle Edit Wiew ‘Wizards Tools Help
LB R R IR At e R S
E?‘; CORP_TREE -] Console View
E‘% Gr i &8 Help Desk @ Provo2
S Administration & Secretaties & Provo3
% Development & AccountReps @ Provod
S Legal & Engineers @ wialtharm1
% Marketing &8 Programmers & waltham2
& provos & Salesmen T administration
g E:S:Eg &8 Testers T Development
-8 Provod @ Campany Car 1 T Legal
Eh Sales 3 Company Car 2 QMarketing
Fa Support @ conference Room 2012 T sales
@ Valtharnd @ Group Meeting Room Q Support
& Waltham?2 3 Lunchroom ﬁ Administration Library
-2 Mavell @ Projector ik Developrment Library
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A library can also be viewed in relationship to the post office that owns it.
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MNovell ConsoleOne
File Edit View Tools Help
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Eh Legal
-8 Prova2
(-8 Provo3
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4 13

|\UBD-NVV\3ys\gwsystem\provn1

‘Corporaie Mail |Provn1

In the GroupWise Windows client, users can view a list of all the libraries to which they have access
by clicking Tools > Options > Documents.

Documents Setup

Library Configuration | Integrations | General
Library names: Froperties...
Accounting Library
Development Libran (D efallt] Set Default
Research Library

Physically, a library consists of a set of directories and databases stored in the gwdms subdirectory of
the post office, as illustrated in “Post Office Directory” in GroupWise 2012 Troubleshooting 3: Message
Flow and Directory Structure.

For complete information on libraries, see Chapter 22, “Creating and Managing Libraries,” on
page 323.

Document Storage Areas

Documents can be stored at the post office, as illustrated in “Post Office Directory” in GroupWise 2012
Troubleshooting 3: Message Flow and Directory Structure. This is the simplest configuration, but it is not
recommended for libraries where substantial growth is anticipated because documents stored at the
post office cannot easily be moved to a different location where additional storage space is available.

Preferably, documents should be stored outside the post office, in document storage areas. Document
storage areas are physical locations, such as drive volumes, optical devices, hard drives on other
servers, and so on. Document storage areas can be located anywhere that the POA can access them
locally or using direct network access (mapped drive or mounted file system).
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21.3

21.3.1

A document storage area has the same internal directory structure that is used to store documents at
the post office. The only difference is that a document storage area can be located anywhere in your
system. Therefore, a document storage area can be moved easily, so it is easy to expand your
document storage capacity if you store documents in a document storage area rather than at the post
office.

For complete information on document storage areas, see Section 22.6.2, “Managing Document
Storage Areas,” on page 345.

Documents

Documents created using GroupWise DMS are not stored as individual files. Instead, documents are
stored in database structures called binary large objects (BLOBs). A document and all of its versions
are stored in the separate BLOB files. BLOBs are compressed (50% or more) to conserve storage
space. BLOBs are encrypted to provide security.

Because documents are stored in a database structure, information can be associated with each
document that is not part of the document itself, such as:

¢ Section 21.3.1, “Document Properties,” on page 318

¢ Section 21.3.2, “Document Types,” on page 319

For complete information on documents, see Chapter 23, “Creating and Managing Documents,” on
page 359.

Document Properties

Document properties are attributes that determine what users see on the document property sheets
when they create DMS documents. In the GroupWise Windows client, the default document
properties for a new document appear like this:

Document | Version | Sharing | Activity Log
Library: Development Library
Document rurmber:
Subject |
Document type: [Dacument E
Aithor: |provo1 development. mpalu ﬂ
Creator:
Date created: 141922012 10:09 &M
Officizl version ]
Current version:
[ Open document naw

In ConsoleOne, the default document properties for a library are defined like this:
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21.3.2

‘@ Document Properties Maintenance

File Edit Help
B #|2] =
g Provo2 Sales Property Field Data Type | Lookup Table Required | Read-only |Hidden |Max Lenagl Test Case
T "'ﬁ Libraries ) Author String Yes Mo Mo 256 Mized
H R - 2l Librang Creator String Mo es Mo 256 tived
B -y Lookup Tables Current Yer # Nurmber Mo Yes Ma - -
Date Created Date No e Mo
Docurnent Mumber — Number Mo Tes Mo - -
Diocument Type Sting Diocument Type  Yes Mo Mo E5535 tived
Official Ver # Nurnber No b Mo - -
Subject String Mo Mo Mo B5535 Mized
< b

The default document properties are often adequate, but for some libraries, additional customized
document properties can be very useful. For example, the legal department might want Client and
Matter fields to be required for most documents created by anyone in that department.

NOTE: Document properties cannot be set in ConsoleOne on Linux. However, you can use
ConsoleOne on Windows to set document properties for libraries that are located on Linux.

Document Types

The Document Type property defines how a document is disposed of when its “life” in the system
has expired. It is a required field. Users select a document type each time they create a new
document.

Lookup Elgl
Document type
|D ocument
Docurnent A
Expense
Form
araph
Image
Memo
Minukes
Misc
Project v

Maximum wersions: 100

Life: 365 days
Action: Archive

A number of default document types are provided, as shown above. If needed, you can set up
additional document types. For example, you could set up Pleading for the legal department,

Spreadsheet for accounting, Correspondence for administration, RFP for marketing, White Paper for

Ré&D, and so on.
The document type establishes the following document characteristics:

¢ “Maximum Versions” on page 320
¢ “Document Life” on page 320

¢ “Expiration Actions” on page 320
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The following table lists some of the default document types and their default characteristics:

Document Type Maximum Versions Expiration Action Document Life

Agenda 100 Archive 99 days
Document 100 Archive 365 days
Memo 1 Delete 99 days
Minutes 100 Archive 99 days
Misc 10 Archive 30 days
Proposal 100 Archive 99 days
Report 100 Archive 99 days
Template 100 Archive 365 days

Maximum Versions

Users can create new versions of their documents when they revise them. Version numbers are
automatically incremented.

Any version of a document can be designated as the official version by the user. The official version,
which is not necessarily the most recently edited version, is the one located in searches. GroupWise
users have the right to designate an official version if they have Edit rights to the document.

Each document type property has a maximum number of versions (up to 50,000 per document). Most
types have a default of 99 versions. A maximum of 0 (zero) versions means that documents of that
type cannot have versions.

Document Life

Document life is the number of days that must pass between the time when a document is last
accessed and when it is ready for archival or deletion. A document life value of 0 (zero) indicates that
the document will never be available for archival or deletion.

Expiration Actions

When a document’s life expires, its associated expiration action takes place:

Archive: The document is archived when it reaches its document life date. This is useful for
important documents because archived documents can be unarchived.

Delete: The document is automatically deleted when its document life date is reached. This is useful
for documents that are temporary in nature.

Retain: The document is not deleted or archived, and remains in the system indefinitely. This option
is practical for documents that have a recurring use, such as template documents.
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21.4 Integrations

Integrations serve as the “glue” between document-producing applications and your GroupWise
DMS system. Integrations provide code specifically designed to allow function calls, such as Open or
Save, to be redirected to the GroupWise Windows client. This allows GroupWise dialog boxes to be
displayed instead of the application’s normal dialog boxes for the integrated functions. Integrations
also allow GroupWise to pull documents from a library and deliver them to applications for
modification. Then, integrations enable GroupWise to return modified documents to the library so
that other users can access them.

For complete information on the integrations available for the Windows client, see Chapter 24,
“Integrations,” on page 387.
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Creating and Managing Libraries

When you first set up a new GroupWise system, a basic library is automatically created for the first
post office. A basic library is adequate when:

¢ Document management is not a primary activity of your GroupWise users.

¢ The library will store documents created and used by members of the post office that owns the
library, or, if you do not need one basic library per post office, by all users within a domain.

¢ All documents will be stored at the post office or in a single document storage area external to
the post office that owns the library.

If your anticipated document management needs are more demanding than those listed above, you
can set up one or more full-service libraries, where you can implement the full range of document
management capabilities offered by GroupWise Document Management Services (DMS).

NOTE: The Linux version of ConsoleOne allows you to create libraries, but it does not allow you to
set document properties as described in Section 23.2, “Organizing Documents in Libraries,” on
page 362.

To use one or more libraries as part of your GroupWise system, perform the following tasks as
needed:

¢ Section 22.1, “Planning a Basic Library,” on page 324

¢ Section 22.2, “Setting Up a Basic Library,” on page 326

¢ Section 22.3, “Planning Full-Service Libraries,” on page 328

¢ Section 22.4, “Setting Up a Full-Service Library,” on page 338

¢ Section 22.5, “Viewing a New Library in Your GroupWise System,” on page 341

¢ Section 22.6, “Managing Libraries,” on page 342

¢ Section 22.7, “Library Worksheets,” on page 355

IMPORTANT: If you are creating a new library in a clustered GroupWise system, see the GroupWise
2012 Interoperability Guide before you create the library.
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22.1

22.1.1

22.1.2

22.1.3

Planning a Basic Library

An initial basic library was created along with the first post office when you set up your GroupWise
system. That initial basic library is available for immediate use. However, you might want to change
the location where documents are stored, as described in Section 22.1.4, “Deciding Where to Store
Documents,” on page 325. You can also create additional basic libraries as needed.

This section provides the information you need in order to set up a new basic library. Section 22.7.1,
“Basic Library Worksheet,” on page 355 lists all the information you need as you set up a basic
library. You should print the worksheet and fill it out as you complete the tasks listed below:

¢ Section 22.1.1, “Selecting the Post Office That the Library Will Belong To,” on page 324

¢ Section 22.1.2, “Determining the Context for the Library Object,” on page 324

¢ Section 22.1.3, “Choosing the Library Name,” on page 324

¢ Section 22.1.4, “Deciding Where to Store Documents,” on page 325

After you have completed the tasks and filled out the worksheet, you are ready to continue with
Section 22.2, “Setting Up a Basic Library,” on page 326.

Selecting the Post Office That the Library Will Belong To

If you are creating a basic library for each post office in your GroupWise system, print a copy of
Section 22.7.1, “Basic Library Worksheet,” on page 355 for each post office.

If users in several post offices will store documents in the same basic library, you must decide which
post office should own the library. A library can never be reassigned to a different post office, so you
should choose the owning post office carefully. You should consider which users will use the library
most frequently and where you might want to create additional libraries in the future.

BASIC LIBRARY WORKSHEET

Under Item 3: Post Office, specify the name of the post office that will own the new basic library.

Determining the Context for the Library Object

Generally, you should create the Library object in the same context as its post office. You cannot move
a Library object after you have created it.

BASIC LIBRARY WORKSHEET

Under Item 1: eDirectory Container, specify the container for the Library object.

Choosing the Library Name

When you create the Library object, you must give the library a name. This is the name that is
displayed in ConsoleOne.

After you have specified the library’s name and created the Library object, the name cannot be
changed. Therefore, if you have or will have other libraries, you should pick a name that uniquely
identifies the library. For example, use the name to identify the post office it is assigned to.
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22.14

Do not use any of the following invalid characters in the library’s name:

ASCI| characters 0-31 Comma,

Asterisk * Double quote "

At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()

Braces { } Period .

Colon : Slash /

By default, the library name that users see in the GroupWise client is the same as the Library object
name. However, you can change the display name if you want it to be different from the Library
object name.

BASIC LIBRARY WORKSHEET

Under Item 2: Library Name, specify the Library object name.
Under Item 7: Library Description, provide a brief description of the planned use for the library.

Under Item 8: Display Name, specify the library name you want users to see in the GroupWise client, if it is
different from the Library object name.

Deciding Where to Store Documents

You can store documents at the post office in the post_office\gwdms\1library\docs subdirectory
of the post office. You can later add document storage areas outside the post office if DMS usage
grows. However, the documents stored at the post office can never be moved.

A document storage area has the same internal directory structure that is used to store documents at
the post office, but it can be located anywhere in your system. Document storage areas can be moved
easily, so it is easy to expand your document storage capacity when you store documents in
document storage areas rather than at the post office.

You might want to set up a document storage area on the same server where the POA runs so as not
to increase network traffic. The POA can index and serve documents to users most efficiently if the
document storage area is located locally.

BASIC LIBRARY WORKSHEET

Under Item 4: Store Documents at the Post Office?, mark Yes or No. (No is recommended for permanent
document storage).

To define a document storage area, you must know its direct access path. For example, a UNC path
specifies the absolute location of the document storage directory.

\\Windows server\sharename\storage directory

For example:

\\win7\c$\docs
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22.2

22.2.1

NOTE: On Linux, ConsoleOne interprets a UNC path so that the first item in the UNC path is the
Linux server hostname, followed by a Linux path to the document storage area.

BASIC LIBRARY WORKSHEET

If you entered No for Iltem 4, specify the direct access path under Item 6: Document Storage Area Path.

Under Item 5: Document Storage Area Description, enter a useful description of the document storage area.
(This description is displayed only in ConsoleOne.)

If you need to add a document storage area to the initial library that was created with the first post
office in your GroupWise system, use the Storage Areas properties page of the Library object in
ConsoleOne to provide the direct access path, as described in “Adding a Document Storage Area” on
page 345.

Setting Up a Basic Library

You should already have reviewed Section 22.1, “Planning a Basic Library,” on page 324 and filled
out Section 22.7.1, “Basic Library Worksheet,” on page 355. Complete the following tasks to set up a
new basic library:

¢ Section 22.2.1, “Creating the Basic Library,” on page 326

¢ Section 22.5, “Viewing a New Library in Your GroupWise System,” on page 341

Creating the Basic Library

To create a new library:

1 Make sure the POA is running for the post office that will own the new basic library.

2 In ConsoleOne, browse to and right-click the Novell eDirectory container where you want to
create the library (worksheet item 1), then click New > Object.

New Object

Creste object in:
2, CORP_TREEIGtoupWise 0K

Class:
Cancel

@ Groupiize Domain
External Entity
Library

Post Otfice

Help

el |

5 Grougwise Distribution List ﬂ
Il

I Groupiise
b Groughise Resource

‘:? hitpServer

& -]

nnnnnnnnnnnnnn

3 Double-click GroupWise Library, then fill in the fields in the Create GroupWise Library dialog
box (worksheet items 2 through 6).
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Create GroupWise Library

Likbrary Mame: l:l

Groupiise Post Office: Cancel
| ﬂ Help

Documert Starage Area

Diocuments may he stored atthe post office
arin one ot more storage areas. Storage
areas can also be added once the library has
heen created.

T

[¥ Store documerts ot post office

[ Define additional properties
[ Creste ancther Library

4 Click Define Additional Properties, then click OK to create the Library object and display the
library Identification page.

Properties of Marketing Library rz‘
General | NDSRights v | Other | Rights ta Files and Folders |
Post Office: |Prov03 Marketing
Diescription: ‘
Start Yersion Mumber: |1 j
Maximum Archive Size: 1] i‘ Bytes
Dizplay Mame: |Marketing Library
Distinguished Mame: Matketing Library GroupWise
Page Options... | Cancel | Help

5 Fill in the Description field (worksheet item 7).

6 If necessary, edit the Display Name field (worksheet item 8).

7 Click OK to save the library information.

8 Test the new library. See Section 22.5, “Viewing a New Library in Your GroupWise System,” on
page 341.

Although there are many configuration options for libraries and documents, as described in
Section 22.3, “Planning Full-Service Libraries,” on page 328, no additional setup is required for a
basic library. GroupWise client users can begin to store documents in the new library at once.
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22.3

22.3.1

Planning Full-Service Libraries

If your document management requirements go beyond basic libraries, you can create one or more
full-service libraries. You might or might not need to make use of all document management features
in order to meet your DMS users’ needs.

This section covers everything you should consider when you set up full-service libraries. The “Full-
Service Library Worksheet” on page 356 lists all the information you need as you set up a full-service
library. You should print a copy of the worksheet for each library you plan to create. Fill out the
worksheet for each library as you complete the tasks listed below.

¢ Section 22.3.1, “Deciding Which Libraries to Create,” on page 328

¢ Section 22.3.2, “Selecting the Post Offices To Own Libraries,” on page 332

¢ Section 22.3.3, “Determining the Contexts for Library Objects,” on page 332

¢ Section 22.3.4, “Choosing Library Names,” on page 332

¢ Section 22.3.5, “Deciding Where to Store Documents,” on page 333

¢ Section 22.3.6, “Setting Document Version Options,” on page 335

¢ Section 22.3.7, “Figuring Maximum Archive Directory Size,” on page 335

¢ Section 22.3.8, “Designating Initial Librarians,” on page 336

¢ Section 22.3.9, “Restricting Initial Public Library Rights,” on page 337

¢ Section 22.3.10, “Determining Your Indexing Needs,” on page 338

¢ Section 22.3.11, “Determining If You Need to Set Up Integrations for DMS Users,” on page 338

After you have completed the above tasks and filled out the worksheets, you are ready to continue
with Section 22.4, “Setting Up a Full-Service Library,” on page 338.

Deciding Which Libraries to Create

When designing a system of libraries for your GroupWise system, you should review the following
considerations:

¢ “Library Access for DMS Users” on page 328
¢ “Centralized vs. Decentralized Library Configurations” on page 328

¢ “Library Specialization” on page 331

Library Access for DMS Users

Client/server access is the preferred access mode for GroupWise client users. It is the best access
mode for DMS users because it enables them to access libraries outside their own post offices.

For information about access modes, see Section 35.4, “Post Office Access Mode,” on page 476.

Centralized vs. Decentralized Library Configurations

Reorganizing existing libraries is not a simple process. Therefore, you should determine whether you
want a centralized or decentralized library configuration before you start creating libraries.

¢ “Centralized Libraries” on page 329

¢ “Decentralized Libraries” on page 330

¢ “Comparative Scenarios” on page 331
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Centralized Libraries

Centralized libraries are located in a post office that is dedicated to libraries (no users). Centralized
libraries are serviced by the POA in the dedicated DMS post office, as shown in the following
illustration:

Figure 22-1 Centralized Libraries

DMS
Accounting Library Post Office Manufacturing Library

Development Library | \ Sales Library

Accounting Development Manufacturing Sales
Post Office Post Office Post Office Post Office
POA POA POA POA

y
i ) v J
4

GroupWise

GroupWise GroupWise GroupWise
Clients Clients Clients Clients
> ;,i" : ;,4#’ : = 4
——7 N7 T 2 o
Integrated Integrated Integrated Integrated
Applications Applications Applications Applications
w W W w
Accounting Development Manufacturing Sales
Users Users Users Users

In the illustration, notice that all libraries belong to the DMS post office, which has no users. All
GroupWise client users are using client/server access mode, which is required because there are no
libraries in their local post offices. Each user has access to all four libraries through TCP/IP links to
the DMS POA.
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The following table lists some advantages and disadvantages of centralized libraries:

Advantages

Disadvantages

+ Administration can be consolidated, allowing one
administrator to specialize in document
management.

* Backup can be easier with hardware dedicated to
one DMS post office, such as optical drives,
RAID, fast backup units, and so on.

+ If a post office server other than the one
dedicated to libraries goes down, DMS access is

unaffected for users in the remaining post offices.

*

You must create and maintain a post office that is
dedicated to libraries only (no users).

This configuration guarantees that all document
searching and accessing is back and forth
between users’ post offices and the libraries’ post
office, possibly degrading network performance.

If the post office server dedicated to libraries
goes down, DMS is unusable for the whole
GroupWise system.

Decentralized Libraries

Decentralized libraries are located along with users in different post offices. Decentralized libraries
are serviced by their own local POAs as shown in the following illustration:

Figure 22-2 Decentralized Libraries

Accounting
Post Office
Accounting m/ Development
Library | Library
W:'U' POA WJ]}

o

&
GroupWise
Clients

‘_\_\/“/’
Integrated
Applications

i
&
Accounting
Users

Development

Post Office
Ty
POA

W

&
GroupWise
Clients

g

Integrated
Applications

|

Development

Users

Manufactu
Library

T

W

Manufacturing
Post Office

POA

Wy

e
GroupWise
Clients

e o
Integrated
Applications

|
|

Manufacturing
Users

Sales
Librar

W

Yy

Sales
Post Office

/T

POA

o

&
GroupWise
Clients

|

Integrated
Applications

|
v

Sales
Users

In the illustration, notice that each post office has its own library. Users can see each others’ libraries
as well as their own because of client/server access mode.

The following table lists some advantages and disadvantages of decentralized libraries
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Advantages Disadvantages

* Network traffic is minimized because most + Libraries and their documents are scattered over
document accessing are in users’ local post different servers, adding to your administrative
offices. workload (such as doing backups).

+ You do not need to maintain an extra DMS post
office dedicated to libraries only.

+ Users in a post office where a library resides
can use direct access mode if necessary.

Comparative Scenarios

The following scenarios further illustrate the differences between centralized and decentralized
libraries:

¢ Assume that you assigned your first library to the same post office your users have membership
in. By initially assigning a library to the same post office as your users, you establish a
decentralized configuration for future libraries. You now want a centralized library
configuration. However, because you cannot reassign the library to another post office, you
must do one of the following:

¢ Create one or more new libraries under a DMS post office, export all of the documents from
the first library and import them to the new libraries, delete the first library, and then
ensure that users can locate their documents.

¢ Create one or more new libraries under a DMS post office and have your librarian use mass
document operations to move the documents from the first library to the other libraries,
delete the first library, and then ensure that users can locate their documents.

¢ Assume that you assigned your first library to a DMS post office that is used only for libraries.
Now you can use either the centralized or decentralized library configuration for your
additional libraries. The DMS post office can be used for all future libraries to create a
centralized configuration, or you could assign future libraries to other post offices and leave that
first one where it is, giving you a decentralized configuration. Setting up your first library on a
post office server dedicated to only libraries allows you to use either configuration option.
However, this method initially requires additional hardware and administration.

Library Specialization

You can create libraries for such user specialties as administration, accounting, development, human
resources, legal, marketing, manufacturing, payroll, R&D, sales, shipping, and so on. You can also
specialize libraries by such functions as general (for all users), administration (including legal and
payroll), engineering and documentation development (R&D), marketing and sales, manufacturing
and shipping, and so on.

You can also use specialization to provide security for sensitive libraries. You do this by setting up
access restrictions for the libraries. The default is for all DMS users to have access to all libraries in the
GroupWise system. For more information about restricting library access, see Section 22.6.3,
“Managing Library Access,” on page 348.

Restricting library access can also improve users’ search time. When users install the GroupWise
client on their workstations, they are either automatically assigned a default library (if there is one on
their post office), or they are asked to select one from the libraries they have access to. By default,
DMS searches are performed only on the user’s default library. To search other libraries (“global”
search), users can select other libraries using the Look In list in the Find dialog box. If you limit users’
access to libraries (perhaps by department), their global searches would also be faster.
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22.3.2

22.3.3

22.3.4

Another reason for creating specialized libraries could be for different library configuration needs.
For example, each library could have specialized document types and document properties that
would not be needed in other libraries. For a review of document types and properties, see
Section 21.3, “Documents,” on page 318. For more detailed information, see “Customizing the
Default Document Type Property” on page 363 and Section 23.2.1, “Customizing Document
Properties,” on page 362.

Specialization can also facilitate library management activities, such as controlling library
accessibility for individual users or groups of users, or managing different uses of document types,
document properties, or field label naming schemes.

Selecting the Post Offices To Own Libraries

As a result of deciding whether you want to use a centralized or decentralized configuration for your
libraries and whether or not you need specialized libraries, you should have a good idea of what post
offices you want to create libraries in.

If you are using a centralized configuration, create the DMS post office by following the instructions
in Chapter 11, “Creating a New Post Office,” on page 173, then return to this point.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 3: Post Office, specify the name of the post office that will own the new library.

Determining the Contexts for Library Objects

You can create a Library object in any container in the eDirectory tree. For example, you could create
the Library object in the same container as its Post Office object. Or you could create it in a special
container just for Library objects:

The containers in which you place the Library objects have no bearing on whether your libraries are
centralized or decentralized. Library objects can be located anywhere in the tree, no matter which
post offices the libraries belong to.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 1: eDirectory Container, specify the name of the eDirectory container where you want to create the
new library.

Choosing Library Names

A library’s name must be unique within the post office; it also must be unique within its container.
You should devise a naming scheme that helps to identify all libraries in the GroupWise system. It
can be useful to include within the library name an indication of which post office it belongs to.

After you have specified the library’s name and created the Library object, the name cannot be
changed.

Do not use any of the following invalid characters in the library’s name:

ASCI| characters 0-31 Comma,

Asterisk * Double quote "
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At sigh @ Extended ASCII characters that are graphical or typographical symbols;
accented characters in the extended range can be used

Backslash \ Parentheses ()
Braces { } Period .
Colon : Slash /

By default, the library name that users see in the GroupWise client is the same as the Library object
name. However, you can change the display name if you want it to be different from the Library
object name.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 2: Library Name, specify the Library object name.
Under Item 7: Library Description, provide a brief description of the planned use for the library.

Under Item 10: Display Name, specify the library name you want users to see in the GroupWise client, if it is
different from the Library object name.

Deciding Where to Store Documents

When deciding where to store documents, you should review the following considerations:

¢ “Document Storage Location” on page 333
¢ “Disk Space Requirements” on page 333

¢ “Direct Access Paths to Document Storage Areas” on page 334

Document Storage Location

Documents belonging to full-service libraries should not be stored at the post office. Instead, they
should be stored in document storage areas. For a review, see Section 21.2, “Document Storage
Areas,” on page 317.

A library can have more than one document storage area. The only requirement is that the POA that
services the library must have direct network access (mapped drive or mounted file system) to each
storage area.

You can set up one document storage area for each library as you create the Library object.
Additional document storage areas can be set up using the Storage Areas properties page of the
Library object, as described in “Adding a Document Storage Area” on page 345.

Disk Space Requirements

You need to know the disk space requirements for your libraries in order to choose appropriate
locations for document storage areas.

If you have chosen a centralized library configuration, your document storage areas are all serviced
by the POA of the DMS post office. Therefore, you can calculate the disk space requirements for your
GroupWise system as a whole. If you have chosen a decentralized configuration, document storage
areas are located throughout your GroupWise system. Therefore, disk space requirements must be
calculated separately for each library.
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If your current document storage statistics are an accurate indicator for a given library or for your
system, use them for calculating your disk space requirements. Otherwise, use the following formula
for determining DMS storage needs:

Formula:

Number of Users
x Average Number of Documents per User
X Average Document Size
x Average Number of Versions per Document

Disk Space Required for Library
Example:

250 Users
x 200 Documents per User
b 50 KB per Document
X 10 Versions per Document

25 GB of Disk Space

Users might create a new version of a document any time they revise it. Because all versions of a
document are saved in BLOB storage with the original document, disk space can be used up quickly!
If you know how many versions per document your users average, use that value in the formula;
otherwise, allow for an average of at least ten versions per document.

If your Average Document Size value for the formula is based on non-GroupWise documents, they
will be compressed by about 50% after they have been imported into GroupWise and stored in
BLOBs.

You should research your current or expected document usage before deciding where to store
documents.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 4: Document Usage Estimate, enter the requested values and calculate the resulting disk space
requirements.

If your values are calculated for the system (rather than per library), enter this information on only one of the
worksheets.

Direct Access Paths to Document Storage Areas

To define a document storage area, you need to know its direct access path. For example, a UNC path
specifies the absolute location of the document storage directory.

\\Windows_ server\sharename\storage directory

For example:

\\win2008\c$\docs

NOTE: On Linux, ConsoleOne interprets a UNC path so that the first item in the UNC path is the
Linux server hostname, followed by a Linux path to the document storage area.

You might want to set up a document storage area on the same server where the POA runs so as not
to increase network traffic. The POA can index and serve documents to users most efficiently if the
document storage area is located locally.
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22.3.7

FULL-SERVICE LIBRARY WORKSHEET

Under Item 6: Document Storage Area Path, specify the direct access path.

Under Item 5: Document Storage Area Description, provide a useful description of the document storage area.
(This description is displayed only in ConsoleOne.)

Setting Document Version Options

When you create a new library, you can establish how document versions are handled. For an
overview of document versioning, see “Maximum Versions” on page 320.

¢ “Official Version” on page 335

¢ “Start Version Number” on page 335

Restricting the maximum number of versions should be done after the library has been created, as
described in Section 22.6.1, “Editing Library Properties,” on page 343.

Official Version

By default, any user can establish the official version of a document. However, you can remove that
right from one or more users if needed.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 11: Restrict Public Access Rights, cross out Designate Official Version if you want to eliminate that
right for all users.

You can later grant the Designate Official Version to specific users or distribution lists, as described in
Section 22.6.3, “Managing Library Access,” on page 348.

Start Version Number

You must set the start number for each library to either 0 (zero) or 1. The default is 1. This number
identifies the original document.

Version numbers are automatically increased from the number you select. If you select 0, the first
version of a document will be 000. If you select 1, the first version will be 001.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 8: Start Version Number, select O or 1.

Figuring Maximum Archive Directory Size

Documents created with GroupWise DMS can be archived, depending on their Document Type
properties. A document’s type determines its disposition, such as archiving or deleting. For more
information, see “Customizing the Default Document Type Property” on page 363.

When you archive documents, their BLOB files are moved into archive directories. Each library in a
document storage area has its own set of archive directories that are automatically created as needed.
They are named arxxxxxx (Where xxxxxx is an incremental integer with leading zeros). A document
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storage area has the same archive directory structure as the gwdms subdirectory in the post office, as
illustrated in “Post Office Directory” in GroupWise 2012 Troubleshooting 3: Message Flow and Directory
Structure.

When a document is archived, GroupWise determines if the document’s BLOB file can fit in the
current archive directory. If it cannot fit, another archive directory is created and the BLOB is
archived there.

An archive set consists of all documents in one archive directory. The Maximum Archive Size
property on the Library object establishes in bytes each archive directory’s size limit. You should set
this to mirror the capacity of your archival medium (such as a CD or DVD). It should not be more
than your archival medium’s capacity.

It is usually better to keep archive sets small in comparison to the size of the backup medium. This
lets you back up archive directories often enough to keep your hard disk space from being used up
too quickly between backups. For example, if your backup medium has 1 GB capacity, you could
limit your archive sets to a maximum archive size of 200 MB.

If your archival system only lets you back up in one pass (in other words, you cannot perform
consecutive backups to the medium), the Maximum Archive Size should match the archival
medium’s capacity.

Some archival mediums require extra space for recording file storage data, such as an index of the
files stored to tape. Ten percent is usually sufficient. For example, a tape system with 100 MB capacity
means you should set your Maximum Archive Size to 90 MB.

Consult your archival medium documentation for information on setting up an effective backup
strategy. Include in your strategy such concepts as multiple archive sets per backup medium, or
allowing extra space for the medium’s file storage data.

ADDITIONAL LIBRARIES WORKSHEET

Under Item 9: Maximum Archive Size, enter a number (in bytes, with no abbreviations or commas).

Designating Initial Librarians

A librarian has full rights to the properties of every document in the library, and can therefore
perform management tasks on all library documents. You can assign yourself as a librarian. You can
also delegate these tasks by assigning responsible users in each library as librarians. Any GroupWise
user who normally has access to the library can be a librarian. You can also have multiple librarians
for each library.

When you first create a new library, you might want to simply designate yourself as the librarian and
assign other users later. For more detailed information, see Section 22.6.4, “Adding and Training
Librarians,” on page 350.

ADDITIONAL LIBRARIES WORKSHEET

Under Item 12: Librarians, list any users that you want to function as librarians for the new library.
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22.3.9

Restricting Initial Public Library Rights

The rights to documents in a library apply to the library as a whole; therefore, they are referred to as
public rights. By default, all public rights are granted to all users in a new library.

You can restrict which GroupWise library features individual users or distribution lists should have
by removing the public rights and then restoring them for selected users or distribution lists.

The following table summarizes the public library rights:

Public Right Description

Add Allows users to add new documents to the library.
Change Allows users to make changes to existing documents in the library.
Delete Allows users to delete documents, regardless of who else created them or has rights to the

documents. However, to be able to delete a document, users must also have rights to locate
and modify the document (View and Change rights), in addition to the Delete right.

View By itself, this right allows searching, viewing, or copying documents, but does not permit
editing them. Copies can be edited, because a copy is saved as a separate document.
Therefore, editing a copy does not affect the original document or any of its versions.

Designate Allows any version of a document to be designated as the official version. The official version,
Official Version which is not necessarily the most recently-edited version, is the one located in searches.

The official version is usually determined by the creator or author of the document. However,
the official version can be designated by the last user to edit the document (if the user has this
right). A user also needs the Change right to the document to be able to designate an official
version. However, you might still want to deselect this as an initial public right.

Reset In-Use The In-Use flag protects against data loss by preventing multiple users from concurrently

Flag opening the same document. The purpose of the Reset In-Use Flag right is to allow a user or
librarian to reset a document’s status when the document is in use by someone else or when
it is erroneously flagged as in use.

Because you can manually reset the In-Use flag to change a document’s status, even if the
document is currently open, you should use prudence in allowing users the public right to
change the In-Use flag. You might want to deselect this as a public right.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 11: Restrict Public Access Rights, cross out any public rights you want to eliminate for all users.

You can later grant the rights to specified users or groups, as described in Section 22.6.3, “Managing Library
Access,” on page 348.

Rights to individual documents in a library can be modified at any time by the user listed as the
creator or author of the document. Just because users might have public rights in a library does not
mean that they have the equivalent rights to every document in the library. For additional
information on rights, see “Sharing Documents” in “Document Management” in the GroupWise 2012
Windows Client User Guide.
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22.3.10 Determining Your Indexing Needs

The POA performs many tasks in the post offices, as described in Section 35.5, “Role of the Post
Office Agent,” on page 477. Indexing documents is just one of its many functions.

If necessary, you can configure an extra POA on another server to handle indexing. Separating POA
functions can optimize the processing load for the respective POAs, particularly if your GroupWise
system will regularly search and index a large number of documents.

If you feel you might need dedicated indexing for DMS documents, see Section 23.3, “Indexing
Documents in Libraries,” on page 374 for in-depth information on different configurations. Then
determine whether you need dedicated indexing.

FULL-SERVICE LIBRARY WORKSHEET

Under Item 13: Dedicated POA for Indexing, mark whether or not you plan to set up a separate indexing POA.

22.3.11  Determining If You Need to Set Up Integrations for DMS Users

For an overview of integrations, see Section 21.4, “Integrations,” on page 321. To determine if you
should set up integrations for a given application, see Chapter 24, “Integrations,” on page 387.

ADDITIONAL LIBRARIES WORKSHEET

Under Item 14: Set Up Integrations, mark whether or not you need to manually set up integrated applications
for your DMS users.

22.4  Setting Up a Full-Service Library

You should have already reviewed Section 22.3, “Planning Full-Service Libraries,” on page 328 and
filled out Section 22.7.2, “Full-Service Library Worksheet,” on page 356 for each new library. Before
starting to create new libraries, be sure your system meets the following prerequisites:

¢ Make sure the eDirectory contexts exist where you will create new Library objects.

+ Make sure the post offices exist that will own the new libraries. If you are using a centralized
configuration, make sure you have created the DMS post office that will own all the libraries by
following the instructions in Chapter 11, “Creating a New Post Office,” on page 173.

+ Make sure the POA is running for each post office that will own a new library.

¢ Make sure you have access to the physical locations where you will set up document storage
areas.

After the prerequisites are met, you are ready set up one or more full-service libraries.

¢ Section 22.4.1, “Creating the Full-Service Library,” on page 338
¢ Section 22.5, “Viewing a New Library in Your GroupWise System,” on page 341
¢ Section 22.4.2, “What’s Next,” on page 340

22.4.1  Creating the Full-Service Library

1 Make sure you are logged in to the eDirectory tree where you want to create the library.

This must be the same tree as the post office the library will belong to (worksheet item 3).

338  GroupWise 2012 Administration Guide



2 In ConsoleOne, browse to and right-click the eDirectory container where you want to create the

library (worksheet item 1), then click New > Object.

New Object
Creste object in:
35 CORP_TREE/GroupWise OK
Class:

ss Cancel

B Groupwise Distrioution List B
@ Groupiize Domain Hel
|1I Grougise External Entity |

IRrary
a Groupwise Post Office
@ Groupiize Resaurce

7 hitserver
D e o Bl

i

3 Double-click GroupWise Library, then fill in the fields in the New Library dialog box (worksheet
items 2 through 6).

Create GroupWise Library

Likrary Mame:

Cancel
ﬂ Help

Groupise Post Office:

Document Storage Area

Diocuments may he stored atthe post office
orin one or mare storage areas. Storage
areas can also be added once the library has
heen created.

e

[V Store documerts ot post office

[ Define additional properties
[ Creste ancther Library

4 Click Define Additional Properties, then click OK to create the new Library object and display the

library Identification page.

Properties of Marketing Library

General | NDSRights v | Other | Rights ta Files and Folders |

Post Office: |Prov03 Marketing
Diescription: ‘
Start Yersion Mumber: |1

Maximum Archive Size: 1] i‘ Bytes

Dizplay Mame: |Marketing Library

Distinguished Mame: Matketing Library GroupWise

Page Options...

Help

5 Fill in the fields (worksheet items 7 through 10).
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6 Click GroupWise > Rights to display the Rights page.

Properties of Development Library E\
GroupWise ~ | Gereral | NDS Rights = | Citier | Rights to Files and Folders |
Rights
Public Rights
IV add IV Wiewe
¥ Change I¥ Set official version
¥ Delete [ Reset in-use flag
Indiviciual or Distribution List Rights
r A
r r
r r
r r
©Fage OHlions... ok | cencal | appy | Hep |

7 In the Public Rights box, deselect any rights you want to remove from all library users

(worksheet item 11).

8 If you want to set up one or more librarians, click Add, browse to and select one or more users or

distribution lists (worksheet item 12), then click OK. Select the users and distribution lists, then
select Manage (Librarian) to give them rights to the properties of all documents in the library.

9 Click OK to save the library information.

10 Test the library. See Section 22.5, “Viewing a New Library in Your GroupWise System,” on

page 341.

22.4.2 What's Next

After you have created the new library, you can expand its capabilities as needed:

*

Import and manage documents.

See Chapter 23, “Creating and Managing Documents,” on page 359.
Set up integrated applications for DMS users (worksheet item 14).
See Chapter 24, “Integrations,” on page 387.

Grant library rights to specific users or distribution lists.

See Section 22.6.3, “Managing Library Access,” on page 348.

Assign librarians.

See Section 22.6.4, “Adding and Training Librarians,” on page 350.
Set up multiple document storage areas.

See “Adding a Document Storage Area” on page 345.

Set up a dedicated indexing POA (worksheet item 13).

See Section 23.3, “Indexing Documents in Libraries,” on page 374.
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22.5.1

Viewing a New Library in Your GroupWise System

After you create a new library, you can see it in ConsoleOne and GroupWise client users can see it in
the GroupWise client.

¢ Section 22.5.1, “Seeing the New Library in ConsoleOne,” on page 341
¢ Section 22.5.2, “Seeing the New Library in the GroupWise Windows Client,” on page 342

Seeing the New Library in ConsoleOne

In the Console View in ConsoleOne, you can see the new Library object in the context of its
eDirectory container object.

Figure 22-3  Console View Showing the New Library Object

Nowell ConsoleOne
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'Jser: admin.Docdey Movell ITree CORP_TREE

In the GroupWise View, you can see the relationship between the new library and the post office it
belongs to.

To locate the library in the GroupWise view:

1 Expand the GroupWise System object.
2 Expand the Domain object where the owning post office resides.

3 Select the owning post office.

Creating and Managing Libraries 341



4 In the drop-down list of objects, select Libraries.

FEX

Novell ConsoleCne
File Edit ¥iew Tools Help

_&|Q||ﬁ"“§‘ ° @|'F§l| éLibrariEs 4
- w-Ga sales 3| Object ID | Domain teme Post Office Name |
Q Staff ﬁ Development Libra. . Provol Development
4@ Support
-8 waltham1
- waltham2
i Movell
B Security

@ NOVELL_ING
=18 Groupwise System
B3 Provol
@ Developrment]
Eh Leqgal
-8 Prova2

-8 Provad

-8 Provod - B
K —

|Cnrpmrate [LET |vam B D-Misysigwsystemipravol

22.5.2 Seeing the New Library in the GroupWise Windows Client

GroupWise Windows client users can see that a new library has been created. They can set it as their
default library if desired.

In the GroupWise client:

1 Click Tools > Options > Documents.

Documents Setup |E|E|

Library Configurstion | Integrations | General
Library names: Properties. .
Accounting Library
D evelopment Library (D efault] Set Default
Fiesearch Library

The Library Configuration tab should include the new library.

2 Select the new library, click Set as Default, then click OK to use the new library as the default
location for storing documents and searching for documents.

22.6 Managing Libraries

As your GroupWise DMS system grows and evolves, you might need to perform the following

activities:
¢ Section 22.6.1, “Editing Library Properties,” on page 343
¢ Section 22.6.2, “Managing Document Storage Areas,” on page 345
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22.6.1 Editing Library Properties

After creating a library, you can change some library properties. Other library properties cannot be

changed.

Section 22.6.3, “Managing Library Access,” on page 348
Section 22.6.4, “Adding and Training Librarians,” on page 350
Section 22.6.5, “Maintaining Library Databases,” on page 354
Section 22.6.6, “Moving a Library,” on page 354

Section 22.6.7, “Deleting a Library,” on page 354

1 In ConsoleOne, browse to and right-click the Library object, then click Properties to display the
library Identification page.

Post Ciffice:

Description:

Start Yersion Mumber:
aximum Archive Size:
Dizplay Mame:

DistingLizhed Mame:

Properties of Marketing Library E‘

v General I MND'S Rights + | Cther I Rights to Files and Folders I

|van3 Marketing

[t

1] i‘ Eytes

|Marketing Library

Matketing Library Groupise

Page Options...

| Cancel | ‘ Help |

2 Change editable fields as needed. For information about individual fields, click Help.

3 Click GroupWise > Storage Areas to display the Storage Areas page.
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Properties of Development Library
GroupWise « | General | MNDS Fights: vl Cther | Rights to Files and Folders I
Storage Areas

its path location

Storage Aress:

Click & check box to use & storage stea. To prevent dsta loss, 8 storage area record should never be deleted if data is stored at

[¥ Developmert Doc Storage Area

[ Store documents at post office

Add | |

Page Options |

Cancel | |

Help |

All document storage areas associated with the library are listed, no matter where they are
located. On this page, you can add, move, and delete document storage areas. See Section 22.6.2,

“Managing Document Storage Areas,” on page 345.

4 Click GroupWise > Rights to display the library Rights page.

Properties of Development Library

GroupWise ~ | General | NDS Rights ~ | cther | Rights to Files and Folders |
Rights
Public Rights
IV agd [V Wiew
¥ Change [+ Set official version
IV Delete

[~ Resetin-use flag

Inddivicdusl or Distribution List Rights

adhatmapals

jstevens Sales.Provol
mbarnard Development Provol

[~ Manage (Librarian)

A Delete
I =
I ~
¥ [+ Reset in-use flag
Page Options... [e]l% | Cancel | Apply | Help |

Public library rights granted to all users are selected in the Public Rights box. The Individual and
Distribution List Rights box shows any additional rights that have been granted to specific users.
See Section 22.6.3, “Managing Library Access,” on page 348 and Section 22.6.4, “Adding and

Training Librarians,” on page 350.

5 Click OK to save changes to the library properties.
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Managing Document Storage Areas

For a review, see Section 21.2, “Document Storage Areas,” on page 317 and Section 22.1.4, “Deciding
Where to Store Documents,” on page 325.

Typically, the initial document storage area for a library is set up when the library is created.
Thereafter, you can create additional document storage areas as the library grows. You can move a
document storage area to a location where more storage is available. You can delete a document
storage area if it is no longer used.

¢ “Adding a Document Storage Area” on page 345

¢ “Moving a Document Storage Area” on page 346

¢ “Deleting a Document Storage Area” on page 347

Adding a Document Storage Area

To help you plan where to create the new document storage area, see Section 22.1.4, “Deciding Where
to Store Documents,” on page 325.

To create a new document storage area for a library:
1 In ConsoleOne, browse to and right-click the Library object, then click Properties.

2 Click GroupWise > Storage Areas to display the Storage Areas page.

Properties of Development Library ﬁl

GroupWise v | General | NDS Fights ~ | Cther | Rightsto Files and Folders |
Storage Areas

Click & check box to use & storage area. To prevent dsta loss, a storade srea record should never be deleted if dats is stored at
its path location

Storage Aress:

¥ Developmert Doc Storage Area

[~ Store documents st post office

add | | |

Page Options... | Cancel | | Help |

Existing document storage areas are listed.

3 Click Add to create a new document storage area.
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Create Document Storage Area El

& storage area's path must be used by only one library and should never be modified unless the
storage area is empty

Description:

[

LING Path [ = |
[
I

Apple Talk Zone:

Linus Path:

H | Cancel ‘ Hela |

Provide a description for the document storage area.

5 Specify the UNC path to the directory where you want to create the document storage area.

If the directory does not exist, it will be created as the document storage area is set up.

As an alternative, you can specify an AppleTalk zone to store documents on an Apple computer,
or you can specify a Linux path to store documents on a Linux server. The POA that will service
the library must have direct access to the location you specify.

Click OK to create the new document storage area and add it to the list of storage areas for the
library.

If you have multiple document storage areas selected in the Storage Areas list, new and modified
documents could be added to any one of them.

If you want to stop storing documents in the previous document storage area, deselect it in the
Storage Areas list.

Click OK to save the document storage area information.

Moving a Document Storage Area

You might choose to move a document storage area if it is close to exceeding the available disk space
at its current location and you do not want to create an additional document storage area.

1
2
3

Stop the POA that services the library.
Copy the document storage area directory and all of its contents to the desired location.

Make sure that the POA has access to the new location so that it can read and write documents
in the document storage area.

In ConsoleOne, browse to and right-click the Library object, then click Properties.

5 Click GroupWise > Storage Areas to display the Storage Areas page.
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Properties of Development Library &l

GroupWise « | General | MNDS Fights: vl Cther | Rights to Files and Folders I
Storage Areas

Click & check box to use & storage stea. To prevent dsta loss, 8 storage area record should never be deleted if data is stored at
its path location

Storage Aress:

[¥ Developmert Doc Storage Area

[ Store documents at post office

dd | | |

Page Options | Cancel | | Help |

Existing document storage areas are listed.
6 Select a document storage area, then click Edit.

7 Provide the new location for the document storage area, then click OK twice to save the new
document storage information.

8 Restart the POA.

Deleting a Document Storage Area

When you delete a document storage area, any documents in the document storage area are moved
to other valid document storage areas for the library. If you want to move documents to a specific
location before deleting the document storage area, see Section 23.1.3, “Managing Groups of
Documents,” on page 361.

To delete a document storage area:

1 In ConsoleOne, browse to and right-click the Library object that owns the document storage
area, then click Properties.

2 Click GroupWise > Storage Areas to display the Storage Areas page.
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Properties of Development Library El

GroupWise « | General | MNDS Fights: vl Cther | Rights to Files and Folders I
Storage Areas

Click & check box to use & storage stea. To prevent dsta loss, 8 storage area record should never be deleted if data is stored at
its path location

Storage Aress:

[¥ Developmert Doc Storage Area

[ Store documents at post office

dd | | |

Page Options | Cancel | | Help |

3 Select a document storage area, then click Delete.

4 Click OK to close the Storage Areas page

If the above steps are not successful in deleting a document storage area, perhaps because one or
more documents were in use during the deletion process, you can use the Analyze/Fix Library action
of Mailbox/Library Maintenance, with the Remove Deleted Storage Areas and Move Documents First
options selected, to finish cleaning up the deleted document storage area. For more information, see
Chapter 28, “Maintaining Library Databases and Documents,” on page 415.

22.6.3 Managing Library Access

Access to libraries is controlled by the rights users have to the Library object. By default, when a new
library is created, all of the following rights are granted:

Public Right Description

Add Allows users to add new documents to the library.

Change Allows users to make changes to existing documents in the library.

Delete Allows users to delete documents, regardless of who created them or has rights to the

documents. However, to be able to delete a document, users must also have rights to
locate and modify the document (View and Change rights), in addition to the Delete right.

View By itself, this right allows searching, viewing, or copying documents, but does not permit
editing them. Copies can be edited, because a copy is saved as a separate document.
Therefore, editing a copy does not affect the original document or any of its versions.

Designate Official Allows any version of a document to be designated as the official version. The official
Version version, which is not necessarily the most recently edited version, is the one located in
searches.

The official version is usually determined by the creator or author of the document.
However, the official version can be designated by the last user to edit the document (if
the user has this right). A user also needs the Change right to the document to be able to
designate an official version.
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Public Right Description

Reset In-Use Flag The In-Use flag protects against data loss by preventing multiple users from concurrently
opening the same document. The purpose of the Reset In-Use Flag right is to allow a
user or librarian to reset a document’s status when the document is in use by someone
else or when it is erroneously flagged as in use.

In the GroupWise client the document properties Status field displays the current In-Use
flag setting for a document. The Status field is automatically set to In Use when a
document is opened and reset to Available when a document is closed. There can also
be other values, such as Checked Out. A document cannot be checked out when its
status is In Use.

There are a variety of reasons for which you might want to restrict certain library rights, including;:
¢ Your libraries are specialized by department and you want to restrict access to sensitive libraries,
such as a payroll library.

¢ Your libraries are distributed across multiple post offices and you want to restrict the scope of
user searches to only the libraries they should use, thereby speeding up searches.

¢ Your libraries are distributed across multiple servers and you want to minimize network traffic.

¢ You have some users who should have more rights than other users to certain libraries.
To restrict public rights while granting individual rights:

1 In ConsoleOne, browse to and right-click the Library object, then click Properties.

2 Click GroupWise > Rights to display the Rights page.

3 In the Public Rights box, deselect the rights that you want to remove from all users.

4 Click Add, then browse to and select the users who need to have rights to the library.

If the number is large, you might find it easier to create a distribution list for users who need
rights. Then you can select one distribution list rather than multiple users. See Chapter 18,
“Creating and Managing Distribution Lists,” on page 285

5 In the Individual or Distribution List Rights box, select the users or distribution lists to grant rights
to.

6 Below the list, select the rights that you want to grant.

Properties of Development Library E|
GroupWise ~ | General | NDS Rights ~ | cther | Rights to Files and Folders |
Rights
Public Rights
IV agd [V Wiew
¥ Change [+ Set official version
[V Delete [~ Resetin-use flag

Inddivicdusl or Distribution List Rights

adhartapalan Marketing P

jstevens Sales.Provol
mbarnard Development Provol

[~ Manage (Librarian) sl Delete
I =
I ~
¥ [+ Reset in-use flag
Page Options... [e]l% Cancel Apply Help
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In the first example, only one user is granted the Reset In-Use Flag right.

Properties of Development Library E\
GroupWise ~ | Gereral | NDS Rights = | Citier | Rights to Files and Folders |
Rights
Public Rights
[~ add ™ Wiews
[ Changs [ Set official version
I~ Delete I Reset in-use flag

Indiviciual or Distribution List Rights

Engiheers Developmerit Pravol

[~ Manage (Libratian) ndl Delete
V¥ et I e
¥ Change [V Set official version
v Delete [V Reset in-use flag Q
Page Options... [e]l% | Cancel | Apply ‘ Help |

In the second example, only members of the Engineers group are granted any rights to the
Development Library.

7 Click OK to save the updated library rights information.

22.6.4 Adding and Training Librarians

When you first create a library, you might for convenience assign yourself as the initial librarian. As
library activity increases you can add librarians, and if desired, remove yourself as a librarian.

¢ “Understanding the Role of the Librarian” on page 350
¢ “Setting Up a Librarian GroupWise Account (Optional)” on page 353

¢ “Assigning Librarians” on page 353

Understanding the Role of the Librarian

Keep in mind the following when assigning librarians:

¢ “Librarian Identity” on page 350
¢ “Librarian Functions” on page 351

¢ “Librarian Rights” on page 351

Librarian Identity

Any GroupWise user with access to a library can be a librarian for the library. You can have multiple
librarians for a single library. You can also assign a single user as a librarian for multiple libraries.
Because being a librarian entails additional functions and rights in the library, you should choose
responsible users as librarians.
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Librarian Functions
A librarian can perform the following actions:

¢ Check out a document without a copy.

¢ Modify the properties of any document in the library.

¢ Copy documents to another library.

¢ Delete both documents and properties.

¢ Reassign document creators and authors to handle orphaned documents

¢ Reset a document’s status (change the In-Use flag).

¢ View all activity log records of any document in the library.

¢ Restore document BLOBs from backup.

¢ Perform mass operations, such as moving, deleting, archiving, and changing properties.

¢ Perform searches (but not full-text searches) on documents that are not available for searching
by regular users.

¢ Use GroupWise third-party APIs to generate reports on all library documents.
All operations available to a normal user are also available to a librarian, as long as the security

requirement discussed under “Librarian Rights” on page 351 is not compromised. The intention is
that librarians can modify their own documents and document properties.

All actions taken by a librarian are written to a document’s activity log.

Unless the librarian’s own GroupWise user ID is in the Author or Security fields, a librarian cannot
perform the following functions:

¢ Open a document

¢ View a document

¢ Save a document

¢ Check out a document with a copy

To help new librarians get started, you should explain these librarian functions to them. You can also
refer new librarians to the “librarian users” topic in the GroupWise client help.

Librarian Rights

In addition to the six public rights, libraries also have a Manage right. When you grant the Manage
right to a GroupWise user, you designate that user as a librarian. The Manage right gives the librarian
full access to the properties of every document in the library. However, the Manage right does not
grant the librarian direct access to the content of any document.

Because a librarian has full access to document properties, the librarian could add his or her own
personal GroupWise user ID to the Author or Security field of a document, thus gaining access to the
document’s content. However, a high-priority email notification would automatically be sent to the
original person listed in the Author field informing him or her of the action by the librarian.
Therefore, document privacy is maintained.

The following table lists the various librarian functions, and whether an email notification is sent if
the function is performed.
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Librarian Function Notification?

Modify the Author or Security fields High-priority email to the author
Copy a document High-priority email to the author
Delete a document High-priority email to the author

Replace a document with a copy from backup  High-priority email to the author

Perform a mass document operation (copy, Mass operation emails
move, delete, or archive documents; modify
document properties)

Reset a document’s status (In-Use flag) None
Check out a document without a copy None
View the activity log of any document None
Generate reports on any documents (using None

GroupWise third-party APIs)

Mass operation notifications do not specify what action was taken by the librarian; they only specify
that an action was taken.

The following table lists the document property fields that the librarian has rights to modify, and
whether an email notification is sent if the field is modified.

Property Field Notification?
Subject No
Author Yes
Security (sharing list) Yes
Document Type No
Version Description No
Custom Fields No
File Extension No
Official Version No
Current Version No

If you remove the Manage right from a user, you must manually deselect any rights that the user
gained from being made a librarian that the user did not previously have.
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Setting Up a Librarian GroupWise Account (Optional)

The Manage right is always in effect for those users who have been assigned as librarians. However,
there might be times librarians want to act on their own accord without the possibility of seeing or
modifying documents that belong to other users.

To allow users assigned as librarians to act as normal GroupWise users, you could create a single
librarian account for a library and have users who need to perform librarian tasks log in using the
librarian GroupWise account and password instead of their own.

If users assigned as librarians log in under a librarian GroupWise account, they do not have access to
any documents they would normally have access to under their own accounts, except by altering the
Author or Security fields.

Assigning Librarians

To add librarians to a library:

1 In ConsoleOne, browse to and right-click the Library object, then click Properties.
2 Click GroupWise > Rights to display the Rights page.

3 Click Add, browse to and select the users that you want to assign as librarians, then click OK to

return to the Rights page.
Properties of Development Library El
GroupWwise « | Genersl | MNDS Rights: vl Cther | Rights to Files and Folders I
Right=
Public Rights
IV Add [ “ignw
¥ Change [+ Set official version
¥ Delete [+ Reset in-use flag

Individual or Distribution List Rights

aramirez Sales Provo2
fthompson Marketing Prova3

{pangiinan Development Provol

[ Manage (Librarian) Addl Delete
3 ¥
¥ ~
I =
Page Options... oK | Cancel | Apply | Help

4 In the Individual or Distribution List Rights box, select the librarian users, select Manage (Librarian),
then click OK to save the library rights changes.
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22.6.5

22.6.6

22.6.7

Maintaining Library Databases

The Mailbox/Library Maintenance feature of ConsoleOne offers database maintenance features to
keep your library and document databases in good condition. See Chapter 28, “Maintaining Library
Databases and Documents,” on page 415. It also helps you manage the disk space occupied by library
and document databases and document storage areas. See Section 30.4, “Reducing the Size of
Libraries and Document Storage Areas,” on page 428.

When document creators or authors are removed from your GroupWise system, orphaned
documents might be left behind. See Section 23.4.3, “Handling Orphaned Documents,” on page 385.

To supplement your library maintenance procedures, you should back up your libraries and
documents regularly. See Section 31.3, “Backing Up a Library and Its Documents,” on page 432.

Moving a Library

You cannot move a Library object from one location to another in the eDirectory tree. To accomplish
the equivalent, you can create a new library in the desired location, make yourself a librarian in both
libraries, use a mass move operation in the GroupWise client to move the library’s documents from
the old library into the new library, and then delete the old library. For instructions for these tasks,
see:

¢ Section 22.2, “Setting Up a Basic Library,” on page 326

¢ Section 22.6, “Managing Libraries,” on page 342

¢ “Managing Groups of Documents” in “Document Management” in the GroupWise 2012 Windows

Client User Guide

As an alternative to moving the library, you can move just its document storage areas. See “Moving a
Document Storage Area” on page 346.

Deleting a Library

You should not delete a library until you make sure that all documents still in the library are no
longer needed.

1 In ConsoleOne, browse to and right-click the Post Office object that owns the library to delete,
then click Properties.

2 Click GroupWise > Libraries to display the Libraries page.
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22.7

22.7.1

Properties of Development ﬁl

{GroupWise ~ i| MDS Rights - | Cther I Rights to Files and Folders |
RN

Libraries: |

Development Library Groudise

Page Options | Cancel | Help |

3 Select the library to delete, then click Delete.
All document storages areas and documents are deleted along with the library.

4 Click OK to close the Libraries page and complete the deletion of the library.

Library Worksheets

¢ Section 22.7.1, “Basic Library Worksheet,” on page 355
¢ Section 22.7.2, “Full-Service Library Worksheet,” on page 356

Basic Library Worksheet

For instructions on how to use this worksheet, see Section 22.1, “Planning a Basic Library,” on
page 324.

Iltem Explanation

1) eDirectory Container: Specify the eDirectory container where you will create the Library object. This
could be the same container as the post office that the library is assigned to. The
Library object cannot later be moved to a different location.

For more information, see Section 22.1.2, “Determining the Context for the Library
Object,” on page 324.

2) Library Name: Specify a name for the new library. Choose the name carefully. After the library is
created, it cannot be renamed.

For more information, see Section 22.1.3, “Choosing the Library Name,” on
page 324.

3) Post Office: Indicate which post office the library will belong to. A library cannot later be
assigned to a different post office.

For more information, see Section 22.1.1, “Selecting the Post Office That the
Library Will Belong To,” on page 324.
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Iltem Explanation

4) Store Documents at the  Mark No unless you are absolutely certain you will never need to move the

Post Office? documents stored at the post office
* No For more information, see Section 22.1.4, “Deciding Where to Store Documents,”
on page 325.
* Yes

5) Document Storage Area Provide a brief description for the document storage area, including such
Description: information as to which post office it belongs, its current capacity in megabytes,
and the types of documents that might be stored in it.

For more information, see Section 22.1.4, “Deciding Where to Store Documents,”
on page 325.

6) Document Storage Area If you are not storing documents at the post office, specify the document storage
Path: area for the library.

For more information, see Section 22.1.4, “Deciding Where to Store Documents,”
on page 325.

7) Library Description: Provide a description for the library to help you identify its function in the system.

For more information, see Section 22.1.3, “Choosing the Library Name,” on
page 324.

8) Display Name: Specify the library name you want users to see in the GroupWise client, if it is
different from the Library object name.

For more information, see Section 22.1.3, “Choosing the Library Name,” on
page 324.

22.7.2 Full-Service Library Worksheet

For instructions on how to use this worksheet, see Section 22.3, “Planning Full-Service Libraries,” on

page 328.

Item Explanation

1) eDirectory Container: Specify the name of the eDirectory container where you will create
the Library object. This could be the same container as for the post
office that owns the library. The Llbrary object cannot later be moved
to a different context.
For more information, see Section 22.3.3, “Determining the
Contexts for Library Objects,” on page 332.

2) Library Name: Specify a name for the new library. Choose the name carefully. After

the library is created, it cannot be renamed.

For more information, see Section 22.3.4, “Choosing Library
Names,” on page 332.
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Item

Explanation

3) Post Office:

4) Document Usage Estimate:

a) Number of DMS users:

b) Average number of documents per
user:

c) Average document size (bytes):

d) Average number of versions per
document:

e) Total: (multiply atimes b times c
times d)

5) Document Storage Area Description:

6) Document Storage Area Path:

7) Library Description:

8) Start Version Number:

* 0
1

9) Maximum Archive Size:

10) Display Name:

Specify the post office that the library will belong to. A library cannot
later be assigned to a different library.

If you will using a centralized library configuration and you have not
yet created the DMS post office, follow the instructions in

Chapter 11, “Creating a New Post Office,” on page 173 before you
begin creating libraries.

For more information, see Section 22.3.1, “Deciding Which Libraries
to Create,” on page 328.

Calculate how much disk space the new library will need in order to
help you select a location where you will store documents.

For more information, see Section 22.3.5, “Deciding Where to Store
Documents,” on page 333.

Provide a brief description for the document storage area, including
such information as which library it belongs to, its current capacity in
megabytes, and the types of documents stored in it.

For more information, see Section 22.3.5, “Deciding Where to Store
Documents,” on page 333.

Specify the UNC path to the location where you want to create the
initial document storage area for the post office.

For more information, see Section 22.3.5, “Deciding Where to Store
Documents,” on page 333.

Provide a brief description for the new library, including what post
office it belongs to, what types of documents will be stored in it, and
so on.

For more information, see Section 22.3.1, “Deciding Which Libraries
to Create,” on page 328.

Select 0 or 1.
For more information, see Section 22.3.6, “Setting Document

Version Options,” on page 335.

Specify the maximum number of bytes to allow per archive directory.
Use a size that conforms with your backup strategy and backup
medium requirements.

For more information, see Section 22.3.7, “Figuring Maximum
Archive Directory Size,” on page 335.

Specify the library name you want users to see in the GroupWise
client, if it is different from the Library object name.

For more information, see Section 22.3.4, “Choosing Library
Names,” on page 332.
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Item

Explanation

11) Restrict Public Library Rights:
+ Add
+ Change
¢ Delete
+ View
+ Designate Official Version

* Reset In-Use Flag

12) Librarians:

13) Dedicated POA for Indexing
+ Yes
* No

14) Set Up Integrations

* Yes

* No

Cross out any public library rights you do not want all users to have.

For more information, see Section 22.3.1, “Deciding Which Libraries
to Create,” on page 328 or Section 22.3.6, “Setting Document
Version Options,” on page 335.

List any users you want to have full rights to all documents in the
library.

For more information, see Section 22.3.8, “Designating Initial
Librarians,” on page 336.

Mark whether or not you want to configure and run a separate POA
dedicated to indexing documents.

For more information, see Section 22.3.10, “Determining Your
Indexing Needs,” on page 338.

Mark whether or not you need to manually set up integrations.

For more information, see Chapter 24, “Integrations,” on page 387.
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3 Creating and Managing Documents

23.1

23.1.1

GroupWise Document Management Services (DMS) lets Windows client users create documents
with integrated applications, save them, then easily locate a specific document later without knowing
the application, a specific document name, or the document’s physical location. Windows client users

can create, share, locate, edit, view, and check out documents that are created under the management
of GroupWise DMS.

¢ Section 23.1, “Adding Documents to Libraries,” on page 359
¢ Section 23.2, “Organizing Documents in Libraries,” on page 362
¢ Section 23.3, “Indexing Documents in Libraries,” on page 374

¢ Section 23.4, “Managing Documents in Libraries,” on page 383

Adding Documents to Libraries

After you set up one or more libraries, users can add new documents to any library to which they
have rights. They can also import existing documents into the GroupWise DMS system.

¢ Section 23.1.1, “Creating New Documents in the GroupWise Windows Client,” on page 359

¢ Section 23.1.2, “Importing Existing Documents into the GroupWise DMS System,” on page 360
¢ Section 23.1.3, “Managing Groups of Documents,” on page 361

Creating New Documents in the GroupWise Windows Client

1 Click File > New > Document.

New Document E]@]
(%) Select an application
() Select a Groupwise template
) Select afile

Applications:

Bitmap Image

Microsoft Access Application
OpenDacument Drawing
Openbocument Presentation
OpenDocument S preadshest
OpenDocument Text

‘wave Sound M,

Library where document will be stored:

Development Library (Default] v

2 Select the program you want to use to create the document, select the library where you want to
store the document, then click OK.

3 In the New Document dialog box, type a brief description of the document.
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23.1.2

360

New Document

Document subject:

[ 0pen document now

1] l [ Cancel ] [ Properties...

4 To set document properties, click Properties.

New Document

Document |Ve|sion Sharing | Activity Lag

Library:

Drocument number:
Subiject:
Dacument tppe:
Author:

Creatar:

Date created:
Official version:

Current version

Development Librany

”Ducumenl |

‘ provo. development. mpalu

IZ [

1/19/2012 10:03 AM
1]

[ 0pen document now

5 Set the document properties as needed, then click OK.

The selected program starts so you can create a new document.

For more detailed information about creating documents in the GroupWise client, see “Creating
Documents” in “Document Management” in the GroupWise 2012 Windows Client User Guide. You can
also look up “documents” in the GroupWise client help.

Some users might have existing documents that they want to manage by adding them to a
GroupWise library.

To import documents using the GroupWise Windows client:

Importing Existing Documents into the GroupWise DMS System

1 Click File > Import/Export > Import Documents.
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Select Files to Import El

Files ta import:

Novell.

[ dd Indivicial Files... | [ Add Entire Directoy...

Quick impart [Recommendad]

Copies documents to your default ibrary and creates document
references in the falder you specify.

Cancel

2 Click Add Individual Documents, browse to and select the documents to add, then click OK.

or

Click Add Entire Directory, browse to and select a directory containing documents to import, then
click OK.

For additional instructions about creating documents in the GroupWise client, see “Importing
Documents into a GroupWise Library” in “Document Management” in the GroupWise 2012 Windows
Client User Guide. You can also look up “import documents” in the GroupWise client help.

23.1.3 Managing Groups of Documents

As users add documents and your GroupWise DMS system grows, your librarians might need to
assist users in managing large groups of documents. If you have not yet assigned librarians to your
GroupWise libraries, see Section 22.6.4, “Adding and Training Librarians,” on page 350.

To manage large groups of documents in the GroupWise Windows client:

1 Click Tools > Mass Document Operations.

Mass Document Operations §|

Select the operation you want to perform. The operation will affect all versions of &
document

Operation
(3) Change properties () Change sharing
) Move () Copy
() Delete

Selection method

(%) Use Find/Advanced Find to select documents
(" Use Find by Example to select documents

() Use documents listed in a file

2 Select the operation to perform on the group of documents:
¢ Change properties

* Move
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¢ Delete
¢ Change sharing
¢ Copy

3 Select the method for identifying the group of documents to perform the operation on:

*

Use Find/Advanced Find to select documents
¢ Use Find by Example to select documents
¢ Use currently selected documents
¢ Use documents listed in a file.
For additional instructions about creating documents in the GroupWise client, see “Managing

Groups of Documents” in “Document Management” in the GroupWise 2012 Windows Client User
Guide. You can also look up “mass document operations” in the GroupWise client help.

IMPORTANT: You must be in Online mode in the GroupWise Windows client in order to perform
mass document operations.

23.2 Organizing Documents in Libraries

Because documents are stored in a database structure, information can be associated with each
document that is not part of the document itself. This additional information is stored as document
properties.

¢ Section 23.2.1, “Customizing Document Properties,” on page 362

¢ Section 23.2.2, “Defining Related Document Properties,” on page 371

NOTE: Document properties cannot be set in ConsoleOne on Linux. However, you can use
ConsoleOne on Windows to set document properties for libraries that are located on Linux.

23.2.1 Customizing Document Properties

For a summary of document properties, see Section 21.3.1, “Document Properties,” on page 318. To
review, the following document properties are provided by default:

Author

Creator

Current Version Number
Date Created

Document Number
Document Type

Official Version Number
Subject

The default document property types cannot be deleted. Except for the Document Type property,
they cannot be modified. However, you can add custom document types as needed.

¢ “Customizing the Default Document Type Property” on page 363
¢ “Planning Custom Document Properties” on page 364

¢ “Adding Custom Document Properties” on page 366
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¢ “Planning Custom Lookup Tables for Custom Document Properties” on page 368

¢ “Adding Custom Lookup Tables” on page 369

Customizing the Default Document Type Property

The Document Type property is the only default document property that you can modify. For a
review of document types, see Section 21.3.2, “Document Types,” on page 319. You must have at least
one document type, because it is a required document property field.

To modify the Document Type property for all libraries in a post office:

1 In ConsoleOne on Windows, browse to and select the post office that has libraries where you
want to modify the Document Type property.

2 Click Tools > GroupWise Utilities > Document Properties Maintenance.

‘%« Document Properties Maintenance

File Edit Help
K #|2|=|

oA Provol Sales
> W,

- -8 Lookup Tables

If you expand Libraries and select each library, you see that each library has the Document Type
property. It is required.

3 Expand Lookup Tables, then select Document Type.

‘@ Document Properties Maintenance

File Edit Help
I +|2|=
g PravoZ. Sales Document Type b aimum ersions | Expiration Action | Document Life
: 'ﬁ Libraries Agenda 100 Archive 99 A
| .““'v Sales Library Contract 100 Archive 93
- %] Lookup Tsbles ) Conresp 10 Archive a3
PRI ocument Type] Docurent 100 Archive 365
Expenze 100 Archive 93
Form 10 Archive a3
Graph 100 Archive 99
Image 100 Archive 93
Mema 1 Delete a3
Minutes 100 Archive 93
Mise 10 Archive an
Project 100 Archive 99
Fropozal 100 Archive 99
Report 100 Archive 93
Template 100 Archive 365 v
< >

The lookup table defines the list of choices offered to users when they select a document type, no
matter which library in the post office they are creating the document in.
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4 To add a new document type, click Edit > Add. In the Value field, type the new document type,
click Add, then click Close.

Lookup Entry: Document Type El

WVale: Il Addd

Espiration Action
M arimum Yersions: 100  Archive

Document Life [days]:  |365 " Retain
" Delete

Cloze ‘ Help |

5 To edit an existing document type, click Edit > Edit. Change the settings as needed, click Update,
then click Close.

Lookup Entry: Document Type El

alue:

E =piration Action

Mawimum Versions: 100 & Archive

Document Life [days]: {99 " Retain
" Delete

Cancel ‘ Help |

For more details about the fields associated with the Document Type property, see Section 21.3.2,
“Document Types,” on page 319.

6 To delete a document type, select the document type, click Edit, then click Delete.

Planning Custom Document Properties

When you need to add custom document properties, print the “Custom Document Properties
Worksheet” on page 365. One copy of the worksheet accommodates three new document properties.

The following table describes the fields and values associated with custom document properties:

Document Property  Field Values

Field
Property Field: The document property field is the label that GroupWise client users see in the
document Properties dialog box.
When you create a new document property, you can provide a description as well.
However, the description displays only in ConsoleOne, not in the GroupWise client.
Read-Only? Yes: The document property field displays information, but it is not accessible to
users.
No: Users can type in the document property field.
Required? Yes: The user must supply a value for the document property.
No: The user can leave the document property field blank.
Hidden? Yes: The document property field is not displayed in the GroupWise client interface.

No: The document property field is displayed in the GroupWise client interface.
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Document Property  Field Values

Field

Lookup Table: A lookup table is required for a custom document property only when you want to offer
the user a list of choices, rather than having the user type in the setting. The lookup
table guarantees that the user provides a valid setting. For more information, see
“Planning Custom Lookup Tables for Custom Document Properties” on page 368.

Related Property: A related property is required for a custom document property only when you create a
lookup table that references a related lookup table. For more information, see
Section 23.2.2, “Defining Related Document Properties,” on page 371.

Data Type: Binary: An Object API reads and writes this information
Date: Displayed in the Windows format selected by the user
Number: Numerical only
String: Alphanumeric

Maximum Length: For the String data type, you can specify the maximum number of characters allowed
in the string. The longest possible string is 65535 alphanumeric characters.

Case: For the String data type, you can control how the user’s input is handled:
Upper: Forces entries to display in uppercase
Lower: Forces entries to display in lowercase
Mixed: Allows alphabetical characters to be displayed as typed

Minimum Value: For the Number data type, you can specify a minimum acceptable value.

Maximum Value: For the Number data type, you can specify a maximum acceptable value.

Parent: If the new document property is related to an existing document property in a parent-

child relationship, you must specify the parent document property. For more
information, see Section 23.2.2, “Defining Related Document Properties,” on
page 371.

Use copies of the “Custom Document Properties Worksheet” on page 365 to plan the custom
document properties you want to add to libraries.

If you need to create one or more lookup tables for your custom document properties, follow the
instructions in “Planning Custom Lookup Tables for Custom Document Properties” on page 368 and
“Adding Custom Lookup Tables” on page 369. Lookup tables used by new document properties
should exist before you create custom document properties.

Then continue with “Adding Custom Document Properties” on page 366.

Custom Document Properties Worksheet

For instructions on how to use this worksheet, see “Planning Custom Document Properties” on
page 364.

Item Custom Document Custom Document Custom Document
Property Property Property

1) Post Office:

2) Libraries:
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Item Custom Document

Property

Custom Document
Property

Custom Document
Property

3) Property Label:
4) Description:
5) Read-Only?
* Yes
* No
6) Required?
* Yes
* No
7) Hidden?
* Yes
* No
8) Lookup Table:
9) Data Type:
¢ Binary
¢ Date
+ Number
* String
10) Maximum Length:
11) Case:
¢ Mixed
* Upper
¢ Lower
12) Minimum Value:
13) Maximum Value:

14) Parent:

Adding Custom Document Properties

After you have determined what new document properties will meet the needs of your DMS system,
as described in “Planning Custom Document Properties” on page 364, and if necessary you have
created lookup tables for your new document properties, as described in “Planning Custom Lookup

Tables for Custom Document Properties” on page 368 and “Adding Custom Lookup Tables” on
page 369, you are ready to add new custom document properties.

To add new custom document properties:

1 In ConsoleOne on Windows, browse to and select the Post Office object that owns the library for

which you are creating custom document properties (worksheet item 1).

2 Click Tools > GroupWise Ultilities > Document Properties Maintenance.

GroupWise 2012 Administration Guide



‘« Document Properties Maintenance

File Edit Help

=P

oA Provod Sales

- -%:Lookup :Tab\es

3 Expand Libraries, then select the library for which you are creating custom document properties

(worksheet item 2).

‘st Document Properties Maintenance

File Edit Help
B #|2|=|
g Provo2 Sales Property Field Data Tepe | Lookup Table Required |Read-only | Hidden |Max Lengl Text Caze
7- Tl Libraies | [Authar String Yes Mo Mo 256 Mired
[ ) - ol Libran i | [ String Mo es No 256 Mired
- - By Lookup Tables Cumertt Ver # Murmber Mo es No . .
Date Created Date Mo e No
Document Mumber — Number Mo ez No - -
Dacument Type String Document Type  Yes Ma Ma B5535 tdined
Official Ver # Nurnber Mo e No - -
Subiject String Mo Mo Mo B8535 Mixed
d 3

4 Click Edit > Add to display the Document Property Definition dialog box.

Document Property Definition rz|
Property Label || ok |
Description; | Cancel
[ Read-only
I” Required Help
I” Hidden

Lookup T able: | J

Related Praperty: |[none] j

Data Type: |Slring j

b aximum Length: |55535

Case: |Mixed ﬂ

Fields vary according to data type.

5 Fill in the fields (worksheet items 3 through 14).

6 Click OK to create the new custom document property.

In the Document Properties Maintenance window, the new document property is listed in

alphabetical order. In the GroupWise client, custom document properties are listed after default
document properties, in the order in which they are added to the library.

7 Repeat Step 4 through Step 6 for each new custom document property.

When users next create documents in the library, the new custom document properties will be

available to them.
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Planning Custom Lookup Tables for Custom Document Properties

A lookup table is required for a custom document property only when you want to offer the user a
list of choices, rather than having the user type in the setting. The lookup table guarantees that the
user provides a valid setting.

Lookup tables are defined for the post office, so that multiple libraries in the post office can reference
the same lookup tables.

When you need to provide lookup tables for custom document properties, print the “Custom Lookup
Tables Worksheet” on page 369. One copy of the worksheet accommodates three new lookup tables.

The following table describes the fields and values associated with lookup tables:

Lookup Table Field Field Values

Lookup Table Name:  The lookup table name identifies the lookup table when you are assigning it to a
property field.

If the lookup table pertains to only one document property, you can name the lookup
table the same as the document property. For example, the default property Document
Type uses a lookup table named Document Type.

However, lookup tables can be used by multiple document properties. For example,
you could have a lookup table named Project used by document properties named
Primary Project and Secondary Project.

When you create a new lookup table, you can provide a description as well. If the
lookup table name does not match a document property, you could indicate what
document properties use the lookup table.

Related Table: A related table is required for a lookup table only when you want to define related
properties. For more information, see Section 23.2.2, “Defining Related Document
Properties,” on page 371.

Data Type: Binary: An Object API reads and writes this information
Date: Displayed in the Windows format selected by the user
Number: Numerical only
String: Alphanumeric

Maximum Length: For the String data type, you can specify the maximum number of characters allowed
in the string. The longest possible string is 65535 alphanumeric characters.

Case: For the String data type, you can control how the user’s input is handled:

Upper: Forces entries to display in uppercase

Lower: Forces entries to display in lowercase

Mixed: Allows alphabetical characters to be displayed as typed
Minimum Value: For the Number data type, you can specify a minimum acceptable value.
Maximum Value: For the Number data type, you can specify a maximum acceptable value.

Lookup Table Entries:  The lookup table entries are the settings that users will choose from when they set the
custom document property.
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Use copies of the “Custom Lookup Tables Worksheet” on page 369 to plan the lookup tables you
need in order to provide values for new custom document properties. If you need to use related
properties, follow the instructions in Section 23.2.2, “Defining Related Document Properties,” on
page 371. Then continue with “Adding Custom Lookup Tables” on page 369.

Custom Lookup Tables Worksheet

For instructions on how to use this worksheet, see “Planning Custom Lookup Tables for Custom

Document Properties” on page 368.

Item

Custom Lookup Table

Custom Lookup Custom Lookup Table
Table

1) Post Office:

2) Property Label:

3) Lookup Table Name:

4) Description:
5) Related Table:
6) Data Type:

+ Binary

+ Date

¢ Number

¢ String

7) Maximum Length:

8) Case:

+ Mixed
* Upper
+ Lower

9) Minimum Value:

10) Maximum Value:

11) Lookup Table Entries:

Adding Custom Lookup Tables

After you have determined what new lookup tables and lookup table entries you need to
accommodate your new custom document properties, as described in “Planning Custom Lookup
Tables for Custom Document Properties” on page 368, you are ready to add new lookup tables.

1 In ConsoleOne on Windows, browse to and select the Post Office object that owns the libraries
for which you are creating lookup tables (worksheet item 1).

2 Click Tools > GroupWise Utilities > Document Properties Maintenance.
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‘« Document Properties Maintenance
File Edit Help

=P

oA Provod Sales
G20 << L ibrarie

- -%:Lookup :Tab\es

3 Select Lookup Tables, then click Edit > Add to display the Lookup Table Definition dialog box.

Lookup Table Definition rz|
Table Namme: |\ 0K |
Description: | Cancel
BRelated Table: |[nnne] J

Help
Data Type |Smng j Q
Mauimum Length: |55535
LCase: |M|xed j

Fields vary depending on data type.
4 Fill in the fields (worksheet items 3 through 10).
5 Click OK to create the new lookup table.
6 Select the new lookup table, then click Edit > Add to display the Lookup Entry dialog box.

. Lookup Entry

7 In the Value field, type one of the document property settings you want to offer to users
(worksheet item 11), then click Add.

8 Repeat Step 7 for all the lookup table entries listed on your worksheet for this lookup table, then
click Close.

9 Click OK to create the custom lookup table.
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23.2.2

Defining Related Document Properties

When document properties are related, your choice for the first property determines the settings you
are offered for the second property. The user’s selection in the first field determines what choices
were offered in the second field.

Related document properties are set up by creating related lookup tables. Complete the following
tasks to set up related document properties:

¢ “Planning Related Document Properties” on page 371
¢ “Creating Related Lookup Tables” on page 373
+ “Setting Up Related Document Properties” on page 373

Planning Related Document Properties

Related document properties use a parent-child relationship. A parent property can have multiple
child properties, but a child property can belong to only one parent. The relationship can include
only two levels. A parent property cannot function as a child and a child property cannot function as
a parent. The default document properties cannot participate as related properties.

In the Development Library example above, the Product document property would be the parent
property and the Component document property would be the child property. If the Development
Library belonged to Novell, products would include GroupWise, Open Enterprise Server,
ZENworks, and so on. When users selected GroupWise as the product, listed components could
include the GroupWise client, the agents, GroupWise system administration, and so on. Or you could
let users type in whatever components they wanted.

When you need to set up related document properties, print the “Related Document Properties
Worksheet” on page 372. One copy of the worksheet accommodates one pair of related property
fields, one parent lookup table, and one child lookup table (optional).

The following table describes the document properties and lookup tables that are required in order to
set up related document properties:

Properties and Tables Description

Parent Document Property The parent document property is the user’s first selection. In the Development
Library example above, the parent document property is Product.

Child Document Property The child document property is the user’'s second selection, based on the first
selection. In the Development Library example above, the child document
property is Component.

Parent Lookup Table The entries in the parent lookup table provide the choices offered to the user in
the parent document property field. In the Development Library example above,
the user could select from GroupWise, Open Enterprise Server, and ZENworks
in the Product field.

Child Lookup Table The entries in the child lookup table provide the choices offered to the user after
a choice from the parent lookup table has been selected. In the Development
Library example above, if the user selected GroupWise in the Product field, the
child lookup table would provide choices such as Agents, Client, and Admin in
the Component field.

The child lookup table is not required if you want to allow the user to type in
anything they want in the child document property field.
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Use copies of the “Related Document Properties Worksheet” on page 372 to plan the related
document properties you want to use. One copy of the worksheet accommodates one pair of related
properties. Continuing with the Development Library example, a filled-in worksheet might look like

this:

Item Setting Item Setting

1) Parent Document Property Name: 4) Child Document Property  Property Name:

Property Product Component

2) Parent Lookup Table Table Name: Product 5) Child Lookup Table Table Name:

Component

3) Parent Lookup Entries  (required) 6) Child Lookup Entries (optional)
Parent Entry: Child Entries: Admin
GroupWise Agents Client
Parent Entry: Open Child Entries:
Enterprise Server eDirectory Servers
Parent Entry: ZENworks Child Entries:

Desktops Servers

When you have finished planning related properties and their associated lookup tables, you should
print and fill in a worksheet for each for each new related property, as described in “Planning
Custom Document Properties” on page 364, and for each new lookup table, as described in
“Planning Custom Lookup Tables for Custom Document Properties” on page 368.

Then you are ready to continue with “Creating Related Lookup Tables” on page 373.

Related Document Properties Worksheet

For instructions on how to use this worksheet, see “Planning Related Document Properties” on

page 371.

Item Setting Item Setting

1) Parent Document Name: 4) Child Document Property Name:

Property

2) Parent Lookup Table Name: 5) Child Lookup Table Name:

3) Parent Lookup Entries (required) 6) Child Lookup Entries (optional)
Entry: Entries:
Entry: Entries:
Entry: Entries:
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Creating Related Lookup Tables

If you are supplying the choices for both related fields, you need both a parent lookup table and a

child lookup table. If you are going to have users type information into the child property field, then
you only need to create the parent lookup table. You should create lookup tables before creating the

document properties that use them.

¢ “Creating the Parent Lookup Table” on page 373

¢ “Creating the Child Lookup Table (Optional)” on page 373

Creating the Parent Lookup Table

1 Create a new lookup table, as described in Step 1 through Step 5 in “Adding Custom Lookup

Tables” on page 369. Use worksheet item 2 in the Table Name field. Leave the Related Table field

set to (none).

2 Add entries to the new lookup table, as described in Step 6 through Step 8 in “Adding Custom

Lookup Tables” on page 369. Use the entries listed under worksheet item 3 in the Value field.

3 Continue with “Creating the Child Lookup Table (Optional)” on page 373.

or

If you are going to have users type information into the child property field, rather than
selecting from a predefined list, skip to “Setting Up Related Document Properties” on page 373

Creating the Child Lookup Table (Optional)

1 Create a new lookup table, as described in Step 1 through Step 5 in “Adding Custom Lookup

Tables” on page 369. Use worksheet item 5 in the Table Name field. Use worksheet item 2 in the
Related Table field to link the child table to the parent table.

2 Select the new lookup table, click Edit, then click Add to display the Lookup Entry dialog box.

Thiz table iz a child in a relationship. Select a value from the parent

table, then enter the child table's values.

Parentvalue: | -

Walue: ‘

Cloze ‘

Help

Add

3 Select a Parent value.

4 In the Value field, type one of the child lookup table entries for the selected parent value

(worksheet item 6), then click Add.

5 Repeat Step 4 for each entry listed under worksheet item 6.

6 Repeat Step 3 through Step 5 for each parent value listed under worksheet item 3.

7 Continue with “Setting Up Related Document Properties” on page 373.

Setting Up Related Document Properties

After you have created related lookup tables, you are ready to set up the related document properties
that use them. A few document property fields are required settings in the context of related

properties:

¢ Read-Only must be set to No.
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23.3

23.3.1

* Hidden must be set to No.

¢ Required must be set the same on the child property as it is on the parent property.
To set up related document properties:

1 Create the parent document property as described in “Adding Custom Document Properties” on
page 366. Use worksheet item 1 in the Property Label field. Use worksheet item 2 in the Lookup
Table field. Leave the Related Property field set to (none).

2 Create the child document property using the same procedure. Use worksheet item 4 in the
Property Label field. Use worksheet item 5 in the Lookup Table field. The Related Property field
should automatically display as worksheet item 1, showing that the child property is related to
the parent property.

Indexing Documents in Libraries

Documents stored in GroupWise libraries need to be indexed so users can locate documents using
the Find feature in the GroupWise Windows client. Your organization might need dedicated
indexing to minimize performance degradation and network congestion. You might also need
dedicated indexing so users can have prompt access to newly created documents.

¢ Section 23.3.1, “Understanding DMS Indexing,” on page 374

¢ Section 23.3.2, “Determining Your Indexing Needs,” on page 381

¢ Section 23.3.3, “Implementing Indexing,” on page 383

Understanding DMS Indexing

Before determining if you will need dedicated indexing, you should have a basic understanding of
how indexing works in GroupWise.

¢ “Index Storage” on page 374

¢ “Index Content” on page 375

¢ “Indexing Performed by the POA” on page 375

¢ “Indexing Cycle” on page 375

+ “Bandwidth Considerations” on page 376

¢ “Indexer Configurations” on page 376

Index Storage

When documents are indexed, the information is stored in QuickFinder indexes, which are located in
a library’s index subdirectory. A library’s QuickFinder index is partitioned into ten *.idx files.
Additionally, temporary *.inc (incremental) files are created that contain each day’s new index
information. The *.inc files are combined once per day into the *.idx files (usually at midnight).

In a system with multiple libraries, each library has its own set of QuickFinder index files. Depending
on how many libraries belong to a post office, and how many post offices with libraries are in your
GroupWise system, there can be many sets of QuickFinder index files.
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Index Content

Indexing can include a document’s full text (depending on its document type), and always includes
the document’s property sheet information (subject, author, version descriptions, and so on). Both
newly edited and newly created documents are indexed, which means indexing volume is
determined by how many existing documents are edited as well as how many new documents are
created.

Newly-created documents must be indexed before users can search for them. In setting up your
indexing strategy, you must know how quickly users will need access to newly-created documents.

The standard search is limited to the QuickFinder indexes in the user’s default library. But users can
choose to search for documents in other libraries to which they have access.

Indexing Performed by the POA

Indexing is among the many functions of the Post Office Agent (POA). To learn more about POA
functions, see Section 35.5, “Role of the Post Office Agent,” on page 477.

You can configure the POA for a post office to meet basic indexing needs. See Section 39.1,
“Regulating Indexing,” on page 573.

To support greater indexing needs, you can set up an additional POA that is dedicated to indexing.
See Section 39.5, “Configuring a Dedicated Indexing POA (Windows Only),” on page 577.

Not all libraries need dedicated POAs for indexing documents because indexing needs vary widely:

¢ In a small GroupWise system that has only one post office and one library, indexing can easily be
done by the one POA.

¢ In a post office with heavy DMS usage, one or more additional POAs can be dedicated to
indexing the documents.

¢ In alarge system that has a DMS post office housing all libraries in the GroupWise system,
indexing can be done by the DMS post office’s POAs.

A library can have more than one POA dedicated to indexing its documents. Because the library’s
QuickFinder index is partitioned into ten separate *.idx files, an organization that is extremely
document-intensive can boost indexing performance by using up to ten POAs dedicated to indexing.
These POAs do not conflict with each other in performing indexing because the *.idx and *.inc files
are locked during the indexing process.

You can temporarily use multiple indexing POAs for importing documents to speed up importing
time.

Indexing Cycle

The frequency of indexing is determined by the POA QuickFinder Interval setting. The default is
once every 24 hours at 8:00 p.m. This might be often enough in an organization where document
usage is minimal, or where searching for newly-created documents is not mission-critical.

You can specify the QuickFinder Interval setting in one-hour increments. For example, a setting of 1
would allow users to find documents created as recently as an hour ago. Whether you should use a
dedicated indexer at this frequency would depend on the volume (per hour) of documents that get

queued for indexing.
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You can set the QuickFinder Interval to 0 (zero) for continuous indexing. This is recommended for
organizations where document usage is intensive, or where users routinely need to find documents
that have just been created. If document usage is intensive in your organization, you might need a
separate indexer server dedicated to continuous indexing because the post office server’s
performance could become unacceptably slow if continuous indexing is performed on it.

Bandwidth Considerations

A primary factor in network speed is bandwidth. This is the amount of data that can be passed
through the network per second. If a network’s bandwidth is not sufficient for handling heavy traffic,
intensive document indexing can degrade network performance.

A number of elements affect network bandwidth, including cable types, transmission protocols, and
hardware. Ethernet networks are susceptible to wide fluctuations in transmission speed during
periods of heavy traffic. WANs can benefit from reduced network traffic.

If you locate a post office in close proximity to its users, you have less traffic through routers, bridges,
and other network hardware. Running GroupWise in client/server access mode also reduces network
traffic.

GroupWise users can add heavy messaging traffic to your existing network. DMS usage adds
document indexing traffic as well. These factors can create much more network bandwidth usage
than you have previously experienced.

Indexer Configurations

Following are five basic examples of how dedicated indexers can be configured. The examples do not
cover all possibilities. You can combine elements from these configurations to customize indexing for
your organization.

In all configuration examples, the post office can contain multiple libraries, although the Single
Server with One POA configuration is best suited to only one library. In the other configuration
examples, one or more POAs can be set up for indexing documents for all libraries in the post office.

¢ “Single Server with One POA” on page 376

¢ “Single Server with Multiple POAs” on page 377

¢ “Dedicated Indexer Server” on page 378

¢ “Dedicated Indexer Server on an Isolated Network Segment” on page 379

¢ “Dedicated DMS Post Office” on page 380

Single Server with One POA

One POA runs on the post office server and performs all POA functions for the post office and its
libraries. This basic configuration is best suited for a small system, or a decentralized library
configuration with small post offices that each have a library. For more information, see “Centralized
vs. Decentralized Library Configurations” on page 328.
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'
B Library

o
y w o w

Message  User Library Document
Database Database Database Database

POA

W

L] L & L
_— _— - _—
GroupWise Client GroupWise Client GroupWise Client GroupWise Client
Workstation Workstation Workstation Workstation
Advantages Disadvantages
+ Default configuration; no additional setup + All operations are performed on one server, which can
is required. cause performance degradation if your organization

+ Troubleshooting is limited to a single does enough DMS operations.

server. + If you increase QuickFinder intervals to lessen the load
on the POA, you lengthen the time users must wait to
search for new files, or find modified information through
new searching keywords.

Single Server with Multiple POAs

It is possible to run more than one POA for the same post office on the same server.
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]
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Library
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_— T — _—
GroupWise Client GroupWise Client GroupWise Client GroupWise Client
Workstation Workstation Workstation Workstation
Advantages Disadvantages
None. + Many processes running on one server can slow it down.

+ A ssingle point of failure can cause the server to shut down
when a problem is encountered.

There are no advantages to running multiple POAs on the same server. If you need more than one
POA, run it on a separate server, as described in “Dedicated Indexer Server” on page 378

Dedicated Indexer Server

You can have the post office on one server and a POA dedicated to indexing DMS documents on
another server. This configuration is useful for systems of any size with heavy DMS usage.
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| Network Segment
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GroupWise Client GroupWise Client GroupWise Client GroupWise Client
Workstation Workstation Workstation Workstation
Advantages Disadvantages

+ A dedicated server for quicker DMS indexing. This + Network traffic can increase significantly during
is useful for organizations that are document- periods of intense indexing.

intensive. . . .
+ Multiple server hardware is required.

* The messaging post office is not hampered by DMS
indexing.

Dedicated Indexer Server on an Isolated Network Segment

You can have the post office on one server and a POA dedicated to indexing documents on another
server that is on an isolated network segment. This configuration minimizes bandwidth congestion
for the production network segment.
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Post Office
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Network
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Message User Library Document dﬁ
Database Database Database Database
POA1
‘9 Production
| Network Segment
L] L] L] ]
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GroupWise Client GroupWise Client GroupWise Client GroupWise Client
Workstation Workstation Workstation Workstation

Advantages

Disadvantages

+ Dedicated server for quicker DMS indexing.
This is useful for organizations that are
document-intensive.

* The messaging post office is not hampered by
DMS indexing.

+ The large amount of information that is passed
between the post office server and the indexing
server does not congest the bandwidth of the
production network segment.

+ Multiple server hardware is required.

+ A dedicated network segment is required (including
second network interface card that is directly linked
to the indexer server).

+ For multiple indexing servers, a dedicated hub
might be needed.

Dedicated DMS Post Office

You can have one post office that is dedicated to messaging and another to DMS. This configuration
is useful for post offices that have heavy DMS usage. For a review of this configuration, see

“Centralized Libraries” on page 329.
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Advantages

Disadvantages

+ A dedicated POA for quicker DMS indexing.
This is useful for organizations that are
document-intensive.

The messaging post office is not hampered by
DMS traffic and indexing.

Logical separation of messaging and DMS
databases. Processes such as backing up
databases are easier.

This configuration is ideal for creating a
centralized library configuration.

High-end hardware is required for DMS server.
An additional post office and POA to be maintained.

Client/server is required for searching and
accessing documents.

Remote access is required for users who cannot
use client/server mode. This ensures that the
slower store-and-forward process is used for
remote searching and accessing of documents.

23.3.2 Determining Your Indexing Needs

The following table presents some indexing considerations and suggests an indexing configuration

based on how the considerations pertain to your

indexing needs:

Consideration Single Dedicated Indexer Dedicated Indexer Dedicated DMS
Server with  Server Server on an Isolated Post Office
One POA Network Segment

Does the post office own  No Yes or No Yes or No Yes

multiple libraries?

What is the expected Light Light or Moderate Moderate or Heavy Heavy

indexing volume (per
hour)?

Creating and Managing Documents

381



Consideration Single Dedicated Indexer Dedicated Indexer Dedicated DMS

Server with Server Server on an Isolated Post Office
One POA Network Segment
Is hardware available fora No Yes Yes Yes
dedicated indexer server?
Could bandwidth No Maybe Maybe or Yes Yes

congestion be a problem?

Use the “Indexing Worksheet” on page 382 to estimate the indexing needs of the libraries in your
GroupWise system. Each worksheet accommodates three libraries.

Identify each library (worksheet items 1 and 2). Estimate the impact of each consideration in each
library (worksheet items 3 through 6). Then compare your estimates for each library to the values in
the table above to determine the indexing configuration for each library (worksheet item 7).

Indexing Worksheet

For instructions on how to use this worksheet, see Section 23.3.2, “Determining Your Indexing
Needs,” on page 381.

Library Library Library

1) Library:
2) Library’s Post Office:
3) Multiple Libraries per Post Office?

* Yes
* No
4) Expected Indexing Volume (per hour):
+ Light
¢ Moderate
¢ Heavy
5) Additional Server Available?
* Yes
* No
6) Bandwidth Congestion Possible?
* Yes
+ Maybe

+ No
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Library Library Library

7) Indexer Configuration:

+ Single server with one POA
+ Dedicated indexer server

+ Dedicated indexer server on an
insolated network segment

+ Dedicated DMS post office

23.3.3 Implementing Indexing

For libraries where a single POA running on the post office server can provide adequate indexing
support for the post office’s libraries, follow the instructions in Section 39.1, “Regulating Indexing,”
on page 573 to implement indexing.

For libraries where additional POAs running on separate servers are required to support the
indexing needs of the post office’s libraries, follow the instructions in Section 39.5, “Configuring a
Dedicated Indexing POA (Windows Only),” on page 577 to implement indexing,.

23.4 Managing Documents in Libraries

As more and more documents are added to your GroupWise libraries, you must manage the disk
space occupied by libraries and respond to various changes in your GroupWise system.

¢ Section 23.4.1, “Archiving and Deleting Documents,” on page 383
¢ Section 23.4.2, “Backing Up and Restoring Archived Documents,” on page 383
¢ Section 23.4.3, “Handling Orphaned Documents,” on page 385

See also Section 22.6.2, “Managing Document Storage Areas,” on page 345.

23.4.1  Archiving and Deleting Documents

The Document Type property determines what happens to documents whose document life in your
GroupWise system has expired. For a review of the document types and document life, see
Section 21.3.2, “Document Types,” on page 319.

You can use the Mailbox/Library Maintenance feature in Console