Domains

Chapter 8, “Creating a New Domain,” on page 109
Chapter 9, “Managing Domains,” on page 123
Chapter 10, “Managing the Links between Domains and Post Offices,” on page 131
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Creating a New Domain

As your GroupWise® system grows, you might need to add new domains.
¢ “Understanding the Purpose of Domains” on page 109
¢ “Planning a New Domain” on page 110
¢ “Setting Up the New Domain” on page 118
* “What’s Next” on page 121

IMPORTANT: If you are creating a new domain in a clustered GroupWise system, see the appropriate section
of the GroupWise 6.5 Interoperability Guide before you create the domain:

- “Setting Up a Domain and Post Office in a Novell Cluster” in “Novell Cluster Services”
- “Setting Up a Domain and Post Office in a Microsoft Cluster” in “Microsoft Clustering Services”

Understanding the Purpose of Domains

The domain functions as the main administrative unit for your GroupWise system. Each
GroupWise system has one primary domain, which was created when you first installed
GroupWise. All other domains that you add are secondary domains.

The domain serves as a logical grouping of one or more post offices and is used for addressing and
routing messages. Each GroupWise user has a GroupWise address that consists of a user ID, the
user’s post office name, the GroupWise domain name, and, optionally, an Internet domain name.

The following diagram illustrates the logical organization of a GroupWise system with multiple
domains and post offices. All of the objects under the domain belong to that domain. All of the
objects under a post office belong to that post office.

GroupWise
System
|
| 1
Primary Secondary
Domain Domain
Message Message
Transfer @ Transfer
\ Agent Agent
Post Post Post Post
Ofﬁce Ofﬁce Ofﬁce Offlce
Post POSt Post Post
Office Office Office Office
Agent Agent Agent Agent
238 &&4& 22& &&4&
GroupWise Users GroupWise Users GroupWise Users GroupWise Users
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Messages are moved from user to user through your GroupWise system by the GroupWise agents.
As illustrated above, each domain must have a Message Transfer Agent (MTA) running for it. The
MTA transfers messages between domains and between post offices in the same domain. Each
post office must have at least one Post Office Agent (POA) running for it. The POA delivers
messages to users’ mailboxes and performs a variety of post office and mailbox maintenance
activities.

When you add a new domain to your GroupWise system, links define how messages are routed
from one domain to another. When you add the first secondary domain, the links between the
primary and secondary domains are very simple. As the number of domains grows, the links
among them can become quite complex. Links are discussed in detail in Chapter 10, “Managing
the Links between Domains and Post Offices,” on page 131.

Physically, a domain consists of a set of directories that house all the information stored in the
domain. To view the structure of a domain directory, see “Domain Directory” in GroupWise 6.5
Troubleshooting 3: Message Flow and Directory Structure. The domain directory does not contain
mailboxes or messages, but it does contain other vital information. For an overview, see
“Information Stored in the Domain” on page 558. Domain directories can be located on NetWare,
Linux, and Windows servers.

Planning a New Domain

After you have your basic GroupWise system up and running, you might need to expand it by
adding one or more domains. The GroupWise architecture lets you create a simple, single domain
system, or a complex system that links dozens of domains across a campus, a city, or around the
world.

This section provides the information you need in order to decide when, where, and how to set up
a new domain. The “Domain Worksheet” on page 122 lists all the information you need. You
should print the worksheet and fill it out as you complete the tasks listed below.

¢ “Determining When to Add a New Domain” on page 111

+ “Deciding Who Will Administer the New Domain” on page 111
+ “Planning Post Offices in the New Domain” on page 112

+ “Determining the Context for the Domain Object” on page 112

¢ “Choosing the Domain Name” on page 114

+ “Deciding Where to Create the Domain Directory” on page 114
¢ “Deciding Where to Install the Agent Software” on page 115

+ “Deciding How to Link the New Domain” on page 117

+ “Selecting the Domain Language” on page 118

+ “Selecting the Domain Time Zone” on page 118

After you have completed the tasks and filled out the “Domain Worksheet” on page 122, you are
ready to continue with “Setting Up the New Domain” on page 118.
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Determining When to Add a New Domain

How do you know when you should add a domain? The answer to this depends on your
administration policies and on physical and logical network organization.

Although a single domain can contain as many post offices and users as you want to add, there are
some conditions that indicate the need for a new domain:

+ Administrative Convenience: To spread out the administrative workload, you can create one
or more new domains with their own administrators. Each new domain can be managed by a
different administrator as long as each administrator has sufficient rights to connect to it and
write to the domain directory.

+ Remote Sites: [f communication between servers is slow, or if you have remote sites, you can
add a new domain to minimize mail traffic between the servers. For example, if you have
locations in three separate cities, you might have an organization that represents each location.
You could then create a domain in each organization. You could administer all of the domains
from one location or you could assign a different administrator for each one.

¢ Demand on the MTA: Each domain has its own MTA that routes messages between post
offices within its domain. If your current domain has many post offices that are placing a
heavy workload on the MTA, you might want to create another domain to handle additional
post offices.

¢ Multiple eDirectory Trees: All of the objects that are logically subordinate to a GroupWise
domain must be in the same Novell® eDirectory™ tree as the domain. If you have users in
other eDirectory trees that need GroupWise accounts, you must create secondary domains and
post offices in each tree.

Deciding Who Will Administer the New Domain

Any user who is an Admin equivalent can administer GroupWise. We recommend that whoever
creates the new domain should be an Admin equivalent so that he or she has the necessary rights
to create objects and directories. You can then assign a different user as a domain administrator
and limit rights to other objects if necessary. For more information, see Chapter 84, “GroupWise
Administrator Rights,” on page 1053.

Depending upon the size, complexity, and layout of your eDirectory tree, you might choose a
centralized administration model with one person administering both eDirectory and GroupWise,
or you might choose a distributed administration model with the administration workload shared
by two or more individuals. With a distributed administration model, each administrator obtains
rights to the GroupWise objects and directory structures over which he or she has jurisdiction. If
you want to restrict access to some network operations or to certain domains, you can limit access
rights to domains the user should not administer.

The user assigned as the administrator must be able to create or modify objects in the domain and
will receive an e-mail message whenever an agent encounters a problem. You can designate
yourself, one or more other users, or a distribution list as an administrator.

WORKSHEET

Under Item 10: Domain Administrator, enter the ID of the user or distribution list that will administer
this domain.

The items in the worksheet are listed in the order you will enter them when setting up your domain.
This planning section does not follow the same order as the worksheet, but all worksheet items are
covered.
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Planning Post Offices in the New Domain

Before adding the new domain, you should plan the post offices that you want to belong to the
domain. You should consider the following issues when planning post offices.

+ Physical Organization: If your network spans several sites, you might want to create post
offices (if not domains) at each physical location. This reduces the demands on long-distance
network links.

+ Logical Organization: Grouping users who frequently send messages to each other is faster
and generates less network traffic than if messages travel between different post offices and
domains.

¢ Number of Users: A typical post office can serve from 1000 to 2500 users, depending on its
configuration. Larger post offices are possible, but grouping similar users might be preferable.

¢ Demand on the POA: Each post office has at least one POA that delivers messages to users’
mailboxes and performs other post office maintenance tasks. It is possible to run multiple
POAs, located on different servers, for the same post office, or you might prefer to create
multiple post offices.

For more details, see “Planning a New Post Office” on page 148.

Determining the Context for the Domain Object

When deciding where to place the new Domain object in the eDirectory tree, you should consider
how you can most easily administer GroupWise and how the domain and its associated post offices
fit into the logical organization of your eDirectory tree.

Domains and their associated objects, including Post Offices, Users, Resources, and Distribution
Lists, must be located in the same eDirectory tree. If you have multiple trees, you must create a
separate domain in each tree. The domains can all belong to the same GroupWise system.

You can place the domain in any context in an eDirectory tree. The following diagrams provide
some examples of how domains can be placed in the eDirectory tree:

* “GroupWise Objects Reflect Physical Locations” on page 112

+ “GroupWise Objects Reflect Company Organization” on page 113

* “GroupWise Objects Are Grouped with Servers” on page 113

+ “GroupWise Objects Are Located in a Separate GroupWise Container” on page 113

WORKSHEET

Under Item 1: Tree Name, specify the name of the eDirectory tree where you plan to create the new
domain.

Under Item 2: eDirectory Container, specify the name of the eDirectory container where you plan to
create the new domain.

GroupWise Objects Reflect Physical Locations

The GroupWise system below focuses on the physical layout of the company. Because most mail
traffic is probably generated by users in the same location, the mail traffic across the WAN is
minimized. An organizational unit was created for each site. A domain was created under each
organizational unit, corresponding to the city. The sites can be administered centrally or at each
site. Administrator rights can be assigned at the domain level.
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&2y Corporate
E“lg Los Angeles
- @@ La-Dom1
- mJaLaror
"8 New York
- Hy-Po1-1
-8 Ny-Dom1

GroupWise Objects Reflect Company Organization

The following GroupWise system focuses on departmental organization, as does the eDirectory
tree. GroupWise domains and post offices parallel eDirectory organizational units, placing the

domains and post offices within the organizational units containing the users that will belong to
them.

&2y Corporate
E“lg Accounting
@@ AcctDom
= AcctPOT
E“lg Development
- @@ Dev-Dom
- Dev-PO1
8 Manufacturing
-7 Sales

GroupWise Objects Are Grouped with Servers

Because domains and post offices have directory structures on network servers, you could also
choose to place the Domain and Post Office objects in the same context as the servers where the
directories will reside, as shown in the following example.

&2y Corporate

.28 Accounting

8 Development

8 Manufacturing

-1 Sales

=-"8 Servers
-8 Acct-Dam
- Acct- PO

PRY-GYW_NSSVOL
PRY-GYW_SYS

GroupWise Objects Are Located in a Separate GroupWise Container

Domains and post offices can also be created in their own organizational unit. Administratively,
this approach makes it easier to restrict a GroupWise administrator’s object and property rights to
GroupWise objects only. For information about GroupWise Administrator rights, see “Deciding
Who Will Administer the New Domain” on page 111.

El-458 Corporate

..... 8 Accounting

..... “8 Development

=78 GroupWise
-8 Acct-Dam
- Acct- PO
-8 Dev-Dom
=-Ja Dev-PO1

----- =3 Manufacturing

----- g Sales
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Choosing the Domain Name

The domain requires a unique name. The name is used as the Domain object’s name in eDirectory.
It is also used for addressing and routing purposes within GroupWise, and might appear in the
GroupWise Address Book.

The domain name can reflect a location, company name or branch name, or some other element
that makes sense for your organization. For example, you might want the domain name to be the
location (for example, Provo) while the post office name is one of the company’s departments (for
example, Research). Name the new domain carefully. After it is created, the name cannot be
changed.

The domain name can consist of one or more words. Use underscores (_) rather than spaces as
separators between words to facilitate addressing across the Internet. Do not use any of the
following invalid characters in the domain name:

ASCII characters 0-13 Comma,

Asterisk * Double quote "

At sign @ Extended characters

Braces { } Parentheses ()

Colon : Period .
WORKSHEET

Under Item 3: Domain Name, specify the domain name.

Under Iltem 8: Domain Description, provide a description for the new domain.

Deciding Where to Create the Domain Directory

Logically, the Domain object resides in eDirectory and is administered through ConsoleOne®.
Physically, the domain has a directory structure for databases, message queues, and other files. The
domain directory structure can be created on NetWare® servers (NetWare 6.x, NetWare 5.x,
NetWare 4.2, or NetWare 3.12), Linux servers (SUSE Standard or Enterprise Server 8, Red Hat*
Enterprise Linux 3 ES or AS), or Windows servers (Windows 2000 or Windows NT*). The server
where you create the domain directory structure can be in the same tree as the Domain object or
in another tree.

Many different configurations are possible. When deciding where to create the domain directory,
you should consider the following.

¢ Domain Directory Space Requirements: The domain directory requires less than 10 MB of
free disk space. However, this requirement could increase as your system grows.

+ Network Access by the MTA: [f the MTA is not installed on the same server with the domain
directory, the MTA must have direct network access (mapped drive or file system mount) to
the domain directory and, depending on link configuration, to the post office directories. This
issue is discussed in detail in “Deciding Where to Install the Agent Software” on page 115.

+ Security from User Access: Users never need access to the domain directory so you should
create it in a location you can easily secure; otherwise, you could have files inadvertently
moved or deleted.
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Choose an empty directory for the new domain. If you want, the directory can reflect the name of
the domain, for example, res_dev for the Research and Development domain. On NetWare and
Windows, use a maximum of § characters in the directory name. On Linux, use only lowercase
characters in the directory name.

Choose the name and path carefully. After the domain directory is created, it is difficult to rename
it. If the directory you specify does not exist, it will be created when you create the domain. Do
not create the domain directory under another domain or post office directory.

WORKSHEET

Under Item 4: Domain Database Location, enter the full path for the domain directory.

Under Item 9: Network Type, enter the type of network in use at that location.

Deciding Where to Install the Agent Software

You must run a new instance of the MTA for each new domain. To review the functions of the
MTA for the domain, see “Role of the Message Transfer Agent” on page 559. For complete

installation instructions and system requirements, see “Installing GroupWise Agents” in the
GroupWise 6.5 Installation Guide.

When planning the installation of the MTA, you need to consider how the new domain links to
existing domains and how the new domain will link to its post offices. For an overview of link

configuration, see Chapter 10, “Managing the Links between Domains and Post Offices,” on
page 131.

The MTA requires direct network access to the domain directory and, depending on the link
configuration, to each post office directory. Consider the following alternatives when selecting a
location for the MTA relative to the domain and its post offices:

¢ “MTA Access to the New Domain: Local vs. Remote” on page 115
* “MTA Access to New Post Offices: Mapped and UNC Links vs. TCP/IP Links” on page 116

¢ “Cross-Platform Access Issues” on page 117

WORKSHEET

Under Item 11: Agent Location, indicate whether you plan to run the MTA on the same server where
the domain directory is located, or on a different server.

Under ltem 12: Agent Platform, enter the platform of the server where the MTA will run (NetWare,
Linux, or Windows).

MTA Access to the New Domain: Local vs. Remote

Running the MTA locally on the same server where the domain and post offices reside simplifies
network connections (no login is required), reduces network traffic, and protects database

integrity. In the following diagram, the agent software is installed on the same server where the
domain and post office reside.

4%, ZHE

MTA? MTA?
&’ Acct-Dom &’ Dev-Dom
Acct-PO1 Dev-PO1
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Running the MTA on a remote server allows you to place the heaviest processing load on your
highest performing server. In the following diagram, the agent software is installed on a different
server from where the domains and post offices reside.

g MTA MTA g

Acct-Dom / \ Dev-Dom
Acct-PO1 Dev-PO1
\ POA POA /

When you run the MTA on a different server from where its directory structures and databases are
located, you need to provide adequate access.

* If the NetWare® MTA needs direct network access to another NetWare server, you must add
the /dn switch or the /user and /password switches to the MTA startup file to provide
authentication information.

+ [fthe Linux MTA needs direct network access to another Linux server, you must mount the
file system where the domain is located before you start the Linux MTA.

+ [fthe Windows MTA needs direct network access to another Windows server, you must map
a drive to the other server before you start the Windows MTA.

MTA Access to New Post Offices: Mapped and UNC Links vs. TCP/IP Links

If the new domain will include multiple post offices, the post offices will probably reside on
different servers from where the domain is located. If you plan to use mapped or UNC links
between the domain and its post offices, the MTA requires the same access to the post office
directories as it requires to the domain directory.

NetWare Wi ndows NetWare

g MTA MTA g

Acct-Dom / \ Dev-Dom
Acct- PO1 Dev-PO1
POA POA /

+ [f the NetWare MTA needs access to a post office on another NetWare server, you must add
the /dn switch or the /user and /password switches to the MTA startup file to provide
authentication information.

+ [fthe Windows MTA needs access to a post office on another Windows server, you must map
a drive to the other server before you start the Windows MTA.

NOTE: The Linux MTA requires TCP/IP links to the POA.

To avoid these direct network access requirements between the MTA and its post offices, you can
use TCP/IP links between the domain and its post offices.

g MTA MTA
Acct-Dom < ﬂ > Dev-Dom
Acct-PO1 Dev-PO1
POA POA
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When using TCP/IP links, the MTA does not write message files into message queues in the post
office directory structure. Instead, the MTA communicates the information to the POA by way of
TCP/IP and then the POA uses its direct network access to write the information.

Cross-Platform Access Issues

In most cases, it is most efficient if you match the MTA platform with the network operating
system where the domain resides. For example, if you create a new domain on a NetWare server,
use the NetWare MTA.

If you decide not to run the MTA on the same platform as the domain, the MTA must still have
direct network access to the domain directory so that it can write to the domain database
(wpdomain.db). For example, you could set up the new domain on a NetWare server and run the
Windows MTA on an Windows server to service it.

Wi ndows NetWare

MTA g

\ Dev-Dom
Dev-PO1
POA /

However, the NetWare MTA could not service a domain located on an Windows server because
Windows does not support the required cross-platform connection.

If you are using mapped or UNC links to post offices, the MTA must also have direct network
access to the post office directories so that it can write messages files into the post office message
queues. You could, for example, run the agents on an Windows server while domains and post
offices were located on NetWare servers.

g MTA MTA !
Acct-Dom / ﬂ Dev-Dom
Dev-PO1
POA POA

Acct-PO1

Again, the opposite combination of NetWare agents servicing domains and post offices on
Windows servers is not an option because Windows does not support the required cross-platform
connection.

To avoid these cross-platform access issues, use TCP/IP links between a domain and its post
offices.

For more detailed information, see “Cross-Platform Issues between Domains and Post Offices” on
page 561.
Deciding How to Link the New Domain

Domain links tell the MTAs how to route messages between domains. Properly configured links
optimize message flow throughout your GroupWise system. For a review of link types, see
“Domain-to-Domain Links” on page 131.
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When you create the new domain, you link it to one existing domain. By default, this link is a direct
link using TCP/IP as the link protocol, which means the new domain’s MTA communicates with
the existing domain’s MTA through TCP/IP. If desired, you can configure the direct link to use a
UNC path as the link protocol, which means the new domain’s MTA transfers information to and
from the existing domain by accessing the existing domain’s directory

WORKSHEET

Under Item 7: Link to Domain, specify the existing domain that you want to link the new domain to,
then specify the link protocol (TCP/IP or UNC path).

After you create the new domain, you can configure links to additional domains as needed. See
“Using the Link Configuration Tool” on page 136.

Selecting the Domain Language

The domain language determines how times, dates, and numbers are displayed in the GroupWise
client and determines the sorting rules for items in the GroupWise Address Book.

WORKSHEET

Under Item 5: Domain Language, specify the domain language.

Selecting the Domain Time Zone

When a message is sent from a user in one time zone to a user in another time zone, GroupWise
adjusts the message’s time so that it is correct for the recipient’s time zone. For example, if a user
in New York (GMT -05:00, Eastern Time) schedules a user in Los Angeles (GMT -08:00, Pacific
Time) for a conference call at 4:00 p.m. Eastern Time, the appointment is scheduled in the Los
Angeles user’s calendar at 1:00 p.m. Pacific Time.

The domain time zone becomes the default time zone for each post office in the domain.

WORKSHEET

Under ltem 6: Domain Time Zone, enter the time zone.

Setting Up the New Domain
You should have already reviewed “Planning a New Domain” on page 110 and filled out the
“Domain Worksheet” on page 122. Complete the following tasks to create the new domain.
¢ “Creating the New Domain” on page 119
+ “Configuring the MTA for the New Domain” on page 120
+ “Installing and Starting the New MTA” on page 121
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Creating the New Domain

1 Make sure you are logged in to the tree where you want to create the domain (worksheet item

1.

2 In ConsoleOne, browse to and right-click the eDirectory container where you want to create

the domain (worksheet item 2), then click New > Object.

Create ohject in:
“H CORP_TREE/Graupwise Provn

LDAP Group
[5E LDAP Server A

3 Double-click GroupWise Domain, then fill in the fields in the Create GroupWise Domain

dialog box (worksheet items 3 through 7).

Create Group¥ise Domain 5'

Cancel

Domain name:

Domain Database Location:

J Help
Language:
|English - Us =l
Time Zane
|aMT-07:00) Mauntain Time (US & Canada) |
Link To Domain
|Ban Jose LI

[¥ Caonfigure link
[~ Define additional properties

[ Create another domain

4 Make sure the Configure Links and Define Additional Properties options are selected, then

click OK to display the Link Configuration Wizard.

Link Configuration Wizard 1'

MTA Link

The Message Transfer Agent (MTA) can link ta the other domain
through & TCP/IP connection to the other domain's MTA or a
direct connection to the other domain's directory.

Novell.

How do you want the MTA to link to the other domain®?
= Direct link

& TCPIP link

= Back

eds

Cancel | Finist | Help |
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5 Follow the on-screen instructions to define how the new domain links to the existing domain
(listed in the Link to Domain field). When you’ve finished defining the link, ConsoleOne
creates the Domain object and displays the domain Identification page.

Properties of Provol x|
| DS Rights - | Cther I Rights to Files and Folders I

Domain: Proval
Description
UMC Path: I'L'LPRV—GWIBYSIQWS\rstemlprDVM'l il
Language |Enghsh—US ;l
Damain Type Prinaty
Time Zone |(GMT-07:00) Mountain Time (S & Canada) =l
Database Yersion: 6.5
Netwark Type: |Movell Netware =l
Administratar. I @l Clear
Pane Options... 6]5¢ | Cancel | Anply | Help |

6 Fill in the fields that have not been filled in for you (worksheet items 8 through 10).

7 Click OK to save the domain information.

Configuring the MTA for the New Domain

120

Although there are many MTA settings, the default settings are sufficient to get your domain
operational. However, there are a few important settings that you can conveniently modify before
you install the agent software.

1 In ConsoleOne, double-click the new Domain object.

2 Right-click the MTA object, then click Properties to display the MTA Identification page.

Properties of MTA il

NDS Rights v | Cther | Rights to Files and Flders |

Domain: Provol

Distinguished Narme: MTA.Frovol.Groupiwise

Mame: hATA

Agent Type: Message Transfer

Desctiption Groupiyise Messaoe Transfer Agent

Platformm: [netvvare Loadable Madule =l

Page Options... 04 Cancel ARl Help
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Enter a description for the MTA.
This description displays on the MTA agent console as the MTA runs.
Select the platform where the MTA will run (worksheet item 12).

If you have multiple domains in your system and want to use TCP/IP to link to the other
domains (worksheet item 7), follow the instructions in “Using TCP/IP Links between
Domains” on page 579.

If you have created the domain in a clustered environment, follow the instructions in the
appropriate section of the GroupWise 6.5 Interoperability Guide:

¢ “Installing and Configuring the MTA and the POA in a Cluster” in “Novell Cluster
Services”

¢ “Installing and Configuring the MTA and the POA in a Cluster” in “Microsoft Clustering
Services”

To ensure that user information in the new domain stays synchronized with user information
in eDirectory, follow the instructions in “Using eDirectory User Synchronization” on
page 598.

For more MTA configuration options, see “Changing MTA Configuration to Meet Domain
Needs” on page 130.

Click OK to save the MTA configuration information.

Installing and Starting the New MTA

To install the MTA for the new domain to the location recorded under worksheet item 11, follow
the instructions in “Installing GroupWise Agents” in the GroupWise 6.5 Installation Guide. For
additional MTA-specific instructions, see Chapter 42, “Installing and Starting the MTA,” on
page 565.

Continue with What’s Next.

What’s Next

After you have added the new domain and started its MTA, you are ready to continue to expand
and enhance your GroupWise system by:

*

*

*

Adding post offices to the new domain. See “Post Offices” on page 145.
Configuring the MTA for optimal performance. See “Message Transfer Agent” on page 555.
Setting up GroupWise Monitor to monitor the GroupWise agents. See “Monitor” on page 901.

Connecting domains and GroupWise systems across the Internet using the GroupWise
Internet Agent. See “Internet Agent” on page 659.

Connecting domains and GroupWise systems using gateways. For a list of gateways, see
GroupWise 6.x Gateways (http://www.novell.com/documentation/gw6xgate/index.html).
GroupWise 5.5 gateways can be used with GroupWise 6.x.
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Domain Worksheet

Use this worksheet as you complete the tasks described in “Planning a New Domain” on page 110.

Item

Explanation

1) Tree Name:

2) eDirectory Container:

3) Domain Name:

4) Domain Database Location:

5) Domain Language:

6) Domain Time Zone:

7) Link to Domain:

Link Protocol:
+ UNC path

+ TCP/IP
Address:
Port:

8) Domain Description:

9) Network Type:

10) Domain Administrator:

11) Agent Location:

* MTA on the same server as
the domain (local)

+ MTA on a different server
from the domain (remote)

12) Agent Platform:
+ NetWare MTA
¢ Linux MTA

¢ Windows MTA

Specify the name of the eDirectory tree where you want to create the secondary domain.
For more information, see “Determining the Context for the Domain Object” on page 112.
Specify the name of the eDirectory container where you want to create the new domain.

For more information, see “Determining the Context for the Domain Object” on page 112.

Specify a name for the new domain. Choose the name carefully. After the domain is created,
it cannot be renamed.

For more information, see “Choosing the Domain Name” on page 114.

Specify the path for the domain directory. Choose the domain directory carefully. After it is
created, it is difficult to rename.

For more information, see “Deciding Where to Create the Domain Directory” on page 114.
Specify a default language for the domain.

For more information, see “Selecting the Domain Language” on page 118.

Specify the time zone where the domain is located.

For more information, see “Selecting the Domain Time Zone” on page 118.

Specify the existing domain that you want to link the new domain to, then specify the link
protocol. If you select TCP/IP, enter the IP address or hostname of the server where the MTA
will run and the port number that the MTA will listen on.

For more information, see “Deciding How to Link the New Domain” on page 117.

Enter a description for the domain to help you identify its function in the system.

Specify the network type in use on the server where this domain will be located.

For more information, see “Deciding Where to Create the Domain Directory” on page 114.
Enter the ID of the user or distribution list that will administer this domain.

For more information, see “Deciding Who Will Administer the New Domain” on page 111.
Mark the location of the MTA relative to the domain.

For more information, see “Deciding Where to Install the Agent Software” on page 115.

Specify the platform on which you plan to run the MTA.

For more information, see “Deciding Where to Install the Agent Software” on page 115.
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Managing Domains

As your GroupWise® system grows and evolves, you might need to perform the following
maintenance activities on domains:

*

*

*

*

*

*

“Connecting to a Domain” on page 123

“Editing Domain Properties” on page 124

“Converting a Secondary Domain to a Primary Domain” on page 126
“Moving a Domain” on page 127

“Deleting a Domain” on page 128

“Changing MTA Configuration to Meet Domain Needs” on page 130

See also Chapter 26, “Maintaining Domain and Post Office Databases,” on page 345.

Connecting to a Domain

Whenever you change domain information, it is most efficient to connect directly to the domain
before you begin making modifications.

To change your domain connection:

1

In ConsoleOne® in the Console View, click Tools > GroupWise System Operations, click
Select Domain, browse to and select the domain directory, then click OK.

or
In the GroupWise View, right-click the Domain object, then click Connect.

The GroupWise view identifies the domain to which you are connected by adding a plug
symbol to the domain icon.

The domain marked with the red underscore is the primary domain.
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Editing Domain Properties

After creating a domain, you can change some domain properties. Other domain properties cannot
be changed.

1 In ConsoleOne, browse to and right-click a Domain object, then click Properties to display the
domain Identification page.

Properties of Provol il
oupWise v | NDS Rights v | Other | Rights to Files and Foiders |
Domain: Provol
Description
UMNC Path: |\\PRV—GW\BYS\gwsvstem\provm\ il
Language [English- Us =
Damain Type Primary
Time Zane |{GMT-07:00) Mountain Time (5 & Canada) =l
Database Yersion: 6.5
Metwark Type: INUVE” Metware LI
Administrator I @ Clear
Page Options... 04 | Cancel | ARl | Help |

2 Change editable fields as needed. For information about individual fields, see “Planning a
New Domain” on page 110 or use online help when editing the domain information.

3 Click GroupWise > Post Offices to display the Post Offices page.

Propetties of Provol x|

GroupWise ~ | NDS Rights ~ | Cther | Rights to Files and Folders |
Post Offices

Groupvise Post Offices:

t.G 0
Manufacturing GroupWise.Provo

Delete |
Page Options... o | cancet | sy | pen |

All post offices in the domain are listed, no matter where their Novell® eDirectory™ objects
are placed in the tree. This is a convenient place to delete post offices from the domain.

4 Click GroupWise > Address Book to display the Address Book page.
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Properties of Provol x|

GroupWise v | NDS Rights + | Ciher | Rights to Files and Folders |
Addrezs Book

Sart address ook by: |First Name, Last Name =l
Address Boak Fields: Available Fields:
Given Name (reguired) Account ID

Last Mame {required) Description

Phone Distinguished Narne
Ohject 1D Middle Initial

Fost Office Name :l Personal Title
Darnain Name Qualifier
Department =»

Title

Metwark 1D

File ID

Fax

|3
Ediblate!

[ Do Mot Display User Gornrments

Page Options... ok | cancel | appy | pew |

*Administrator-defined field

8 Use this page to configure the Address Book to control how it appears to GroupWise client
users in all post offices in the domain. See Chapter , “Address Book,” on page 81 for more
information.

6 Click GroupWise > Addressing Rules to display the Addressing Rules page.

Properties of Provol x|

NDS Rights « | Cther | Rights to Files and Folders I

Lfddressing Rules

Addressing rules used by this dormnain:

TiEst: |
Pane Options... 6]5¢ | Cancel | Anply | Help |

This page lists all addressing rules that have been set up for the domain. See Chapter ,
“Addressing Rules,” on page 97 for more information.

7 Click GroupWise > Internet Addressing to display the Internet Addressing page.
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Properties of Provol x|

oupWise = i| NDS Righis = | Gther | Rights to Files and Folders |
ernet Addressing

Ovettide | Addressing format:
= |U59r\D.PostOﬁ’lce.Domain@\memetdomain nameLI

Internet domain name
O I -

[ Farincaming mail, recinients are known exclusively biithis (ntermet domain name

Internet Agent for outbound SMTPMMIME messages:
= Ivam Gy -

Page Options... ok | cancel | s | mew |

Use this page to override any Internet addressing settings established at the system level. See
Chapter , “Internet-Style Addressing,” on page 87 for more information.

8 Click GroupWise > Default WebAccess to display the Default WebAccess page.

Properties of Provol il
NDS Rights + | Cther | Rights to Files and Folders
COrverride DefaultWebAccess Gateway:
=0 2]
Page Options... 04 | Cancel | ARl | Help |

Use this page to designate the default WebAccess Agent (gateway) for the domain. See
“WebAccess” on page 803 for more information.

9 Click OK to save the new domain settings.

Converting a Secondary Domain to a Primary Domain

You can change which domain is primary if it becomes more convenient to administer the primary
domain from a different location. You can, however, have only one primary domain at a time.
When you convert a secondary domain to primary, the old primary domain becomes a secondary
domain.
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To convert a secondary domain to primary:

1 In ConsoleOne, connect to the primary domain, as described in “Connecting to a Domain” on
page 123.

2 Make sure there are no pending operations for the current primary domain. See “Pending
Operations” on page 51.

3 In ConsoleOne, browse to and select the secondary domain you want to convert.

4 Click Tools > GroupWise Utilities > System Maintenance.

Gruupwise System Maintenance x|

" Validate Datahase Run

" Recover Database
Close |

" Rebuild Database
Hell
 Reclaim Unused Space _pl

© Rebuild Indexes for Listing

™ Syne Primary with Secondary

& £
" Release Secondary
~
-

Description:
Conver to primary promotes a secondary domain to
primary. The existing primary domain for the system
becomes a secondary dormain.

8 Click Convert Secondary to Primary.
6 Enter the path to the secondary domain database, then click OK.

The GroupWise View in ConsoleOne displays the primary domain with a red underscore.

@ Pravot

Eﬁ Manufacturing
Fa reD

-8 Pravoz

Moving a Domain

You cannot use ConsoleOne to move a Domain object to a different location in the eDirectory tree
because it is a container object. Only leaf objects can be moved. If you need to change the context,
graft the GroupWise domain to its corresponding eDirectory object in the new container location.
See “GW / eDirectory Association” on page 73 for more information about grafting objects.

You can, however, move the domain directory and the domain database (wpdomain.db) by
copying the domain directory structure and all its contents to the new location.

IMPORTANT: Follow these instructions if you want to move a domain on a NetWare or Windows server to
another directory on the same server or to a different NetWare or Windows server. If you want to move a
domain located on a NetWare or Windows server onto a Linux server, see “Moving a Domain to Linux” in
“Update” in the GroupWise 6.5 Installation Guide.

1 Back up the domain. See Chapter 31, “Backing Up GroupWise Databases,” on page 375.
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2 In ConsoleOne, browse to and right-click the domain to move, then click Properties to display
the domain Identification page.

3 I[n the UNC Path field, change the UNC path to the location where you want to move the
domain, then click OK to save the new location.

The location change will be propagated throughout your GroupWise system.
4 Stop the MTA and any gateways running for the domain.

85 Use xcopy with the /s and /e options to copy the domain directory and database to the new
location. These options re-create the same directory structure even if directories are empty.

Example: xcopy domain directory /s /e destination
6 Give rights to all objects that need to access the domain database.
For example, the NetWare® MTA needs rights if the new location is on a different server.

7 Edit the MTA and gateway startup files to reflect the changes, then restart the MTA and
gateways.

See “Adjusting the MTA for a New Location of a Domain or Post Office” on page 587.

8 When you are sure the domain is functioning properly in its new location, delete the original
domain directory and its contents.

If you need to move the MTA along with its domain, see “Moving the MTA to a Different Server”
on page 586.

Deleting a Domain

You can delete a domain only when it no longer owns subordinate GroupWise objects. For
example, you cannot delete the primary domain of your GroupWise system if it still owns
secondary domains.You cannot delete a secondary domain if it still owns post offices. However,
MTA and Gateway objects are automatically deleted along with the Domain object.

1 In ConsoleOne, connect to the primary domain of your GroupWise system, as described in
“Connecting to a Domain” on page 123.

2 Browse to and right-click the Domain object you want to delete, then click Properties to
display the domain Identification page.
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Properties of Provol x|

{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |

: Ientification
Domain: Pravol
Desctiption
UNC Path: [uPRv- GV S vSgwsystemipravolt il
Language |Enghsh-US LI
Domain Type Primary
Time Zone |{GMT-07:00) Mauntain Time (US & Canada) =l
Database Yersion: 6.5
NMetwork Type: |Navell Netware =l
Administrator, I @l Clear
Page Options... ok | cancel | s | mew |

3 Verify that the current directory path displayed on the domain Identification page is correct.

4 Click Post Offices, then move or delete any post offices that belong to this domain. See
“Moving a Post Office” on page 183 and “Deleting a Post Office” on page 184.

Properties of Provol il

GroupWise v | NDS Rights ~ | Other | Rights to Files and Flders |
Post Crffices

GroupWise Post Offices:

prment.Gr 1]

Manufacturing. Grougyise. Provo

Delete |
Page Options... 04 | Cancel | ARl | Help |

5 Right-click the Domain object, then click Delete to delete the Domain object from eDirectory.
6 When prompted, click Yes to delete the corresponding domain directory structure.
7 Stop the MTA for the domain and uninstall the MTA software if applicable.

See “Stopping the MTA” on page 609 and “Uninstalling the MTA Software” on page 573.
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Changing MTA Configuration to Meet Domain Needs

Because the MTA transfers messages between domains and between post offices in the same
domain, its functioning affects the domain itself, local users in post offices belonging to the
domain, and users who exchanges messages with local users in the domain. Proper MTA
configuration is essential for a smoothly running GroupWise system. Complete details about the
MTA are provided in “Message Transfer Agent” on page 555. As you create and manage domains,
you should keep in mind the following aspects of MTA configuration:

¢ “Enhancing Domain Security with SSL Connections to the MTA” on page 589
* “Restricting Message Size between Domains” on page 588

¢ “Scheduling Direct Domain Links” on page 593

+ “Optimizing TCP/IP Links” on page 635
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Managing the Links between Domains and Post
Offices

When you create a new secondary domain in your GroupWise® system or a new post office in a
domain, you configure one direct link to connect the new domain or post office to a domain in your
GroupWise system. For simple configurations, this initial link might be adequate. For more
complex configurations, you must modify link types and protocols to achieve optimum message
flow throughout your GroupWise system.

The following topics help you manage links between domains and post offices:
¢ “Understanding Link Configuration” on page 131
+ “Using the Link Configuration Tool” on page 136
+ “Interpreting Link Symbols” on page 143
* “Modifying Links” on page 144

Understanding Link Configuration

In GroupWise, a link is defined as the information required to route messages between domains,
post offices, and gateways in a GroupWise system. Initial links are created when domains, post
offices, and gateways are created. The following topics help you understand link configuration:

+ “Domain-to-Domain Links” on page 131
+ “Domain-to-Post Office Links” on page 134

+ “Link Protocols for Direct Links” on page 134

Domain-to-Domain Links

The primary role of the MTA is to route messages from one domain to another. Domain links tell
the MTA how to route messages between domains. Domain links are stored in the domain database
(wpdomain.db). There are three types of links between source and destination domains:

+ “Direct Links” on page 132
¢ “Indirect Links” on page 132
* “Gateway Links” on page 134

As an alternative to configuring individual links between individual domains throughout your
GroupWise system, you can establish a system of one or more routing domains. See “Using
Routing Domains” on page 591.
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Direct Links

Indirect Links

In a direct link between domains, the source domain’s MTA communicates directly with the
destination domain’s MTA. If it is using a TCP/IP link, the source domain MTA communicates
messages to the destination domain MTA by way of TCP/IP, which does not require disk access
by the source MTA in the destination domain. If it is using a mapped or UNC link, the source
domain MTA writes message files into the destination domain MTA input queue, which does
require disk access by the source MTA in the destination domain. For additional details about the
configuration options for direct links, see “Link Protocols for Direct Links” on page 134.

Domain A Domain B
@ UNC Path @
—eeeeep
Mapped Drive
TCP/IP

Direct links can be used between all domains. This is a very efficient configuration but might not
be practical in a large system.

Domam 1

/// Y

Domain 5 Domain 2

QL _®

Domain 4 *~~—"Domain 3

In an indirect link between domains, the source domain’s MTA routes messages through one or
more intermediate MTAs in other domains to reach the destination domain’s MTA. In other words,
an indirect link is a series of two or more direct links. In large systems, direct links between each
pair of domains might be impractical, so indirect links can be common. A variety of indirect link
configurations are possible, including:

+ “Simple Indirect Links” on page 133

+ “Star Configuration” on page 133

+ “Two-Way Ring Configuration” on page 133
¢ “Combination Configuration” on page 134

Properly configured links optimize message flow throughout your GroupWise system.
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Simple Indirect Links

In simplest form, an indirect link can be used to pass messages between two domains that are not
directly linked.

Domain A

UNC Path UNC Path

Mapped Drive / ¢ AN Mapped Drive
TCP/IP Re Inf?rid R TCP/IP
Q® @ ®
Domain B Domain C

Star Configuration

In a star configuration, one central domain is linked directly to all other domains in the system. All
other domains are indirectly linked to each other through the central domain.

Domain 2

Domain 6 ]l Domain 3

@v\D‘omaml//V @

//\

Domaln 5 Domaln 4

If you have more than ten domains, you might want to designate the central domain as a routing
domain. The sole function of a routing domain is to transfer messages between other domains; it
has no post offices of its own. See “Using Routing Domains” on page 591.

The major drawback of the star configuration is that the central domain is a single point of failure.
Two-Way Ring Configuration

In a two-way ring configuration, each domain is directly linked to the next and previous domains
in the ring and indirectly linked to all other domains in the system.

Domain 1

O\

Domain 5 Domain 2

@ @

@

\_j
Domain 4 *~~—"Domain 3
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An advantage of the two-way ring configuration is that it has no single point of failure. A
disadvantage is that, depending on the size of the system, a message might go through several
domains before arriving at its destination. A two-way ring works well in a system with five
domains or less because transferring a message never requires more than two hops.

Combination Configuration

These three basic link configurations can be combined in any way to meet the needs of your
GroupWise system.

Gateway Links

In a gateway link between domains, the sending domain’s MTA must route the message through
a gateway to reach its destination. Gateways can be used to:

+ Link domains within your GroupWise system. See “Using Gateway Links between Domains”
on page 583.

+ Link your GroupWise system to another GroupWise system through an external domain. See
“Using Direct Links” in “Connecting to GroupWise 5.x and 6.x Systems” in the Group Wise
6.5 Multi-System Administration Guide

+ Link your GroupWise system to a different e-mail system through a non-GroupWise domain.
See “Connecting to Non-Group Wise Messaging Systems” in the Group Wise 6.5 Multi-System
Administration Guide.

A variety of GroupWise gateways are available. For a list of gateways, see GroupWise 6.x
Gateways (http://www.novell.com/documentation/gw6xgate/index.html). GroupWise 5.5
gateways can be used with GroupWise 6.x.

You cannot locate a post office across a gateway link from its domain. This would preclude
locating a post office across a modem connection.

Domain-to-Post Office Links

Between a domain and its post offices, all links must be direct links. There are no alternative link
types between a domain and its post offices.

Link Protocols for Direct Links

The link protocol of a direct link between domains determines how the MTAs for the domains
communicate with each other across the link. When you create a new domain, you must link it to
an existing domain. This creates the initial domain-to-domain link.

Between a domain and a post office, the link protocol determines how the MTA transfers messages
to the post office. Messages do not flow directly from one post office to another within a domain.
Instead, they are routed through the domain. When you create a new post office, you must specify
which domain it belongs to. This creates the initial domain-to-post office link.

There are three link protocols for direct links between domains and between a domain and its post
offices:

¢ “TCP/IP Links” on page 135
+ “Mapped Links” on page 135
¢ “UNC Links” on page 135
NOTE: On Linux, TCP/IP links are required.
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TCP/IP Links

Mapped Links

UNC Links

Domain-to-Domain TCP/IP Links

In a TCP/IP link between domains, the source MTA and the destination MTA communicate by
way of TCP/IP rather than by writing message files. The source MTA establishes a TCP/IP link
with the destination MTA and transmits whatever messages need to go to that domain. The
destination MTA receives the messages and routes them on to local post offices or to other
domains as needed. During the process, message files are created in the gwinprog directory for
backup purposes and are deleted when the TCP/IP communication process is completed.

Domain-to-Post Office TCP/IP Links

In a TCP/IP link between a domain and a post office, you must configure both the POA and the
MTA for TCP/IP. The source MTA establishes a TCP/IP link with the destination POA and
transmits whatever messages need to go to that post office. The destination POA receives the
messages and delivers them into mailboxes in the post office. During this process, message files
are created in the POA input queue for backup purposes and are deleted when delivery is
completed.

Domain-to-Domain Mapped Links

In a mapped link between domains, the location of the destination domain is specified in the
following format:

drive:\domain directory
The source MTA writes message files into its output queue at the location:
drive:\domain directory\wpcsin

as input for the destination domain’s MTA. Because drive mappings are changeable, you could
move the domain directory structure, map its new location to the original drive letter, and the
domain-to-domain link would still be intact.

Domain-to-Post Office Mapped Links

In a mapped link between a domain and a post office, the location of the post office is specified in
the following format:

drive:\post office directory
The MTA writes message files into its output queue at the location:
drive:\post office directory\wpcsout

as input for the post office’s POA. Because drive mappings are changeable, you could move the
post office directory structure, map its new location to the original drive letter, and the domain-to-
post office link would still be intact.

Domain-to-Domain UNC Links

In a UNC link between domains, the location of the destination domain is specified in the
following format:
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\\server\volume\domain directory
The source MTA writes message files into its output queue at the location:
\\server\volume\domain directory\wpcsin

as input for the destination domain’s MTA. Because UNC paths represent absolute locations on
your network, if you move the domain to a new location, you would need to edit the link to match.

Domain-to-Post Office UNC Links

In a UNC link between a domain and a post office, the location of the post office is specified in
the following format:

\\server\volume\post office directory
The MTA writes message files into its output queue at the location:
\\server\volume\post office directory\wpcsout

as input for the post office’s POA. Because UNC paths represent absolute locations in your
network, if you move the post office to a new location, you would need to edit the link to match.

Using the Link Configuration Tool

The Link Configuration tool helps you manage the links between the domains and post offices in
your GroupWise system. The following topics help you perform basic link management tasks:

+ “Starting the Link Configuration Tool” on page 136

¢ “Editing a Domain Link™ on page 138

¢ “Editing Multiple Domain Links” on page 139

+ “Editing a Post Office Link” on page 140

* “Viewing the Path of an Indirect Link between Domains” on page 141
* “Viewing the Indirect Links Passing through a Domain” on page 141

+ “Viewing the Gateway Links Passing through a Gateway” on page 142

¢ “Saving and Synchronizing Link Configuration Information” on page 143

Starting the Link Configuration Tool

136

The Link Configuration tool is provided to help you change from default links to whatever link
configuration best suits your GroupWise system.

1 In ConsoleOne®, select the Domain object whose links you want to modify.

2 Click Tools > GroupWise Utilities > Link Configuration to display the Link Configuration
Tool window.
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Gruupwise Link Configuration Tool - "-‘,"-.‘PRV-GW"-.,SYS"\.,gwsy _|EI il
File Edit Search Wiew Window Help

5 °3|':| 7 Rl&l ?{:l‘ﬁal |Prava2 (Secondary) =l Elml |
E8pomain: Provo2 1 [=]
Outbound Links fram Provo2
rDirect Indirect rGatewa Undefined
% Provol % Provo3 (Provo1) | %, Provo5 (GWIA)
% Provod
| [ ol |l | 2l

Inbound Links to Provo2

rindirect
%, Provo1 “% Provo3 (Provo1)
“% Provo5 (Provot)

The most frequently used features of the Link Configuration tool are available on the toolbar:

Menu
Button Equivalent Function
File > Open Open a different domain database (wpdomain.db) to modify
links in a different domain
File > Save Save the current link configuration information to the
= domain database
IEI Edit > Undo Undo your changes to the link configuration (since the last
save)
Help > Help Display online Help for the Link Configuration tool
Search > Find Search for a specified domain
Double-click object Display details of the selected object
Eﬁ View > Domain Links View domain links for the selected domain
iy
View > Post Office Links View post office links for the selected domain
°

3 Continue with a specific link management task:
¢ “Editing a Domain Link” on page 138
¢ “Editing Multiple Domain Links” on page 139
¢ “Editing a Post Office Link” on page 140
¢ “Viewing the Path of an Indirect Link between Domains” on page 141
¢ “Viewing the Indirect Links Passing through a Domain” on page 141

+  “Viewing the Gateway Links Passing through a Gateway” on page 142
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Editing a Domain Link
After starting the Link Configuration tool:
1 From the drop-down list, select the domain whose links you want to edit.
2 Click View > Domain Links to display domain links.

Outbound and inbound links for the selected domain are listed.

Gruupwise Link Configuration Tool - 4\PRY-GW!5YS, gwsysti - | [m] 1'
File Edit Search Yiew YWindow Help
50 .3|‘=| ? al&l ?@l‘@l |Prova2 (Secondary) =l Elml |
I®pomain: Provo2 1 =1 E3
Outhound Links from Provo2

rDirect: Indirect rGateway Undefined

%, Provo1 “I Provo3 (Provo1) | %, Provo5 (GWIA)

%, Provod

| I ol |l |+l

Inbound Links to Praovo2

rindirect
%, Provol *%  Provo3 (Provo1)
*%  Provo5 (Provo1)

3 Double-click a domain in the Outbound Links list to edit the link to that domain from the
selected domain.

or

Double-click a domain in the Inbound Links list to edit the link from that domain to the
selected domain.

Edit Domain Link

Description How Provot connects to Prova2

Lkaype: IDH’EC‘ hd QEHCE| |

~Seting |

Protocal: [rerar =]

IPAddress:  [123.45678161  MTPort |7100 ﬁ' Scheduling |
[ override

Maximum send message size: I ] ::I MBytes
Delay message size I ] ::I Bytes

Transfer Pull Info... External Link Info... |

TIP: You can also open the Edit Domain Link dialog box by dragging a domain from one link type to
another.

4 Sclect the link type.
¢ “Direct Links” on page 132
¢ “Indirect Links” on page 132
¢ “QGateway Links” on page 134
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8 For a direct link, select the link protocol.
¢ “Mapped Links” on page 135
¢ “UNC Links” on page 135
¢ “TCP/IP Links” on page 135
6 Provide the location of the domain in the format appropriate to the selected protocol.
7 Click OK.
8 Repeat Step 1 through Step 7 for whatever links you need to modify.

As a time-saving measure, you can make a new domain’s links the same as an existing
domain’s links. Click Edit > Default Links, then click the domain whose links you want to use
as a pattern for the new domain. Select Outbound and/or Inbound as needed, then click OK.

To look at the same link information from different points of view, you can start the Link
Configuration tool multiple times to open multiple Link Configuration Tool windows.

9 To exit the Link Configuration Tool and save your changes, click File > Exit > Yes.

Editing Multiple Domain Links

When your GroupWise system includes indirect links, it is not unusual for several domains to link
to the same domain. As a time-saving measure, you can create links from multiple domains to the
same domain in one operation.

After starting the Link Configuration tool:
1 Click Edit > Multiple Link Edits.

Multiple Link Edits - Dutbound Links

~Domains to be linked:—— ~Indirect link through: ~Linkto——— FrmEE
Provol Provol Provod
Prava2 Provo2 Prova2 ﬂl
Provo3 Provo3 Frovo3

Help
Provod Pravod Provod —
Select All | Select All

2 In the Domains to Be Linked column, select the source domains whose outgoing links you
want to modify.

3 Inthe Indirect Link Through column, select the intermediate domain through which you want
the indirect links to pass.

4 In the Link To column, select one or more destination domains.

5 Click OK.
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6 Fill in the fields in the Edit Domain Link dialog box for each direct link between a source

domain and the intermediate domain, as described in “Editing a Domain Link” on page 138,
then click OK.

Edit Domain Link

Description How Provol connects to Pravo2
Link Type: ID\recI hd Cancel |
~Setling Heip |
Frotocol: [TcPip |
I Address:  [123.45.678.161  MTPart [7100 ﬁl G,
[ Override
Maximum send message size: I 1] ::I MBytes
Delay message size I 1] ::I MBiytes
Transfer Pull Info... External Link Info... |

The Edit Domain Link dialog box continues to appear until you have defined all the direct
links between the source domains and the intermediate domain.

IMPORTANT: After defining links from the source domains to the intermediate domain, make sure the links
from the intermediate domain to other domains are set up correctly.

Editing a Post Office Link

After starting the Link Configuration tool:

1 From the drop-down list, select the domain whose post office link you want to edit.
2 Click View > Post Office Links to display post office links.

GruupWise Link Configuration Tool - 1\PRY-GW\sys\awsystemip

=13l x|
File Edit Search Yiew Yindow Help

gl .;lﬂ:l ;?I al&l ?@l‘@l |Provet ¢Primany) Jia | E|ED|

I8 Post Office Links for Provo1

Past Office Links for Proval

Postofice | Domain |
%y Manufacturing
% R&D

Link
123.45.678.136: 1677, 7101
123.45.678.136: 1677,7201

Provo1

Provo1

3 Double-click a post office to edit the link from the domain to the post office.

I[8 GroupWise Link Configuration Tool - {\PRY-GW,sys\gwsystemip

(ol x|
Flle Edit Search Miew Window Help

gl .=|4=| il Rl&l ?;l‘ﬁ?l [Frovat (Frimany =l Elml

Pusl Office Links for Provo1

Post Office Links for Proval

Paost Office | Domain |

Link
% Manufacturing Pravo1 123.45.678.136:1677,7101
% R&D Provo1 123.45.678.136: 1677,7201

4 Sclect the link protocol for the direct link.
¢ “Mapped Links” on page 135
¢ “UNC Links” on page 135

¢ “TCP/IP Links” on page 135
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8 Provide the location of the post office in the format appropriate to the selected protocol.

6 For a TCP/IP link, provide the message transfer port number where you want the POA to
listen for incoming messages from the MTA.

The default message transfer port for the POA is 7101.
7 Click OK.

8 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.

Viewing the Path of an Indirect Link between Domains

The more hops between two indirectly linked domains, the longer it takes a message to travel
between them. To make sure the number of hops between two indirectly linked domains is as small
as possible, you can list the route a message would take from one domain to the other in
ConsoleOne.

After starting the Link Configuration tool:
1 Select a domain from the drop-down list.
2 Select a domain in the Indirect links list.

3 Click View > Link Path to see a list of the hops between the two domains.

[ GroupWise Link Configuration Tool - \\PRY-GWDOCSB!5YS5h ¢ =101 x|
File Edit Search Yiew YWindow Help

g0 FR[E] 7| Rl B =l B

® 1 ink path: Provo3 - Provnd

Provo3
Provo2
Provod

You can also use GroupWise Monitor to trace the path a message would take between two
domains. See “Link Trace Report” on page 931 and “Tracing a Link at the Monitor Web Console”
on page 950.

Viewing the Indirect Links Passing through a Domain

If a domain serves as a hop in an indirect link, making changes to that domain could affect all
indirect links passing through that domain. You can list all the indirect links that pass through a
domain in ConsoleOne.

After starting the Link Configuration tool:

1 Click View > Link Hop to list all domains in your system.

Select a Domain x|
Domain ‘ A |
Provo1
Provo2 Cancel |
Provo3
Provod Help |

2 Double-click a domain to list the indirect links passing through it.
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I GroupWise Link Configuration Tool - "m,"-.‘PRV—GW"-.,SYS"\.,gwsyste'if: — 3|
File Edit Search Wiew Window Help

5 Oa,l‘@l 7 Rl&l ?{:l‘ﬁal |Pravat (Primany) =l Elm”
[8 Hop Domain Name: Provo2 M=k
Domain | Hop Domain Name | Dest Domain Name |

Provo2 Provod
Provo2 Provod

Provo1
Prove3

3 Ifyouneed to reroute a link, right-click the link, then click Edit to open the Edit Domain Link
dialog box and make changes as needed.

You can also use GroupWise Monitor to check the links passing through a selected domain. See
“Link Configuration Report” on page 932 and “Checking Links Configuration at the Monitor Web
Console” on page 950. However, you cannot change link information using Monitor.

Viewing the Gateway Links Passing through a Gateway

Before making changes to a gateway, you can list all the links that pass through the gateway.

After starting the Link Configuration tool:

1 Click View > Gateway Hop to list all gateways in your system.

Select a Gateway |
F— | ev— | ‘OKl
GWIA PProvo1 |
cancel |
Help |

2 Double-click a gateway to list the domains linked through that gateway.

Gruupwise Link Configuration Tool - "w,"-.‘PRV—GW"-.,SYS"‘.,gwsystE'.I{: = |E| 5'
File Edit Search View MWindow Help
i Y L]
ol e 2| Bla Blw = =M
(8 Gateway Hop: GWIA = =] 3
Damain | Gateway | Dest Domain Name |
Provo1 |Gwia |Provos |

3 If you need to reroute a link, right-click the link, then Edit to open the Edit Domain Link
dialog box and make changes as needed.
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Saving and Synchronizing Link Configuration Information

Whenever you modify link configuration information, a cautionary symbol (see “Link Status
Symbols” on page 143) appears next to the modified link until you save the current link
configuration by clicking Edit > Save. If you are making extensive changes to link configuration
information, you should save regularly. When you save, the information is written out to the
domain database (wpdomain.db) for the domain to which you are currently connected. You can
change to a different domain database without exiting the Link Configuration tool by clicking File
> QOpen.

The MTA routinely synchronizes the information in the domain databases throughout your
GroupWise system. If you are making extensive changes to link configuration information, you
can synchronize the information immediately by clicking Edit > Synchronize.

Interpreting Link Symbols
As you modify links, you see symbols that represent the various link types. Along with the link
type symbols, you sometimes see link status symbols.
+ “Link Type Symbols” on page 143
+ “Link Status Symbols” on page 143

Link Type Symbols
Link Type Meaning
Symbol
S Direct link
=¥ Indirect link
%, Gateway link
% TCP/IP link to domain
N TCP/IP link to post office
% Undefined link

Link Status Symbols

Link Status Meaning

Symbol

+ Link modification not yet saved

7 Link modification not yet synchronized
ci]-': Insufficient rights to modify link

2 Rights not yet checked
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Modifying Links

In “Post Office Agent” on page 415 and “Message Transfer Agent” on page 555, detailed
instructions for changing link types are provided as outlined below:
Changing the Link Protocol between the Post Office and the Domain

+ “Using TCP/IP Links between the Post Office and the Domain” on page 443

+ “Using Mapped or UNC Links between the Post Office and the Domain” on page 444

Changing the Link Protocol between Domains
+ “Using TCP/IP Links between Domains” on page 579
+ “Using Mapped or UNC Links between Domains” on page 582

* “Using Gateway Links between Domains” on page 583
Customizing Link Configuration

+ “Using Routing Domains” on page 591

* “Scheduling Direct Domain Links” on page 593

* “Using a Transfer Pull Configuration” on page 596
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