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25 Understanding GroupWise Databases

Your GroupWise® system includes numerous databases where vital information is stored.

“Domain Databases” on page 341

“Post Office Databases” on page 341

“User Databases” on page 342

“Message Databases” on page 342

“Library Databases” on page 342

“Guardian Databases” on page 343

Domain Databases
The domain database (wpdomain.db) in each domain contains all administrative information for 
the domain, including:

Address information about all GroupWise objects (such as users and resources), post offices, 
and gateways in the domain

System configuration and linking information for the domain’s MTA

Address and message routing information to other domains

The first domain you create is the primary domain. In the primary domain, the wpdomain.db file 
contains all administrative information for your entire GroupWise system (all domains, post 
offices, users, and so on). Because the wpdomain.db file in the primary domain is so crucial, you 
should back it up regularly and keep it secure. See “Backing Up a Domain” on page 375.

You can re-create your entire GroupWise system from the primary domain wpdomain.db file; 
however, if the primary domain wpdomain.db file becomes unusable, you can no longer make 
administrative updates to your GroupWise system.

In a secondary domain, the wpdomain.db file contains administrative information about that 
secondary domain only. 

For the location of the domain database, see “Domain Directory” in GroupWise 6.5 
Troubleshooting 3: Message Flow and Directory Structure. For additional domain information, see 
“Information Stored in the Domain” on page 558.

Post Office Databases
The post office database (wphost.db) in each post office contains all administrative information for 
the post office, including a copy of the GroupWise Address Book. This information is necessary 
for users to send messages to others in the GroupWise system.
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For the location of the post office database, see “Post Office Directory” in GroupWise 6.5 
Troubleshooting 3: Message Flow and Directory Structure. For more post office information, see 
“Information Stored in the Post Office” on page 418.

User Databases
Each member of the post office has a personal database (userxxx.db) which represents the user’s 
mailbox. The user database contains the following:

Message header information

Pointers to messages

Personal groups

Personal address books

Rules

When a member of another post office shares a folder with one or more members of the local post 
office, a “prime user” database (puxxxxx.db) is created to store the shared information. The “prime 
user” is the owner of the shared information.

Local user databases and prime user databases are stored in the ofuser directory in the post office.

Because resources are addressable just like users, resources also have user databases.

For the location of user databases in the post office, see “Post Office Directory” in GroupWise 6.5 
Troubleshooting 3: Message Flow and Directory Structure. For more post office information, see 
“Information Stored in the Post Office” on page 418.

Message Databases
Each member of the post office is assigned to a message database (msgnn.db) where the body 
portions of messages are stored. Many users in a post office share a single message database. There 
can be as many as 25 message databases in the post office. Message databases are stored in the 
ofmsg directory in the post office. 

Outgoing messages from local senders are stored in the message database assigned to each sender. 
Incoming messages from users in other post offices are stored in the message database with the 
same name as the message database assigned to the sender in his or her own post office. In each 
case, only one copy of the message is stored in the post office, no matter how many members of 
the post office it is addressed to.

For the location of message databases in the post office, see “Post Office Directory” in GroupWise 
6.5 Troubleshooting 3: Message Flow and Directory Structure. For more post office information, 
see “Information Stored in the Post Office” on page 418.

Library Databases
A library is a collection of documents and document properties stored in a database system that 
can be managed and searched. You do not need to set up libraries unless you are using GroupWise 
Document Management Services (DMS). See “Libraries and Documents” on page 261.

The databases for managing libraries are stored in the gwdms directory and its subdirectories in 
the post office.
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The dmsh.db file is a database shared by all libraries in the post office. It contains information 
about where each library in the post office is located.

Each library has its own subdirectory in the gwdms directory. In each library directory, the 
dmxxnn01-FF.db files contain information specific to that library, such as document properties 
and what users have rights to access the library.

For the location of library databases in the post office, see “Post Office Directory” in GroupWise 
6.5 Troubleshooting 3: Message Flow and Directory Structure. For more post office information, 
see “Information Stored in the Post Office” on page 418.

The actual documents in a library are not kept in the library databases. They are kept in a document 
storage area, which consists of a series of directories for storing documents. Documents are 
encrypted and stored in BLOBs (binary large objects) to make document management easier. A 
document, its versions, and related objects are stored together in the same BLOB.

A document storage area might be located in the post office itself, or in some other location where 
more storage space is available. If it is located in the post office, the document storage area can 
never be moved. Therefore, storing documents in the post office directory structure is not usually 
recommended. If it is stored outside the post office, a document storage area can be moved when 
additional disk space is required.

See Chapter 22, “Creating and Managing Libraries,” on page 269 and Chapter 23, “Creating and 
Managing Documents,” on page 303 for more information about Document Management 
Services.

Guardian Databases
The guardian database (ngwguard.db) serves as a reference for the following subordinate 
databases in the post office:

User databases (userxxx.db)

Message databases (msgnn.db)

Prime user databases (puxxxxx.db)

Library databases (dmsh.db and dmxxnn01-FF.db)

The guardian database stores information that is common among all databases, thus eliminating 
duplication of information. The subordinate databases reference information stored in the guardian 
database. The benefits of the guardian database include the following:

Single Reference Point: The guardian database stores information for each post office. 
Instead of storing the dictionary information in multiple dictionary databases, it is stored once 
in the guardian database.

Increased Performance: When the information in the guardian database is accessed, it is 
written to cache memory. Each subsequent request can be handled with information already 
available in cache memory, which is faster than disk access.

Tracking Attachments and Documents: When an attachment or document becomes 
orphaned (loses pointers to the message or profile), the guardian database is used to re-locate 
the origination of the attachment or document.

GroupWise Remote Management: When a user starts GroupWise Remote, a local guardian 
database is created on the remote workstation to store information similar to the guardian 
database in the remote user’s post office in the master system. 
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The guardian database is vital to GroupWise functioning. Therefore, the POA has an automated 
back-up and roll-forward process to protect it. The POA keeps a known good copy of the guardian 
database called ngwguard.fbk. Whenever it modifies the ngwguard.db file, the POA also records 
the transaction in the roll-forward transaction log called ngwguard.rfl. If the POA detects damage 
to the ngwguard.db file on startup or during a write transaction, it goes back to the ngwguard.fbk 
file (the “fall back” copy) and applies the transactions recorded in the ngwguard.rfl file to create a 
new, valid and up-to-date ngwguard.db.

In addition to the POA back-up and roll-forward process, you should still back up the 
ngwguard.db, ngwguard.fbk, and ngwguard.rfl files regularly to protect against media failure. 
Without a valid ngwguard.db file, you cannot access your e-mail. With current ngwguard.fbk and 
ngwguard.rfl files, you can rebuild a valid ngwguard.db file should the need arise.

The ngwguard.dc file is the structural template for building the guardian database and its 
subordinate databases. Also called a dictionary file, the ngwguard.dc file contains schema 
extension information, such as administrator-defined fields, data types, and record indexes. If this 
dictionary file is missing, no additional databases can be created in the post office.
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26 Maintaining Domain and Post Office Databases

Occasionally, it is necessary to perform maintenance tasks on domain databases (wpdomain.db) or 
post office databases (wphost.db). The frequency depends on the reliability of your network and 
your own experience of how often problems are likely to occur. The following tasks help you 
maintain the integrity of your domain and post office databases:

“Validating Domain or Post Office Databases” on page 345

“Recovering Domain or Post Office Databases” on page 346

“Rebuilding Domain or Post Office Databases” on page 349

“Rebuilding Database Indexes” on page 351
NOTE: Unfortunately, damage to databases cannot be prevented. A power outage can occur in the middle of 
a write to a database. A hard drive can fail. However, the GroupWise tools for repairing damaged databases 
are very effective and should be able to resolve most damage to GroupWise databases.

To further protect your GroupWise® system against loss of domain and post office information, 
see Chapter 31, “Backing Up GroupWise Databases,” on page 375 and Chapter 32, “Restoring 
GroupWise Databases from Backup,” on page 379. 

To ensure that the same information exists in all domain and post office databases throughout your 
GroupWise system, see “Synchronizing the Primary Domain from a Secondary Domain” on 
page 366, “Synchronizing a Secondary Domain” on page 365, and “Synchronizing a Post Office” 
on page 364.

Validating Domain or Post Office Databases
You can validate the data in the domain and post office databases at any time without interrupting 
normal GroupWise operation. The frequency can vary depending on the size of your system and 
the number of changes you make to users, resources, and distribution lists.

1 Make sure you have full administrative rights to the domain and post office database 
directories you are validating.

2 In ConsoleOne®, browse to and select the Domain object or Post Office object where you 
want to validate the database.

3 Click Tools > GroupWise Utilities > System Maintenance.
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4 Click Validate Database > Run.

5 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database being validated. Click OK.

You will be notified if there are any physical problems, so you can then recover or rebuild the 
database. 

See “Recovering Domain or Post Office Databases” on page 346 and “Rebuilding Domain or 
Post Office Databases” on page 349.

Recovering Domain or Post Office Databases
The database recover process corrects physical problems in the database structure, but does not 
update incorrect information contained in the database.

If you receive an administrative message informing you that an internal database error has 
occurred, or if you detect database damage and don’t want to take users out of GroupWise, you 
can recover the database. If no errors are reported after the recover process, you will not need to 
take further action.

The recover process is run against a copy of the domain database (wpdomain.db) or post office 
database (wphost.db). Therefore, while the recover process is being run, you can continue to 
access the database through ConsoleOne and you do not need to stop the MTA or the POA. 

As the copy of the database is created, the recover process skips invalid records. If the number of 
records in the original wpdomain.db file or wphost.db file is different from the number in the new, 
valid copy, GroupWise will send an administrative message informing you that data has been lost. 
When the recover process is completed, the backup database will be deleted.
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For convenience, the agents are configured by default to automatically recover domain and post 
office databases whenever a physical problem is encountered. See “Recovering the Domain 
Database Automatically or Immediately” on page 614 and “Recovering the Post Office Database 
Automatically or Immediately” on page 485.

To recover a specific database in ConsoleOne:

1 Make sure you have network access to the domain or post office directory for the database you 
are recovering.

Successful?

creating.ddb

NO YES

creating.ddb

Read and copy records from 
recover.ddb into creating.ddb.  Skip 
invalid records. Check the number of 

records (Y) in creating.ddb.

Delete creating.ddb.

creating.ddb
wpdomain.db

Try rebuilding 

wpdomain.db.

Notify the administrator

that wpdomain.db

could not be recovered.

Rename recover.ddb 

to wpdomain.db.

Delete recover.ddb.

 
wpdomain.db

Rename creating.ddb 

to wpdomain.db.

wpdomain.db has been

successfully recovered.

 wpdomain.db

Check the number of 

records (X) in wpdomain.db.

wpdomain.db
creating.ddb

Rename wpdomain.db

to recover.ddb.

recover.ddb

recover.ddb
wpdomain.db

X=Y?NO YES

wpdomain.db  

is useable.

Notify the administrator

that information has 

been lost in the 

recovery process.

 
wpdomain.db

wpdomain.db
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If you have administration rights in the primary domain, you can recover the primary domain 
database, the post office databases in the primary domain, and any secondary domain 
databases.

From a secondary domain, you can recover the secondary domain database and the post office 
databases in the secondary domain.

2 Make sure you have sufficient disk space for the copy of the database that is created during 
recovery. 

3 In ConsoleOne, browse to and select the Domain object or Post Office object where you want 
to recover the database.

4 Click Tools > GroupWise Utilities > System Maintenance.

5 Click Recover Database > Run.

6 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database being validated. Click OK.

If recovery is successful, the backup database is deleted, and the new domain database is renamed 
to wpdomain.db, or the new post office database is renamed to wphost.db.

If recovery fails for any reason, the backup database will be copied back to wpdomain.db or 
wphost.db. If any data was lost, you will be notified by an administrative message.

You have several options for retrieving lost data from other sources:

If data has been lost from the primary domain, you can synchronize it with a secondary 
domain that is known to contain current information. See “Synchronizing the Primary Domain 
from a Secondary Domain” on page 366.

If data has been lost from a secondary domain, you can synchronize it with the primary 
domain. See “Synchronizing a Secondary Domain” on page 365.

You can also rebuild the database at a later time when you have exclusive access to the 
database where the data has been lost. See “Rebuilding Domain or Post Office Databases” on 
page 349.
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Rebuilding Domain or Post Office Databases
In addition to correcting the physical problems resolved by the database recover process, the 
rebuild process updates user and object information in a domain database (wpdomain.db) or post 
office database (wphost.db). However, the process requires that no users or GroupWise agents 
(MTA or POA) have access to the database during the rebuild process.

You should rebuild a domain or post office database if you encounter any of the following 
conditions:

Objects are not being replicated between domains.

The agent that writes to the database went down unexpectedly.

The server where the database resides went down unexpectedly.

You receive an administrative message informing you that an internal database error has 
occurred or there is database damage and you think there might be data loss.

You ran the recover database process and received a notification of data loss.

When you rebuild a secondary domain database, information is retrieved from the primary 
domain. When you rebuild a post office database, information is retrieved from the domain it 
belongs to.

During the rebuild process, a backup of the domain or post office database is created as well as a 
new wpdomain.db or wphost.db. The records from the primary domain database are copied into 
the new wpdomain.db. There should not be any data loss. When the rebuild process is complete, 
the temporary database and the backup database are deleted.
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To rebuild a database:

1 All GroupWise agents that might access the database must be stopped during the rebuild. See 
“Stopping the MTA” on page 609 and “Stopping the POA” on page 480.

2 If you are rebuilding a post office database, all users should exit and you should disable the 
post office before the rebuild. See “Disabling a Post Office” on page 183.

3 Make sure you have sufficient disk space for the copy of the database that is created during 
the rebuild process. 

4 In ConsoleOne, browse to and select the Domain object or Post Office object where you want 
to rebuild the database.

5 Click Tools > GroupWise Utilities > System Maintenance.

Primary Domain
wpdomain.db

 
wpdomain.db

Successful?

creating.ddb

NO YES

creating.ddb

Copy records from the primary 
domain wpdomain.db 

into creating.ddb.

Delete creating.ddb.

 
wpdomain.db

creating.ddb
wpdomain.db

 
wpdomain.db

Restore wpdomain.db

from backup.

Notify the administrator

that wpdomain.db

could not be rebuilt.

wpdomain.db remains

unchanged.

Delete wpdomain.db.

 
wpdomain.db

Rename creating.ddb 

to wpdomain.db.

wpdomain.db has been

successfully rebuilt.
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6 Click Rebuild Database > Run.

7 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database being rebuilt. Click OK.

Rebuilding Database Indexes
Each domain database (wpdomain.db) and post office database (wphost.db) contains three indexes 
that are used to determine the order of the Address Book: the system index, the domain index, and 
the post office index. When you display the system Address Book, the system index is used. When 
you display a domain-level Address Book, the domain index is used, and when you display the 
Address Book for a post office, the post office index is used.

The GroupWise client uses the post office database to list users. If you are in the GroupWise client 
and the indexes for listing system, domain, and post office users are different than the domain 
database indexes, you should rebuild the post office database indexes. The most common cause of 
incorrect indexes in a post office is that the post office database was closed when you set up the 
list information.

To rebuild a database index:

1 Make sure you have administrative rights to the database whose indexes you are rebuilding.

2 In ConsoleOne, browse to and select the Domain object or Post Office object where you want 
to rebuild the database index.

3 Click Tools > GroupWise Utilities > System Maintenance.
Maintaining Domain and Post Office Databases 351



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
4 Select Rebuild Indexes for Listing, then click Run. 

5 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database being whose indexes are being rebuilt. Click OK.
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27 Maintaining User/Resource and Message 
Databases

It is sometimes necessary to perform maintenance tasks on user and resource databases 
(userxxx.db) and message databases (msgnn.db). The frequency depends on the reliability of your 
network and your own experience of how often problems are likely to occur. The following tasks 
help you maintain the integrity of your user and message databases.

“Analyzing and Fixing User and Message Databases” on page 353

“Performing a Structural Rebuild of a User Database” on page 355

“Re-creating a User Database” on page 356
NOTE: Unfortunately, damage to databases cannot be prevented. A power outage can occur in the middle of 
a write to a database. A hard drive can fail. However, the GroupWise tools for repairing damaged databases 
are very effective and should be able to resolve most damage to GroupWise databases.

To further protect your GroupWise® users against loss of mailbox contents, see Chapter 31, 
“Backing Up GroupWise Databases,” on page 375 and Chapter 32, “Restoring GroupWise 
Databases from Backup,” on page 379.

To ensure that the same information exists for users and messages throughout your GroupWise 
system, see “Synchronizing Individual Users or Resources” on page 363.

Analyzing and Fixing User and Message Databases
The Analyze/Fix option of Mailbox/Library Maintenance looks for problems and errors in user 
and resource databases (userxxx.db) and/or message databases (msgnn.db) and then fixes them if 
you select the Fix Problems option. You can analyze databases individually or you can analyze all 
user, resource, and/or message databases in one or more post offices.

To analyze and repair user, resource, and/or message databases:

1 In ConsoleOne®, browse to and select one or more User or Resource objects to check 
individual users or resources.

or

Browse to and select one or more Post Office objects to check all user and/or message 
databases in the post office.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
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3 From the Action drop-down menu, select Analyze/Fix Databases.

4 Select from the following options:

Structure: When a user experiences a problem that is related to the user, message, or library 
databases, you should perform a structure check. The structure check verifies the integrity of 
the databases and reports the amount of space that could be recovered. If there is a structural 
problem, the databases are rebuilt with free space reclaimed.

Index Check: If you select Structure, you can also select Index Check. You should run an 
index check if a user tries to open a message and gets a read error, or when sent items that 
show a delivered status in the Properties window do not appear in the recipient’s mailbox. An 
index check can be time-consuming.

Contents: The user databases (located in the ofuser directory) do not contain user messages. 
Messages are contained in the message databases under the ofmsg directory. However, the 
message databases do not contain the message attachments; these are located in the offiles 
directory. A contents check analyzes references to other items. For example, in the user 
database, Mailbox/Library Maintenance verifies that any referenced messages actually exist 
in the message database. In the message database, it verifies that any attachments that are 
referenced actually exist in the attachment directories. 

Collect Statistics: If you selected Contents, the Collect Statistics option is available to collect 
and display statistics about the post office, such as the number of messages and appointments 
in the post office and the average number per user. In addition, you can display any user 
mailboxes that have more than a specified number of items. This can help determine if some 
users are using an excessive amount of disk space. If this is a problem, you might want to 
encourage users to delete unneeded items or to use the Archive feature in the GroupWise 
client to store messages on their local drives. You can also limit the amount of disk space each 
user can have. See “Managing Disk Space Usage in the Post Office” on page 171.

Fix Problems: This option tells Mailbox/Library Maintenance to fix any problems it finds. 
Otherwise, Mailbox/Library Maintenance will just report the problems.

Reset User Disk Space Totals: Recalculates the total disk space a GroupWise user is using 
by reading the selected user mailboxes and updating the poll record used for disk space 
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management. Because disk space is user-specific, the program calculates the amount of disk 
space in use by the user in the user databases, in any of the message databases, and in the 
attachment directory. Disk space limitations do not take into account the disk space used in 
document libraries. This option is usually run if the user totals are not being reflected 
correctly.

5 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397
“Exclude” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

6 Click Run to perform the Analyze/Fix operation.

Analyze/Fix can also be run using the standalone GroupWise Check program. See “GroupWise 
Check” on page 391. It can also be scheduled to run on a regular basis by properly configuring the 
POA. See “Scheduling Database Maintenance” on page 467.

Performing a Structural Rebuild of a User Database
The Structural Rebuild option of Mailbox/Library Maintenance rebuilds the structure of a user or 
resource database (userxxx.db) and reclaims any free space. It does not re-create the contents of 
the database. If you need to recover database contents as well as structure, see “Re-creating a User 
Database” on page 356.

To rebuild a user database:

1 In ConsoleOne, browse to and select one or more User or Resource objects whose database 
needs to be rebuilt.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
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3 From the Action drop-down list, select Structural Rebuild.

4 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

5 Click Run to perform a structural rebuild of the user database.

Re-creating a User Database
The Re-create User Database option of Mailbox/Library Maintenance will rebuild a user or 
resource database (userxxx.db) and recover any information it can. Some information is lost, such 
as the folder assignments. 

You should never need to select this option for regular database maintenance. It is designed for 
severe problems, such as replacing a user database that has been accidentally deleted and for which 
you have no backup copy. Because folder assignments are lost, all items are placed into the 
Cabinet folder. The user must then reorganize all the items in his or her mailbox. Use of filters and 
searching can facilitate this process, but it is not a desirable experience. It is, however, preferable 
to losing everything.

To re-create a user database:

1 In ConsoleOne, browse to and select one or more User or Resource objects that need the user 
database re-created.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
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3 From the Action drop-down list, select Re-create User Database.

4 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

5 Click Run to re-create the user database.
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28 Maintaining Library Databases and Documents

GroupWise® Document Management Services (DMS) uses libraries as repositories for 
documents. For a review of library database structure, see “Library Databases” on page 342.

“Analyzing and Fixing Databases for Libraries and Documents” on page 359

“Analyzing and Fixing Library and Document Information” on page 360
NOTE: Unfortunately, damage to databases cannot be prevented. A power outage can occur in the middle of 
a write to a database. A hard drive can fail. However, the GroupWise tools for repairing damaged databases 
are very effective and should be able to resolve most damage to GroupWise databases.

Analyzing and Fixing Databases for Libraries and Documents
For libraries, the Analyze/Fix Databases option of Mailbox/Library Maintenance looks for 
problems and errors in library and document databases and then fixes them if you select the Fix 
Problems option.

To analyze and repair library and document databases:

1 In ConsoleOne®, browse to and select one or more Library objects.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

3 From the Action drop-down menu, select Analyze/Fix Databases.

4 Select from the following options:
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Structure: When a user experiences a problem that is related to the library databases, you 
should perform a structure check. The structure check verifies the integrity of the databases 
and reports the amount of space that could be recovered. If there is a structural problem, the 
databases are rebuilt with free space reclaimed.

Index Check: If you select Structure, you can also select Index Check. An index check can 
be time-consuming.

Contents: The library database (located in the gwdms directory of the post office) does not 
contain documents. Documents are stored in the lib0000-FF directories. A contents check 
analyzes references from libraries to documents. 

Collect Statistics: If you selected Contents, the Collect Statistics option is available to collect 
and display statistics about the library, such as the number and size of documents.

Fix Problems: This option tells Mailbox/Library Maintenance to fix any problems it finds. 
Otherwise, Mailbox/Library Maintenance will just report the problems.

5 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

6 Click Run to perform the Analyze/Fix Databases operation on the library.

Analyze/Fix Databases can also be run using the standalone GroupWise Check program. See 
“GroupWise Check” on page 391. It can also be scheduled to run on a regular basis by properly 
configuring the POA. See “Scheduling Database Maintenance” on page 467.

Analyzing and Fixing Library and Document Information
The Analyze/Fix Library option of Mailbox/Library Maintenance performs more library-specific 
functions that Analyze/Fix Databases. For all options except Verify Library, all documents in each 
of the selected library databases are checked. This can be a time-consuming process. Therefore, if 
you intend to select more than one of the Analyze/Fix Library options, you can save time by 
selecting each of them before clicking Run. This causes all selected options to be run against each 
document, which is faster than running each option individually against all documents.

To validate library databases:

1 In ConsoleOne, browse to and select one or more Post Office objects where you want to 
validate libraries.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
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3 From the Action drop-down menu, select Analyze/Fix Library.

4 Select from the following options:

Verify Library: This is a post office-level check. It verifies that all libraries are on the 
libraries list. It also checks the schema and guarantees its integrity. If there is a problem with 
the schema, it resets to a default schema to reclaim any missing items. For example, if you 
deleted the Document Type property, you could recover it using this option.

Fix Document/Version/Element: This performs an integrity check to verify the following:

Each document has one or more versions linked to it.

Each version has one or more elements linked to it.

All versions are linked to a document. 

All elements are linked to a version.

If there are any missing links, the missing documents or versions are created from the 
information contained in the existing version or element for which the link is missing. For 
example, if a version is found that shows no link to a document, a document is created from 
the information contained in the version and the link is reestablished. Of course, any 
information in the lost document that might have been newer than the information contained 
in the old version is lost.

Verify Document Files: This determines if the BLOB exists for a document and the 
document is accessible. If not, an error is logged for that document. The log message does not 
indicate why a file is missing or inaccessible. You can recover a file by restoring it from 
backup.

Possible errors that would be logged include:

If the file system on the network becomes corrupted, this will tell you which documents 
cannot be opened or which BLOB files are missing. 

If a file was marked by someone as Read Only or Hidden, this option would log an error 
that the file is inaccessible.
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Validate All Document Security: This option validates document security for the Author, 
Creator and Security (document sharing) fields. The validation replaces the results of 
selecting the Validate Author/Creator Security option, and is more thorough. Therefore, you 
only need to select one option or the other.

Synchronize User Name: The Author and Creator fields display users’ full names, not unique 
IDs. If a user’s name is changed, such as for marriage, this option verifies that the user’s name 
on document and version records is the same as the user’s current display name. In other 
words, the Author and Creator fields in documents and versions are updated to the user’s 
newer name.

Remove Deleted Storage Areas: When you delete a document storage area in the Storage 
Areas page of a library’s details dialog box, the document storage area and the documents 
stored there remain on the system. Deleting the storage area from the library only means that 
new documents will not be stored there. The documents there will continue to be available to 
users.

If you want to also remove the document storage area from the system, you have two options: 
delete the storage area and its documents, or first move the documents and then delete the 
storage area. The first option is not advisable, but exists so that if you have moved all of the 
documents that can be moved, but some corrupted documents are left behind, you can force 
the document storage area to be deleted.

You should normally check the Move Documents First box so that users will continue to have 
access to those documents from a different document storage area. With this option, all 
BLOBs in the library are checked to see which documents are in the area being deleted.

Reassign Orphaned Documents: Documents can occasionally become orphaned 
(unattached to a user). For example, this can happen when a user leaves your organization and 
the user object is removed. All documents belonging to that user are no longer available in 
GroupWise searches and cannot be accessed by anyone (document security is controlled by 
the user listed in the Author and Creator fields). This option lets you reassign these documents 
to another user. You must select a new author from the browser menu after checking this 
option. The new author you designate will have access to all orphaned documents in this 
library.

Reset Word Lists: Documents stored in a library are indexed and inserted into a generated 
word list. This allows users to search for a document by keywords as well as any word 
contained within a document. The document library word list might become outdated and if 
this occurs, the word list must be regenerated. This option allows the program to regenerate 
the document library word list the next time an index operation is performed.

5 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

6 Click Run to perform the Analyze/Fix Library operation. 

Analyze/Fix Library can also be run using the standalone GroupWise Check program. See 
“GroupWise Check” on page 391. It can also be scheduled to run on a regular basis by properly 
configuring the POA. See “Scheduling Database Maintenance” on page 467.
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29 Synchronizing Database Information

In general, synchronization of object information throughout your GroupWise® system occurs 
automatically. Whenever you add, delete, or modify a GroupWise object, the information is 
automatically replicated to all appropriate databases. Ideally, each domain database 
(wpdomain.db) in your system contains original records for all objects it owns and accurately 
replicated records for all objects owned by other domains. However, because unavoidable events 
such as power outages and hardware problems can disrupt network connectivity, information in 
various databases might get out of sync.

If you think you have a synchronization problem, especially soon after adding, deleting, or 
modifying objects, it is wise to check Pending Operations to make sure your changes have been 
processed. See “Pending Operations” on page 51. When waiting for replication to take place, 
patience is a virtue.

When information differs between the original record and a replicated record, the original record 
is considered correct. If you perform synchronization from the owning domain, the owning 
domain notifies the primary domain of the correct information, then the primary domain 
broadcasts the correct information to all secondary domains. Therefore, the best place to perform 
synchronization is from the domain that owns the object that is out of sync. The next best place to 
perform synchronization is from the primary domain, because the primary domain sends a request 
to the owning domain for the correct information, then broadcasts the correct information to all 
secondary domains.

Any GroupWise object can be synchronized:

“Synchronizing Individual Users or Resources” on page 363

“Synchronizing a Post Office” on page 364

“Synchronizing a Secondary Domain” on page 365

“Synchronizing the Primary Domain from a Secondary Domain” on page 366

Synchronizing Individual Users or Resources
Most often, you will notice a synchronization problem when a user has trouble sending a message. 
Symptoms include:

The sender receives a "user is undeliverable" message.

A new user or resource created in ConsoleOne® does not appear in the Address Book in some 
or all post offices.

User or resource information is incorrect in the Address Book but correct in ConsoleOne.

A user or resource is listed in the Address Book as belonging to one post office but actually 
belongs to another.

To synchronize individual User and/or Resource objects: 
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1 In ConsoleOne, connect to the domain that owns the users and/or resources. See “Connecting 
to a Domain” on page 123.

or

Connect to the primary domain.

2 Browse to and right-click one or more User or Resource objects to synchronize, then click 
Properties.

3 Make sure the correct information appears on the object’s Identification page, then click 
Cancel.

4 Repeat Step 2 and Step 3 for each user or resource you need to synchronize.

5 Select each User or Resource object, then click Tools > GroupWise Utilities > Synchronize.

6 When you are asked whether to proceed, click Yes. 

Current, correct information will then be replicated throughout your GroupWise system.

If many User or Resource objects are being synchronized, you can check progress by viewing 
pending operations. See “Pending Operations” on page 51.

After synchronization is complete, you can verify that it was successful by checking the 
synchronized objects in Address Books and several post offices in your GroupWise system. 

If there are indications that a large number of User or Resource objects need to be synchronized, 
rebuilding the post office database (wphost.db) can be preferable to synchronizing individual 
objects. However, this process requires exclusive access to the post office database. See 
“Rebuilding Domain or Post Office Databases” on page 349.

Occasionally, GroupWise user information can get out of sync with Novell® eDirectoryTM user 
information. This requires a different type of synchronization process. See “Using eDirectory User 
Synchronization” on page 598.

Synchronizing a Post Office
If information for a particular post office does not display the same throughout your GroupWise 
system, you can synchronize the post office.

1 In ConsoleOne, connect to the domain that owns the post office. See “Connecting to a 
Domain” on page 123.

or

Connect to the primary domain.

2 Browse to and right-click the Post Office object to synchronize, then click Properties.

3 Make sure the correct information appears on the post office Identification page, then click 
Cancel.

4 Select the Post Office object, then click Tools > GroupWise Utilities > Synchronize.

5 When you are asked whether to proceed, click Yes. 

Current, correct post office information will then be replicated throughout your GroupWise 
system.

After synchronization is complete, you can verify that it was successful by checking the post 
office information when connected to different domains in your GroupWise system. 

See also “Rebuilding Domain or Post Office Databases” on page 349.
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Synchronizing a Library
If information for a library does not display the same throughout your GroupWise system, you can 
synchronize the library.

1 In ConsoleOne, connect to the domain that owns the library. See “Connecting to a Domain” 
on page 123.

or

Connect to the primary domain.

2 Browse to and right-click the Library object to synchronize, then click Properties.

3 Make sure the correct information appears on the library Identification page, then click 
Cancel.

4 Select the Library object, then click Tools > GroupWise Utilities > Synchronize.

5 When you are asked whether to proceed, click Yes. 

Current, correct library information will then be replicated throughout your GroupWise 
system.

After synchronization is complete, you can verify that it was successful by checking the 
library information when connected to different domains in your GroupWise system. 

See also “Analyzing and Fixing Library and Document Information” on page 360.

Synchronizing a Secondary Domain
If information for a particular secondary domain does not display the same throughout your 
GroupWise system, you can synchronize the secondary domain.

1 In ConsoleOne, connect to the primary domain. See “Connecting to a Domain” on page 123.

2 If there is any doubt about the correctness of that secondary domain’s information as stored 
in the primary domain database, synchronize the primary domain with the secondary domain 
before proceeding. See “Synchronizing the Primary Domain from a Secondary Domain” on 
page 366.

3 Browse to and right-click the Domain object to synchronize, then click Properties.

4 Make sure the correct information appears on the domain Identification page, then click 
Cancel.

5 Select the Domain object, then click Tools > GroupWise Utilities > Synchronize.

6 When you are asked whether to proceed, click Yes. 

Current, correct domain information for the secondary domain will then be replicated 
throughout your GroupWise system.

After synchronization is complete, you can verify that it was successful by checking the 
domain information when connected to different domains in your GroupWise system. 

See also “Rebuilding Domain or Post Office Databases” on page 349.
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Synchronizing the Primary Domain from a Secondary Domain
Information about a secondary domain stored in the secondary domain database is considered 
more current and correct than information about that secondary domain stored in the primary 
domain database. If the primary domain database contains out-of-date information, you can 
synchronize the primary domain from the secondary domain.

When you synchronize the primary domain database from a secondary domain database, any 
records the secondary domain owns, such as post offices or users added to the secondary domain, 
are replicated from the secondary domain database to the primary domain database.

To synchronize the primary domain from a secondary domain:

1 You must have administrative rights to the primary domain directory and the secondary 
domain directory from which the primary domain is being synchronized.

2 In ConsoleOne, browse to and select the Domain object of the secondary domain whose 
database you want to use to synchronize the primary domain database.

3 Click Tools > GroupWise Utilities > System Maintenance.

4 Select Sync Primary with Secondary, then click Run.

5 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database being validated. Click OK.

To make sure the primary domain database is totally up-to-date, repeat the procedure for each 
secondary domain in your system. 
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30 Managing Database Disk Space

One of the most common maintenance issues in a growing system is running out of disk space. In 
addition to sending messages, users tend to use GroupWise® for all sorts of communication, such 
as transferring large files. Library documents created with Document Management Services 
(DMS) can use huge amounts of disk space. Archived library documents can also quickly use up 
disk space assigned to the post office, where space is usually limited.

You should let your users know about the archive and auto-delete features of GroupWise mail, or 
set client options in ConsoleOne® to automatically archive or delete. See Chapter 74, “Setting 
Defaults for the GroupWise Client Options,” on page 973.

“Gathering Mailbox Statistics” on page 367

“Reducing the Size of User and Message Databases” on page 369

“Reclaiming Disk Space in Domain and Post Office Databases” on page 370

“Reducing the Size of Libraries and Document Storage Areas” on page 371

See also “Managing Disk Space Usage in the Post Office” on page 171.

Gathering Mailbox Statistics
If you have some users who don’t like to throw anything away, you might want to monitor the size 
of their mailboxes and, where appropriate, suggest voluntary cleanup. You can assess e-mail 
retention by the number of messages, age of messages, or size of user databases.

The Mailbox Statistics option in Mailbox/Library Maintenance collects and displays statistics 
about the post office, such as the number of messages and appointments in the post office and the 
average number per user. It is valid only for user databases. In addition, you can display any user 
mailboxes that have more than a specified number of items. This can help determine which users 
might be using an excessive amount of file server disk space.

To gather mailbox statistics: 

1 In ConsoleOne, browse to and select one or more User or Resource objects or one or more 
Post Office objects.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
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3 From the Action drop-down menu, select Mailbox Statistics.

4 Select Mailbox Statistics.

Mailbox Statistics: Enter a maximum number of items. You will see a report showing each 
user whose mailbox has more items in it than the number you specify.

or

Select Expire Statistics.

Expire Statistics: Select one of the following:

Items Older Than: Shows how many items are older than the number of days you 
specify. 

Downloaded Items Older Than: Shows how many items have been downloaded to 
users’ GroupWise Caching or Remote mailboxes that are older than the number of days 
you specify. This does not include items that have been downloaded to non-GroupWise 
mailboxes (for example, POP and IMAP accounts).

Items Larger Than: Shows how many items are larger than the size you specify.

Reduce Mailbox To: Shows how many items need to be expired before the mailbox 
would be reduced to the size you specify. Older, larger items are expired before newer, 
smaller items.

Reduce Mailbox to Limited Size: Shows how many items need to be expired before the 
mailbox is the size specified using the Disk Space Management feature under Client 
Options, as described in “Setting Mailbox Size Limits” on page 172.

5 In the Include box, select Received Items, Sent Items, Calendar Items, and/or Only Backed-
Up Items to specify the types of items to gather statistics for.

6 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
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“Results” on page 396
“Misc” on page 397
“Exclude” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

By default, the mailbox statistics are sent to the domain administrator, as designated in 
“Notifying the Domain Administrator” on page 632.

7 If you want to send the statistics to one or more other users, click Results, select Individual 
Users, specify the e-mail addresses in the users in the CC line, then click Message if you want 
to include explanatory text.

8 Click Run to gather the mailbox statistics and e-mail the results to the specified users.

Reducing the Size of User and Message Databases
The Expire/Reduce Messages option of Mailbox/Library Maintenance eliminates expired 
messages and reclaims any free space in the database. You can expire/reduce messages for one or 
more users or resources, or for all users and resources in one or more post offices. You should 
inform users before you run this process so they have a chance to archive or delete messages.

1 In ConsoleOne, browse to and select one or more User or Resource objects to expire/reduce 
messages for the selected users and resources.

or

Browse to and select one or more Post Office objects to expire/reduce messages for all users 
and resources in each selected post office.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

3 From the Action drop-down menu, select Expire/Reduce Messages.

4 Click Reduce Only to delete items that have already expired.
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or

Click Expire and Reduce.

Expire and Reduce: Select one or more of the following:

Items Older Than: Expires items that are older than the number of days you specify. 

Downloaded Items Older Than: Expires items that have been downloaded to users’ 
GroupWise Caching or Remote mailboxes that are older than the number of days you 
specify. It does not expire items that have been downloaded to non-GroupWise 
mailboxes (for example, POP and IMAP accounts).

Items Larger Than: Expires items that are larger than the size you specify.

Trash Older Than: Expires items in the Trash that are older than the number of days you 
specify.

Reduce Mailbox To: Expires items until the mailbox is reduced to the size you specify. 
Older, larger items are expired before newer, smaller items.

Reduce Mailbox to Limited Size: Expires items until the mailbox is the size specified 
using the Disk Space Management feature under Client Options, as described in “Setting 
Mailbox Size Limits” on page 172.

5 In the Include box, select Received Items, Sent Items, Calendar Items, and/or Only Backed-
Up Items. You might want to notify users of the types of items that will be deleted.

6 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397
“Exclude” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

7 Click Run to perform the Expire/Reduce Messages operation.

For additional disk space management assistance, see “Managing Disk Space Usage in the Post 
Office” on page 171.

Reclaiming Disk Space in Domain and Post Office Databases
As you add information to your system, the domain databases (wpdomain.db) and post office 
databases (wphost.db) increase in size. If you delete information, the space created in the databases 
for the information is not immediately recovered. GroupWise will use the free space before 
requiring more disk space; however, if you have deleted a large amount of information, you might 
want to reclaim unused database space. If you have frequent changes to your users, especially 
deletions, you should occasionally reclaim disk space.

1 In ConsoleOne, browse to and select the Domain object or Post Office object where you want 
to reclaim disk space.

2 Click Tools > GroupWise Utilities > System Maintenance.
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3 Select Reclaim Unused Space, then Run.

4 When prompted, make sure the Path to Database is correct. If an incorrect path is displayed, 
browse to and select the path to the database where you want to reclaim disk space. Click OK.

Reducing the Size of Libraries and Document Storage Areas
The amount of disk space you allow at each post office for your library databases varies according 
to the GroupWise features they use.

If you are using GroupWise Document Management Services, you will need to determine storage 
requirements for your documents. If you feel your current disk space usage by documents is not 
representative of your long-term requirements, you can estimate the disk space users will need for 
documents by multiplying an average document size by the average number of documents per user 
by the total number of users in the post office.

For example, the typical document size is 50 KB. Each user owns about 50 documents and there 
are 100 users on your post office.

Sample Calculation: 

50 KB (document size)

x 50 documents (per user)

x 100 users

-----

2.5 GB of disk space

Be sure to allow your libraries room to grow.

When room to grow is no longer available, the following tasks help you make the best use of 
available disk space:

“Archiving and Deleting Documents” on page 372

“Deleting Activity Logs” on page 373

See also “Backing Up and Restoring Archived Documents” on page 328.
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Archiving and Deleting Documents
Documents can be archived, retained indefinitely, or simply deleted. The document type property 
determines a document’s disposition (archive, delete, or retain). The document life property 
determines when it can be archived or deleted. When you run the Archive/Delete Documents 
option of Mailbox/Library Maintenance, documents in the selected libraries that have reached 
their document life dates are either deleted or archived.

Documents that have reached their document life and been marked for deletion in the document 
type are simply deleted from the library, after which the document and its property information 
can no longer be found by any search. You can recover deleted documents from database backups.

When documents are archived, their BLOBs are moved to archive directories. These directories 
are named arnnnnnn (where nnnnnn is an incremented integer with leading zeros), and are 
automatically created as needed. They are sometimes referred to as archive sets. The archive 
directories are located at post_office_directory\gwdms\lib01-FF\archive. When a document is 
archived, GroupWise determines if the document BLOB will fit in the current archive directory. 
If the BLOB will not fit, another archive directory is created and the BLOB is archived there.

To archive/delete documents from one library or all libraries in the selected post offices:

1 In ConsoleOne, select one or more Library objects or Post Office objects for the documents 
you want to archive/delete.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

3 From the Action drop-down menu, select Archive/Delete Documents.

4 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397
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Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

5 Click Run to perform the Archive/Delete Documents operation.

Deleting Activity Logs
To free up disk space by deleting the activity logs for one or more libraries:

1 In ConsoleOne, select one or more Library objects or Post Office object where you want to 
delete activity logs.

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

3 From the Action drop-down menu, select Delete Activity Logs.

4 Enter the number of days in the Delete Activity Logs Older Than field. The default is 60 days.

5 Using the tabs at the bottom of the Mailbox/Library Maintenance dialog box, set the following 
options:

“Databases” on page 396
“Logging” on page 396
“Results” on page 396
“Misc” on page 397

Selected options can be saved for repeated use. See “Saving Mailbox/Library Maintenance 
Options” on page 397.

6 Click Run to delete unneeded activity logs.
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31 Backing Up GroupWise Databases

You should back up GroupWise® databases regularly so that if a database sustains damage that 
cannot be repaired using the GroupWise database maintenance tools, you can still recover with 
minimum data loss. 

“Backing Up a Domain” on page 375

“Backing Up a Post Office” on page 375

“Backing Up a Library and Its Documents” on page 376

“Backing Up Individual Databases” on page 377

Backing Up a Domain
All critical domain-level information is stored in the domain database (wpdomain.db). 

On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup program 
or other backup software of choice to back up each domain database to a secure location. For 
details about how to use a Target Service Agent, see “Target Service Agents” on page 398.

On Linux and Windows, use your backup software of choice to back up each domain database to 
a secure location. For a list of compatible products, see the Partner Product Guide (http://
www.novell.com/partnerguide). You can also use the GroupWise Database Copy utility (DBCopy) 
and the GroupWise Time Stamp utility (GWTMSTMP) to assist with backups. For details about 
how to use these utilities, see “Standalone Database Maintenance Programs” on page 391. If your 
backup software cannot handle open files, stop the MTA for the domain while the backup of the 
domain database takes place.

See also “Restoring a Domain” on page 379.

Backing Up a Post Office
Critical post office-level information is stored in many different databases. The table below 
summarizes the databases and their locations:

Database Location

wphost.db \post_office_directory

ngwguard.db \post_office_directory

msgnn.db \post_office_directory\ofmsg

userxxx.db \post_office_directory\ofuser

puxxxxx.db \post_office_directory\ofuser
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To view a post office directory structure diagram, see “Post Office Directory” in GroupWise 6.5 
Troubleshooting 3: Message Flow and Directory Structure.

On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup program 
or other backup software of choice to regularly back up all databases in each post office to a secure 
location. For details about how to use a Target Service Agent, see “Target Service Agents” on 
page 398.

On Linux and Windows, use your backup software of choice to back up each post office to a secure 
location. For a list of compatible products, see the Partner Product Guide (http://www.novell.com/
partnerguide). You can also use the GroupWise Database Copy utility (DBCopy) and the 
GroupWise Time Stamp utility (GWTMSTMP) to assist with backups. For details about how to 
use these utilities, see “Standalone Database Maintenance Programs” on page 391.

See also “Restoring a Post Office” on page 379.

Backing Up a Library and Its Documents
If the document storage area for a library is physically located in a post office, the library and 
documents are backed up along with the rest of the data in the post office. However, document 
storage areas are frequently located outside of the post office directory structure due to disk space 
considerations. Therefore, remote document storage areas must be backed up separately. A post 
office can have multiple libraries and each library can have multiple document storage areas, so 
make sure you have identified all document storage areas in your library/document backup 
procedure.

On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup program 
or other backup software of choice to back up document storage areas. For details about how to 
use a Target Service Agent, see “Target Service Agents” on page 398.

On Linux and Windows, use your backup software of choice to back up each document storage 
area to a secure location. For a list of compatible products, see the Partner Product Guide (http://
www.novell.com/partnerguide).

After you have initially performed a full backup of your document storage areas, you can perform 
incremental backups by backing up to the same location to shorten the backup process.

To ensure consistency between the backups of post office databases and document storage areas:

1 Back up your document storage areas.

2 Back up the post office. See “Backing Up a Post Office” on page 375.

*.idx and *.inc \post_office_directory\ofuser\index

fd0-F6 \post_office_directory\offiles

dmsh.db \post_office_directory\gwdms

dmxxnn01-FF.db \post_office_directory\gwdms\lib0000-FF

fd0-FF \post_office_directory\gwdms\lib0000-FF\docs

*.idx and *.inc \post_office_directory\gwdms\lib0000-FF\index

Database Location
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3 Perform an incremental backup of your document storage areas to pick up all new documents 
and document modifications that occurred while backing up the post office.

You should need to restore data in a document storage area only if files have been damaged or 
become inaccessible due to a hard disk failure.

See also “Restoring a Library” on page 380.

Backing Up Individual Databases
If you need to back up individual databases separately from backing up a post office, you can use 
your backup software of choice.

See also “Restoring an Individual Database” on page 380.
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32 Restoring GroupWise Databases from Backup

Database damage can usually be repaired using the database maintenance tools provided with 
GroupWise®. Only very occasionally should you need to restore databases from backup.

“Restoring a Domain” on page 379

“Restoring a Post Office” on page 379

“Restoring a Library” on page 380

“Restoring an Individual Database” on page 380

“Restoring Deleted Mailbox Items” on page 381

“Recovering Deleted GroupWise Accounts” on page 384

Restoring a Domain
Typically, damage to the domain database (wpdomain.db) can be repaired using the database 
maintenance tools provided in ConsoleOne®. See Chapter 26, “Maintaining Domain and Post 
Office Databases,” on page 345.

If damage to the domain database is so severe that rebuilding the database is not possible:

1 Stop the MTA for the domain. See “Stopping the MTA” on page 609.

2 On NetWare, use a Target Service Agent (GWTSA of TSAFS) with a supported backup 
program or your backup software of choice to restore the domain database into the domain 
directory. See “Target Service Agents” on page 398. 

or

On Linux or Windows, use your backup software of choice to restore the domain database into 
the domain directory.

3 Restart the MTA for the domain. See “Starting the MTA” on page 568.

4 To update the restored domain database with administrative changes made since it was backed 
up, synchronize the restored domain database with the primary domain database. See 
“Synchronizing a Secondary Domain” on page 365. 

If the restored domain database is for the primary domain, see “Synchronizing the Primary 
Domain from a Secondary Domain” on page 366.

Restoring a Post Office
Typically, damage to databases in a post office can be repaired using the database maintenance 
tools provided in ConsoleOne or using GroupWise Check (GWCheck). See Chapter 26, 
“Maintaining Domain and Post Office Databases,” on page 345, Chapter 27, “Maintaining User/
Resource and Message Databases,” on page 353, and “GroupWise Check” on page 391.
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If damage to the post office was so severe that rebuilding databases is not possible:

1 Stop the POA for the post office. See “Stopping the POA” on page 480.

2 On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup 
program or your backup software of choice to restore the various databases into their proper 
locations in the post office directory. See “Target Service Agents” on page 398. 

or

On Linux or Windows, user your backup software of choice to restore the various databases 
into their proper locations in the post office directory.

3 If you do not use GWTSA to restore the post office, time-stamp the restored user databases so 
that old items will not be automatically purged during nightly maintenance. Select the Post 
Office object, then click Tools > GroupWise Utilities > Backup/Restore Mailbox. On the 
Backup tab, select Restore, then click Yes.

4 Restart the POA for the post office. See “Starting the POA” on page 431.

5 To update the restored post office database (wphost.db) with the most current information 
stored in the domain database, rebuild the post office database. See “Rebuilding Domain or 
Post Office Databases” on page 349.

6 To update other restored databases such as user databases (userxxx.db) and message databases 
(msgnn.db) with the most current information stored in other post offices, run Analyze/Fix 
Databases with Contents selected. See “Analyzing and Fixing User and Message Databases” 
on page 353. 

Restoring a Library
Typically, damage to library databases (dmsh.db and others) can be repaired using the database 
maintenance tools provided in ConsoleOne or using GroupWise Check (GWCheck). See Chapter 
28, “Maintaining Library Databases and Documents,” on page 359 and “GroupWise Check” on 
page 391.

If damage to the library is so severe that rebuilding databases is not possible:

1 Stop the POA that services the library. See “Stopping the POA” on page 480.

2 On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup 
program or your backup software of choice to restore the library. See “Target Service Agents” 
on page 398. 

or

On Linux or Windows, user your backup software of choice to restore the library.

3 Restart the POA. See “Starting the POA” on page 431.

4 To update the restored library databases with the most current information stored in other post 
offices, run Analyze/Fix Databases with Contents selected. Also run Analyze/Fix Library. See 
“Analyzing and Fixing Library and Document Information” on page 360. 

Restoring an Individual Database
Typically, damage to user and resource databases (userxxx.db) and message databases (msgnn.db) 
can be repaired using the database maintenance tools provided in ConsoleOne or using GroupWise 
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Check (GWCheck). See Chapter 27, “Maintaining User/Resource and Message Databases,” on 
page 353 and “GroupWise Check” on page 391.

If damage to an individual database is so severe that repair is not possible:

1 Make sure the user to whom the affected database belongs is not running the GroupWise 
client.

2 Use your backup software of choice to restore the database into the proper location in the post 
office directory.

User databases are stored in the ofuser subdirectory in the post office. Message databases are 
stored in the ofmsg subdirectory.

3 To update the restored database with the most current information available, run Analyze/Fix 
Databases with Contents selected. See “Analyzing and Fixing User and Message Databases” 
on page 353. 

Restoring Deleted Mailbox Items
With proper planning, you can assist users in retrieving accidently deleted items and items that 
became unavailable because of database damage.

“Setting Up a Restore Area” on page 381

“Restoring a User’s Mailbox Items” on page 383

“Letting Windows Client Users Restore Their Own Mailbox Items” on page 384
NOTE: The Cross-Platform client cannot access a restore area.

Setting Up a Restore Area
A restore area is only as useful as the post office data that is backed up regularly. Make sure you 
are backing up every GroupWise post office regularly, as described in “Backing Up a Post Office” 
on page 375.

A restore area is a location you designate to hold a backup copy of a post office so that you or 
GroupWise Windows client users can access it to retrieve mailbox items that are unavailable in 
your live GroupWise system.

To set up a restore area:

1 In ConsoleOne, click Tools > GroupWise System Operations > Restore Area Management.
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The Restore Area Directory Management dialog box lists any restore areas that currently exist 
in your GroupWise system.

2 Click Create to set up a new restore area.

3 On the Identification tab, specify a unique name for the new restore area. If desired, provide 
a lengthier description to further identify the restore area.

4 In the UNC Path field, browse to and select an existing directory that you want to use as a 
restore area.

or

Specify the full path to a new directory, which will be created by the Target Service Agent 
that performs the restore. For more information, see “Target Service Agents” on page 398.

or

For a post office on Linux, specify the full path to an existing or new directory in the Linux 
Path field, so that the Linux POA can locate the restore area. The Linux POA cannot interpret 
a UNC path.

5 Click Membership.

6 Click Add, select one or more post offices or users that need access to the new restore area, 
then click OK to add them to the membership list.

7 When the membership list is complete, click OK to create the new restore area. 
382   GroupWise 6.5 Administration Guide



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
If you display the Post Office Settings page for a post office that has a restore area assigned 
to it, you see that the Restore Area field has been filled in.

8 On NetWare, use a Target Service Agent (GWTSA or TSAFS) with a supported backup 
program to restore a backup copy of the post office into the restore area. See “Target Service 
Agents” on page 398. 

or

Use your backup software of choice to restore the backup copy.

9 Grant the POA Read and Write rights to the restore area.

10 If the restore area is located on a different server from where the post office directory is 
located, provide the POA with a username and password for logging in to the remote server.

You can provide that information using the Remote User Name and Password fields on the 
Post Office object’s Post Office Settings page, using the /user and /password startup switches, 
or using the /dn startup switch.

11 If you want users to be able to retrieve individual items themselves, grant users Read and 
Write rights to the restore area.

12 Continue with “Restoring a User’s Mailbox Items” on page 383 or “Letting Windows Client 
Users Restore Their Own Mailbox Items” on page 384 as needed.

Restoring a User’s Mailbox Items
After you have set up a restore area and placed a backup copy of a post office into it, you can 
restore a user’s mailbox items for the user.

1 In ConsoleOne, browse to and select a User object for which you need to restore mailbox 
items.

2 Click Tools > GroupWise Utilities > Backup/Restore Mailbox.

The Restore tab is automatically selected for you, with the restore area and directory location 
displayed for verification.

3 Click Yes to restore the selected user’s mailbox items into his or her mailbox.

4 Notify the user and explain the following about the restored items:

The user might want to manually delete unwanted restored items.

The user should file or archive the items that he or she wants within seven days. After 
seven days, unaccessed items will be deleted after the amount of time allowed by existing 
auto-delete settings, as described in “Environment Options: Cleanup” on page 983. If 
auto-deletion is not enabled, the restored items will remain in the mailbox indefinitely.
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Letting Windows Client Users Restore Their Own Mailbox Items
After you have set up a restore area and given Windows client users access to it, users can 
selectively restore individual items into their mailboxes. This saves you the work of restoring 
mailbox items for users and it also saves users the work of deleting unwanted restored items.

After a restore area has been set up:

1 In the GroupWise Windows client, click File > Open Backup.

2 Browse to and select the restore area directory, then click OK.

3 In the Password field, type your GroupWise password, then click OK to access the backup 
copy of your mailbox.

4 Retrieve individual items as needed.

The backup copy of your mailbox offers basic features such as Read, Search, and Undelete so 
that you can locate and retrieve the items you need.

5 When you are finished restoring items to your live mailbox, click File > Open Backup again 
to remove the check mark from the Open Backup option and return to your live mailbox. 

Recovering Deleted GroupWise Accounts
If you have a reliable backup procedure in place, as described in Chapter 31, “Backing Up 
GroupWise Databases,” on page 375, you can restore recently deleted GroupWise user and 
resource accounts.

1 Make available a backup copy of a domain database (wpdomain.db) where the deleted 
GroupWise account still exists.

2 In ConsoleOne, click Tools > GroupWise Utilities > Recover Deleted Account.

3 Browse to and select the backup copy of the domain database.

4 Select the user or resource that you need to recover the account for.

5 Click Next.
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6 If desired, click Save to Clipboard, paste it into a file, then save or print it.

7 Click Next.

8 Click Finish.

At this point, you have restored the user’s or resource’s GroupWise account into the 
GroupWise system. However, this does not restore ownership of resources, nor does the 
account’s mailbox contain any item at this point.

9 If the restored user owned resources, manually restore the ownership. See “Changing a 
Resource’s Owner” on page 227

10 To restore the contents of the account’s mailbox, follow the instructions in “Restoring Deleted 
Mailbox Items” on page 381.
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33 Retaining User Messages

GroupWise® enables you to retain user messages until they have been copied from message 
databases to another storage location. This means that a user cannot perform any action, such as 
emptying the mailbox Trash, that will result in a message being removed from the message 
database before it has been copied.

Message retention primarily consists of two activities: 1) not allowing users to remove messages 
until they have been retained and 2) retaining the messages by copying them from message 
databases to another location.

GroupWise supplies the ability to not allow users to remove messages until they’ve been retained. 
It also provides methods for message retention applications to securely access user mailboxes and 
copy messages. However, it does not provide the message retention application. You must develop 
or purchase a third-party (non-GroupWise) application that performs this service. 

“How Message Retention Works” on page 387

“Acquiring a Message Retention Application” on page 389

“Enabling Message Retention” on page 389

How Message Retention Works
To understand how message retention works, you need to understand what GroupWise does and 
what the message retention application does, as explained in the following sections:

“What GroupWise Does” on page 387

“What the Message Retention Application Does” on page 388

What GroupWise Does
During installation of the message retention application, the application uses the GroupWise 
Trusted Application API to create a trusted application record in the GroupWise system. The 
trusted application record includes a flag that designates it as a message retention application. This 
flag is surfaced through the trusted application’s Provides Message Retention Service setting in 
ConsoleOne (Tools menu > GroupWise System Operations > Trusted Applications > Edit).
Retaining User Messages 387



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
When ConsoleOne reads a trusted application record that has the Provides Message Retention 
Service setting turned on, it adds a Retention tab to the GroupWise Client Environment Options 
(Tools menu > GroupWise Utilities > Client Options > Environment). 

You use this Retention tab to enable message retention at the domain, post office, or user level, 
meaning that you can enable it for all users in a domain, all users in a post office, or individual 
users.

Turning on message retention alters the GroupWise client purge behavior by preventing a user 
from purging any messages from his or her mailbox that have not yet been retained.

What the Message Retention Application Does
Different message retention applications might vary slightly in their approach to retaining 
messages. This section provides a general approach to message retention.

To determine whether or not mailbox messages have been retained, the message retention 
application adds a time stamp to the mailbox. The message retention application can use the 
GroupWise Object API or GroupWise IMAP support to write (and read) the time stamp. In 
addition, you can use the GroupWise Time Stamp Utility (page 405) to manually set the time 
stamp.

The time stamp represents the most recent date and time that message retention was completed for 
the mailbox. Messages delivered after the time stamp cannot be purged until they have been 
retained. This requires that the message retention application retain items chronologically, oldest 
to newest. For example, assume a mailbox has a message retention time stamp of May 7, 2003 
12:00:00. The mailbox has three folders with a total of seven messages:
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The message retention application reads the existing time stamp (May 7, 2003 12:00:00) and 
selects a time between that time and the current time. For example, suppose the current time is May 
9, 2003 14:00:00. The message retention application could choose May 8, 2003 12:00:00 as the 
new time stamp. It would then retain any messages delivered between the existing time stamp 
(May 7, 2003 12:00:00) and the new time stamp (May 8, 2003, 12:00:00).

In the above example, messages 1, 4, and 6 are older than the existing time stamp (May 7, 2003 
12:00:00). The message retention application would not retain these messages again, assuming 
that they had already been safely retained. Messages 2 and 5 have dates that fall between the 
existing time stamp (May 7, 2003 12:00:00) and the new time stamp (May 8, 2003, 12:00:00) so 
they would be retained. Messages 3 and 7 have dates that fall after the new time stamp (May 8, 
2003, 12:00:00) so they would not be retained until the next time the message retention application 
ran against the mailbox.

Acquiring a Message Retention Application
If you do not already have a message retention application to use with GroupWise, you have two 
options: 1) you can purchase an application from a GroupWise partner or 2) you can develop your 
own application.

For information about GroupWise partners that provide message (e-mail) retention applications, 
see the Partner Product Guide (http://www.novell.com/partnerguide/).

For information about developing a message retention application, see the GroupWise Object API 
and GroupWise Trusted Application API documentation at the Novell Developer Kit Web site 
(http://developer.novell.com/ndk).

Enabling Message Retention
This section assumes that you’ve installed a message retention application as a GroupWise trusted 
application and that it is configured to provide a message retention service. If not, see “Trusted 
Applications” on page 62.

Message retention is not enabled until you designate the users whose messages you want retained 
by the application. You can designate users at the domain level, post office level, or individual user 
level.

1 In ConsoleOne, right-click the domain, post office, or user for which you want to enable 
message retention, click GroupWise Utilities > Client Options to display the GroupWise 
Client Options dialog box.
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2 Click Environment to display the Environment Options dialog box, then click the Retention 
tab.

3 Turn on the Enable Message Retention Service setting.

4 If you want to lock the setting at this level, click the Lock button.

For example, if you lock the setting at the domain level, the setting cannot be changed for any 
post offices or users within the domain. If you lock the setting at the post office level, it cannot 
be changed individually for the post office’s users.

This setting does not display in the GroupWise client. Therefore, there is no lock available 
when editing this setting for individual users.

5 Click OK to save the changes.
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34 Standalone Database Maintenance Programs

Some aspects of GroupWise® database maintenance are performed by standalone maintenance 
programs that can be incorporated into batch files along with other system maintenance programs.

“GroupWise Check” on page 391

“Target Service Agents” on page 398

“GroupWise Time Stamp Utility” on page 405

“GroupWise Database Copy Utility” on page 412

GroupWise Check
GroupWise Check (GWCheck) is a tool provided for GroupWise that will check and repair 
GroupWise user, message, library, and resource databases without needing ConsoleOne®. In 
addition to checking post office, user, and library databases, it will also check users’ remote, 
caching, and archive databases.

“GWCheck Functionality” on page 391

“Starting GWCheck on a Windows Workstation” on page 393

“Starting GWCheck on a Linux Workstation” on page 394

“Using GWCheck on a Workstation” on page 395

“Executing GWCheck from a Windows Batch File” on page 398

“Executing GWCheck from a Linux Script” on page 398

“GroupWise Check Error Codes”
NOTE: GWCheck is not currently available for use on Macintosh workstations.

GWCheck Functionality
The GWCheck utility begins by comparing three databases.

After GWCheck makes the database comparisons, it begins processing according to the databases 
selected and any inconsistencies found.

WPHOST.DB NGWGUARD.DB FILE SYSTEM

The post office database 
(wphost.db) is checked for 
the file ID (FID) of the 
selected user. 

The guardian database 
(ngwguard.db) is checked to find 
out if this user database has been 
created.

The file system for this post office is 
checked to see if the user database 
(userxxx.db) for this user exists.
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Case 1 - Missing Entry in the Post Office Database (wphost.db)

In this example, a contents check is run either against all users on the post office or against one 
user, “ABC.” GWCheck does not find the FID of one or more users.

GWCheck will remove the entry from ngwguard.db, delete userabc.db and systematically delete 
all of the user’s messages from the message databases that are not still being referenced by other 
users. If the user has been deleted, GWCheck will clean up after that user.
WARNING: If a post office database becomes damaged so some users are unable to log in, GWCheck should 
not be run until the post office has been rebuilt. For more information, see “Rebuilding Domain or Post Office 
Databases” on page 349.

Case 2 - Missing Entry in the Guardian Database (ngwguard.db)

In this example, a GWCheck is run either against all users on the post office or against one user, 
“ABC.” A user’s FID is found and the user’s database is found in the post office, but the user is 
missing in ngwguard.db.

GWCheck will create the user in ngwguard.db, using database userabc.db. Even if ngwguard.db 
is damaged, it is unlikely that data will be lost.

Case 3 - Missing User Database (userxxx.db)

In this example, a GWCheck is run either against all users on the post office or against one user, 
“ABC.” The user’s FID is found, as well as the user’s record in ngwguard.db. However, the user’s 
database is not found.

GWCheck will take actions depending on what options are selected.

WPHOST.DB NGWGUARD.DB FILE SYSTEM

? userabc.db userabc.db

No entry for this user is found in 
the post office database 
(wphost.db).

An entry is found in the guardian 
database (ngwguard.db), 
indicating that the user has been 
deleted.

Also, a user database 
(userxxx.db) for this user is 
found in the ofuser directory.

WPHOST.DB NGWGUARD.DB FILE SYSTEM

FID abc ? userabc.db

The user appears in the post 
office database (wphost.db). 

The guardian database 
(ngwguard.db) shows no user 
database for this user.

A user database (userxxx.db) for 
the user does exist in the ofuser 
directory.

WPHOST.DB NGWGUARD.DB FILE SYSTEM

FID abc userabc.db ?

The user is found in the post 
office database (wphost.db).

The user is found in the guardian 
database (ngwguard.db).

No user database 
(userxxx.db) is found in the 
ofuser directory.
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Contents Check: GWCheck will delete all of this user’s messages from the message databases if 
they are not referenced by other users.

Structural Rebuild: GWCheck will create a blank user database for this user. Existing messages 
for this user will be ignored.

Re-create User Database: GWCheck will create a blank user database for this user and populate 
it with messages in the message databases that have been sent to or from this user.
WARNING: If a user database has been deleted, do not run a Contents Check until after a Structural Rebuild 
or Re-create User Database has been run for that user. For more information, see “Performing a Structural 
Rebuild of a User Database” on page 355 and “Re-creating a User Database” on page 356.

Starting GWCheck on a Windows Workstation
You can use GWCheck on any Windows 98/NT/2000/XP workstation. 

As an administrator, you can run GWCheck for databases in any post office accessible from the 
workstation where GWCheck is installed. The GWCheck program performs all database 
maintenance itself, rather than handing off a task to the POA as ConsoleOne would do to perform 
database maintenance.

Depending on how GroupWise Check is installed, users might have a Repair Mailbox item on the 
GroupWise Windows client Tools menu that enables them to run GWCheck from the client. If the 
GWCheck program is available to users, users can perform database maintenance on their Remote, 
Caching, and archive mailboxes, which are not accessible from ConsoleOne. 

For the Repair Mailbox item to display on the GroupWise Windows client Tools menu, the 
following files must be installed in the GroupWise directory; by default, this is 
c:\novell\groupwise.

gwcheck.exe

gwchkxx.dll (Replace xx with your language code)

gwchkxx.chm (Replace xx with your language code)

The GroupWise administrator can install these files by using SetupIP to install the GroupWise 
Windows client, and selecting to install and enable GWCheck. The default for SetupIP is to install 
GWCheck, but not enable GWCheck. The files are then copied to the \novell\groupwise\gwcheck 
directory. For additional information about SetupIP and GWCheck, see “[GWCHECK]” on 
page 1009.

If the client was installed from the installation program on the CD or the defaults are chosen for 
SetupIP, the client user needs to copy the files from the GWCheck directory 
(\novell\groupwise\gwcheck) to the main GroupWise directory (\novell\groupwise\).

1 From the Start menu, click Run, then browse to and double-click gwcheck.exe.
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2 To view online help in GWCheck, click Help.

3 Continue with “Using GWCheck on a Workstation” on page 395.

Starting GWCheck on a Linux Workstation
You can use GWCheck on any Linux workstation where you can run the Cross-Platform client. 
GWCheck is not installed along with the client, so you must install it manually.

1 Change to the directory where the GWCheck RPM is located or copy it to a convenient 
location on your workstation.

The GWCheck RPM (groupwise-gwcheck-6.5.1-mmdd.i386.rpm) is located in the /client and 
/admin directories in your GroupWise software distribution directory if it is has been updated 
or on the GroupWise 6.5 for Linux Administrator CD if an updated software distribution 
directory is not available.

2 Install GWCheck.

rpm -i groupwise-gwcheck-6.5.1-mmdd.i386.rpm

3 Change to the /opt/novell/groupwise/gwcheck/bin directory. 

4 Enter ./gwcheck to start GWCheck.
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5 To view online help in GWCheck, click Help.

6 Continue with Using GWCheck on a Workstation.

Using GWCheck on a Workstation
With only a few differences in interface functionality, as described in the online help, you can 
perform the same maintenance activities in GroupWise Check as you can in Mailbox/Library 
Maintenance in ConsoleOne:

“Analyzing and Fixing User and Message Databases” on page 353

“Performing a Structural Rebuild of a User Database” on page 355

“Re-creating a User Database” on page 356

“Analyzing and Fixing Databases for Libraries and Documents” on page 359

“Analyzing and Fixing Library and Document Information” on page 360

“Gathering Mailbox Statistics” on page 367

“Reducing the Size of User and Message Databases” on page 369

“Reclaiming Disk Space in Domain and Post Office Databases” on page 370

“Archiving and Deleting Documents” on page 372

“Deleting Activity Logs” on page 373

“Using Mailbox/Library Maintenance Tab Options” on page 395

“Reusing Library/Mailbox Maintenance Settings” on page 397

Using Mailbox/Library Maintenance Tab Options

Both GroupWise Check and Mailbox/Library Maintenance in ConsoleOne use tab options to 
control the checking process.

“Databases” on page 396

“Logging” on page 396
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“Results” on page 396

“Misc” on page 397

“Exclude” on page 397

Databases

To select the types of database to perform the Mailbox/Library Maintenance check on, click 
Databases.

Depending on the object type and action already selected in the main window, some database types 
might be unavailable. If all the database types are unavailable, then one or more database types 
have been pre-selected for you.

You can perform an action on the following databases when the type is not unavailable:

User: Checks the user databases.

Message Databases: Checks the message databases.

Document: Checks the library and document properties databases.

Logging

To specify the name of the file where you want the results of the MailBox/Library Maintenance 
check to be stored, click Logging.

Specify a file name. By default, the file is created in the post_office_directory\wpcsout\ofs 
directory. To redirect the log file to another location, specify a full path and file name. Use a UNC 
path, or make sure the mapped drive path is from the perspective of the POA. 

Click Verbose Logging to log detailed information. Verbose logging might produce large log files 
and slow execution.

This file will be sent to the users selected on the Results tab.

Results

To select users to receive the results of the Mailbox/Library Maintenance check, click Results.
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Select Administrator to send the results to the user defined as the GroupWise domain 
administrator. Select Individual Users to send each user the results that pertain to him or her. Click 
Message to include a message with the results file.

Misc

If you need to run a Mailbox/Library Maintenance check with special options provided by Novell 
Support, click Misc.

Use the Support Options field to specify command line parameters. Support options are typically 
obtained from Novell Support representatives when you need assistance resolving specific 
database problems. Search the Novell Support Knowledgebase (http://support.novell.com/search/
kb_index.jsp) for TIDs and Support Pack Readmes that list support options. Make sure that you 
clearly understand what the Support options do before you use them. 

Exclude

If you want to exclude certain users in the selected post office from having the Mailbox/Library 
Maintenance check performed on their databases, click Exclude.

Click Add, select one or more users to exclude, then click OK.

Reusing Library/Mailbox Maintenance Settings

For convenience, you can store the options you select in Mailbox/Library Maintenance and 
GroupWise Check so that you can retrieve them for later use.

“Saving Mailbox/Library Maintenance Options” on page 397

“Retrieving Mailbox/Library Maintenance Options” on page 397

Saving Mailbox/Library Maintenance Options

1 After you have selected all of the options in the Mailbox/Library Maintenance dialog box, 
click Save.

2 Browse to the directory where you want to save the options file if you do not want to use the 
default of wptools in the domain to which you’re currently connected.

3 Enter a file name if you do not want to use the default of gwcheck.opt.

4 Click Save.

Retrieving Mailbox/Library Maintenance Options

1 In the Mailbox/Library Maintenance dialog box, click Retrieve.
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2 Browse to and select your saved option file.

3 Click Open.

Executing GWCheck from a Windows Batch File
The GWCheck program is located in the \admin\utilities\gwcheck directory in your GroupWise 
software distribution directory if it has been updated or on the GroupWise 6.5 Administrator CD 
if an updated software distribution directory is not available. It might also be installed along with 
the GroupWise client software in the gwcheck subdirectory of the client installation directory.

1 Use the following syntax to create a batch file to execute GWCheck:

gwcheck /opt=options_file /batch

If you want to include the path to an archive database, use the /pa switch.

2 To create an options file, see “Saving Mailbox/Library Maintenance Options” on page 397.

Executing GWCheck from a Linux Script
The GWCheck program is located in the /admin directory in your GroupWise software distribution 
directory if it has been updated or on the GroupWise 6.5 for Linux Administrator CD if an updated 
software distribution directory is not available.

1 Make sure that GWCheck has been installed, as described in “Starting GWCheck on a Linux 
Workstation” on page 394

2 Create a script to execute GWCheck using the following syntax:

/opt/novell/groupwise/gwcheck/bin --opt options_file --batch

If you want to include the path to an archive database, use the --pa switch.

3 To create an options file, see “Saving Mailbox/Library Maintenance Options” on page 397.

Target Service Agents
A Target Service Agent (TSA) helps generic backup software back up specialized data located on 
any “target.” A target is a specific location where data is stored, such as a NetWare file system, an 
eDirectory database, or a collection of GroupWise databases. A target could also be an application 
that provides data to be backed up. A TSA is specialized to scan, read, and write the specific types 
of data available at the target. A TSA serves as an intermediary between specific data types and a 
general backup engine.

The GroupWise Target Service Agent (GWTSA) has long been included with GroupWise and can 
back up GroupWise data stored on NetWare 4.2, 5.1, and 6.x servers. It is specialized to back up 
specific GroupWise data types, such as domains and post offices.

The NetWare Target Service Agent for File Systems (TSAFS), available on NetWare 6.x (but not 
on earlier versions of NetWare), includes a startup option enabling it to handle GroupWise data. 
TSAFS includes file system backup enhancements that GWTSA does not provide.

For optimum backups on NetWare, select the Target Service Agent appropriate for your version 
of NetWare and GroupWise:

“GroupWise Target Service Agent” on page 399

“NetWare Target Service Agent for File Systems” on page 403
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GroupWise Target Service Agent 
The GroupWise Target Service Agent (GWTSA) provides reliable backups of a running 
GroupWise system on NetWare by successfully backing up open files and locked files, rather than 
skipping them. 

“GWTSA Functionality” on page 399

“Running GWTSA” on page 400

“GWTSA Startup Switches” on page 403

GWTSA Functionality

The GroupWise Target Service Agent (GWTSA) works with other backup software on NetWare. 
For a complete and current list of compatible backup software, use the Partner Product Guide 
(http://www.novell.com/partnerguide).

GWTSA has no user interface of its own, but its presence running along with other backup 
software provides GroupWise options in the backup software that would not otherwise be 
available. As a Target Service Agent, GWTSA supports any feature that your backup software 
supports. So if your backup software supports full, incremental, and differential backups or 
working set and copy jobs, so does GWTSA.

GWTSA backs up standard GroupWise directories and files; extra directories and files that appear 
within a standard GroupWise directory structure are not backed up by GWTSA. The table below 
lists the directories and files that are backed up by GWTSA.

GroupWise 
Location

Directories Subdirectories/Files 
Backed Up

Domain domain_directory wpdomain.db
wpdomain.dc
wphost.dc
gwdom.dc
gwpo.dc
mtaname

domain_directory\wpgate async
gwia
webac60a
etc.
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To see directory structure diagrams showing where the files are located, see “Domain Directory” 
and “Post Office Directory” in GroupWise 6.5 Troubleshooting 3: Message Flow and Directory 
Structure.

GWTSA automatically time-stamps all backed-up user databases (userxxx.db), so that the Allow 
Purge of Items Not Backed Up option described in “Modifying Environment Options” on 
page 977 can function to safeguard users’ deleted items against being purged from your 
GroupWise system before they have been backed up. 
IMPORTANT: If you decide not to use GWTSA, user databases must be time-stamped as a separate process 
in order for the purge control environment option to work properly. For instructions, see “GroupWise Time 
Stamp Utility” on page 405.

Running GWTSA

GWTSA is available for use on NetWare 4.2, 5.1, and 6.x. The gwtsa.nlm program file is 
automatically installed along with the GroupWise agents (POA and MTA). If the domains and post 
offices to back up are located on a different server from where the agents run, you must copy 
GWTSA (gwtsa.nlm), along with the agent engine (gwenn4.nlm), to the server where the data 
resides and run it there.

Post Office post_office_directory wphost.db
ngwguard.db
ngwguard.dc
ngwguard.rfl
ngwguard.fbk
ngwcheck.db
ngwcheck.log
gwpo.dc

post_office_directory\gwdms dmsh.db

post_office_directory\gwdms\library_directory *.db
archive\*.*
docs\*.*

post_office_directory\offiles *.*

post_office_directory\ofmsg *.*

post_office_directory\ofmsg\guardbak ngwguard.fbk

post_office_directory\ofuser userxxx.db

post_office_directory\ofuser\index *.idx
*.inc

post_office_directory\ofviews\win *.vew
*.ini

Library 
(Document 
Storage Area)

library_directory *.db
archive\*.*
docs\*.*

GroupWise 
Location

Directories Subdirectories/Files 
Backed Up
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During agent installation, a gwtsa.ncf file is created in the directory where you installed the agents. 
By default, it loads gwtsa.nlm and provides a /home switch for each domain and post office you 
selected to be serviced by the MTA and POA. For example:

Syntax:
load sys:\system\gwtsa /home-domain_directory

/home-post_office_directory

Example:
load sys:\system\gwtsa /home-sys:\gwsystem\provo1 

/home-sys:\gwsystem\dev

You can add additional instances of the /home switch to back up more domains and post offices. 

Syntax:
load sys:\system\gwtsa /home-domain_directory

/home-domain_directory
/home-post_office_directory
/home-post_office_directory
/home-post_office_directory

Example:
load sys:\system\gwtsa /home-sys:\gwsystem\provo1 

/home-sys:\gwsystem\provo2
 /home-sys:\gwsystem\dev 
/home-sys:\gwsystem\sales
/home-sys:\gwsystem\research

You can also add instances of the /home switch to point to restore areas for post offices or to other 
temporary locations where you want to restore data. 

By default, GWTSA places temporary files in the sys:\system\temp directory during the backup 
process. If necessary, use the /tempdir switch to specify an alternate location where more disk 
space is available for temporary files. Additional configuration of GWTSA can be done using 
other startup switches. See “GWTSA Startup Switches” on page 403 for a complete list.

To start GWTSA immediately, run the gwtsa.ncf file at the NetWare server console. To start 
GWTSA automatically each time you restart the server, add a gwtsa.ncf line to the autoexec.ncf 
file. With GWTSA running, you are ready to back up GroupWise data with Novell Storage 
Management Services or other compatible backup software.

Using GWTSA with Your Backup Software

The GWTSA adds GroupWise options to your backup software. This section uses Novell Storage 
Management Services (SMS) and the NetWare Backup utility (nwback32.exe) as an example of 
how to integrate GWTSA into your backup software. Similar steps are necessary to integrate 
GWTSA with other backup software.

If you plan to use GWTSA with SMS, this section assumes that SMS has been installed and 
configured and is running properly. If you need assistance with SMS, refer to Backup and Restore 
Services (Storage Management Services) on the NetWare 6.5 Documentation Web site (http://
www.novell.com/documentation/nw65/index.html).

“Backing Up GroupWise Data with SMS” on page 402

“Restoring GroupWise Data with SMS” on page 402
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NOTE: If you are using Veritas Backup Exec 9 for NetWare, be sure to deselect Delete Existing Trustees on 
the Backup Exec NetWare tab when you are creating a restore job. If you do not deselect Delete Existing 
Trustees, GWTSA cannot restore any file that has a .db extension. All GroupWise databases have a .db 
extension.

Backing Up GroupWise Data with SMS

To back up GroupWise data using SMS with GWTSA running:

1 Start nwback32.exe from the sys:\public directory of your NetWare server.

You can also use sbcon.nlm at the NetWare server console to perform the backup.

2 In the Quick Access dialog box, click Backup.

3 Expand the WHAT TO BACKUP object.

A GROUPWISE DATABASE object has been added to the list of things you can back up.

4 Expand the GROUPWISE DATABASE object to list GroupWise domains, post offices, and 
libraries that are available for backup.

5 After selecting the GroupWise data to back up, continue using SMS as you usually would to 
perform the backup.

Restoring GroupWise Data with SMS

To restore GroupWise data using SMS with GWTSA running:

1 Start nwback32.exe from the sys:\public directory of your NetWare server.

You can also use sbcon.nlm at the NetWare server console to restore GroupWise data.

2 In the Quick Access dialog box, click Restore.

3 Expand the WHAT TO RESTORE object, then select your backup device.

4 Expand the WHERE TO RESTORE object.

A GROUPWISE DATABASE object appears on the list of things you can restore.

5 Expand the GROUPWISE DATABASE object to list GroupWise domains, post offices, 
libraries, and restore areas where data can be restored.

6 After selecting the GroupWise data to restore, continue using SMS as you usually would to 
restore data.
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If you need to restore GroupWise data to an existing domain, post office, or library, make sure 
your backup software is configured to overwrite newer files than those that are being restored.

If you are restoring GroupWise data to a temporary location, make sure you have sufficient 
free disk space to accommodate the files that are being restored.

GWTSA Startup Switches

The following startup switches can be used with GWTSA:

/home
Specifies the GroupWise location to back up or restore to. Multiple instances of the /home switch 
are typical. Use a /home switch for each domain and post office to back up. Also use a /home 
switch for each post office restore area and any other temporary location to which you want to 
restore GroupWise data outside the standard GroupWise directory structure.

/tempdir
Specifies where GWTSA places its temporary files during the backup process. The default is the 
sys:\system\tsa\temp directory.

/log
Turns on logging and displays a logging screen. By default, logging is turned off. When you turn 
logging on, a gwtsa.log file is created in the sys:\system\tsa directory.

/ll
Sets the log level to determine how much information is written to GWTSA log file. Use n for 
Normal and v for Verbose.

NetWare Target Service Agent for File Systems
The Target Service Agent for File Systems (TSAFS) is available on NetWare 6.0 and later.

“TSAFS Functionality” on page 403

“Running TSAFS” on page 404

“Using TSAFS with Novell Storage Management Service (SMS)” on page 404
IMPORTANT: If you are using GroupWise 6.5 Support Pack 3 or later, TSAFS can time-stamp GroupWise 
databases as part of the backup process. If you are using an earlier version of GroupWise, time stamping must 
be performed as a separate process, as described in “GroupWise Time Stamp Utility” on page 405.

TSAFS Functionality

The Target Service Agent for File Systems (TSAFS) includes enhancements that earlier versions 
of TSAFS did not include:

Supports GroupWise database lock/backup/unlock functionality so that you can back up a 
running GroupWise system

Provides time stamping of GroupWise 6.5.3 and later user databases so that the Allow Purge 
of Items Not Backed Up option described in “Modifying Environment Options” on page 977 
can function to safeguard users’ deleted items against being purged from your GroupWise 
system before they have been backed up

Supports backups of clustered servers so that the backup job continues on failover

Uses a read-ahead, data caching mechanism to improve backup performance

For complete details about the TSAFS, see the NetWare 6.5 Storage Management Services 
Administration Guide on the NetWare 6.5 Documentation page (http://www.novell.com/
documentation/nw65/index.html).
Standalone Database Maintenance Programs 403

http://www.novell.com/documentation/nw65/index.html


    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Running TSAFS

At your NetWare server console, unload TSAFS, then use the following command to start TSAFS 
with GroupWise functionality:

load tsafs /EnableGW=True

The switch setting is saved in a configuration file, so that you do not need to include the switch 
when you load tsafs.nlm in the future.

To start TSAFS automatically each time you restart the server, load tsafs.nlm in the autoexec.ncf 
file.

To run TSAFS without GroupWise functionality, unload TSAFS, then reload using:

load tsafs /EnableGW=False

To determine whether or not TSAFS is running with GroupWise functionality, use:

tsafs

Scroll down to the /EnableGW entry and look for a value of True or False.

Using TSAFS with Novell Storage Management Service (SMS)

1 After TSASF is running on the NetWare server, start the NetWare Backup utility 
(nwbackup32.exe) on a Windows machine.

You can also use sbcon.nlm at the NetWare server console to perform the backup.

2 In the Quick Access dialog box, click Backup, then expand WHAT TO BACKUP.

The GROUPWISE DATABASES item is listed if you have been using the GroupWise Target 
Service Agent (GWTSA). Do not use it with TSAFS.

3 Expand NETWARE SERVERS, then browse to and select directories where GroupWise 
domains, post offices, and document storage areas are located. 
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For background information about GroupWise directory structures, see “Domain Directory” 
and “Post Office Directory” in “Directory Structure Diagrams” in GroupWise 6.5 
Troubleshooting 3: Message Flow and Directory Structure.

4 Configure the backup job as needed, as described in NetWare 6.5 Storage Management 
Services Administration Guide on the NetWare 6.5 Documentation page (http://
www.novell.com/documentation/nw65/index.html).

To avoid error messages caused by open files that do not need to be backed up, some files can 
be excluded from the backup, for example:

Agent log files (mmddpoa.nnn, mmddmta.nnn, mmddgwia.nnn, and mmddweb.nnn)

Internet Agent lock and cycle files (proc and pulse.tmp)

Transitory xNStore files used briefly by the agents in the message queues

5 When you have finished configuring the backup job, click Backup > Submit the Job.

If you need to restore GroupWise data, be sure to run GroupWise Check (GWCheck) as described 
in Chapter 32, “Restoring GroupWise Databases from Backup,” on page 379.

GroupWise Time Stamp Utility
You can use the GroupWise Time Stamp (GWTMSTMP) utility to ensure that GroupWise user 
databases include the dates when they were last backed up, restored, and retained.

The following sections provide information about the utility:

“GWTMSTMP Functionality” on page 406

“Running GWTMSTMP on NetWare” on page 406

“Running GWTMSTMP on Linux” on page 407

“Running GWTMSTMP on Windows” on page 407

“GWTMSTMP Startup Switches” on page 408
NOTE: GWTMSTMP is available in GroupWise 6.5 for Linux Support Pack 2, but not in the original release of 
GroupWise 6.5 for Linux. Time stamp functionality is included in the NetWare Target Service Agent for File 
Systems (TSAFS) for GroupWise 6.5 systems where Support Pack 3 has been installed, so you do not need 
to use GWTMSTMP when backing up a GroupWise 6.5.3 system with TSAFS.
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GWTMSTMP Functionality
GWTMSTMP places date and time information on user databases (userxxx.db) in order to support 
message backup, restore, and retention. No other databases are affected. You can run 
GWTMSTMP on all user databases in a post office or on a single user database.

Backup

To ensure thorough user database backups, you can make sure that deleted items are not purged 
from users’ databases until they have been backed up. Two conditions must be met in order to 
provide this level of protection against loss of deleted items:

The Allow Purge of Items Not Backed Up option must be deselected in ConsoleOne, as 
described in “Modifying Environment Options” on page 977.

User databases (userxxx.db) must be time-stamped every time a backup is performed so that 
items can be purged only after being backed up. 

If you use GWTSA or TSAFS on NetWare to back up user databases, the backup time stamp is 
automatically added as part of the backup process. However, if you do not use GWTSA or TSAFS, 
you must use GWTMSTMP to make sure that user databases are time-stamped so that items will 
not be prematurely purged. 

Restore

If you use the GWTSA or TSAFS on NetWare to restore a mailbox, the restore time stamp is 
automatically added as part of the restore process. However, if you do not use GWTSA or TSAFS, 
you can use GWTMSTMP to add the restore time stamp to the database. The restore time stamp 
is not required for any GroupWise feature to work properly. Its primary purpose is informational.

Retention

If you use a message retention application (see Chapter 33, “Retaining User Messages,” on 
page 387), the application should automatically add the retention time stamp after retaining the 
database’s messages. Any messages with dates that are newer than the retention time stamp cannot 
be purged from the database.

You can also use GWTMSTMP to manually add a retention time stamp. 

Running GWTMSTMP on NetWare
The GWTMSTMP program (gwtmstmp.nlm) is installed into the same directory where you 
installed the GroupWise agents (POA and MTA). You can copy it to additional locations if needed.

To check the existing time stamp on all GroupWise user databases in a post office, use the 
following command:

Syntax:
gwtmstmp.nlm /ph-volume:\post_office_directory 

Example:
gwtmstmp.nlm /ph-sys:\gwsystem\dev 

The results are written to the console.log file.

To set a current time stamp on all user databases in a post office, use the following command:
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Syntax:
gwtmstmp.nlm /ph-volume:\post_office_directory /set 

Example:
gwtmstmp.nlm /ph-sys:\gwsystem\dev /set 

A basic backup time stamp can also be set in ConsoleOne. Select a Post Office object, then click 
Tools > GroupWise Utilities > Backup/Restore Mailbox. On the Backup tab, select Backup, then 
click Yes.

More specialized functionality is provided through additional GWTMSTMP startup switches. See 
“GWTMSTMP Startup Switches” on page 408.

Running GWTMSTMP on Linux
The GWTMSTMP executable (gwtmstmp) is installed into the bin and lib subdirectories of /opt/
novell/groupwise/agents along with the GroupWise agents (POA and MTA). You can copy it to 
additional locations if needed.

To check the existing time stamp on all GroupWise user databases in a post office, use the 
following command:

Syntax:
./gwtmstmp -p /post_office_directory

Example:
./gwtmstmp -p /gwsystem/acct

The results are displayed on the screen.

To set a current time stamp on all user databases in a post office, use the following command:

Syntax:
./gwtmstmp -p /post_office_directory --set

Example:
./gwtmstmp -p /gwsystem/acct --set

A basic backup time stamp can also be set in ConsoleOne. Select a Post Office object, then click 
Tools > GroupWise Utilities > Backup/Restore Mailbox. On the Backup tab, select Backup, then 
click Yes.

More specialized functionality is provided through additional GWTMSTMP startup switches. See 
“GWTMSTMP Startup Switches” on page 408.

Running GWTMSTMP on Windows
The GWTMSTMP program file (gwtmstmp.exe) is installed into the same directory where you 
installed the GroupWise agents (POA and MTA). You can copy it to additional locations if needed.

To check the existing time stamp on all GroupWise user databases in a post office, use the 
following command:

Syntax:
gwtmstmp.exe /ph-drive:\post_office_directory
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Example:
gwtmstmp.exe /ph-m:\gwsystem\acct

The results are displayed on the screen

To set a current time stamp on all user databases in a post office, use the following command:

Syntax:
gwtmstmp.exe /ph-drive:\post_office_directory /set

Example:
gwtmstmp.exe /ph-m:\gwsystem\acct /set

A basic backup time stamp can also be set in ConsoleOne. Select a Post Office object, then click 
Tools > GroupWise Utilities > Backup/Restore Mailbox. On the Backup tab, select Backup, then 
click Yes.

More specialized functionality is provided through additional GWTMSTMP startup switches.

GWTMSTMP Startup Switches
The following startup switches can be used with GWTMSTMP:

/ph

Specifies the post office directory where the user databases to time-stamp are located. This switch 
is required.

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

/ph -p /ph

/backup -b or --backup /backup

/restore -r or --restore /restore

/retention -n or --retention /retention

/get -g or --get /get

/set -s or --set /set

/clear -c or --clear /clear

/date -d or --date /date

/time -t or --time /time

/@u -u or -userid /@u

/userdb -e or --userdb /userdb

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /ph-volume:\post_office_dir -p /post_office_dir /ph-drive:\post_office_dir

Example: /ph-mail:\dev -p /gwsystem/dev /ph-j:\dev
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/backup, /restore, and /retention

Specifies the time stamp on which to perform the operation. If no time stamp is specified, the 
operation is performed on the backup time stamp.

For example, to set the restore time stamp, you would use:

/get

Lists existing backup, restore, and retention time stamp information for user databases. If no time 
stamps are set, no times are displayed.

For example:

If no other operational switch is used, /get is assumed. The following example returns the same 
results as the above example:

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /backup

/restore

/retention

-b
--backup
-r
--restore
-n
--retention

/backup

/restore

/retention

NetWare: gwtmstmp /ph-j:\dev /restore /set

Linux: ./gwtmstmp -p /gwsystem/dev -r -s

Windows: gwtmstmp /ph-j:\dev /restore /set

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /get -g
--get

/get

NetWare: gwtmstmp /ph-j:\dev /get

Linux: ./gwtmstmp -p /gwsystem/dev -g

Windows: gwtmstmp /ph-j:\dev /get

NetWare: gwtmstmp /ph-j:\dev

Linux: ./gwtmstmp -p /gwsystem/dev

Windows: gwtmstmp /ph-j:\dev
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/set

Sets the current date and time on user databases.

For example, to set the backup time stamp, you would use:

or

-c, --clear

Clears existing time stamps.

For example, to clear all time stamps on databases in a post office, you would use:

/date

Specifies the date that you want placed on user databases.

For example, to set the restore date to June 15, 2004, you would use:

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /set -s
--set

/set

NetWare: gwtmstmp /ph-j:\dev /backup /set

Linux: ./gwtmstmp -p /gwsystem/dev -b -s

Windows: gwtmstmp /ph-j:\dev /backup /set

NetWare: gwtmstmp /ph-j:\dev /set

Linux: ./gwtmstmp -p /gwsystem/dev -s

Windows: gwtmstmp /ph-j:\dev /set

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /clear -c 
--clear 

/clear

NetWare: gwtmstmp /ph-j:\dev /clear

Linux: ./gwtmstmp -p /gwsystem/dev -c

Windows: gwtmstmp /ph-j:\dev /clear

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /date-mm/dd/yyyy -d mm/dd/yyyy
--date mm/dd/yyyy

/date-mm/dd/yyyy

Example: /date-01/03/2004 -d 05/18/2004
--date 05/18/2004

/date-04/12/2004
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/time

Specifies the time that you want placed on user databases.

For example, to set the restore time to 4:45 p.m., you would use:

/@u

Provides a specific GroupWise user ID so that an individual user database can be time-stamped.

For example, to set the retention time stamp for a user whose GroupWise user ID is mpalu, you 
would use:

-e, --userdb

Provides a specific GroupWise user database (userxxx.db) so that an individual user database can 
be time-stamped.

NetWare: gwtmstmp /ph-j:\dev /restore /date-06/14/2004

Linux: ./gwtmstmp -p /gwsystem/dev --restore --date 06/15/2004

Windows: gwtmstmp /ph-j:\dev /restore /date-06/14/2004

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /time-hh:mm am|pm -t hh:mm am|pm
--time hh:mm am|pm

/time-hh:mm am|pm

Example: /time-11:30pm -t 2:00am
--time 2:00am

/time-6:15pm

NetWare: gwtmstmp /ph-j:\dev /restore /time-4:45pm

Linux: ./gwtmstmp -p /gwsystem/dev -r -t 4:45pm

Windows: gwtmstmp /ph-j:\dev /restore /time-4:45pm

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /@u-userID -u userID
--userid userID

/@u-userID

Example: /@u-khuang -u sjones
--userid gsmith

/@u-mbarnard

NetWare: gwtmstmp /ph-j:\dev /@u-mpalu /retention /set

Linux: ./gwtmstmp -p /gwsystem/dev -u mpalu -n -s

Windows: gwtmstmp /ph-j:\dev /@u-mpalu /retention /set
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For example, to set the retention time stamp for a user whose user database is named user3gh, you 
would use:

GroupWise Database Copy Utility
The GroupWise Database Copy utility (DBCopy) copies files from a live GroupWise post office 
or domain to a static location for backup. During the copy process, DBCopy prevents the files from 
being modified, using the same locking mechanism used by other GroupWise programs that access 
databases. This ensures that the backed-up versions are consistent with the originals even when 
large databases take a substantial amount of time to copy.

DBCopy is included in GroupWise 6.5 for Linux to assist with backing up your GroupWise 
system. DBCopy is available for use on NetWare and Windows servers, but it is not included in 
GroupWise 6.5 or 6.0.

“Using DBCopy on Linux Servers” on page 412

“Using DBCopy on NetWare and Windows Servers” on page 413

Using DBCopy on Linux Servers
1 Change to the directory where the DBCopy RPM is located or copy it to a convenient location 

on your workstation.

The DBCopy RPM (groupwise-dbcopy-6.5.2-mmdd.i386.rpm is located in the /admin 
directory in your GroupWise software distribution directory if you have created one or on the 
GroupWise 6.5 for Linux Administrator CD.

2 Install DBCopy.

rpm -i groupwise-dbcopy-6.5.2-mmdd.i386.rpm

3 Change to the /opt/novell/groupwise/agents/bin directory. 

4 Use the following command to back up a post office:

./dbcopy /post_office_directory /destination_directory

or

Use the following command to back up a domain:

./dbcopy /domain_directory /destination_directory

NetWare GWTMSTMP Linux GWTMSTMP Windows GWTMSTMP

Syntax: /userdb user_database -e user_database
--userdb user_database

/userdb user_database

Example: /userdb user3gh.db -e user3gh.db
--userdb user3gh.db

/userdb user3gh.db

NetWare: gwtmstmp /ph-j:\dev /userdb user3gh.db /retention /set

Linux: ./gwtmstmp -p /gwsystem/dev -e user3gh.db -n -s 

Windows: gwtmstmp /ph-j:\dev /userdb user3gh.db /retention /set
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You can also include the -I switch to specify a date (for example, 11-25-2005) so that only 
files that are newer than the specified date are copied.

5 After DBCopy has finished copying the post office or domain, use your backup software of 
choice to back up the static copy of the post office or domain directory structure.

6 After the backup has finished, delete the static copy of the post office or domain directory 
structure to conserve disk space.

You might find it helpful to set up a cron job to run DBCopy regularly at a time of day when your 
system is not busy.

DBCopy can also be useful for moving domains and post office from NetWare or Windows to 
Linux. For more information, see “Moving Your Existing GroupWise System to Linux” in 
“Update” in the GroupWise 6.5 Installation Guide.

Using DBCopy on NetWare and Windows Servers
For information about using DBCopy to back up GroupWise post offices on NetWare and 
Windows servers, see the following TIDs in the Novell Support Knowledgebase (http://
support.novell.com/search/kb_index.jsp): 

TID 10023756: Questions and Answers Regarding DBCopy

TID 2929217: GroupWise Backup Utilities (includes Windows download)
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