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Understanding Message Delivery and Storage in

the Post Office

A post office is a collection of user mailboxes and GroupWise® objects. Messages are delivered
into mailboxes by the Post Office Agent (POA). The following topics help you understand the post

office and the functions of the POA:

*

*

*

*

“Post Office Representation in ConsoleOne” on page 417
“Post Office Directory Structure” on page 418
“Information Stored in the Post Office” on page 418
“Post Office Access Mode” on page 422

“Role of the Post Office Agent” on page 423

“Message Flow in the Post Office” on page 425
“Cross-Platform Issues in the Post Office” on page 425

Post Office Representation in ConsoleOne

In ConsoleOne®, post offices are container objects that contain at least one POA object, as shown

below:
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Although each post office is linked to a domain, it does not display as subordinate to the domain
in the Console View. However, using the GroupWise View, you can display post offices as
subordinate to the domains to which they are linked in your GroupWise system.
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Post Office Directory Structure

Physically, a post office consists of a set of directories that house all the information stored in the
post office. See “Post Office Directory” in GroupWise 6.5 Troubleshooting 3: Message Flow and
Directory Structure.

Information Stored in the Post Office

The following types of information are stored in the post office:
+ “Post Office Database” on page 418
+ “Message Store” on page 418
¢ “Guardian Database” on page 420
* “Agent Input/Output Queues in the Post Office” on page 421
* “Libraries (optional)” on page 422

All databases in the post office should be backed up regularly. How often you back up GroupWise
databases depends on the reliability of your network and hardware. See “Backing Up a Post
Office” on page 375.

Post Office Database

The post office database (wphost.db) contains all administrative information for the post office,
including a copy of the GroupWise Address Book. This information is necessary for users to send
messages to others in the GroupWise system.

Message Store

GroupWise messages are made up of three parts:

¢ Message Header: The message header contains addressing information including the
sender’s address, recipient’s address, message priority, status level, and a pointer that links the
header to the message body.
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+ Message Body: The message body contains the message text in an encrypted format and a
distribution list containing user IDs of the sender and recipients.

+ File Attachments (optional): File attachments can be any type of file that is attached to the
message.

The message store consists of directories and databases that hold messages. The message store is
shared by all members of the post office so only one copy of a message and its attachments is
stored in the post office, no matter how many members of the post office receive the message. This
makes the system more efficient in terms of message processing, speed, and storage space.

All information in the message store is encrypted to prevent unauthorized access. For more
information, see “Native GroupWise Encryption” on page 1039.

The message store contains the following components:
+ “User Databases” on page 419
+ “Message Databases” on page 419

* “Attachments Directory” on page 420

User Databases

Each member of the post office has a personal database (userxxx.db) which represents the user’s
mailbox. The user database contains the following:

+ Message header information
+ Pointers to messages

¢ Personal groups

* Personal address books

+ Rules

+ Contacts

¢ Checklists

+ Categories

* Junk Mail lists

When a member of another post office shares a folder with one or more members of the local post
office, a “prime user” database (puxxxxx.db) is created to store the shared information. The “prime
user” is the owner of the shared information.

Local user databases and prime user databases are stored in the ofuser directory in the post office.

Message Databases

Each member of the post office is arbitrarily assigned to a message database (msgnn.db) where the
body portions of messages are stored. Many users in a post office share a single message database.
There can be as many as 25 message databases in a post office. Message databases are stored in
the ofmsg directory in the post office.

Outgoing messages from local senders are stored in the message database assigned to each sender.
Incoming messages from users in other post offices are stored in the message database that
corresponds to the message database assigned to the sender in his or her own post office. In each
case, only one copy of the message is stored in the post office, no matter how many members of
the post office it is addressed to.
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Attachments Directory

The attachments directory (offiles) contains subdirectories that store file attachments, message
text, and distribution lists that exceed 2 KB. Items of this size are stored more efficiently as files
than as database records. The message database contains a pointer to where each item is found.

Guardian Database

The guardian database (ngwguard.db) serves as a reference for the following subordinate
databases in the post office:

¢ User databases (userxxx.db)
+ Message databases (msgnn.db)
+ Prime user databases (puxxxxx.db)

+ Library databases (dmsh.db and dmxxnn0I-FF.db)

The guardian database stores information that is common among all databases, thus eliminating
duplication of information. The subordinate databases reference information stored in the guardian
database. The benefits of the guardian database include the following:

+ Single Reference Point: The guardian database stores information for each post office.
Instead of storing the dictionary information in multiple dictionary databases, it is stored once
in the guardian database.

+ Increased Performance: When the information in the guardian database is accessed, it is
written to cache memory. Each subsequent request can be handled with information already
available in cache memory, which is faster than disk access.

¢ Tracking Attachments and Documents: When an attachment or document becomes
orphaned (loses pointers to the message or profile), the guardian database is used to re-locate
the origination of the attachment or document.

¢ GroupWise Remote Client Management: When a user starts the GroupWise client in
Remote mode, a local guardian database is created on the user’s workstation to store
information similar to the guardian database in the remote user’s post office in the GroupWise
system.

The guardian database is vital to GroupWise functioning. Therefore, the POA has an automated
back-up and roll-forward process to protect it. The POA keeps a known good copy of the guardian
database called ngwguard.fbk. Whenever it modifies the ngwguard.db file, the POA also records
the transaction in the roll-forward transaction log called ngwguard.rfl. If the POA detects damage
to the ngwguard.db file on startup or during a write transaction, it goes back to the ngwguard.fbk
file (the "fall back" copy) and applies the transactions recorded in the ngwguard.rfl file to create a
new, valid and up-to-date ngwguard.db.

In addition to the POA back-up and roll-forward process, you should regularly back up the
ngwguard.db, ngwguard.fbk, and ngwguard.rfl files regularly to protect against media failure.
Without a valid ngwguard.db file, you cannot access your e-mail. With current ngwguard.fbk and
ngwguard.rfl files, you can rebuild a valid ngwguard.db file should the need arise. See “Backing
Up a Post Office” on page 375.

The ngwguard.dc file is the structural template for building the guardian database and its
subordinate databases. Also called a dictionary file, the ngwguard.dc file contains schema
extension information, such as administrator-defined fields, data types, and record indexes. If this
dictionary file is missing, no additional databases can be created in the post office.
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Agent Input/Output Queues in the Post Office

Each post office contains agent input/output queues where messages are deposited and picked up
for processing by the POA and the MTA. The MTA transfers messages into and out of the post
office, while the POA handles message delivery.

For illustrations of the processes presented below, see “Message Delivery to a Different Post
Office” and “Message Delivery to a Different Domain” in GroupWise 6.5 Troubleshooting 3:
Message Flow and Directory Structure.

MTA Output Queue in the Post Office

The MTA output queue in each post office is the post office\wpcsout directory.

If the MTA has a mapped or UNC link to the post office, the MTA writes user messages directly
into its output queue, which requires write access to the post office. If the MTA has a TCP/IP link
to the post office, the MTA transfers user messages to the POA by way of TCP/IP. The POA then
stores the messages in the MTA output queue on behalf of the MTA, so the MTA does not need
write access to the post office.

The post_office\wpcsout\ofs subdirectory is where the MTA transfers user messages for delivery
by the POA to users’ mailboxes in the local post office.

The MTA post office\wpcsout\ads subdirectory is where the MTA transfers administrative
messages instructing the POA admin thread to update the post office database (wphost.db).

POA Input Queue in the Post Office

The POA input queue in each post office is the post_office\wpcsout directory, which is the same
as the MTA output queue.

The post_office\wpcsout\ofs subdirectory is where the POA picks up user messages deposited
there by the MTA and updates the local message store, so users receive their messages.

The post_office\wpcsout\ads subdirectory is where the POA admin thread picks up administrative
messages deposited there by the MTA and updates the post office database (wphost.db).
POA Output Queue in the Post Office

The POA output queue (post_office\wpcsin) is where the POA deposits user messages for the
MTA to transfer to other domains and post offices.

Historical Note: In earlier versions of GroupWise, the GroupWise client wrote user messages to
the POA output queue when using direct access to the post office. In GroupWise 6.x, client/server
access to the post office is the preferred method.

MTA Input Queue in the Post Office

The MTA input queue in each post office (post_office\wpcsin) is the same as the POA output
queue. The MTA picks up user messages deposited there by the POA and transfers them to other
domains and post offices.

For a mapped or UNC link between the domain and post office, the MTA requires read/write
access rights to its input/output queues in the post office. For a TCP/IP link, no access rights are
required because messages are communicated to the MTA by way of TCP/IP.

Understanding Message Delivery and Storage in the Post Office 421



Libraries (optional)

A library is a collection of documents and document properties stored in a database system that
can be managed and searched. You do not need to set up libraries unless you are using GroupWise
Document Management Services (DMS). See “Libraries and Documents” on page 261.

Library Databases

The databases for managing libraries are stored in the gwdms directory and its subdirectories in
the post office.

The dmsh.db file is a database shared by all libraries in the post office. It contains information
about where each library in the post office is located.

Each library has its own subdirectory in the gwdms directory. In each library directory, the
dmxxnn01-FF.db files contain information specific to that library, such as document properties
and what users have rights to access the library.

Document Storage Areas

The actual documents in a library are not kept in the library databases. They are kept in a document
storage area, which consists of a series of directories for storing document files. Documents are
encrypted and stored in BLOBs (binary large objects) to make document management easier. A
document, its versions, and related objects are stored together in the same BLOB.

A document storage area might be located in the post office directory structure, or in some other
location where more storage space is available. If it is located in the post office, the document
storage area can never be moved. Therefore, storing documents in the post office directory
structure is not usually recommended. If it is stored outside the post office, document storage areas
can be moved when additional disk space is required.

Post Office Access Mode

The GroupWise 6.x Windows client and the GroupWise 6.5 Cross-Platform client both use client/
server access mode to the post office. This requires a TCP/IP connection between the GroupWise
clients and the POA in order for users to access their mailboxes. Benefits of client/server access
include:

+ Load Balancing: The workload is split between the client workstation and the POA on
another server. The POA can perform a processor-intensive request while the client is doing
something else.

+ Database Integrity: The GroupWise client does not need write access to databases in the post
office. Therefore, client failures cannot damage databases.

¢ Reduced Network Traffic: Requests are processed on the POA server and only the results
are sent back across the network to the client workstation.

+ Tighter Security: Client users do not need to log in to the server where the post office is
located. This eliminates the need for users to have write access to the post office directory.

¢ Scalability: More concurrent users can be supported in a single post office.

+ Platform Independence: The GroupWise client on any platform can access the post office
by way of TCP/IP communication with the POA.
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+ Simplified Client Connections: The GroupWise client can communicate with any POA in
the GroupWise system. Any POA can then redirect the client to connect to the correct POA
for the users’ post office.

Historical Note: In GroupWise 5.x, the GroupWise client allowed the user to enter a path to the
post office directory to facilitate direct access mode. The GroupWise 6.x client no longer offers the
user that option. However, you can force the GroupWise 6.x client to use direct access by starting
it with the /ps switch and providing the path to the post office directory. For information about
alternatives to client/server access mode, see the GroupWise 5.5 Agent Setup Guide (http://
www.novell.com/documentation/gw55/index.html).

Role of the Post Office Agent

The GroupWise Post Office Agent (POA) delivers messages to users’ mailboxes, connects users
to their post offices in client/server access mode, updates post office databases, indexes messages
and documents, and performs other post office-related tasks.You must run at least one POA for
each post office.

The following sections help you understand the various functions of the POA:
+ “Client/Server Processing” on page 423
+ “Message File Processing” on page 424
¢ “Other POA Functions” on page 424

Client/Server Processing

Using client/server access mode, the GroupWise client maintains one or more TCP/IP connections
with the POA and does not access the post office directly. Consequently, the performance of the

POA in responding to requests from the GroupWise client directly affects the GroupWise client’s
responsiveness to users. To provide the highest responsiveness to client users, you can configure
a POA just to handle client/server processing. See “Configuring a Dedicated Client/Server POA”
on page 510.

When using client/server access mode, the GroupWise client can be configured to control how
much time it spends actually connected to the POA.

¢ In Online mode, the client is continuously connected.

+ In Caching mode, the client connects at regular intervals to check for incoming messages and
also whenever the client user sends a message. Address lookup is performed locally. Caching
mode allows the POA to service a much higher number of users than Online Mode.

+ In Remote mode, the client connects whenever the client user chooses, such as when using a
brief modem connection to download and upload messages.

NOTE: Remote mode is not currently available in the Cross-Platform client.

For more information about the client modes available with client/server access mode, see “Using
Caching Mode” and “Using Remote Mode” in the Group Wise 6.5 Windows Client User Guide and
“Using Caching Mode” in the GroupWise 6.5 Cross-Platform Client User Guide.

Client/server access mode also allows users to access their GroupWise mailboxes from POP and
IMAP clients, in addition to the GroupWise client. See “Supporting IMAP Clients” on page 450.

In client/server mode, the POA can provide and, if necessary, force secure SSL connections with
all clients. See “Enhancing Post Office Security with SSL Connections to the POA” on page 458.
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Message File Processing

Messages from users in other post offices arrive in the local post office in the form of message files
deposited in the POA input queue. See “Agent Input/Output Queues in the Post Office” on
page 421.

The POA picks up the message files and updates all user and message databases to deliver
incoming messages in the local post office. To provide timely delivery for a large volume of
incoming messages, you can configure a POA just to handle message file processing. See
“Configuring a Dedicated Message File Processing POA™ on page 513.

Other POA Functions

In addition to client/server processing (interacting with client users) and message file processing
(delivering messages), the POA:

*

*

Performs indexing tasks for document management. See “Regulating Indexing” on page 514.

Performs scheduled maintenance on databases in the post office. See “Scheduling Database
Maintenance” on page 467.

Monitors and manages disk space usage in the post office. See “Scheduling Disk Space
Management” on page 469.

Restricts the size of messages that users can send outside the post office. See “Restricting
Message Size between Post Offices” on page 455.

Primes users’ mailboxes for Caching mode. See “Supporting Forced Mailbox Caching” on
page 454.

Performs nightly user upkeep so users do not have to wait while the GroupWise client
performs it; also creates a downloadable version of the system Address Book for Remote and
Caching users. See “Performing Nightly User Upkeep” on page 472.

Provides LDAP authentication and LDAP server pooling. See “Providing LDAP
Authentication for GroupWise Users” on page 461.

Prevents unauthorized access to the post office. See “Enabling Intruder Detection” on
page 465.

Tracks the GroupWise client software in use in the post office. See “Checking What
GroupWise Clients Are in Use” on page 452.

Automatically detects and repairs invalid information in user databases (userxxx.db) and
message databases (msgnn.db) for the local post office by using an efficient multi-threaded
process. See “Adjusting the Number of POA Threads for Database Maintenance” on

page 517.

Automatically detects and repairs invalid information in the post office database (wphost.db).

Automatically detects and repairs damage to the guardian database (ngwguard.db) in the post
office.

Updates the post office database whenever GroupWise users, resources, post offices, or other
GroupWise objects are added, modified, or deleted.

Replicates shared folders between post offices.
Executes GroupWise client rules.

Processes requests from GroupWise Remote users.
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Message Flow in the Post Office

To see how messages are delivered using client/server access mode, see “Message Delivery in the
Local Post Office” in GroupWise 6.5 Troubleshooting 3: Message Flow and Directory Structure.

Cross-Platform Issues in the Post Office
GroupWise is designed to function in a variety of environments. The GroupWise Windows client
runs on the following platforms:
+ Windows 98
Windows NT/2000
Windows 3.1 (GroupWise 5.2 and below)
Macintosh (GroupWise 5.2 and below)
+ UNIX (GroupWise 5.2 and below)

*

*

*

The GroupWise Cross-Platform client runs on the following platforms:
¢ Linux

+ Macintosh

In addition, GroupWise users can access their mailboxes without using a GroupWise client
through the following applications:

* GroupWise WebAccess (see “WebAccess” on page 803)

+ POP and IMAP clients such as Netscape* Mail, Eudora* Pro, Microsoft Outlook, and
Entourage*

+ MAPI clients such as Microsoft Mail and cc:Mail*
Post offices can be located on the following platforms:
Novell® NetWare®
Windows NT/2000

*

*

*

Linux (GroupWise 6.5 for Linux)
UNIX (GroupWise 5.x)

*

The GroupWise agents can run on the following platforms:
Novell NetWare
Windows NT/2000

*

*

*

Linux (GroupWise 6.5 for Linux)

¢ UNIX (GroupWise 5.x)
In general, GroupWise is most efficient if you match the agent platform with the network operating
system, so the POA and the post office should be on the same platform, and the client should be

on a compatible platform. Those with mixed networks might wonder what combinations are
possible. You have several alternatives.

+ “Client/Post Office Platform Independence through Browser Technology” on page 426
+ “Client/Post Office Platform Independence through Client/Server Mode” on page 426

+ “POA/Post Office Platform Dependencies Because of Direct Access Requirements” on
page 426
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Client/Post Office Platform Independence through Browser Technology

If your GroupWise users want to access their mailboxes through POP3 or IMAP4 clients, it makes
no difference what platform their post offices are located on. However, users are limited to the
client capabilities of their POP3 or IMAP4 clients.

If you install GroupWise WebAccess on a Web server, GroupWise users can still access their
mailboxes through their browsers and with more native GroupWise features available. See
“WebAccess” on page 803 for more information.

Client/Post Office Platform Independence through Client/Server Mode

The GroupWise 6.5 Windows client and Cross-Platform client require client/server access mode.
With this configuration, it makes no difference what platform users’ post offices are located on.
The GroupWise client accesses the post office by communicating with the POA using TCP/IP,
which is a platform-independent protocol.

POA/Post Office Platform Dependencies Because of Direct Access Requirements

The POA must have direct access to the post office directory. Therefore, the POA must be able to
log in to the server where the post office is located and must be able to write to the databases and
directories located in the post office.

Although the recommended configuration is for the POA and the post office to be on the same
platform and preferably on the same server, some variation is possible. The table below
summarizes the various combinations of POA and post office platforms and indicates which
combinations work for direct access and which ones do not for GroupWise 6.x:

NetWare POA Windows POA Linux POA UNIX POA

Post Office on Yes Yes Not supported? Not supported?

NetWare

Post Office on No' Yes Yes Not supported?

Windows

Post Office on Linux Not supported? Yes Yes Not supported?

Post Office on UNIX  Not supported? Not supported? Yes Supported for
GroupWise 5.x

Post Office on No3 No3 No?® No3

Macintosh

! The NetWare®™ POA cannot service a post office on a Windows server because Windows does
not support the required cross-platform connection.

2 For these combinations, an NFS connection would be required, which is not a supported
configuration for the agents. However, the agents often can work adequately in this
configuration.

3 Post offices cannot be created on Macintosh computers.
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Installing and Starting the POA

Detailed instructions for installing and starting the POA for the first post office of a new
GroupWise® system are provided in “Installing a Basic GroupWise System” in the GroupWise 6.5
Installation Guide. Additional agent installation and startup instructions and worksheets are
available in “Installing GroupWise Agents” in the GroupWise 6.5 Installation Guide.

IMPORTANT: If you are installing and running the POA in a clustered GroupWise system, see the appropriate
section of the GroupWise 6.5 Interoperability Guide before you install the POA:

- “Deciding How to Install and Configure the Agents in a Cluster” in “Novell Cluster Services”
- “Deciding How to Install and Configure the Agents in a Cluster” in “Microsoft Clustering Services”

This section presents some additional POA installation and startup information that might be
useful as you install and start additional POAs for post offices throughout your GroupWise system.

¢ “Installing the POA Software” on page 427
+ “Starting the POA” on page 431

Installing the POA Software

Select the platform where you have installed the POA:
¢ “Fine-Tuning Your NetWare POA Installation” on page 427
¢ “Fine-Tuning Your Linux POA Installation” on page 430
¢ “Fine-Tuning Your Windows POA Installation” on page 430

Fine-Tuning Your NetWare POA Installation

After initial installation, you can fine-tune your NetWare® POA installation for improved
performance:

¢ “Recommended NetWare Server Parameters for the NetWare POA” on page 427
+ “Recommended NSS Parameters for the NetWare POA” on page 428
+ “Estimating NetWare POA Memory Requirements” on page 428

Recommended NetWare Server Parameters for the NetWare POA

Some default settings on the NetWare® server where the NetWare POA will run might be
inadequate for configurations of more than 100 concurrent client/server user connections. For a
discussion of how the POA interacts with the GroupWise client, see “Post Office Access Mode”
on page 422.

If you are planning a large client/server configuration, check the NetWare server parameters where
the NetWare POA will be installed to make sure they are adequate for the anticipated number of

Installing and Starting the POA 427



GroupWise clients. For example, in a medium-size system of 500 users in a post office, use the
following settings:

Parameter Setting
Maximum Packet Receive Buffers 2500
Minimum Packet Receive Buffers 1000
Maximum Concurrent Disk Cache Writes 200

If you are also running the NetWare MTA on the same server, see “Recommended NetWare Server
Parameters for the NetWare MTA” on page 565.

Recommended NSS Parameters for the NetWare POA

If you run the NetWare POA on NetWare 5.1 or 6.x Novell Storage Services™ (NSS) volumes, you
can significantly improve GroupWise performance by using the following parameters and settings
on the nss command in the autoexec.ncf file:

/NameCacheSize=20000

/OpenFileHashShift=15

/ClosedFileCacheSize=50000

/CacheBalance=60

The best /ClosedFileCacheSize setting for a server depends on many things, such as the amount of
memory on the server, the load on the POA, and the number of other programs running on the
server. For example, the 50000 setting can work well for a server that has 650 MB of memory.
Experiment with various settings in order to optimize performance.

The following TID, although originally written for GroupWise 5.x and NetWare 5.x, applies to
GroupWise 6.x and NetWare 6.x as well:

+ TID 10065215: Resolving GroupWise Performance Issues with NSS Volumes

Estimating NetWare POA Memory Requirements

The amount of memory required for the NetWare POA is influenced by many factors, including:
+ Number of client/server connections being supported
¢ Number of active client connections vs. idle connections
¢ Number of TCP handler threads
¢ Number of message handler threads

* Number of database maintenance threads

The table below provides approximate memory requirements for various POA activities. Actual
numbers might vary somewhat from release to release, but the numbers provided do illustrate what
activities require relatively more or less memory and what configuration options require more
memory than others. This information can be used to produce a rough estimate of the memory
required for your particular POA configuration. Always remember this basic rule when it comes
to planning for memory: More is better.
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POA Component Approx. References
Memory
Agent engine (gwenn4.nim)? 500 KB (required)
POA (gwpoa.nlm) 320 KB (required)
Main thread, Ul, logging 500 KB (required)
Dispatcher thread 60 KB (required)
Message handler threads (each)? (required for message file processing)
Startup 40 KB L
Idle 30 KB See “Adjusting the Number of POA Threads for
Processing 2000 KB Message File Processing” on page 512.
See also /threads.
TCP dispatch/monitor/ (required for client/server processing)
listener thread 100 KB ) ) i
See “Using Client/Server Access to the Post Office”
on page 447.
TCP handler threads (each)? (required for client/server processing)
Startup 40 KB o ) )
Idle 35 KB See “Adjusting the Number of Connections for Client/
Processing 2500 KB Server Processing” on page 508.
See also /tcpthreads.
Client/server connections (each) (required for client/server processing)
No message processing 45 KB o . .
Limited processing 70 KB See “Adjusting the Number of Connections for Client/
Heavy processing 155 KB Server Processing” on page 508.
See also /maxappconns and /maxphysconns.
MTP processes (required for TCP/IP link with MTA)
Scanner/listener 10 KB
Senders/receivers (each) 5KB See “Using TCP/IP Links between the Post Office
and the Domain” on page 443.
QuickFinder™ thread 30 KB (required for indexing)
Building/updating indexes 3000 KB

Compressing/combining indexes 4000 KB

Nightly User Upkeep 90 KB
Remote Address Book generation 40 KB
Auto-Date events
25 events 1530 KB
100 events 2140 KB
365 events 7885 KB
Notify 30 KB

See “Regulating Indexing” on page 514.
See also /qfinterval, /gfintervalinminute, /
gfbaseoffset, /qfbaseoffsetinminute, and /nogf.

(recommended)

See “Performing Nightly User Upkeep” on page 472.
See also /nuuoffset and /nonuu.

(optional)

See “Performing Nightly User Upkeep” on page 472.
See also /rdaboffset and /nordab.

(required; occasional, temporary usage)

(required)
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POA Component Approx. References

Memory
Admin thread (required for post office database update and repair)
Idle 20 KB
Processing 125 KB See /noada.

! The Agent Engine (gwenn4.nlm) needs to be loaded only once per server, no matter how many
agents (POAs, MTAs, Internet Agents, WebAccess Agents) are running on that server, as long
as they are running in the same address space.

2 By default, there are six message handler threads and six TCP handler threads, for a default total
of 450 KB for handler threads.

The table below provides some very general memory figures for running both GroupWise agents
on the same server.

Concurrent Users Actual Memory Usage at Peak Time

100 active users (100-250 users in post office) 50 MB
250 active users (250-500 users in post office) 110 MB
500 active users (500-1000 users in post office) 125 MB
1000 active users (1000-2500 users in post office) 150 MB

Fine-Tuning Your Linux POA Installation
After initial installation on Linux, no fine-tuning is necessary. The POA runs very efficiently in a
standard Linux installation.

Fine-Tuning Your Windows POA Installation

After initial installation, you can fine-tune your Windows POA installation for improved
performance:

¢ “Recommended Windows Parameters” on page 430

¢ “Estimating Windows POA Memory Requirements” on page 430

Recommended Windows Parameters

If you are running the Windows POA for a post office located on a NetWare server, you might need
to increase Maximum File Locks Per Connection from its default setting.

Estimating Windows POA Memory Requirements

Although the Windows POA memory requirements differ slightly from the NetWare POA, you can
use the figures provided for the NetWare POA to see what POA processes are most memory
intensive. See “Estimating NetWare POA Memory Requirements” on page 428.
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Starting the POA

Select the platform where you are starting the POA:
+ “Starting the NetWare POA” on page 431
+ “Starting the Linux POA” on page 433
+ “Starting the Windows POA” on page 434

Starting the NetWare POA

After installing the NetWare POA software, you can start the NetWare POA in several ways:
+ “Manually on the Command Line” on page 431
* “With a Startup File” on page 432

+ “Automatically in the autoexec.ncf File” on page 432

Manually on the Command Line

1 Go to the console of the NetWare server where the NetWare POA is installed.
or
Use Remote Console to access the server:
1a Press Alt+F1 to display the options.
1b Choose Select a Screen to View.
1¢c Choose System Console.

2 Enter the command to load the NetWare POA.
Syntax: load gwpoa.nlm /home- [svr\] [vol:]\po dir
Example: load gwpoa.nlm /home-serverl\mail:\sales

The /home startup switch is required to start the NetWare POA. If the post office is located on
a different server from where the NetWare POA is running, the /dn switch or the /user and /
password switches are also required so the NetWare POA can log in to that server. You can
also provide user and password information on the Post Office Settings page in ConsoleOne.

The NetWare POA agent console appears and displays normal startup status messages. See
Chapter 38, “Monitoring the POA,” on page 475.

#% ACCOUNTING.PROVO2 - GroupWise PDA =]
File Configuiation Log  Statistics  Actions  Help
ACCOUNTING. PROVO2 Up Tirne: 0 Days 2 Hrs 39 Mins
Groupwise Post Office Agent
7~ Status Statistic:
Processing / Busy: 0 :0 C/5 Requests: 2 Message Files 0
User Connections: 1] Requests Pending: 0 Undeliverable: 0
File Queles: 1) Users Timed Out: 0 Problem Messages: 0

T116:3311E  Database check action: Analyze/Fisup ﬂ
111633 11E  Level of database analysis and vernfication: Structural

11:16:3311E  Delete temporary/backup files older than [days] 7

11:16:33 11

11:16:33 157 Initizlizing dispatcher

11:16:33 158 Initishizing dispatcher

11:16:33 154 Initializing worker

11:16:33 158 Initializing worker

11:16:33 15C Initializing worker

11:16:33 15D Initializing warker

11:16:33 152 Initialzing worker
11:16:38 155 M TP Listening far inbound connections

11:16:33 15E Initializing worker j
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If the NetWare POA agent console does not appear, see “Post Office Agent Problems” in
GroupWise 6.5 Troubleshooting 2: Solutions to Common Problems.

When you start the NetWare POA as described above, it is configured according to the POA
settings specified in ConsoleOne®. You can go to ConsoleOne and modify POA functioning as
needed. See Chapter 37, “Configuring the POA,” on page 437.

With a Startup File

Another way to start the NetWare POA is to use a startup file. You could use a startup file with the
NetWare POA for the following reasons:

¢ Override POA settings defined in ConsoleOne.
+ Control the POA locally without using ConsoleOne.

+ Adjust specialized POA functions not controllable from ConsoleOne.

When you run the Agent Installation program, an initial POA startup file is created in the agent
installation directory. It is named using the first 8 characters of the post office name with a .poa
extension. This initial startup file includes the /home startup switch set to the location of the post
office directory.

If the post office is located on a different server from where the NetWare POA is running, you must
edit the startup file and provide settings for the /dn switch or the /user and /password switches so
the NetWare POA can log in to that server. You can also provide user and password information
on the Post Office Settings page in ConsoleOne.

The POA startup file can be modified to use other startup switches as needed. Startup switches
specified on the command line override those in the startup file. Startup switches in the startup file
override corresponding settings in ConsoleOne. See Chapter 40, “Using POA Startup Switches,”
on page 523.

When you use a startup file, you must include it on the command line when you load the NetWare
POA. For example:

Syntax: load gwpoa.nlm @POA startup filename
Example: load gwpoa.nlm @sales.poa

In addition to the initial POA startup file, the Agent Installation program also provides a
grpwise.ncf file to load the agents. If you plan to run only the NetWare POA, you should edit the
grpwise.ncf file to remove the command to load the MTA.

If you run multiple NetWare POAs for the same post office, you need a startup file with the /name
switch and a corresponding line in the grpwise.ncf file for each POA. A POA object in
eDirectory™ is also required for each POA. See “Creating a POA Object in eDirectory” on

page 438.

Automatically in the autoexec.ncf File

When the POA is running smoothly, you should modify the NetWare configuration file
(autoexec.ncf) to load the NetWare POA and required NetWare programs automatically whenever
you restart the server.

IMPORTANT: If you are running the POA in a Novell cluster, see “Configuring the GroupWise Volume
Resource to Load and Unload the Agents” in “Novell Cluster Services” in theGroupWise 6.5 Interoperability
Guide for alternative instructions.

1 Edit the autoexec.ncf file in the NetWare sys:\system directory.
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2 Add the following command to load the agents:
grpwise.ncf
or
To start the agents in protected mode, add the following command:
protect grpwise.ncf

3 Save the autoexec.ncf file.

4 If possible, restart the server to verify that the NetWare programs and the NetWare POA are
loading properly.

Starting the Linux POA

You can start the Linux POA in several ways:
¢ “Manually with a User Interface” on page 433
¢ “Manually as a Daemon” on page 433

+ “Automatically at System Startup” on page 434

Manually with a User Interface
1 Make sure you are logged in as root.
2 Change to the GroupWise agent bin directory.
cd /opt/novell/groupwise/agents/bin
3 Enter the following command to start the POA:

Syntax:
./gwpoa --show --home post office directory &

Example:
./gwpoa --show --home /gwsystem/polnx &

The POA startup file is created by the Installation Advisor in the /opt/novell/groupwise/agents/
share directory and is named after the post office that the POA services. Because the Installation
Advisor prompted you for post office names and directories, it can set the --home startup switch
in the POA startup file. In the bin directory where the POA executable is located, you could start
the POA with a command similar to the following example:

./gwpoa --show @../share/lnxpost.poa

Manually as a Daemon
1 Make sure you are logged in as root.
2 Change to the /etc/init.d directory.

3 To start the Linux POA (and perhaps the MTA as well, depending on the configuration of the
server), enter the following command:

./grpwise start

4 To confirm that the agents have started, enter the following command:
ps -eaf | grep gw
This lists all GroupWise agent process IDs.
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Automatically at System Startup

If you selected Launch GroupWise Agents on System Startup in the Agent Installation program,
the Agent Installation program configured your system so that the agents would start automatically
each time you restart your server. The Agent Installation program always creates a grpwise startup
script in /etc/init.d for starting the agents. To enable automatic startup, the Agent Installation

program also creates symbolic links named S99grpwise in the rc3.d and rc5.d directories so that
the agents load on restart into level 3 or 5, depending on the configuration of your Linux system.

When the grpwise script runs and starts the agents, it reads the agent startup files in /opt/novell/
groupwise/agents/share to check for configuration information provided by startup switches.
Because the --show switch cannot be used in the startup files, the agents never run with agent
console interfaces when started automatically when the server restarts.

During agent installation, if you specified only post offices and no domains, only POA startup files
were created and the grpwise startup script starts only the POA.

Starting the Windows POA

You can start the Windows POA in several ways:
¢ “Manually from the Windows Desktop” on page 434
* “With a Startup File” on page 434
+ “Automatically in the Windows Startup Group” on page 435

+ “Automatically as a Windows Service” on page 435

Manually from the Windows Desktop

With a Startup File

In Windows, click Start > Programs > GroupWise Agents, then start the Windows POA.

The Windows POA agent console should appear and display normal startup status messages. See
Chapter 38, “Monitoring the POA,” on page 475.

If the Windows POA agent console does not appear, see “Post Office Agent Problems” in
GroupWise 6.5 Troubleshooting 2: Solutions to Common Problems.

When you start the Windows POA as described above, it is configured according to the POA
settings specified in ConsoleOne. You can go back to ConsoleOne and modify POA functioning
as needed. See Chapter 37, “Configuring the POA,” on page 437.

Another way to start the Windows POA is to use a startup file. You could use a startup file to
configure the POA for the following reasons:

¢ Override POA settings defined in ConsoleOne.
+ Control the POA locally without using ConsoleOne.

+ Adjust specialized POA functions not controllable from ConsoleOne.

When you run the Agent Installation program, an initial POA startup file is created in the agent
installation directory. It is named using the first 8 characters of the post office name with a .poa
extension. This initial startup file includes the /home startup switch set to the location of the post
office directory.

434 GroupWise 6.5 Administration Guide



The POA startup file can be modified to use other startup switches as needed. Startup switches in
the startup file override corresponding settings in ConsoleOne. See Chapter 40, “Using POA
Startup Switches,” on page 523.

If you run multiple Windows POAs for the same post office, you need a startup file with the /name
switch and a corresponding desktop icon or Program menu item for each one. A POA object in
eDirectory is also required for each POA. See “Creating a POA Object in eDirectory” on page 438.

Automatically in the Windows Startup Group

After the Windows POA is running smoothly, you should add it to the Windows Startup group to
start the Windows POA automatically whenever you restart the Windows server.

1 In Windows NT, click Start > Settings > Taskbar > Start Menu Programs > Add.
or
In Windows 2000, click Start > Settings > Taskbar & Start Menu > Advanced > Add.
2 Browse to the directory where you installed the Windows POA.
3 Double-click gwpoa.exe, then add the startup file to the command line.
Example: gwpoa.exe @sales.poa
4 Click Next.
5 Select the Startup folder, provide a name for the shortcut, then click Finish.

6 If possible, restart the server to verify that the Windows POA starts when you log in.

Automatically as a Windows Service

To start the GroupWise Windows POA as a service for the first time after installation:
1 From the Windows desktop, click Start > Settings > Control Panel.
2 Double-click Services, select the POA service (named after the post office), then click Start.
To make sure the POA starts automatically each time you restart the server:
1 Click Start > Settings > Control Panel.
2 Double-click Services, select the POA service (named after the post office), then click Startup.
3 Select Automatic, then click OK.

Thereafter, you can manage the Windows agents just as you would any other services.

Uninstalling the POA Software

If you move the POA to a different server, you can uninstall the POA software from the old
location to regain disk space as long as the MTA is not running on the server. Select the platform
where you have been running the POA:

¢ “Uninstalling the NetWare or Windows POA” on page 436
¢ “Uninstalling the Linux POA” on page 436
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Uninstalling the NetWare or Windows POA
1 Stop the POA.

2 Run install.exe in the \agents subdirectory of the GroupWise software distribution directory
or GroupWise 6.5 Administrator CD.

3 In the Install/Uninstall dialog box, click Uninstall to remove the POA software from the
server.

Windows Note: If the Windows POA was running as a service, the Agent Installation program
removes the service, registry entry, and Start menu icon from Windows.

Uninstalling the Linux POA
1 Make sure you are logged in as root.
2 Stop the POA.

3 Enter the following command to determine the specific version of the POA that is running on
the server:

rpm -ga | grep groupwise
4 Enter the following command uninstall the POA:
rpm -e novell-groupwise-agents-version-date

where version is the version number (for example, 6.5.1) and date is the is the date when the
RPM was created (for example, 0428 for April 28).

This process removes all files and directories associated with the POA.
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Configuring the POA

As your GroupWise® system grows and evolves, you might need to modify POA configuration to
meet the changing needs of the post office it services. The following topics help you configure the

POA:

+ “Performing Basic POA
Configuration” on page 437

+ “Configuring User Access to
the Post Office” on page 446

+ “Configuring Post Office
Security” on page 456

+ “Configuring Post Office
Maintenance” on page 467

Creating a POA Object in eDirectory

Configuring the POA in ConsoleOne

Changing the Link Protocol between Post Office and Domain
Moving the POA to a Different server

Adjusting the POA for a New Post Office Location

Adjusting the POA Logging Level and Other Log Settings

Using Client/Server Access to the Post Office

Simplifying Client/Server Access with a GroupWise Name Server
Supporting IMAP Clients

Supporting CAP Clients

Checking What GroupWise Clients Are in Use

Supporting Forced Mailbox Caching

Restricting Message Size between Post Offices

Securing Client/Server Access through a Proxy Server
Enhancing Post Office Security with SSL Connections to the POA
Providing LDAP Authentication for GroupWise Users

Enabling Intruder Detection

Configuring Trusted Application Support

Scheduling Database Maintenance
Scheduling Disk Space Management
Performing Nightly User Upkeep

Performing Basic POA Configuration

POA configuration information is stored as properties of its POA object in eDirectory. The
following topics help you modify the POA object in ConsoleOne and change POA configuration
to meet changing system configurations:

+ “Creating a POA Object in eDirectory” on page 438

+ “Configuring the POA in ConsoleOne” on page 439

¢ “Changing the Link Protocol between the Post Office and the Domain™ on page 442

* “Moving the POA to a Different server” on page 445

¢ “Adjusting the POA for a New Post Office Location” on page 445
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Creating a POA Object in eDirectory

When you create a new post office, one POA object is automatically created for it. You can set up
additional POAs for an existing post office if message traffic in the post office is heavy. To
accomplish this, you must create additional POA objects as well.

To create a new POA object in Novell® eDirectory™:

1 In ConsoleOne®, browse to and right-click the Post Office object for which you want to create
anew POA object, then click New > Object.

2 Double-click GroupWise Agent to display the Create GroupWise Agent dialog box.

I8 create GroupWise Agent x|

[ ]
[eeoa |

Cancel

Agent Narne:

Type:

[Fast office 1=

[ Define additional properties

[ Create another agent

3 Type a unique name for the new POA. The name can include as many as 8 characters. Do not
use any of the following invalid characters in the name:

ASCII characters 0-13 Comma ,

Asterisk * Double quote "

At sigh @ Extended characters
Braces {} Parentheses ()
Colon : Period .

You use this name with the /name startup switch when you start the new POA.
The Type field is automatically set to Post Office.

4 Sclect Define Additional Properties.

5 Click OK.
The POA object is automatically placed within the Post Office object.

6 Review the information displayed for the first four fields on the Identification page to ensure
that you are creating the correct type of Agent object in the correct location.
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Propetties of POA x|
{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |
i Iekentification
Domain.PO; Provo1.Development
Distinguished Marne: POA Development Grouptvise
Mame: POA
Agent Type: Post Office
Drescription Groupiyise Post Office Agent
Platform: Netare Loadable Module LI
Page Options... | cancel | | mew |

7 In the Description field, type one or more lines of text describing the POA.

This description displays on the POA agent console as the POA runs. When you run multiple
POAs on the same server, the description should uniquely identify each one. If multiple
administrators work at the server where the POA runs, the description could include a note
about who to contact before stopping the POA.

8 In the Platform field, select the platform (NetWare, Linux, or Windows) where the POA will
run.

9 Continue with “Configuring the POA in ConsoleOne” on page 439.

Configuring the POA in ConsoleOne

The advantage to configuring the POA in ConsoleOne, as opposed to using startup switches in a
POA startup file, is that the POA configuration settings are stored in eDirectory.

1 In ConsoleOne, expand the eDirectory container where the Post Office object is located.
2 Expand the Post Office object.
3 Right-click the POA object, then click Properties.

The table below summarizes the POA configuration settings in the POA object properties pages
and how they correspond to POA startup switches (as described in Chapter 40, “Using POA
Startup Switches,” on page 523):

ConsoleOne Properties Pages Corresponding Tasks and Startup Switches
and Settings

POA Identification Page

Domain.PO See “Creating a POA Object in eDirectory” on page 438.
Distinguished Name

Name

Type

Description

Platform
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ConsoleOne Properties Pages

and Settings

Corresponding Tasks and Startup Switches

POA Agent Settings Page

Message File Processing

Message Handler Threads

Enable TCP/IP (for C/S)

TCP Handler Threads

Max Physical Connections

Max Application Connections

Enable Caching

CPU Utilization (NLM)
Delay Time (NLM)

Max Thread Usage for
Priming and Moves

Enable IMAP
Max IMAP Threads

Enable CAP
Max CAP Threads

Enable SNMP
SNMP Community "Get"
String

HTTP User Name
HTTP Password

Network Address Page

TCP/IP Address
IPX/SPX Dress

Proxy Server Address

Message Transfer

See “Configuring a Dedicated Message File Processing POA” on
page 513.
See also /nomf, /nomfhigh, and /nomflow.

See “Adjusting the Number of POA Threads for Message File
Processing” on page 512.
See also /threads.

See “Using Client/Server Access to the Post Office” on page 447 and
“Configuring a Dedicated Client/Server POA” on page 510.
See also /notcpip.

See “Adjusting the Number of Connections for Client/Server
Processing” on page 508.
See also /tcpthreads.

See “Adjusting the Number of Connections for Client/Server
Processing” on page 508.
See also /maxphysconns and /maxappconns.

See /nocache.

See “Optimizing CPU Utilization for the NetWare POA” on page 520.
See also /cpu and /sleep.

See “Supporting Forced Mailbox Caching” on page 454.
See also /primingmax.

See “Supporting IMAP Clients” on page 450.
See also /imap and /imapmaxthreads.

See “Supporting CAP Clients” on page 451.
See also /cap and /capmaxthreads.

See “Using SNMP Monitoring Programs” on page 499.
See also /nosnmp.

See “Setting Up the POA Web Console” on page 489.
See also /httpuser and /httppassword.

See “Using Client/Server Access to the Post Office” on page 447 and
“Using TCP/IP Links between the Post Office and the Domain” on
page 443.

See also /ip.

See “Securing Client/Server Access through a Proxy Server” on
page 456.

See “Using TCP/IP Links between the Post Office and the Domain” on
page 443.

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, /
mtpsendmax and /msgtranssl.
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ConsoleOne Properties Pages
and Settings

Corresponding Tasks and Startup Switches

HTTP

Local Intranet Client/Server
Internet Proxy Client/Server

IMAP

CAP

QuickFinder Page

Enable QuickFinder Indexing
Start QuickFinder Indexing
QuickFinder Interval

Maintenance Page
Enable Auto DB Recovery

Maintenance Handler
Threads

Perform User Upkeep

Start User Upkeep

Generate Address Book
for Remote

Start Address Book
Generation

Disk Check Interval
Disk Check Delay

POA Log Settings Page

Log File Path
Logging Level

Max Log File Age
Max Log Disk Space

POA Scheduled Events
Page

Disk Check Event

Mailbox/Library Maintenance
Event

POA SSL Settings Page

See “Setting Up the POA Web Console” on page 489.
See also /httpport and /httpssl.

See “Using Client/Server Access to the Post Office” on page 447 and
“Using TCP/IP Links between the Post Office and the Domain” on
page 443.

See also /port, /internalclientssl, and /externalclientssl.

See “Supporting IMAP Clients” on page 450.
See also /imapport, /imapssl, and /imapsslport.

See “Supporting CAP Clients” on page 451.
See also /capport and /capssl.

See “Regulating Indexing” on page 514 and “Configuring a Dedicated
Indexing POA” on page 516.

See also /qfbaseoffset, /gfbaseoffsetinminute, /gfinterval, /
gfintervalinminute, and /noqgf.

See /norecover.

See “Adjusting the Number of POA Threads for Database
Maintenance” on page 517.

See also /gwchkthreads and /nogwchk.

See “Performing Nightly User Upkeep” on page 472.
See also /nuuoffset, /nonuu, /rdaboffset, and /nordab.

See “Scheduling Disk Space Management” on page 469.

See “Using POA Log Files” on page 497.
See also /log, /logdays, /logdiskoff, /loglevel, and /logmax.

See “Scheduling Disk Space Management” on page 469.

See “Scheduling Database Maintenance” on page 467.
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ConsoleOne Properties Pages
and Settings

Corresponding Tasks and Startup Switches

Certificate File
SSL Key File
Password

Post Office Settings Page

Remote User Name
Remote Password

Post Office Client Access
Settings Page

Lock Out Older GroupWise
Clients

Minimum Client Release
Version

Minimum Client Release Date

Enable Intruder Detection
Incorrect Logins Allowed
Incorrect Login Reset Time
Lockout Reset Time

Post Office Security Page

LDAP Authentication

See “Enhancing Post Office Security with SSL Connections to the
POA” on page 458.
See also /certfile, /keyfile, /keypassword.

See Chapter 36, “Installing and Starting the POA,” on page 427.
See also /user and /password.

See “Checking What GroupWise Clients Are in Use” on page 452.
See also /gwclientreleasedate, /gwclientreleaseversion, and /
enforceclientversion.

See “Enabling Intruder Detection” on page 465.
See also /intruderlockout, /incorrectloginattempts, /
attemptsresetinterval, and /lockoutresetinterval.

See “Providing LDAP Authentication for GroupWise Users” on

page 461.

See also /Idapipaddr, /Idapport, /Idapuser, /Idappwd, /
Idapuserauthmethod, /Idapdisablepwdchg, /Idapssl, /Idapsslkey, and /
Idaptimeout.

See also /Idapippooln, /Idappoolresettime, /Idapportpooln, /
Idapsslpooln, and /Idapsslkeypooln.

After you install the POA software, you can further configure the POA using a startup file. See
Chapter 40, “Using POA Startup Switches,” on page 523 to survey the many ways the POA can

be configured.

Changing the Link Protocol between the Post Office and the Domain

442

How messages are transferred between the POA and the MTA is determined by the link protocol
in use between the post office and the domain. For a review of link protocols, see “Link Protocols

for Direct Links” on page 134.

If you need to change from one link protocol to another, some reconfiguration of the POA and its
link to the domain is necessary.

¢ “Using TCP/IP Links between the Post Office and the Domain™ on page 443

¢ “Using Mapped or UNC Links between the Post Office and the Domain” on page 444

NOTE: The Linux POA requires TCP/IP lines between the post office and the domain.
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Using TCP/IP Links between the Post Office and the Domain

To change from a mapped or UNC link to a TCP/IP link between a post office and its domain, you
must perform the following two tasks:

*

*

“Configuring the Agents for TCP/IP” on page 443
“Changing the Link between the Post Office and the Domain to TCP/IP” on page 443

Configuring the Agents for TCP/IP

1

2

If the MTA in the domain is not yet set up for TCP/IP communication, follow the instructions
in “Configuring the MTA for TCP/IP” on page 579.

To make sure the POA is properly set up for TCP/IP communication, follow the instructions
in “Using Client/Server Access to the Post Office” on page 447.

Only one POA per post office needs to communicate with the MTA. If the post office has
multiple POAs, have a POA that performs message file processing communicate with the
MTA for best performance. For information about message file processing, see “Role of the
Post Office Agent” on page 423.

In ConsoleOne, browse to and right-click the POA object, then click Properties.
Click GroupWise > Network Address to display the Network Address page.

Properties of POA x|
GroupWise ~ | NDS Rights vI Cther | Rights to Files and Folders I
hetwork Address
TCP/IP Address |17218.518 =l
Proxy Server Address: | ZI
IPHSPX Address: I Z|
Fart S5L SSL Port
Message Transfer: 71m il lm
HTTP [7181 3] [Disabled =]
Local Intranet ClientServer, Iﬁﬂ lm
Internet Proxy Client/Server: I—Dil lm
IMAP: [1aa 3] [Disabled =] [ 583 3
AP [1028 3] [Disabled =]
Page Options... ok | cancel | appy | pew |

In the Message Transfer field, specify the TCP port on which the POA will listen for incoming
messages from the MTA.

The default message transfer port for the POA to listen on is 7101.

6 Click OK to save the TCP/IP information and return to the main ConsoleOne window.

Corresponding Startup Switches
You could also use the /mtpinipaddr and /mtpinport startup switches in the POA startup file to set
the incoming IP address and port.

Changing the Link between the Post Office and the Domain to TCP/IP

1

In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration.
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2 In the drop-down list, select the domain where the post office resides.

3 Click Post Office Links, then double-click the post office for which you want to change the
link protocol.

4 In the Protocol field, select TCP/IP.

Edit Post Office Link

Post Office: Accounting

Protocol: ITCPIIP vl Cancel

Past Cfice Agent. [FoA = Help

IP Address |123 45.678.136 MT Part: |?1D1 il
Client/Setver Port: |1E??
Maximum send message size 0 ::I MBytes

5 Make sure the information displayed in the Edit Post Office Link dialog box matches the
information on the Network Address page for the POA.

6 Click OK.
7 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.

ConsoleOne then notifies the POA and MTA to restart using the new link protocol.

For a sample message flow for this configuration, see “TCP/IP Link Open: Transfer between Post
Offices Successful” in “Message Delivery to a Different Post Office” in GroupWise 6.5
Troubleshooting 3: Message Flow and Directory Structure.

Corresponding Startup Switches
You could also use the /mtpoutipaddr and /mtpoutport startup switches in the POA startup file to
set the outgoing IP address and port.

Using Mapped or UNC Links between the Post Office and the Domain

To change from a TCP/IP link to a mapped or UNC link between a post office and its domain:
1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration.
2 In the drop-down list, select the domain where the post office resides.

3 Click Post Office Links, then double-click the post office for which you want to change the
link protocol.

In the Protocol field, select Mapped or UNC.
Provide the location of the post office in the format appropriate to the selected protocol.

Click OK.

N~ o a b

To exit the Link Configuration tool and save your changes, click File > Exit > Yes.

ConsoleOne then notifies the POA and MTA to restart using the new link protocol.

For a sample message flow for this configuration, see “Mapped/UNC Link Open: Transfer
between Post Offices Successful” in “Message Delivery to a Different Post Office” in Group Wise
6.5 Troubleshooting 3: Message Flow and Directory Structure.

444 GroupWise 6.5 Administration Guide



Moving the POA to a Different server

As your GroupWise system grows and evolves, you might need to move a POA from one server
to another. For example, you might decide to run the POA on a different platform, or perhaps you
want to move it to a server that has more memory.

1 When moving the POA, pay special attention to the following details:

*

For a POA configured for client/server processing, reconfigure the POA object with the
new [P address and port number for the POA to use on the new server. See “Using Client/
Server Access to the Post Office” on page 447.

For the NetWare POA, if it was originally on the same server where the post office is
located and you are moving it to a different server, add the /dn switch or the /user and /
password switches to the POA startup file to give the NetWare POA access to the server
where the post office is located. You can also provide user and password information on
the Post Office Settings page.

2 Install the POA on the new server. See “Installing GroupWise Agents” in the Group Wise 6.5
Installation Guide.

3 Start the new POA. See “Starting the POA” on page 431.

4 Observe the new POA to see that it is running smoothly. See Chapter 38, “Monitoring the
POA,” on page 475.

5 Stop the old POA.

6 If you are no longer using the old server for any GroupWise agents, you can remove them to
reclaim the disk space. See “Uninstalling the POA Software” on page 435.

Adjusting the POA for a New Post Office Location

If you move a post office from one server to another, you also need to edit the POA startup file to
provide the new location of the post office directory.

1 Stop the POA for the old post office location if it is still running.
2 Use an ASCII text editor to edit the POA startup file.

The POA startup file is named after the post office name, plus a.poa extension.

*

On NetWare and Windows, only the first 8 characters of the post office name are used in
the filename. The startup file is typically located in the directory where the POA software
is installed.

On Linux, the full post office name is used in the filename. However, all letters are
lowercase and any spaces in the post office name are removed. The startup file is located
in the /opt/novell/groupwise/agents/share directory.

3 Adjust the setting of the /home switch to point to the new location of the post office directory.
4 Save the POA startup file.

5 Start the POA for the new post office location. See “Starting the POA” on page 431.

6 Adjust the link between the post office and the domain. See “Adjusting the MTA for a New
Location of a Domain or Post Office” on page 587.
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Adjusting the POA Logging Level and Other Log Settings

When installing or troubleshooting the POA, a logging level of Verbose can be useful. However,
when the POA is running smoothly, you can set the logging level down to Normal to conserve disk
space occupied by log files.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Log Settings to display the Log Settings page.

Properties of POA x|
+| NoS Rights = | ctter | Rights 1o Files and Folders |
Log File Path: [ =
Logging Level INormaI LI
Wax Lag File Age: 7 ::I days
-
Max Log Disk Space: 1024 j KBytes
Pane Options... 0K Cancel Apply Help

3 Set the desired settings for logging.

For more information about log settings and log files, see “Using POA Log Files” on
page 497.

Corresponding Startup Switches
You could also use the /log, /loglevel, /logdays, /logmax, and /logdiskoff switches in the POA
startup file to configure logging.

POA Web Console
You can view and search POA log files on the Log Files page.

Configuring User Access to the Post Office

As described in “Post Office Access Mode” on page 422, the GroupWise 6.x client defaults to
client/server access mode. The following topics help you configure the POA to customize the
types of client/server access provided to the post office:

+ “Using Client/Server Access to the Post Office” on page 447

+ “Simplifying Client/Server Access with a GroupWise Name Server” on page 449
+ “Supporting IMAP Clients” on page 450

+ “Supporting CAP Clients” on page 451

¢ “Checking What GroupWise Clients Are in Use” on page 452

* “Supporting Forced Mailbox Caching” on page 454

* “Restricting Message Size between Post Offices” on page 455

446 GroupWise 6.5 Administration Guide



Using Client/Server Access to the Post Office

To make sure the GroupWise client has proper client/server access to the post office:
1 Make sure TCP/IP is properly set up on the server where the POA is running.
2 In ConsoleOne, browse to and right-click the POA object, then click Properties.
3 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA H x|

| DS Rights - | Cther I Rights to Files and Folders I

Message File Processing: |AII ;I
Message Handler Threads: I—aﬁ

[¥ Enable TGRAF for ClientiSenver)

TCF Handler Threads: [ &g

Max Physical Connections: mﬁ

Max App Connections: Imﬁ

[ Enable Caching

CPU Utilization (NLM): [ 85 2] percent

Delay Time (NLM): [ 100 2] miliseconds

Max Thread LUsage for Priming and Moves: I 20 ﬁ’ percent -

¥ Enable IMAP

Max IMAF Threads [ 50 2

¥ Enahle CAP

Max CAP Threads: [ 50 2 =
Page Options... 04 I Cancel | ARl | Help |

4 Make sure that Enable TCP/IP (for Client/Server) is selected.

The default numbers of physical connections and application connections are appropriate for
a post office with as many as 500 users. If you are configuring the POA to service more than
500 users, see “Adjusting the Number of Connections for Client/Server Processing” on
page 508 for more detailed recommendations. Configuring the POA with insufficient
connections can result in error conditions.

5 Click GroupWise > Network Address.
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Propetties of POA x|
GroupWise ~ | NDS Rights vI Cther | Rights to Files and Folders I
hetwork Address
TCP/IP Address |17218.518 =l
Proxy Server Address: | ZI
IPHSPX Address: I Z|
Part 55L S5L Port
Message Transfer: Wi‘ lm
HTTP [7181 3] [Disabled =]
Local Intranet ClientServer, Iﬁﬂ lm
Internet Proxy Client/Server: I—Dil lm
IMAP: [1aa 3] [Disabled =] [ 583 3
AP [1028 3] [Disabled =]
Page Options... ok | cancel | appy | pew |

6 On the Network Address page, click the pencil icon for the TCP/IP Address field to display
the Edit Network Address dialog box.

+ Edit Network Address x|

CPIIP Address

& |P Address 123 I 45 I BT I a4

 DNS Host Name: |

oK I gancell Help |

7 Select IP Address, then specify the IP address, in dotted decimal format, of the server where
the POA is running.

or

Select DNS Host Name, then provide the DNS hostname of the server where the POA is
running.

IMPORTANT: The POA must run on a server that has a static IP address. DHCP cannot be used to
dynamically assign an IP address for it.

Specifying the DNS hostname rather than the IP address makes it easier to move the POA
from one server to another, should the need arise at a later time. You can assign a new [P
address to the hostname in DNS, without needing to change the POA configuration
information in ConsoleOne.

8 Click OK.

9 To use a TCP port number other than the default port of 1677, type the port number in the
Local Intranet Client/Server Port field.

If multiple POAs will run on the same server, each POA must have a unique TCP port number.

10 Ifneeded, select Enabled or Required in the SSL drop-down list for local intranet client/server
connections, Internet client/server connections, or both. For more information, see
“Enhancing Post Office Security with SSL Connections to the POA” on page 458.

11 Click OK to save the network address and port information and return to the main ConsoleOne
window.

ConsoleOne then notifies the POA to restart with client/server processing enabled.
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For a sample message flow for this configuration, see “Message Delivery in the Local Post Office”
in GroupWise 6.5 Troubleshooting 3: Message Flow and Directory Structure.

Corresponding Startup Switches

You could also use the /port switch in the POA startup file to provide the client/server port number.
On a server with multiple IP addresses, you can use the /ip switch to bind the POA to a specific
address.

POA Web Console
You can view the TCP/IP address and port information for the POA on the Configuration page
under the Client/Server Settings heading.

Simplifying Client/Server Access with a GroupWise Name Server

If GroupWise users are set up correctly in eDirectory, the GroupWise client can determine which
post office to access for each user based on the information stored in eDirectory. This lets the
GroupWise client start automatically in client/server mode without users needing to know and
provide any IP address information. However, some GroupWise users might be on platforms
where eDirectory is not in use. To fill the same function for non-eDirectory users, you can set up
a GroupWise name server.

A GroupWise name server redirects each GroupWise client user to the [P address and port number
of the POA that services the user’s post office. By setting up a GroupWise name server, non-
eDirectory GroupWise client users do not need to know and provide any IP address information
when they start the GroupWise client in client/server mode. The GroupWise name server takes
care of this for them.

¢ “Required Hostnames” on page 449

¢ “Required Port Number” on page 449

* “How a GroupWise Name Server Helps the GroupWise Client Start” on page 449
+ “Setting Up a GroupWise Name Server” on page 450

Required Hosthames

The primary GroupWise name server must be designated using the hostname ngwnameserver. You
can also designate a backup GroupWise name server using the hostname ngwnameserver2.

Required Port Number

Each server designated as a GroupWise name server must have a POA running on it that uses the
default port number of 1677. Other agents can run on the same server, but one POA must use the
default port number of 1677 in order for the GroupWise name server to function. For setup
instructions, see “Using Client/Server Access to the Post Office” on page 447.

How a GroupWise Name Server Helps the GroupWise Client Start

After a server has been designated as ngwnameserver, and a POA using the default port number
of 1677 is running on that server, the GroupWise client can connect to the POA of the appropriate
post office by contacting the POA located on ngwnameserver. If ngwnameserver is not available,
the client next attempts to contact the backup name server, ngwnameserver2. If no GroupWise
name server is available, the user would need to provide the IP address and port number of the
appropriate POA in order to start the GroupWise client in client/server mode.
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Setting Up a GroupWise Name Server

1 Make sure that TCP/IP is set up and functioning on your network.

2 Know the IP address of the server you want to set up as a GroupWise name server.
3 Make sure the POA on that server uses the default TCP port of 1677.
4

If you want a backup Group Wise name server, identify the IP address of a second server where
the POA uses the default TCP port of 1677.

5 Use your tool of choice for modifying DNS.
NetWare Note: On a NetWare server, you could use INETCFG.

Linux Note: On a SUSE server, you could use the YaST Control Center. On a Red Hat server,
you could use Server Settings > Domain Name Server on the Red Hat menu.

Windows Note: On a Windows server, you could use DNS Manager.
6 Create an entry for the IP address of the first POA and give it the hostname ngwnameserver.

7 If you want a backup name server, create an entry for the IP address of the second
POA and give it the hostname ngwnameserver2.

You must use the hostnames ngwnameserver and ngwnameserver2. Any other hostnames are
not recognized as GroupWise name servers.

8 Save your changes.

As soon as the hostname information replicates throughout your system, GroupWise client users
can start the GroupWise client in client/server mode without specifying a TCP/IP address and port
number.

Supporting IMAP Clients

You can configure the POA so that IMAP (Internet Messaging Application Protocol) clients such
as Netscape Mail, Eudora Pro, Microsoft Outlook, and Entourage can connect to the post office
much like the GroupWise client does.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.
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Propetties of PDA x|

{GroupWise = || NDS Rights » | Cther | Rights to Files and Foiders |

§ Agent Settings
Megsage File Processing: Jan =l
Message Handler Threads: I—Eﬁ
[¥ Enable TCPAP (for ClientiServer)
TGP Handler Threads: [ &
Max Physical Conne ctions: mﬁ
Max App Cannections: Imi’
[¥ Enable Caching
CPU Utilization (MLM): I—eaﬁ percent
Delay Time (NLM: mﬁ milliseconds

Max Thread Usage for Priming and Moves: I 20 i’ percent o

[ Enable IMAP

Max IMAP Threads | 50 2]

[ Enable CAP

Max CAP Threads: [ 50 2 |
Page Options... | cancel | mew |

3 Select Enable IMAP.

The default maximum number of IMAP threads is 50. This is adequate for most post offices,
because each IMAP thread can service multiple IMAP clients. New threads are started
automatically to service clients until the maximum number is reached.

4 If you want IMAP clients to use SSL connections to the post office, click GroupWise >
Network Address, then select Enabled or Required in the IMAP SSL drop-down list.

For additional instructions about using SSL connections, see Chapter 80, “Encryption and
Certificates,” on page 1039.

5 Click OK to save the IMAP settings and return to the main ConsoleOne window.
ConsoleOne then notifies the POA to restart with IMAP enabled.

Corresponding Startup Switches

You could also use the /imap, /imapmaxthreads, /imapport, /imapssl, /imapsslport, and /
imapreadlimit startup switches in the POA startup file to configure the POA to support IMAP
clients.

POA Web Console
You can see whether IMAP is enabled on the Configuration page under the General Settings
heading.

Supporting CAP Clients

You can configure the POA so that CAP (Calendar Access Protocol) clients can connect to the post
office much like the GroupWise client does.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.
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Propetties of PDA x|

{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |

§ Agent Settings
Megsage File Processing: Jan =l
Message Handler Threads: I—Eﬁ
[¥ Enable TCPAP (for ClientiServer)
TGP Handler Threads: [ &
Max Physical Conne ctions: mﬁ
Max App Cannections: Imi’
[¥ Enable Caching
CPU Utilization (MLM): I—eaﬁ percent
Delay Time (NLM: mﬁ milliseconds

Max Thread Usage for Priming and Moves: I 20 i’ percent o

[ Enable IMAP

Max IMAP Threads | 50 2]

[ Enable CAP

Max CAP Threads: [ 50 2 |
Page Options... | cancel | mew |

3 Select Enable CAP.

The default maximum number of CAP threads is 50. This is adequate for most post offices,
because each CAP thread can service multiple CAP clients. New threads are started
automatically to service clients until the maximum number is reached.

4 [f you want CAP clients to use SSL connections to the post office, click GroupWise >
Network Address, then select Enabled or Required in the CAP SSL drop-down list.

For additional instructions about using SSL connections, see Chapter 80, “Encryption and
Certificates,” on page 1039.

5 Click OK to save the CAP settings and return to the main ConsoleOne window.
ConsoleOne then notifies the POA to restart with CAP enabled.

Corresponding Startup Switches
You could also use the /cap, /capmaxthreads, /capport, and /capssl startup switches in the POA
startup file to configure the POA to support CAP clients.

POA Web Console
You can see whether CAP is enabled on the Configuration page under the General Settings
heading.

Checking What GroupWise Clients Are in Use

452

You can configure the POA to identify GroupWise client users who are running GroupWise clients
that do not correspond to a specified release version and/or date. You can also force them to update
to the specified version.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties.
2 Click GroupWise > Client Access Settings to display the Client Access Settings page.
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{Groupwise = i| Memberships | NDS Rights = | Other | Rights to Files and Folders

i Cliert Access Settings
Lock Qut Older GroupWise Clients
[ Minimum Client Release Yersion ok IE.D LI
[T Minimum Client Release Date |
[~ Disahle Loging
[ Enahle Infruder Detection
I s
—
—
Page Options... | cancel | | Hew

3 Specify the approved GroupWise release version, if any.
Only 6.x versions of the client are supported for lockout.
4 Specify the approved GroupWise release date, if any

You can specify the minimum version, the minimum date, or both. If you specify both
minimums, any user for which both minimums are not true is identified as running an older
GroupWise client.

5 Select Lock Out Older GroupWise Clients for the version and/or date if you want to force
users to update in order to access their GroupWise mailboxes.

If you lock out older clients, client users receive an error message and be unable to access their
mailboxes until they upgrade their GroupWise client software to the minimum required
version and/or date.

6 Click OK to save the GroupWise version and/or date settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches

You could also use the /gwclientreleaseversion, /gwclientreleasedate, and /enforceclientversion
startup switches in the POA startup file to configure the POA to check client version and/or date
information.

POA Web Console

On the Status page of the POA Web console, click C/S Users to display the Current Users page,
which lists all GroupWise users who are currently accessing the post office. Users who are running
GroupWise clients older than the approved version and/or date are highlighted in red in the list.

Historical Note: The capability of identifying client version and date information was first
introduced in GroupWise 5.5 Enhancement Pack Support Pack 1. Any clients with versions and
dates earlier than GroupWise 5.5 Enhancement Pack Support Pack 1 do not appear at all on the
Current Users page of the POA Web console.
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Supporting Forced Mailbox Caching

GroupWise client users have the option to download their GroupWise mailboxes to their
workstations so they can work without being continuously connected to the network. This is called
Caching mode. For more information, see “Caching Mode” on page 965.

When client users change to Caching mode, the contents of their mailboxes must be copied to their
hard drives. This process is called "priming" the mailbox. If users individually decide to use
Caching mode, the POA easily handles the process.

If you force all users in the post office to start using Caching mode, as described in “Allowing or
Forcing Use of Caching Mode” on page 966, multiple users might attempt to prime their
mailboxes at the same time. This creates a load on the POA that can cause unacceptable response
to other users.

To configure the POA to handle multiple requests to prime mailboxes:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of PDA ﬁl

{GroupWise v || NDS Rights v | Other | Rights to Files and Foiers |

i Agent Seffings
Message File Processing: |AII LI
Message Handler Threads: I—Eﬁi
[¥ Enable TCPAP (for ClientiServer)
TCP Handler Threads: [ 3
Max Physical Conneclions: Wﬂ
Max App Connections: Imﬁ’
[¥| Enable Caching
CPU Utilizatian (WLM): [ 85 2] percent
Delay Time (NLM): [ 100 2] miliseconds

Max Thread Usage for Priming and Moves: I 20 ﬁ’ percent -

[ Enable IMAF

Max IMAP Threads [ 50 2

[ Enable CAP

Max CAP Threads: | 505 |
Page Options | cancel | | pew |

3 Set Max Thread Usage for Priming and Moves as needed.

By default, the POA allocates only 20% of its TCP handler threads for priming mailboxes for
users who are using Caching mode for the first time. In a default configuration, this would be
only one thread. You might want to specify 60 or 80 so that 60% to 80% of POA threads are
used for priming mailboxes. You might also want to increase the number of TCP handler
threads the POA can start in order to handle the temporarily heavy load while users are
priming their mailboxes. See “Adjusting the Number of Connections for Client/Server
Processing” on page 508.

4 Click OK to save the new setting.

ConsoleOne then notifies the POA to restart so the new setting can be put into effect.

Corresponding Startup Switches
You could also use the /primingmax switch in the POA startup file to configure the POA to handle
multiple requests to prime mailboxes.
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POA Web Console
You can change the POA’s ability to respond to caching requests for the current POA session on

the Configuration page. Under the Client/Server Settings heading, click Max Thread Usage for
Priming and Live Moves. To increase the number of client/server threads, click Client/Server
Processing Threads under the Performance Settings heading.

Restricting Message Size between Post Offices

You can configure the POA to restrict the size of messages that users are permitted to send outside
the post office.

1 In ConsoleOne, click Tools > GroupWise Utilities > Link Configuration.

Gruupwise Link Configuration Tool - "-‘,"-.‘PRV-GW"-.‘sys"-‘,gwsysteni_:' = Ellﬂ
File Edit Search Wiew Window Help
pe| BB 7| mla 9zl et erma [ E|m”
E8pomain: Provo1 1 [=]
Quthound Links from Provol
rDirect Indirect - Gatewar Undefined
% Provo2

Inbound Links to Provo1

rindirect

2 In the drop-down list, select the domain where the post office resides, then click Post Office

Links.
Gruupwise Link Configuration Tool - 4\PRY-GW\sys! gwsyske| - Ellﬂ
File Edit Search Wiew ‘Window Help
pe| BB 7| mla 9zl et erma = |
M8 Post Office Links for Provo1
Post Office Links for Provol
Post Office Domain Link
\ Manufacturing |Provo1 123.45.678.136: 1677, 7101
\‘ R&D Provo1 123.45.678.136: 1677, 7201

3 Double-click the post office where you want to restrict message size.

Edit Post Office Link
PostOffice:  Accounting -
Protocol: ITCPIIP 'l Cancel

Post Office Agent: [POA =l Help
P agdress. [12345678136  WTPor [rion 2|

ClientSenver Part. [1677

Maximumm send message size ID_::I MBytes

4 In the Maximum Send Message Size field, specify in megabytes the size of the largest
message you want users to be able to send outside the post office, then click OK.

5 To exit the Link Configuration tool and save your changes, click File > Exit > Yes.
ConsoleOne then notifies the POA to restart using the new maximum message size limit.
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Configuring

If a user’s message is not sent out of the post office because of this restriction, the user receives an
e-mail message with a subject line of:

Delivery disallowed

plus the subject of the original message. This message provides information to the user about why
and where the message was disallowed. However, the message is still delivered to recipients in the
sender’s own post office.

There are additional ways to restrict the size of messages that users can send, as described in
“Restricting the Size of Messages That Users Can Send” on page 175.

Corresponding Startup Switches
You could also use the /mtpsendmax startup switch in the POA startup file to restrict message size.

POA Web Console

You can view the maximum message size on the Configuration page. You can change the
maximum message size for the current POA session using the Message Transfer Protocol link on
the Configuration page.

Post Office Security

You can configure the POA in various ways to meet the security needs of the post office.
¢ “Securing Client/Server Access through a Proxy Server” on page 456
¢ “Enhancing Post Office Security with SSL Connections to the POA” on page 458
* “Providing LDAP Authentication for GroupWise Users” on page 461
+ “Enabling Intruder Detection” on page 465

Securing Client/Server Access through a Proxy Server

If the server where the POA runs is behind your firewall, you can link it to a proxy server in order
to provide client/server access to the post office for GroupWise client users who are outside the
firewall.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the POA Network Address page.
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3 Make sure the POA is already configured for client/server processing as explained in “Using
Client/Server Access to the Post Office” on page 447.

4 Click the pencil icon for the Proxy Server Address field to display the Edit Network Address
dialog box.

+ Edit Network Address x|

CPIIP Address

&+ IF Address 123 I 45 I BT I a4

" DNE Host Name: |

oK I gancell Help |

5 Sclect IP Address, then specify the IP address, in dotted decimal format, of the server that
GroupWise client users access from outside your firewall.

or
Select DNS Host Name, then provide the DNS hostname of that server.
6 Click OK.

7 If you want to use a different port number for the proxy server than you are using for client/
server access to the POA itself, provide the port number in the Internet Proxy Client/Server
field.

8 Click OK to save the proxy server network address and port and return to the main
ConsoleOne window.

ConsoleOne then notifies the POA to restart and begin communicating with the proxy server.

POA Web Console
You can list all POAs in your GroupWise system, along with their proxy server addresses. On the
Configuration page, click IP Addresses Redirection Table under the General Settings heading.
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Controlling Client Redirection Inside and Outside Your Firewall

When a user tries to access his or her mailbox without providing the IP address of the POA for his
or her post office, any POA or a GroupWise name server POA can redirect the request to the POA
for the user’s post office.

A POA that is configured with both an internal IP address and a proxy IP address automatically
redirects internal users to internal IP addresses and external users to proxy IP addresses. However,
if you want to control which users are redirected to which IP addresses based on other criteria than
user location, you can configure a post office with one POA to always redirect users to internal IP
addresses and a second POA to always redirect users to proxy IP addresses. Users are then
redirected based on which POA IP address they provide in the GroupWise Startup dialog box when
they start the GroupWise client to access their mailboxes.

1 Configure the initial POA for the post office with the IP address that you want for internal
users. For instructions, see “Using Client/Server Access to the Post Office’ on page 447.

Do not fill in the Proxy Server Address field on the Network Address page of the POA object.

2 Create a second POA object in the post office and give it a unique name, such as POA PRX.
For instructions, see “Creating a POA Object in eDirectory” on page 438.

3 Configure this second POA with a proxy IP address. For instructions, see “Securing Client/
Server Access through a Proxy Server” on page 456.

Do not fill in the TCP/IP Address field on the Network Address page of the POA object.
4 Create a startup file for the new instance of the POA.
4a Use the /name switch to specify the name of the POA object that you created in Step 2.

4b Use the /ip switch to specify the IP address of the server where this instance of the POA
runs.

4c¢c Use the /port switch to specify the client/server port that this instance of the POA listens
on.

This information needs to be specified in the POA startup file because this information is
not specified in ConsoleOne for this instance of the POA.

5 Start the new instance of the POA.

6 Give users that you want to be redirected to internal IP addresses the [P address you used in
Step 1.

7 Give users that you want to be redirected to proxy IP addresses the IP address you used in
Step 3.

Enhancing Post Office Security with SSL Connections to the POA

Secure Sockets Layer (SSL) ensures secure communication between the POA and other programs
by encrypting the complete communication flow between the programs. For background
information about SSL and how to set it up on your system, seeChapter 80, “Encryption and
Certificates,” on page 1039.

To configure the POA to use SSL:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.
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Properties of POA

GroupWise v | NDSRights = | Other | Rightsto Files and Folders |
Metwork Address

TCF/IP Address |1?2156.18

Proxy Server Address: |

IPXIGPY Address: |

Fort SsL

Message Transfer: Wi‘ lm
HTTP [7181 3] [Disabled =]
Local Intranet ClientServer, Iﬁﬂ lm
Internet Proxy Client/Server: I—Dil lm

SEL Port

I s [

IMAP: [1as 3] [Disabled = 993 3]
CAP [1028 3] [Disabled =
Page Options... cancel | appy | Hew |

3 To use SSL connections between the POA and GroupWise clients located inside your firewall,
select Enabled in the Local Intranet Client/Server SSL drop-down list to let the GroupWise
client determine whether an SSL connection or non-SSL connection is used. (Non-SSL
connections are still protected by native GroupWise encryption.)

or

Select Required in the Local Intranet Client/Server SSL drop-down list if you want the POA
to force SSL connections, so that non-SSL connections are denied.

IMPORTANT: Clients older than GroupWise 6.5 cannot connect to the POA if SSL is required.

4 To use SSL connections between the POA and GroupWise clients located outside your
firewall (for example, across the Internet), select Enabled in the Internet Client/Server SSL
drop-down list to let the GroupWise client determine whether an SSL connection or non-SSL
connection is used. (Non-SSL connections are still protected by native GroupWise

encryption.)

or

Select Required in the Internet Client/Server SSL drop-down list if you want the POA to force

SSL connections, so that non-SSL connections are denied.

IMPORTANT: Clients older than GroupWise 6.5 cannot connect to the POA if SSL is required.

5 To use SSL connections between the POA and IMAP clients, select Enabled in the IMAP SSL
drop-down list to let the IMAP client determine whether an SSL. connection or non-SSL

connection is used.

or

Select Required in the IMAP SSL drop-down list if you want the POA to force SSL
connections, so that non-SSL connections from IMAP clients are denied.

6 To use SSL connections between the POA and its MTA, select Enabled in the Message

Transfer SSL drop-down list.

The POA must use a TCP/IP link with the MTA in order to enable SSL for the connection.
See “Using TCP/IP Links between the Post Office and the Domain” on page 443.
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The MTA must also have SSL enabled for the connection to be secure. See “Enhancing
Domain Security with SSL Connections to the MTA” on page 589. If the MTA does not have
SSL enabled, the POA falls back to native GroupWise encryption.

7 To use SSL connections between the POA and the POA Web console displayed in your Web
browser, select Enabled in the HTTP SSL drop-down list.

To set up the POA Web console, see “Setting Up the POA Web Console” on page 489.
8 Click Apply to save the settings on the Network Address page.
9 Click GroupWise > SSL Settings to display the SSL Settings page.

Propetties of POA x|
{GroupWise ~ | NOS Rights ~ | Other | Rights o Files and Folders |
155 Settingss ..

Cerficate file: [ Js=|
S5L key ile [ |
Set Password

Page Options... o | cancer | s | pew |

For background information about certificate files and SSL key files, see Chapter 80,
“Encryption and Certificates,” on page 1039.

By default, the POA looks for the certificate file and SSL key file in the same directory where
the POA executable is located, unless you provide a full pathname.

10 In the Certificate File field, browse to and select the public certificate file provided to you by
your CA.

11 In the SSL Key File field:
11a Browse to and select your private key file.
11b Click Set Password.
11c¢ Provide the password that was used to encrypt the private key file when it was created.
11d Click Set Password.
12 Click OK to save the SSL settings.

ConsoleOne then notifies the POA to restart and access the certificate and key files.

Corresponding Startup Switches
You could also use the /certfile, /keyfile, /keypassword, /httpssl, /msgtranssl, /imapssl, and /
imapsslport switches in the POA startup file to configure the POA to use SSL.

POA Web Console
You can view SSL information for the POA on the Status and Configuration pages. In addition,
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when you list the client/server users that are accessing the post office, SSL information is
displayed for each user.

Providing LDAP Authentication for GroupWise Users

By default, GroupWise client users’ passwords are stored in eDirectory and the POA authenticates
users to their GroupWise mailboxes through eDirectory. For background information about
passwords, see Chapter 79, “GroupWise Passwords,” on page 1033.

By enabling LDAP authentication for the POA, users’ password information can be retrieved from
any network directory that supports LDAP. For background information about LDAP, see
“Authenticating to GroupWise with Passwords Stored in an LDAP Directory” on page 1047.

When you enable LDAP authentication, it is important to provide fast, reliable access to the LDAP
directory because GroupWise client users cannot access their mailboxes until they have
authenticated. The following sections provide instructions for configuring the POA to make the
most efficient use of the LDAP servers available on your system:

¢ “Providing LDAP Server Configuration Information” on page 461
¢ “Enabling LDAP Authentication for a Post Office” on page 462

+ “Configuring a Pool of LDAP Servers” on page 464

* “Specifying Failover LDAP Servers (Non-SSL Only)” on page 465

Providing LDAP Server Configuration Information

Information about your available LDAP servers must be provided in ConsoleOne before you can
enable LDAP authentication for users.

1 In ConsoleOne, click Tools > GroupWise System Operations > LDAP Servers to display the
Configure LDAP Servers dialog box.

8 Configure LDAP Servers

LDAP Servers Close

Add
Edft

Delete

difdd,

Help

2 Click Add to add an LDAP server and provide configuration information about it.

¥ add LDAP Server E x|

Mame I

Description:

[ Use S5L

SEL ey file |

LDAF Server Address |

L s |

User Authentication Method IBInd

Select Post Offices |
(636 I gamcell Help |
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3 In the Name field, type the name by which you want the LDAP server to be known in your
GroupWise system.

4 In the Description field, provide additional information about the LDAP server as needed.

5 Ifthe LDAP server requires an SSL connection, select Use SSL, then browse to and select the
SSL key file, as provided by the LDAP server.

For additional instructions about using SSL connections, see the following resources:

¢ Authentication and Security (http://www.novell.com/documentation/edir873/edir873/
data/agtxhz5.html#agtxhz5)

¢ Enabling LDAP Authentication with GroupWise (http://support.novell.com/cgi-bin/
search/searchtid.cgi?/10067375.htm)

6 Click the pencil icon for the LDAP Server Address field.

@ Edit LDAP Server Address x|

TCPIIP Address

@ IP Address 1. . I

€ DNE Host Name: |

LDAP Port: 3849
I gancell Help |

7 Select IP Address, then specify the IP address, in dotted decimal format, of the LDAP server.
or
Select DNS Host Name, then provide the DNS hostname of the LDAP server.
The default LDAP port is 389 for non-SSL connections and 636 for SSL connections.
8 If the default port number is already in use, specify a unique LDAP port number.
9 Click OK to save the LDAP server address and port information.
10 In the User Authentication Method field, select Bind or Compare.

For a comparison of these methods, see “Authenticating to GroupWise with Passwords Stored
in an LDAP Directory” on page 1047.

11 Click OK to save the configuration information for the LDAP server.

12 Repeat Step 2 through Step 11 for each LDAP server that you want to make available to
GroupWise for LDAP authentication.

Providing configuration information for multiple LDAP servers creates a pool of LDAP
servers, which provides fault tolerance and load balancing to ensure fast, reliable mailbox
access for GroupWise users.

13 Continue with “Enabling LDAP Authentication for a Post Office” on page 462

Corresponding Startup Switches
You could also use the /ldapipaddr, /ldapport, /Idapuserauthmethod, /ldapssl, and /Idapsslkey
startup switches in the POA startup file to provide the LDAP server information.

Enabling LDAP Authentication for a Post Office

To configure the POA to perform LDAP authentication for the users in a post office:
1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties.
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2 Click GroupWise > Security to display the Security page.

Properties of Development EI

GroupWise v | Memberships v | MDS Rights | Ciher | Rights to Files and Folders |
Security

Security Level:
 Low

* High
High Security Options
[ eDirectary Authentication
LA
LDAP User Mame: | ﬂ

LOAP Password: Set Password

[ Disahle LDAP Password Changing

Inactive Connection Timeaout; 30 ﬁ seconds
LDAP Pool Senver Reset Timeaout: ] ﬁ minutes

Select Servers |

fiory

Page Options... Ok I Cancel Apply Help

3 For Security Level, select High.
4 In the High Security Options box, select LDAP Authentication.

5 If you want the POA to access the LDAP server with specific rights to the LDAP directory,
specify a username that has those rights.

If you are using a Novell LDAP server, you can browse for an eDirectory User object. The
information returned from eDirectory uses the following format:

cn=username,ou=orgunit,o=organization

If you are using another LDAP server, you must type the information in the format used by
that LDAP server.

If the LDAP username for the POA requires a password, click Set Password, type the
password twice for verification, then click Set Password.

For more information about LDAP usernames, see “Authenticating to GroupWise with
Passwords Stored in an LDAP Directory” on page 1047.

6 If you want to prevent GroupWise users from changing their LDAP passwords by using the
Password dialog box in the GroupWise client, select Disable LDAP Password Changing.

This option is deselected by default, so that if users change their passwords in the GroupWise
client through the Security Options dialog box (GroupWise Windows client > Tools menu >
Options > Security) or on the Passwords page (GroupWise WebAccess client > Options >
Password), their LDAP passwords are changed to match the new passwords provided in the
GroupWise client.

7 If the LDAP server is configured for bind connections, as described in “Providing LDAP
Server Configuration Information” on page 461, specify the number of seconds the POA
should maintain an inactive connection to the LDAP server.

The default is 30 seconds.

8 If you have only one LDAP server, click OK to save the security settings for the post office.
You have provided all the necessary information to provide LDAP authentication for users in
the post office.
or
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If you have multiple LDAP servers and want to configure them into an LDAP server pool,
click Apply, then continue with “Configuring a Pool of LDAP Servers” on page 464.

or

If you have multiple LDAP servers and want to configure them for failover, click OK to save
the security settings for the post office, then continue with “Specifying Failover LDAP
Servers (Non-SSL Only)” on page 465

Corresponding Startup Switches
You could also use the /ldapuser, /ldappwd, /Idapdisablepwdchg, and /ldaptimeout startup
switches in the POA startup file to configure POA access to the LDAP server.

POA Web Console

You can see if LDAP is enabled on the Configuration page. Under the General Settings heading,
click LDAP Authentication to view LDAP settings and change some of them for the current POA
session.

Configuring a Pool of LDAP Servers

464

You can configure the POA to contact a different LDAP server each time it needs to access the
LDAP directory. This provides load balancing and fault tolerance because each LDAP server in
the pool is contacted equally often by the POA. The LDAP server pool can include as many as five
servers.

1 Make sure you have enabled LDAP Authentication as described in “Enabling LDAP
Authentication for a Post Office” on page 462.

2 Inthe LDAP Pool Server Reset Timeout field, specify the number of minutes the POA should
wait before trying to contact an LDAP server in the pool that failed to respond to the previous
contact.

The default is 5 minutes.

3 Click Select Servers to define the specific pool of LDAP servers that you want to be available
to users in this post office for LDAP authentication.

i Select LDAP Servers x|

Selected Servers Available Servers
Netniare LDAP Server
WWindows 2000 LDAP Server

Close | Help

4 Seclect one or more LDAP servers in the Available Servers list, then click the arrow button to
move them into the Selected Servers list.

5 Click OK to save the list of LDAP servers.
6 Click OK to save the security settings for the post office.
ConsoleOne then notifies the POA to restart so the new LDAP settings can be put into effect.
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Corresponding Startup Switches

You could also use the /Idapippooln and /Idappoolresettime startup switches in the POA startup
file to configure the LDAP server pool and the timeout interval. If you choose to configure the
LDAP server pool in the startup file rather than in ConsoleOne, additional switches must be
provided to complete the configuration (/ldapportpooln, /Idapsslpoolrn, and /ldapsslkeypooln.
Configuring the pool in ConsoleOne is the recommended approach.

If you previously set up LDAP authentication on the post office Security page in ConsoleOne and
then you add the pooling startup switches to the POA startup file, the pooling switches override
any LDAP information provided in ConsoleOne.

Specifying Failover LDAP Servers (Non-SSL Only)

If the POA does not need to use an SSL connection to your LDAP servers, you can use the /
Idapipaddr switch to list multiple LDAP servers. Then, if the primary LDAP server fails to
respond, the POA tries the next LDAP server in the list, and so on until it is able to access the
LDAP directory. This provides failover LDAP servers for the primary LDAP server but does not
provide load balancing, because the primary LDAP server is always contacted first.

1 Make sure you have provided the basic LDAP information on the post office Security page in
ConsoleOne, as described in “Enabling LDAP Authentication for a Post Office” on page 462.

2 Edit the POA startup file with an ASCII text editor.
For information about the POA startup file, see “Starting the POA” on page 431.

3 Use the /ldapipaddr startup switch to list addresses for multiple LDAP servers. Use a space
between addresses.

For example:
/Idapipaddr-123.45.67.89 135.246.7.8 987.65.43.21

IMPORTANT: Do not include any LDAP servers that require an SSL connection. There is currently no
way to specify multiple SSL key files unless you are using pooled LDAP servers, as described in
“Configuring a Pool of LDAP Servers” on page 464.

4 Save the POA startup file, then exit the text editor.
5 Stop the POA, then start the POA so that it reads the updated startup file.

Enabling Intruder Detection

You can configure the POA to detect system break-in attempts in the form of repeated unsuccessful
logins. This feature can be especially helpful when allowing Remote client users to establish
client/server connections to MTAs in your system. See “Enabling Live Remote” on page 589.

1 In ConsoleOne, browse to and right-click the Post Office object, then click Properties.
2 Click GroupWise > Client Access Settings to display the Client Access Settings page.
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Properties of Development EI

Group + | Memberships + | MDS Rights v | Other | Rights to Files and Folders
Cliert Access Seftings
Lock Qut Older GroupWise Clients
[ Minimum Client Release Yersion ok IE.D
[~ Minimum Client Release Date |
[~ Disahle Loging
¥ En: i
Incarrect Lagins Allowed [ 3 ew
Incorrect Login Reset Time [ a0 2] minutes 1560y
Lackaut Resst Time: [ a0 2] minutes 54
Page Options... 0K I Cancel Apply Help

3 Select Enable Intruder Detection.

4 Specify how many unsuccessful login attempts are allowed before the user is locked out.
The default is 5: valid values range from 3 to 10.

5 Specify in minutes how long unsuccessful login attempts are counted.
The default is 15; valid values range from 15 to 60.

6 Specify in minutes how long the user login is disabled.
The default is 30; the minimum setting is 15.

7 Click OK to save the intruder detection settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

If a user gets locked out by intruder detection, his or her GroupWise account is disabled. To restore
access for the user in ConsoleOne, right-click the User object, click GroupWise > Account, then
deselect Disable Logins. At restore access for the user at the POA Web console, click
Configuration > Intruder Detection, then clear the lockout.

Corresponding Startup Switches

You could also use the /intruderlockout, /incorrectloginattempts, /attemptsresetinterval, and /
lockoutresetinterval startup switches in the POA startup file to configure the POA for intruder
detection.

POA Web Console
You can view current intruder detection settings on the Configuration page and change them using
the Intruder Detection link.

Configuring Trusted Application Support

For background information about setting up trusted applications in ConsoleOne, see “Trusted
Applications” on page 62.
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Configuring Post Office Maintenance
You can configure the POA to manage databases and disk space in the post office on a regular
basis:
¢ “Scheduling Database Maintenance” on page 467
* “Scheduling Disk Space Management” on page 469
+ “Performing Nightly User Upkeep” on page 472

Scheduling Database Maintenance

By default, the POA performs one recurring database maintenance event. At 12:00 a.m. each
Friday, the POA performs a structural check of all user, message, and document databases in the
post office. You can modify this default database maintenance event, or create additional database
maintenance events for the POA to perform on a regular basis.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Scheduled Events to display the Scheduled Events page.

Propetties of PDA x|

i +i| NDs Riohts + | cther | Rights to Files and Folders
| Scheduled Events §

Scheduled events used by this agent:
[¥l Default POA Disk Check Event
[#| Default POA MailbowLibrary Maintenance Event

Create | | |

Pane Options... | Cance\l | Help |

The Scheduled Events page lists a pool of POA events available to all POAs in your
GroupWise system.

3 To modify the default database maintenance event, which would affect all POAs that have this
database maintenance event enabled, select Default POA Mailbox/Library Maintenance
Event, then click Edit.

or

To create a new database maintenance event, which will be added to the pool of POA events
that can be enabled for any POA in your GroupWise system, click Create, then type a name
for the new database maintenance event. Select Mailbox/Library Maintenance in the Type
field.

NOTE: If the Create button is dimmed and you have a View button rather than an Edit button, you are
connected to a secondary domain in a GroupWise system where Restrict System Operations to Primary
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Domain has been selected under System Preferences. For more information, see “System Preferences”

on page 44.
| Edit Scheduled Event x|
Mame |DefaunF'0A MailbosdLibrary Maintenance Evenf
Type: IMaiIbU:dLibranf Maintenance j
Trigger
& Wieekday Weekday: IFrlday :I
i Daily
 Interal Time: [12:00 am

Actions

[v Default POA MailbowLibrary Maintenance Actions

Create
_&n |
[ ]

Ol I Cancel |

Help |

4 In the Trigger box, specify when you want the database maintenance event to take place.

You can have the database maintenance event take place once a week, once a day, or at any
other regular interval, at whatever time you choose.

Below the Trigger box is listed the pool of POA database maintenance actions that are
available for inclusion in all POA database maintenance events in your GroupWise system.

5 To modify the default database maintenance action, select Default POA Mailbox/Library
Maintenance Actions, then click Edit.

or

To create a new database maintenance action, click Create, then type a name for the new
database maintenance action.

Database maintenance actions and options you could schedule include:

Actions Options on Actions
Analyze/Fix Databases Databases
Structure User
Index check Message
Contents Document
Collect statistics .
. Logging
Fix problems Log file

Reset user disk space totals

Analyze/Fix Library

Verify library

Fix document/version/element
Verify document files

Validate security

Synchronize username
Reassign orphaned documents
Reset word lists

Verbose log level

Results mailed to
Administrator
Individual users

Exclude
Selected users

Notification
Action status
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For more detailed descriptions of the above actions, click Help in the Scheduled Event
Actions dialog box. See also Chapter 27, “Maintaining User/Resource and Message
Databases,” on page 353 and Chapter 28, “Maintaining Library Databases and Documents,”
on page 359.

6 Sclect and configure the database maintenance action to perform for the database maintenance
event.

7 Click OK three times to close the various scheduled event dialog boxes and save the modified
database maintenance event.

ConsoleOne then notifies the POA to restart so the new or modified database maintenance
event can be put into effect.

POA Web Console
You can see what database maintenance events the POA is scheduled to perform at the bottom of
the Configuration page.

Scheduling Disk Space Management

By default, the POA performs one recurring disk space management event. Every 5 minutes, the
POA checks to make sure there is at least 100 MB of free disk space in the post office directory.
If there is ever less than 100 MB of free disk space, the POA performs a Reduce operation on the
user and message databases in the post office. You can modify this default disk space management
event, or create additional disk space management events for the POA to perform on a regular
basis.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Maintenance to display the POA Maintenance page.

Properties of POA ﬁl

{GroupWise || NDS Rights v | Other | Rightsto Files and Foiders |

[v Enable Automatic Database Recovery

Maintenance Handler Threads: 4 ﬁ

[¥ Petform User Upkeep

Start User Upkeep 1 ﬁ’ hours after midnight

[ Generate Address Book for Remote

Start Address Book Generation: 0 i’ hours after midnight

Disk Check Interval 5 i’ minutes
Disk Check Delay: 2 ﬁ hours
Page Options... | Cancel | | Help |

3 To change the interval at which the selected POA checks for free disk space in its post office,
adjust the number of minutes in the Disk Check Interval field as needed.

The default is 5 minutes, which could be much too frequent if plenty of disk space is readily
available.
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When a disk space problem is encountered, the time interval no longer applies until after the
situation has been corrected. Instead, the POA continually checks available disk space to
determine if it can restart message threads that have been suspended because of the low disk
space condition.

4 To change the amount of time the POA allows to pass before notifying the administrator again
of an already reported problem condition, adjust the number of hours in the Disk Check Delay
field as needed.

The default is 2 hours.
5 Client Apply to save the maintenance settings.

6 Click GroupWise > Scheduled Events to display the Scheduled Events page.

Propetties of POA x|

{GroupWise  + | NDS Rights ~ | Other | Rights to Files and Folders

Scheduled events used by this agent:
[ Default POA Disk Check Event
[ Default POA MailboxLibrary Maintenance Event

Create | Edit | Delete |

Page Options Loje | Cancel | fatalal | Help |

The Scheduled Events page lists a pool of POA events available to all POAs in your
GroupWise system.

7 To modify the default disk space management event, which would affect all POAs that have
this disk space management event enabled, select Default POA Disk Check Event, then click
Edit.

or

To create a new disk space management event, which will be added to the pool of POA events
that can be enabled for any POA in your GroupWise system, click Create, then type a name
for the new disk space management event. Select Disk Check in the Type field.

NOTE: If the Create button is dimmed and you have a View button rather than an Edit button, you are
connected to a secondary domain in a GroupWise system where Restrict System Operations to Primary
Domain has been selected under System Preferences. For more information, see “System Preferences”
on page 44.
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10

11

¢ Edit Scheduled Event [X]

MName IDefaullPOA Disk Check Event
Event Type [Disk check |
[ Trigger

i~ Percent Trigger actions at: I 100 i’ MB

i+ MB Stop rmail processing at I—Dﬂ MBE

Action:

[ Default POA Disk Gheck Actions Create
Edit
Leleie

Qs I Qancell Help |

In the Trigger box, select Percent or MB to determine whether you want the amount of
available disk space measured by percentage or by megabytes.

In the Trigger Actions At field, specify the minimum amount of available disk space you want
to have in the post office. When the minimum amount is reached, the Disk Check actions are
triggered

In the Stop Mail Processing At field, specify the minimum amount of available disk space at
which you want the POA to stop receiving and processing messages.

Below the Trigger box is listed the pool of disk space management actions that are available
for inclusion in all POA disk space management events in your GroupWise system.

To modify the action that the default disk space management event includes, select Default
POA Disk Check Actions, then click Edit.

or

To create a new disk space management action, click Create, then type a name for the new
disk space management action.

Disk space management actions and options you could schedule include:
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Actions Options on Actions

Reduce/Expire Messages Databases
Reduce only User
Expire and reduce Message
- Items older than Document
- Downloaded items older than .

Logging
- ltems larger than Log file

- Trash older than

i Verbose log level
- Reduce mailbox to

- Reduce mailbox to limited size Results
Include Administrator
- Received items Individual users
- Sent item§ Misc
- Calendar items Support options
- Only backed-up items

Exclude

Archive/Delete Documents Selected users

Delete Activity Logs

For more detailed descriptions of the above actions, click Help in the Scheduled Event
Actions dialog box. See also Chapter 30, “Managing Database Disk Space,” on page 367.

12 Select and configure the disk space management action to perform.

13 Click OK twice to close the scheduled event dialog boxes and save the modified disk space
management event.

ConsoleOne then notifies the POA to restart so the new or modified disk space management
event can be put into effect.

You might want to create several disk space management events with different triggers and actions.
For example, at 250 MB, you could mail a warning to the administrator; at 200 MB, you could
have the POA perform a Reduce Only; at 150 MB, you could have the POA perform an Expire and
Reduce.

For some specific suggestions on implementing disk space management, see “Managing Disk
Space Usage in the Post Office” on page 171.

POA Web Console
You can view the currently scheduled disk check events on the Scheduled Events page.

Performing Nightly User Upkeep

To keep GroupWise users’ mailboxes and calendars up to date, the following activities must be
performed each day:

+ Delete expired items from users’ mailboxes
* Empty expired items from the Trash

+ Synchronize each user’s Frequent Contacts Address Book with the system Address Book

*

Advance uncompleted tasks to the next day

*

Generate a current copy of the system Address Book for Remote and Caching users
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The first two activities used to be performed by the GroupWise client, but to minimize user wait
time, the client no longer deletes expired items. The last two activities can still be performed by
the GroupWise client when needed, but the required processing might cause users to wait. You can
configure the POA to take care of these user upkeep activities once a day, at a convenient time.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Maintenance to display the POA Maintenance page.

Propetties of PDA x|

{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |
i Maintenance

[¥ Enable Automatic Database Recovety

Maintenance Handler Threads: 4 ﬂ

[v Perform User Upkeep

Start User Upkeep 1 ﬂ hours after midnight

[v Generate Address Book for Rermote

Start Address Book Generation: 0 ﬁ’ hours after midnight

Disk Check Interral g ﬁ’ minutes
Disk Check Delay: 2 ﬁ’ hours
Page Options... Cancel Help

3 Seclect Perform User Upkeep.

4 In the Start User Upkeep field, specify the number of hours after midnight for the POA to start
performing user upkeep.

The default is 1 hour.
5 If you have Remote or Caching users, select Generate Address Book for Remote.

6 Specify the number of hours after midnight for the POA to generate the daily copy of the
system Address Book for Remote and Caching users.

The default is 0 hours (that is, at midnight).

If you want to generate the system Address Book for download more often than once a day,
you can delete the existing wprof50.db file from the \wpcsout\ofs subdirectory of the post
office. A new downloadable system Address Book will be automatically generated for users
in the post office.

7 Click OK to save the new nightly user maintenance settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches

You could also configure nightly user upkeep using startup switches in the POA startup file. By
default, nightly user upkeep is enabled. Use the /nuuoffset and /rdaboffset switches to specify the
start times.

POA Web Console
You can view the current user upkeep schedule on the Scheduled Events page.
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Monitoring the POA

By monitoring the POA, you can determine whether or not its current configuration is meeting the

needs of the post office it services. You have a variety of tools to help you monitor the operation
of the POA:

+ “Using the POA Agent Console” on page 475

+ “Using the POA Web Console” on page 489

+ “Using POA Log Files” on page 497

+ “Using GroupWise Monitor” on page 498

+ “Using NetWare 6.5 Remote Manager” on page 498

¢ “Using SNMP Monitoring Programs” on page 499

+ “Notifying the GroupWise Administrator” on page 503

¢ “Using the POA Error Message Documentation” on page 504
+ “Employing POA Troubleshooting Techniques” on page 504

+ “Using Platform-Specific POA Monitoring Tools” on page 505

Using the POA Agent Console

The following topics help you monitor and control the POA from the POA agent console:
¢ “Monitoring the POA from the POA Agent Console” on page 475
+ “Controlling the POA from the POA Agent Console” on page 479

Monitoring the POA from the POA Agent Console

The POA agent console provides information, status, and message statistics about the POA to help
you assess its current functioning.

#% ACCOUNTING PROVO? - GroupWise PDA M=
File Configuration Log  Statistics  Actions  Help
ACCOUNTING. PROVO2 Up Time: 0 Days 2 Hrz 9 Mins
GroupWwise Post Office Agent
-~ Stahu Statistics
Piocessing / Busy: 0 :0 C/5 Reguests: 2 Message Files: 0
User Connections: 1] Requests Pending: 0 Undeliverable: 0
File: QueLes: a Users Timed Qw0 Problem Messages: 0

T116:3311E  Database check action: Analyze/Fisup ;I
11:16:3311E  Level of database analysis and verification: Structural

1116:3311E  Delete temporary/backup files older than [davs] 7

111633 11E

11:16:33 157 Initishizing dispatcher

11:16:33 158 Initizlizing dizpatcher

11:16:33 154 Initializing worker

11:16:33 158 Initializing worker

11:16:33 15L Initializing worker

11:16:33 18D |nitializing warker
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Linux Note: You must use the --show startup switch in order to display the Linux POA agent
console. See “Starting the Linux POA” on page 433

Windows Note: You can suppress the Windows POA agent console by running the POA as a
service. See “Starting the Windows POA” on page 434.

The POA agent console consists of several components:
+ “POA Information Box” on page 476
+ “POA Status Box” on page 476
* “POA Statistics Box™ on page 477
* “POA Log Message Box” on page 478
¢ “POA Admin Thread Status Box™ on page 478

Do not exit the POA agent console unless you want to stop the POA.

NetWare Note: Ata NetWare® server console, you can use Alt+Esc to change screens. In a remote
console window, you can use Alt+F1 to select a screen to view. You can use these keystrokes to
display the POA agent console if it is not immediately visible on the NetWare console.

Linux Note: On a Linux server, you can minimize the POA agent console, but do not close it unless
you want to stop the POA.

Windows Note: On a Windows server, you can minimize the POA agent console, but do not close
it unless you want to stop the POA.

POA Information Box

POA Status Box

The POA Information box identifies the POA whose POA agent console you are viewing, which
is especially helpful when multiple POAs are running on the same server.

PostOffice.Domain: Displays the name of the post office serviced by this POA, and what domain
it is linked to.

Description: Displays the description provided in the Description field in the POA Identification
page in ConsoleOne. When you run multiple POAs on the same server, the description should
uniquely identify each one. If multiple administrators work at the server where the POA runs, the
description could include a note about who to contact before stopping the POA.

Up Time: Displays the length of time the POA has been running.

POA Web Console
The Status page also displays this information.

The POA Status box displays the current status of the POA and its backlog. The information
displayed varies depending on whether the POA is processing client/server connections, message
files, both, or neither.

Processing: Displays a rotating bar when the POA is running. If the bar is not rotating, the POA
has stopped. For assistance, see “Post Office Agent Problems” in GroupWise 6.5 Troubleshooting
2: Solutions to Common Problems.

Busy: Displays the number of POA threads currently in use (busy) for client/server connections,
message files, or both, depending on POA configuration. You can change the total number of
threads available. See “Adjusting the Number of Connections for Client/Server Processing” on
page 508 and “Adjusting the Number of POA Threads for Message File Processing” on page 512.
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POA Statistics Box

User Connections (for client/server processing): Displays the number of active application
("virtual") TCP/IP connections between the POA and the GroupWise® clients run by GroupWise
users. You can change the maximum number of user connections. See “Adjusting the Number of
Connections for Client/Server Processing” on page 508.

Physical Connections (for client/server processing): Displays the number of active physical
TCP/IP connections between the post office and the GroupWise clients run by GroupWise users.
You can change the maximum number of physical connections. See “Adjusting the Number of
Connections for Client/Server Processing” on page 508.

Priority Queues (for message file processing): Displays the number of messages waiting in the
high priority message queues. You can control the number of threads processing message files. See
“Adjusting the Number of POA Threads for Message File Processing” on page 512.

Normal Queues (for message file processing): Displays the number of messages waiting in the
normal priority message queues. You can control the number of threads processing message files.
See “Adjusting the Number of POA Threads for Message File Processing” on page 512.

File Queues (for message file processing): Displays the total number of messages waiting in all
message queues, when client/server information and message file information are displayed
together.

The number of messages displayed as waiting in message queues is not an exact count. For
example, if the POA detects numerous messages to process in the priority 4 queue (normal
messages), it does not scan and count messages in lower priority queues. Therefore, actual counts
of message files waiting in queues could be higher than the counts displayed in the Status box.

For information about the various message queues in the post office, see “Post Office Directory”
in GroupWise 6.5 Troubleshooting 3: Message Flow and Directory Structure.

POA Web Console
The Status page also displays the status information listed above. In addition, you can display
detailed information about specific queue contents.

The POA Statistics box displays statistics showing the current workload of the POA. The
information displayed varies depending on whether the POA is processing client/server
connections, message files, both, or neither.

C/S Requests (for client/server processing): Displays the number of active client/server requests
between GroupWise clients and the POA.

Requests Pending (for client/server processing): Displays the number of client/server requests
from GroupWise clients the POA has not yet been able to respond to. If the number is large, see
“POA Statistics Box Shows Requests Pending” in “Post Office Agent Problems” in Group Wise 6.5
Troubleshooting 2. Solutions to Common Problems.

Users Timed Out (for client/server processing): Displays the number of GroupWise clients no
longer communicating with the POA. If the number is large, see “POA Statistics Box Shows Users
Timed Out” in “Post Office Agent Problems” in GroupWise 6.5 Troubleshooting 2: Solutions to
Common Problems.

Message Files (for message file processing): Displays the total number of messages processed
by the POA. This includes user messages, status messages, and service requests processed by the
POA.
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Undeliverable (for message file processing): Displays the number of messages that could not be
delivered because the user was not found in that post office or because of other similar problems.
Senders of undeliverable messages are notified. For assistance, see “Message Has Undeliverable
Status” in “Strategies for Message Delivery Problems” in GroupWise 6.5 Troubleshooting 2:
Solutions to Common Problems.

Problem Messages (for message file processing): Displays the number of invalid message files
that have problems not related to user error. It also displays requests the POA cannot process
because of error conditions. For assistance, see “Message Is Dropped in the problem Directory” in
“Strategies for Message Delivery Problems” in GroupWise 6.5 Troubleshooting 2: Solutions to
Common Problems.

Users Delivered: Displays the number of user messages delivered to recipients in the post office.
A message with six recipients in the local post office is counted six times.

Statuses: Displays the number of status messages delivered to recipients in the post office.
Rules Executed: Displays the number of users’ rules executed by the POA.

POA Web Console
The Status page also displays this information. In addition, you can display detailed information
about client/server connections and message file processing.

POA Log Message Box

The POA Log Message box displays the same information that is being written to the POA log file.
The amount of information displayed in the POA Log Message box depends on the current log
settings for the POA. See “Using POA Log Files” on page 497. The information scrolls up
automatically.

Windows Note: To stop the automatic scrolling, click Log, then deselect Auto Scroll.You can then
use the scroll bar to browse through the contents of the log message box.

POA Web Console
You can view and search POA log files on the Log Files page.

Informational Messages

When you first start the POA, you typically see informational messages that list current agent
settings, current number of threads, TCP/IP options (client/server), and scheduled events. As the
POA runs, it continues to provide status and delivery information in the POA Log Message box.

Error Messages

If the POA encounters a problem processing a message, it displays an error message in the POA
Log Message box. See “Post Office Agent Error Messages” in Group Wise 6.5 Troubleshooting 1:
Error Messages.

POA Admin Thread Status Box

The POA admin thread updates the post office database (wphost.db) when users and/or user
information are added, modified, or removed, and repairs it when damage is detected.

To display the POA Admin Thread Status box from the POA agent console, click
Configuration > Admin Status.
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The following tasks pertain specifically to the POA admin thread:

*

*

*

“Suspending/Resuming the POA Admin Thread” on page 481
“Displaying POA Admin Thread Status” on page 484
“Recovering the Post Office Database Automatically or Immediately” on page 485

POA Web Console
You can display POA admin thread status on the Configuration page. Under the General Settings
heading, click Admin Task Processing. You can also change the admin settings for the current POA
session.

Controlling the POA from the POA Agent Console

You can perform the following tasks to monitor and control the POA from the POA agent console
at the server where the POA is running:

*

*

*

*

“Stopping the POA” on page 480

“Suspending/Resuming the POA Admin Thread” on page 481
“Displaying the POA Software Date” on page 481

“Displaying Current POA Settings” on page 481

“Displaying Detailed Statistics about POA Functioning” on page 482
“Displaying Client/Server Information” on page 482

“Listing Message Queue Activity” on page 483

“Displaying Message Transfer Status” on page 483

“Restarting the MTP Thread” on page 484

“Displaying POA Admin Thread Status” on page 484

“Recovering the Post Office Database Automatically or Immediately”” on page 485
“Recovering User and Message Databases Automatically” on page 486
“Updating QuickFinder Indexes” on page 486

“Compressing QuickFinder Indexes” on page 487

“Browsing the Current POA Log File” on page 487
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Stopping the POA

“Viewing a Selected POA Log File” on page 488
“Cycling the POA Log File” on page 488
“Adjusting POA Log Settings” on page 488
“Editing the POA Startup File” on page 489
“Accessing Online Help for the POA” on page 489

You might need to stop and restart the POA for the following reasons:

*

*

*

*

Updating the agent software
Troubleshooting message flow problems
Backing up GroupWise databases
Rebuilding GroupWise databases

To stop the POA from the POA agent console:

1

Click File > Exit > Yes.

NetWare Note: Use Exit (F7). If the POA does not respond to Exit, you can use the unload
command to stop the POA. However, this would stop all instances of the POA running on the
server.

Linux Note: If the Linux POA does not respond to Exit, you can kill the POA process, as
described below, but include the -9 option.

Windows Note: If the Windows POA does not respond to Exit, you can close the POA agent
console to stop the POA or use the Task Manager to terminate the POA task.

2 Restart the POA. See “Starting the POA” on page 431.

To stop the POA on Linux when it is running in the background as a daemon:

1

Make sure you are logged in as root.

2 [fyou started the Linux POA using the grpwise script:

2a Change to the /etc/init.d directory.
2b Enter the following command:
./grpwise stop

2c¢ Skip to Step 4

3 If you started the Linux POA manually (not using the grpwise script):

3a Determine the process IDs (PIDs) of the POA:
ps -eaf | grep gwpoa
The PIDs for all gwpoa processes are listed.

You can also obtain this information from the Environment page of the POA Web
console.

3b Kill the first POA process listed:

Syntax:
kill PID
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Example:
kill 1483

It might take a few seconds for all POA processes to terminate.

4 Use the ps command to verify that the POA has stopped.

ps -eaf | grep gwpoa

Suspending/Resuming the POA Admin Thread

You can cause the POA to stop accessing the post office database (wphost.db) without stopping
the POA completely. For example, you could suspend the POA admin thread while backing up the
post office database.

To suspend the POA admin thread:
1 At the POA agent console, click Configuration > Admin Status.
2 Click Suspend.
NetWare Note: Use Options (F10) > Admin Status > Suspend.
The POA admin thread no longer accesses the post office database until you resume processing.
To resume the POA admin thread:
1 At the POA agent console, click Configuration > Admin Status.
2 Click Resume.
NetWare Note: Use Options (F10) > Admin Status > Resume.

POA Web Console
You can suspend and resume the POA admin thread from the Configuration page. Under the
General Settings heading, click Admin Task Processing > Suspend or Resume > Submit.

Displaying the POA Software Date

It is important to keep the POA software up-to-date. You can display the date of the POA software
from the POA agent console.

1 At the server where the POA is running, display the POA agent console.
2 Click Help > About POA.

NetWare Note: To check the date of the POA NetWare®, you must list the gwpoa.nlm file in the
agent installation directory (typically, in the sys:\system directory) or use the modules
gwpoa .nlm command at the server console prompt.

POA Web Console
You also check the POA software date on the Environment page.

Displaying Current POA Settings

You can list the current configuration settings of the POA at the POA agent console.
1 At the server where the POA is running, display the POA agent console.
2 Click Configuration > Agent Settings.
The configuration information displays in the log message box and is written to the log file.

NetWare Note: Use Show Configuration (F4) > Show Configuration.
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If information you need scrolls out of the log message box, you can scroll back to it. See
“Browsing the Current POA Log File” on page 487.

For information about POA configuration settings, see Chapter 37, “Configuring the POA,” on
page 437 and Chapter 40, “Using POA Startup Switches,” on page 523.

POA Web Console
You check the current POA settings on the Configuration page.

Displaying Detailed Statistics about POA Functioning

The POA agent console displays essential information about the functioning of the POA. More
detailed information is also available.

1 At the server where the POA is running, display the POA agent console.
2 Click Statistics > Misc. Statistics.
NetWare Note: This feature is not available in the NetWare POA.

3 Review the Detailed Statistics dialog box. The following statistics are displayed and written
to the log file for the current POA up time:

¢ Databases rebuilt

¢ Users deleted

¢ Users moved

¢+ Moved messages processed

¢ Statuses processed

POA Web Console
You can display statistics on the Status page.

Displaying Client/Server Information

When the POA and the GroupWise clients communicate in client/server mode, you can display
statistics to indicate the performance level of the TCP/IP communication.

1 At the server where the POA is running, display the POA agent console.
2 Click Statistics > Client/Server.

NetWare Note: Use Configuration (F4) > Display Client/Server Information.
3 Click the type of statistics to display.

The selected type of statistics for the current POA up time are listed in the message log box
and are written to the POA log file.

If information you need scrolls out of the log message box, you can scroll back to it. See
“Browsing the Current POA Log File” on page 487.

All Statistics: Lists the information for General Statistics, Throughput, Physical Connections,
and Application Connections, as described below.

General Statistics: Lists the DNS address and IP address of the server, along with the TCP
port for the POA, the number of messages received, sent, and aborted, and the number of
physical and application connections active and allowed.

Show Throughput: Lists the total number of messages processed by the POA for all users.
Statistics are provided for the current elapsed time and as a per second average.
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Clear Throughput: Resets the current elapsed time to zero.

Physical Connections: Lists the currently active physical connections. Physical connections
are active TCP connections created whenever GroupWise users do something that requires
communication and closed when the specific activities have been completed. By listing the
physical connections, you can see what users are actively using GroupWise and how much
throughput each user is generating. Users’ IP addresses are also listed.

Application Connections: Lists the currently active application connections. Every user that
starts GroupWise has an application connection for as long as GroupWise is running, even if
GroupWise is not actively in use at the moment. By listing the application connections, you

can see what users have started GroupWise and how much throughput each user is generating.
Users’ IP addresses are also listed.

Show Redirection List: Lists all POAs in your GroupWise system and indicates whether
each is configured for TCP/IP. The list includes the IP address of each POA and the IP address
of its proxy server outside the firewall, if applicable. This redirection information is obtained
from the post office database (wphost.db).

Check Redirection List: Attempts to contact each POA in your GroupWise system and
reports the results. If a POA is listed as "Connection Failed," see “Post Office Agent
Problems” in GroupWise 6.5 Troubleshooting 2: Solutions to Common Problems.

POA Web Console
You can display client/server information on the Configuration page. You can list client/server
users from the Status page using the C/S Users and Remote/Caching Users links.

Listing Message Queue Activity

The POA uses eight queues to process message files. You can view the activity in each of these
queues. For more information about message queues, see ‘“Post Office Directory” in Group Wise
6.5 Troubleshooting 3. Message Flow and Directory Structure.

1 At the server where the POA is running, display the POA agent console.
2 Click Actions > View MF Queues.
NetWare Note: Use Options (F10) > Actions > View MF Queues.

3 View the queue activity in the message log box. Use the scroll bar if necessary to scroll
through the information.

If information you need scrolls out of the log message box, you can scroll back to it. See
“Browsing the Current POA Log File” on page 487.

The information is also written to the POA log file.

You can check queue activity on the Status page. Under the Thread Status heading, click the type
of thread to view queue activity for.

Displaying Message Transfer Status

When the POA links to the MTA by way of TCP/IP, you can view the status of the TCP/IP link
from the POA agent console.

1 At the server where the POA is running, display the POA agent console.
2 Click Configuration > Message Transfer Status.
NetWare Note: Use Options (F10) > Message Transfer Status.
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3 View the following information about the TCP/IP link:

Outbound TCP/IP Address: Displays the TCP/IP address and port where the MTA listens
for messages from the POA.

Inbound TCP/IP Address: Displays the TCP/IP address and port where the POA listens for
messages from the MTA.

Hold Directory: Displays the path to the directory where the POA stores messages if the
TCP/IP link to the MTA is closed.

Current Status: Lists the current status of the TCP/IP link.

¢ Open: The POA and the MTA are successfully communicating by way of TCP/IP.

¢ Closed: The POA is unable to contact the MTA by way of TCP/IP

¢ Unavailable: The POA is not yet configured for TCP/IP communication with the MTA.
¢ Unknown: The POA is unable to contact the MTA in any way.

Messages Written: Displays the number of messages the POA has sent.

Message Read: Displays the number of messages the POA has received.

Last Closure Reason: Provides an explanation for why the post office was last closed. For
assistance resolving closure reasons, see “Post Office Agent Error Messages” in Group Wise
6.5 Troubleshooting 1: Error Messages.

POA Web Console
You can display message transfer status on the MTP Status page.

Restarting the MTP Thread

When the POA links to the MTA by way of TCP/IP, you can restart the Message Transfer Protocol
(MTP) thread that provides the link between the POA and the MTA.

1 At the server where the POA is running, display the POA agent console.
2 Click Actions > Restart MTP.
NetWare Note: Use Options (F10) > Actions > Restart MTP.

POA Web Console

You can restart the MTA thread from the Configuration page. Click Message Transfer Protocol >
Restart MTP > Submit. In addition, you can control the send and receive threads separately on the
MTP Status page. In the Send or Receive column, click the current status > Stop/Start MTP Send/
Receive > Submit.

Displaying POA Admin Thread Status

484

Status information for the POA admin thread is displayed in a separate dialog box, rather than on
the main POA agent console.

1 At the server where the POA is running, display the POA agent console.
2 Click Configuration > Admin Status.
NetWare Note: Use Options (F10) > Admin Status.

The following admin status information is displayed:
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Admin Message Box
The Admin Message box provides the following information about the workload of the POA
admin thread:

Completed: Number of administrative message successfully processed.
Errors: Number of administrative messages not processed because of errors.
In Queue: Number of administrative messages waiting in the queue to be processed.

Send Admin Mail: Select this options to send a message to the administrator whenever a
critical error occurs. See “Notifying the GroupWise Administrator” on page 503.

Admin Database Box

The Admin Database box provides the following information about the post office database
(wphost.db):

Status: Displays one of the following statuses:
¢ Normal: The POA admin thread is able to access the post office database normally.
¢ Recovering: The POA admin thread is recovering the post office database.

¢ DB Error: The POA admin thread has detected a critical database error. The post office
database cannot be recovered. Rebuild the post office database in ConsoleOne. See
“Rebuilding Domain or Post Office Databases™ on page 349.

The POA admin thread does not process any more administrative messages until the
database status has returned to Normal.

¢  Unknown: The POA admin thread cannot determine the status of the post office
database. Exit the POA, then restart it, checking for errors on startup.

DB Sort Language: Displays the language code for the language that determines the sort
order of lists displayed in ConsoleOne and the GroupWise system Address Book.

Recovery Count: Displays the number of recoveries performed on the post office database
by this POA for the current POA session.

Admin Thread Box
The Admin Thread box displays the following information:

Status: Displays one of the following statuses:

¢ Running: The POA admin thread is active.

¢ Suspended: The POA admin thread is not processing administrative messages.
¢ Starting: The POA admin thread is initializing.

¢ Terminated: The POA admin thread is not running.

POA Web Console
You can display POA admin thread status from the Configuration page. Under the General Settings
heading, click Admin Task Processing.

Recovering the Post Office Database Automatically or Immediately
The POA admin thread can recover the post office database (wphost.db) when it detects a problem.

To enable/disable automatic post office database recovery:

1 At the server where the POA is running, display the POA agent console.
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2 Click Configuration > Admin Status > Automatic Recovery to toggle this feature on or off for
the current POA session.

NetWare Note: Use Options (F10) > Admin Status > Automatic Recovery.
To change the setting permanently, see “Configuring the POA in ConsoleOne” on page 439.

To recover the post office database immediately:
1 At the server where the POA is running, display the POA agent console.
2 Click Configuration > Admin Status > Perform DB Recovery.
NetWare Note: Use Options (F10) > Admin Status > Perform DB Recovery.

For additional database repair procedures, see Chapter 26, “Maintaining Domain and Post Office
Databases,” on page 345.

POA Web Console

You can recover the post office database from the Configuration page. Under the General Settings
heading, click Admin Task Processing. Select Automatic Recovery or Perform DB Recovery as
needed.

Recovering User and Message Databases Automatically

The POA can recover user databases (userxxx.db) and message databases (msgnn.db)
automatically when it detects a problem because databases can be open during the recover process.
This procedure is a “recover” rather than a “rebuild,” because a “rebuild” requires that all users
and agents be out of the database being rebuilt. See Chapter 27, “Maintaining User/Resource and
Message Databases,” on page 353.

To enable/disable automatic message and user database recovery:
1 At the server where the POA is running, display the POA agent console.
2 Click Actions > Auto Rebuild to toggle this feature on or off for the current POA session.
NetWare Note: Use Options (F4) > Actions > Enable Auto Rebuild.

To change the setting permanently, see “Configuring the POA in ConsoleOne” on page 439.

POA Web Console
You can see whether automatic message and user database recovery is enabled on the
Configuration page under the Performance Settings heading.

Updating QuickFinder Indexes

GroupWise uses QuickFinder® technology to index messages and documents stored in post
offices. You can start indexing from the POA agent console. For example, if you just imported a
large number of documents, you could start indexing immediately, rather than waiting for the next
scheduled indexing cycle.

To update QuickFinder indexes for the post office:
1 At the server where the POA is running, display the POA agent console.
2 Click Actions > QuickFinder > Update Indexes.
NetWare Note: Use Options (F10) > Actions > Update QuickFinder Indexes.

To avoid overloading the POA with indexing processing, a maximum of 1000 items are indexed
per database. If a very large number of messages are received regularly, or if a user with a very
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large mailbox is moved to a different post office (requiring the user’s messages to be added into
the new post office indexes), you might need to repeat this action multiple times in order to get all
messages indexed. If too many repetitions would be required to complete the indexing task, refer
to TID10063970 (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10063970.htm) for
assistance.

You can set up indexing to occur at regular intervals. See “Regulating Indexing” on page 514.

If the indexing load on the POA is heavy, you can set up a separate POA just for indexing. See
“Configuring a Dedicated Indexing POA” on page 516.

POA Web Console
You can update QuickFinder indexes from the Configuration page. Under the General Settings
heading, click QuickFinder Indexing.

Compressing QuickFinder Indexes

QuickFinder indexes are automatically compressed at midnight each night to conserve disk space.
You can start compression at any other time from the POA agent console. For example, if you just
imported and indexed a large number of documents and are running low on disk space, you could
compress the indexes immediately, rather than waiting for it to happen at midnight.

To compress QuickFinder indexes for the post office:
1 At the server where the POA is running, display the POA agent console.
2 Click Actions > QuickFinder > Compress Indexes.

NetWare Note: Use Options (F10) > Actions > Compress QuickFinder Indexes.

POA Web Console
You can compress QuickFinder indexes from the Configuration page. Under the General Settings
heading, click QuickFinder Indexing.

Browsing the Current POA Log File

In the log message box, the POA displays the same information being written to the POA log file.
The amount of information depends on the current log settings for the POA.

The information automatically scrolls up the screen as additional information is written. You can
stop the automatic scrolling so you can manually scroll back through earlier information.

To browse the current POA log file and control scrolling:
1 At the server where the POA is running, display the POA agent console.
2 Click Log > Auto Scroll to toggle automatic scrolling on or off.

NetWare Note: Use View Log File (F9).

For explanations of messages in the POA log file, see “Post Office Agent Error Messages” in
GroupWise 6.5 Troubleshooting 1: Error Messages.

See also “Using POA Log Files” on page 497.

POA Web Console
You can browse and search POA log files on the Log Files page.
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Viewing a Selected POA Log File

Reviewing log files is an important way to monitor the functioning of the POA.
1 At the server where the POA is running, display the POA agent console.
2 Click Log > View Log.
NetWare Note: Use Options (F10) > View Log Files.
The following information is provided:

Log Files: Lists the current POA log files, ordered from the oldest log file at the top to the
newest log file at the bottom. The current log file is marked with an asterisk (*).

Date/Time: Displays the date and time of each POA log file.

Space Used: Displays the amount of disk space currently occupied by that POA’s log files.
You can control the amount of space consumed by POA log files during the current POA
session. You can also control the default amount of disk space for POA log files in the POA
Log Settings page in ConsoleOne or in the POA startup file. See “Configuring POA Log
Settings and Switches” on page 497.

Log File Directory: Displays the full path of the directory where the POA writes its log files.
See “Configuring POA Log Settings and Switches” on page 497.

3 In the log file list, select the POA log file you want to view.

Windows Note: For the Windows POA, you can select the viewer to use by providing the full
path to the viewer program. The default viewer is Notepad.

4 Click View.

For explanations of messages in the POA log file, see “Post Office Agent Error Messages” in
GroupWise 6.5 Troubleshooting 1: Error Messages.

See also “Using POA Log Files” on page 497.

POA Web Console
You can view and search POA log files on the Log Files page.

Cycling the POA Log File

You can have the POA start a new log file as needed.
1 At the server where the POA is running, display the POA agent console.
2 Click Log > Cycle Log.
NetWare Note: Use Options (F10) > Cycle Log.

Adjusting POA Log Settings

488

Default log settings are established when you start the POA. However, you can adjust the POA log
settings for the current session from the POA agent console. This overrides any settings provided
in ConsoleOne or in the POA startup file. The modified settings remain in effect until you restart
the POA, at which time the log settings specified in ConsoleOne or the startup file take effect
again.

1 At the server where the POA is running, display the POA agent console.
2 Click Log > Log Settings.
NetWare Note: Use Options (F10) > Logging Options.
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3 Adjust the values as needed for the current POA session.

See “Using POA Log Files” on page 497.

POA Web Console
You can adjust POA log settings from the Configuration page. Click the Log Settings heading.

Editing the POA Startup File

You can change the configuration of the POA by editing the POA startup file from the POA agent
console.

1 At the server where the POA is running, display the POA agent console.
2 Click Configuration > Edit Startup File.

NetWare Note: Use Options (F10) > Actions > Edit Startup File.
3 Make the necessary changes, then save and exit the startup file.

4 Stop and restart the POA.

Accessing Online Help for the POA

Click Help on the menu bar for information about the POA agent console. Click the Help button
in any dialog box for additional information.

NetWare Note: Press F1 for information in any dialog box or menu.

Using the POA Web Console

The POA Web console enables you to monitor and control the POA from any location where you
have access to a Web browser and the Internet. This provides substantially more flexible access
than the POA agent console, which can only be accessed from the server where the POA is
running.

+ “Setting Up the POA Web Console” on page 489
* “Accessing the POA Web Console” on page 491
¢ “Monitoring the POA from the POA Web Console” on page 492
¢ “Controlling the POA from the POA Web Console” on page 495

Setting Up the POA Web Console

The default HTTP port for the POA Web console is established during POA installation. You can
change the port number and increase security after installation in ConsoleOne.

1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.
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Propetties of POA x|
GroupWise ~ | NDS Rights vI Cther | Rights to Files and Folders I
hetwork Address
TCP/IP Address |17218.518 =l
Proxy Server Address: | ZI
IPHSPX Address: I Z|
Part 55L S5L Port
Message Transfer: 71m il lm
HTTP [7181 3] [Disabled =]
Local Intranet ClientServer, Iﬁﬂ lm
Internet Proxy Client/Server: I—Dil lm
IMAP: [1aa 3] [Disabled =] [ 583 3
AP [1028 3] [Disabled =]
Page Options... ok | cancel | appy | pew |

If you configured the POA for TCP/IP links during installation, the TCP/IP Address field
should display the POA server’s network address. If it does not, follow the instructions in
“Using TCP/IP Links between the Post Office and the Domain” on page 443. The POA must
be configured for TCP/IP in order to provide the POA Web console.

3 Make a note of the IP address or DNS hostname in the TCP/IP Address field. You need this
information to access the POA Web console.

The HTTP Port field displays the default port number of 7181.

4 [f the default HTTP port number is already in use on the POA server, specify a unique port
number.

5 Make a note of the HTTP port number. You need this information to access the POA Web
console.

6 If you want to use an SSL connection for the POA Web console, select Enabled in the HTTP
SSL drop-down list.

For additional instructions about using SSL connections, see Chapter 80, “Encryption and
Certificates,” on page 1039.

7 Click Apply to save your changes on the Network Address page.

If you want to limit access to the POA Web console, you can provide a username and
password.

8 Click GroupWise > Agent Settings, then scroll down to HTTP Settings.
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Propetties of PDA x|

{GroupWise = || NDS Rights » | Cther | Rights to Files and Foiders |

| Agent Settings
Max Physical Connections: mﬁ =
Max App Connections: Imi’
[ Enable Caching
CPU Utilization (NLM): [ 85 2] percent
Delay Time (NLM): [ 100 2] miliseconds

Max Thread LUsage for Priming and Moves: I 20 ﬁ’ percent

[¥ Enable IMAP

Max IMAP Threads [ 50 4

[ Enable SHMP

SHMP Community " Get' String: |

HTTP Settings

HTTP User Name |

HTTF Passwird: Set Passward

Ll

Page Options... I Cancel Help

9 In the HTTP Settings box:
9a In the HTTP User Name field, specify a unique username.
9b Click Set Password.
9¢ Type the password twice for verification.
9d Click Set Password.

Unless you are using an SSL connection, do not use Novell® eDirectory™ username and
password because the information passes over the insecure connection between your Web
browser and the POA.

For convenience, use the same username and password for all agents that you plan to monitor
from GroupWise Monitor. This saves you from having to provide the username and password
information as Monitor accesses each agent.

10 Click OK to save the POA Web console settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches

You could also use the /httpport, /httpuser, /httppassword, and /httpssl startup switches in the POA
startup file to enable and secure the POA Web console. In addition, you can use the /httprefresh
switch to control how often the POA refreshes the information provided to your Web browser.

Accessing the POA Web Console

To monitor the POA from your Web browser, view the POA Web console by supplying the
network address and port number as displayed on the Network Address page in ConsoleOne. For
example:

http://172.16.5.18:1677
http://172.16.5.18:7181
http://serverl:7181
https://server2:1677
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When viewing the POA Web console, you can specify either the client/server port or the HTTP
port.

C/S Users
Remote/Caching Users
Application Connections
Fhysical Connections

AP

Priority Queues

Maormal Gueues

GWCheck Auto Queues
GWCheck Scheduled Queuss

Tatal

2
1
2
2
0
0
0
0
0

Sessions

hread Status

Total Busy
C/S Handler Threads B 0
Message Worker Threads B 1]
GWCheck Worker Threads 4 0
IMAP Threads 0 i}
Message Transfer Status Open

[Statistics

/5 Requests 3248
C/5 Requests Pending 0

Users Timed Out

AP
AP
Rules

1
Client Requests u]
Fending Reguests u]
Executed 0

Monitoring the POA from the POA Web Console

The POA Web console provides several pages of information to help you monitor the performance
of the POA. The bar at the top of the POA Web console displays the name of the POA and its post
office. Below this bar appears the POA Web console menu that lists the pages of information
available in the POA Web console. Online help throughout the POA Web console helps you
interpret the information being displayed and use the links provided.

*
*
*
*

*

Monitoring POA Status

“Monitoring POA Status” on page 492

“Checking the POA Operating System Environment” on page 493
“Viewing and Searching POA Log Files” on page 494

“Listing POA Scheduled Events” on page 494

“Checking Link Status to the MTA” on page 495

When you first access the POA Web console, the Status page is displayed. Online help on the
Status page helps you interpret the status information being displayed.
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Total

2
1
2
2
0
0
0
0
0

C/5 Users

Remote/Caching Users
Application Connections
Physical Connections

IMAP Sessions

Priority Queues

Mormal Gueues

GWCheck Auto Queues
GWCheck Scheduled Queues

Tatal Busy
C/8 Handler Threads B ]
Message Warker Threads B 1}
GWCheck YWorker Threads 4 i}
IMAP Threads 0 1}
Message Transfer Status Open

C/3 Requests 3246
C/2 Requests Pending 0
Users Timed Out

IMAP Client Reguests 0
IMAP Pending Reguests 0
Rules Executed 0

Click any hyperlinked status items for additional details. The status information is much the same
as that provided at the POA agent console, as described in “Monitoring the POA from the POA

Agent Console” on page 475.

Checking the POA Operating System Environment

On the POA Web console menu, click Environment to display information about the operating
system where the POA is running. On a NetWare server, the following information is displayed:

Servar PRY-GWDOC5E

Cornpany Novell

O3 Revision MNetWare 5.60.01
05 Date January 15, 2002
Supported Connections 1599

Connections in Use 35

Receive Buffer Max 10000 (Recommended 2500)
Module Information

GroupWYise Engine (release version)

GWWENEMA. MM

Wersion B.05

Mermory Allocated 10568

Build Date 1-16-2003
GroupWise MTA (release version)

GWWITA, ML

Wersiaon b.05

Memory Allocated 14792

Build Date 1-16-2003
GroupWise Post Office Agent (Release version)
GWPOA.MLM

“ersion B.05

Mermory Allocated 14856

Build Date 1-16-2003

Movell Standard C Runtime Library for KNLMs [optimized, 1820]
CLIB. MLM

“ersion 580 e

On a Linux server, the following information is displayed:
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hPr

Gr . )
| Log Files | Scheduled Events | MTP Status | Help

Status | Configuration | Envir

Server jbd-Inx

05 Revision Linux Release 2.4 19-4GB
Main Thread Process 1D 21065

Build Dates

GroupWyise Agent Build Date 04-23-04

GroupWyise Resource Build Date 04-30-04

On a Windows server, the following information is displayed:

0 Prowo2
Status | Configuration | Envir | Log Files | Scheduled Events | MTF Status | Help
085 Data
Windows NT (Th) Version 4.0 (Build 1381) Service Pack &
Build Dates
GroupWWise Agent Build Date 01-16-03
GroupWWise Engine Build Date 01-16-03
GroupWWise Resource Build Date 01-16-03

Viewing and Searching POA Log Files
On the POA Web console menu, click Log Files to display and search POA log files.

POA-D ent.Pro
Status | Configuration | Environment | Log Files | Scheduled Events | MTE Status | Help

View Event Log Seftings

vent Log Filter

Events containing

Eventlogs: ™ selectan

0120poa001 01-20-03 20:00112 5254
0121poa 00 01-21-03 20:4810 6100
0122poa001 01-22-03 21:4414 13140
0123poa00l 01-23-03 20:00:12 6479
0124poa 001 01-24-03 20:00:12 5254
0126poa 001 01-25-03 20:0012 5254
0126poa001 01-26-03 20:00:14 5566
* 0127poa001 01-27-0316:48:26 14380

Wiew Events

To view a particular log file, select the log file, then click View Events.

To search all log files for a particular string, type the string in the Events Containing field, select
Select All, then click View Events. You can also manually select multiple log files to search.

The results of the search are displayed on a separate page which can be printed.

Listing POA Scheduled Events

On the POA Web console menu, click Scheduled Events to view currently scheduled events and
their status information.
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G

\skCheck

ts | MTP Status | Help

Event Current Status Idle

Event next start time 012772003 16:57:40
Event schedule interal 4 ming

# of concurrent events allowed 1

QuickFinder Indexing

Event Current Status Idle

Event next start time 012772003 20:00:01
Event schedule interval 24 hour(s)

# of concurrent events allowed

1

Remote Downloadable Address Book Generation

Event Current Status Idle

Event next start time 01262003 00:00:31
Event schedule interval 1 dayis)

# of concurrent events allowed 1

Mightly User DB Upkeep (Phase 1)

Event Current Status Idle

Event next start time 01262003 01:00:01
Event schedule interval 1 dayis)

# of concurrent events allowed

1

QuickFinder indexing and remote downloadable Address Book generation can be controlled using
links from the Configuration page. The Configuration page also displays information about disk
check events and database maintenance events. However, scheduled events must be created and

modified using ConsoleOne.

Checking Link Status to the MTA

On the POA Web console menu, click MTP Status to view status information about the link
between the POA for the post office and MTA for the domain.

Status | Configuration | Environment | Log Files | Scheduled Events | MTP Status | Help

& Transf

Send Receive
Current Status Open Open
Last Closed 01-17-03 16:34:39
Last Opened 01-17-03 16:34:55 01-17-03 16:24:15

Last Closure Reason

TCPAP connection failure

137 55.47.93:7100
Inbound TCPAP 137.65.47 937101
Hold PRY-GWDOCEB sy s \yws ystermideviwpesin
Message Transfer Statistics
Written 21
Read 99

The Outbound TCP/IP link displays the MTA Web console where you can get status information
about the MTA. The Hold link displays the contents of the MTA input queue, so you can find out
if messages are waiting for processing by the MTA.

Controlling the POA from the POA Web Console

At the POA Web console, you can change some POA configuration settings for the current POA
session. You can also stop and start some specific POA threads.

¢ “Changing POA Configuration Settings” on page 496
¢ “Controlling the POA Admin Thread” on page 496
+ “Controlling the POA MTP Threads” on page 497
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Changing POA Configuration Settings

On the POA Web console menu, click Configuration. Online help on the Configuration page helps
you interpret the configuration information being displayed.

Status | Configur

| Enwironment | Log Files | Scheduled Events | MTP Status | Help

(E]
General Settings:
Post Office Directory

Post Office Access Mode

Post Office Configuration Instance:

PRY-GWWsys\gwsysternidey
Client/Server Only
PO&

Read Configuration from Database Yes
Errar Mail to Adrinistrator. Mo

IP Addresses Redirection Table: Shwe
QuickFinder Indexing: Enabled

CuickFinder Indexing Base Offset (hours from Midnight): 20 Hours O Mins (Default)
CuickFinder Indexing Interral 24 Hours 0 Mins (Default)
Sirnple Network Management Protocol (SNMP): Enabled (index 1)

Admin Task Processing Yes

Intruder Detection: Enabled
Incarrect login attempts before lockout: 3

Login Atternpt reset interval: 30 mins
Intruder lockout reset interval 30 rins
GWCheck Processing: Enabled
Metware Clustering Enabled: Mo
Running in Protected Address Space: Mo

Fost Office Security Requires Password Mo
LDAP Authentication: Disabled
Mave User (live) via TCPIP: Enabled
IMAP Agent: Enabled
IMAP Port for incoming IMAP requests: 144
IMAP Login using SS5L: Dizabled
CAP Agent: Enabled
CAP Port for incorming CAP reguests: 1026 (Default)
CAP Login using S50 Dizabled
Log Settings:

Log Level: Marrmal
Disk Logging: Enabled

Click any hyperlinked configuration items to change settings for the current agent session. The
settings that can be modified are much the same as those that can be changed at the POA agent
console, as described in “Controlling the POA from the POA Agent Console” on page 479.

Controlling the POA Admin Thread

On the Configuration page, click Admin Task Processing.

[t ent P

Status | Configuration | Envirenment | Log Files | Scheduled Events | MTP Status | Help

Admin Messages

Caompleted g3
Errors 0

In Queue 0
Send Admin Mail ~
Admin Database

Status Marmal
DB Sort Language us
Recovery Count 0
Automatic Recovery ~
Perform DB Recovery |
Admin Thread

Status Running
Suspend sl
Resurme e

Submit | Resst |

Modify the functioning of the POA admin thread as needed, then click Submit. The changes
remain in effect for the current POA session.
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Controlling the POA MTP Threads

On the Configuration page, click Message Transfer Protocol.

Elf 8.5.0POA - Development Provo 1
tatus | Configuration | Enviranment | Log Files | Scheduled Events | MTP Status | Heln

I g

Message Transfer Protocol Settings

Outhound TCR/IP

Address: IT 2345.67.89
Port: I?‘\ oo
Inbound TCR/IP

Address: IT 2345.67.89
Paort: I?T 01
Maxirnum File Transfer Send Size ID MWEB
Restart MTP ("

On this page, you can restart MTA processing between the POA and the MTA. On the MTP status
page, you can restart the send and receive threads separately.

Using POA Log Files

Error messages and other information about POA functioning are written to log files as well as
displaying on the POA agent console. Log files can provide a wealth of information for resolving
problems with POA functioning or message flow. This section covers the following subjects to
help you get the most from POA log files:

* “Configuring POA Log Settings and Switches” on page 497
+ “Viewing POA Log Files” on page 498
¢ “Interpreting POA Log File Information” on page 498

Configuring POA Log Settings and Switches

The following aspects of logging are configurable:
Log File Path (/log)
Disk Logging (/logdiskofY)

*

*

*

Logging Level (/loglevel)
+ Maximum Log File Age (/logdays)
+ Maximum Log File Size (/logmax)
You can configure the log settings in the following ways:

+ Using ConsoleOne to establish defaults (see “Adjusting the POA Logging Level and Other
Log Settings” on page 446)

¢ Using startup switches to override ConsoleOne settings (see “Using POA Startup Switches”
on page 523)

+ Using the POA agent console to override other settings for the current POA session (see
“Adjusting POA Log Settings” on page 488)

+ Using the POA Web console to override other settings for the current POA session (see
“Controlling the POA from the POA Web Console” on page 495)
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Viewing POA Log Files

You can view the contents of the POA log file from the POA agent console and Web console. See
the following tasks:

+ “Browsing the Current POA Log File” on page 487

* “Viewing a Selected POA Log File” on page 488

¢ “Cycling the POA Log File” on page 488

* “Viewing and Searching POA Log Files” on page 494

Interpreting POA Log File Information

On startup, the POA records the POA settings currently in effect. Thereafter, it logs events that
take place, including errors. To look up error messages that appear in POA log files, see “Post
Office Agent Error Messages” in GroupWise 6.5 Troubleshooting 1: Error Messages.

Because the POA consists of multiple threads, you might find it useful to retrieve the log file into
an editor and sort it on the thread ID that follows the date and time information. Sorting groups all
messages together for the same POA thread. You can also use the search capability of the POA
Web console to gather information about a specific POA thread. See “Viewing and Searching POA
Log Files” on page 494.

Using GroupWise Monitor

GroupWise Monitor is a monitoring and management tool that allows you to monitor GroupWise
agents and gateways from any location where you are connected to the Internet and have access to
a Web browser. The POA Web console can be accessed from GroupWise Monitor, enabling you
to monitor all POAs in your GroupWise system from one convenient location. In addition,
GroupWise Monitor can notify you when agent problems arise.

GroupWise, Monitor

Novell

+ % Corporate Mail [0] Monitored agents for "Corporate Mail.NetWare Agents” group
» NetWare Agents [2] Total: 2 Displayed: 1 - 2

»  Windows Agents [2
= Refresh | Select &ll | | Problem H Suspend | Fesume Options
Clear All Thresholds

Create

Mame Status Status Duration Up Time  Type
Fename
Mave [© @ Proval Hormal 10d1hd4em 10d1h29m wTA 8.5
Delets I (@ Development.Provol Mormal 10d1h29m  10d1h29m POA 6.5

Refresh
Help

For installation and setup instructions, see “Installing GroupWise Monitor” in the Group Wise 6.5
Installation Guide. For usage instructions, see “Monitor” on page 901.

Using NetWare 6.5 Remote Manager

If the POA is running on a NetWare 6.5 server, you can use the [P Address Management feature
in NetWare Remote Manager (NetWare Remote Manager > Manage Server > I[P Address
Management) to view the IP address and port configuration for the POA. This is also true for other
GroupWise agents (MTA, Internet Agent, and WebAccess Agent) running on NetWare 6.5 servers.

IMPORTANT: If the POA is running in protected mode, it does not display in NetWare Remote Manager.
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You access NetWare Remote Manager by entering the following URL in a Web browser:
http://server address:8008

For example:

http://137.65.123.11:8008

For more information about using NetWare Remote Manager, see the NetWare 6.5 documentation
(http://www.novell.com/documentation/nw65).

Using SNMP Monitoring Programs

You can monitor the POA from the Management and Monitoring component of Novell
ZENworks® for Servers, ManageWise®, or any other SNMP management and monitoring
program. When properly configured, the POA sends SNMP traps to network management
consoles for display along with other SNMP monitored programs.

Although the POA is SNMP-enabled by default, the server where the POA is installed must be
properly configured to support SNMP, and the POA object in eDirectory must be properly
configured as well. To set up SNMP services for your server, complete the following tasks:

+ “Setting Up SNMP Services for the POA” on page 499

¢ “Copying and Compiling the POA MIB File” on page 502

¢ “Customizing Your ManageWise Installation to Monitor the POA” on page 503
¢ “Configuring the POA for SNMP Monitoring” on page 503

Setting Up SNMP Services for the POA

Select the instructions for the platform where the POA runs:
+ “Setting Up SNMP Services for the NetWare POA” on page 499
* “Setting Up SNMP Services for the Linux POA” on page 500
+ “Setting Up SNMP Services for the Windows POA” on page 500

Setting Up SNMP Services for the NetWare POA

The NetWare POA supports SNMP through the SNMP services loaded on the NetWare server.
SNMP services are provided through the SNMP NLM. The SNMP NLM initiates and responds to
requests for monitoring information and generates trap messages.

If the SNMP NLM is not loaded before the NetWare POA, the POA still loads and functions
normally, but SNMP support is disabled. The POA does not attempt to auto-load snmp.nlm.

To load the SNMP NLM manually:
1 Go to the console of each NetWare server where you want to implement SNMP services.
These servers should already have the GroupWise agents installed.
2 Type the command to load the SNMP NLM:

Syntax:
load snmp v control=x monitor=y trap=z
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where v represents Verbose, meaning to display informational messages, and x, y and z are
replaced with your system SNMP community strings for SNMP SETs, GETs and TRAPs).

Example:
load snmp v control=private monitor=public trap=all

The configuration for the SNMP NLM is found in snmp.cfg and traptarg.cfg in the sys:\etc
directory. View the contents of these files for more information.

The TCP/IP NLM automatically loads snmp.nlm, using default values for the community
strings. If your system uses different community string values, load snmp.nlm before
tepip.nlm.

3 If the SNMP NLM is already loaded, you can add the control and trap parameters by typing
the following at the console prompt:

snmp control= trap=
To automatically load these commands, include them in the autoexec.ncf file.
For more information about implementing SNMP services, see your NetWare documentation.

4 Skip to “Copying and Compiling the POA MIB File” on page 502.

Setting Up SNMP Services for the Linux POA

The Linux POA is compatible with NET-SNMP. An older version of SNMP called UCD-SNMP
cannot be used with the Linux POA. NET-SNMP comes standard with the versions of Red Hat
Linux supported for GroupWise 6.5 for Linux, but it does not come standard with the supported
versions of SUSE Linux. If you are using SUSE Linux, you must update to NET-SNMP in order
to use SNMP to monitor the Linux POA.

1 Make sure you are logged in as root.

2 [f NET-SNMP is not already set up on your Linux server, use the following command to
configure SNMP:

snmpconf -g basic setup

The snmpconf command creates the snmpd.conf file in one of the following directories,
depending on your version of Linux:

/ust/share/snmp
/ust/local/share/snmp
~/.snmp

3 Locate the snmpd.conf file on your Linux server.

4 In a text editor, open the snmpd.conf file and add the following line:
dlmod Gwsnmp /opt/novell/gw/agents/lib/libgwsnmp.so

8§ Save the snmpd.conf file and exit the text editor.

6 Restart the SNMP daemon (snmpd) to put the changes into effect.

7 Skip to “Copying and Compiling the POA MIB File” on page 502.

Setting Up SNMP Services for the Windows POA

SNMP support is provided for up to eight Windows POAs on the same Windows server. Upon
startup, each instance of the POA is dynamically assigned a row in its SNMP table. View the
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contents of the POA MIB for a description of the SNMP variables in the table. See “Copying and
Compiling the POA MIB File” on page 502 for more information about MIB files.

To set up SNMP services for the Windows POA, complete the following tasks:
¢ “Installing Windows SNMP Support” on page 501
¢ “Installing GroupWise Agent SNMP Support” on page 501

Installing Windows SNMP Support

For Windows, the SNMP service is usually not included during the initial operating system
installation. The SNMP service can be easily added at any time. To add or configure the SNMP
service, you must be logged in as a member of the Administrator group.

To add the SNMP service to a Windows NT server:
1 From the Control Panel, double-click Network.
2 Click Services > Add > select SNMP Service.
3 Follow the on-screen prompts. You need your original Windows NT media.

You are given the opportunity to configure the SNMP service. The only required information
for GroupWise is the Trap Destination and Community Name.

4 After the installation is complete, reboot the server.

For more information about configuring the SNMP service, see your Windows NT
documentation.

To add the SNMP service to a Windows 2000 server:
1 From the Control Panel, double-click Add/Remove Programs.
2 Click Add/Remove Windows Components.
3 Select Management and Monitoring Tools.

4 Click Details, then select Simple Network Management Protocol.

Continue with “Installing GroupWise Agent SNMP Support” on page 501.

Installing GroupWise Agent SNMP Support

The GroupWise Agent Installation program includes an option for installing SNMP support.
However, if the server where you installed the agents did not yet have SNMP set up, that
installation option was not available. Now that you have set up SNMP, you can install GroupWise
agent SNMP support.

At the Windows server where you want to install the GroupWise agent SNMP support:

1 Run setup.exe at the root of the GroupWise 6.5 Administrator CD. Click Install Products >
GroupWise Agents > Install GroupWise Agents.

or

Run install.exe from the agents subdirectory on the GroupWise 6.5 Administrator CD or in
your software distribution directory if you have updated it with the latest GroupWise software.

2 In the Installation Path dialog box, browse to and select the path where the agent software is
installed, then select Install and Configure SNMP for GroupWise Agents.

3 To shorten the install time, deselect Install GroupWise Agent Software.
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4 Continue through the rest of the installation process as prompted by the Agent Installation
program.

The Agent Installation program copies the SNMP support files to the agent installation
directory, makes the appropriate Windows registry entries, and restarts the Windows SNMP
service.

8 Continue with “Copying and Compiling the POA MIB File” on page 502.

Copying and Compiling the POA MIB File

An SNMP-enabled POA returns information contained in a Management Information Base (MIB).
The MIB is an ASCII data structure that defines the information gathered. It also defines the
properties that can be monitored and managed on the SNMP-enabled POA.

Before you can monitor an SNMP-enabled POA, you must compile the gwpoa.mib file using your
SNMP management program. For NetWare or Windows, the GroupWise MIBs are located on the
GroupWise 6.5 Administrator CD in the \agents\snmp directory or in the
software_distribution_directory\agents\snmp directory if you have updated it with the latest
GroupWise software. For Linux, the GroupWise MIBs are located on the GroupWise 6.5 for Linux
Administrator CD in the /agents/snmp directory.

1 Copy the gwpoa.mib file to the location required by your SNMP management program.

For example, ManageWise users would copy the gwpoa.mib file to the
\mw\nms\snmpmibs\current directory. ZENworks Server Management users can access the
gwpoa.mib file in the software distribution directory.

2 Compile or import the gwpoa.mib file as required by your SNMP management program.
For example, to compile the gwpoa.mib file for ZENworks Server Management:
2a In ConsoleOne, right-click the Site Server object, then click Properties > MIB Pool.
2b Click Modify Pool > Add.
2c¢ Browse to and select the gwpoa.mib file, then click OK.
2d Click Compile.

2e Make sure that the server where the POA is running is configured to send SNMP traps to
the ZENworks Server Management Site Server.

¢ On a NetWare server, add the IP address or hostname of the ZENworks Server
Management Site Server to the traptarg.cfg file in the sys:\etc directory.

¢ On a Windows server, add the IP address or hostname of the ZENworks Server
Management Site Server to the list of trap destinations.

From the Windows NT Control Panel, double-click Network; or, from the Windows
2000 Control Panel, double-click Administrative Tools. Then click Services >
SNMP Service > Properties > Traps.

Refer to your SNMP management program documentation for specific instructions.

3 If you are using Novell ManageWise, continue with “Customizing Your ManageWise
Installation to Monitor the POA” on page 503.

or

If you are not using ManageWise, skip to “Configuring the POA for SNMP Monitoring” on
page 503.
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Customizing Your ManageWise Installation to Monitor the POA

The GroupWise agent installation includes files that help ManageWise monitor the GroupWise
agents more effectively.

+ “GroupWise MIB Files” on page 503
* “GroupWise Agent Alarm Help File” on page 503

These capabilities are available only with ManageWise, not with ZENworks Server Management.

GroupWise MIB Files

The GroupWise MIB files include the standard SNMP management information. In addition, the
files include annotations that enhance the Alert functions of ManageWise.

For example, the Summary provides more detailed information than the Description does in other
SNMP management programs. The ManageWise annotations are embedded in comments;
therefore, they have no affect on other SNMP management programs.

GroupWise Agent Alarm Help File

When GroupWise alarms appear in ManageWise, you can double-click the alarm to display the
alarm information contained in the Agent Alarm help file. To enable this feature, copy the
gwalarm.hlp file from the \agents\snmp directory to the \mw\nms\help directory on your
ManageWise station. This help file explains the alarms each agent might produce by giving a
description, cause, and action for each alarm.

Configuring the POA for SNMP Monitoring

In order for SNMP monitoring programs to monitor the POA, the POA must be configured with a
network address and SNMP community string.

1 Browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Network Address to display the Network Address page.

3 Click the pencil icon to provide the TCP/IP address or IPX™/SPX™ address of the server
where the POA runs, then click Apply.

4 Click GroupWise > Agent Settings page, then scroll to the bottom of the settings list.
5 Provide your system SNMP community GET string, then click OK.
ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

The POA should now be visible to your SNMP monitoring program.

Notifying the GroupWise Administrator

If you want to be notified with an e-mail message whenever POAs encounter critical errors, you
can designate yourself as an administrator of the domain where the post offices are located.

1 In ConsoleOne, browse to and right-click the Domain object, then click Properties to display
the Identification page.
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Properties of Provol x|

{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |

: Ientification
Dramain: Praval
Description
UMNC Path: I\\PRV—GV\I’\SYS\gwsystem\pmvm\ il
Language [Engiish- us =]
Darmain Type Primary
Time Zone [(@MT-07:00) Mountain Time (US & Canada) =
Database Yersion: 4}
Metwork Type: [Moven netware =]
Administrator. I "rE:l
Page Options... ok | cancel | appy | pew |

2 [n the Administrator field, browse to and select your GroupWise user ID.

A domain can have a single administrator, or you can create a group of users to function as

administrators.

3 Click OK to save the administrator information.

The selected user or group then begins receiving e-mail messages whenever POAs servicing
post offices in the domain encounter critical errors.

Corresponding Startup Switches
By default, the POA generates error mail if an administrator has been assigned for the domain.
Error mail can be turned off using the /noerrormail switch in the POA startup file.

POA Web Console

Another way to receive e-mail notification of POA problems is to use GroupWise Monitor to
access the POA Web console. See “Configuring E-Mail Notification” on page 918.

Using the POA Error Message Documentation

POA error messages are documented with the source and explanation of the error, possible causes
of the error, and actions to take to resolve the error. See “Post Office Agent Error Messages” in
GroupWise 6.5 Troubleshooting 1: Error Messages.

Employing POA Troubleshooting Techniques

If you are having a problem with the POA but not receiving a specific error message, or if the
suggested actions for the specific error did not resolve the problem, you can review more general
troubleshooting strategies for dealing with POA problems. See “Strategies for Agent Problems” in
GroupWise 6.5 Troubleshooting 2: Solutions to Common Problems.
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Using Platform-Specific POA Monitoring Tools

Each operating system where the GroupWise POA runs provides tools for monitoring programs.
+ “NetWare Monitoring Tools” on page 505
¢ “Linux Monitoring Tools” on page 505

+ “Windows Monitoring Tools” on page 505

NetWare Monitoring Tools

If you are running the POA on NetWare servers, you can use the NetWare Monitor NLM to
monitor the effects of the POA on the NetWare server. NetWare 6.x provides monitoring tools that
you can use from your Web browser. Processor, resource, and memory utilization can be compared
to other non-GroupWise NLM programs to determine if the POA NLM program is monopolizing
resources. See your NetWare documentation for additional monitoring suggestions.

Linux Monitoring Tools

If you are running the POA on Linux servers, you can use SNMP tools like snmpget and snmpwalk
that allow you to retrieve the data about all the services registered with the SNMP service. These
tools are part of the NET-SNMP package. See your Linux documentation for additional
monitoring suggestions.

Windows Monitoring Tools

If you are running the POA on Windows servers, you can use the Performance Monitor in
Windows Administrator Tools to gather similar information. See your Windows documentation
for additional monitoring suggestions.
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Optimizing the POA

You can adjust how the POA functions to optimize its performance. Before attempting
optimization, you should run the POA long enough to observe its efficiency and its impact on other
network applications running on the same server. See Chapter 38, “Monitoring the POA,” on
page 475.

Also, remember that optimizing your network hardware and operating system can make a
difference in POA performance.

The following topics help you optimize the POA:
¢ “Optimizing Client/Server Processing” on page 507
¢ “Optimizing Message File Processing” on page 511
¢ “Optimizing Indexing” on page 514
* “Optimizing Database Maintenance” on page 517

* “Optimizing CPU Utilization for the NetWare POA” on page 520

Optimizing Client/Server Processing

If you run only one POA for the post office, you can adjust the number of POA threads and
connections for client/server processing. If client/server processing needs are extremely heavy for
a post office, you can set up a dedicated client/server POA to meet those needs.

* “Adjusting the Number of POA Threads for Client/Server Processing” on page 507
¢ “Adjusting the Number of Connections for Client/Server Processing” on page 508

* “Configuring a Dedicated Client/Server POA” on page 510

Adjusting the Number of POA Threads for Client/Server Processing

If the POA is configured with client/server processing enabled, it starts TCP handler threads to

respond to current client/server requests, up to the number of threads specified by the TCP Handler
Threads option. To respond to occasional heavy loads, the POA can increase the number of TCP
handler threads above the specified amount if CPU utilization is below the threshold established
by the CPU Utilization setting. When the POA rereads its configuration information, the number
of TCP handler threads drops back within the configured limit. You can determine how often this
happens by checking the Client/Server Pending Requests History page at the POA Web console.

If the POA is frequently not keeping up with the client/server requests from GroupWise® client
users, you can increase the maximum number of TCP handler threads so the POA run create
additional threads regularly. The default is 6 TCP handler threads; valid values range from 1 to 99.

If GroupWise client users cannot connect to the POA immediately or if response is sluggish, you
can increase the number of threads.
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1 In ConsoleOne®, browse to and right-click the POA object, then click Properties.

2 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA x|
{GroupWise || NDS Rights v | Other | Rightsto Files and Foiders |
Message File Processing: |AII ;I
Message Handler Threads: [ &g
[¥ Enable TCPIP (for GlientiSerer)
TCP Handler Threads: I—Eﬁi
Max Physical Connections: Wﬁi
Max App Connections: Imﬁ’
[ Enable Caching
CPU Utilizatian (WLM): [ 85 2] percent
Delay Time (NLM): [ 100 2] miliseconds
Max Thread LUsage for Priming and Moves: I—Qﬂﬁi percent -
[¥ Enable IMAP
Max IMAP Threads [ g
[ Enable CAP
Max CAP Threads: [ |
Page Options... I Cancel | | Help |

3 Increase the number in the TCP Handler Threads field to increase the maximum number of
threads the POA can create for client/server processing.

The optimum number of threads for a POA is affected by many factors, including available
system resources, number of users in Caching mode, number of users priming Caching

mailboxes, and so on.

Plan on at least one TCP handler thread per 20-30 client/server users. Or, you can increase the
number of TCP handler threads in increments of three to five threads until acceptable
throughput is reached. Another approach would be to set the value high initially and then
monitor thread usage with the C/S Handler Threads link on the Status page of the POA Web
console. If some of the threads always have a count of 0 (zero), meaning they are never used,
you can decrease the number of TCP handler threads accordingly.

4 Click OK to save the new thread setting.

ConsoleOne then notifies the POA to restart so the new thread setting can be put into effect.

Corresponding Startup Switches

You could also use the /tcpthreads switch in the POA startup file to adjust the number of POA

threads.

POA Web Console

The Status page helps you assess whether the POA is currently meeting the client/server needs of
the post office. Under the Thread Status heading, click C/S Handler Threads to display the
workload and status of the client/server handler threads.

You can change the number of client/server handler threads on the Configuration page. Under
Performance Settings, click Client/Server Processing Threads.

Adjusting the Number of Connections for Client/Server Processing

Connections are the number of “sockets” through which client/server requests are communicated
from the GroupWise client to the POA.
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+ Application connections: Each GroupWise user uses one application connection when he or
she starts GroupWise. Depending on what activities the user is doing in the GroupWise client,
additional application connections are used. For example, the GroupWise Address Book and
GroupWise Notify use individual application connections. The default maximum number of
application connections is 2048. You should plan about 3 to 4 application connections per
user, so the default is appropriate for a post office of about 500 users.

Physical connections: Each GroupWise user could have zero or multiple active physical
connections. One physical connection can accommodate multiple application connections.
Inactive physical connections periodically time out and are then closed by the clients and the
POA. The default maximum number of physical connections is 1024. You should plan about
1 to 2 physical connections per user, so the default is appropriate for a post office of about 500

users.

If the POA is configured with too few connections to accommodate the number of users in the post
office, the POA can encounter an error condition such as “GWPOA: Application connection table

full”.

1 In ConsoleOne®, browse to and right-click the POA object, then click Properties.

2 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA

{GroupWise ~ i| NDS Rights ~ | Other | Rights to Files anel Foklers |

| Agert Seftings.

Message File Processing:
Message Handler Threads:

[ Enable TCPIP {for ClientServer)
TCP Handler Threads:

Max Physical Connections:

Max App Connections:

[¥ Enable Caching

CPL Ltilization (MLM):

Delay Time (NLM):

Max Thread Usage for Priming and Moves:
[ Enable IMAP

hlax IMAP Threads

[¥ Enable CAP

hax CAP Threads:

Jen
—
_—
[
[
-
-
—
—

[ =4

percent
milliseconds

percent

Page Options

[ ok 1]

cancel | | Hem

3 Increase the number in the Max Physical Connections field to increase the amount of TCP/IP
traffic the POA can accommodate.

4 Increase the number in the Max App Connections field to increase the number of activities the
attached users can perform concurrently.

5 Click OK to save the new connection settings.

ConsoleOne then notifies the POA to restart so the new connection settings can be put into

effect.

Corresponding Startup Switches

You could also use the /maxappconns and /maxphysconns switches in the POA startup file to
adjust the POA client/server processing.
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POA Web Console

The Status page helps you assess whether the POA is currently meeting the client/server needs of
the post office. Under the Statistics heading, click C/S Requests Pending. You can also manually
select multiple log files to search in order to display a history of times during the last 24 hours
when the POA was unable to respond immediately to client/server requests.

Configuring a Dedicated Client/Server POA

When GroupWise users access the post office in client/server mode, the responsiveness of the
GroupWise client depends entirely on the ability of the POA to handle the load placed upon it by
the users. When you configure a dedicated client/server POA, GroupWise client users do not
compete with other POA activities.

Because many POA functions are disabled when a POA is dedicated to client/server processing,
you must run at least one other POA for the post office to take care of the POA functions that the
dedicated client/server POA is not performing. This additional POA could be a multipurpose POA,
or you could configure additional POAs dedicated to specific types of processing.

To configure a dedicated client/server POA:

1 Create a new POA object for the post office as described in “Creating a POA Object in
eDirectory” on page 438.

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA ﬁl
GroupWise | MNDS Rights + I Cther I Rights to Files and Folders I
Agert Settings
=
Message File Processing: |Oﬁ ;I
Message Handler Threads: [ &g
[¥ Enable TCPIP (for GlientiSerer)
TGP Handler Threads: [ 3
Max Physical Connections: IW?’
Max App Connections: Imﬁi
[¥ Enable Caching
CPU Utilization (MLM): I—eaﬁ percent
Delay Time (NLM: mﬁ milliseconds
Max Thread Usage for Priming and Moves: I—Quﬁ percent
[¥ Enable IMAP .
Max IMAP Threads [ a3
[¥ Enable SMMP
SHMP Community " Get" String: | _.I
Page Options... Ok I Cancel | Apply | Help |

4 Make sure Enable TCP/IP (for Client/Server) is selected.

5 Increase the number in the TCP Handler Threads field as needed to increase the maximum
number of threads the POA can create.

The optimum number of threads for a POA is affected by many factors, including available
system resources, number of users in Caching mode, number of users priming Caching
mailboxes, and so on.

Plan on at least one TCP handler thread per 20-30 client/server users. Or, you can increase the
number of TCP handler threads in increments of three to five threads until acceptable
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12
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throughput is reached. Another approach would be to set the value high initially and then
monitor thread usage with the C/S Handler Threads link on the Status page of the POA Web
console. If some of the threads always have a count of 0 (zero), meaning they are never used,
you can decrease the number of TCP handler threads accordingly.

Increase the number in the Max Physical Connections field as needed to increase the amount
of TCP/IP traffic the POA can accommodate.

Plan on one to two physical connections per user in the post office.

Increase the number in the Max App Connections field as needed to increase the number of
activities the attached users can perform concurrently.

Plan on three to four application connections per user in the post office.

Set Message File Processing to Off. Make sure another POA handles message file processing.
Click Apply to save the updated information on the Agent Settings page.

Click GroupWise > QuickFinder.

Deselect Enable QuickFinder Indexing, then click Apply. Make sure another POA handles
indexing.

Click GroupWise > Maintenance.

Deselect Enable Automatic Database Recovery. Make sure another POA handles database
recovery.

To turn off all POA admin thread activity, add the /noada switch to the POA startup file for
this dedicated client/server POA.

Set Maintenance Handler Threads to 0 (zero). Make sure another POA handles database
maintenance and disk space management.

Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure
another POA handles these tasks.

Click OK to save the new settings for dedicated client/server processing.

Install the POA software on a different server from where the original POA for the post office
is already running. See “Installing GroupWise Agents” in the GroupWise 6.5 Installation
Guide.

Add the /name switch to the POA startup file and specify the name designated when you
created the new POA object. Also add the /name switch to the startup file for the original
POA.

Start the dedicated client/server POA. See “Starting the POA” on page 431.

Corresponding Startup Switches

You could also use the /nomf, /noqf, /norecover, /nogwchk, /monuu, and /nordab switches in the
POA startup file to disable non-client/server processing, then use the /tcpthreads, /maxappconns,
and /maxphysconns switches to adjust the POA client/server processing.

Optimizing Message File Processing

If you run only one POA for the post office, you can adjust the number of POA threads for message
file processing. If message file processing needs are extremely heavy for a post office, you can set
up a dedicated message file processing POA to meet those needs.

*

“Adjusting the Number of POA Threads for Message File Processing” on page 512
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+ “Configuring a Dedicated Message File Processing POA” on page 513

Adjusting the Number of POA Threads for Message File Processing

If the POA is configured for message file processing, it starts the number of threads specified by
the Message Handler Threads option. Message handler threads deliver messages to users’
mailboxes. The default number of message handler threads is 8; valid values range from 1 to 30.

The more message threads the POA uses, the faster it can process messages. However, the more
threads the POA uses, the fewer resources are available to other processes running on the server.

To adjust the number of POA message handler threads:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA il
1| NDs Rights + I Cther I Rights to Files and Folders I
1=
Message File Processing: |AII ;I
Message Handler Threads: I—aﬁ
[¥| Enahble TCRIIF (far ClientiServer)
TCF Handler Threads: [ &g
Max Physical Connections: mﬁ
Max App Connections: Imﬁ
[ Enable Caching
CPU Utilization (NLM): [ a5 2] percent
Delay Time (MLM): [ 1002 mitiseconds
Max Thread Usage for Priming and hMoves: I—Euﬁ percent =
[ Enable IMAP
Max IMAF Threads [ oz
[ Enable CAP
Max CAP Threads: [ a3 o
Pane Options... I Cancel | | Help |

3 Increase the number in the Message Handler Threads field.

For example, you could increase the number of threads in increments of three to five threads
until acceptable throughput is reached. The optimum number of threads for a POA 1is affected
by many factors, including available system resources.

4 Click OK to save the new thread setting.

ConsoleOne then notifies the POA to restart so the new setting can be put into effect.

Corresponding Startup Switches
You could also use the /threads switch in the POA startup file to adjust the number of message
handler threads.

POA Web Console

The Status page helps you assess whether the POA is currently meeting the message file
processing needs of the post office. Under the Thread Status heading, click Message File
Processing Threads to display the workload and status of the message handler threads.

You can change the number of message handler threads on the Configuration page. Under
Performance Settings, click Message File Processing Threads.
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Configuring a Dedicated Message File Processing POA

If client/server processing is being handled by a dedicated client/server POA, you can set up one
or more other POAs to handle other POA functions such as message file processing.

1

10
11

Create a new POA object for the post office as described in “Creating a POA Object in
eDirectory” on page 438.

Right-click the new POA object, then click Properties.
Click GroupWise > Agent Settings to display the Agent Settings page.

Properties of POA |
GroupWise - | NDS Rights + I Cther I Rights to Files and Folders I
Agert Settings
=
Message File Processing: |AII ;I
Message Handler Threads: I—auﬁ
[ Enable TCRIP (for ClientiSerer)
TCP Handler Threads: [ 3
Max Physical Conneclions: Wﬂ
Max App Connections: Imﬁ’
[ Enable Caching
CPU Utilization (MLM): I—%ﬁ percent
Delay Time (MM mﬁ milliseconds
Max Thread Usage for Priming and Moves: l—zmﬁ percent
I Eable -
Max IMAF Threads [ ag
[¥ Enable SNMP
SHMP Cormmunity " Get" String: | _.I
Pane Options... 0K I Cancel | Apply | Help |

Set Message File Processing to the desired level for this message file processing POA.
If you are using just one message file processing POA, set Message File Processing to All.

For additional load balancing, you could set up two message file processing POAs, one with
Message File Processing set to High to handle Busy Searches and requests from Remote client
users promptly, and a second with Message File Processing set to Low to handle regular
message delivery in the post office.

Increase the number in the Message Handler Threads field as needed.

You can configure as many as 30 message handler threads. The optimum number is affected
by many factors, including available system resources.

Deselect Enable TCP/IP (for Client/Server). Make sure another POA handles client/server
processing.

Click Apply to save the updated information on the Agent Settings page.
Click GroupWise > QuickFinder.

Deselect Enable QuickFinder Indexing, then click Apply. Make sure another POA handles
indexing.

Click GroupWise > Maintenance.

Deselect Enable Automatic Database Recovery. Make sure another POA handles database
recovery.
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To turn off all POA admin thread activity, add the /noada switch to the POA startup file for
this dedicated message file processing POA.

12 Set Maintenance Handler Threads to 0 (zero). Make sure another POA handles database
maintenance and disk space management.

13 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure
another POA handles these tasks.

14 Click OK to save the new settings for dedicated message file processing.

15 Install the POA software on a different server from where the original POA for the post office
is already running. See “Installing GroupWise Agents” in the GroupWise 6.5 Installation
Guide.

16 Add the /name switch to the POA startup file and specify the name designated when the new
POA object was created. Also add the /name switch to the startup file for the original POA.

17 Start the dedicated message file processing POA. See “Starting the POA™ on page 431.

Corresponding Startup Switches

You could also use the /notcpip, /noqf, /norecover, /nogwchk, /nonuu, and /nordab switches in the
POA startup file to disable non-message file processing, then use the /nomfhigh and /nomflow
switches in the POA startup file to adjust the POA message file processing.

Optimizing Indexing

If you run only one POA for the post office, you can adjust the indexing schedule. If indexing
needs are extremely heavy for a post office, you can set up a dedicated indexing POA to meet those
needs.

+ “Regulating Indexing” on page 514
+ “Configuring a Dedicated Indexing POA” on page 516

NOTE: To facilitate the Find feature in the GroupWise client, the POA searches unindexed messages as well
as those that have already been indexed, so that all messages are immediately available to users whenever
they perform a search. The POA does not search unindexed documents, so documents cannot be located
using the client Find feature until after indexing has been performed.

Regulating Indexing

514

By default, the POA indexes messages and documents in the post office every 24 hours at 8:00
p.m. You can modify this interval if users need messages and documents indexed more quickly. To
start indexing immediately, see “Updating QuickFinder Indexes” on page 486.

To adjust the interval at which indexing occurs:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > QuickFinder to display the QuickFinder page.
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Properties of PDA =
{GroupWise ~ || NDS Rights = | Gther | Rights 1o Files and Folders |
i QuickFinder
[V Enable QuickFinder Indexing
Start QuickFinder Indexing 20 il hours I 1] é’ minutes
QuickFinder Interval 24 3] hours | 0 4] minutes
Page Options... 0K I Cancel | Apply | Help

3 Make sure Enable QuickFinder Indexing is selected.

4 In the Start QuickFinder Indexing field, specify the number of hours and minutes after
midnight you want the POA to start its indexing cycle.

For example, if you set QuickFinder Interval to 6 and Start QuickFinder Indexing to 1 hour,
indexing cycles would occur at 1:00 a.m., 7:00 a.m., 1:00 p.m., and 7:00 p.m.

5 Decrease the number of hours and minutes in the QuickFinder Interval field so indexing
occurs more frequently.

The interval is measured from the start of one indexing cycle to the next, so that indexing starts
atregular intervals, no matter how long each indexing session takes. By default, the start point
of the cycle is 8:00 p.m.

To avoid overloading the POA with indexing processing, a maximum of 500 items are
indexed per database for each indexing cycle. If a very large number of messages are received
regularly, you should configure the POA with frequent indexing cycles in order to get all
messages indexed in a timely manner.

To handle occasional heavy indexing requirements, you can start indexing manually. See
“Updating QuickFinder Indexes” on page 486.

6 Click OK to save the new indexing settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches
You could also use the /qfinterval, /qfintervalinminute, /qfbaseoffset, and /qfbaseoffsetinminute
switches in the POA startup file to regulate indexing.

POA Web Console

You can control indexing for the current POA session on the Configuration page. Under the
General Settings heading, click QuickFinder Indexing. If indexing is currently in progress, you can
check the status of the indexing process on the Scheduled Events page.
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Configuring a Dedicated Indexing POA

If your GroupWise client users rely heavily on indexed documents, you can set up a dedicated
indexing POA so that indexing can be done quickly without impacting other POA functions. The
steps provided in this section would be appropriate for a basic indexing POA. For a discussion of
more complex configuration options, see “Indexing Documents” on page 319.

To configure a basic dedicated indexing POA:

1 Create a new POA object for the post office as described in “Creating a POA Object in
eDirectory” on page 438.

2 Right-click the new POA object, then click Properties.
3 Click GroupWise > QuickFinder to display the QuickFinder page.

Properties of POA x|
GroupWise ~ | NDS Rights + | Cther | Rights to Files and Folders |
QuickFinder
[¥ Enable GQuickFinder Indexing
Start QuickFinder Indexing 20 2] hours | 0 2] minutes
GuickFinder Interral 0 il hours I 0 é’ minutes
Page Options ok | cancal | apuy | pen

4 Make sure Enable QuickFinder Indexing is selected.

5 In the Start QuickFinder Indexing field, specify the number of hours and minutes after
midnight you want the POA to start its indexing cycle.

The default is 20, meaning at 8:00 p.m.

6 Sct QuickFinder Update Interval low enough to keep up with the indexing demands of your
GroupWise client users.

To avoid overloading the POA with indexing processing, a maximum of 500 items are
indexed per database for each indexing cycle. If a very large number of messages are received
regularly, you should configure the POA with very frequent indexing cycles in order to get all
messages indexed in a timely manner.

For continuous QuickFinder™ indexing, set QuickFinder Update Interval to 0 (zero).
7 Click Apply to save the updated QuickFinder settings.
8 Click GroupWise > Agent Settings.
9 Set Message File Processing to Off. Make sure another POA handles message file processing.

10 Deselect Enable TCP/IP (for Client/Server) and set TCP Handler Threads to 0. Make sure
another POA handles client/server processing.
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11 Click Apply to save the updated agent settings.
12 Click GroupWise > Maintenance.

13 Deselect Enable Automatic Database Recovery. Make sure another POA handles database
recovery.

To turn off all POA admin thread activity, add the /noada switch to the POA startup file for
this dedicated indexing POA.

14 Sect Maintenance Handler Threads to 0 (zero). Make sure another POA handles database
maintenance and disk space management.

15 Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure
another POA handles these tasks.

16 Click OK to save the new settings for dedicated indexing.

17 Install the POA software on a different server from where the original POA for the post office
is already running. See “Installing GroupWise Agents” in the GroupWise 6.5 Installation
Guide.

18 Add the /name switch to the POA startup file and specify the name designated when the new
POA object was created. Also add the /name switch to the startup file for the original POA.

19 Start the dedicated indexing POA. See “Starting the POA™ on page 431.

Corresponding Startup Switches

You could also use the /nomf, /notcpip, /norecover, /nonuu, and /nordab switches in the POA
startup file to disable unwanted processing, then use the /qfinterval, /qfintervalinminute, /
gfbaseoffset, and /qfbaseoffsetinminute switches to control the indexing schedule.

Optimizing Database Maintenance

If you run only one POA for the post office, you can adjust the number of database maintenance
threads. If database maintenance needs are extremely heavy for a post office, you can set up a
dedicated database maintenance POA to meet those needs.

+ “Adjusting the Number of POA Threads for Database Maintenance” on page 517
+ “Configuring a Dedicated Database Maintenance POA” on page 518

Adjusting the Number of POA Threads for Database Maintenance

The POA by default performs a certain amount of database maintenance. In addition, you can
create your own customized maintenance events as described in “Scheduling Database
Maintenance” on page 467 and “Scheduling Disk Space Management” on page 469.

By default, the POA starts one thread to handle all POA scheduled events and also all usage of the
Mailbox/Library Maintenance feature in ConsoleOne.

To adjust the number of POA database maintenance handler threads:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.

2 Click GroupWise > Maintenance to display the Maintenance page.
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Properties of POA x|

/ e v | NDS Rights » | Gther | Rights taFiles and Foiders |
i Maintenance

[¥ Enable Automatic Database Recovety

Maintenance Handler Threads: 4 ﬂ

[v Perform User Upkeep

Start User Upkeep 1 ﬂ hours after midnight

[v Generate Address Book for Rermote

Start Address Book Generation: 0 ﬁ’ hours after midnight

Disk Check Interral g ﬁ’ minutes
Disk Check Delay: 2 ﬁ’ hours
Page Options... | cancel | | mew |

3 Increase the number in the Maintenance Handler Threads field.
4 Click OK to save the new thread setting.

ConsoleOne then notifies the POA to restart so the new setting can be put into effect.

Corresponding Startup Switches
You could also use the /gwchkthreads switch in the POA startup file to increase the number of POA
threads started for database maintenance activities.

POA Web Console

The Status page helps you assess whether the POA is currently meeting the database maintenance
needs of the post office. Under the Thread Status heading, click GWCheck Worker Threads to
display the workload and status of the database maintenance handler threads.

You can change the number of database maintenance handler threads on the Configuration page.
Under Performance Settings, click Maximum GWCheck Processing Threads.

Configuring a Dedicated Database Maintenance POA

518

If a large amount of database maintenance needs to be performed for a post office, you can set up
a dedicated database maintenance POA so that the database maintenance activities do not impact
other POA activities, such as responding to GroupWise client users.

1 Create a new POA object for the post office as described in “Creating a POA Object in
eDirectory” on page 438.

2 Right-click the new POA object, then click Properties.

3 Click GroupWise > Maintenance to display the Maintenance page.
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10
11
12

13
14
15
16
17

18

19

Propetties of POA x|
GroupWise - | NDS Rights + I Cther I Rights= to Files and Folders I
Maintenance
[¥ Enable Automatic Database Recovety
Malntenance Handler Threads: [ =4
[ Perform User Upkeep
Start User Upkeen [ 1 2] hours afler mignight
[ Genetate Address Book for Remote
Start Address Book Generation: I—Uﬂ hours after midnight
Disk Check Interral I—Eﬂ minutes
Disk Check Delay: |—1§’ hours
Page Options... ok | cancel | appy | pew |

Make sure Enable Automatic Database Recovery is selected.
Set Maintenance Handler Threads as needed.
The maximum number of threads you can start for database maintenance is 8.

Deselect Perform User Upkeep and deselect Generate Address Book for Remote. Make sure
another POA handles these tasks.

Set Disk Check Interval and Disk Check Delay as appropriate for the database maintenance
events you plan to schedule.

Click Apply to save the updated information on the Maintenance page.

Click GroupWise > Scheduled Events, then create database maintenance events as needed, as
described in “Scheduling Database Maintenance” on page 467 and “Scheduling Disk Space
Management” on page 469.

Click GroupWise > Agent Settings.
Set Message File Processing to Off. Make sure another POA handles message file processing.

Deselect Enable TCP/IP (for Client/Server) and set TCP Handler Threads to 0. Make sure
another POA handles client/server processing.

Click Apply to save the updated information on the Agent Settings page.

Click GroupWise > QuickFinder.

Deselect Enable QuickFinder Indexing. Make sure another POA handles indexing.
Click OK to save the new settings for dedicated database maintenance processing.

Install the POA software on a different server from where the original POA for the post office
is already running. See “Installing GroupWise Agents” in the GroupWise 6.5 Installation
Guide.

Add the /name switch to the POA startup file and specify the name designated when you
created the new POA object. Also add the /name switch to the startup file for the original
POA.

Start the dedicated database maintenance POA. See “Starting the POA™ on page 431.
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Corresponding Startup Switches

You could also use the /nomf, /notcpip, /noqf, /nonuu, and /nordab switches in the POA startup file
to disable unwanted processing, then use the /gwchkthreads switch to increase the number of
database maintenance handler threads.

Optimizing CPU Utilization for the NetWare POA

To ensure that it does not dominate the NetWare® server CPU, the NetWare POA has a CPU
utilization threshold. The default CPU utilization threshold for the NetWare POA is 85 percent.
You can change this threshold using the CPU Utilization option. If CPU utilization exceeds the
threshold by 5 percent, any idle NetWare POA threads remain idle for the number of milliseconds
set by the Delay Time option. This cycle continues until CPU utilization drops below the CPU
utilization threshold.

To determine the optimum utilization setting for your network, you must consider the following
factors:

+ Amount of available memory
+ Demands of other network applications

* Type of throughput you want the NetWare POA to provide

As you raise the utilization threshold, NetWare POA efficiency increases; however, other network
applications have fewer available resources. As you decrease the utilization threshold, NetWare
POA efficiency is reduced; however, the NetWare POA cooperates better with other applications
running on the same server. The best way to determine these settings for your network is to
experiment.

To adjust the NetWare POA CPU utilization and delay time:
1 In ConsoleOne, browse to and right-click the POA object, then click Properties.
2 Click GroupWise > Agent Settings to display the Agent Settings page.

Propetties of POA x|
oupWise v | NDS Rights v | Other | Rights toFiles and Foiders |
i Agert Settings
Message File Processing: |AII =l
Message Handler Threads: I—Eﬁ
[¥ Enable TCPAP (for ClientiServer)
TGP Handler Threads: [ &
Max Physical Conne ctions: mﬁ
Max App Connections: Imi’
[¥ Enable Caching
CPU Utilization (NLM): | 85 2] nercent
Delay Time (NLM: mﬁ milliseconds
Max Thread Usage for Prirming and Moves: I—Quﬁ percent -
[ Enable IMAP
Max IMAP Threads [ ag
[ Enable CAP
Max CAP Threads: I—EDE’ j
Page Options... | cancel | | mew |

3 Increase the number in the CPU Utilization field to allow the NetWare POA to use more server
resources.
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or

Decrease the number in the CPU Ultilization field to give the NetWare POA fewer server
resources so those resources can be used by other programs on the server.

4 Deccrease the number in the Delay Time field to allow NetWare POA threads to take on new
tasks more quickly.

or

Increase the number in the Delay Time field to force NetWare POA threads to pause before
taking on new tasks.

5 Click OK to save the new CPU utilization settings.

ConsoleOne then notifies the POA to restart so the new settings can be put into effect.

Corresponding Startup Switches
You could also use the /cpu and /sleep switches in the POA startup file to adjust CPU utilization
and delay time.
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Using POA Startup Switches

You can override settings provided in ConsoleOne® by using startup switches. You can override
startup switches provided in the startup file by using startup switches on the command line. For
more information about starting the POA, see “Starting the POA™ on page 431.

The table below summarizes POA startup switches for all platforms and how they correspond to
configuration settings in ConsoleOne.

NetWare POA

Linux POA

Windows POA

ConsoleOne Settings

@filename
/attemptsresetinterval
[certfile

[cap

/capmaxthreads
/capport

/capssl

[cluster

/cpu

/dn
/enforceclientversion
lexternalclientssl
/gwchkthreads
/gwclientreleasedate
/gwclientreleaseversion
/help

/home

/httppassword
/httpport

/httprefresh

@filename
--attemptsresetinterval
--certfile

--cap
--capmaxthreads
--capport

--capssl

N/A

N/A

N/A
--enforceclientversion
--externalclientssl
--gwchkthreads
--gwclientreleasedate
--gwclientreleaseversion
--help

--home
--httppassword
--httpport

--httprefresh

@filename
/attemptsresetinterval
[certfile

/cap

/capmaxthreads
/capport

/capssl

N/A

N/A

N/A
/enforceclientversion
/externalclientssl|
/gwchkthreads
/gwclientreleasedate
/gwclientreleaseversion
/help

/home

/httppassword
/httpport

/nttprefresh

N/A

Incorrect Login Reset Time
Certificate File

Enable CAP

Max CAP Threads

CAP Port

CAP SSL

N/A

CPU Utilization

N/A

Lock Out Older GroupWise Clients
Internet Client/Server SSL
Maintenance Handler Threads
Minimum Client Release Date
Minimum Client Release Version
N/A

N/A

HTTP Password

HTTP Port

N/A
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NetWare POA Linux POA Windows POA ConsoleOne Settings
/httpssl --httpssl /httpssl HTTP SSL
/httpuser --httpuser /httpuser HTTP User Name
/imap --imap /imap IMAP
/imapmaxthreads --imapmaxthreads /imapmaxthreads Max IMAP Threads
/imapport --imapport /imapport IMAP Port
/imapreadlimit --imapreadlimit /imapreadlimit N/A

/imapssl --imapssl /imapssl IMAP SSL
/imapsslport --imapsslport /imapsslport IMAP SSL Port

/incorrectloginattempts

/internalclientssl
/intruderlockout

lip

/keyfile
/keypassword
/language
/ldapdisablepwdchg
/Idapipaddr
/Idapippooln
/Idappoolresettime
/Idapport
/Idapportpooln
/ldappwd

/ldapssl
/ldapsslpooln
/ldapsslkey
/ldapsslkeypooln
/ldaptimeout
/Idapuser
/ldapuserauthmethod

/lockoutresetinterval

--incorrectloginattempts

--internalclientssl
--intruderlockout
—-ip

--keyfile
--keypassword
--language
--ldapdisablepwdchg
--ldapipaddr
--ldapippooln
--ldappoolresettime
--ldapport
--ldapportpooln
--ldappwd

--ldapssl
--ldapsslpooln
--ldapsslkey
--ldapsslkeypooln
--ldaptimeout

--ldapuser

--ldapuserauthmethod

--lockoutresetinterval

/incorrectloginattempts

/internalclientssl
/intruderlockout

lip

/keyfile
/keypassword
/language
/ldapdisablepwdchg
/Idapipaddr
/Idapippooln
/ldappoolresettime
/ldapport
/Idapportpooln
/ldappwd

/ldapssl
/Idapsslpooln
/Idapsslkey
/ldapsslkeypooln
/ldaptimeout
/ldapuser
/ldapuserauthmethod

/lockoutresetinterval

Incorrect Logins Allowed
Local Intranet Client SSL
Enable Intruder Detection
N/A

SSL Key File

SSL Key File Password

N/A

Disable LDAP Password Changing
LDAP Server Address
Select LDAP Servers

LDAP Pool Server Reset Timeout
LDAP Server Address

LDAP Server Address

LDAP Password

Use SSL

Use SSL

SSL Key File

SSL Key File

Inactive Connection Timeout
LDAP User Name

User Authentication Method

Lockout Reset Time
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NetWare POA Linux POA Windows POA ConsoleOne Settings
/log --log /log Log File Path
/logdays --logdays /logdays Max Log File Age
/logdiskoff --logdiskoff /logdiskoff Logging Level
/loglevel --loglevel /loglevel Logging Level
/logmax --logmax /logmax Max Log Disk Space
/maxappconns --maxappconns /maxappconns Max Application Connections
/maxphysconns --maxphysconns /maxphysconns Max Physical Connections
/msgtranssl --msgtranssl /msgtranssl Message Transfer SSL
/mtpinipaddr --mtpinipaddr /mtpinipaddr IP Address (POA)
/mtpinport --mtpinport /mtpinport Message Transfer Port (POA)
/mtpoutipaddr --mtpoutipaddr /mtpoutipaddr IP Address (MTA)
/mtpoutport --mtpoutport /mtpoutport Message Transfer Port (MTA)
/mtpsendmax --mtpsendmax /mtpsendmax Maximum Send Message Size
/name --name /name N/A
/noada --noada /noada N/A
/nocache --nocache /nocache Enable Caching
/noconfig --noconfig /noconfig N/A
/noerrormail --noerrormail /noerrormail N/A
/nogwchk --nogwchk /nogwchk N/A
/nomf --nomf /nomf Message File Processing
/nomfhigh --nomfhigh /nomfhigh Message File Processing
/nomflow --nomflow /nomflow Message File Processing
/nomtp --nomtp /nomtp N/A
/nonuu --nonuu /nonuu Perform User Upkeep
/nogf --noqf /noqgf Enable QuickFinder Indexing
/nordab --nordab /nordab Generate Address

Books for Remote
/norecover --norecover /norecover Enable Auto DB Recovery
/nosnmp --nosnmp /nosnmp Enable SNMP
/notcpip --notcpip /notcpip Enable TCP/IP

(for C/S)
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NetWare POA Linux POA Windows POA ConsoleOne Settings

/nuuoffset --nuuoffset /nuuoffset Start User Upkeep

/password --password /password Remote Password

/port --port /port Client/Server Port

/primingmax --primingmax /primingmax Max Thread Usage for Priming and
Moves

/gfbaseoffset --gfbaseoffset /gfbaseoffset Start QuickFinder Indexing

/gfbaseoffsetinminute
/gfinterval

/gfintervalinminute

--gfbaseoffsetinminute
--gfinterval

--gfintervalinminute

/qfbaseoffsetinminute
/gfinterval

/gfintervalinminute

Start QuickFinder Indexing
QuickFinder Interval

QuickFinder Interval

/rdaboffset --rdaboffset /rdaboffset Start Address Book
Generation
[rights --rights [rights N/A
Isleep N/A N/A Delay Time (NLM)
/tcpthreads --tcpthreads /tcpthreads TCP Handler Threads
/threads --threads /threads Message Handler Threads
luser --user luser Remote User Name
@filename
Specifies the location of the POA startup file. On NetWare and Windows, the full path must be
included if the file does not reside in the same directory with the POA program. On Linux, the
startup file always resides in the /opt/novell/groupwise/agents/share directory. The startup file
must reside on the same server where the POA is installed. For more information about the POA
startup file, see Chapter 36, “Installing and Starting the POA,” on page 427.
NetWare POA Linux POA Windows POA
Syntax: @[vol][\dinlfile @l/dirNfile @Idrive:][\din]file
@\\svA\voldinfile @\\svisharename\din\file
Example: load gwpoa @sales.poa /gwpoa @../share/lnxpost.poa gwpoa.exe @sales.poa

load gwpoa @sys:\agt\sales.poa
load gwpoa @\\s2\sys\agt\sales.poa

gwpoa.exe @d:\agt\sales.poa
gwpoa.exe @\\s2\c\agt\sales.poa

/attemptsresetinterval

Specifies the length of time during which unsuccessful login attempts are counted, leading to
lockout. The default is 30 minutes; valid values range from 15 to 60. See “Enabling Intruder

Detection” on page 465.
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NetWare POA Linux POA Windows POA

Syntax: [attemptsresetinterval-minutes --attemptsresetinterval minutes /attemptsresetinterval-minutes

Example: /attemptsresetinterval-15 --attemptsresetinterval 45 /attemptsresetinterval-60

See also /intruderlockout, /incorrectloginattempts, and /lockoutresetinterval.

/cap

Enables CAP (Calendar Access Protocol) so that the POA can communicate with CAP clients. See
“Supporting CAP Clients” on page 451.

NetWare POA Linux POA Windows POA
Syntax: /cap-enabled or disabled  --cap enabled or disabled /cap-enabled or disabled
Example: /cap-enabled --cap enabled /cap-enabled

See also /capmaxthreads, /capport, and /capssl.

/capmaxthreads

Specifies the maximum number of CAP threads the POA can create to service CAP clients. The
default is 50. This setting is appropriate for most systems. See “Supporting CAP Clients” on

page 451.
NetWare POA Linux POA Windows POA
Syntax: /capmaxthreads-number --capmaxthreads number /capmaxthreads-number
Example: /capmaxthreads-30 --capmaxthreads 40 /capmaxthreads-40

See also /cap, /capport, /capssl.

/capport

Sets the TCP port number used for the POA to communicate with CAP clients. The default is 1026.
See “Supporting CAP Clients” on page 451.

NetWare POA Linux POA Windows POA
Syntax: /capport-port_number --capport port_number /capport-port_number
Example: /capport-1027 --capport 1028 /capport-1028

See also /cap, /capmaxthreads, and /capssl.
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Icapssl

[certfile

Icluster

Icpu

Sets the availability of secure SSL communication between the POA and CAP clients. Valid
settings are enabled and disabled. CAP uses TLS (Transport Layer Security) to negotiate the SSL
connection. See “Enhancing Post Office Security with SSL Connections to the POA” on page 458.

NetWare POA Linux POA Windows POA
Syntax: [/capssl-setting --capssl setting [/capssl-setting
Example: /capssl-enabled --capssl enabled /capssl-enabled

See also /imap, /imapmaxthreads, and /imapport.

Specifies the full path to the public certificate file used to provide secure SSL. communication
between the POA and other programs. See “Enhancing Post Office Security with SSL Connections
to the POA” on page 458.

NetWare POA Linux POA Windows POA
Syntax: [certfile-[svA][vol:]\dir\file --certfile /dir/file [certfile-[drive:]\dinfile
[certfile-\\svAvodir\file [certfile-\\svAsharename\din\file
Example: /certfile-\ssl\gw.crt --certfile /certs/gw.crt  /certfile-\ssl\gw.crt
[certfile-server2\sys:\ssl\gw.crt [certfile-m:\ssl\gw.crt
[certfile-\\server2\sys\ssl\gw.crt [certfile-\\server2\c\ssl\gw.crt

See also /keyfile and /keypassword.

Informs the NetWare® POA that it is running in a Novell cluster. See “Novell Cluster Services” in
the GroupWise 6.5 Interoperability Guide.

If you are running the NetWare POA on the latest version of NetWare 6.x and Novell Cluster
Services, the POA can detect the cluster automatically.

NetWare POA Linux POA Windows POA

Syntax: /cluster N/A N/A

See also /ip.

Sets the CPU utilization threshold for the NetWare POA. The default is 85 per cent. See
“Optimizing CPU Ultilization for the NetWare POA” on page 520.
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NetWare POA Linux POA Windows POA

Syntax: /cpu-percentage N/A N/A

Example: /cpu-55 N/A N/A

See also /sleep.

/dn

Specifies the Novell® eDirectory™ distinguished name of the NetWare POA object to facilitate
logging into remote servers. It can be used instead of the /user and /password switches.

NetWare POA Linux POA Windows POA
Syntax: /dn-distinguished_name N/A N/A
Example: /dn-POA. sales.provo2 N/A N/A

Jenforceclientversion

Enforces the minimum client release version and/or date so that users of older clients are forced to
update in order to access their GroupWise® mailboxes. Valid settings are version, date, both, and
disabled. See “Checking What GroupWise Clients Are in Use” on page 452.

NetWare POA Linux POA Windows POA
Syntax: /enforceclientversion-setting --enforceclientversion setting /enforceclientversion-setting
Example: /enforceclientversion-version --enforceclientversion date /enforceclientversion-both

See also /gwclientreleasedate, and /gwclientreleaseversion.

lexternalclientssl

Sets the availability of SSL communication between the POA and GroupWise clients that are
running outside your firewall. Valid values are enabled, required, and disabled. See “Enhancing
Post Office Security with SSL Connections to the POA™ on page 458.

NetWare POA Linux POA Windows POA

Syntax: /externalclientssl-setting --externalclientssl setting /externalclientssl-setting

Example: /externalclientssl-enabled --externalclientssl disabled /externalclientssl-required

See also /certfile, /keyfile, /keypassword, and /port.
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Igwchkthreads

Specifies the number of threads the POA starts for Mailbox/Library Maintenance activities. The
default is 4; valid values range from 1 to 8. See “Adjusting the Number of POA Threads for
Database Maintenance” on page 517.

NetWare POA Linux POA Windows POA
Syntax: /gwchkthreads-number --gwchkthreads number /gwchkthreads-number
Example: /gwchkthreads-5 --gwchkthreads 6 /gwchkthreads-8

See also /nogwchk.

Igwclientreleasedate

Specifies the date of the approved GroupWise client software for your system. See “Checking
What GroupWise Clients Are in Use” on page 452.

NetWare POA Linux POA Windows POA

Syntax: /gwclientreleasedate-mm-dd-yyyy  --gwclientreleasedate mm-dd-yyyy Igwclientreleasedate-mm-dd-yyyy

Example: /gwclientreleasedate-04-02-2001 --gwclientreleasedate 04-28-2004  /gwclientreleasedate-04-02-2001

See also /gwclientreleaseversion and /enforceclientversion.

Igwclientreleaseversion

Specifies the version of the approved GroupWise client software for your system. See “Checking
What GroupWise Clients Are in Use” on page 452.

NetWare POA Linux POA Windows POA
Syntax: /gwclientreleaseversion-n.n.n --gwclientreleaseversion n.n.n /gwclientreleaseversion-n.n.n
Example: /gwclientreleaseversion-6.0.0 --gwclientreleaseversion 6.5.1 /gwclientreleaseversion-6.0.0

See also /gwclientreleasedate and /enforceclientversion.

/help

Displays the POA startup switch Help information. When this switch is used, the POA does not

start.
NetWare POA Linux POA Windows POA
Syntax: /help or [? --help /help or /?
Example: load gwpoa /help ./gwpoa --help gwpoa.exe /help
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/home

Specifies the post office directory, where the POA can find the message and user databases to
service. There is no default location. You must use this switch in order to start the POA. See
“Starting the POA” on page 431.

NetWare POA Linux POA Windows POA
Syntax: /home-[svA][vol:]\dir --home /dir /home-[drive:]\dir
/home-\\svAvoldir /home-\\svAsharename\dir
Example: /home-\sales --home /gwsystem/sales /home-\sales
/home-mail:\sales /home-m:\sales
/home-server2\mail:\sales /home-\\server2\c\sales

/home-\\server2\mail\sales

/httppassword

Specifies the password for the POA to prompt for before allowing POA status information to be
displayed in your Web browser. Do not use an existing eDirectory password because the
information passes over the insecure connection between your Web browser and the POA. See
“Using the POA Web Console” on page 489.

NetWare POA Linux POA Windows POA
Syntax: /httppassword-unique_password --httppassword unique_password /httppassword-unique_password
Example: /httppassword-AgentWatch --httppassword AgentWatch /httppassword-AgentWatch

See also /httpuser, /httpport, /httprefresh, and /httpssl.

/httpport

Sets the HTTP port number used for the POA to communicate with your Web browser. The default
is 7181; the setting must be unique. See “Using the POA Web Console” on page 489.

NetWare POA Linux POA Windows POA
Syntax: /httpport-port_number --httpport port_number /httpport-port_number
Example: /httpport-7182 --httpport 7183 /httpport-7184

See also /httpuser, /httppassword, /httprefresh, and /httpssl.

/httprefresh

Specifies the rate at which the POA refreshes the status information in your Web browser. The
default is 60 seconds. See “Using the POA Web Console” on page 489.
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NetWare POA Linux POA Windows POA

Syntax: /httprefresh-seconds --httprefresh seconds /httprefresh-seconds

Example: /httprefresh-30 --httprefresh 90 /httprefresh-120

See also /httpuser, /httppassword, /httpport, and /httpssl.

/httpssl

Sets the availability of secure SSL communication between the POA and the POA Web console
displayed in your Web browser. Valid values are enabled and disabled. See “Enhancing Post Office
Security with SSL Connections to the POA” on page 458.

NetWare POA Linux POA Windows POA
Syntax: /httpssl-setting --httpssl setting /httpssl-setting
Example: /httpssl-enabled --httpssl enabled /httpssl-enabled

See also /certfile, /keyfile, and /keypassword.

/httpuser

Specifies the username for the POA to prompt for before allowing POA status information to be
displayed in a Web browser. Providing a username is optional. Do not use an existing eDirectory
username because the information passes over the insecure connection between your Web browser
and the POA. See “Using the POA Web Console” on page 489.

NetWare POA Linux POA Windows POA
Syntax: /httpuser-unique_name --httprefresh unique_name /httprefresh-unique_name
Example: /httpuser-GWWebCon --httpuser GWWebCon /httpuser-GWWebCon

See also /httppassword, /httpport, /httprefresh, and /httpssl.

limap

Enables IMAP so that the POA can communicate with IMAP clients. Valid settings are enabled
and disabled. See “Supporting IMAP Clients” on page 450.

NetWare POA Linux POA Windows POA
Syntax: /imap-enabled or disabled  --imap enabled or disabled /imap-enabled or disabled
Example: /imap-enabled --imap disabled /imap-enabled

See also /imapmaxthreads, /imapport, /imapssl, /imapsslport, and /imapreadlimit.
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/imapmaxthreads

Specifies the maximum number of IMAP threads the POA can create to service IMAP clients. The
default is 50.This setting is appropriate for most systems. See “Supporting IMAP Clients” on

page 450.
NetWare POA Linux POA Windows POA
Syntax: /imapmaxthreads-number  --imapmaxthreads number /imapmaxthreads-number
Example: /imapmaxthreads-40 --imapmaxthreads 30 /imapmaxthreads-40

See also /imap, /imapport, /imapssl, /imapsslport, and /imapreadlimit.

/imapreadlimit

Specifies in thousands the maximum number of messages that can be downloaded by an IMAP
client. For example, specifying 10 represents 10,000. The default is 5,000

NetWare POA Linux POA Windows POA
Syntax: /imapreadlimit-number --imapreadlimit number /imapreadlimit-number
Example: /imapreadlimit-10 --imapreadlimit 20 /imapreadlimit-50

See also /imap, /imapmaxthreads, /imapport, /imapssl, and /imapsslport.

/imapport

Sets the TCP port number used for the POA to communicate with IMAP clients when using a non-
SSL connection. The default is 143. See “Supporting IMAP Clients” on page 450.

NetWare POA Linux POA Windows POA
Syntax: /imapport-port_number --imapport port_number /imapport-port_number
Example: /imapport-145 --imapport 146 /imapport-147

See also /imap, /imapmaxthreads, /imapssl, /imapsslport, and /imapreadlimit.

limapssl

Sets the availability of secure SSL communication between the POA and IMAP clients. Valid
settings are enable and disable. See “Enhancing Post Office Security with SSL Connections to the
POA” on page 458.

NetWare POA Linux POA Windows POA

Syntax: /imapssl-setting --imapssl setting /imapssl-setting
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Example: /imapssl-enable --imapssl enable /imapssl-enable

See also /imap, /imapmaxthreads, /imapport, /imapsslport, and /imapreadlimit.

/imapsslport

Sets the TCP port number used for the POA to communicate with IMAP clients when using an
SSL connection. The default is 993. See “Supporting IMAP Clients” on page 450.

NetWare POA Linux POA Windows POA
Syntax: /imapsslport-port_number  --imapsslport port_ number  /imapsslport-port_number
Example: /imapsslport-994 --imapsslport 995 /imapsslport-996

See also/imap, /imapmaxthreads, /imapport, /imapssl, and /imapreadlimit.

lincorrectloginattempts

Specifies the number of unsuccessful login attempts after which lockout occurs. The default is 5
attempts; valid values range from 3 to 10. See “Enabling Intruder Detection” on page 465.

NetWare POA Linux POA Windows POA
Syntax: /incorrectloginattempts-number --incorrectloginattempts number /incorrectloginattempts-number
Example: /incorrectloginattempts-3 --incorrectloginattempts 10 /incorrectloginattempts-10

See also /intruderlockout, /attemptsresetinterval, and /lockoutresetinterval.

/linternalclientssl

Sets the availability of secure SSL communication between the POA and GroupWise clients that
are running inside your firewall. Valid values are enabled, required, and disabled. See “Enhancing
Post Office Security with SSL Connections to the POA” on page 458.

NetWare POA Linux POA Windows POA
Syntax: /internalclientssl-setting --internalclientssl| setting /internalclientssl-setting
Example: /internalclientssl-enabled --internalclientssl required l/internalclientssl-required

See also /certfile, /keyfile, /keypassword, and /port.
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lintruderlockout

lip

Ikeyfile

Turns on intruder lockout processing, using defaults that can be overridden by the /
incorrectloginattempts, /attemptsresetinterval, and /lockoutresetinterval switches. See “Enabling
Intruder Detection” on page 465.

NetWare POA Linux POA Windows POA

Syntax: /intruderlockout --intruderlockout /intruderlockout

Binds the POA to a specific IP address when the server where it runs uses multiple IP addresses,
such as in a clustering environment. The specified IP address is associated with all ports used by
the POA (HTTP, IMAP, LDAP, and so on.) Without the /ip switch, the POA binds to all available
IP addresses and users can access the post office through all available IP addresses. See “Editing
Clustered Agent Startup Files” in “Novell Cluster Services” in GroupWise 6.5 Interoperability
Guide.

NetWare POA Linux POA Windows POA
Syntax: lip-IP_address --ip IP_address fip-IP_address
Example: /ip-172.16.5.18 --ip 172.16.5.18 /ip-172.16.5.18

See also /cluster.

Specifies the full path to the private file used to provide secure SSL communication between the
POA and other programs. See “Enhancing Post Office Security with SSL Connections to the POA”
on page 458.

NetWare POA Linux POA Windows POA
Syntax: /keyfile-[svA][vol:\din\file --keyfile /dirlfile /keyfile-[drive:]\dinfile
/keyfile-\\svAvoldi\file /keyfile-\\svAsharename\dir\file
Example: /keyfile-\ssl\gw.key --keyfile /certs/gw.key /keyfile-\ssl\gw.key
/keyfile-server2\sys:\ssl\gw.key /keyfile-m:\ssl\gw.key
/keyfile-\\server2\sys\ssl\gw.key /keyfile-\\server2\c\ssl\gw.key

See also /certfile and /keypassword.
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/keypassword

/language

536 GroupWise 6.5 Administration Guide

Specifies the password used to encrypt the private SSL key file when it was created. See
“Enhancing Post Office Security with SSL Connections to the POA” on page 458.

NetWare POA

Linux POA

Windows POA

Syntax: /keypassword-password

Example: /keypassword-gwssl

--keypassword password

--keypassword gwssl

/keypassword-password

/keypassword-gwssl|

See also /certfile and /keyfile.

Specifies the language to run the POA in, using a two-letter language code as listed below. You
must install the POA in the selected language in order for the POA to display in the selected

language.

The initial default is the language used in the post office. If that language has not been installed,
the second default is the language used by the operating system. If that language has not been
installed, the third default is English. You only need to use this switch if you need to override these

defaults.

NetWare POA

Linux POA

Windows POA

Syntax: /language-code

Example: /language-de

--language code

--language de

/language-fr

/language-code

The table below lists the valid language codes. Contact your local Novell sales office for
information about language availability.

Language Language Language Language
Code Code
Arabic AR Hungarian MA
Czechoslovakian Cs Italian IT
Chinese-Simplified CS Japanese NI
Chinese-Traditional CT Korean KR
Danish DK Norwegian NO
Dutch NL Polish PL
English-United States us Portuguese-Brazil BR
Finnish SuU Russian RU
French-France FR Spanish ES
German-Germany DE Swedish SV
Hebrew HE Turkish TR




/Idapdisablepwdchg

/ldapipaddr

Prevents GroupWise users from changing their LDAP passwords by using the Password dialog
box in the GroupWise client. See “Enabling LDAP Authentication for a Post Office” on page 462.

NetWare POA Linux POA Windows POA

Syntax: /ldapdisablepwdchg --ldapdisablepwdchg /ldapdisablepwdchg

See also /ldapipaddr, /ldapport, /ldapuser, /Idappwd, /Idapuserauthmethod, /ldapssl, /Idapsslkey,
and /ldaptimeout.

Specifies the LDAP server’s network address as either an IP address or a DNS hostname. You can
specify multiple network addresses to provide failover capabilities for your LDAP servers. See
“Specifying Failover LDAP Servers (Non-SSL Only)” on page 465.

NetWare POA Linux POA Windows POA
Syntax: /Idapipaddr-network_address --ldapipaddr network _address /ldapipaddr-network_address
Example: /Idapipaddr-172.16.5.18 --ldapipaddr 172.16.5.19 /ldapipaddr-172.16.5.20
/ldapipaddr-server1 server2 --ldapipaddr server1 server2 /ldapipaddr-server1 server2

If you specify multiple LDAP servers, use a space between each address. When so configured, the
POA tries to contact the first LDAP server in order to authenticate a user to GroupWise. If that
LDAP server is down, the POA tries the next LDAP server in the list, and so on until it is able to
authenticate.

See also /ldapport, /Idapuser, /Idappwd, /Idapuserauthmethod, /Idapdisablepwdchg, /1dapssl, /
Idapsslkey, and /Idaptimeout.

/ldapippooln

Specifies a pooled LDAP server’s network address as either an IP address or a DNS hostname. As
many as five LDAP servers can participate together as a pool; therefore, n ranges from 1 to 5. See
“Configuring a Pool of LDAP Servers” on page 464.

NetWare POA Linux POA Windows POA
Syntax: /Idapippooln-network_address --ldapippooln network_address /ldapippooln-network_address
Example: /Idapippool1-172.16.5.18 --ldapippool1 172.16.5.18 /ldapippool1-172.16.5.18
/ldapippool2-server1 --ldapippool2 server1 /ldapippool2-server1
/Idapippool3-172.16.5.19 --ldapippool3 172.16.5.19 /Idapippool3-172.16.5.19

See also /ldapportpooln, /Idapsslpooln, /Idapsslkeypooln, and /Idappoolresettime.
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/Idappoolresettime

Specifies the number of minutes between the time when the POA receives an error response from
apooled LDAP server and the time when that LDAP server is reinstated into the pool of available
LDAP servers. The default is 5 minutes; valid values range from 1 to 30. See “Configuring a Pool
of LDAP Servers” on page 464.

NetWare POA Linux POA Windows POA
Syntax: /ldappoolresettime-minutes  --ldappoolresettime minutes /ldappoolresettime-minutes
Example: /Idappoolresettime-10 --ldappoolresettime 20 /ldappoolresettime-30

See also /ldapippooln, /Idapportpooln, /Idapsslpooln, and /Idapsslkeypooln.

/Idapport

Specifies the port number that the LDAP server listens on for authentication. The default is 389.
See “Providing LDAP Authentication for GroupWise Users” on page 461.

NetWare POA Linux POA Windows POA
Syntax: /ldapport-port_number --ldapport port_number /Idapport-port_number
Example: /Idapport-390 --ldapport 391 /Idapport-392

See also /ldapipaddr, /ldapuser, /Idappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /ldapssl, /
ldapsslkey, and /Idaptimeout.

/Idapportpooln

Specifies the port number that pooled LDAP server n listens on for authentication. The default is
389. See “Configuring a Pool of LDAP Servers” on page 464.

NetWare POA Linux POA Windows POA
Syntax: /Idapportpooln-port --ldapportpooln port /Idapportpooln-port
Example: /ldapportpool2-390 --ldapportpool3 391 /ldapportpool4-392

See also /ldapippooln, /Idappoolresettime, /Idapsslpoolr, and /ldapsslkeypooln.

/ldappwd

Provides the password for the LDAP user that the POA uses to log in to the LDAP server. See
“Providing LDAP Authentication for GroupWise Users” on page 461.

NetWare POA Linux POA Windows POA

Syntax: /lIdappwd-LDAP_password --ldappwd LDAP_password /Idappwd-LDAP_password
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Example: /Idappwd-gwldap --ldappwd gwldap /ldappwd-gwlidap

See also /lIdapipaddr, /ldapport, /ldapuser, /Idapuserauthmethod, /ldapdisablepwdchg, /1dapssl, /
ldapsslkey, and /ldaptimeout.

/ldapssl
Indicates to the POA that the LDAP server it is logging in to is using SSL. See “Providing LDAP
Authentication for GroupWise Users” on page 461.
NetWare POA Linux POA Windows POA
Syntax: /Idapssl --Idapssl /ldapssl
See also /ldapipaddr, /ldapport, /ldapuser, /Idappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
Idapsslkey and /ldaptimeout.
/ldapssipooln
Indicates to the POA that the pooled LDAP server it is logging in to is using SSL. See
“Configuring a Pool of LDAP Servers” on page 464.
NetWare POA Linux POA Windows POA
Syntax: /Idapsslpooln --ldapsslpooln /Idapsslpooln
Example: /Idapsslpool2 --ldapsslpool3 /ldapsslpool4
See also /ldapippooln, /Idapportpooln, /Idappoolresettime, and /ldapssikeypooln.
/Idapsslkey
Specifies the full path to the SSL key file used with LDAP authentication. See “Providing LDAP
Authentication for GroupWise Users” on page 461.
NetWare POA Linux POA Windows POA
Syntax: /ldapsslkey-[svA][vol:\dir\file --Idapsslkey /dir/file /\dapsslkey-[drive:]\dinfile
/ldapsslkey-\\svAvoldinfile /ldapsslkey-\\svAsharename\din\file
Example: /Idapsslkey-\ldap\gwkey.der --ldapsslkey /certs/gwkey.der /ldapsslkey-\Idap\gwkey.der
/ldapsslkey-server2\sys:\Idap\gwkey.der /ldapsslkey-m:\Idap\gwkey.der
/Idapsslkey-\\server2\sys\ldap\gwkey.der /ldapsslkey-\\server2\c\ldap\gwkey.der

See also /ldapipaddr, /ldapport, /ldapuser, /Idappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
Idapssl and /ldaptimeout.
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/Idapsslkeypooln

Specifies the full path to the SSL key file used with pooled LDAP server n for authentication. See
“Configuring a Pool of LDAP Servers” on page 464.

NetWare POA Linux POA Windows POA
Syntax: /ldapsslkeypooln-[svA][vol:]\diAfile --Idapsslkeypooln-/dirifile /ldapsslkeypooln-[drive:]\diAfile
/Idapsslkeypooln-\\svAvoldinfile /ldapsslkeypooln-\\svAsharename\dinfile
Example: /Idapsslkeypool4-\ldap\gwkey.der --ldapsslkeypool4 /certs/gwkey.der /Idapsslkeypool4-\ldap\gwkey.der
/ldapsslkeypool4- /ldapsslkeypool4-m:\Idap\gwkey.der
svr2\sys:\Idap\gwkey.der /ldapsslkeypool4-\\svr2\c\[dap\gwkey.der
/Idapsslkeypool4-

\\svr2\sys\ldap\gwkey.der

See also /ldapippooln, /Idapportpooln, /Idappoolresettime, and /1dapsslpooln.

/Idaptimeout

Specifies the number of seconds that the POA connection to the LDAP server can be idle before
the POA drops the connection. The default is 30 seconds. See “Providing LDAP Authentication
for GroupWise Users” on page 461.

NetWare POA Linux POA Windows POA
Syntax: /ldaptimeout-seconds --ldaptimeout seconds /ldaptimeout-seconds
Example: /Idaptimeout-60 --ldaptimeout 70 /ldaptimeout-80

See also /ldapipaddr, /ldapport, /ldapuser, /Idappwd, /ldapuserauthmethod, /ldapdisablepwdchg, /
Idapssl, and /Idapsslkey.

/ldapuser

Specifies the username that the POA can use to log in to the LDAP server in order to authenticate
GroupWise client users. See “Providing LDAP Authentication for GroupWise Users” on
page 461.

NetWare POA Linux POA Windows POA

Syntax: /\dapuser-LDAP_user_ID  --ldapuser LDAP_user_ID /ldapuser-LDAP_user_ID

Example: /Idapuser-GWAuth --ldapuser GWAuth /ldapuser-GWAuth

See also /ldapipaddr, /Idapport, /Idappwd, /ldapuserauthmethod, /Idapdisablepwdchg, /Idapssl, and
/Idapsslkey, and /ldaptimeout.
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/Idapuserauthmethod

Specifies the LDAP user authentication method you want the POA to use when accessing an
LDAP server. Valid settings are bind and compare. See “Providing LDAP Authentication for
GroupWise Users” on page 461.

NetWare POA Linux POA Windows POA
Syntax: /ldapuserauthmethod-method --ldapuserauthmethod method /ldapuserauthmethod-method
Example: /Idapuserauthmethod-bind --ldapuserauthmethod bind /ldapuserauthmethod-compare

See also /ldapuser, /Idapipaddr, /1dapport, /Idappwd, /ldapdisablepwdchg, /ldapssl, and /
Idapsslkey, and /Idaptimeout.

llockoutresetinterval

Specifies the length of time the user login is disabled after lockout. The default is 30 minutes; the
minimum setting is 15; there is no maximum setting. The login can also be manually re-enabled
in ConsoleOne in the GroupWise Account page of the User object. If /lockoutresetinterval is set
to 0 (zero), the login must be re-enabled manually through ConsoleOne. See “Enabling Intruder
Detection” on page 465.

NetWare POA Linux POA Windows POA
Syntax: /lockoutresetinterval-minutes --lockoutresetinterval minutes /lockoutresetinterval-minutes
Example: /lockoutresetinterval-15 --lockoutresetinterval 60 /lockoutresetinterval-90

llog

See also /intruderlockout, /incorrectloginattempts, and /attemptsresetinterval.

Specifies the directory where the POA stores its log files. On NetWare and Windows, the default
location is the post_office\wpcsout\ofs directory. On Linux, the default location is the /var/log/
novell/groupwise/post_office_name.poa directory. See “Using POA Log Files” on page 497.

NetWare POA Linux POA Windows POA
Syntax: Nlog-[svA][vol:]\dir --log /dir Nlog-[drive:)\dir
Nlog-\\svAvohdir /log-\\svAsharename\dir
Example: /log-\agt\log --log /gwsystem/logs /log-\agt\log
Nlog-\\server2\mail:\agt\log /log-m:\agt\log
Nlog-\\server2\mail\agt\log Nlog-\\server2\c\mail\agt\log

Typically you would find multiple log files in the specified directory. The first 4 characters
represent the date. The next 3 characters identify the agent. A three-digit extension allows for
multiple log files created on the same day. For example, a log file named 0518po0a.001 would
indicate that it is a POA log file, created on May 18. If you restarted the POA on the same day, a
new log file would be started, named 0518poa.002.

See also /loglevel, /logdiskoff, /logdays, and /logmax.
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llogdays

llogdiskoff

lloglevel

/logmax

Specifies how many days to keep POA log files on disk. The default is 7 days. See “Using POA
Log Files” on page 497.

NetWare POA Linux POA Windows POA
Syntax: /logdays-days --logdays days /logdays-days
Example: /logdays-5 --logdays 10 /logdays-14

See also /log, /loglevel, /logdiskoff, and /logmax.

Turns off disk logging for the POA so no information about the functioning of the POA is stored
on disk. The default is for logging to be turned on. See “Using POA Log Files” on page 497.

NetWare POA Linux POA Windows POA

Syntax: Nlogdiskoff --logdiskoff /logdiskoff

See also /loglevel.

Controls the amount of information logged by the POA. Logged information is displayed in the
log message box and written to the POA log file during the current agent session. The default is
Normal, which displays only the essential information suitable for a smoothly running POA. Use
Verbose to display the essential information, plus additional information helpful for
troubleshooting. Verbose logging does not degrade POA performance, but log files saved to disk
consume more disk space when verbose logging is in use. See “Using POA Log Files” on

page 497.

NetWare POA Linux POA Windows POA
Syntax: lloglevel-level --loglevel level lloglevel-level
Example: /loglevel-verbose --loglevel verbose /loglevel-verbose

See also /log, /logdiskoff, /logdays, and /logmax.

Sets the maximum amount of disk space for all POA log files. When the specified disk space is
consumed, the POA deletes existing log files, starting with the oldest. The default is 65536 KB.
See “Using POA Log Files” on page 497.
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Syntax: /logmax-kilobytes --logmax kilobytes /logmax-kilobytes

Example: /logmax-32000 --logmax 130000 /logmax-16000

See also /log, /loglevel, /logdiskoff, and /logdays.

/maxappconns

Sets the maximum number of application connections allowed between the POA and the
GroupWise clients run by GroupWise users. The default maximum number of application
connections is 2048. See “Adjusting the Number of Connections for Client/Server Processing” on

page 508.
NetWare POA Linux POA Windows POA
Syntax: /maxappconns-number --maxappconns number /maxappconns-number
Example: /maxappconns-3072 --maxappconns 4096 /maxappconns-5120

See also /maxphysconns.

/maxphysconns

Sets the maximum number of physical TCP/IP connections allowed between the POA and the
GroupWise clients run by GroupWise users. The default maximum number of physical
connections is 1024. See “Adjusting the Number of Connections for Client/Server Processing” on

page 508.
NetWare POA Linux POA Windows POA
Syntax: /maxphysconns-number --maxphysconns number /maxphysconns-number
Example: /maxphysconns-2048 --maxphysconns 4096 /maxphysconns-5120

See also /maxappconns.

Imsgtranssl

Sets the availability of secure SSL communication between the POA and its MTA. Valid settings
are enabled and disabled. See “Enhancing Post Office Security with SSL Connections to the POA”

on page 458.
NetWare POA Linux POA Windows POA
Syntax: /msgtranssl-setting --msgtranssl setting /msgtranssl-setting
Example: /msgtranssl-enabled --msgtranss| enabled /msgtranssl-enabled

See also /certfile, /keyfile and /keypassword.
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/mtpinipaddr

Specifies the network address of the server where the POA runs, as either an IP address or a DNS
hostname. See “Using TCP/IP Links between the Post Office and the Domain” on page 443.

NetWare POA Linux POA Windows POA

Syntax: /mtpinipaddr-network_addr  --mtpinipaddr network_addr /mtpinipaddr-network_addr

Example: /mtpinipaddr-172.16.5.18 --mtpinipaddr 172.16.5.19 /mtpinipaddr-172.16.5.20

/mtpinipaddr-server1 --mtpinipaddr server2 /mtpinipaddr-server3

See also /mtpinport, /mtpoutipaddr, /mtpoutport, /mtpsendmax, and /nomtp.

Imtpinport

Sets the message transfer port number the POA listens on for messages from the MTA. The default
is 7101. See “Using TCP/IP Links between the Post Office and the Domain” on page 443.

NetWare POA Linux POA Windows POA
Syntax: /mtpinport-port_number --mtpinport port_number /mtpinport-port_number
Example: /mtpinport-7201 --mtpinport 7202 /mtpinport-7203

See also /mtpinipaddr, /mtpoutipaddr, /mtpoutport, /mtpsendmax, and /nomtp.

/mtpoutipaddr

Specifies the network address of the server where the MTA for the domain runs, as either an IP
address or a DNS hostname. See “Using TCP/IP Links between the Post Office and the Domain”

on page 443.
NetWare POA Linux POA Windows POA
Syntax: /mtpoutipaddr-network_address --mtpoutipaddr network_address /mtpoutipaddr-network_address
Example: /mtpoutipaddr-172.16.5.18 --mtpoutipaddr 172.16.5.19 /mtpoutipaddr-172.16.5.19
/mtpoutipaddr-server2 --mtpoutipaddr server3 /mtpoutipaddr-server4

See also /mtpinipaddr, /mtpinport, /mtpoutport, /mtpsendmax, and /nomtp.

/Imtpoutport

Specifies the message transfer port number the MTA listens on for messages from the POA. The
default is 7100. See “Using TCP/IP Links between the Post Office and the Domain” on page 443.
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NetWare POA Linux POA Windows POA

Syntax: /mtpoutport-port_number --mtpoutport port_number  /mtpoutport-port_number

Example: /mtpoutport-7200 --mtpoutport 7300 /mtpoutport-7400

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpsendmax, and /nomtp.

/mtpsendmax

Sets the maximum size in megabytes for messages being sent outside the post office. By default,
messages of any size can be transferred to the MTA. See “Restricting Message Size between Post
Offices” on page 455.

NetWare POA Linux POA Windows POA
Syntax: /mtpsendmax-megabytes --mtpsendmax megabytes  /mtpsendmax-megabytes
Example: /mtpsendmax-2 --mtpsendmax 4 /mtpsendmax-6

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, and /nomtp.

/name

Specifies the object name of the POA object in the post office. If you have multiple POAs
configured for the same post office, you must use this switch to specify which POA configuration
to use when the POA starts. Several useful configurations include multiple POAs for a single post
office, as described in the following sections:

* “Configuring a Dedicated Client/Server POA” on page 510

* “Configuring a Dedicated Message File Processing POA” on page 513
¢ “Configuring a Dedicated Indexing POA” on page 516

¢ “Configuring a Dedicated Database Maintenance POA” on page 518

NetWare POA Linux POA Windows POA

Syntax: /name-object_name --name object_name /name-object_name

Example: /name-POA2 --name POA2 /name-POA2

Inoada

Disables the POA admin thread. For an explanation of the POA admin thread, see “POA Admin
Thread Status Box” on page 478.

The POA admin thread must run for at least one POA for each post office. However, it can be
disabled for POAs with specialized functioning where the database update and repair activities of
the POA admin thread could interfere with other, more urgent processing.
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NetWare POA Linux POA Windows POA

Syntax: /noada --noada /noada

Historical Note: In GroupWise 5.2 and earlier, a separate agent, the Administration Agent (ADA),
handled the functions now consolidated into the POA admin thread. Hence the switch name, /
noada.

Inocache

Disables database caching. The default is for caching to be turned on. Use this switch if you are
running NFS or if your backup system cannot back up open files.

NetWare POA Linux POA Windows POA

Syntax: /nocache --nocache /nocache

Inoconfig

Ignores any configuration information provided for the POA in ConsoleOne and uses only settings
from the POA startup file. The default is for the POA to use the information provided in
ConsoleOne, overridden as needed by settings provided in the startup file or on the command line.

NetWare POA Linux POA Windows POA

Syntax: /noconfig --noconfig /noconfig

Inoerrormail

Prevents problem files from being sent to the GroupWise administrator. The default is for error
mail to be sent to the administrator. See “Notifying the GroupWise Administrator” on page 503.

NetWare POA Linux POA Windows POA

Syntax: /noerrormail --noerrormail /noerrormail

Inogwchk

Turns off Mailbox/Library Maintenance processing for the POA. The default is for the POA to
perform Mailbox/Library Maintenance tasks requested from ConsoleOne and configured as POA
scheduled events.

NetWare POA Linux POA Windows POA
Syntax: /nogwchk --nogwchk /nogwchk
See also /gwchkthreads.
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Inomf

Inomfhigh

Inomflow

/Inomtp

Turns off all message file processing for the POA. The default is for the POA to process all
message files.

Two specialized configurations that require turning off message files are described in
“Configuring a Dedicated Client/Server POA” on page 510 and “Configuring a Dedicated
Indexing POA” on page 516.

NetWare POA Linux POA Windows POA

Syntax: /nomf --nomf /nomf

See also /nomfhigh and /nomflow.

Turns off processing high priority messages files (message queues 0 and 1). For information about
message queues, see “Post Office Directory” in Group Wise 6.5 Troubleshooting 3: Message Flow
and Directory Structure.

NetWare POA Linux POA Windows POA

Syntax: /nomfhigh --nomfhigh /nomfhigh

See also /nomf and /nomflow.

Turns off processing lower priority messages files (message queues 2 through 7). For information
about message queues, see “Post Office Directory” in Group Wise 6.5 Troubleshooting 3: Message
Flow and Directory Structure.

NetWare POA Linux POA Windows POA

Syntax: /nomflow --nomflow /nomflow

See also /nomf and /nomfhigh.

Disables Message Transfer Protocol, so that a TCP/IP link cannot be used between the POA and
the MTA. See “Changing the Link Protocol between the Post Office and the Domain™ on page 442.

NetWare POA Linux POA Windows POA

Syntax: /nomtp --nomtp /nomtp

See also /mtpinipaddr, /mtpinport, /mtpoutipaddr, /mtpoutport, and /mtpsendmax.

Using POA Startup Switches 547



/nonuu

Inoqf

Inordab

Inorecover

Disables nightly user upkeep. See “Performing Nightly User Upkeep” on page 472.

NetWare POA Linux POA Windows POA

Syntax: /nonuu --nonuu /nonuu

See also /nuuoffset.

Disables the periodic QuickFinder™ indexing done by the POA. The default is for periodic
indexing to be turned on. See “Regulating Indexing” on page 514.

NetWare POA Linux POA Windows POA

Syntax: /nogf --nogf /nogf

See also /qfinterval, /qfintervalinminute, /qfbaseoffset, and /qfbaseoffsetinminute.

Disables daily generation of the system Address Book for Remote users. See “Performing Nightly
User Upkeep” on page 472.

NetWare POA Linux POA Windows POA

Syntax: /nordab --nordab /nordab

See also /rdaboffset.

Disables automatic database recovery. The default is for automatic database recovery to be turned
on.

If the POA detects a problem with a database, when automatic database recovery has been turned
off, the POA notifies the administrator, but it does not recover the problem database. The
administrator can then recover or rebuild the database as needed. See Chapter 26, “Maintaining
Domain and Post Office Databases,” on page 345.

Two specialized configurations that require turning off automatic database recovery are described
in “Configuring a Dedicated Client/Server POA” on page 510 and “Configuring a Dedicated
Indexing POA” on page 516.

NetWare POA Linux POA Windows POA

Syntax: /norecover --norecover /norecover
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/nosnmp

Disables SNMP for the POA. The default is to have SNMP enabled. See “Using SNMP
Monitoring Programs” on page 499.

NetWare POA Linux POA Windows POA

Syntax: /nosnmp --nosnmp /nosnmp

Inotcpip

Disables TCP/IP communication for the POA. The default is to have TCP/IP communication
enabled. Use this switch if you do not want this POA to communicate with GroupWise clients

using TCP/IP.
NetWare POA Linux POA Windows POA
Syntax: /notcpip --notcpip /notcpip

Two specialized configurations that require turning off automatic database recovery are described
in “Configuring a Dedicated Message File Processing POA” on page 513 and “Configuring a
Dedicated Indexing POA” on page 516.

Inuuoffset
Specifies the number of hours after midnight for the POA to start performing user upkeep. The
default is 1 hour; valid values range from 0 to 23. See “Performing Nightly User Upkeep” on
page 472.
NetWare POA Linux POA Windows POA
Syntax: /nuuoffset-hours --nuuoffset hours /nuuoffset-hours
Example: /nuuoffset-2 --nuuoffset 3 /nuuoffset-4
See also /nonuu.
Ipassword
Provides the password for the POA to use when accessing post offices or document storage arecas
on remote servers. You can also provide user and password information on the Post Office Settings
page in ConsoleOne. See “Starting the POA” on page 431.
NetWare POA Linux POA Windows POA
Syntax: /password-NetWare_password --password network_password /password-network_password
Example: /password-GWise --password GWise /password-GWise

See also /user and /dn.
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/port

Sets the TCP port number used for the POA to communicate with GroupWise clients in client/
server access mode. The default is 1677. See “Using Client/Server Access to the Post Office” on

page 447.
NetWare POA Linux POA Windows POA
Syntax: Iport-port_number --port port_number [Iport-port_number
Example: /port-1678 --port 1679 /port-1680

See also /ip.

/primingmax

Sets the maximum number of TCP handler threads that POA can use for priming users’ Caching
mailboxes. The default is 20 per cent. See “Supporting Forced Mailbox Caching” on page 454.

NetWare POA Linux POA Windows POA
Syntax: /primingmax-percentage --primingmax percentage /primingmax-percentage
Example: /primingmax-40 --primingmax 50 /primingmax-60

See also /tcpthreads.

Igfbaseoffset

Specifies the number of hours after midnight for the POA to start its indexing cycle as specified
by the /qfinterval or /qfintervalinminute switch. The default is 20 hours (meaning at 8:00 p.m.);
valid values range from 0 to 23. See “Regulating Indexing” on page 514.

NetWare POA Linux POA Windows POA
Syntax: /gfbaseoffset-hours --gfbaseoffset hours /gfbaseoffset-hours
Example: /gfbaseoffset-1 --gfbaseoffset 2 /qfbaseoffset-3

See also /qfbaseoffsetinminute, /qfinterval, /qfintervalinminute, and /noqf.

Igfbaseoffsetinminute

Specifies the number of minutes after midnight for the POA to start its indexing cycle as specified
by the /qfinterval or /qfintervalinminute switch. The default is 20 hours (1200 minutes, meaning
at 8:00 p.m.). The maximum setting is 1440 (24 hours). See “Regulating Indexing” on page 514.

NetWare POA Linux POA Windows POA

Syntax: /qfbaseoffsetinminute-minutes --gfbaseoffsetinminute minutes /gfbaseoffsetinminute-minutes
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NetWare POA Linux POA Windows POA

Example: /gfbaseoffset-30 --gfbaseoffset 45 /gfbaseoffset-90

See also /qfbaseoffset, /qfinterval, /qfintervalinminute, and /noqf.

[gfinterval

Specifies the interval in hours for the POA to update the QuickFinder indexes in the post office.
The default is 24 hours. See “Regulating Indexing” on page 514.

NetWare POA Linux POA Windows POA
Syntax: /gfinterval-hours --gfinterval-hours /gfinterval-hours
Example: /qfinterval-12 --gfinterval-6 /dfinterval-2

See also /qfbaseoffset, /qfbaseoffsetinminute, /qfintervalinminute, and /noqf.

/gfintervalinminute

Specifies the interval in minutes for the POA to update the QuickFinder indexes in the post office.
The default is 24 hours (1440 minutes). See “Regulating Indexing” on page 514.

NetWare POA Linux POA Windows POA

Syntax: /gfintervalinminute-minutes  --gfintervalinminute minutes  /dfintervalinminute-minutes

Example: /gfintervalinminute-90 --gfintervalinminute 30 /gfintervalinminute-120

See also /qfinterval, /qfbaseoffset, /qfbaseoffsetinminute, and /noqf.

[rdaboffset

Specifies the number of hours after midnight for the POA to generate the daily copy of the system
Address Book for Remote users. The default is 0; valid values range from 0 to 23. See “Performing
Nightly User Upkeep” on page 472.

NetWare POA Linux POA Windows POA
Syntax: /rdaboffset-hours --rdaboffset hours /rdaboffset-hours
Example: /rdaboffset-2 --rdaboffset 3 /rdaboffset-4

See also /nordab.
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Irights

Isleep

Itcpthreads

Ithreads

Verifies that the POA has the required network rights or permissions to all directories where it
needs access in the post office directory.

When started with this switch, the POA lists directories it is checking, which can be a lengthy
process. Use this switch on an as needed basis, not in the POA startup file. If the POA encounters
inadequate rights or permissions, it indicates the problem and shuts down.

NetWare POA Linux POA Windows POA

Syntax: /rights --rights [rights

Sets how long NetWare POA threads remain dormant when the CPU utilization threshold has been
exceeded. The default is 100 milliseconds. See “Optimizing CPU Utilization for the NetWare
POA” on page 520.

NetWare POA Linux POA Windows POA
Syntax: Isleep-milliseconds N/A N/A
Example: /sleep-300 N/A N/A

See also /cpu.

Specifies the maximum number of TCP handler threads the POA can create to service client/server
requests. The default is 6; valid values range from 1 to 99. Plan on about one TCP handler thread
per 20-30 client/server users. See “Adjusting the Number of POA Threads for Client/Server
Processing” on page 507.

NetWare POA Linux POA Windows POA
Syntax: ltcpthreads-number --tcpthreads number ltcpthreads-number
Example: /tcpthreads-10 --tcpthreads 20 /tcpthreads-20

See also /primingmax.

Specifies the maximum number of message handler threads the POA can create. The default is §;
valid values range from 1 to 30. See “Adjusting the Number of POA Threads for Message File
Processing” on page 512.
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luser

NetWare POA Linux POA Windows POA

Syntax: lthreads-number --threads number lthreads-number

Example: /threads-10 --threads 20 /threads-30

Provides the network user ID for the POA to use when accessing post offices and/or document
storage areas on remote servers. You can also provide user and password information on the Post
Office Settings page in ConsoleOne. For the NetWare POA, see “Creating a NetWare Account for
Agent Access (Optional)” in “Installing GroupWise Agents” in the GroupWise 6.5 Installation
Guide.

NetWare POA Linux POA Windows POA
Syntax: luser-eDirectory_user_ID --user Linux_user_ID luser-Windows_user_ID
Example: /user-GWAgents --user GWAgents luser-GWAgents

See also /password and /dn.

NetWare Note: The eDirectory user ID is a user that the POA can use to log in to the remote
NetWare server.

Linux Note: On OES Linux, the Linux_user ID is a LUM-enabled user that the POA can use to
log in to the remote OES Linux server. On SLES Linux, it is a standard Linux user.

Windows Note: The Windows_user ID is a user that the POA can use to log in to the remote
Windows server. The Windows POA gains access to the post office directory when it starts.
However, a particular user might attempt to access a remote document storage area to which the
POA does not yet have a drive mapping available. By default, the POA attempts to map a drive
using the same user ID and password it used to access the post office directory. If the user ID and
password for the remote storage area are different from the post office, then use the /user and /
password switches to specify the needed user ID and password. You can also provide user and
password information on the Post Office Settings page in ConsoleOne. However, it is preferable
to use the same user ID and password on all servers where the POA needs access.

Using POA Startup Switches 553



554 GroupWise 6.5 Administration Guide



	IX Post Office Agent
	35 Understanding Message Delivery and Storage in the Post Office
	Post Office Representation in ConsoleOne
	Post Office Directory Structure
	Information Stored in the Post Office
	Post Office Database
	Message Store
	Guardian Database
	Agent Input/Output Queues in the Post Office
	Libraries (optional)

	Post Office Access Mode
	Role of the Post Office Agent
	Client/Server Processing
	Message File Processing
	Other POA Functions

	Message Flow in the Post Office
	Cross-Platform Issues in the Post Office
	Client/Post Office Platform Independence through Browser Technology
	Client/Post Office Platform Independence through Client/Server Mode
	POA/Post Office Platform Dependencies Because of Direct Access Requirements


	36 Installing and Starting the POA
	Installing the POA Software
	Fine-Tuning Your NetWare POA Installation
	Fine-Tuning Your Linux POA Installation
	Fine-Tuning Your Windows POA Installation

	Starting the POA
	Starting the NetWare POA
	Starting the Linux POA
	Starting the Windows POA

	Uninstalling the POA Software
	Uninstalling the NetWare or Windows POA
	Uninstalling the Linux POA


	37 Configuring the POA
	Performing Basic POA Configuration
	Creating a POA Object in eDirectory
	Configuring the POA in ConsoleOne
	Changing the Link Protocol between the Post Office and the Domain
	Moving the POA to a Different server
	Adjusting the POA for a New Post Office Location
	Adjusting the POA Logging Level and Other Log Settings

	Configuring User Access to the Post Office
	Using Client/Server Access to the Post Office
	Simplifying Client/Server Access with a GroupWise Name Server
	Supporting IMAP Clients
	Supporting CAP Clients
	Checking What GroupWise Clients Are in Use
	Supporting Forced Mailbox Caching
	Restricting Message Size between Post Offices

	Configuring Post Office Security
	Securing Client/Server Access through a Proxy Server
	Controlling Client Redirection Inside and Outside Your Firewall
	Enhancing Post Office Security with SSL Connections to the POA
	Providing LDAP Authentication for GroupWise Users
	Enabling Intruder Detection
	Configuring Trusted Application Support

	Configuring Post Office Maintenance
	Scheduling Database Maintenance
	Scheduling Disk Space Management
	Performing Nightly User Upkeep


	38 Monitoring the POA
	Using the POA Agent Console
	Monitoring the POA from the POA Agent Console
	Controlling the POA from the POA Agent Console

	Using the POA Web Console
	Setting Up the POA Web Console
	Accessing the POA Web Console
	Monitoring the POA from the POA Web Console
	Controlling the POA from the POA Web Console

	Using POA Log Files
	Configuring POA Log Settings and Switches
	Viewing POA Log Files
	Interpreting POA Log File Information

	Using GroupWise Monitor
	Using NetWare 6.5 Remote Manager
	Using SNMP Monitoring Programs
	Setting Up SNMP Services for the POA
	Copying and Compiling the POA MIB File
	Customizing Your ManageWise Installation to Monitor the POA
	Configuring the POA for SNMP Monitoring

	Notifying the GroupWise Administrator
	Using the POA Error Message Documentation
	Employing POA Troubleshooting Techniques
	Using Platform-Specific POA Monitoring Tools
	NetWare Monitoring Tools
	Linux Monitoring Tools
	Windows Monitoring Tools


	39 Optimizing the POA
	Optimizing Client/Server Processing
	Adjusting the Number of POA Threads for Client/Server Processing
	Adjusting the Number of Connections for Client/Server Processing
	Configuring a Dedicated Client/Server POA

	Optimizing Message File Processing
	Adjusting the Number of POA Threads for Message File Processing
	Configuring a Dedicated Message File Processing POA

	Optimizing Indexing
	Regulating Indexing
	Configuring a Dedicated Indexing POA

	Optimizing Database Maintenance
	Adjusting the Number of POA Threads for Database Maintenance
	Configuring a Dedicated Database Maintenance POA

	Optimizing CPU Utilization for the NetWare POA

	40 Using POA Startup Switches
	@filename
	/attemptsresetinterval
	/cap
	/capmaxthreads
	/capport
	/capssl
	/certfile
	/cluster
	/cpu
	/dn
	/enforceclientversion
	/externalclientssl
	/gwchkthreads
	/gwclientreleasedate
	/gwclientreleaseversion
	/help
	/home
	/httppassword
	/httpport
	/httprefresh
	/httpssl
	/httpuser
	/imap
	/imapmaxthreads
	/imapreadlimit
	/imapport
	/imapssl
	/imapsslport
	/incorrectloginattempts
	/internalclientssl
	/intruderlockout
	/ip
	/keyfile
	/keypassword
	/language
	/ldapdisablepwdchg
	/ldapipaddr
	/ldapippooln
	/ldappoolresettime
	/ldapport
	/ldapportpooln
	/ldappwd
	/ldapssl
	/ldapsslpooln
	/ldapsslkey
	/ldapsslkeypooln
	/ldaptimeout
	/ldapuser
	/ldapuserauthmethod
	/lockoutresetinterval
	/log
	/logdays
	/logdiskoff
	/loglevel
	/logmax
	/maxappconns
	/maxphysconns
	/msgtranssl
	/mtpinipaddr
	/mtpinport
	/mtpoutipaddr
	/mtpoutport
	/mtpsendmax
	/name
	/noada
	/nocache
	/noconfig
	/noerrormail
	/nogwchk
	/nomf
	/nomfhigh
	/nomflow
	/nomtp
	/nonuu
	/noqf
	/nordab
	/norecover
	/nosnmp
	/notcpip
	/nuuoffset
	/password
	/port
	/primingmax
	/qfbaseoffset
	/qfbaseoffsetinminute
	/qfinterval
	/qfintervalinminute
	/rdaboffset
	/rights
	/sleep
	/tcpthreads
	/threads
	/user




<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


